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Note for Mac users

Some keystrokes and menu items are different on a Mac from those used in Windows and Linux.
The table below gives some common substitutions for the instructions in this chapter. For a more
detailed list, see the application Help.

Windows or Linux Mac equivalent Effect

Tools > Options menu  LibreOffice > Preferences Access setup options
selection

Right-click Control+click or right-click Open a context menu
depending on system setup
Ctrl (Control) 3 (Command) Used with other keys
F5 Shift+38+F5 Open the Navigator
F11 #+T Open the Styles and Formatting window

Documentation for LibreOffice is available at http.//www.libreoffice.org/get-help/documentation
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Connectors and glue points

Connectors and glue points were briefly introduced in Chapter 2 Drawing Basic Shapes. This
section describes them in more detail and how to use them.

Connectors are lines or arrows whose ends automatically dock to a connection or glue point on an
object. Connectors are useful when drawing, for example, flowcharts and organization charts. The
connecting lines between objects remain intact even when objects are moved or rearranged. Also, if
you copy an object with a connector, the connector is also copied.

Connectors

Draw has a comprehensive selection of connectors on a Connectors toolbar (Figure 1) to help you
connect objects in, for example, a flowchart or organization chart. To open this toolbar, click the

small triangle to the right of the Connector icon DLU on the Drawing toolbar. Note that this icon
changes shape depending on the last connector tool used. This toolbar can become a floating
toolbar by clicking on the bottom of the pop-up toolbar and dragging it into your workspace.
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Figure 1: Connector toolbar

Types of connectors
Connectors fall into four type groups:
e Standard connectors (Figure 2) — the line segments run vertically and horizontally. Draws a

connector with one or more 90-degree angle bends. Click on an object glue point on an
object, drag to a glue point on another object, then release.

Connector

Connector Starts with Arrow
Connector Ends with Arrow
Connector with Arrows
Connector Starts with Circle
Connector Ends with Circle
Connector with Circles
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Figure 2: Standard connectors

* Line connectors (Figure 3) — consist of a line segment with two smaller segments at the
ends. Draws a connector that bends near a glue point. Click on an object glue point, drag
to a glue point on another object, then release. To adjust the length of the line segment
between a bend point and a glue point, click the connector and drag the bend point.
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Line Connector

Line Connector Starts with Arrow
Line Connector Ends with Arrow
Line Connector with Arrows

Line Connector Starts with Circle
Line Connector Ends with Circle
Line Connector with Circles
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Figure 3: Line connectors

* Straight connectors (Figure 4) — consist of a single line. Draws a straight line connector.
Click on an object glue point, drag to a glue point on another object, then release.

Straight Connector

Straight Connector starts with Arrow
Straight Connector ends with Arrow
Straight Connector with Arrows
Straight Connector starts with Circle
Straight Connector ends with Circle
Straight Connector with Circles
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Figure 4: Straight connectors

* Curved connectors (Figure 5) — are based on Bézier curves and curve around objects.
Draws a curved line connector. Click on an object glue point, drag to a glue point on
another object, then release.

Curved Connector

Curved Connector Starts with Arrow
Curved Connector Ends with Arrow
Curved Connector with Arrows
Curved Connector Starts with Circle
Curved Connector Ends with Circle
Curved Connector with Circles
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Figure 5: Curved connectors

Adding connectors

When you select a connector and move the mouse pointer over a filled object or the edge of an
unfilled object, glue points appear. A glue point is a fixed point where you can attach a connector
line. You can also add custom glue points to an object, see “Glue points” on page 7 for more
information.

Figure 6: Connector between two objects
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To draw a connector, select the connector type and click on a glue point on an object. Drag the
cursor to a glue point on another object and then release. Figure 6 shows a line connector drawn
between two objects. Remember not to drag the connector so that it overlaps or touches any
objects and creates a confusing drawing. If this does happen, see “Modifying connectors” below on
how to change the connector route to avoid any objects the connector crosses over.

You can also drag a connector to an empty part of your document. When you release the mouse
button, the unattached end of the connector is locked into place until you drag the end to a different
location.

Modifying connectors

To detach or reposition a connector, click and drag either end of the connector line to a different
location.

To change the connector route between objects avoiding any objects on the route, click on a
control point on the connector line and drag it to a new position. In Figure 6, the control points are
shown as small red squares at the point where the connector changes direction.

To modify a connector, right-click on the connector and select Connector from the context menu to
open the Connector dialog (Figure 7). Use this doialog to change connector type and its properties.
* Line skew — defines the skew of the line and the dialog preview displays the result.
* Line spacing — sets the spacing for the connectors.

- Begin horizontal — enter the amount of horizontal space you want at the beginning of
the connector.

- Begin vertical — enter the amount of vertical space you want at the beginning of the
connector.

- End horizontal — enter the amount of horizontal space you want at the end of the
connector.

- End vertical — enter the amount of vertical space you want at the end of the connector.

@ Connector

Type iLine Connector oo

Line skew cancel
Line1
Help

Line2
Line3

Line spacing

Begin horizontal
Begin vertical
End horizontal

End vertical

Figure 7: Connector dialog

You cannot swap the ends of the connector using this dialog, that is start point
Note becomes the end point and the end point becomes the start point. To swap the
ends of a connector, you have to draw a new connector.
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Glue points

Glue points are not the same as the selection handles of an object. The selection handles are for
moving or changing the shape of an object; see Chapter 3 Working with Objects and Object Points
for more information. Glue points are used to fix or glue a connector to an object so that when the
object moves, the connector stays fixed to the object.

All Draw objects have glue points, which normally are not displayed and only become visible when

the Connectors icon Dlﬂ on the Drawing toolbar is selected. Note that the Connectors icon
changes shape depending on the last connector tool used.

To add, customize or delete glue points to an object, go to View > Toolbars > Gluepoints on the
main menu bar to open the Gluepoints toolbar (Figure 8). This toolbar only becomes active after

you click on the Glue Points icon ﬁ or select Edit > Glue Points on the main menu bar. Figure 6
on page 5 shows an example of active glue points.
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Exit Direction Left
Exit Direction Top
Exit Direction Right
Exit Direction Bottom

Glue Point Relative

Glue Point Horizontal Left
Glue Point Horizontal Center
Glue Point Horizontal Right

Glue Point Vertical Top
Glue Point Vertical Center
Glue Point Vertical Bottom
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Figure 8: Gluepoints toolbar

Types of glue points

When the Gluepoints toolbar opens, only the six tools on the left of the toolbar are active. The
remaining six tools on the right of the toolbar only become active when the Glue Point Relative
icon is deselected.

With reference to Figure 8, the following briefly describes the function of each tool on the
Gluepoint toolbar.

* Insert Glue Point — inserts a glue point where you click in an object.

¢ Exit Direction Left — connector attaches to the left edge of the selected glue point.

* Exit Direction Top — connector attaches to the top edge of the selected glue point.

¢ Exit Direction Right — connector attaches to the right edge of the selected glue point.

¢ Exit Direction Bottom — connector attaches to the bottom edge of the selected glue point.

Connectors and glue points 7



Glue Point Relative — maintains the relative position of a selected glue point when you
resize an object. This tool is selected by default when the Gluepoint toolbar opens. The
following six tools only become active when this tool is deselected.

Glue Point Horizontal Left — when the object is resized, the current glue point remains
fixed to the left edge of the object.

Glue Point Horizontal Center — when the object is resized, the current glue point remains
fixed to the center of the object.

Glue Point Horizontal Right — when the object is resized, the current glue point remains
fixed to the right edge of the object.

Glue Point Vertical Top — when the object is resized, the current glue point remains fixed
to the top edge of the object.

Glue Point Vertical Center — when the object is resized, the current glue point remains
fixed to the vertical center of the object.

Glue Point Vertical Bottom — when the object is resized, the current glue point remains
fixed to the bottom edge of the object.

Each glue point you have added can have only one horizontal position and one

Note vertical position. Only one of the horizontal position tools and one of the vertical

position tools can be selected and used at any one time.

Adding glue points

By default, most objects normally have four glue points. To add extra glue points to an object or to
an object that does not have glue points, proceed as follows:

1)

2)

3)
4)

5)

Make sure no objects are selected and click on the Glue Points icon ﬁ or select Edit >
Glue Points on the main menu bar. Glue points will appear as small crosses on objects
(Figure 6 on page 5).

If the Gluepoints toolbar (Figure 8 on page 7) does not open, go to View > Toolbars >
Gluepoints on the main menu bar.

Select the object and then the Insert Glue Point icon .
Move your cursor to a position where you want the glue point on an object and click to
insert the glue point.

To move a glue point to another position, click on the glue point and drag it to its new
position. Guide lines automatically appear when moving glue points.

When adding, moving or customizing glue points, it is recommended to use the
Tip zoom function to make it easier to work with glue points. See Chapter 3 Working
with Objects and Object Points for more information.

Customizing glue points

Only glue points that have added to an object can be customized. The default glue points included
with an object cannot be customized.

1)

2)

Make sure no objects are selected and click on the Glue Points icon ﬁ or select Edit >
Glue Points on the main menu bar. Glue points will appear as small crosses on objects
(Figure 6 on page 5).

If the Gluepoints toolbar (Figure 8 on page 7) does not open, go to View > Toolbars >
Gluepoints on the main menu bar.

Connectors and glue points



3)
4)

5)

6)

Make sure the object is not selected and double-click on a glue point that you have added
to select the glue point.

Select the exit directions you want to use for connectors and double-click again on the glue
point to customize the glue point.

To use horizontal and vertical positioning, click on the Glue Point Relative icon or right-
click on the glue point and select Adapt Position to Object from the context menu to
deselect this tool.

Select the horizontal and vertical positioning tools you want to use and double-click on the
glue point to customize the glue point. Only one horizontal positioning tool and one vertical
positioning tool can be used at any one time.

Deleting glue points

Only glue points that have added to an object can be deleted. The default glue points included with
an object cannot be deleted.

1)

2)

3)

Make sure no objects are selected and click on the Glue Points icon ﬁ or select Edit >
Glue Points on the main menu bar. Glue points will appear as small crosses on objects
(Figure 6 on page 5).

Make sure the object is not selected and double-click on a glue point that you have added
to select the glue point.

Right-click on the glue point and select Cut from the context menu, or press the Delete key
on the keyboard, or go to Edit > Cut on the main menu bar.

Connector text

Text can be easily added to connectors, then formatted or edited to make, for example, your
flowchart or organization chart easier to follow. See Chapter 2 Drawing Basic Shapes and Chapter
9 Advanced Draw Techniques for more information on working with text.

Adding text

1)
2)

3)

4)

Select the connector.and the control points become active.

Click on the Text icon T or Text Vertical icon ™ on the Drawing toolbar and the familiar
flashing text cursor appears close to the connector. The Text Formatting toolbar replaces
the Line and Filling toolbar.

Use the Text Formatting toolbar or Format and Tools on the main menu bar to change
the default format of the text.

Type the text and, when you have finished typing the text and using the text tools, move the
cursor away from the objects and connector and click to end the text mode. The Line and
Filling toolbar then replaces the Text Formatting toolbar.

Formatting and editing text

1)

2)

3)

Click on the connector text to enter text editing mode. The Text Formatting toolbar
replaces the Line and Filling toolbar under the menu bar.

Perform any changes to the text using the text tools provided on the Text Formatting
toolbar or Format and Tools on the main menu bar. You can also right-click on the text and
select text tools from the context menu.

Right-click on the connector text and select Text from the context menu or go to Format >
Text to open the Text dialog (Figure 9) where you can change the Text anchor and
Spacing to borders.
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Figure 9: Text dialog

A connector has an invisible rectangle around it. Text anchor will position the text
Note within this invisible rectangle and Spacing to borders will create margins between
the text and the borders. These options are in addition to the standard text tools.

4) Click on the Text Animation tab where you can animate the text. However, this is not
recommended unless you are going to display the drawing as part of a presentation. See
the Impress Guide for more information on text animation.

5) When you have finished formatting and editing your text, move the cursor away from the
objects and connector and click to end the text mode. The Line and Filling toolbar then
replaces the Text Formatting toolbar.

Flowcharts

For drawing flowcharts (also known as flow diagrams), Draw has a Flowchart toolbar that includes
a large selection of flowchart tools to help you to easily draw a flowchart.(Figure 10). Click on the

small triangle to the right of the Flowchart icon ﬁ on the Drawing toolbar to open the Flowchart
toolbar. Note that this icon changes shape depending on the last flowchart tool used. This toolbar
can become a floating toolbar by clicking on the bottom of the pop-up toolbar and dragging it into

your workspace.

1) When adding objects to your flowchart, see Chapter 2 Drawing Basic Shapes for
information on how to draw and resize object shapes.

2) Add text to each flowchart shape to make it easily identified in the flowchart. See Chapter 2
Drawing Basic Shapes and Chapter 9 Advanced Draw Techniques for more information.

3) Use connections lines in your flowchart. This allows repositioning of an object in your chart
while maintaining connections with the other objects in the chart. See “Connectors” on
page 4 for more information.

4) Use the zoom, grid and snap functions to help in positioning objects in your flowchart. See
Chapter 3 Working with Objects and Object Points for more information.
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Flowchart: Process

Flowchart: Alternate Process
Flowchart: Decision
Flowchart: Data

Flowchart: Predefined Process
Flowchart: Internal Storage

Flowchart: Document
Flowchart: Multidocument
Flowchart: Terminator
Flowchart: Preparation
Flowchart: Manual Input
Flowchart: Manual Operation

Flowchart: Connector
Flowchart: Off-page Connector
Flowchart: Card

Flowchart: Punched Tape
Flowchart: Summing Junction
Flowchart: Or

Flowchart: Collate
Flowchart: Sort
Flowchart: Extract
Flowchart: Merge
Flowchart: Stored Data
Flowchart: Delay

Flowchart: Sequential Access
Flowchart: Magnetic Disc
Flowchart: Direct Access Storage
Flowchart: Display
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Figure 10: Flowchart toolbar

5) Use the alignment and distribution functions to give your flowchart a more professional
look. See Chapter 5 Combining Multiple Objects for more information.

6) Duplicate objects when you require more than one of the same shape and size. See
Chapter 5 Combining Multiple Objects for more information.

Organization charts

Draw does not have a toolbar for organization charts, but these charts are easily created using
basic shapes, flowchart shapes, connection points and connector lines. Hierarchy in an
organization is easily indicated using shading and/or color. When using shading and color in an
organization chart, make sure that your choices provide a good contrast between the text and the
shading or color to make the chart easy to read on a computer display or in a printed document.
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An example of an organization chart is shown in Figure 11. This was drawn using the process
shape from the Flowchart toolbar and connection lines.

1) When adding objects to your chart, see Chapter 2 Drawing Basic Shapes for information on
how to draw and resize object shapes.

2) Add text to each object in the organization chart to make it easily identified in the chart. See
Chapter 2 Drawing Basic Shapes and Chapter 9 Advanced Draw Techniques for mare
information.

3) Use connections lines in your organization chart. This allows repositioning of an object in
your chart while maintaining connections with the other objects in the chart. See
“Connectors” on page 4 for more information.

4) Use the zoom, grid and snap functions to help in positioning objects in your chart. See
Chapter 3 Working with Objects and Object Points for more information.

5) Use the alignment and distribution functions to give your organization chart a more
professional look. See Chapter 5 Combining Multiple Objects for more information.

6) Duplicate objects when you require more than one of the same shape and size. See
Chapter 5 Combining Multiple Objects for more information.

Management
[ |
Development Sales
Hardware Software Assembly Parts Europe America

Figure 11: Example organization chart
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