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Note for Mac users

Some keystrokes and menu items are different on a Mac from those used in Windows and Linux. 
The table below gives some common substitutions for the instructions in this chapter. For a more 
detailed list, see the application Help.

Windows/Linux Mac equivalent Effect

Tools > Options menu 
selection

LibreOffice > Preferences Access setup options

Right-click Control+click Open context menu

Ctrl (Control) z (Command) Used with other keys

F5 Shift+z+F5 Open the Navigator

F11 z+T Open Styles and Formatting window

Documentation for LibreOffice is available at www.libreoffice.org
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Choosing options that affect all of LibreOffice

This section covers some of the settings that apply to all the components of LibreOffice and are of 
most interest to users of Impress. Other general options are discussed in Chapter 2, Setting Up 
LibreOffice, in the Getting Started guide.

1) Click Tools > Options (LibreOffice > Preferences on a Mac). The list on the left-hand 
side of the Options – LibreOffice dialog box varies depending on which component of 
LibreOffice is open. The illustrations in this chapter show the list as it appears when 
Impress is open.

2) Click the expansion marker (+ or triangle) by LibreOffice on the left-hand side. A list of 
subsections drops down.

Figure 1: LibreOffice options

Note
The Back button has the same effect on all pages of the Options dialog box. It resets 
the options to the values that were in place when you opened LibreOffice.

User Data options
Impress uses the first and last name stored in the User Data page to fill in the Created by and 
Modified by fields in the document properties, the optional Author field often used in the footer of a 
presentation, and the name associated with comments. You will want to ensure that your name 
appears there. To do this:

1) In the Options dialog box, click LibreOffice > User Data.

2) Fill in the form on the LibreOffice – User Data page or delete any existing incorrect 
information.

Print options
On the LibreOffice – Print page, set the print options to suit your default printer and your most 
common printing method. 

You can change these settings at any time, either through the Options dialog box or during the 
printing process (by clicking the Options button on the Print dialog box).

See Chapter 10, Printing, e-mailing, exporting, and saving slide shows, for more about the options 
on this page.
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Color options
On the LibreOffice – Colors page, you can specify colors to use in LibreOffice documents. You can 
select a color from a color table, edit an existing color, and define new colors. These colors are 
stored in your color selection palette and are then available in all components of LibreOffice. You 
can also define colors within Impress by choosing Format > Area on the menu bar, or through the 
Line and Filling toolbar, but those colors will not be available to other components of LibreOffice.

Figure 2. Defining colors to use in color palettes in LibreOffice

Appearance options
On the LibreOffice – Appearance page, you can specify which items are visible and the colors used 
to display various elements of the user interface.

Figure 3. Changing the color of grid points in Impress and Draw

The only choice specific to Impress (and Draw) is the color of the grid points. Scroll down in the 
page until you find Drawing/Presentation.

To change the default color for grid points, click the down-arrow by the color and select a new color 
from the pop-up box.

If you wish to save your color changes as a color scheme, click Save, type a name in the Scheme 
box, then click OK.
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Choosing options for Impress

In the Options dialog box, click the expansion marker to the left of LibreOffice Impress on the left-
hand side. A list of subsections drops down.

Figure 4: Options for Impress

General options
In the Options dialog box, click LibreOffice Impress > General.

Figure 5: Specifying general options for Impress

Text objects section
Allow quick editing sets Impress to immediately switch to the text editing mode when you click a 

text object. You can also activate the text editing mode through the Allow Quick Editing icon  
on the Options toolbar.
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Only text area selectable sets Impress to select a text frame when you click on text. In the area of 
the text frame that is not filled with text, an object behind the text frame can be selected. You can 

also activate this mode through the Select Text Area Only icon  on the Options toolbar.

New document section
Start with Wizard sets Impress to start with the Presentation Wizard when creating a new 
presentation with File > New > Presentation or other methods.

Settings section
Use background cache sets Impress to use the cache for displaying objects on the master page. 
This setting speeds up the display. Unmark this box if you want Impress to draw the background 
every time you display a slide.

y when moving automatically creates a copy when you move, rotate or resize an object while 
holding down the Ctrl key (  key for Mac)⌘ . The original object will remain in its current position and 
size.

Objects always movable lets you move an object with the Rotate tool enabled. If this box is not 
marked, the Rotate tool can only be used to rotate an object.

Unit of measurement determines the unit of measurement for presentations.

Tab stops defines the spacing between tab stops.

Start presentation section
Always with current page specifies that a presentation starts with the current slide. Unmark this box 
to always start a presentation with the first page.

Compatibility section
The settings in this area are valid for the current document only.

Use printer metrics for document formatting applies printer metrics for printing and for formatting 
the display on the screen; some formatting will depend on the printer selection or default printer on 
your computer and may vary if the presentation is moved to a different computer. If this box is not 
checked, a printer-independent layout is used for screen display and printing.

Add spacing between paragraphs (in current document) calculates the paragraph spacing in 
Impress exactly as Microsoft PowerPoint does. Microsoft PowerPoint adds the bottom spacing of a 
paragraph to the top spacing of the next paragraph to calculate the total spacing between both 
paragraphs. Impress normally uses only the larger of the two spacings.

View options
In the Options dialog box, click LibreOffice Impress > View.

Figure 6: Specifying view options for Impress
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Rulers visible displays the rulers at the top and the left of the work area.

Guides when moving displays dotted guides that extend beyond the box containing the selected 
object and which cover the entire work area, helping you position the object when moving it. You 

can also use the Guides when moving icon  on the Options toolbar.

All control points in Bézier editor displays the control points of all Bézier points if you have 
previously selected a Bézier curve. If this box is not marked, only the control points of the selected 
Bézier points will be visible.

Contour of each individual object displays the contour line of each individual object when moving 
the object. This enables you to see if single objects conflict with other objects in the target position. 
If you do not mark this box, Impress displays only a square contour that includes all selected 
objects.

Grid options
The Grid page defines the grid settings for Impress. Using a grid helps you determine the exact 
position of your objects. You can also set this grid in line with the snap grid.

In the Options dialog box, click LibreOffice Impress > Grid.

Figure 7: Specifying grid options for Impress

Grid section
Snap to grid activates the “snap” function.

If you have activated the snap grid but wish to move or create individual objects without snap 
positions, you can press the Ctrl key to deactivate the snap grid for as long as needed.

Visible grid displays grid points on the screen. These points will not display or print as part of a 
presentation.
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Resolution section
Here you can set the unit of distance for the spacing between horizontal and vertical grid points 
and subdivisions (intermediate points) of the grid.

Synchronize axes applies any changes to the Resolution or Subdivision settings to both axes.

Snap section
To snap lines snaps the edge of a dragged object to the nearest snap line when you release the 

mouse button. You can also use the Snap to Guides icon  on the Options toolbar.

To the page margins aligns the contour of the graphic object to the nearest page margin. The 
cursor or a contour line of the graphic object must be in the snap range. You can also use the 

Snap to Page Margins icon  on the Options toolbar.

To object frame aligns the contour of the graphic object to the border of the nearest graphic object. 
The cursor or a contour line of the graphic object must be in the snap range. You can also use the 

Snap to Object Border icon  on the Options toolbar.

To object points aligns the contour of the graphic object to the points of the nearest graphic object. 
The cursor or a contour line of the graphic object must be in the snap range. You can also use the 

Snap to Object Points icon  on the Options toolbar.

Snap range defines the snap distance between the mouse pointer and the object contour. Impress 
snaps to a snap point if the mouse pointer is nearer than the distance selected in the Snap range 
box.

Snap position section
When creating or moving objects restricts graphic objects vertically, horizontally or diagonally (45°) 
when creating or moving them. You can temporarily deactivate this setting by pressing the Shift 
key.

Extend edges controls how a square or circle is drawn with the drawing tool.  When the Extend 
edges box is marked, the sides of the square drawn when the Shift key is pressed before you 
release the mouse button will be equal to the longer side of a rectangle. This also applies to the 
ellipse tool: when the Shift key is pressed before you release the mouse button a circle will be 
created based on the longest diameter of the ellipse. When the Extend edges box is not marked, 
a square or a circle will be created based on the shorter side or diameter.

When rotating restricts the rotation of graphic objects within the rotation angle that you select in the 
When rotating box. If you want to rotate an object outside of the defined angle, press the Ctrl key 
(Shift key on Mac) when rotating. Release the key when the desired rotation angle is reached.

Point reduction defines the angle for point reduction. When working with polygons, you might find it 
useful to reduce their editing points.

Print options
In the Options dialog box, click LibreOffice Impress > Print.

See Chapter 10, Printing, e-mailing, exporting, and saving slide shows, for more about the options 
on this page.
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Figure 8: Specifying print options for Impress

Customizing the user interface

Customizing the menu font
If you want to change the menu font from that supplied by LibreOffice to the system font for your 
operating system, do this:

1) Choose Tools > Options > LibreOffice > View.

2) Check Use system font for user interface and click OK.

Customizing menu content
You can customize menus: add and rearrange items on the menu bar, add items to menus, and 
make other changes.

1) Choose Tools > Customize.

2) On the Customize dialog box, pick the Menus page.

3) In the Save In drop-down list, choose whether to save this changed menu for Impress or 
for a selected document (for example, MySlideShow.odp).

4) In the section LibreOffice Impress Menus, select from the Menu drop-down list the menu 
that you want to customize.

5) To customize the selected menu, click on the Menu or Modify buttons. You can also add 
commands to a menu by clicking on the Add button. These actions are described in the 
following sections. Use the up and down arrows next to the Entries list to move the 
selected menu item to a different position.

6) When you have finished making all your changes, click OK to save them.
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Figure 9. The Menus page of the Customize dialog box

Creating a new menu
In the Menus page of the Customize dialog box, click New to display the dialog shown in Figure
10.

1) Type a name for your new menu in the Menu name box.

2) Use the up and down arrow buttons to move the new menu into the required position on 
the menu bar.

3) Click OK to save.

The new menu now appears on the list of menus in the Customize dialog box. (It will appear on the 
menu bar itself after you save your customizations.)

After creating a new menu, you need to add some commands to it, as described in “Adding a
command to a menu” on page 12.
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Figure 10: Adding a new menu

Modifying existing menus
To modify an existing menu, select it in the Menu list and click the Menu button to drop down a list 
of modifications: Move, Rename, Delete. Not all of these modifications can be applied to all the 
entries in the Menu list. For example, Rename and Delete are not available for the menus supplied 
by LibreOffice.

To move a menu (such as File), choose Menu > Move. A dialog box similar to the one shown in 
Figure 10 (but without the Menu name box) opens. Use the up and down arrow buttons to move 
the menu into the required position.

To move submenus (such as File | Send), select the main menu (File) in the Menu list and then, in 
the Menu Content section of the dialog, select the submenu (Send) in the Entries list and use the 
arrow keys to move it up or down in the sequence. Submenus are easily identified in the Entries list 
by a small black triangle on the right hand side of the name.

In addition to renaming, you can specify a keyboard shortcut that allows you to select a menu 
command when you press Alt+ an underlined letter in a menu command.

1) Select a menu or menu entry.

2) Click the Modify button and select Rename.

3) Add a tilde (~) in front of the letter that you want to use as an accelerator. For example, to 
select the Save All command by pressing Alt+V (after opening the File menu using Alt+F), 
enter Sa~ve All.

Caution Be careful when using these shortcuts. In the example above, if the File menu is 
not already open, then pressing Alt+V opens the View menu; if some other menu is 
open, Alt+V might activate some other command.

Adding a command to a menu
You can add commands to the supplied menus and to menus you have created. In the Customize 
dialog box, select the menu in the Menu list and click the Add button in the Menu Content section 
of the dialog.
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On the Add Commands dialog, select a category and then the command, and click Add. The 
dialog remains open, so you can select additional commands. When you have finished adding 
commands, click Close. Back in the Customize dialog box, you can use the up and down arrow 
buttons to arrange the commands in your preferred sequence.

Figure 11: Adding a command to a menu

Modifying menu entries
In addition to changing the sequence of entries on a menu or submenu, you can add submenus, 
rename or delete the entries, and add group separators.

To begin, select the menu or submenu in the Menu list near the top of the Customize page, then 
select the entry in the Entries list under Menu Content. Click the Modify button and choose the 
required action from the drop-down list of actions. Most of the actions should be self-explanatory. 
Begin a group adds a separator line after the highlighted entry.

Customizing toolbars
You can customize toolbars in several ways, including choosing which icons are visible, and 
locking the position of a docked toolbar, as described in Chapter 1, Introducing LibreOffice, of the 
Getting Started guide. This section describes how to create new toolbars and add other icons 
(commands) to the list of those available on a toolbar.

To get to the toolbar customization dialog, do any of the following:

• On the toolbar, click the arrow at the end of the toolbar and choose Customize Toolbar.

• Choose View > Toolbars > Customize from the menu bar.

• Choose Tools > Customize > Toolbars tab from the menu bar.
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Figure 12. The Toolbars page of the Customize window

To customize toolbars:

1) In the Save In drop-down list, choose whether to save this changed toolbar for Impress or 
for a selected document.

2) In the LibreOffice Impress Toolbars section, select from the Toolbar drop-down list the 
toolbar that you want to customize.

3) Click the Toolbar button on the right to display a drop-down list of choices.

4) To display or hide commands, select or deselect the checkboxes in the Toolbar Content – 
Commands section.

5) To change the position of commands on a toolbar, select a command and click the big up 
and down arrows to the right of the lists.

6) You can create a new toolbar by clicking on the New button, or customize existing toolbars 
by clicking on the Toolbar or Modify buttons, and add commands to a toolbar by clicking on 
the Add button. These actions are described below.

7) When you are done customizing toolbars, click OK to save your changes.
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Creating a new toolbar
To create a new toolbar:

1) Choose Tools > Customize > Toolbars from the menu bar.

2) Click New. In the Name dialog, type the new toolbar's name and choose from the Save In 
drop-down list where to save this changed menu: for Impress or for a selected document.

Figure 13: Dialog box used to create a new toolbar

The new toolbar now appears on the list of toolbars in the Customize dialog box. After creating a 
new toolbar, you need to add some commands to it, as described below.

Adding a command to a toolbar
If the list of available buttons for a toolbar does not include all the commands you want on that 
toolbar, you can add commands.

1) On the Toolbars page of the Customize dialog box, select the toolbar in the Toolbar list and 
click the Add button in the Toolbar Content section of the dialog.

2) The Add Commands dialog is the same as for adding commands to menus. Select a 
category and then the command, and click Add. The dialog remains open, so you can 
select additional commands. When you have finished adding commands, click Close. If 
you insert an item which does not have an associated icon, the toolbar will display the full 
name of the item; the next section describes how to choose an icon for a toolbar command.

3) Back on the Customize dialog box, you can use the up and down arrow buttons to arrange 
the commands in your preferred sequence.

4) When you are done making changes, click OK to save.

Choosing icons for toolbar commands
Toolbar buttons usually have icons, not words, on them, but not all of the commands have 
associated icons.

To choose an icon for a command, select the command and click Modify > Change icon. On the 
Change Icon dialog, you can scroll through the available icons, select one, and click OK to assign 
it to the command.

To use a custom icon, create it in a graphics program and import it into LibreOffice by clicking the 
Import button on the Change Icon dialog. Custom icons must be 16 x 16 or 26 x 26 pixels in size 
and cannot contain more than 256 colors.
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Figure 14: Change Icon dialog

Customizing keyboard shortcuts 
The Appendix to this book lists the default keyboard shortcuts supplied with Impress. You can 
change these defaults or add new shortcuts. You can assign shortcuts to standard Impress 
functions or your own macros and save them for use with Impress only, or with the entire 
LibreOffice suite.

Caution

Be careful when reassigning your operating system’s or LibreOffice’s predefined 
shortcut keys. Many key assignments are universally understood shortcuts, such as 
F1 for Help, and are always expected to provide certain results. Although you can 
easily reset the shortcut key assignments to the LibreOffice defaults, changing some 
common shortcut keys can cause confusion, frustration and possible data loss or 
corruption, especially if other users share your computer.

As an example, suppose you wish to assign a shortcut key to easily insert a duplicate slide in your 
presentation. You could assign the Insert key as a logical shortcut for this purpose, as described 
below:

1) Choose Tools > Customize.

2) On the Customize dialog box, pick the Keyboard page (Figure 15).

3) As the shortcut key assignment is only relevant with Impress, and not LibreOffice in 
general, select the Impress button (at the upper right corner of the Keyboard tab).

4) Next select Insert in the Category list and Duplicate Slide in the Function list.

5) Now select the shortcut key Insert in the Shortcut keys list and click the Modify button at 
the upper right.

6) Click OK to accept the change. Now the Insert shortcut key will insert a duplicate slide 
immediately after the currently selected slide.
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Figure 15: Customizing keyboard shortcuts

Note

All existing shortcut keys for the currently selected Function are listed in the Keys 
selection box. Since there was no currently assigned shortcut for the 
Insert > Duplicate Slide function the Keys list was empty. If it had not been, and you 
wished to reassign a shortcut key combination that was already in use, you would 
first have had to Delete the existing Key.

Shortcut keys that are greyed out in the listing on the Customize dialog box, such as 
F1 and F10, are not available for reassignment.

Saving changes to a file
Changes to the shortcut key assignments (and other configurations) can be saved in a keyboard 
configuration file for use at a later time, thus permitting you to create and apply different 
configurations as the need arises. To save keyboard shortcuts to a file:

1) After making your keyboard shortcut assignments, click the Save button near the bottom 
right of the Customize dialog box.

2) In the Save Keyboard Configuration dialog box, select All files from the Save as Type list.

3) Next enter a name for the keyboard configuration file in the File name box, or select an 
existing file from the list. If you need to, browse to find a file from another location.
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4) Click Save. A confirmation dialog box will appear if you are about to overwrite an existing 
file; otherwise there will be no feedback and the file will be saved.

Loading a saved keyboard configuration
To load a saved keyboard configuration file and replace your existing configuration, click the Load 
button near the bottom right of the Customize dialog box, and then select the configuration file from 
the Load Keyboard Configuration dialog box.

Resetting the shortcut keys
To reset all of the keyboard shortcuts to their default values, click the Reset button beneath the 
Save button on the right side of the Customize dialog box. Use this feature with care as no 
confirmation dialog box will be displayed; the defaults will be set without any further notice or user 
input.

Running macros from key combinations
You can also define shortcut key combinations that will run macros. These shortcut keys are strictly 
user-defined; none are built in. For information on macros, see Chapter 13, Getting started with 
macros, in the Getting Started guide.

Adding functionality with extensions

An extension is a package that can be installed into LibreOffice to add new functionality.

Although individual extensions can be found in different places, the official LibreOffice extension 
repository is at http://extensions.services.openoffice.org/. Some extensions are free of charge; 
others are available for a fee. Check the descriptions to see what licenses and fees apply to the 
ones that interest you.

Installing extensions
To install an extension, follow these steps:

1) Download an extension and save it anywhere on your computer.

2) In LibreOffice, select Tools > Extension Manager from the menu bar. In the Extension 
Manager dialog box (Figure 16), click Add.

3) A file browser window opens. Find and select the extension you want to install and click 
Open. The extension begins installing. You may be asked to accept a license agreement.

4) When the installation is complete, the extension is listed in the Extension Manager dialog.

Tip
To get extensions that are listed in the repository, you can open the Extension 
Manager and click the Get more extensions here link.

Note
To install a shared extension, you need write access to the LibreOffice installation 
directory. 
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Figure 16: Installing an extension

Using extensions
This section describes some of the more important and popular extensions to Impress. In each 
case, you need to first install the extension as described in the previous section.

Presenter Console
(Bundled with most installations of LibreOffice.) Provides extra control over slide shows 
(presentations); for example, the presenter has the ability to see the upcoming slide, the slide 
notes, and a presentation timer—while the audience sees only the current slide. The Presenter 
Console displays the elements in three easily changeable views:

• The first view displays the current slide, including the effects, and the upcoming slide.

• The second view shows the speaker's notes in large, clear, and scalable type, plus the 
current and upcoming slide.

• The third view is a slide sorter view with the slide thumbnails.

See Chapter 9, Slide Shows, for more about using Presenter Console.

Note
The Presenter Console works only on an operating system that supports multiple 
displays and only when two displays are connected (one may be the laptop’s built-in 
screen).

Professional Template Pack II
Provides more than 120 templates for Writer, Calc, and Impress. Available in several languages. 
After you have installed this extension, you will find the templates under File > New > Templates 
and Documents. 
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Presentation Minimizer
Reduces the file size of the current presentation. Images are compressed, and data that is no 
longer needed is removed. Can optimize the image quality size. Presentations designed for screen 
or projector do not require the same high quality as presentations designed for print. From Oracle 
Corp. 

Template Changer
Adds two new items to the File > Templates menu that allow you to assign a new template to a 
folder of presentations. All styles and formatting will be loaded from that template and the 
document will behave as if it were created using that template.
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