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Introduction

LibreOffice Math allows you to create or edit formulas (equations) in a symbolic form, within 
LibreOffice documents or as stand-alone objects; example formulas are shown below. However, if 
you want to evaluate numeric values using formulas, then refer to the Calc Guide for more 
information as Math does not carry out any actual calculation.

df (x)
dx

=ln (x)+tan−1(x2) or NH3+H2 O⇌NH4
++OH −

The Formula Editor in Math uses a markup language to represent formulas. This markup language 

is designed to be easily read wherever possible; for example, a over b produces the fraction
a
b

.

Getting started

Using the Formula Editor, you can create a formula as a separate document or file for a formula 
library, or insert formulas directly into a document using LibreOffice Writer, Calc, Impress, or Draw.

Formulas as separate documents or files
To create a formula as a separate document or file, use one of the following methods to open an 
empty formula document in LibreOffice Math (Figure 1):

• On the Menu bar, go to File > New > Formula.

• On the Standard toolbar, click the triangle to the right of the New icon and select Formula.

• From the Start Center, click Math Formula.

• From within LibreOffice Math, use the keyboard shortcut Ctrl+N.

Figure 1: An empty formula document in Math
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As you enter the markup language in the Formula Editor, the formula will appear in the Preview 
window during and after input of the markup language. The Elements Dock to the left of the 
Preview window may also appear, if these have been selected in View on the Menu bar. For more 
information on creating formulas, see “Creating formulas” on page 7.

Formulas in LibreOffice documents
To insert a formula into a LibreOffice document, open the document in Writer, Calc, Draw, or 
Impress. The component you are using affects how you position the cursor to insert the formula.

• In Writer, click in the paragraph where you want to insert the formula.

• In Calc, click in the spreadsheet cell where you want to insert the formula.

• In Draw and Impress, the formula is inserted into the center of the drawing or slide.

Then, go to Insert > Object > Formula on the Menu bar to open the Formula Editor. Alternatively, 
go to Insert > Object > OLE Object on the Menu bar to open the Insert OLE Object dialog, select 
Create new and the Formula option from the list of object types, then click OK to open the Formula
Editor. The Elements Dock to the left of the Preview window and/or the Elements dialog as a 
floating dialog may also appear, if these have been selected in View on the Menu bar. 

Figure 2 shows an example Writer document with the formula box selected ready for a formula to 
be entered.

Figure 2: Empty formula in a Writer document

When you have completed entering the markup language for your formula, close the Formula 
Editor by pressing the Esc key or by clicking an area outside the formula in your document. 
Double-clicking on the formula object in the document will open the Formula Editor again so you 
can edit the formula.
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Formulas are inserted as OLE objects into documents. You can, as with any OLE object, change 
how the object is placed within your document. For more information on OLE objects, see 
“Formulas in Writer” on page 25, “Formulas in Calc, Draw, and Impress” on page 31, and the user 
guides for Writer, Calc, Draw, and Impress.

If you frequently insert formulas into documents, it is recommended to add the Formula button to 
the Standard toolbar or create a keyboard shortcut. See “Customization” on page 32 for more 
information.

Creating formulas

You can insert a formula using one of the following methods:

• In the Elements dock, select a category from the drop-down list, then a symbol.

• Right-click in the Formula Editor and select a category, then a symbol from the context 
menu.

• Enter markup language directly in the Formula Editor.

Note

Using the Elements dock or the context menus to insert a formula provides a 
convenient way to learn the markup language used by Math.

Tip

When using the Elements dock, it is recommended to have Extended tips selected in 
the LibreOffice Options. This will help you identify the categories and symbols you 
want to use in your formula. Go to Tools > Options > LibreOffice > General and 
select Extended tips in the Help section.

Elements dock
The Elements dock can be used when entering your formula data. The Elements dock also 
provides an Example category which gives you example formulas to use as a starting point for your
formula or equation.

 1) Go to View > Elements on the Menu bar to open the Elements dock (Figure 3).

Figure 3: Elements dock

 2) Select the category you want to use in your formula from the drop-down list at the top of the
Elements dock.
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 3) Select the symbol you want to use in your formula from the Elements dock. The symbols 
that are available change according to the selected category.

Note

The Elements dock can either be a floating dialog, as shown in Figure 3, or positioned 
to the left of the Formula Editor, as shown in Figure 1 and Figure 2.

Context menu
The Formula Editor also provides a context menu to access categories and symbols. Right-click in 
the Formula Editor to open the context menu. Select a category and then select the markup 
example that you want to use from the sub-context menu, an example is shown in Figure 4.

Note

The Elements Dock and context menu contain only the most common commands that 
are used in formulas. For some seldom-used commands, you must always enter the 
command using the markup language. For a complete list of commands, see Appendix
A, Commands Reference, in the Math Guide.

Figure 4: Context menu in Formula Editor
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Markup language
Markup language is entered directly into the Formula Editor. For example, typing the markup 
language 5 times 4 into the Formula Editor creates the simple formula 5×4 . If you are 
experienced in using markup language, it can be the quickest way to enter a formula. Table 1 
shows some examples of using markup language to enter commands. For a full list of commands 
that can be used in the Formula Editor, see Appendix A, Commands Reference, in the Math Guide.

Table 1: Example commands using markup language

Display Command Display Command

a=b a = b √a sqrt {a}

a2 a^2 an a_n

∫ f (x)dx int f(x) dx ∑ an sum a_n

a≤b a <= b ∞ infinity

a×b a times b x⋅y x cdot y

Greek characters

Using markup language
Greek characters are commonly used in formulas, but Greek characters cannot be entered into a 
formula using the Elements dock or the context menu. Use the English names of Greek characters 
in markup language when entering Greek characters into a formula. See Appendix A, Commands 
Reference, in the Math Guide for a list of characters that can be entered using markup language.

• For a lowercase Greek character, type a percentage % sign, then type the character name 
in lowercase using the English name. For example, typing %lambda creates the Greek 
character λ.

• For an UPPERCASE Greek character, type a percentage % sign, then type the character 
name in UPPERCASE using the English name. For example, typing %LAMBDA creates the
Greek character Λ.

• For an italic Greek character, type a percentage % sign followed by the i character, then the
English name of the Greek character in lower or UPPER case. For example, typing 
%iTHETA creates the italic Greek character Θ.

Symbols dialog
Greek characters can also be entered into a formula using the Symbols dialog.

 1) Make sure your cursor is in the correct position in the Formula Editor.

 2) Go to Tools > Symbols on the Menu bar, or click the Symbols icon in the Tools toolbar, to 
open the Symbols dialog (Figure 5).

 3) Select Greek from the Symbol set drop-down list. For italic characters, select iGreek from 
the drop-down list.

 4) Select the Greek character from the symbol list, then click Insert. When selected, the name
of a Greek character is shown below the symbol list.

 5) Click Close when you have finished entering Greek characters into your formula.
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Figure 5: Symbols dialog

Formula examples
Example 1
The simple formula 5×4  can be created using LibreOffice Math as follows:

 1) Make sure your cursor is flashing in the Formula Editor, then select the category 
Unary/Binary Operators and symbol Multiplication using one of the following methods:

– In the Elements Dock, select Unary/Binary Operators from the drop-down list and then
select the Multiplication icon .

– Right-click in the Formula Editor and select Unary/Binary Operators > a times b from 
the context menu.

– Using markup language, enter 5 times 4 in the Formula Editor.

The first two methods place the formula text <?> times <?> in the Formula Editor and 

the symbol  appears in the document. For the third method, using markup language 
in the Formula Editor places the formula 5×4 directly into your document and there is no 
need to carry out the following steps.

 2) Select the first placeholder <?> before the word times in the Formula Editor and replace it 
with the character 5. The formula in your document updates automatically.

 3) Select the second placeholder <?> after the word times in the Formula Editor and replace 
it with the character 4. The formula in your document updates automatically.

Tip

To move forward from one placeholder to the next placeholder in a formula, press the 
F4 key. To move backward from one placeholder to the previous placeholder in a 
formula, use the key combination Shift+F4.
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Note

If necessary, you can prevent a formula in a document from updating automatically. Go
to View on the Menu bar and deselect AutoUpdate display. To then manually update 
a formula, press the F9 key or select View > Update on the Menu bar.

Example 2
You want to enter the formula π ≃ 3.14159 where the value of pi is rounded to 5 decimal 
places. You know the name of the Greek character (pi), but do not know the markup associated 
with the Is Similar Or Equal symbol ≃ .

 1) Make sure your cursor is flashing in the Formula Editor.

 2) Enter %pi in the Formula Editor to enter the Greek character for pi (π).

 3) Select the category Relations and symbol Is Similar Or Equal using one of the following 
methods:

– In the Elements dock, select Relations from the drop-down list and then select the Is 
Similar Or Equal icon .

– Right-click in the Formula Editor and select Relations > a simeq b from the context 
menu.

 4) Delete the first placeholder <?> before the word simeq in the Formula Editor.

 5) Select the second placeholder <?> after the word simeq in the Formula Editor and replace 
it with the characters 3.14159. The formula π ≃ 3.14159 now appears in your 
document.

Editing formulas

How you edit a formula and switch into formula editing mode depends on whether the formula is in 
Math or another LibreOffice component.

 1) In Math, double-click on a formula element in the formula that appears in the Preview 
window to select the formula element in the Formula Editor, or directly select a formula 
element in the Formula Editor.

 2) In Writer, Calc, Impress, or Draw, double-click on the formula, or right-click on the formula 
and select Edit from the context menu, to open the Formula Editor and enter editing mode. 
The cursor is positioned at the start of the formula in the Formula Editor.

Note

If you cannot select a formula element using your cursor, click on the Formula Cursor
icon in the Tools toolbar to activate the formula cursor.

 3) Select the formula element you want to change using one of the following methods:

– Click on the formula element in the Preview window, positioning the cursor at the 
beginning of the formula element in the Formula Editor, then select the formula element 
in the Formula Editor.

– Double-click on the formula element in the Preview window to select the formula 
element in the Formula Editor.

– Position the cursor in the Formula Editor at the formula element you want to edit, then 
select that formula element.

– Double-click directly on the formula element in the Formula Editor to select it.
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 4) Make your changes to the formula element you have selected.

 5) Go to View > Update on the Menu bar, or press the F9 key, or click on the Update icon on 
the Tools toolbar to update the formula in the Preview window or your document.

 6) In Math, save your changes to the formula after editing.

In Writer, Calc, Impress, or Draw, click anywhere in your document away from the formula 
to leave editing mode, then save the document to save your changes to the formula.

Formula layout

This section provides some advice on how to lay out complex formulas in Math or in your 
document.

Using braces
Math knows nothing about order of operation within a formula. You must use braces (curly 
brackets) to state the order of operations that occur within a formula. The following examples show
how braces can be used in a formula.

Example 1

2 over x + 1 gives the result
2
x
+1

Math has recognized that the 2 before and the x after the over as belonging to the fraction, 
and has represented them accordingly. If you want x+1 rather than x to be the denominator, 
you must bracket them together using braces so that both will be placed there.

Inserting braces into 2 over {x + 1} gives the result
2
x+1

where x+1 is now the 

denominator.

Example 2

– 1 over 2 gives the result
−1
2

Math has recognized the minus sign as a prefix for the 1 and has therefore placed it in the 
numerator of the fraction. If you wish to show that the whole fraction is negative, with the 
minus sign in front of the fraction, you must put the fraction in braces to signify to Math that 
the characters belong together.

Adding braces  into the markup language – {1 over 2} gives the result –
1
2

and the 

whole fraction is now negative.

Example 3
When braces are used in markup language, they are used to define the layout of the formula 
and are not displayed or printed. If you want to use braces within a formula, use the 
commands lbrace and rbrace within the markup language.

x over {–x + 1} gives the result
x

– x+1

Replace the braces using the commands lbrace and rbrace in the markup language. Write x

over lbrace –x + 1 rbrace and the result is 
x

{– x+1}
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Brackets (parentheses) and matrices
If you want to use a matrix in a formula, you have to use a matrix command. For example, 

matrix { a # b ## c # d } gives the resulting matrix a b
c d

in your formula, where rows 

are separated by two hashes (##) and entries within each row are separated by one hash (#).

Normally, when you use brackets within a matrix, the brackets do not scale as the matrix increases

in size. For example, ( matrix { a # b ## c # d } ) gives the result (a b
c d

)

To overcome this problem of brackets with a matrix, Math provides scalable brackets that grow in 
size to match the size of a matrix. The commands left( and right) have to be used to create 
scalable brackets within a matrix. For example, left( matrix { a # b ## c # d } 

right) gives the result (a b
c d) where the matrix is now bracketed by scalable brackets.

Scalable brackets can also be used with any element of a formula, such as fraction, square root, 
and so on.

Tip

Use the commands left[ and right] to obtain square brackets. A list of all brackets
available within Math can be found in Appendix A, Commands Reference, of the Math 
Guide.

Tip

If you want all brackets to be scalable, go to Format > Spacing on the Menu bar to 
open the Spacing dialog. Click on Category, select Brackets from the drop-down list, 
and then select the option Scale all brackets.

Unpaired brackets
When using brackets in a formula, Math expects that for every opening bracket there will be a 
closing one. If you forget to add a closing bracket, Math places an inverted question mark next to 
where the closing bracket should have been placed. This inverted question mark disappears when 
all the brackets are paired. However, an unpaired bracket is sometimes necessary and you have 
the following options.

Non scalable brackets
A backslash \ is placed before a non scalable bracket to indicate that the following character should
not be regarded as a bracket, but as a literal character.

For example, the unpaired brackets in the formula [ a; b [ are deliberate, but gives a result with
an inverted question mark. To remove the inverted question mark and create unpaired brackets, 
backslashes are added. The formula now becomes \ [ a; b \ [ and the result [a;b [ shows 
unpaired brackets without any inverted question marks.

Scalable brackets
To create unpaired scalable brackets or braces in a formula, the markup commands left, right, 
and none are used.
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Example

You want to create the formula |x|={ x for x≥0
−x for x<0

and in the Formula Editor you enter abs 

x = lbrace stack {x "for" x >= 0 # -x "for" x < 0}. However, this gives an 
incorrect result. To remove inverted question marks and create the correct formula, you have 
to use the markup commands left, right, and none. Change your entry in the Formula 
Editor to abs x = left lbrace stack {x "for" x >= 0 # -x "for" x < 0} 
right none and this creates the correct formula.

Recognizing functions
In the basic installation of Math, Math outputs functions in normal characters and variables in italic 
characters. However, if Math fails to recognize a function, you can tell Math that you have just 
entered a function. Enter the markup command func before a function forces Math to recognize 
the following text as a function and uses normal characters.

For a full list of functions within Math, see Appendix A, Commands Reference, of the Math Guide.

Some Math functions have to be followed by a number or a variable. If these are missing, Math 
places an inverted question mark where the missing number or variable should be. To remove the 
inverted question mark and correct the formula, you have to enter a number, a variable, or a pair of
empty brackets as a placeholder.

Tip

You can navigate through errors in a formula using the key F3 (next error) or the key 
combination Shift+F3 (previous error).

Formulas over multiple lines

Suppose you want to create a formula that requires more than one line, for example x=3
y=1

. Your 

first reaction would normally be to press the Enter key. However, if you press the Enter key, the 
markup language in the Formula Editor goes to a new line, but the resulting formula does not have 
two lines. You must type the macro command newline each time you want to create and display 
a new line in a formula.

Example
x = 3
y = 1
gives the incorrect result x=3 y=1

x = 3 newline y = 1 gives the correct result x=3
y=1

It is not possible in Math to create multiple line formulas when a line ends with an equals sign and 
you want to continue the calculation on a new line without completing the term on the right side of 
the equals sign. If you require a multiple line formula to have an equals sign at the end of a line 
without a term after the equals sign, then use either empty quotes “”, or empty braces {}, or the 
space characters grave ` or tilde ˜.

By default, the alignment of a multiple line formula is center aligned. For more information on 
alignment using the equals sign, see “Customization” on page 32.

Spacing between the elements in a formula is not set by using space characters in the markup 
language. If you want to add spaces into your formula, use one of the following options:

• Grave ` to add a small space.
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• Tilde ~ for a large space.

• Add space characters between quotes “ ”. These spaces will be considered as text.

Any spaces at the end of a line in the markup language are ignored by default. For more 
information, see “Customization” on page 32.

Adding limits to sum/integral commands
The sum and integral commands can take the parameters from and to if you want to set the 
lower and upper limits respectively. The parameters from and to can be used singly or together 
as shown by the following examples. For more information on the sum and integral commands, 
see Appendix A, Commands Reference, of the Math Guide.

Examples

sum from k = 1 to n a_k gives the result ∑
k=1

n

ak

int from 0 to x f(t) dt gives the result ∫
0

x

f (t)dt

int_0^x f(t) dt gives the result ∫0

x

f ( t)dt

int from Re f gives the result ∫
ℜ

f

sum to infinity 2^{-n} gives the result ∑
∞

2−n

Writing derivatives
When writing derivatives, you have to tell Math that it is a fraction by using the over command. 
The over command is combined with the character d for a total derivative or the partial 
command for a partial derivative to achieve the effect of a derivative. Braces {} are used each 
side of the element to surround the element and make the derivative as shown by the following 
examples.

Examples

{df} over {dx} gives the result
df
dx

{partial f} over {partial y} gives the result
∂ f
∂ y

{partial^2 f} over {partial t^2} gives the result
∂2 f

∂ t2

Note

To write function names with primes, as is normal in school notation, you must first add
the symbols to the catalog. See “Customization” on page 32 for more information.
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Markup language characters as normal characters
Characters that are used as controls in markup language cannot be entered directly as normal 
characters. These characters are: %, {, }, &, |, _, ^, and ". To overcome this limitation in markup 
language, use one of the following methods:

• Use double quotes either side of the character to mark that character as text, for example 
2"%"= 0.02 will appear in your formula as 2%=0.02 . However, this method cannot be 
used for the double-quote character itself, see “Text in formulas” below.

• Add the character to the Math Catalog, for example the double quote character.

• Use commands, for example lbrace and rbrace give you literal braces {} .

Note

The Special Characters dialog used by other LibreOffice components is not available 
in Math. If you are going to regularly require special characters in Math, then it is 
recommended to add the characters to the Math Catalog, see “Customization” on 
page 32 for more information.

Text in formulas
To include text in a formula, you have to enclose any text in double-quotes, for example x " for 
" x >= 0 in markup language will create the formula x  for x≥0 . All characters, except double 
quotes, can be used in text. However, if you require double quotes in your formula text, then you 
have to create your text with double quotes in LibreOffice Writer, then copy and paste the text into 
the Formula Editor as shown in Figure 6.

The font used for text in a formula will be the default font that has been set in the Fonts dialog. For 
more information on how to change fonts used for in formulas, see “Changing formula appearance”
on page 17.

By default, text alignment is left-justified in formulas. For more information on how to change text 
alignment, see “Adjusting formula alignment” on page 23.

Figure 6: Example of double quotes in formula text

Formatting commands are not interpreted within text used in formulas. If you want to use 
formatting commands within formula text, then you must break up the text using double quotes in 
the Formula Editor.
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Example
Entering the following in the Formula Editor:

"In " color blue bold "isosceles" "triangles, the base angles are 
equal"

creates the following text in a formula In isosceles triangles, the base angles are equal

Aligning formulas using equals sign
LibreOffice Math does not have a command for aligning formulas on a particular character. 
However, you can use a matrix to align formulas on a character and this character is normally the 
equals sign (=).

Example
Creating the matrix:

matrix{ alignr x+y # {}={} # alignl 2 ## alignr x   # {}={} # alignl
2-y }

gives the following result where formulas are aligned on the equals sign x+ y = 2
x = 2− y

Note

The empty braces each side of the equals sign are necessary because the equals sign
is a binary operator and requires an expression on each side. You can use spaces, or `
or ~ characters each side of the equals sign, but braces are recommended as they are
easier to see within the markup language.

You can reduce the spacing on each side of the equals sign if you change the inter-column spacing
of the matrix. See “Adjusting formula spacing” on page 20 for more information.

Changing formula appearance

Formula font size

Current formula font size
To change the font size used for a formula already inserted in Math or another LibreOffice 
component:

 1) Click in the markup language in the Formula Editor.

 2) Go to Format > Font size on the Menu bar to open the Font Sizes dialog (Figure 7).

 3) Select a different font size using the Base size spinner or type a new font size in the Base 
size box.

 4) Click OK to save your changes and close the dialog. An example result when you change 
font size is shown below.

Example
Default font size 12pt: π ≃ 3.14159

After font size change to 18pt: π ≃ 3.14159
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Figure 7: Font Sizes dialog

Default formula font size
To change the default font size used for all formulas in Math or another LibreOffice component:

 1) Before inserting any formulas in your document, go to Format > Font size on the Menu bar
to open the Font Sizes dialog (Figure 7).

 2) Select a different font size using the Base size spinner or type a new font size in the Base 
size box.

 3) Click Default and confirm your changes to the base size font. Any formulas created from 
this point on will use the new base size font for formulas.

 4) Click OK to save your changes and close the Font Sizes dialog.

Note

If you have already inserted formulas into your document and you change the default 
font size, only formulas inserted after the change in default font size will use the new 
default settings. You have to individually change the font size of formulas already 
inserted if you want these formulas to use the same font size as the default settings.

Tip

There is an extension “Formatting of All Math Formulas” that allows you to change font
name and font size for all or only for selected formulas in your document. You can 
download it from the official extension site: 
https://extensions.libreoffice.org/extensions/formatting-of-all-math-formulas

Font size options
The Font Sizes dialog (Figure 7) specifies the font sizes for your formula. Select a base size and all
elements of the formula will be scaled in relation to this base.

• Base size – all elements of a formula are proportionally scaled to the base size. To change 
the base size, select or type in the desired point (pt) size. You can also use other units of 
measure or other metrics, which are then automatically converted to points. For example, if 
you enter 1in or 1”, Math converts the value to 72 pt.

• Relative Sizes – in this section, you can determine the relative sizes for each type of 
element with reference to the base size.

– Text – select the size for text in a formula relative to the base size.

– Indexes – select the relative size for the indexes in a formula in proportion to the base 
size.
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– Functions – select the relative size for names and other function elements in a formula 
in proportion to the base size.

– Operators – select the relative size of the mathematical operators in a formula in 
proportion to the base size.

– Limits – select the relative size for the limits in a formula in proportion to the base size.

• Default – clicking this button saves any changes as a default for all new formulas. A 
confirmation message appears before saving any changes.

Formula fonts

Current formula fonts
To change the fonts used for the current formula in Math or another LibreOffice component:

 1) Click in the markup language in the Formula Editor.

 2) Go to Format > Fonts on the Menu bar to open the Fonts dialog (Figure 8).

 3) Select a new font for each of the various options from the drop-down lists.

 4) If the font you want to use does not appear in the drop-down list, click Modify and select 
the option from the context menu to open a fonts dialog. Select the font you want to use 
and click OK to add it to the drop-down list for that option.

 5) Click OK to save your changes and close the Fonts dialog.

Figure 8: Fonts dialog

Default formula fonts
To change the default fonts used for all formulas in Math or another LibreOffice component:

 1) Before inserting any formulas in your document, go to Format > Fonts on the Menu bar to 
open the Fonts dialog (Figure 8).

 2) Select a new font for each of the various options from the drop-down lists.

 3) If the font you want to use does not appear in the drop-down list, click Modify and select 
the option from the context menu to open a fonts dialog. Select the font you want to use 
and click OK to add it to the drop-down list for that option.

 4) Click Default and confirm your changes to the fonts. Any formulas created from this point 
on will use the new font for formulas.

 5) Click OK to save your changes and close the Fonts dialog.
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Note

If you have already inserted formulas into your document and you change the default 
fonts, only formulas inserted after the change in default fonts will use the new default 
settings. You have to individually change the font of formulas already inserted if you 
want these formulas to use the same font as the default settings.

Formula font options
Defines the fonts that can be applied to formula elements.

• Formula Fonts – defines the fonts used for the variables, functions, numbers and inserted 
text that form the elements of a formula.

– Variables – selects the fonts for the variables in your formula. For example, in the 
formula x=SIN(y), x and y are variables and will reflect the assigned font.

– Functions – selects the fonts for names and properties of functions. For example, the 
functions in the formula x=SIN(y) are =SIN( ).

– Numbers – selects the fonts for the numbers in a formula.

– Text – defines the fonts for the text in a formula.

• Custom Fonts – in this section of the Fonts dialog (Figure 8), fonts are defined which 
format other text components in a formula. The three basic fonts Serif, Sans and Fixed are 
available. Other fonts can be added to each standard installed basic font using the Modify 
button. Every font installed on a computer system is available for use.

– Serif – specifies the font to be used for the font serif format. Serifs are the small 
"guides" that can be seen, for example, at the bottom of a capital A when the Times serif
font is used. Using serifs is quite helpful since it guides the eye of a reader in a straight 
line and can speed up reading.

– Sans-serif – specifies the font to be used for sans font formatting.

– Fixed-width – specifies the font to be used for fixed font formatting.

• Modify – click one of the options from the context menu to access the Fonts dialog, where 
the font and attributes can be defined for the respective formula and for custom fonts.

• Default – clicking this button saves any changes as a default for all new formulas. A 
confirmation message appears before saving any changes.

Note

When a new font is selected for a formula, the old font remains in the list alongside the
new one and can be selected again.

Note

Variables should be written in italics, so make sure that the Italic option is selected. For
the font you want to use. For all other elements, use the basic form of a font. The style 
can be easily altered in the formula itself by using the commands italic or bold to 
set these characteristics and nitalic or nbold to unset them.

Adjusting formula spacing
Use the Spacing dialog (Figure 9) to determine the spacing between formula elements. The 
spacing is specified as a percentage in relation to the defined base size for font sizes.
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Figure 9: Spacing dialog

Current formula spacing
To change the spacing used for the current formula in Math or another LibreOffice component:

 1) Click in the markup language in the Formula Editor.

 2) Go to Format > Spacing on the Menu bar to open the Spacing dialog (Figure 9).

 3) Click Category and select one of the options from the drop-down list. The options in the 
Spacing dialog change according to the category selected.

 4) Enter new values for the spacing category and click OK.

 5) Check the result in your formula. If not to your satisfaction, repeat the above steps.

Default formula spacing
To change the default spacing used for all formulas in Math or another LibreOffice component:

 1) Before inserting any formulas in your document, go to Format > Spacing on the Menu bar 
to open the Spacing dialog (Figure 9).

 2) Click Category and select one of the options from the drop-down list. The options in the 
Spacing dialog change according to the category selected.

 3) Enter new values for the spacing category.

 4) Click Default and confirm your changes to the formula spacing. Any formulas created from 
this point on will use the new spacing for formulas.

 5) Click OK to save your changes and close the Spacing dialog.

Note

If you have already inserted formulas into your document and you change the spacing,
only formulas inserted after the change in spacing will use the new default settings. 
You have to individually change the spacing of formulas already inserted if you want 
these formulas to use the same spacing as the default settings.

Spacing options
Use Category in the Spacing dialog (Figure 9) to determine the formula element for which you 
would like to specify the spacing. The appearance of the dialog depends on the selected category. 
A preview window shows you which spacing is modified through the respective boxes.

• Category – pressing this button allows you to select the category for which you would like 
to change the spacing.

• Spacing – defines the spacing between variables and operators, between lines, and 
between root signs and radicals.

– Spacing – determines the spacing between variables and operators.

– Line spacing – determines the spacing between lines.
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– Root spacing – determines the spacing between the root sign and radicals.

• Indexes – defines the spacing for superscript and subscript indexes.

– Superscript – determines the spacing for superscript indexes.

– Subscript – determines the spacing for subscript indexes.

• Fractions – defines the spacing between the fraction bar and the numerator or 
denominator.

– Numerator – determines the spacing between the fraction bar and the numerator.

– Denominator – determines the spacing between the fraction bar and the denominator.

• Fraction Bars – defines the excess length and line weight of the fraction bar.

– Excess length – determines the excess length of the fraction line.

– Weight – determines the weight of the fraction line.

• Limits – defines the spacing between the sum symbol and the limit conditions.

– Upper limit – determines the spacing between the sum symbol and the upper limit.

– Lower limit – determines the spacing between the sum symbol and the lower limit.

• Brackets – defines the spacing between brackets and the content.

– Excess size (left/right) – determines the vertical distance between the upper edge of the
contents and the upper end of the brackets.

– Spacing – determines the horizontal distance between the contents and the upper end 
of the brackets.

– Scale all brackets – scales all types of brackets. If you then enter ( a over b) in the 
Formula Editor, the brackets will surround the whole height of the argument. You 
normally achieve this effect by entering left ( a over b right ).

– Excess size – adjusts the percentage excess size. At 0% the brackets are set so that 
they surround the argument at the same height. The higher the entered value is, the 
larger the vertical gap between the contents of the brackets and the external border of 
the brackets. The field can only be used in combination with Scale all brackets.

• Matrices – defines the relative spacing for the elements in a matrix.

– Line spacing – determines the spacing between matrix elements in a row.

– Column spacing – determines the spacing between matrix elements in a column.

• Symbols – defines the spacing of symbols in relation to variables

– Primary height – defines the height of the symbols in relation to the baseline.

– Minimum spacing – determines the minimum distance between a symbol and variable.

• Operators – defines the spacing between operators and variables or numbers.

– Excess size – determines the height from the variable to the operator upper edge.

– Spacing – determines the horizontal distance between operators and variables.

• Borders – adds a border to a formula. This option is particularly useful if you want to 
integrate the formula into a text file in Writer. When making settings, make sure that you do 
not use 0 as a size as this creates viewing problems for text that surrounds the insertion 
point.

– Left – the left border is positioned between the formula and background.

– Right – the right border is positioned between the formula and background.

– Top – the top border is positioned between the formula and background.
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– Bottom – the bottom border is positioned between the formula and background.

• Preview Field – displays a preview of the current selection.

• Default – saves any changes as default settings for all new formulas. A confirmation dialog 
will appear before saving these changes.

Adjusting formula alignment
The alignment settings determine how formula elements located above one another are aligned 
horizontally relative to each other.

Note

It is not possible to align formulas on a particular character and formula alignment 
does not apply to text elements. Text elements are always aligned left.

Note

Independent of using formula alignment given below, it is possible to align formulas 
using the commands alignl, alignc and alignr. These commands also work for 
text elements.

Current formula alignment
To change the alignment used for the current formula in Math or another LibreOffice component:

 1) Click in the markup language in the Formula Editor.

 2) Go to Format > Alignment on the Menu bar to open the Alignment dialog (Figure 10).

 3) Select either Left, Centered, or Right for horizontal alignment.

 4) Click OK and check the result in your formula. If not to your satisfaction, repeat the above 
steps.

Figure 10: Alignment dialog

Default formula alignment
To change the default alignment used for all formulas in Math or another LibreOffice component:

 1) Before inserting any formulas in your document, go to Format > Alignment on the Menu 
bar to open the Alignment dialog (Figure 10).

 2) Select either Left, Centered, or Right for horizontal alignment.

 3) Click Default and confirm your changes to the formula alignment. Any formulas created 
from this point on will use the new alignment for formulas.

 4) Click OK and check the result in your formula. If not to your satisfaction, repeat the above 
steps.
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Note

If you have already inserted formulas into your document and you change the formula 
alignment, only formulas inserted after the change in alignment will use the new 
default settings. You have to individually change the alignment of formulas already 
inserted if you want these formulas to use the same alignment as the default settings.

Changing formula color

Character color
Formula color for the characters used in a formula is changed by using the command color in the 
mark up language. This command only works on the formula element immediately after the color 
name. For example, entering the markup language color red ABC 5 times 4 gives the result
ABC 5×4 .

To change the color of the whole formula, you have to enclose the whole formula within brackets. 
For example, entering the markup language color red {ABC 5 times 4} gives the result
ABC 5×4 .

For information on the colors available in Math, see Appendix A, Commands Reference, in the 
Math Guide.

Background color
It is not possible to select a background color for formulas in Math. The background color for a 
formula is by default the same color as the document or frame that the formula has been inserted 
into. However, in LibreOffice documents, you can use object properties to change the background 
color for a formula. For more information on using a background color (area fill for objects) with a 
formula, please refer to the user guides for Writer, Calc, Draw and Impress.

Formula library

If you regularly insert the same formulas into your documents, you can create a formula library 
using formulas that you have created using the Formula Editor. Individual formulas can be saved 
as separate files using the ODF format for formulas with the file suffix of .odf, or in MathML format 
with the file suffix of .mml.

You can use Math, Writer, Calc, Draw, or Impress to create formulas and build up your formula 
library.

Using Math
 1) Create a folder on your computer to contain your formulas and give the folder a memorable 

name, for example Formula Library.

 2) In LibreOffice, go to File > New > Formula on the Menu bar, or click on Math Formula in 
the opening splash screen to open Math and create your formula using the Formula Editor. 
See “Formulas as separate documents or files” on page 5 for more information.

 3) Go to File > Save As on the Menu bar or use the keyboard shortcut Ctrl+Shift+S to open a 
Save As dialog.

 4) Navigate to the folder you have created for your formula library.

 5) Type in a memorable name for your formula in the File name text box.

 6) Select from the File type drop-down list either ODF Formula (.odf) or MathML 2.0 (.mml) as 
the file type for your formula.

 7) Click Save to save your formula and close the Save As dialog.
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Using Writer, Calc, Draw, or Impress
 1) Create a folder on your computer to contain your formulas and give the folder a memorable 

name, for example Formula Library.

 2) Open a document using Writer, Calc, Draw, or Impress.

 3) Go to Insert > Object > Formula on the Menu bar to open the Formula Editor and create 
your formula. See “Formulas in LibreOffice documents” on page 6 for more information.

 4) Right-click on your formula object and select Save Copy as from the context menu to open 
a Save As dialog.

 5) Navigate to the folder you have created for your formula library.

 6) Type a memorable name for your formula in the File name text box.

 7) Select from the File type drop-down list either ODF Formula (.odf) or MathML 2.0 (.mml) as 
the file type for your formula.

 8) Click Save to save your formula and close the Save As dialog.

Using your formula library
You cannot insert a formula from your library into a document by dragging and dropping using the 
mouse, nor by using Insert > File on the Menu bar. You must insert a formula from your library into
your document as an OLE object.

 1) Open your document in Writer, Calc, Draw, or Impress.

 2) Go to Insert > Object > OLE Object on the Menu bar to open the Insert OLE Object 
dialog.

 3) Select the option Create from file.

 4) Click Search to open your file browser dialog.

 5) Navigate to the folder you have created for your formula library.

 6) Select the formula you want to insert and click Open, or double-click on the formula you 
want to insert.

 7) Click OK to insert your formula as an OLE object in your document and close the dialog.

Formulas in Writer

When a formula is inserted into a document, Writer inserts the formula into a frame and treats the 
formula as an OLE object. Double-clicking on an inserted formula will open the Formula Editor in 
Math allowing you to edit the formula.

This section explains what options you can change for each individual formula within a Writer 
document. Please refer to the chapters on styles in the Writer Guide for information on how to 
change the default settings for frame styles for OLE objects.

Automatic formula numbering
Automatic numbering of formulas for cross reference purposes can only be carried out in Writer. 
The easiest way to add numbered formulas in sequence is to use the AutoText entry fn (for 
'formula numbered').

 1) Start a new line in your document.

 2) Type fn and then press the F3 key. A two column table with no borders is inserted into your 
document with the left column containing a sample formula and the right column containing 
a reference number, as shown below. 

ABC 5×4 (1)
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 3) Delete the sample formula and insert your formula as an object in the left column.

 4) Alternatively, you can first insert your formula into the document, then carry out Steps 1 and
2 above replacing the sample formula with your formula.

Figure 11: Fields dialog – Cross-references tab

Cross referencing
 1) Click in your document where you want the cross reference to appear.

 2) Go to Insert > Cross-reference on the Menu bar to open the Fields dialog (Figure 11).

 3) Click on the Cross-references tab, then select Text in the Type section.

 4) In the Selection section, select the formula number you want to refer to. 

 5) In the Insert reference to section, select Reference and click Insert.

 6) When you have finished creating cross references, click Close to close the Fields dialog.

Tip

To insert the cross reference number without parentheses, select Numbering instead 
of Reference in the Insert reference to section.

Note

If you want to use square parentheses instead of round ones, or if you want the cross 
reference number to be separated from the formula by tabs instead of using a table, 
then refer to the chapter on automatic text in the Writer Guide.

26 | Formulas in Writer



Anchoring formulas
A formula is treated as an object within Writer and its default anchoring is To character within a 
paragraph when it is inserted into a document. To change the anchoring of a formula object:

 1) Right-click on the selected formula object and select Anchor from the context menu.

 2) Select a new anchoring option from the context sub-menu. The anchoring positions 
available are To Page, To Paragraph, To Character, or As Character.

Figure 12: Object dialog – Type tab with Anchor options

 3) Alternatively, right-click on the selected formula object and select Properties from the 
context menu, or go to Format > Frame and Object > Properties on the Menu bar to open
the Object dialog (Figure 12).

 4) Make sure the Type tab is selected and select a new anchoring position from the Anchor 
section.

 5) Click OK to save your changes and close the Object dialog.

Note

The anchoring options are not available in the Object dialog when you are making 
changes to the various options available for frame styles. For more information on how
to modify frame styles, please refer to the chapters on styles in the Writer Guide.

Vertical alignment
The normal default setting for vertical alignment for formula objects is to use the text base line as a
reference. This default setting can be changed by modifying the Formula frame style, see the 
chapters on styles in the Writer Guide for more information.

To change the vertical alignment position of an individual formula object (assuming that the As 
character anchoring option is selected):

 1) Right-click on the selected formula object and select Properties from the context menu, or 
go to Format > Frame and Object > Properties to open the Object dialog (Figure 12).
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 2) Make sure the Type tab is selected and select a new alignment position from the drop-down
list in the Position section. The vertical alignment options available are Top, Bottom, 
Center, or From bottom.

 3) If necessary, type in the text box a plus or minus value for vertical alignment. This option is 
only available if From bottom vertical alignment has been selected.

 4) Select the type of text alignment from the drop-down list in the Position section. The text 
alignment options available are Base line, Character, and Row.

 5) Click OK to save your changes and close the Object dialog.

Note

If the Position section in the Object dialog is greyed out and not available, then go to 
Tools > Options > LibreOffice Writer > Formatting Aids and uncheck the option 
Math baseline alignment. This setting is stored with the document and applies to all 
formulas within it. Any new documents created will also use this setting.

Object spacing
A formula object, when inserted into a Writer document, has spacing each side of the formula 
object. The default value used for spacing is set within the frame style for formula objects and can 
be changed by modifying the Formula frame style, see the chapters on styles in the Writer Guide 
for more information.

You can individually adjust the spacing for each formula object within your document as follows:

 1) Create your formula in your Writer document.

 2) Right-click on your selected formula object and select Properties from the context menu, or
go to Format > Frame and Object > Properties on the Menu bar to open the Object 
dialog.

 3) Click on the Wrap tab to open the Wrap page in the Object dialog (Figure 13).

 4) In the Spacing section, enter the spacing value for Left, Right, Top and Bottom spacing.

 5) Click OK to save your changes and close the Object dialog.

Figure 13: Object dialog – Wrap tab

28 | Formulas in Writer



Text mode
In large formulas placed within a line of text, the formula elements can often be higher than the text
height. Therefore, to make large formulas easier to read, it is recommended to always insert a 
large formula into a separate paragraph of its own so that it is separated from text.

However, if it is necessary to place a large formula within a line of text, double-click on the formula 
to open the Formula Editor and then go to Format > Text Mode on the Menu bar. The Formula 
Editor will try to shrink the formula to fit the text height. The numerators and denominators of 
fractions are shrunk, and the limits of integrals and sums are placed beside the integral/sum sign, 
as shown in the following example.

Example
A formula in a separate paragraph:

∑
i=2

5

i2

and the same formula embedded into a line of text using text mode format: ∑i=2
5 i2

Background and borders
The default setting for background (area fill) and borders for formula objects is set by the formula 
frame style. To change this default setting for formula frame style, refer to the chapters on styles in 
the Writer Guide. However, for individual formulas in your document, you can change the 
background and borders.

Note

The size of the frame that a formula is placed in when inserted into a document cannot
be changed. The frame size for a formula object depends on the setting of the formula 
font size; see “Creating formulas” on page 7 and “Editing formulas” on page 11 for 
more information.

Backgrounds

 1) In your document, select the formula where you want to change the background.

 2) Right-click on the formula and select Properties from the context menu, or go to Format > 
Frame and Object > Properties on the Menu bar to open the Object dialog.

 3) Click on the Area tab and use the buttons to select the type of fill you want to use for your 
formula (Figure 14).

 4) Select the options you want to use for your formula background. The options change 
depending on the type of fill selected.

 5) Click OK to save your changes and close the Object dialog.

Borders

 1) In your document, select the formula where you want to change the borders.

 2) Right-click on the formula and select Properties from the context menu, or go to Format > 
Frame and Object > Properties on the Menu bar to open the Object dialog.

 3) Click on the Borders tab and select the options you want to use for your formula borders 
(Figure 15).

 4) Click OK to save your changes and close the Object dialog.
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Figure 14: Object dialog – Area tab

Figure 15: Object dialog – Borders tab
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Quick insertion of formulas
You can quickly insert a formula into your Writer document without opening the Formula Editor, if 
you know the markup language for the formula:

 1) Type the formula markup language into your document at the position where you want the 
formula.

 2) Select the markup language.

 3) Go to Insert > Object on the Menu bar and select Formula to create a formula from the 
selected markup language.

Formulas in Calc, Draw, and Impress

In Calc, Draw, and Impress, formulas are inserted as OLE objects without any background (area 
fill) or borders. Each formula object is inserted into a spreadsheet, drawing, or slide as follows:

• In Calc, formulas are inserted into a selected cell in a spreadsheet with no style assigned to
the formula object.

• In Draw and Impress, formulas are inserted into a central position on your drawing or slide 
and, by default, are assigned the drawing object style Object with no fill and no line. For 
more information on how to modify or assign drawing object styles, see the Draw Guide or 
the Impress Guide.

Anchoring formulas

Calc
A formula object can be anchored into your spreadsheet as To Page (default setting), or as To 
Cell. To change the anchoring type of formulas in a Calc spreadsheet:

 1) Select the formula object in your spreadsheet.

 2) Right-click on the formula and select Anchor > To Page or To Cell from the context menu

 3) Alternatively, go to Format > Anchor on the Menu bar and select To Page or To Cell.

Draw and Impress
When a formula is inserted into a drawing or slide, it is inserted as a floating OLE object and is not 
anchored to any particular position in a drawing or slide.

Formula object properties
Formula objects in Calc, Draw, and Impress can be modified just like any other object that has 
been placed in your spreadsheet, drawing, or presentation, with the exception of formula object 
size and changing the format of any text within a formula. For more information on how to change 
object properties, see the Calc Guide, Draw Guide and Impress Guide.

The following points will help you select which dialog to use if you want to change the properties of 
formula objects.

• For formula backgrounds, use the various options in the tabs of the Area dialog.

• For formula borders, use the various options in the Line dialog. Note that formula borders 
are separate from cell borders in a Calc spreadsheet.

• To accurately re-position a formula object, use the various options in tabs of the Position 
and Size dialog.

• In Draw and Impress, you can arrange, align, group, flip, convert, break, combine, and edit 
points of formula objects.
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• You cannot change the text attributes of a formula object. The text used in a formula is set 
when you create the formula in the Formula Editor.

• Formula object size is set by the formula font size when the formula is created in the 
Formula Editor. The formula object size is protected in the Position and Size dialog, but this
can be deselected if you wish. However, this is not recommended as resizing a formula 
object using the Position and Size dialog could lead to distortion of a formula making it 
difficult to read.

Formulas in charts
A chart in a Calc spreadsheet is itself an OLE object, therefore, you cannot use the Formula Editor 
to create and insert a formula into a chart.

To insert a formula into a chart, create the formula first using the Formula Editor and copy the 
formula to the clipboard. You then create your chart in Calc and paste the formula into your chart. 
The formula is automatically converted into the correct format for insertion into the chart.

If you want to change the formula at a later date, then you must repeat the whole process of 
creating, copying, and pasting.

Customization

This section explains how you can customize Math to suit the way you create formulas for use in 
LibreOffice documents. Also, refer to Chapter 14, Customizing LibreOffice, of this Guide for more 
general information on how to customize LibreOffice.

Chemical formulas
The primary purpose of Math is to create mathematical formulas, but it can also be used to write 
chemical formulas. However, in chemical formulas, the chemical symbols are normally written in 
uppercase using non-italic characters. The following table shows some examples of chemical 
formulas.

Construction Example Markup Language

Molecules H 2SO4
H_2 SO_4

Isotopes U92
238 U lsub 92 lsup 238

Ions SO4
2− or SO4

2 - SO_4^{2-{}} or SO_4^{2"-"}

To create chemical formulas using Math, you have to change the font used for variables to a non-
italic font. For more information , see “Formula fonts” on page 19.

For reversible reactions in chemical formulas, there is no symbol you can use for a double arrow in
Math. If you have a font available with correct symbols for use in chemical formulas, then you can 
add these symbols to the Catalog. See “Catalog customization” on page 33 for more information 
on how to add symbols to the Catalog.

Floating dialogs
The Formula Editor and Elements dock can cover a large part of your document. To help create 
more space and/or allow you to move either the Formula Editor or Elements dock out of the way, 
you can turn both of them into floating dialogs.

 1) Position the cursor on the frame.

 2) Hold down the Ctrl key and double-click. This turns the Formula Editor into the Commands 
dialog (Figure 16) and the Elements dock into the Elements dialog (Figure 17).
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Figure 16: Commands dialog

Figure 17: Elements dialog

To return the Commands dialog and Elements dialog back to their default positions:

 1) Position the cursor on the frame of the dialog, NOT the title bar at the top of the dialog.

 2) Hold down the Ctrl key and double-click.

Adding keyboard shortcuts
You can add keyboard shortcuts to LibreOffice to make creating documents much easier and to 
match your workflow. See Chapter 14, Customizing LibreOffice, for instructions.

Catalog customization
If you regularly use a symbol that is not available in Math, you can add it to the Symbols dialog 
(Figure 18) by opening the Edit Symbols dialog (Figure 19).

Using the Edit Symbols dialog you can add symbols to a symbol set, edit symbol sets, or modify 
symbol notations. You can also define new symbol sets, assign names to symbols, or modify 
existing symbol sets.

Adding symbols
 1) Go to Tools > Symbols on the Menu bar or click on the Symbols icon in the Tools toolbar 

to open the Symbols dialog.

 2) Click the Edit button to open the Edit Symbols dialog.

 3) Select a font from the Font drop-down list.

 4) Select a symbol character that you want to add from the preview box. You may have to 
scroll down in the preview box to locate the symbol you want to use. The small right 
preview box displays the new symbol.

 5) In the Symbol box, type a memorable name for the symbol you are adding.

 6) In the Symbol set box, select a symbol set from the drop-down list to add your new symbol 
to, or type a new name to create a new symbol set for your new symbol.

 7) If required, select a font style from the Style drop-down list – Standard, Italic, Bold, or 
Bold, Italic.
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 8) Click Add, then click OK to close the Edit Symbols dialog. The new symbol and, if created, 
new symbol set are now available for use.

Figure 18: Symbols dialog

Figure 19: The Edit Symbols dialog
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Note

When a new symbol is added to the catalog, you can type a percentage sign (%) 
followed by the new name into the markup language in the Formula Editor and your 
new symbol will appear in your formula. Remember that symbol names are case 
sensitive, for example, %prime is a different symbol to %Prime.

Note

Numerous free fonts are available that contain several symbols if you cannot find a 
symbol to use in the fonts already installed on your computer. For example, the STIX 
font was developed specially for writing mathematical and technical texts. Also, the 
DejaVu and Lucida fonts have a wide range of symbols that you can use.

Note

When LibreOffice is installed on a computer, only those user-defined symbols that 
actually occur in the document are stored with it. Sometimes it is useful to embed all 
the user-defined symbols, so that when the document is transferred to another 
computer it can be edited by another person. Go to Tools > Options > LibreOffice 
Math > Settings, uncheck the option Embed only used symbols (smaller file 
size).This setting is only available when you are working with LibreOffice Math.

Editing symbols

Modifying symbol names
You can change the name of a symbol as follows:

 1) Select the symbol name you want to change from the Old symbol drop-down list. The 
symbol appears in the left preview pane at the bottom of the Edit Symbols dialog (Figure
19).

 2) Type a new name for the symbol in the Symbol text box, or select a new name from the 
Symbol drop-down list. The new symbol name appears above the right preview pane at the 
bottom of the Edit Symbols dialog.

 3) Click Modify and the symbol name is changed.

 4) Click OK to close the Edit Symbols dialog.

Moving symbols
You can move a symbol from one symbol set to another as follows:

 1) In the Old symbol set drop-down list, select the symbol set where the symbol you want to 
move is located.

 2) Select the symbol name you want move from the Old symbol drop-down list. The symbol 
appears in the left preview pane at the bottom of the Edit Symbols dialog (Figure 19).

 3) In the Symbol set drop-down list, select the symbol set that you want to move the symbol 
to. The new symbol set name appears below the right preview pane at the bottom of the 
Edit Symbols dialog.

 4) Click Modify and the symbol is moved to the new symbol set.

 5) Click OK to close the Edit Symbols dialog.
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Deleting symbols
You can delete a symbol from a symbol set as follows:

 1) In the Old symbol set drop-down list, select the symbol set from which you want to delete 
the symbol.

 2) Select the symbol name you want delete from the Old symbol drop-down list. The symbol 
appears in the left preview pane at the bottom of the Edit Symbols dialog (Figure 19).

 3) Click Delete and the symbol is deleted from the symbol set without any confirmation.

 4) Click OK to close the Edit Symbols dialog.

Note

The only way you can delete a symbol set is by deleting all of the symbols in that set. 
When you delete the last symbol from a set, the set is also deleted.

Options for editing symbols
• Old symbol – select the name of the current symbol. The symbol, the name of the symbol, 

and the set that the symbol belongs to are displayed in the left preview pane at the bottom 
of the Edit Symbols dialog.

• Old symbol set – this list box contains the name of the current symbol set. You can also 
select a different symbol set using this list box.

• Symbol – lists the names for the symbols in the current symbol set. Select a name from the 
list or type a name for a newly added symbol.

• Symbol set – this list box contains the names of all existing symbol sets. You can modify a 
symbol set or create a new one.

• Font – displays the name of the current font and enables you to select a different font.

• Subset – if you selected a non-symbol font in the Font list box, you can select a Unicode 
subset in which to place your new or edited symbol. When a subset has been selected, all 
symbols belonging to this subset of the current symbol set are displayed in the Symbol list.

• Style – the current style of font is displayed. You can change the font style by selecting one 
from the list box.

• Add – click this button to add the symbol shown in the right preview window to the current 
symbol set. It will be saved under the name displayed in the Symbol list. You must specify a
name under Symbol or Symbol set to be able to use the Add button. Names cannot be 
used more than once.

• Modify – click this button to replace the name of the symbol shown in the left preview 
window (the old name is displayed in the Old symbol list) with the new name you have 
entered in the Symbol list.

• Delete – click this button to remove the symbol shown in the left preview window from the 
current symbol set. There will be confirmation of deletion. Deleting the last remaining 
symbol of a symbol set also deletes the symbol set.

• Cancel – click this button at any time to close the dialog without saving any of the changes.

Formula spacing
The grave accent (`) inserts an additional small space and the tilde (~) inserts an additional large 
space into formulas. However, in the basic installation of LibreOffice, these symbols are ignored 
when they occur at the end of a formula. If you are working with running text in a formula, it may be
necessary to include spacing at the end of formulas as well. This customization is only required 
when you are working with a Math document and is not required when you are inserting a formula 
into another LibreOffice component.
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To add spacing at the end of formula in Math, go to Tools > Options > LibreOffice Math > 
Settings on the Menu bar and uncheck Ignore ~ and ` at the end of the line in the Miscellaneous
Options section.

Extensions
If you create formulas frequently in your documents, you can customize LibreOffice by adding 
extensions that are designed to help you create formulas. Extensions are easily installed using the 
Extension Manager. For more information on how to install extensions, see Chapter 14 of the 
Getting Started Guide.

One extension that is recommended for installation is Dmaths. This extension is designed for use 
in Writer and adds a mathematical macro package providing five toolbars for creating formulas. For
more information on this extension, go to the website http://www.dmaths.org.

A second extension that is recommended is Formatting of All Math Formulas. It allows you to 
format all Math formulas in your Writer, Calc, Draw, or Impress document. You can change font and
font size for all formulas or only for selected formulas. For more information on this extension, go to
https://extensions.libreoffice.org/extensions/formatting-of-all-math-formulas.

Exporting and Importing

Math ML format
In addition to exporting documents as PDFs, LibreOffice offers the possibility of saving formulas in 
the MathML format. This allows you or another person to insert formulas into documents that were 
created in other software, for example, Microsoft Office or an internet browser.

Note

Some internet browsers do not fully support the MathML format and your formula may 
not display correctly.

If you are working on a Math document, go to File > Save as on the Menu bar or use the keyboard
combination Ctrl+Shift+S to open the Save as dialog. Select MathML from the list of available file 
formats to save your formula as MathML.

If you are working in another LibreOffice component, right-click on the formula object and select 
Save copy as from the context menu to open the Save as dialog. Select MathML from the list of 
available file formats to save the formula object as MathML.

In Math you can also import a MathML formula. Use Tools > Import MathML from Clipboard.

Microsoft file formats
To control how formulas in Microsoft format are imported and exported using LibreOffice, go to 
Tools > Options > Load/Save > Microsoft Office on the Menu bar and select or deselect the 
options for MathType to LibreOffice Math or reverse.

• [L]: Load and convert the object

• [S]: Convert and save the object

[L]: Load and convert the object
Select this option if Microsoft OLE objects are to be converted into the specified LibreOffice OLE 
object when a Microsoft document is opened in LibreOffice. For formulas, any embedded 
MathType objects must not exceed the MathType 3.1 specifications to be successfully loaded and 
converted. Information on MathType format can be found on the website http://www.dessci.com/en.
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If a document containing OMML formulas has been saved in .docx format and then converted to 
the older .doc format, then any OMML objects are converted into graphics, which will be displayed 
in LibreOffice as graphics.

[S]: Convert and save the object
Select this option if LibreOffice OLE objects are to be converted and saved in Microsoft file format. 
LibreOffice converts any formulas into a format that can be read and modified by Microsoft 
Equation Editor and MathType.

When this option is not selected, the formula is treated as an OLE object on conversion into a .doc 
format and remains linked to LibreOffice. A double-click on the object in Microsoft Office will 
attempt to launch LibreOffice.
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