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Introduction

This chapter covers the use of interactive forms within Writer documents. A form has sections that
are not to be edited, and other sections that are designed for the reader to make changes. For
example, a questionnaire has an introduction and questions (which do not change) and spaces for
the reader to enter answers.

Writer provides several ways to enter information into a form, including check boxes, option
buttons, text boxes, pull-down lists, and other items, collectively known as form controls.

LibreOffice forms include a lot of features; not everything is described here. Notable omissions are
using forms in HTML documents and writing macros to link to form controls.

LibreOffice Calc, Impress, and Draw also support forms in much the same way that Writer does.

When to use forms

Forms are used in three ways:

» To create a simple document for the recipient to complete, such as a questionnaire sent out
to a group of people who fill it in and return it.

* To link into a database or data source and allow the user to enter information. Someone in
a sales department might enter purchasers’ information into a database using a form.

* To view information held in a database or data source. A librarian might call up information
about books.

Using forms to access a database offers a fast and easy way to build complex graphical front ends.
Your form can include not only the fields that link to the data source, but also text, graphics, tables,
drawings and other elements.

A typical way to use a simple form is:
1) You design the form, then save it.
2) You send the form to others (for example, by email).
3) They fill in the form, save it, and send it back to you.
4) You open the form and see what their answers are.

‘:@:‘ Tip

By using a data source, or setting a form to update over the web, you can gather data
automatically. However, those methods are more complex and are not covered in this
book.

Alternatives to using forms in Writer

LibreOffice Base provides an alternative way to access a data source. There are a lot of similarities
between forms in Base and Writer, but one may be better for a particular task than the other. Base
is appropriate only if the form accesses a data source; you would not use it for simple forms.

Creating a simple form

This section explains how to create a simple form without any links to a data source or database
and without advanced customization.
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Create a document

There is nothing special to be done when creating a document to use as a form, though it's a good
idea to make sure that the grid is enabled (View > Grid and Helplines) so that controls can be
positioned accurately.

Create a new Writer document with File > New > Text document.

Open the form toolbars

Two toolbars control form creation: Form Controls and Form Design. Select View > Toolbars >
Form Controls and View > Toolbars > Form Design to show them both. The Form Controls
toolbar has an icon for each of the most commonly used types of control.

You can also open the Form Design toolbar from the Form Controls toolbar. Some of the less
commonly used controls are on a third toolbar (More Controls) also opened from the Form Controls
toolbar.

‘:Q:‘ Tip

Many of these controls are also located on the Form menu.

You can dock these toolbars in different places on the Writer window, or leave them floating. Figure
1 shows the three toolbars floating. When they are floating, you can also change them from vertical
to horizontal and change the number of tools on a row; to make these changes, drag a corner of
the toolbar.

See “Form controls reference” on page 7 for descriptions of the tools on these toolbars.

Form Controls - X

% (&) B o]

@ 7 = an|E iR 1B
More Contrclsv/x F% ¥ X
il R@mO Y oy BEG &40
3 & M Em OE- B 32O

Figure 1: The Form Control, More Controls, and Form Design Toolbars

Activate desigh mode

Click the Desigh Mode On/Off icon on the Form Controls toolbar to turn design mode on. (Click it
again to turn it off.) This activates or deactivates the icons for inserting form controls and selects
controls for editing.

When design mode is off, the form behaves as it would for the end user. Buttons can be pressed,
check boxes selected, list items selected, and so on.

Insert form controls

1) Toinsert a form control into the document, click the control’'s icon to select it. The mouse
|

pointer changes to look like this: ' ©

2) Click in the document where you want the control to appear. (You can move it later.)
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3) Hold the left mouse button down and drag the control to size it. Some controls have a fixed
size symbol followed by the name of the control (for example, Check Box or Option Button).

4) The control icon remains active, so you can insert several controls of the same type without
needing to go back to the toolbar.

5) To change to another tool, click its icon on the toolbar.

6) To stop inserting controls, click the Select icon on the Form Controls toolbar, or click any of
the controls you have just inserted. The mouse pointer changes back to its normal
appearance.

‘:@:‘ Tip

To make a form control square, hold down the Shift key when creating it. To keep the
proportions of an existing control the same, hold down Shift when resizing it.

Configure controls

After inserting the controls, you need to configure them to look and behave as you want. Right-click
a form control within the document and select Control from the context menu to open the
Properties dialog for the selected control. Double-clicking on a form control also opens this dialog.

The Properties dialog has three pages: General, Data, and Events. For simple forms, only the
General page is needed. Use this page to set the look and feel of the control. See “Configure form
controls” on page 11 and “Form control formatting options” on page 21 for more information, and
the descriptions in the Help for details. Configuration for use with a database is discussed in “Click
OK to exit the Registered databases dialog.” on page 17.

¢ @ @ Properties: Option Button
(General Data Events

| NamMe...coccceeeccme e Option Button 1

| Label ..o Option Button =
Label Field.....................
Group Name........cceeeenns
S5 LH ] N —— Yes |~ |
VISIDIE coevceecveeeee e Yes =
Printa e Yes | < |
Tabstop.. e, Yes [ < |
Tab Order.......c.oeveeeeren. 0 B
Default status................ MNot Selected | < |
£00 1 Poreeerooooonooooooeoooonos As Character [ < |

Figure 2: Example of the Properties dialog for a form control
The fields on this dialog vary with the type of control.
To see additional fields, use the scroll bar or enlarge the dialog.

Use the form

To use the form, leave design mode by clicking the Design Mode On/Off icon to deactivate it.
Save the form document.
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Form controls reference

The icons you see in Writer may differ from the ones shown here.

Form Control toolbar

Ly

I@I

#

5 |

B @ E

B [E

®

I
4 |+

= i
WAL

il

Select

Design mode on/off

Control

Form

Check Box

Text Box

Formatted Field

Push Button

Option Button

List Box

Combo Box

Label Field

More Controls

Form Design

Wizards On/Off

Selects a form control to perform some other action on it.

Toggles between design mode on (to edit forms) and design mode off
(to use forms).

Launches form control properties dialog. This dialog can be kept open
as different controls are selected.

Launches form properties dialog, controlling properties for the form as
a whole, such as which data source it connects to.

A box that can be selected or deselected on the form. You can label
the box.

A control to create a box into which the form’s user can type any text.

A control allowing numeric formatting options. For example, you can
set maximum and minimum values for the number entered, or the
number type (decimal places, scientific, currency).

Creates a button that can be linked to a macro. The label is the name
that appears on the button.

Creates an option button (also known as a radio button). When
multiple buttons are grouped together, only one can be selected at a
time. The easiest way to group multiple buttons is to use the Group
Box icon on the More Controls toolbar, with wizards enabled.

Creates a list of options as a pull-down menu that the user can
choose from. If the form is linked to a data source and wizards are on,
creating a list box launches the List Box Wizard.

If the form is not linked to a data source, turn wizards off and create
an empty list box. Then in the List Entries field on the General tab,
enter the options you want to appear on the list.

As with a List Box, you set up a list of choices. In addition, a panel at
the top either displays the choice made or allows the form user to type
in something else. This works the same as the List Box.

Atext label. The difference between this and just typing on the page is
that, as a control, you can link a label field to macros so, for example,
something happens when the mouse passes over it or clicks on it.

Launches the More Controls toolbar.

Launches the Form Design toolbar, which can also be opened with
View > Toolbars > Form Design.

Some form controls (List Box and Combo Box) have optional wizards.
If you do not want the wizard to launch when you create one of these
controls, use the Wizards On/Off icon to switch wizards off.
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More Controls toolbar

&

Spin Button

Allows form users to choose a number by cycling through the list of
numbers. You can specify maximum, minimum, default, and the step
between numbers.

This control is not commonly used in Writer.

E Scrollbar

Creates a scrollbar, with a number of options to define the exact
appearance. This control is not commonly used in Writer.

Image Button

Behaves exactly like a push button, but displays as an image. Choose
the image in the Graphics option on the General tab in the Control
Properties dialog.

Image Control

Only useful when the form is connected to a data source and a field in
the data source exists that can hold images. You can add new images
to the database or retrieve and display images from it.

Date Field

Stores a date. You need to configure the earliest and latest dates the
field will accept, the default date, and the date format. You can add a
spinner.

) Time Field

Works like a date field but specifies a time.

File Selection

Allows a user to select a file, either by typing the path and name
directly or by clicking on a Browse button and choosing the file from a
dialog.

123 Numeric Field

Displays a number. You need to specify formatting, maximum,
minimum and default values. You can add a spinner.

Currency Field

Works like a numeric field; additionally you can add a currency
symbol.

Pattern Field

Useful when the form links into a data source. Specify an Edit Mask to
restrict what a user can enter into the field. Specify a Literal Mask to
restrict which data is displayed from the data source.

Group Box

Group boxes have two different uses.

If wizards are on, creating a group box launches the Group Element
wizard. This creates a group of options buttons (in which only one
may be selected at a time). In most cases, using a group box is the
best way to create a set of option buttons.

If wizards are off, a group box is simply a visual box to group together
different controls. It has no effect on the way the controls operate.

Table Control

Table controls are only useful with a data source. If no data source is
specified, you will be prompted to choose one in the Table Element
Wizard. You then pick the fields to display and, when design mode is
off, the data appears in the table. The table also includes controls to
step through the records.

Records can be added, deleted, and modified in the table.

'EI Navigation Bar

A navigation bar is the same as the Form Navigation toolbar (View >
Toolbars > Form Navigation), but can be placed anywhere in the
document and be resized.
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Form Design toolbar

[:Ig Select Selects a form control to perform an action on it.

* Design mode on/off Toggles between design mode on (to edit forms) and design mode off
(to use forms).
Launches form control properties dialog. This dialog can be kept

2, Control ; .
open whiles different controls are selected.

N Form Launches form properties dialog, which controls properties for the

form as a whole, such as which data source it connects to.

Displays all the forms and controls in the current document and
allows you to edit and delete them easily.

If you use the Form Navigator, give your controls names (in the
properties dialog) you can tell which is which in the navigator.

i Form Navigator

Useful only if you have specified a data source for the form.

Otherwise, an empty box opens.

If you have specified a data source, Add Field opens a list of all the
= Add Field fields in the specified table, which you can then drag and drop onto

the page. The fields are placed on the page with the name of the field

before them.

This is a quick and easy way to create a form from a data source.

Allows you to specify the order in which focus shifts between
% Activation Order controls. You can test the order by leaving design mode and using
Tab to switch between the controls.

Opens the current form in design mode (to edit the form rather than

=) Open in Design Mode entering data into it).

L égé?ga“c Control If activated, focus is set to the first form control.
Launches the Position and Size dialog, where you can type precise
O Position and Size values, rather than dragging the control. You can also lock the size or

position, so they do not get changed accidentally. For some controls,
you can rotate and set the slant and corner radius.

Just as with a frame, any form control can be anchored to page,
& - Change Anchor paragraph, or character and also anchored as a character (meaning
that it behaves like any other character on the page).

Disabled unless the control is anchored as a character. You can align
a control in different ways, for example so the top of the control lines
up with the top of the text or the bottom lines up with the bottom of
the text.

|5 - Alignment

i Display Grid Displays a grid of dots on the page, to help you line up controls.

When a control is brought close to a grid point or line, it will snap to

g .
Snap to Grid the grid. This makes it is easier to line up controls.

When a control is being moved, lines extend from the control

= i i ) . o
s Guides when Moving horizontally and vertically to help you position it accurately.
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Example: a simple form

Create the document

Open a new document (File > New > Text Document). It is a good idea to sketch the final result to
use as a guide when designing the form, although it can easily be changed later.

Favorite shape questionnaire

Thank you for agreeing to take part in this questionnaire.
Please complete the form to say what your favorite shapes are.

Name:
Gender:
Favorite shape:

All shapes you like:

Figure 3: Initial document without form controls

Add form controls
The next step is to add the form controls to the document. We will have four controls:
* Name is a text box.
* Gender is three option buttons: male, female, or other; user can select one.
* Favorite shape is a list of options.
* All shapes you like is a series of check boxes.
To add these controls:
1) Select View > Toolbars > Form Controls to open the Form Control toolbar.

2) If the tools are not active, click the Design Mode On/Off icon to activate them.

3) Click the Text Box icon, then click in the document and drag the shape of the Name text
box to approximately the size you want. Drag it to line up with the Name: label.

4) Make sure Wizards On/Off is off. Click the Option Button icon. Click and drag to create
three option buttons near the Gender: label in the document. We will configure these in the
next section.

5) Click the List Box icon and draw a list box by Favourite Shape: in the document. This will
just be an empty pane for now.

6) Click the Check Box icon and create four check boxes by All shapes you like, side by side
across the page.

Your document should now look something like Figure 4.
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Favorite shape questionnaireq
Thank you for agreeing to take part in this questionnaire. « More Controls v %
Please complete the form to say what your favorite shapes are.§ EERBEO
Name: 1] @ 13 &9 LU D M
Gender:q - Male
" Female
1 " QOther Form Controls v
Q |”_ | | [EEL [%F [om

Favorite shape: il S

- @ [ = An 90| &y
All shapes you like: Check Box Check Box 2  Check Box 3 Check Box 4 9

Figure 4: Document with form controls

Configure form controls
No further configuration is required for the Name field.

For the option buttons, do this:

1) Be sure design mode is on. Right-click the first option button and click Control on the
context menu. In the Properties dialog (Figure 5), on the General tab, type Male in the
Label field and Gender in the Group name field.

2) Repeat for the other two options, using Female and Other, respectively, for the Label and

Gender for the Group name. (Grouping options allows only one to be selected at a time.)

. Properties: Option Button
| General Data Events

= reeroossnoonrerooooooooo Option Button 1
Label....ooooveiiieiiiiiiieens Male
Label Field.....................
Group Name.........ceeeeues Gender
[E 115 LN ] Fen—— Yes
Visible.. ... Yes

1 Printable...........coceenes Yes
Tabstop....ccccvieiiciee, Yes
Tab order.........cccecemeeenn. 0

Default status................ Mot Selected

ANCRON e As Character

Lol

-
-
st

<
<)

Figure 5: Specifying label and group names for an option button

To add the list of choices to the the list box, do this:

1) Be sure Design Mode is on and Wizards are off. Double-click the List Box control to open
the control’'s Properties dialog (Figure 6). Select the General tab.
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2) Scroll down to find the List Entries text input box. Type the names of the shapes (Circle,
Triangle, Square, Pentagon) one at a time. After each, press Shift+Enter. You should end
up with a line saying "Circle";"Triangle";"Square";"Pentagon".

Properties: List Box =
General |Da13 Events
[ 11 =P List Box 1 [ﬁ]
Label Field...vvvorrenean, ol
Enabled.........coovvvnen, |"I'ES M
Wisible, v, |"I'ES M
Read-only. oo, |N'I' M
Printable........cooovien, |"I'ES M =
Tab stop...oocvveiien, |"I'ES M
Tab order.vviieininens a {ﬁ E]
Mouse wheel scroll......... |NE"-"EF BI
ANCHOT 2 ccvearinee IT':- Paragraph M
POSHONY . v eee v evenerarenens &, 249cm {ﬁ B
POSHONY . veeevnererenens 5.04cm {ﬁ
Width oo, 9. 16cm ksl
[ (=110 ] P 4.87cm {ﬁ
Ietemnese "Cirde”;"Square"; "Triangle "; "Pentagon” E]
FOME st erereserserarsesssnes albany, Regular, 12 _]
Alignment......ocovvin ||-Ef't M |1|

Figure 6: Properties dialog for a list box

To give the check boxes names (instead of Check Box, Check Box 2, and so forth):

1) Double-click the first Check Box. The Properties dialog stays open but changes to show the
properties for the check box.

2) Change the text in the Label field to Circle and press Enter. The cursor moves to the next
line, and the label on the check box in the document changes immediately.

Properties: Check Box £
General |DEE Events
TJEME  evvvaersrnrenrenrenns Chedk Box 3 [ﬁ]
Label...ooviiiiiniiniinns Cirdle E]
Label Figld....v..coon.. o
Enabled...........coveee |‘I'ES M
ViSBIE. . vvveeeer e, Yes v

Figure 7: Top part of Properties dialog for a check box
3) Click each of the other three check boxes in turn. Change the text in the Label text input
box in the Properties dialog to Triangle, Square, and Pentagon in turn.
4) Close the Properties dialog.
5) Turn design mode off and close the two Controls toolbars.
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You have now completed the form, which should look something like Figure 8.

Favorite shape questionnaire

Thank you for agreeing to take part in this questionnaire.
Please complete the form to say what your favorite shapes are.

Name:
Gender: Male
Female
* Other

Favorite shape: |

Circle
All shapes you ]Triangle Jare v Pentagon

Square
Pentagon

Figure 8: Completed form

Finishing touches

The form is complete, but you are free to make further changes to the document. If you plan to
send this out to other people to complete, you probably want to make the document read-only so
that users would be able to fill in the form but not make any other changes to the document.

To make the document read-only, select File > Properties, select the Security tab and enable
Open file read-only.

Z Note

If the document is read-only, anyone filling in the form will need to use File > Save as
to save the document.

Accessing data sources

The most common use for a form is to input information into a database. For example, you can
design a form that others can use to enter information into a contacts database. Because it is part
of a Writer document, the form can contain graphics, formatting, tables, and other elements to
make it look just the way you want. Modifying the form is as simple as editing a document.

LibreOffice can access numerous data sources. These include ODBC, MySQL, Oracle JDBC,
spreadsheets and text files. As a general rule, databases can be accessed for reading and writing;
other data sources (such as spreadsheets) are read-only.

‘:Q:‘ Tip

To see the list of supported data source types for your operating system, choose File >
New > Database. On the first page of the Database Wizard (Figure 9), select Connect
to an existing database and then open the drop-down list.
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Creating a database

Chapter 8, Getting Started with Base, in the Getting Started Guide covers in more detail how to
create a database. Below is a short guide to creating a very simple database.

1) Select File > New > Database to start the Database Wizard.

Database Wizard

St Welcome to the LibreOffice Database Wizard

2.5ave and proceed

eieneesmemnineanieenenen Use the Database Wizard to create a new database, open an existing database
____________________________ file, or connect to a database stored on a server.

What do you want to do?
(s) Create a new database
Embedded Database: |HSQLDB Embedded >
() Open an existing database file

Recently used

Open
() Connect to an existing database

JDBC

Help << Back [ Next >> | Finish Cancel

Figure 9: Database Wizard

2)
3)

4)

Select Create a new database and click Next >>.

On the next page, select Yes, register the database for me and Open the database for
editing. Registering the database means that it can be accessed from other LibreOffice
components such as Writer and Calc. You need to do this if you want to link forms to it.

Click Finish and save your new database, giving it a name. Unlike other documents in
LibreOffice, databases must be saved when you first create them.

After saving the database, you should see the main Base window (Figure 10), which contains three
panels. The left-hand panel is Database, with icons for Tables, Queries, Forms and Reports.

The next step is to create a table:

1)
2)

3)

Choose Tables in the left-hand column, then choose Create Table in Design View under
Tasks.

Use the Table Design window to tell Base which fields to create. We will have three input
data fields: Name, Address, and Telephone.

On the first line, enter under Field Name, ID, and set the Field Type to Integer [INTEGER].
In the box at the left of the line, right-click and select Primary Key, bringing up a key icon in
the box. In the Field Properties at the bottom of the window is an Auto Value option; change
this to Yes. Optionally, type Primary key in the Description column. See Figure 11.
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New Database.odb - LibreOffice Base E|_
File Edit View Insert Tools Window Help
B - - E- @, .
_— E Create Table in Design Vie]y... Description
LEESL % Use Wizard to Create Table...
Tables Create View...
Queries
Forms
Reports
None -
Embedded database HSQL database engine

Figure 10: Main Base window

A Caution

Setting up the Primary Key field with Auto Value set to Yes is a critical step. If this is
not done, the form you create later will be much trickier to use and may generate
errors for the user. It could even prevent the user from saving the records in the form.
Make sure you get this step right!

[§ New Database.odb : Table1 - LibreOffice
File Edit View Tools Window Help

H & &5 2 -

Field Name | Field Type

ID Integer [ INTEGER ]
— Cut

L | Copy
Delete
Insert Rows

Primary Key

-
Figure 11: Setting a primary key

4) On the next three lines, enter under Field Name Name, Address and Telephone. Accept the
default Field Type of Text [VARCHAR] and leave Description blank.

5) Save the table (File > Save). You will be prompted to name it. The name can be anything
you like. Click OK.

6) Finally, close the table design window to return to the main Base window. If File > Save is
available, select it to save the whole database.
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[3 New

Database.odb : Table1 - LibreOffice Base: Table Design EI

File E

dit View Tools Window Help

H E « 5 B & g

Field Name |  Field Type | Description
g |ID Integer [ INTEGER ] Primary key L]
p |Name Text [ VARCHAR ]

Address Text [ VARCHAR ]

Phone Text [ VARCHAR ]

Entry r

Length

Field Properties

equired No v

Default value |

Format example | @

Figure 12: Database table design

Registering an existing data source

If you h

ave an existing data source, such as a spreadsheet or database, you need to register it

with LibreOffice. An example of registering a spreadsheet as a data source is given in Chapter 14,
Mail Merge. To summarize:

1)
2)
3)

4)

Select File > New > Database to launch the Database Wizard.
Select Connect to an existing database and choose the type from the drop-down list.

Click Next >> and follow the instructions to select the database to register. The exact
process varies between different types of data source.

In Step 3: Save and proceed, ensure that Yes, register the database for me is selected.
Deselect Open the database for editing; you just need to register it, not edit it through Base.

Deregistering a data source

To remove a registered data source from LibreOffice so that it is no longer available for use, as for
example an obsolete address list, do the following:

1)

2)
3)
4)
5)
6)
7)
This do

Open the Data sources window (by selecting View > Data Sources from the Menu bar, or
by pressing F4, or by selecting the Data Sources icon on the Standard toolbar).

In the left pane, the Data source explorer, right-click a data source.

Select Registered databases from the context menu.

In the Registered databases dialog, select the data source to be removed.

Click Delete, then click Yes in the confirmation box which opens.

Repeat steps 4) and 5) as required.

Click OK to close the Registered databases dialog.

es not delete the database from your system. It can be registered again using the methods

outlined below.
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Re-registering an existing data source

To re-register an existing database file (.odt) of addresses, do the following:

1)
2)
3)
4)
5)

6)
7
8)

Open the Data sources window.

In the left pane, the Data source explorer, right-click a data source.
Select Registered databases from the context menu.

In the Registered databases dialog, click the New button.

In the Create Database Link dialog, click the Browse button, and navigate to the database
file location and select it. Click Open to return to the Create Database Link dialog.

Change the Registered name if required.
Click OK to exit this dialog.
Click OK to exit the Registered databases dialog.

Creating a form for data entry

Once a database is registered with LibreOffice, follow these steps to link a form to the data source:

1)
2)
3)
4)

5)

6)

Create a new document in Writer (File > New > Text Document).
Design your form, without putting in the actual fields (you can always change it later).
Show the Form Controls toolbar (View > Toolbars > Form Controls).

Click the Design Mode On/Off icon to put the document into design mode, if necessary.
With design mode off, most of the toolbar buttons are grayed out. If the Design Mode icon
is also grayed out, click the Select icon to activate it.

Click the Text Box icon. Click in the document and drag to create a text box for the first
form field (for example, Name, if you are linking to the database created above).

Click the Text Box icon again and drag the mouse to draw another field. Additional fields, of
any type, can be added in the same way (click and drag).

So far you have followed the same steps used before when creating your first form. To link the form
with the data source you registered:

1)

Click the Form icon in the Form Controls toolbar, or right-click any of the fields you inserted
and select Form, to open the Form Properties dialog (Figure 13).

[§ Form Properties x
General | Data Events
Data source.................... |Euo|utionLocaI E]
Content type.................. Table ¥
(S0 [A—————— | E]
Analyze SQL command...|Yes x|

e SO | =
Y L | =

Allow additions............... Yes x|
Allow modifications......... Yes ™|
Allow deletions............... Yes X
Add data only................. No ™|
Navigation bar................ Yes hal
CYCle. e Default v

Figure 13: Form properties, connecting to a data source
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2)

3)

4)

5)

N

In the Form Properties dialog, choose the Data tab.
— Set Data Source to be the data source you registered.

— Set Content Type to be Table.
— Set Content to be the name of the table you want to access.
— Close the dialog.

For each form control in turn, click the control to select it (small green boxes appear around
it), then launch the Properties dialog: either right-click and select Control or click the
Control icon on the Form Controls toolbar.

In the Properties dialog, click the Data tab (Figure 14). If you set up the form correctly, the
Data Field option will contain a list of the different fields in the data source (for example,
Name, Address and Telephone). Select the field you want.

[§ Pproperties: Text Box
General Data Events

Data field................... family name
Empty string is NULL... |Yes v

Input required............. Yes v

Filter proposal............. No v

Figure 14: Form control properties, Data tab

Repeat for each control in turn until every control that should be assigned to a field has
been assigned.

Caution

If you created a database in LibreOffice Base and your Primary Key field had Auto
Value set to Yes, that field does not need to be part of the form. If Auto Value was set
to No, you will have to include it and have your users enter a unique value into that
field whenever they make a new entry—not something that is recommended.

Entering data into a form

Once you have created a form and tied it to a database, use it to enter data into the database or
modify data already there:

1) Make sure that the form is not in design mode. (In the Form Controls toolbar, click the
Design Mode On/Off icon. If design mode is off, most of the buttons on the toolbar will be
grayed out.)

2) Make sure that the Form Navigation toolbar is on (View > Toolbars > Form Navigation).
This toolbar normally appears at the bottom of the workspace.

#& Record [2 of 11 * K 4 b oD b & 2 - ==
Figure 15: Form Navigation toolbar

3) If there is existing data in the data source, use the control buttons on the Form Navigation
toolbar to look at different records. To amend data in a record, edit the values in the form.
To submit the changes, press Enter with the cursor in the last field. The record is saved and
the next record is displayed.

4) If there is no data in the form, enter information by typing into the fields of the form. To

submit the new record, press Enter with the cursor in the last field.
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5)

H

Other functions can be performed from the Form Navigation toolbar, including deleting a
record and adding a new record.

Note

If a user tries to fill in the form and receives the error “Attempt to insert null into a non-
nullable column”, then the form designer should go back to the database and confirm
that the Primary Key field has the Auto Value set to Yes. This error will prevent the
form user from saving the records.

Advanced form customization

Linking a macro to a form control

You can set any form control (for example, text box or button) to perform an action when triggered
by some event.

To assign a macro to an event:

1)

2)

3)
4)

Create the macro. See Chapter 13, Getting Started with Macros, in the Getting Started
Guide.

Be sure the form is in design mode. Right-click the form control, select Control and click
the Events tab (Figure 16).

[§ properties: Text Box
General Data Events

Changed..........ccooo |
Text Modified. ..........co.covvvverveeenen. |

Mouse button pressed.................. |

Mouse button released.................. |

Mouse outside..........ccceeeeiennnnee, |

Rrierteireset.. ... |

After resetting.............................. |

Before updating.........cccooevniinn |

5
2 6| O 2 [ 0 [ [ 9 Eo o 0 [ [ e e

After updating..........cccooeeeinnnnnl, |

Figure 16: Control properties, Events tab

Click the browse icon by any event to open the Assign action dialog (Figure 17).

Click the Macro button and select the macro from the list in the Macro Selector dialog (not
shown). You return to the Assign action dialog. Repeat as needed, then click OK to close
the dialog.
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[§ Assign action

Event |Assigned Action Assign:
Changed

Text modified l
When receiving focus

When losing focus l
Key pressed

Key released

Mouse inside

Mouse moved while key pressed

Mouse moved

Maouse button pressed

Mouse button released

Mouse outside

Prior to reset

After resetting

Before updating

After updating

Macro... ]

Remove ]

Help oK l l Cancel

Figure 17: Assign action dialog

Macros can also be assigned to events relating to the form as a whole. To do this, right-click a form
control in the document, select Form and click the Events tab.

Read-only documents

Having created your form, you want whoever is using it to be able to access the information stored
in the database, or complete the form, without changing the layout. To do this, make the document
read-only by choosing File > Properties > Security and selecting Open file read-only.

Fine-tuning database access permissions

By default, when a database is accessed from a form, any changes can be made to it: records can
be added, deleted, and amended. You may not want that behavior. For example, you may want
users to be able only to add new records or to be prohibited from deleting existing records.

In design mode, right-click a form control and select Form from the context menu. On the Data tab
of the Form Properties dialog are a number of options: Allow additions, Allow deletions, Allow
modifications and Add data only. Set each of these to Yes or No to control the access users have
to the data source.

Individual fields can also be protected. This might be useful if you wanted a user to be able to
modify some parts of a record but only view others, such as a stock list where item descriptions are
fixed and quantities can be modified.

To make an individual field read-only, in design mode, right-click the form control within the
document and select Control from the context menu. Select the General tab (Figure 18) and set
Read-only to Yes.
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Sort e
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(ol Default L

Figure 18: Data Properties of a form

Form control formatting options

You can customize the way form controls look and behave in a number of ways. These are all
accessed in design mode. Right-click the form control, select Control from the context menu and
select the General tab in the Properties dialog.

Set a label for the control in the Label box (not to be confused with the box called Label
Field). Some form controls, such as push buttons and option buttons, have visible labels
that can be set. Others, such as text boxes, do not.

Set whether the form control will print out if the document is printed with the Print option.

Use the Font setting to set the font, typeface, and size for a field’s label or for text typed into
a field. This setting does not affect the size of check boxes or option buttons.

For a text box, you can set the maximum text length. This is very useful when adding
records into a database. Every database text field has a maximum length and, if the data
entered is too long, LibreOffice displays an error message. By setting the maximum text
length of the form control to be the same as that of the database field, this error can be
avoided.

You can set the default option for a form control. By default, a control is blank, or has every
option unselected. You can set the control to start with a particular option or list item
selected.

For controls where a password is being entered, setting the Password character (for
example to *) displays only that character, but saves what the user really types.

You can add additional information and help text for a form control.

You can use other formatting controls such as background color, 3-D look, text formatting,
scroll bars, and borders to further define how the control appears.
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