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Introduction

This chapter briefly presents some of the setup options found under Tools > Options on the Menu
bar. Additional options, and more details about the ones given here, are covered in the Help and in
Chapter 2, Setting up LibreOffice, in the Getting Started Guide.

Several of the most relevant options are discussed in other chapters of this book, in the context of
tasks where they are most applicable.

‘:Q:‘ Tip

Many options are intended for power users and programmers. If you don't understand
what an option does, it's usually best to leave it on the default setting unless
instructions in this book recommend changing the setting.

Choosing options that affect all LibreOffice components

This section covers some of the settings that apply to all the components of LibreOffice (Writer,
Calc, Impress, Draw, Math, and Base) and that are particularly important when using Writer.

To navigate to options that govern all LibreOffice components, click Tools > Options and then click
the marker (+ or triangle) by LibreOffice on the left-hand side. A list of pages drops down. Select
an item in the list to display the relevant page on the right-hand side of the dialog.

‘:Q:‘ Tip

The Reset button (located in the lower right of any page of the Options dialog) resets
the values on that page to the values that were in place when you opened the dialog.

If you are using a version of LibreOffice other than US English, some field labels may be different
from those shown in the illustrations.

User data

Because Writer can use the name or initials stored in the LibreOffice — User Data page for several
things, including document properties (‘created by’ and ‘last edited by’ information), the name of
the author of comments and changes, and the sender address in mailing lists, you will want to
ensure that the correct information appears here. If you do not want user data to be part of the
document’s properties, deselect Use data for document properties.

Memory options

The options on the LibreOffice — Memory page control how LibreOffice uses your computer’s
memory and how much memory it requires.

This page includes the option for enabling or disabling the Quickstarter, where this feature is
available. It is not available on macOS or on systems where the Quickstarter module has not been
installed. For more about Quickstarter, see Chapter 1.

View options

The options on the LibreOffice — View page affect how the document window looks and behaves.
Set them to suit your personal preferences. For details, see the Help or Chapter 2, Setting up
LibreOffice, in the Getting Started Guide.
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Print options

On the LibreOffice — Print page, set the print options to suit your default printer and your most
common printing method.

Reduce Print Data

Settings for: Printer Print to file
[£] Reduce transparency [E] Reduce gradient
Automatically Gradient stripes: |54 -
Mo transparency Intermediate color

Convert colors to grayscale

High print quality
Mormal print quality
Resolution: |200 DPI (default)

[E] Include transparent objects

[E] PDF as standard print job format

Printer Warnings
Paper size ransparency
Paper orientation

Figure 1: Choosing general printing options to apply to all LibreOffice components

In the Printer warnings section near the bottom of the page, you can choose whether to be warned
if the paper size or orientation specified in your document does not match the paper size or
orientation available for your printer. Having these warnings turned on can be quite helpful,
particularly if you work with documents produced by people in other countries where the standard
paper size is different from yours.

‘:Q:‘ Tip

If your printouts are incorrectly placed on the page or chopped off at the top, bottom, or
sides, or the printer is refusing to print, a likely cause is incorrect page size in printer
settings.

Paths options

On the LibreOffice — Paths page, you can change the location of files associated with, or used by,
LibreOffice to suit your needs. For example, you might want to store documents by default
somewhere other than My Documents. Multiple paths are possible.

Fonts options

If you receive a document containing fonts that you do not have on your system, LibreOffice will
use substitute fonts for those it does not find. On the LibreOffice — Fonts page, you can specify a
font different from the one the program chooses.
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‘:Q:‘ Tip

Liberation fonts (Serif, Sans, and Mono) are often good choices to substitute for
Times, Arial, and Courier.

£7 Note

The Font Options choices do not affect the default fonts for your documents. To
change them, you need to create a new default template for Writer documents, as
described in Chapter 10, Working with Templates.

Security options

Use the LibreOffice — Security page to choose security options for saving documents and for
opening documents that contain macros. For information on the options not mentioned here, refer
to the Help or to the Getting Started Guide.

Security options and warnings
If you record changes, save multiple versions, or include hidden information or notes in your
documents, and you do not want some recipients to see that information, you can set
warnings to remind you to remove it, or you can have LibreOffice remove some of it
automatically. Note that unless the information is removed, much of it is retained even when
the file has been saved to other formats, including PDF.

Click the Options button to open a separate dialog with several options, including:

Remove personal information on saving
Select this option to always remove user data from the file properties when saving the file. To
save personal information with documents and still be able to manually remove personal
information only from specific documents, do not select this option.

Ctrl-click required to follow hyperlinks
The default behavior in LibreOffice is that using Ctrl+click a hyperlink opens the linked
document or website. This is because many people find writing and editing documents easier
when accidental clicks on links do not activate the links. To set LibreOffice to activate
hyperlinks using just an ordinary click, deselect this option.

Application colors

Writing, editing, and (especially) page layout are often easier when you can see the page margins
(text boundaries), the boundaries of tables and sections, grid lines, and other features. In addition,
you might prefer to use colors that are different from LibreOffice’s defaults.

On the LibreOffice — Application colors page (Figure 2), you can specify which user interface
elements are visible and the colors used to display them.

¢ To show or hide items such as text boundaries, select or deselect the boxes in the On
column next to the names of the elements.

* To change the default colors for a specific element, click the down-arrow in the Color
setting column by the name of the element and select a color from the drop-down list.

» To save your color changes as a color scheme, click Save, type a name in the Scheme
box, and then click OK.

£7] Note

To change the color settings used in Track Changes mode, go to Tools > Options >
LibreOffice Writer > Changes.
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Color Scheme

Scheme: |LibreOffice - Save Delete

Custom Colors

On |User interface elements Color setting
AutoSpellcheck B ~.utomatic -
Smart Tags B -.utomatic -

B Shadows B -.utomatic -

Text Document

Grid [ ] Automatic -
[E Field shadings [ ] Automatic -
[E Index and table shadings [ ] Automatic -
Script Indicator B -.utomatic -
[E] Section boundaries [ ] Automatic -

Figure 2: Showing or hiding text, object, and table boundaries

Choosing options for loading and saving documents

You can set the options for loading and saving documents to suit the way you work.

If the Options dialog is not already open, click Tools > Options. Click the expansion symbol (+ or
triangle) to the left of Load/Save.

General

Most of the choices on the Load/Save — General page (Figure 3) are familiar to users of other
office suites. Some items of interest are described below.

Load user-specific settings with the document
When a LibreOffice document is saved, certain settings from the user's system are saved
with it. When the document is opened on another user’s system, it will use the settings saved
from the previous user’s system. Deselecting this option causes the current user’s settings to
override the settings previously saved with the document.

Even if you deselect this option, some settings are always loaded with the document:

Settings available in File > Print > Options.

Name of Fax.

Spacing options for paragraphs before text tables.

Information about automatic updating for links, field functions, and charts.
Information about working with Asian character formats.

Z Note

The settings for any data sources linked to a document are always loaded with the
document, whether or not Load user-specific settings with the document is selected.
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Load

B Load userspecific settings with the document

B Load printer settings with the document

Save
& Save AutoRecovery information every: (10 > | minutes
Edit document properties before saving
Always create backup copy
[ save URLs relative to file system

& save URLs relative to internet

Default File Format and ODF Settings

ODF format version: (1.2 Extended (recommended) =

& warn when not saving in ODF or default Format

1]

Document type: Text document

Always save as: ODF Text Document =

4

Figure 3: Choosing Load and Save options

Load printer settings with the document
If this option is enabled, the printer settings of the previous user will be loaded with the
document. In an office setting, this may cause a document to be printed on a distant network
printer unless the printer is manually changed in the Print dialog. If disabled, the current
user’s default printer will be used to print the document. The current printer settings will be
stored with the document whether or not this option is selected.

Save AutoRecovery information every _ minutes
Choose whether to enable AutoRecovery and how often to save the information used by the
AutoRecovery process. AutoRecovery in LibreOffice saves the information needed to restore
all open documents in case of a crash. If you have this option set, recovering your document
after a system crash will be easier.

Edit document properties before saving
If this option is selected, the document’s Properties dialog pops up to prompt you to enter
relevant information the first time you save a new document (or whenever you use Save As).

Always create backup copy
Saves the previously-saved version of a document as a backup copy in a separate folder
whenever you save a document. When LibreOffice creates a new backup copy, the previous
backup copy is replaced. To see or change the backup folder, go to Tools > Options >
LibreOffice > Paths. When opening a backup file, you will be prompted to specify the
program to open it with; choose LibreOffice.

‘:Q:‘ Tip

Authors whose work may be very lengthy should always consider enabling LibreOffice
to create an automatic backup copy.

Save URLs relative to file system / to internet
Use these options to select the default for relative addressing of URLSs in the file system and
on the Internet. For details, see Chapter 2, Setting up LibreOffice, in the Getting Started
Guide.
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Default file format and ODF settings
ODF format version: LibreOffice by default saves documents in OpenDocument Format
(ODF) version 1.2 Extended. You will rarely need to change this for compatibility when
exchanging files with other people.

Document type: If you routinely share documents with users of Microsoft Word, you might
want to change the Always save as option to one of the Word formats. However, you can
choose a Word format when you save any individual file.

Microsoft Office

On the Load/Save — Microsoft Office page, you can choose what to do when importing and
exporting Microsoft Office OLE objects (linked or embedded objects or documents such as
equations or spreadsheets): convert them into or from the corresponding LibreOffice OLE object or
load and save them in their original format.

HTML compatibility

Choices made on the Load/Save — HTML Compatibility page (not shown) affect HTML pages
imported into LibreOffice and those exported from LibreOffice. See HTML documents; HTML
import and export in the Help, and Chapter 2 in the Getting Started Guide, for more information.

Choosing Writer-specific options

Settings chosen in the LibreOffice Writer section of the Options dialog determine how Writer
documents look and behave while you are working on them.

If the Options dialog is not already open, choose Tools > Options. Click the marker (+ or triangle)
by LibreOffice Writer on the left side of the dialog.

General options

The choices on the LibreOffice Writer — General page affect the updating of links and fields, the
units used for rulers and other measurements, and the default tab stop positions.

Update Links when Loading Automatically Update
Always [E] Fields
On request [E] Charts
Never
Settings

Measurement unit: | Centimeter

Tabstops: [1.25¢cm |5

Word Count

Additional separators:  |—

[Z] Show standardized page count!

Characters per standardized page: 1,800
Figure 4: Choosing general options for Writer

Update Links when Loading
Depending on your work patterns, you may not want links to be updated when you load a
document. For example, if your file links to other files on a network, you won't want those
links to try to update when you are not connected to the network.
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Automatically Update [Fields and Charts]
You may not want fields or charts to update automatically while you are working, because
that slows down performance. Alternatively, you may want automatic updates if you are
referring to information in the fields or charts.

Settings — Measurement unit

Document designers recommend using points as the default measurement because you can
easily relate things like font size to things like indents and tabs.

Settings - Tab stops
The Tab stops setting specifies the distance the cursor travels for each press of the Tab key.
This setting is also used for the indent distance applied by the Increase Indent and
Decrease Indent buttons on the Formatting Toolbar, which affect the indentation of entire
paragraphs.

‘:@:‘ Tip

To avoid unwanted changes, do not rely on default tab settings. Rather, define your
own tabs in paragraph styles or individual paragraphs (see “Defining your own tab
stops and indents” in Chapter 4, Formatting Text).

Word Count — Additional separators

For counting words, specifies the characters that are considered to separate words, in
addition to spaces, tabs, line breaks, and paragraph breaks.

Word Count - Show standardized page count
Editors and publishers often define a “standard” page as containing a specified humber of
characters or words; this field allows quick calculation of the number of these pages.

View options

Two pages of options set the defaults for viewing Writer documents: View (described here) and
Formatting Aids (described below).

View is a good page to check if, for example, you cannot see graphics on the screen.

Guides View
[E Helplines While Moving Horizontal ruler |Centimeter «
Display [£]] Vertical ruler Centimeter
[E Images and objects Smooth scroll
& Tables

[E Drawings and controls
Field codes

£ Comments

Figure 5: Choosing View options for Writer

Enabling Helplines While Moving helps to precisely position a drawing object on a page. When
enabled, horizontal and vertical parallel lines appear that are the height and width of the object.
These lines extend across the complete working area as the object is moved.

‘:Q:‘ Tip

If you have inserted a field but do not see the text or number you expect, uncheck
Field codes here. Example: Date (fixed) appears on the screen when Field codes is
enabled, while 21/07/17 appears when it is disabled.
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Formatting Aids options
On the LibreOffice Writer — Formatting Aids page (Figure 6), select the desired options.

The Display of options determine which symbols show when you select View > Formatting Marks
from the Menu bar or the Formatting Marks icon in the Standard toolbar. Symbols such as
paragraph ends and tabs can help in writing, editing, and page layout. For example, they can show
if there are any blank paragraphs or if any tables or graphics are too wide and intrude into the
margins of the page.

£7] Note

Direct cursor lets you enter text, images, tables, frames, and other objects in any blank
area in your document. Writer then inserts blank paragraphs, tabs, spaces and so on
to position the text or objects. However, this feature can lead to many formatting
oddities and is incompatible with rigorous use of styles, so it should be avoided.

Display of Direct Cursor
[E) Paragraphend b | Direct cursor
[@ Soft hyphens - Insert
Spaces : Paragraph alignment
[E] Morn-breaking spaces Left paragraph margin
[E) Tabs o Tabs
[ Breaks = Tabs and spaces
Hidden text iC) Spaces
Fields: Hidden text Protected Areas
[E] Fields: Hidden paragraphs [E] Enable cursor

Layout Assistance

Math baseline alignment

Figure 6: Choosing Formatting Aids options

Grid options

Snap to grid automatically moves an object to the nearest gridlines. This can be very helpful when
you are trying to align several objects such as graphics or tables.

On the LibreOffice Writer — Grid page, you can choose whether to enable this feature and what
grid intervals to use. If the grid intervals (subdivisions) are too large, you may find that you do not
have enough control in placing the objects.

Print options

On the LibreOffice Writer — Print page, you can choose which items are printed with a Writer
document by default. These options are in addition to the general options for all LibreOffice
components on the LibreOffice — Print page (see page 5).

‘:Q:‘ Tip

You can override any of these defaults when printing a specific document. Click File >
Print, then use the options on the various pages of the Print dialog.

Choosing Writer-specific options | 11



Contents Pages Comments

[E£] Images and objects £ Left pages © None

[E Form controls [ Right pages Comments only

[E Page background Brochure End of document
Print text in black End of page
Hidden text In margins

Text placeholder

Other
Print automatically inserted blank pages
Paper tray from printer settings

Fax |[MNone] -

Figure 7: Choosing Print options for Writer

Some considerations:

When you are working on drafts and you want to save printer ink or toner, you might want
to deselect some of the items in the Contents section.

The Print text in black option causes color text (but not graphics) to print as black on a

color printer; on a black-and-white printer, this option causes color text to print as solid
black instead of shades of gray (dithered).

By comparison, the Convert colors to grayscale option on the Options - LibreOffice -
Print page (Figure 1), prints all text and graphics as grayscale on color printers. (On black-
and-white printers, color in graphics normally prints as grayscale.)

If you are printing double-sided on a non-duplexing printer, you might choose to print only
left or right pages, then turn the stack over and print the other pages.

Table options

On the LibreOffice Writer — Table page (Figure 8), you can specify the default behavior of tables.
See the Help or Chapter 13, Tables of Data, for more information.

Some considerations:

If most of your tables will require borders or headings, you may wish to select those
options. If most of your tables are used for page layout, deselect Border and Heading.

Select Do not split to prevent tables from being split across pages. Number recognition
can be very useful if most of your tables contain numerical data. Writer will recognize dates
or currency, for example, and format the numbers appropriately. However, if you want the
numbers to remain as ordinary text, this feature can be quite irritating, so you may want to
deselect it.

The Keyboard handling section specifies the distances that cells move when you use
keyboard shortcuts to move them and the size of rows and columns inserted using
keyboard shortcuts. If you don't use keyboard shortcuts for this purpose, you can ignore
these settings. See the Help for more information.

The Behavior of rows/columns section specifies the effects that changes to rows or
columns have on adjacent rows or columns and the entire table. You might need to test
these selections to fully understand the effects.
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New Table Defaults Inputin Tables

[ Heading ["] Mumber recognition

Repeat on each page MNumber format recognition
[ Do not split Alignment
[E Border

Keyboard Handling

Move cells Insert cell
Row: |E].5E] Cim : Row: |U.5[J cm :
Column: |U.50 tm| o Column: |2.5l:| tm 5

Behavior of rows/columns

Fixed Changes affect the adjacent area only
Fixed, proportional  Changes affect the entire table

(&) Variable Changes affect the table size

Figure 8: Choosing default Table options

Changes options

If you plan to use the change-tracking feature of Writer (described in Chapter 3, Working with Text:
Advanced), use the LibreOffice Writer — Changes page to choose the way changes to text and
formatting are marked. Change bars can show wherever a change has been made to a line of text
and are formatted under Lines Changed.

Insertions
Attributes:  |Underlined v |
Insert
Color: | By author v |
Deletions
Attributes: | Strikethrough v |
Delete
Color: | By author v |
Changed Attributes
Attributes:  |Bold v |
Atiributes
Color: |By author v |
Lines Changed
Mark: |Left margin >[I
Color: /I Black N =

Figure 9: Choosing options for tracking changes

Comparison options

The options on the LibreOffice Writer — Comparison page determine the level of detail used by the
Compare Document feature (Edit > Track Changes > Compare Document), described in
Chapter 3, Working with Text: Advanced.
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Compare Documents

() Auto
" Byword
O By

Random number to improve accuracy of document comparison

[ Take itinto account when comparing
[| Ignore pieces of length 1

[ store it when changing the document

Figure 10: Options for comparing documents

Compatibility options

The settings on the LibreOffice Writer — Compatibility page (Figure 11) are used mainly when
importing documents from Microsoft Word. If you are not sure about the effects of these settings,
leave them as the defaults provided by LibreOffice. For information about settings that are not
described below, see the Help. All settings selected will apply only to the current document, unless

you select the Use as Default button at the bottom.
Compatibility options for WG6020-SettingUpWriter_bb_gp_jhw"

Use printer metrics for document formatting

Add spacing between paragraphs and tables

Add paragraph and table spacing at tops of pages

Use OpenOffice.org 1.1 tabstop formatting

Do not add leading (extra space) between lines of text

Use OpenOffice.org 1.1 line spacing

B |

Add paragraph and table spacing at bottom of table cells

Use OpenOffice.org 1.1 object positioning

Use OpenOffice.org 1.1 text wrapping around objects

Consider wrapping style when positioning objects

Expand word space on lines with manual line breaks in justified paragraphs

Protect form

MS Word-compatible trailing blanks

[ Tolerate white lines of PDF page backgrounds for compatibility with old documents

Figure 11: Choosing compatibility options
Use printer metrics for document formatting

| Use as Default |

If this option is selected, the printer specified for the document determines how the document
is formatted for viewing on screen. The line breaks and paragraph breaks you see on screen
match those that apply when the document is printed on that printer. If this option is not
selected, a printer-independent layout will be used for screen display and printing.
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This setting can be useful when several people are reviewing a document that will eventually
be printed on a specific printer or when the document is exported to PDF. It is most useful
with PostScript printers.

Add spacing between paragraphs and tables (in current document)
Paragraph spacing is treated differently in LibreOffice Writer than it is in Microsoft Word. If
you have defined spacing between paragraphs or tables in LibreOffice, this spacing is added
to the spacing defined in Microsoft Word.

If this option is selected, Microsoft Word-compatible spacing is added between paragraphs
and tables in LibreOffice Writer documents.

Add paragraph and table spacing at tops of pages (in current document)
You can define paragraphs and tables to have space appear before (above) them. If this
option is selected, any space above a paragraph will also appear if the paragraph is at the
beginning of a page or column, or if the paragraph is positioned on the first page of the
document, or after a manual page break.

If you import a Microsoft Word document, the spaces are automatically added during the
conversion.

Add paragraph and table spacing at bottom of table cells
Specifies that the bottom spacing is added to a paragraph, even when it is the last paragraph
in a table cell.

Use as Default
Click this button to use the settings on this page as the default in Writer.

AutoCaption options

LibreOffice can automatically insert captions for tables, pictures, frames, and OLE objects in a
Writer document. To set this up, use the options on the LibreOffice Writer > AutoCaption page.
Select the object you want to be automatically captioned (LibreOffice Writer Image in Figure 12).
With the item highlighted, specify the characteristics of the caption.

Add captions automatically Caption
when inserting:
Category: |Tab|e -
[3¢]
. } Numbering: |Arabic(123 -
LibreOffice Writer Frame = { ]
[E LibreOffice Writer Image Murmbering separator
LibreOffice Spreadsheet Separator: |
LibreOffice Drawing Position: | Below -

LibreOffice Formula

LibreOffice Chart Numbering Captions by Chapter

LibreOffice Presentation (=l b
Separator: |
Caption Order
éCategoryﬁrst - Category and Frame Format
. ' Character style: |Caption Characters g

Table 1

Figure 12: Setting up automatic captions

The categories supplied for captions are Drawing, lllustration, Table, and Text. To use another
name (for example, Figure) for the caption label, type the required term in the Category box.
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£7] Note

You may not want captions for every table, for example if you use tables for layout as
well as for tables of data. You can always add captions to individual tables, graphics,
or other objects (right-click > Insert Caption).

Information about numbering captions by chapter, character styles, frame styles, and other items
on the AutoCaption page is given in other chapters in this book.

Mail Merge E-mail options

Using a data source such as an address book, Writer can insert personal, address, and other
information into form letters. These documents can be printed for mailing or they can be e-mailed
through Writer. (See Chapter 14, Mail Merge, for details.)

Use the LibreOffice Writer — Mail Merge E-mail page to set up the user and server information for
sending form letters by e-mail. If you are not sure what information to put in any of the fields,
consult your e-mail program or your internet service provider.

User Information

Your name: [ l

E-mail address: [ l

[E send replies to different e-mail address:

Reply address: [ l

Outgoing Server (SMTP) Settings

Server name: [ l

'y

Port: |25 =

Use secure connection (S5L)

Server Authentication...

Figure 13: Specifying settings for use when emailing mail-merged form letters

Choosing language settings

You may need to do several things to get the language settings you want:
* Install the required dictionaries.
* Change some locale and language settings.
* Choose spelling and grammar options.

Install the required dictionaries

LibreOffice automatically installs many language modules with the program. A language module
can contain up to three submodules: spelling dictionary, hyphenation dictionary, and thesaurus.
These are usually referred to as “dictionaries” in Writer.

To add other dictionaries, be sure you are connected to the Internet, and then choose Tools >
Language > More Dictionaries Online from the Menu bar. LibreOffice will open your default web
browser to a page containing links to additional dictionaries that you can install. Follow the prompts
to select and install the ones you want.
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Change some locale and language settings

You can change some details of the locale and language settings that LibreOffice uses for all
documents or for specific documents. See the Help for details on all these options.

In the Options dialog, click the expansion symbol (+ sign or triangle) by Language Settings and
choose Languages.

On the right-hand side of the Language Settings — Languages page (Figure 14), change the
settings as required. In the example, English (USA) has been chosen for all the appropriate
settings, but you could choose a mixture of languages. For example, if you were working in
Germany, you might prefer the user interface to be in English (USA), but German (Germany) for
the Locale setting, which influences settings for numbering, currency, and units of measure.

If you want the language setting to apply to the current document only, instead of being the default
for all new documents, select For the current document only.

Changes to the system input language/keyboard normally affect text typed into a document after
the change. If you do not want this to happen, select Ignore system input language; new text will
then continue to follow the language of the document or the paragraph, not the system language.

If necessary, select the options to enable support for Asian languages (Chinese, Japanese,
Korean) and support for CTL (complex text layout) languages such as Hindi, Thai, Hebrew, and
Arabic. If you choose either of these options, the next time you open the Options dialog, you will
see some extra pages under Language Settings. These pages are not discussed here.

Language Of
User interface: Default - English (USA) -
Locale setting: gEninEh{USA] -
Decimal separator key: [E] Same as locale setting | . )
Default currency: Default- USD -

Date acceptance patterns: |MIDN:MID

Default Languages for Documents

Western: *% English (USA) -
Asian: [Mone]
Complex text layout: [Mone]
For the current document only

Enhanced Language Support

Ignore system input language

Figure 14: Choosing language options

Sentence checking

LibreOffice can check sentences in many languages. These checkers are enabled by default if the
language is the computer’s default language, and others can be added using the Extension
Manager (see Chapter 21, Customizing Writer). The set of rules available for the sentence
checkers depends on the language.
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Choose spelling and grammar options

To change the options for checking spelling and grammar, use the Language Settings > Writing
Aids page (Figure 15). Some considerations:

* If you do not want spelling checked while you type, deselect Check spelling as you type.
(You can over-ride this setting in a document using Tools > Automatic Spell Checking on
the Menu bar or the Auto Spellcheck icon on the Standard toolbar.)

* If you want grammar to be checked as you type, you must have Check spelling as you
type enabled too.

* Check special regions means that text in headers, footers, frames, and tables are also
checked when checking spelling.

Here you can also select which of the user-defined (custom) dictionaries are active, add a new

custom dictionary, edit dictionaries, and delete custom dictionaries. Dictionaries installed by the
system cannot be deleted.

‘:@:‘ Tip

When checking spelling, words marked “Add to Dictionary” are added by default to the
Standard dictionary. Words marked “Ignore All” are added to the IgnoreAllList
dictionary. See Chapter 2, Working with Text: Basics.

Writing aids
Available language modules

[+] Hunspell SpellChecker & Edit
¥ | Lightproaf grammar checker {(English) —
v'|Libhvohen Hyohenator st

Liser-defined dictionaries

standard [All]
technical [All]
en-GB [ English (LK) 7'
en-Us [ English (Usa) T Edit...
IgnoreAllList [All]

v
¥

Delete

m 1=
o i
= ;:E

Check spelling as you type ”
Check grammar as you type
Check uppercase words
Check words with numbers
Check spedial regions

Get more dictionaries online. ..

Figure 15: Choosing languages, dictionaries, and options for checking spelling

English sentence checking

On the Language Settings > English sentence checking page, you can choose which items are
checked for, reported to you, or converted automatically. This menu is also found in the English
dictionaries extension installed by default by LibreOffice (select Tools > Extension Manager,
select English spelling dictionaries and click the Options button to reveal the menu). Select
which of the optional features you wish to check. These are described in Chapter 2, Working with
Text: Basics.

After selecting the additional grammar checks, you must restart LibreOffice, or reload the
document, for them to take effect.
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