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Introduction

You can add graphic and image files, including photos, drawings, and scanned images, to
LibreOffice documents. LibreOffice can import various vector (line drawing) and raster (bitmap) file
formats. The most commonly used graphic formats are GIF, JPG, PNG, and BMP. See Appendix B
for a full list of the graphic formats LibreOffice can import.

Graphics in LibreOffice are of three basic types:

* Image files, such as photos, drawings, PDF Documents, and scanned images
» Diagrams created using LibreOffice’s drawing tools
* Charts created using LibreOffice’'s Chart component

This chapter covers images and diagrams.

More detailed descriptions on working with drawing tools can be found in the Draw Guide and
Impress Guide. Instructions on how to create charts are given in the Calc Guide.

Adding images to a document

Images can be added to a document in several ways: by inserting an image file, directly from a
graphics program or a scanner, by dragging them from the clip art internal gallery, or by copying
and pasting from a source being viewed on your computer.

Inserting an image file

When the image is in a file stored on the computer, you can insert it into a LibreOffice document
using either of the following methods.

Drag and drop
1) Open a file browser window and locate the image you want to insert.

2) Drag the image into the LibreOffice document and drop it where you want it to appear. A
faint vertical line marks where the image will be dropped.

This method embeds (saves a copy of) the image file in the document. To link the file instead of
embedding it, hold down the Ctr/+Shift keys while dragging the image.

Insert Image dialog
1) Click in the LibreOffice document where you want the image to appear.
2) Choose Insert > Image from the menu bar.
3) On the Insert Image dialog, navigate to the file to be inserted, and select it.
4) At the bottom of the dialog (Figure 1) a Link option. See page 5 for the use of Link.
5) Click Open.

£7] Note

If you choose the Link option, a message box appears when you click Open. It asks if
you want to embed the graphic instead. Choose Keep Link if you want the link, or
Embed Graphic if you do not. To prevent this message from appearing again,
deselect the option Ask when linking a graphic at the bottom of the message.
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Figure 1: Insert Image dialog

Linking an image file

If the Link option in the Insert picture dialog is selected, LibreOffice creates a link to the file
containing the image instead of saving a copy of the image in the document. The result is that the
image is displayed in the document, but when the document is saved, it contains only a reference
to the image file, not the image itself. The document and the image remain as two separate files,
and they are merged together only when you open the document again.

Linking an image has two advantages and one disadvantage:

* Advantage — Linking can reduce the size of the document when it is saved, because the
image file itself is not included. File size is usually not a problem on a modern computer
with a reasonable amount of memaory, unless the document includes many large graphics
files; LibreOffice can handle quite large files.

* Advantage — You can modify the image file separately without changing the document
because the link to the file remains valid, and the modified image will appear when you next
open the document. This can be a big advantage if you (or someone else, perhaps a
graphic artist) is updating images.

+ Disadvantage — If you send the document to someone else, or move it to a different
computer, you must also send the image files, or the receiver will not be able to see the
linked images. You need to keep track of the location of the images and make sure the
recipient knows where to put them on another machine, so that the document can find
them. For example, you might keep images in a subfolder named Images (under the folder
containing the document); the recipient of the file needs to put the images in a subfolder
with the same name and in the same place relative to the document.

Z Note

When inserting the same image several times in the document, it would appear
beneficial to link rather than embed; however, this is not necessary as LibreOffice
embeds only one copy of the image file in the document.

Linking an image file | 5



Embedding linked images

If you originally linked the images, you can easily embed one or more of them later if you wish. To
do so:

1) Open the document in LibreOffice and choose Edit > Links to External Files.

2) The Edit Links dialog (Figure 2) shows all the linked files. In the Source file list, select the
files you want to change from linked to embedded.

3) Click the Break Link button.
4) Click the Close button.
5) Save the document.

& Edit Links
Source file Element: Type Status Close
./IMG_20130716_170904.jp: <All Formats= Image Manual | Help
..f/IMG_20130603_082125.jpt <All Formats> Image Manual
.../IMG_20130603_082125.jpt <All Formats= Image Manual _ Update
Modify...
Break Link
Source file file:///home/radiance/Pictures/IMG_20130417_162911.jpg
Element: <All Formats>
Type: Image
Update: Automatic Manual

Figure 2: The Edit Links dialog

£7 Note

Going the other way, from embedded to linked, is not so easy—you must replace the
images, one at a time, selecting the Link option when you do so.

Inserting an image from the clipboard

Using the clipboard, you can copy images into a LibreOffice document from another LibreOffice
document and from other programs. To do this:

1) Open both the source document and the target document.
2) Inthe source document, select the image to be copied.
3) Click once on the selected image and press Ctr/+C to copy the image to the clipboard.
4) Switch to the target document.
5) Click to place the cursor where the graphic is to be inserted.
Press Ctrl+V to insert the image.

6)
A Caution

If the application from which the graphic was copied is closed before the graphic is
pasted into the target, the image stored on the clipboard could be lost.

6 | Inserting an image from the clipboard



Inserting an image using a scanner

If a scanner is connected to your computer, LibreOffice can call the scanning application and insert
the scanned item into the LibreOffice document as an image. To start this procedure, and choose
Insert > Media > Scan > Select Source. Then place the cursor where you want the graphic to be
inserted, and choose Insert > Media > Scan > Request.

Although this practice is quick and easy, it is unlikely to result in a high-quality image of the correct
size. You may get better results by passing scanned material into a graphics program and cleaning
it up there before inserting the resulting image into LibreOffice.

Inserting an image from the Gallery

The Gallery (Figure 3) provides a convenient way to group reusable objects such as graphics and
sounds that you can insert into your documents. The Gallery is available in all components of
LibreOffice. See “Managing the LibreOffice Gallery” on page 9. You can copy or link an object from
the Gallery into a document.

To insert an object:
1) Click the Gallery icon in the Sidebar.
2) Select atheme.
3) Select an object with a single click.
4) Drag and drop the image into the document.
You can also right-click on the object and choose Insert.

Gallery X

A

MNew Theme...

[] People

[] School & University
[ Sounds

[ symbols

[[] Text Shapes

[[] Transportation

@ BA -

Figure 3: The Gallery in the Sidebar

To insert an object as a link:

1) Choose Insert > Media > Gallery and select a theme.

2) Select an object with a single click, then while pressing the Shift and Ctrl keys, drag and
drop the object into the document.
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Inserting an image as a background
To insert an image as the background to a page or paragraph:

1) Choose Insert > Media > Gallery and select a theme.

2) Select an object with a single click, right-click on the object, and choose Insert as
Background > Page or > Paragraph.

Modifying, handling, and positioning graphics

LibreOffice provides many tools for cropping, resizing, modifying, filtering, and positioning graphics;
wrapping text around graphics; and using graphics as backgrounds and watermarks. These tools
are described in relevant chapters of the other guides. Some sophisticated adjustments of the
graphics are best done in an image manipulation program and the results brought into LibreOffice,
rather than using LibreOffice’s built-in tools.

Exporting images

If you need to make complex adjustments to the image, or want to save the image for use in
another document, you can export the image directly from your document. Right-click on the image
to select it and open the context menu. Then choose Save to open the Image Export dialog.
Depending on the original format of the image, LibreOffice will let you save the picture in many
different formats. Give a name to the image, select the desired image format in the File Type filter
list, and click Save. Before the image is finally saved another dialog (not shown) opens, where you
can choose various image size and format options.

Compressing images

If you insert a large image in your document and resize it to fit into the layout of the page, the
complete full size original image is stored in the document file to preserve its content, resulting in a
large document file to store or send by mail.

If you can accept some loss of quality of the image rendering or want to resize it, you can
compress or resize the image object to reduce its data volume while preserving its display in the
page layout.

@ Compress Image

Resolution

Comp

@ . & Reduceimage resolution
90 = width: 665 - px
PNG Compression Height: 443 - px
9 Resolution: |96 v| DPI

a

Interpolation: |Lanczos

Image Information
Type: Jpeg image
Actual dimensions: 16.67 "% 11.11 " (1600 x 1067 px)
Apparentdimensions: 6.93" x4.62 " at 230 DPI
Image size: 102 kiB

Calculate New Size: | 7?7

Help oK i Cancel

Figure 4: Compressing an image
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Right-click to select the image and open the context menu. Then choose Compress to open the
Compress Image dialog (Figure 4). Note that the Calculate button updates the image information
on the dialog on each parameter set you change. Click OK to apply the compression settings. If
the resulting image is not acceptable, press Ctr/+Z to undo and choose another compression
setting. For more information, see the Help.

Managing the LibreOffice Gallery

Graphics in the Gallery are grouped by themes, such as Arrows, Diagrams, and People. You can
create other groups or themes and add your own pictures or find extensions containing more
graphics. Click on a theme to see its contents displayed in the Gallery window.

You can display the Gallery in Icon View (Figure 3) or Detailed View (Figure 5), and you can hide
or show the Gallery by clicking on the Sidebar’s Hide button.

Gallery x

New Theme...

] Homepage
[ My Theme
] New Theme

[ School & University
[ Sounds

_ =  People il

Title |

Artist-Femalel
Artist-Female2
Artist-Malel

Artist-Male2

j«f OF °F i 1 o)

BusinessPerson-Femalel

BusinessPerson-Female2

BusinessPerson-Female3

[ < N <

Figure 5: Gallery in Detailed View

£7] Note

In some installations, only the My themes theme is customizable, although new
themes can be added as explained in “Adding a new theme to the Gallery” on page
10. The locked themes are easily recognizable by right-clicking on them; the only
available option in the context menu is Properties.

Adding objects to the Gallery

You may wish to add to the My Theme folder in the Gallery any images that you use frequently, for
example, a company logo. You can then easily insert these graphics into a document later.

1) Right-click on the My Theme folder and select Properties from the context menu.
2) Inthe theme’s Properties dialog, click the Files tab (Figure 6).

Adding objects to the Gallery | 9



New Theme...

: # Properties of My Theme

] Computers & General | Files

B Diagram  Delete

B Environi Rename i : : : :

M Finance FEile type }:All Files= (*.bmp;*.dxF;*.emf;*.eps;*.gif;* | = _ Find Files...
-

EH omeps. <No Files> _ Add

B People

B School & University Add All

B Sounds T

Figure 6: Gallery Properties dialog
To add several files at once:

1) Click the Find Files button.

2) The Select path dialog (not shown) opens. You can enter the path for the file’s directory in
the Path text box, or you can navigate to locate the file's directory.

3) Click the Select button to start the search. A list of graphic files is then displayed in the
Properties dialog. You can use the File type drop-down list to limit the files displayed.

4) To add all of the files shown in the list, click Add All. Otherwise, select the files to add and
then click Add (hold down either the Shift key or the Ctrl key while clicking on the files).

To add a single file:
1) Click Add to open the Gallery dialog.

2) Use the navigation controls to locate the image to add to the theme. Select it and then click
Open to add it to the theme.

3) Click OK on the Properties dialog to close it.

Deleting images from the Gallery
To delete an image from a theme:

1) Right-click on the name of the image file or its thumbnail in the Gallery.

2) Click Delete in the context menu. A message appears, asking if you want to delete this
object. Click Yes.

Z Note

Deleting the name of a file from the list in the Gallery does not delete the file from the
hard disk or other location.

Adding a new theme to the Gallery
To add a new theme to the Gallery:

1) Click the New Theme button above the list of themes (Figure 5).

2) Inthe Properties of New Theme dialog, click the General tab and type a name for the new
theme.

3) Click the Files tab and add images to the theme, as described earlier.

Deleting a theme from the Gallery
To delete a theme from the Gallery:
1) Goto Insert > Media > Gallery.
2) Select from the list of themes the theme you wish to delete.
3) Right-click on the theme, then click Delete on the context menu.

10 | Deleting a theme from the Gallery



Location of the Gallery and the objects in it

Graphics and other objects shown in the Gallery can be located anywhere on your computer’s hard
disk, on a network drive, or other removable media. When you add graphics to the Gallery, the files
are not moved or copied; the location of each new object is simply added as a reference.

In a workgroup, you may have access to a shared Gallery (where you cannot change the contents
unless authorized to do so) and a user Gallery, where you can add, change, or delete objects.

The location of the user Gallery is specified in Tools > Options > LibreOffice > Paths. You can
change this location, and you can copy your gallery files (SDV) to other computers.

Gallery contents provided with LibreOffice are stored in a different location. You cannot change this
location.

Z Note

Gallery themes can be packed for distribution through the LibreOffice extensions
framework. In that case, the location of the graphic files is determined by the extension
settings. To get more gallery themes, visit the LibreOffice extensions website at
http://extensions.libreoffice.org.

Creating an image map

An image map defines areas of an image (called hotspots) with hyperlinks to web addresses, other
files on the computer, or parts of the same document. Hotspots are the graphic equivalent of text
hyperlinks (described in Chapter 12). Clicking on a hotspot causes LibreOffice to open the linked
page in the appropriate program (for example, the default browser for an HTML page; LibreOffice
Calc for an ODS file; a PDF viewer for a PDF file). You can create hotspots of various shapes and
include several hotspots in the same image.

To use the image map editor:
1) Inyour LibreOffice document, click on the picture in which you want to create the hotspots.
2) Choose Edit > ImageMap from the menu bar. The ImageMap Editor (Figure 7) opens.
3) Select the hotspot drawing shape from the toolbar and draw on the image.
4) Use the fields in the dialog (described below) to define the hotspots and links necessary.

5) Click the Apply icon “ to apply the settings.
6) When done, click the Save icon to save the image map to a file, then click the X in the
upper right corner to close the dialog.

The main part of the dialog shows the image on which the hotspots are defined. A hotspot is
identified by a line indicating its shape.
The toolbar at the top of the dialog contains the following tools:

« Apply button: click this button to apply the changes.

* Load, Save, and Select icons.

» Tools for drawing a hotspot shape: these tools work in exactly the same way as the
corresponding tools in the Drawing toolbar.

* Edit, Move, Insert, Delete Points: advanced editing tools to manipulate the shape of a
polygon hotspot. Choose the Edit Points tool to activate the other tools.

» Active icon: toggles the status of a selected hotspot between active and inactive.
* Macro: associates a macro with the hotspot instead of just associating a hyperlink.
* Properties: sets the hyperlink properties and adds the Name attribute to the hyperlink.

Creating an image map | 11
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Figure 7: The dialog to create or edit an image map
Below the toolbar, specify for the selected hotspot:

* Address: the address pointed to by the hyperlink. You can also point to an anchor in a
document; to do this, write the address in this format:
file:///<path>/document_name#anchor_name

* Text: type the text that you want to be displayed when the mouse pointer is moved over the
hotspot.

* Frame: where the target of the hyperlink will open: pick among _blank (opens in a new
browser window), _self (opens in the active browser window), _top or _parent.

‘:@:‘ Tip

The value _self for the target frame will usually work just fine. It is therefore not
recommended to use the other choices unless absolutely necessary.

Using LibreOffice’s drawing tools

You can use LibreOffice’s drawing tools to create graphics such as simple diagrams using
rectangles, circles, lines, text, and other predefined shapes. You can also group several drawing
objects to make sure they maintain their relative position and proportion.

You can place the drawing objects directly on a page in your document, or you can insert them into
a frame.

You can also use the drawing tools to annotate photographs, screen captures, or other illustrations
produced by other programs, but this is not recommended because:

* You cannot include images in a group with drawing objects, so they may not remain aligned
in your document.

» If you convert a document to another format, such as HTML, the drawing objects and the
graphics will not remain associated; they are saved separately.

In general, if you need to create complex drawings, it is recommended to use LibreOffice Draw,
which includes many more features such as layers, styles, and so on.

12 | Using LibreOffice’s drawing tools



Creating drawing objects

To begin using the drawing tools, display the Drawing toolbar (Figure 8) by clicking View >
Toolbars > Drawing or by clicking on the Show Draw Functions icon & on the standard toolbar.

‘::‘ Tip

If you are planning to use the drawing tools repeatedly, you can tear off (undock) this
toolbar and move it to a convenient place it as a floating toolbar in the window.

B/~ 2¢2rnrmeocle@Al ¢ @« % 8 0lfana
bt S S S S S S S S N S R S B N
1 23 4 5 6 7 8 910111213 14 15 16 17 18 19 20 21 22 23 24

1 Select 7 Rectangle 13 Right Triangle 19 Flowchart

2 Insert Line 8 Rectangle, Rounded 14 Insert Basic Shapes 20 Callouts

3 LinesandArrows 9  Square 15 Symbol 21 Insert Text Box
4 Curve, Freehand 10 Ellipse 16 Arrow 22 Fontwork

5 Curve, Bézier 11 Circle 17 Star 23 Points

6 Polygon 12 Isosceles Triangle 18 Callout 24 Toggle extrusion

Figure 8: The Drawing Toolbar

To use a drawing tool:

1) Click in the document where you want the drawing to be anchored. You can change the
anchor later, if necessary.

2) Choose the tool from the Drawing toolbar (Figure 8). The mouse pointer changes to a

drawing-functions pointer -- and the normal Formatting Toolbar changes to Drawing
I

Object Properties toolbar (Figure 9).

3) Move the cross-hair pointer to the place in the document where you want the graphic to
appear and then click and drag to create the drawing object. Release the mouse button.
The selected drawing function remains active, so that you can draw another object of the
same type.

4) To cancel the selected drawing function, press the Esc key or click on the Select icon (the
arrow) on the Drawing toolbar.

5) You can now change the properties (fill color, line type and weight, anchoring, and others)
of the drawing object using either the Drawing Object Properties toolbar (Figure 9) or the
choices and dialogs reached by right-clicking on the drawing object.

Setting or changing properties for drawing objects
To set the properties for a drawing object before you draw it:

1) On the Drawing toolbar (Figure 8), click the Select tool.

2) On the Drawing Object Properties toolbar (Figure 9), click on the icon for each property and
select the value you want for that property.

3) For more control, or to define new attributes, you can click on the Area or Line icons on the
toolbar to display detailed dialogs.

Setting or changing properties for drawing objects | 13
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1 Line Color 8 Wrap Off 15 Align 22  Group

2  Arrow Style 9 Page Wrap 16  Bring to Front 23  Enter Group

3 Line Style 10 Optimal Page Wrap 17  Forward One 24  Exit Group

4  Line Width 11  Wrap Left 18 Back One 25 Ungroup

5 Area Style / Filling 12  Wrap Right 19 Send to Back 26 Insert Caption
6  Fill Color 13  Wrap Through 20  To Foreground

7  Anchor 14 Rotate 21  To Background

Figure 9: Drawing Object Properties toolbar

The default you set applies to the current document and session. It is not retained when you close
the document or close Writer, and it does not apply to any other document you open. The defaults
apply to all the drawing objects except text objects.

To change the properties for an existing drawing object:
1) Select the object.
2) Continue as described above.

You can also specify the position and size, rotation, and slant and corner radius properties of the
drawing object:

1) Right-click on the drawing object and then choose Position and Size from the context
menu. The Position and Size dialog is displayed.

2) Choose any properties, as required.

Resizing a drawing object

An object is resized in a similar way to an image. Select the object, click on one of the eight
handles around it and drag it to its new size. The object will be scaled up or down.

When you grab the corner handle of an object and drag it, LibreOffice will resize proportionately. If
you also press the Shift key, the resizing will not keep object proportions. Conversely, if you grab
one of the edges, LibreOffice will scale disproportionately in the direction perpendicular to the
edge; if you also press the Shift key, LibreOffice will scale proportionately.

For more sophisticated control of the size of the object, choose Format > Frame and Object >
Properties from the Menu bar. Use the Type tab to set the position and size independently. If the
Keep ratio option is selected, then the two dimensions change so that the proportion is
maintained, resulting in a scaled resizing.

Grouping drawing objects
Grouping drawing objects makes it easier to handle several objects as a single entity, while
preserving their relative sizes and positions.

To group drawing objects:

1) Select one object, then hold down the Shift key and select the others you want to include in
the group. The bounding box expands to include all the selected objects.

2) With the objects selected, hover the mouse pointer over one of the objects and choose
Format > Group > Group from the Menu bar, or click the Group icon on the Drawing
Object Properties toolbar, or right-click and choose Group > Group from the pop-up menu.

14 | Grouping drawing objects



£7 Note

You cannot include an embedded or linked graphic in a group with drawing objects.

Using Fontwork

With Fontwork you can create graphical text art objects to make your work more attractive. There
are many different settings for text art objects (line, area, position, size, and more), so you have a
large choice.

Fontwork is available with each component of LibreOffice, but you will notice small differences in
the way that each component displays it.

Creating a Fontwork object
1) On the Fontwork toolbar (View > Toolbars > Fontwork) or the Drawing toolbar (View >

~

Toolbars > Drawing), click the Fontwork Gallery icon fg|, or choose Insert > Media >
FontWork Gallery.

2) Inthe Fontwork Gallery (Figure 10), select a Fontwork style, then click OK. The Fontwork
object will appear in your document. Notice the colored squares around the edge (indicating
that the object is selected) and the yellow dot; these are discussed in “Moving and resizing
Fontwork objects” on page 19.

Fontwork Gallery |5

Select a Fontwork style:
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Figure 10: The Fontwork Gallery
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3) Double-click the object to edit the Fontwork text (see Figure 11). Select the text and type
your own text in place of the black Fontwork text that appears over the object.

Figure 11: Editing Fontwork text

4) Click anywhere in a free space or press Esc to apply your changes.

Editing a Fontwork object

Now that the Fontwork object is created, you can edit some of its attributes. To do this, you can use
the Fontwork toolbar, the Formatting toolbar, or menu options as described in this section. If the
selected Fontwork object is a 3-D object, you can also use the 3D-Settings toolbar.

Using the Fontwork toolbar

Make sure that the Fontwork toolbar, shown in Figure 12, is visible. If you do not see it, go to View
> Toolbars > Fontwork. Click on the different icons to edit Fontwork objects.

Fontwork -
vom o= M-

Figure 12: The floating Fontwork toolbar

?}_ . Fontwork Shape: Edits the shape of the selected object. (— - x
You can choose from a palette of shapes. { vo-am =AY |
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Figure 13: Fontwork toolbar
showing palette of shapes

. Fontwork Same Letter Heights: Changes the height of characters in the object. Toggles
A8  between normal height (some characters taller than others, for example capital letters, d,
h, | and others) and all letters the same height.

Forfomorts SO0,

Figure 14: Left: normal letters; right: same letter heights
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= . Fontwork Alignment: Changes the alignment of characters. = - A .
ol Choices are left align, center, right align, word justify, and
stretch justify. The effects of the text alignment can only be Left Aligs
seen if the text spans over two or more lines. In the stretch 2o
justify mode, all the lines are filled completely. Right Align
Word Justify

Stretch Justify

’&9 . Fontwork Character Spacing: Changes the character spacing AV .
and kerning in the object. Select from the choices in the drop-
down list. |

Tight

® MNormal
Loose
Very Loose
Custom...

v Kern Character Pairs

Using the Formatting toolbar
Now let us go further and customize the Fontwork object with several more attributes.

Click on the Fontwork object. The Formatting toolbar changes to The Drawing Object Properties
toolbar (Figure 9) when you use Fontwork in Writer.)

The Formatting toolbar provides a large choice of options for customizing your object. These
choices are the same as the ones for other drawing objects. For more information, see the Draw
Guide.

Line options

Line icon: Opens a dialog with three tabs: Line, Line Styles, Arrow Styles. Use the Line tab to
edit the most common properties of the line around the selected Fontwork object, by choosing from
previously-defined attributes including line style, line color, and arrow styles. Use the Lines Styles
and Arrow Styles tabs to edit the properties of line and arrow styles, and define new styles.

Arrow Style icon: Choose from the different arrow styles.
Line Style box: Choose from the available line styles.
Line Width box: Set the width of the line.

Line Color box: Select the color of the line.

Area options
Area icon: Opens a dialog with seven tabs: Area, Shadow, Transparency, Colors, Gradients,
Hatching, Bitmaps.

* Areatab: Choose from the predefined list a color, bitmap, gradient or hatching pattern to fill
the selected object.

* Shadow tab: Set the shadow properties of the selected object.

* Transparency tab: Set the transparency properties of the selected object.

* Colors tab: Modify the available colors or add new ones to appear on the Area tab.

* Gradients tab: Modify the available gradients or add new ones to appear on the Area tab.

* Hatching tab: Modify the available hatching patterns or add new ones to appear on the
Area tab.

Editing a Fontwork object | 17



* Bitmaps tab: Create simple bitmap patterns and import bitmaps, to make them available on
the Area tab.

Area Style | Filling boxes: Select the type of the fill of the selected object. For more detailed
settings, use the Area icon.

Positioning options
Rotate icon: Rotate the selected object manually using the mouse to drag the object.

To Foreground icon: Move the selected object in front of the text.
To Background icon: Move the selected object behind the text.
Alignment icon: Modify the alignment of the selected objects.
Bring to front icon: Move the selected object in front of the others.
Send to back icon: Move the selected object behind the others.
Change Anchor icon: Choose between anchoring options:

* To Page—The object keeps the same position in relation to the page margins. It does not
move as you add or delete text.

» To Paragraph—The object is associated with a paragraph and moves with the paragraph. It
may be placed in the margin or another location.

* To Character—The object is associated with a character but is not in the text sequence. It
moves with the paragraph but may be placed in the margin or another location. This
method resembles anchoring to a paragraph.

* As Character—The object is placed in the document like any character and moves with the
paragraph as you add or delete text before the object.

Ungroup icon: Ungroup a selection of grouped objects, so that they can be managed individually.
Group icon: Group the selected objects, so you can manage them as a single object.

Using menu options

You can use some the choices on the Format menu to anchor, align, arrange, and group selected
Fontwork objects, wrap text around them, and flip them horizontally and vertically.

You can also right-click on a Fontwork object and choose many of the same options from the pop-
up menu. The pop-up menu also provides quick access to the Line, Area, Text, and Position and
Size dialogs. The Text dialog offers only a few options for Fontwork objects and is not discussed
here. On the Position and Size dialog, you can enter precise values for size and position. For more
information on all of these menu options, see the Draw Guide.

Using the 3D-Settings toolbar

If the selected Fontwork object is a 3-D object, you can also use the options on the 3D-Settings
toolbar. You can also change a 2-D Fontwork object into a 3-D object (or change a 3-D object into
a 2-D object) by clicking the Extrusion On/Off icon on the 3D-Settings toolbar. For more
information, see the Draw Guide.

3D-Settings s
% S H-F- -9 -w-8 -
I | |
Egrﬁg?fn Depth ‘ Surface
: Direction 3D Color
Tilt Down, Up, oo
Left, Right Lighting

Figure 15: 3D-Settings toolbars
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Moving and resizing Fontwork objects

When you select a Fontwork object, eight colored squares (known as handles) appear around the
edge of the object, as shown below. You can drag these handles to resize the object.

A yellow dot also appears on the object. This dot may be o o o
along an edge of the object, or it may be somewhere else;
in the example on the right. If you hover the pointer over
this yellow dot, the pointer turns into a hand symbol. You
can drag the dot in different directions to distort the object.

Hovering the pointer over other parts of the object turns the
pointer into the usual symbol for dragging the object to
another part of the page.

m]

For precise control of the location and size of the object, use the Position and Size areas
of the Type tab in the Properties dialog.
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