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Why use LibreOffice Draw?

Most full-featured software packages offer a choice of at least three or four different ways to get a 
task done. Using LibreOffice to design eye-catching posters is a perfect case in point. You could 
certainly do the job in Writer, and perhaps, with some concentrated creativity, in Calc as well. But if 
you want full, detailed control over each of the many objects that can find their way into your 
document, then Draw is definitely your tool of choice.

Creating a new Draw document

To get started, you need to create a new Drawing. On the top menu bar, click on File > New > 
Drawing (or press Ctrl+N on the keyboard). You will see a blank workspace surrounded by the 
menu bars specific to Draw. 

Figure 1: The Open New File menu

Now you need to set up your page. Click on Format > Page to open the Page Setup dialog. There 
you can choose from pre-set page formats (the default is 8.5"x11" Letter), or manually set your 
own width and height. Importantly, you can also choose either portrait (where the height is greater 
than the width) or landscape (where the width is greater than height) orientation. Page margins 
aren't usually a significant factor in poster creation.

Note

Even if you're not planning to print this poster directly from your PC, perhaps 
because it's destined for digital display or because it's going to be too large for 
your personal printer to handle, you've still got to tell LibreOffice its dimensions and
orientation to ensure that your file will be interpreted accurately no matter who – or 
what – will end up reading it. 

For our example, we'll use the default (Letter) setting, but change the orientation to landscape.
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Figure 2: The Page Setup dialog

Now is a good time to give your document a name and save it. Click on File > Save As to display 
the Save dialog, which will prompt you to enter a name and a save location and to choose a file 
type. We'll stick with the default file type (ODF Drawing) which will append a .odg suffix to the 
filename.

Remember to regularly save any document you're working on because you really can never predict
when a software or system crash might strike, destroying any work you might have done since the 
last backup. Saving by pressing Ctrl+S is a quick shortcut that needn't interrupt your workflow.

Choosing and editing a background image

Most posters are built from the background out. The image or object you choose for your 
background will act as a kind of anchor, influencing the tone, color scheme, style, and balance of 
everything else you add.

Using a pre-existing image
If you decide to use an existing image for your background, make sure that its resolution is high 
enough for printing, and that its shape at least closely resembles that of your poster. Let's explore 
those two points:

Resolution. A bitmapped image is made up of a grid of tiny pixels, each contributing to the 
overall appearance. However, if an image was created using a relatively small number of pixels
(say, 640 by 480), it can't be stretched to cover a large canvas (either virtual or print) without 
compromising its quality – often taking on an unattractive fuzzy look. Therefore, you should be 
careful to select only an image whose resolution is high enough for your project's needs.
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Proportion. Even if your image is large enough, it must also have a compatible shape. Suppose
your poster is meant to fill a regular letter-sized page, 8.5" x 11", but the image you'd like to use
for your background is a square. What can be done?

• Once you've inserted your image into your document (by clicking on Insert > Picture > 
From File...), you could select the image by clicking on it, and then drag one of its handles, 
stretching the picture until it fills the canvas. But that, in many cases, will badly distort the 
image, leaving it effectively unusable.

• Alternatively, if your image resolution will allow it, you could increase the image size until it 
covers the canvas even along its short side, with the overhang of its long side effectively 
cropped from the image (you will still see it in your document during design, but nothing 
beyond the page borders will print). Do this by right-clicking on your image to display the 
context menu, select Position and Size, then click the Keep ratio box and adjust either the
width or height value (whichever value you don't change will automatically be updated to 
protect the original proportions). If you can live with a partially cropped image, this might be 
a workable solution.

Tip
If neither of those solutions works, you may be forced either to find a new image, 
or opt instead for a predefined LibreOffice shape.

Figure 3: Position and Size dialog

Tip
If your poster is going to be printed professionally, you might want your background 
to extend a little bit beyond the page borders to allow for bleed (to avoid ugly white 
lines at the edges of your poster).
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Using a predefined LibreOffice shape
LibreOffice Draw makes adding basic shapes to your document easy. But it also offers countless 
combinations of colors and textures to fill those shapes. A predefined shape could work perfectly to
set the tone for your poster, for which, as it will likely be right angled, a rectangle would be the most
obvious shape to use for a background. 

Tip
If you're ever unsure what an icon does, hover your mouse above it without clicking 
and, usually, a brief description will appear.

Click once on the rectangle icon from the Drawing menu bar at the bottom of the Draw window, 
then click (holding down the mouse button) on the page where you would like the first corner of the
rectangle to go. In our case, that might be the bottom-left corner of the page. Drag your mouse to 
the position you'd like for the opposite corner of the rectangle (the top right corner of the page, 
perhaps) and release the mouse button. You can always adjust the shape to better fit the page 
later.

The default area fill of a predefined shape is usually a solid color like blue. However, that's just a 
suggestion. You can change that color for any one of millions of others.

Tip

You can edit a shape's color by right-clicking on it and selecting Area from the 
context menu that appears. Choose from the selection of basic colors under the 
Area tab; or select the Colors tab, click Edit, and choose from the vertical range 
bar, color box, or numeric value fields of LibreOffice's color picker.

Beyond color, you can also edit the texture of the area fill. Right-click on your shape and, again, 
choose Area from the context menu. This time however, select one of the Gradients, Hatching,  
or Bitmaps tabs.

• Gradients. Under the Gradients tab, you can select from a number of multicolored 
patterns, using the Properties fields on the left to edit both the colors and the way they 
interact. Feel free to experiment until you find the combination of elements that is most 
pleasing and best reflects the mood you're trying to create.

• Hatching. The Hatching tab allows you to apply a line-based design to your shape. You 
can configure the spacing, angle, color, and type of each of these designs.

• Bitmaps. The Bitmaps tab allows you to create your own fill pattern using the Pattern 
Editor, or to choose from a list of predefined patterns.

Choosing and editing a background image 7



Working with layers

So now you've got a page with a simple background (in our case, we chose this LibreOffice-
themed image):

Figure 4: The background image

Of course, the background is only one element of your poster. Even if it does anchor everything 
that's yet to come, it should not overwhelm everything else on the page. In our case, the colors are
so bright and the text so prominent, that there's a real risk any new objects or text that we add to 
the poster might simply be drowned out. We'll have to find a way to filter our background.

Let's create a new rectangle (click on the Rectangle icon from the Drawing toolbar) and size it so 
that it completely covers the background image. Make sure that the new rectangle is highlighted, 
and right-click on it, displaying the context menu. Select Area and then click on the Transparency 
tab (see Figure 6. Make sure Transparency is selected (rather than the default No Transparency) 
and assign a percentage value: "10%" would give only 10% visibility to the objects beneath our 
rectangle while at "90%" the rectangle would nearly disappear, leaving the image below almost 
fully visible. We'll go with "20%" for the time being.

Now, while still in the Area dialog, select the Colors tab and choose the color you'd like to use for 
your rectangle/filter. You will notice that the drop-down menu of colors includes around ten shades 
of gray. These can be very useful to fine-tune the intensity of your filtering layer. We've chosen 
blue-gray. Here's how it now looks:

Working with layers 8



Figure 5: Background with a filtering layer

Figure 6: Transparency dialog
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Tip

Once your project has more than one object – and especially when objects cover 
each other – you should take special care to ensure that the object you've 
highlighted is the one you're actually aiming to edit. Use the Tab key to cycle through
all the page objects until you've highlighted the one you're after. 

Adding banner text

What's a poster without a message? There are many ways that LibreOffice Draw can help. For one
approach, try clicking on the Fontwork Gallery. 

Figure 7: Fontwork Gallery 
(left-most icon)

The gallery contains some particularly fancy text layout templates called favorites (favorite 1, 
favorite 2, and so on.). For our poster, we chose favorite 14. Clicking on it causes some formatted 
text to appear in the document. Double-click to substitute your own text. 

While the text is highlighted, you can use many of Draw's formatting tools to change the way it's 
presented. So for instance, you could click on the Area fill drop-down menu at the top of the screen
(by default, it will be labeled “color”) to select hatching or gradient patterns for your text instead of a
solid color. If you're happy using a solid color, you could click on the drop-down menu to the right of
Area fill to select a different color.

One particularly useful (and fun) option is extrusion, which adds 3D depth to objects and 
characters. Clicking on the Extrusion icon (a few icons to the right of the Fontwork Gallery) while 
your Font Gallery text is highlighted causes the extrusion editing icons to be automatically added 
to the bottom menu bar. Play around with the various options: you can edit the depth of the 
extrusion, its horizontal and vertical tilt, and lighting.

You can also adjust the size and proportions of your text by dragging the edge handles apart or 
together.

Tip
After making changes to the size or position, you can automatically reset your text's 
preferred horizontal or vertical position on the page by clicking on the alignment 
menu icon on the top menu bar.

Adding objects

Let's liven up our poster just a bit. How about splashing an attention-grabbing banner across the 
top right corner? Click on the rectangle icon on the bottom menu bar, then – just as we did when 
creating the filter/layer rectangle – click (without releasing the mouse button) where you'd like the 
first corner to go. Drag your mouse to the place you'd like the rectangle's opposite corner to go and
release the mouse button.

Double-click anywhere on the new rectangle to permit text entry (we typed “Free Classes!”). 

Tip
Text added directly to a shape or object will remain permanently associated and 
synchronized with it.
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Then, using the standard tools, set the fill color, line (border), and transparency attributes and the 
text font/size. You can also manually resize the rectangle to better fit the text inside by dragging its 
handles.

Tip

When working on a document containing multiple objects, the Arrange tool (right-
click on an object and select Arrange from the context menu) is hugely important: by
choosing from the four options Arrange provides, you can change an object's 
appearance by "moving" it either "above" or "below" other overlapping objects.

How can you now rotate this shape? Right-click on the rectangle and, from the context menu that 
appears, select Position and Size and click on the Rotation tab. Entering a value of 315 next to 
the Angle label will rotate the rectangle clockwise by 45 degrees (which is the same as counter-
clockwise by 315 degrees).

Now drag the rectangle towards the top-right corner of the page until its two ends extend beyond 
the edges of the page. It will look a bit odd in the design view, but once the document is printed or 
exported as a final image, you shouldn't see anything beyond the page borders.

Figure 8: Top corner in design view

Finally, let's add another object with some more detailed text. Instead of a rectangle, click on the 
Ellipse icon that's right next to it. You can resize, add some text, and edit the size, color, and 
transparency of the ellipse just as you did for the rectangle.

We can give our ellipse a 3D look to make it really stand out using Extrude. Make sure that the 
Extrude icon (located a few icons to the right of the Fontwork Gallery icon) is active – if the 
ellipse is highlighted, then the icon should be active. If the icon is not, you can activate it by clicking
on it.

When Extrude is available, seven child icons will appear to the right of (or, in some cases, 
immediately below) the Extrude icon. These icons allow you to adjust the tilt, rotation, lighting and 
extrude depth of your object.

So we're done. It will certainly never win any awards for its design, but the final version of our 
poster does help illustrate the techniques we've been discussing:
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Figure 9: The final product!

Adding block text

Although we haven't used this in our poster, Draw also allows you to insert text using a simple 
border-less text frame by clicking once on the large “T” on the bottom menu bar (towards the left) 
and then clicking (and not releasing) your mouse again where you'd like one corner of your text to 
go. Move your mouse to the opposite corner of where you imagine your text going and release it. 
Then, before clicking anywhere else, start typing text.

From this point, by highlighting all or some of your text, you will have access to all the formatting 
tools of a word processor. However, because Draw is a design package, there is one significant 
difference: by clicking anywhere outside your text frame and then clicking again within it, you will 
be able to move (by dragging with your mouse), resize, or cut/paste the frame as a whole within 
your page.

Exporting the document as a PDF

Naturally, once you've finished your document you can print it. However you might need to send 
your poster to a professional printing company or display it digitally as part of a web site. This 
presents a potential problem: while you can count on any healthy pair of human eyes to function 
pretty much the same way and see your poster just the way you do, computers are far less 
reliable. Tiny incompatibilities between operating systems or software configurations can cause 
one system to render an image quite differently than you might have intended.
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The easiest and safest solution is to export your poster as a PDF file. In most cases, all you will 
need to do is click on the PDF icon on the top menu bar (it's usually next to the printer icon). The 
PDF dialog will ask you for a file name and a location where the file should be saved, and you're 
done.

Sometimes you will need greater control over the way LibreOffice converts your file to a PDF. 
Perhaps, for instance, you want to use a non-standard graphic resolution or compression scheme, 
or perhaps you'd like to limit access to the embedded text. Settings covering these issues and 
more can be accessed by clicking on File > Export as PDF.

Note

Adobe's Portable Document Format (PDF) was specifically designed to create a 
file format that would be understood and viewed identically on any operating 
system and using any software viewer. It has become the industry standard for 
sharing many classes of files.
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