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Note for Mac users

Some keystrokes and menu items are different on a Mac from those used in Windows and Linux. 
The table below gives some common substitutions for the instructions in this chapter. For a more 
detailed list, see the application Help.

Windows or Linux Mac equivalent Effect

Tools > Options menu 
selection

LibreOffice > Preferences Access setup options

Right-click Control+click Opens a context menu

Ctrl (Control) z (Command) Used with other keys

F5 Shift+z+F5 Opens the Navigator

F11 z+T Opens the Styles and Formatting window

Documentation for LibreOffice is available at http://www.libreoffice.org/get-help/documentation
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Selecting options affecting LibreOffice

This section covers some of the settings that apply to all the components of LibreOffice and are of 
interest to users of Impress. Other general options are discussed in Chapter 2, Setting Up 
LibreOffice in the Getting Started guide.

1) Click Tools > Options (LibreOffice > Preferences on a Mac). The list on the left-hand 
side of the Options – LibreOffice dialog (Figure 1) varies depending on which component 
of LibreOffice is open. The illustrations in this chapter show the list as it appears when 
Impress is open.

2) Click the expansion marker (+ or triangle) by LibreOffice on the left-hand side. A list of 
subsections drops down.

Figure 1: LibreOffice options

Note
The Revert button (not shown in the illustrations in this chapter) has the same effect 
on all pages of the Options dialog. It resets the options to the values that were in 
place when you opened LibreOffice.

User Data options
Impress uses the first and last name stored in the User Data to fill in the Created by and Modified 
by fields in document properties, the optional Author field used in the footer of a presentation, and 
the name associated with comments. If you want your name to appear, then do the following:

1) In the Options dialog, click LibreOffice > User Data (Figure 2).

2) Fill in the form on the LibreOffice – User Data page or delete any existing incorrect 
information.
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Figure 2: User Data

Print options
On the LibreOffice – Print page, set the print options to suit your default printer and your most 
common printing method.

You can change these settings at any time, either through the Options dialog or during the printing 
process (by clicking the Options button on the Print dialog). See Chapter 10, Printing, E-mailing,  
Exporting, and Saving Slide Shows for more information about the options available.

Color options
On the LibreOffice – Colors page (Figure 3), you can specify colors used in LibreOffice 
documents. You can select a color from a color table, edit an existing color, or define new colors. 
These colors are stored in your color selection palette and are then available in all components of 
LibreOffice.

You can also define colors within Impress by choosing Format > Area on the menu bar, or through 
the Line and Filling toolbar, but those colors will not be available to other components of 
LibreOffice.

Figure 3. Defining colors for use in LibreOffice
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Appearance options
On the LibreOffice – Appearance page (Figure 4), you can specify which items are visible and 
the colors used to display various elements of the user interface. The only option specific to 
Impress (and Draw) is the color of the grid points. Scroll down in the page until you find 
Drawing/Presentation.

To change the default color for grid points, click the down-arrow by the color and select a new color 
from the pop-up dialog.

If you wish to save your color changes as a color scheme, click Save, type a name in the Save 
scheme dialog, then click OK.

Figure 4. Changing the color of grid points in Impress and Draw

Choosing options for Impress

In the Options dialog, click the expansion marker to the left of LibreOffice Impress on the left-
hand side. A list of subsections for Impress drops down (Figure 5).

Figure 5: Options for Impress
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General options
In the Options dialog, click LibreOffice Impress > General (Figure 6).

Figure 6: Selecting general options for Impress

Text objects section

• Allow quick editing: sets Impress to immediately switch to text editing mode when you 
click on a text object. You can also activate the text editing mode through the Allow Quick 

Editing icon  on the Options toolbar (Figure 7). If the Options toolbar is not open, then 
go to View > Toolbars > Options on the main menu.

Figure 7: Options toolbar

• Only text area selectable: sets Impress to select a text frame when you click on text. In 
the area of the text frame that is not filled with text, an object behind the text frame can be 

selected. You can also activate this mode through the Select Text Area Only icon  on 
the Options toolbar.

New document section

• Start with Wizard: when selected Impress starts with the Presentation Wizard when 
creating a new presentation using File > New > Presentation or one of the other methods 
of creating a presentation.

Settings section

• Use background cache: sets Impress to use the cache for displaying objects on the 
master page. This setting speeds up the display. Uncheck this option if you want Impress to 
draw the background every time you display a slide.

• Copy when moving: automatically creates a copy when you move, rotate or resize an 
object while holding down the Ctrl key (⌘ key for Mac). The original object will remain in its 
current position and size.
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• Objects always movable: lets you move an object with the Rotate tool enabled. If this 
option is not selected, the Rotate tool can only be used to rotate an object.

• Unit of measurement: determines the unit of measurement used in presentations.

• Tab stops: defines the spacing between tab stops.

Start presentation section

• Always with current page: specifies that a presentation starts with the current slide. 
Uncheck this option to always start a presentation with the first page.

Compatibility section
The settings in this section are valid for the current presentation only.

• Use printer metrics for document formatting: applies printer metrics for printing and for 
formatting the display on the screen. Some formatting will depend on the printer selection 
or default printer on your computer and may vary if the presentation is moved to a different 
computer. If this option is not checked, a printer-independent layout is used for screen 
display and printing.

• Add spacing between paragraphs and tables (in current document): calculates the 
paragraph spacing in Impress exactly as Microsoft PowerPoint does. Microsoft PowerPoint 
adds the bottom spacing of a paragraph to the top spacing of the next paragraph to 
calculate the total spacing between both paragraphs. Impress normally uses only the larger 
of the two spacings.

View options
In the Options dialog, click on LibreOffice Impress > View (Figure 8).

Figure 8: Specifying view options for Impress

• Rulers visible: displays the rulers at the top and the left of the Workspace area.

• Guides when moving: displays dotted guides that extend beyond the box containing the 
selected object and which cover the entire work area, helping you position the object when 

moving it. You can also use the Helplines When Moving icon  on the Options toolbar 
(Figure 7 on page 7).

• All control points in Bézier editor: displays the control points of all Bézier points if you 
have previously selected a Bézier curve. If this option is not selected, only the control 
points of the selected Bézier points will be visible.

• Contour of each individual object: displays the contour line of each individual object 
when moving the object. This enables you to see if single objects conflict with other objects 
in the target position. If you do not select this option, Impress displays only a square 
contour that includes all selected objects.
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Grid options
The Grid page defines the grid settings for Impress. Using a grid helps you determine the exact 
position of your objects. You can also set this grid in line with the snap grid.

In the Options dialog, click LibreOffice Impress > Grid (Figure 9).

Figure 9: Specifying grid options for Impress

Grid section

• Snap to grid: activates the snap function. If this option is selected, but you want to move or 
create individual objects without snapping to the grid, press the Ctrl key to deactivate Snap 

to grid whilst moving the individual object. You can also use the Snap to Grid icon  on 
the Options toolbar.

• Visible grid: displays grid points on the screen. These points will not display or print as 
part of a presentation.

Resolution and Subdivision sections
This section allows you to set the unit of distance for the spacing between horizontal and vertical 
grid points and subdivisions (intermediate points) of the grid.

• Synchronize axes: applies any changes to the Resolution or Subdivision settings to both 
axes of object movement.

Snap section

• To snap lines: snaps the edge of an object to the nearest snap line when you release the 

mouse button. You can also use the Snap to Snap Lines icon  on the Options toolbar.

• To the page margins: aligns the contour of the graphic object to the nearest page margin. 
The cursor or a contour line of the graphic object must be within snap range. You can also 

use the Snap to Page Margins icon  on the Options toolbar.

• To object frame: aligns the contour of the graphic object to the border of the nearest 
graphic object. The cursor or a contour line of the graphic object must be within snap 

range. You can also use the Snap to Object Border icon  on the Options toolbar.
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• To object points: aligns the contour of the graphic object to the points of the nearest 
graphic object. The cursor or a contour line of the graphic object must be within snap 

range. You can also use the Snap to Object Points icon  on the Options toolbar.

• Snap range: defines the snap distance between the mouse pointer and the object contour. 
Impress snaps to a snap point if the mouse pointer is nearer than the distance selected in 
the Snap range box.

Snap position section

• When creating or moving objects: restricts graphic objects vertically, horizontally or 
diagonally (45°) when creating or moving them. You can temporarily deactivate this setting 
by pressing the Shift key.

• Extend edges: controls how a square or circle is drawn with the drawing tool.  When this 
option is selected, when the Shift key is pressed before before pressing the mouse button a 
square is drawn equal to the longer side of a rectangle. This also applies to the ellipse tool: 
when the Shift key is pressed before you press the mouse button a circle will be drawn 
based on the longest diameter of the ellipse. When the Extend edges option is not 
selected, a square or a circle will be created based on the shorter side or diameter.

• When rotating: restricts the rotation of graphic objects within the rotation angle that you 
select. If you want to rotate an object outside of the defined angle, press the Ctrl key (Shift 
key on Mac) when rotating. Release the key when the desired rotation angle is reached.

• Point reduction: defines the angle for point reduction. When working with polygons, you 
might find it useful to reduce their editing points.

Print options
In the Options dialog, click on LibreOffice Impress > Print (Figure 10). See Chapter 10, Printing, 
E-mailing, Exporting, and Saving Slide Shows for more information about the options available.

Figure 10: Specifying print options for Impress
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Customizing the user interface

Customizing menu font
If you want to change the menu font from that supplied by LibreOffice to the system font for your 
operating system, do this:

1) Choose Tools > Options > LibreOffice > View.

2) Check Use system font for user interface and click OK.

Customizing menu content
You can customize the menus in Impress by adding and rearrange items on the menu bar, adding 
items to menus, and other changes.

1) Choose Tools > Customize to open the Customize dialog (Figure 11).

Figure 11. Menus page of the Customize dialog

2) Make sure the Menus page is open.

3) In the Save In drop-down list, select whether to save this customized menu in LibreOffice 
Impress or for a presentation.

4) In the section LibreOffice Impress Menus, select from the Menu drop-down list the menu 
that you want to customize.

5) To customize the selected menu, click on the Menu or Modify buttons. You can also add 
commands to a menu by clicking on the Add button. These actions are described in the 
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following sections. Use the up and down arrows next to the Entries list to move the 
selected menu item to a different position.

6) When you have finished making all your changes, click OK to save them.

Creating a new menu
To create a new menu:

1) In the Menus page of the Customize dialog box, click New to open the New Menu dialog 
(Figure 12).

2) Type a name for your new menu in the Menu name box.

Figure 12: Adding a new menu

3) Use the up and down arrow buttons to move the new menu into the required position on 
the menu bar.

4) Click OK to save. The new menu now appears on the list of menus in the Customize 
dialog. It will appear on the menu bar itself after you save your customizations.

After creating a new menu, you need to add some commands to it, as described in “Adding a
command to a menu” on page 13.

Modifying existing menus
To modify an existing menu:

1) Select it in the Menu list and click the Menu button to open a list of modifications: Move, 
Rename, Delete. Only Move is available in the list. Rename and Delete are not available 
for the menus supplied by LibreOffice.

2) To move a menu (such as File), select Menu > Move to open the dialog (Figure 13). Use 
the up and down arrow buttons to move the menu into the required position.

3) To move submenus (such as File | Send), select the main menu (File) in the Menu list and 
then, in the Menu Content section of the Customize dialog (Figure 11), select the submenu 
Send in the Entries list and use the arrow keys to move it up or down in the sequence.
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Figure 13: Moving a menu

In addition to renaming a menu, you can specify a keyboard shortcut that allows you to select a 
menu command when you press Alt key plus an underlined letter in a menu command.

1) Select a menu or menu entry.

2) Click the Modify button in the Customize dialog (Figure 11) and select Rename.

3) Add a tilde (~) in front of the letter that you want to use as an accelerator. For example, to 
select the Save All command by pressing Alt+V, enter Sa~ve All.

Caution Be careful when creating new shortcuts. In the example above, if the File menu is 
not already open, then pressing Alt+V opens the View menu. If another menu is 
open, Alt+V might activate some other command.

Adding a command to a menu
You can add commands to menus and to menus you have created.

1) In the Customize dialog (Figure 11), select the menu in the Menu list and click the Add 
button.

2) In the Add Commands dialog (Figure 14), select a category and then the command, and 
click Add. The dialog remains open, so you can select additional commands.

Figure 14: Adding a command to a menu
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3) When you have finished adding commands, click Close.

4) In the Customize dialog, you can use the up and down arrow buttons to arrange the 
commands in your preferred sequence.

Modifying menu entries
In addition to changing the sequence of entries on a menu or submenu, you can add submenus, 
rename or delete the entries, and add group separators.

1) Select the menu or submenu in the Menu list near the top of the Customize dialog (Figure
11 on page 11).

2) Select the entry in the Entries list under Menu Content.

3) Click the Modify button and choose the required action from the drop-down list of actions. 
Most of the actions are self-explanatory. Begin a group adds a separator line after the 
highlighted entry.

Figure 15. Toolbars page of the Customize dialog

Customizing toolbars
You can customize toolbars in several ways, including choosing which icons are visible, and 
locking the position of a docked toolbar, as described in Chapter 1, Introducing LibreOffice of the 
Getting Started guide. This section describes how to create new toolbars and add other icons 
(commands) to the list of those available on a toolbar.
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To open the customization dialog (Figure 15), do any of the following:

• On the toolbar, click the arrow at the end of the toolbar and choose Customize Toolbar.

• Choose View > Toolbars > Customize from the menu bar.

• Choose Tools > Customize > Toolbars tab from the menu bar.

To customize toolbars:

1) Make sure the Toolbars page is open.

2) In the Save In drop-down list, select whether to save this customized toolbar for Impress or 
for a selected presentation.

3) In the LibreOffice Impress Toolbars section, select from the Toolbar drop-down list the 
toolbar that you want to customize.

4) Click the Toolbar button on the right to display a drop-down list of options for customizing 
the toolbar.

5) To display or hide commands, select or deselect the checkboxes in the Toolbar Content – 
Commands section.

6) To change the position of commands on a toolbar, select a command and click the up and 
down arrows to the right of the lists.

7) When you have finished customizing a toolbar, click OK to save your changes.

Creating a new toolbar
To create a new toolbar:

1) Choose Tools > Customize > Toolbars from the main menu to open the Customize dialog 
(Figure 15).

2) Make sure the Toolbars page is open.

3) Click on New to open the Name dialog (Figure 16).

4) Type a name for the new toolbar and select from the Save In drop-down list where to save 
this new menu: for Impress or for a selected document.

Figure 16: New toolbar dialog

The new toolbar now appears on the list of toolbars in the Customize dialog. After creating a new 
toolbar, you need to add some commands to it, as described below.

Adding commands to a toolbar
To add commands to a new toolbar or to customize an existing toolbar as follows:

1) On the Toolbars page of the Customize dialog (Figure 15), select the toolbar from the 
Toolbar drop down list and click the Add button. The Add Commands dialog (Figure 14 on 
page 13) opens and is the same dialog used for adding commands to menus.

2) Select a Category and then the Command from the relevant list.

3) Click on Add. The dialog remains open, so you can select additional commands.
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4) When you have finished adding commands, click Close. If you insert an item which does 
not have an associated icon, the toolbar will display the full name of the item; the next 
section describes how to choose an icon for a toolbar command.

5) On the Customize dialog, you can use the up and down arrow buttons to arrange the 
commands in your preferred sequence.

6) When you have finished making changes, click OK to save.

Choosing icons for toolbar commands
Toolbar buttons usually have icons, not words, on them, but not all of the commands have 
associated icons.

To choose an icon for a command:

1) Select the command and click on Modify > Change icon to open the Change Icon dialog 
(Figure 17).

2) Scroll through the available icons and select the one you want to use.

3) Click OK to assign it to the command.

Figure 17: Change Icon dialog

To use a custom icon, create it in a graphics program and then import it into LibreOffice by clicking 
the Import button on the Change Icon dialog. Custom icons must be 16 x 16 or 26 x 26 pixels in 
size and cannot contain more than 256 colors.

Customizing keyboard shortcuts 
The Appendix to this guide lists the default keyboard shortcuts supplied with Impress. You can 
change these defaults or add new shortcuts. You can assign shortcuts to standard Impress 
functions or your own macros and save them for use with Impress only or with the LibreOffice 
suite.

Caution

Be careful when reassigning predefined shortcut keys used in your operating system 
or LibreOffice. Many key assignments are universally understood shortcuts, such as 
F1 for Help, and are always expected to provide certain results. Although you can 
easily reset the shortcut key assignments to LibreOffice defaults, changing some 
common shortcut keys can cause confusion, frustration and possible data loss or  
corruption, especially if other users share your computer.
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For example, suppose you wish to assign a shortcut key to easily insert a duplicate slide in your 
presentation. You could assign the Insert key as a logical shortcut for this purpose, as described 
below.

1) Choose Tools > Customize.

Figure 18: Customizing keyboard shortcuts

2) On the Customize dialog, open the Keyboard page (Figure 18).

3) As the shortcut key assignment is only relevant with Impress and not LibreOffice, select 
Impress at the upper right corner of the Keyboard page.

4) Select Insert in the Functions - Category list and Duplicate Slide in the Function list.

5) Select the shortcut key Insert in the Shortcut keys list and click the Modify button at the 
upper right.

6) Click OK to accept the change. Now the Insert key will insert a duplicate slide immediately 
after the currently selected slide.

Note

All existing shortcut keys for the currently selected Function are listed in the Keys 
selection box. Since there was no currently assigned shortcut for the Insert > 
Duplicate Slide function the Keys list was empty. If it had not been, and you wished 
to reassign a shortcut key combination that was already in use, you would first have 
to Delete the existing Key.

Shortcut keys not available for reassignment are greyed out in the listing on the 
Customize dialog, such as F1 and F10.
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Saving changes to a file
Changes to the shortcut key assignments (and other configurations) can be saved in a keyboard 
configuration file for use at a later time. This allows you to create and apply different configurations 
as the need arises.

To save keyboard shortcuts to a file:

1) After making your keyboard shortcut assignments, click the Save button on the Customize 
dialog.

2) In the Save Keyboard Configuration dialog box, select All files from the Save as Type list.

3) Enter a name for the keyboard configuration file in the File name box, or select an existing 
file from the list. If you need to, browse to find a file from another location.

4) Click Save. A confirmation dialog will appear if you are about to overwrite an existing file; 
otherwise there will be no feedback and the file will be saved.

Loading a saved keyboard configuration
To load a saved keyboard configuration file and replace your existing configuration, click the Load 
button on the Customize dialog, and then select the configuration file from the Load Keyboard 
Configuration dialog.

Resetting the shortcut keys
To reset all of the keyboard shortcuts to their default values, click the Reset button on the 
Customize dialog. Use this feature with care as no confirmation dialog will be displayed and the 
defaults will be set without any further notice or user input.

Running macros from key combinations
You can also define shortcut key combinations that will run macros. These shortcut keys are strictly 
user-defined; none are built in. For information on macros, see Chapter 13, Getting started with 
macros in the Getting Started guide.

Adding functionality with extensions

An extension is a package that can be installed into LibreOffice to add new functionality.

Although individual extensions can be found in different places, the official LibreOffice extension 
repository is at http://extensions.libreoffice.org/. Some extensions are free of charge; others are 
available for a fee. Check the descriptions to see what licenses and fees apply to the ones that 
interest you.

Installing extensions
To install an extension, follow these steps:

1) Download an extension and save it anywhere on your computer.

2) In LibreOffice, select Tools > Extension Manager from the main menu.

3) In the Extension Manager dialog (Figure 19), click Add.

4) A file browser window opens. Find and select the extension you want to install and click 
Open. The extension begins installing. You may be asked to accept a license agreement.

5) When the installation is complete, the extension is listed in the Extension Manager dialog.
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Tip
To get extensions that are listed in the repository, you can open the Extension 
Manager and click the Get more extensions online link.

Note
To install a shared extension, you need write access to the LibreOffice installation 
directory. 

Figure 19: Extension Manager dialog

Using extensions
This section describes some of the more important and popular extensions to Impress. In each 
case, you need to first install the extension as described in the previous section.

Presenter Console
This is bundled with most installations of LibreOffice and provides extra control over slide shows 
(presentations). For example, the presenter has the ability to see the upcoming slide, the slide 
notes, and a presentation timer, while the audience only sees the current slide. The Presenter 
Console displays the elements in three easily changeable views:

• The first view displays the current slide, including the effects, and the upcoming slide.

• The second view shows notes for the speaker in large, clear, and scalable type, plus the 
current and upcoming slide.

• The third view is a slide sorter view with the slide thumbnails.

The Presenter Console is only available for use if you have a second display connected to your 
computer. See Chapter 9, Slide Shows for more information about using the Presenter Console.

Note
The Presenter Console works only on an operating system that supports multiple 
displays and only when two displays are connected (one may be the laptop’s built-in  
screen).
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Professional Template Pack II
Provides more than 120 templates for Writer, Calc, and Impress. Available in several languages. 
After you have installed this extension, you will find the templates under File > New > Templates 
and Documents.

Presentation Minimizer
Reduces the file size of the current presentation. Images are compressed and data that is no 
longer needed is removed. Can also optimize the image quality size. Presentations designed for 
screen or projector do not require the same high quality as presentations designed for print.

Template Changer
Adds two new items to the File > Templates menu that allow you to assign a new template to a 
folder of presentations. All styles and formatting will be loaded from that template and the 
document will behave as if it were created using that template.
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