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What are styles? Why use them?

A style is a set of formats that you can apply to selected elements in a document to quickly change 
their appearance. Applying a style often means applying a group of formats at the same time.

Many people manually format spreadsheet cells and pages without paying any attention to styles 
and are accustomed to formatting documents according to physical attributes. For example, for the
contents of a cell you might specify the font family, font size, and any character formatting such as 
bold or italic.

Styles are logical attributes. Using styles means that you stop applying attributes and 
characteristics individually (for example, font size 14pt, Times New Roman, bold, centered) and 
start using a style, for example Title. Applying attributes and characteristics is time-consuming and 
prone to errors. In contrast, using a style, which has been defined to include the attributes and 
characteristics you want, will save you time and give greater consistency in formatting.

Styles also make major formatting changes easy. For example, you may decide to change the 
appearance of all subtotals in a spreadsheet to be 10 pt Arial instead of 8 pt Times New Roman 
after you have created a 15-page spreadsheet. You can change all of the subtotals in the 
document by simply changing the properties for the subtotal style.

Calc also provides page styles, as described below.

You can modify the attributes of the supplied styles and define as many new styles as you require. 
Creating, modifying, and accessing styles is explained in the following sections.

Direct formatting and Style formatting
Direct formatting (also called manual formatting) overrides styles, and you cannot remove the 
direct formatting by applying a style to it.

To remove manual formatting, select the text, right-click, and choose Format > Clear Direct 
Formatting from the context menu, or select the text and press Ctrl+M, or select the text and click 

the Clear Direct Formatting icon  in the Standard toolbar.

Calc style types

While some components of LibreOffice offer many style types, Calc offers only two: cell styles and 
page styles. These style types are explained in the following sections.

Cell styles
Cell styles are similar to paragraph styles used in LibreOffice Writer. They are the most basic type 
of style in Calc. Cell styles are used for applying fonts, alignment, borders, background, number 
formats (for example, currency, date, number), and cell protection to format the data in the cells.

A basic range of cell styles is supplied with Calc. These styles are shown on the Styles menu on 
the Menu bar and in the Styles deck of the Sidebar. When you create a new cell style, it is shown 
in the Sidebar. You can also add it to the Styles menu; see Chapter 14, Setting up and 
Customizing, for instructions.

Initially, the basic styles are configured so that if you change the font family of the Default style, 
then all of the other styles, inheriting from it, will change to match.

Page styles
Page styles in Calc are applied to sheets. Although one sheet may print on several pages, only one
page style can be applied to a sheet. If a spreadsheet file contains more than one sheet, then a 
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different page style can be applied to each sheet. For example, a spreadsheet might contain some 
sheets to be printed in landscape orientation and other sheets to be printed in portrait orientation. 

Two page styles are supplied with Calc: Default and Report. Page styles allow you to set page size
and orientation, page margins, headers and footers, borders and backgrounds, and the sequence 
for printing sheets.

Applying cell styles

To apply cell styles in Calc, you can use the Styles menu on the Menu bar, the Styles deck in the 
Sidebar, Fill Format mode, the Apply Style list on the Formatting toolbar, and keyboard shortcuts.

Styles menu
The Styles menu (Figure 1) lists the cell styles supplied with Calc. To apply a cell style, select the 
cell or group of cells to be formatted, and then choose Styles and click on the required style.

Figure 1: The Styles menu

Styles deck in Sidebar
The Styles deck in the Sidebar lists and shows previews of the styles available. If the Sidebar is 
not open, choose View > Styles, or Styles > Manage Styles, or tap the F11 function key to open 
it.

 1) Go to the Styles deck in the Sidebar.

 2) Click the Cell Styles icon on top of the Styles deck to open the list of cell styles. Figure 2 
shows the panel with cell styles visible.

 3) In the spreadsheet, highlight the cell or group of cells where you want to apply a cell style.

 4) Double-click on the cell style name in the Styles deck and the formatting attributes for that 
style are applied to the data contained in the highlighted cells.
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Figure 2: Styles deck in Sidebar, showing cell styles

Fill Format mode
Fill Format mode is useful when you want to apply the same style to many scattered cells.

 1) Go to the Styles deck in the Sidebar (Figure 2).

 2) Select the style you want to apply.

 3) Click the Fill Format Mode  icon in the top right of the Styles deck. The cursor changes 
shape.

 4) Click in each cell where you want to apply the selected style.

 5) When you have finished formatting cells, click the Fill Format Mode icon to disable it.

Note

When Fill Format mode is active, a right-click anywhere in the document cancels the 
last Fill Format action. Be careful not to accidentally right-click and thus cancel any 
formatting actions you want to keep.

Apply Style list
The Apply Style drop-down list is not included by default on the Formatting toolbar in Calc, but you 
can add it as follows:

 1) Right-click on any icon in the Formatting toolbar and select Visible Buttons from the 
context menu (Figure 3).

 2) Click Apply Style. The context menu closes and the Apply Style list appears at the left end 
of the Formatting toolbar.

Figure 3: Adding the Apply Style list to the Formatting toolbar
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To apply a style using the Apply Styles list:

 1) Select a cell or a group of cells in the spreadsheet.

 2) Click the down arrow at the right of the Apply Styles list to open the drop-down menu 
(Figure 4).

 3) Select the required style. The formatting attributes of that style are applied to the selected 
cells.

Figure 4: Applying a style from
the list

Only the styles that are in use are shown on the list. Click More Styles to go to the Styles deck 
where all cell styles are available.

Keyboard shortcuts
You can create keyboard shortcuts to apply commonly-used cell or page styles, including any 
custom styles that you have created. See Chapter 14, Setting up and Customizing, for more 
information.

Applying page styles

The page style applied to a sheet within a spreadsheet is indicated on the Status Bar, as shown in 
Figure 5.

Figure 5: Page style (Default) indicated on Status Bar

To apply a different page style:

 1) Select the sheet to be styled by clicking its sheet tab at the bottom of the window.

 2) Go to the Styles deck in the Sidebar (Figure 2).

 3) In the top of the Styles deck, click the Page Styles icon.

 4) Double-click on the required page style.

Creating new (custom) styles

To create a new (custom) style, follow the procedure described in this section.
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Note

Any new (custom) styles, and any changes to existing styles, apply only to the 
spreadsheet in use. To save new styles in a template, see “Creating a template” on 
page 21 for more information.

 1) Go to the Styles deck in the Sidebar (Figure 2).

 2) To create a new cell style, click the Cell Styles icon, or to create a new page style, click the
Page Styles icon.

 3) Right-click in the Styles deck and select New from the context menu to open either the Cell 
Style dialog or the Page Style dialog.

 4) Use the various tabbed pages in the dialogs to set the attributes for the new style. See “Cell
style attributes” on page 9 and “Page style attributes” on page 16 for more information.

 5) Click OK to close the dialog and save the new style.

Note

Style names are case sensitive. You can define, for example, a style called red and 
another style called Red. Make sure all style names are sufficiently different to prevent 
any confusion.

Cell style attributes
The following attributes are available on the tabbed pages of the Cell Style dialog (Figure 6).

Organizer tab

Figure 6: Cell Style dialog – Organizer tab

• Name – displays the name of the selected style. If you are creating or modifying a custom 
style, enter a name for the style. You cannot change the name of a predefined style.

• Inherit from – you can choose to link the new style to an existing style and then modify 
some of the attributes. If you do this, any change to the parent style’s attributes will affect 
the new style. For example, you could make the styles identical except for the font color; if 
you later change the font family of the parent style, the new style’s family will also change.

• Category – displays the category for the current style. If you are creating or modifying a 
new style, select Custom Styles from the list. You cannot change the category for a 
predefined style.
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• Contains – describes the formatting used in the style.

Numbers tab

Figure 7: Cell Style dialog – Numbers tab

• Category – select a category from the list. Examples: Currency, Date, Number, Text, ....

• Format – select how you want the contents of the selected cell(s) to be displayed. 

When you select Currency as a category, you need to select a currency from the drop-
down list and then select the format to use from the options available for that currency.

The currency format is not dependent on the language that you select in the Language 
box. The default currency format for a cell is determined by the regional settings of your 
operating system.

• Language – specifies the language settings for the selected cells. With the language set to 
the default, Calc automatically applies the number formats associated with the system 
default language. The language setting ensures that date and currency formats are 
preserved even when the document is opened in an operating system that uses a different 
default language setting.

• Options – specify the options for the selected format.

• Decimal places – enter the number of decimal places that you want to display.

• Leading zeroes – enter the maximum number of zeroes to display in front of the decimal
point.

• Negative numbers red – select to change the font color of negative numbers to red.
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• Thousands separator – select to insert a separator between thousands. The type of 
separator (for example, a comma or a space) depends on your language settings.

• Format code – displays the number format code for the selected format. You can also 
enter a custom format.

• Preview field – displays a preview of the current selection.

Font tab

Figure 8: Cell Style dialog – Font tab

• Font – select a font family from the list.

• Style – select the formatting you want to apply, for example Bold or Italic.

• Size – select or enter the font size that you want to apply. For scalable fonts, you can also 
enter decimal values. If you are creating a style that is based on another style, you can 
enter a percentage value or a point value (for example, 2pt or 5pt).

• Language – sets the language that the spelling checker is to use. The spelling checker 
works only when you have installed the corresponding language module. A language entry 
has a check mark in front of it if the spelling checker is activated for that language.

• Features – some fonts offer special features such as Discretionary Ligatures and 
Horizontal Kerning. Click this button to access the Font Features dialog (not shown) to 
select those features.

• Preview – displays a preview of the current selection.
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Font Effects tab

Figure 9: Cell Style dialog – Font Effects tab

• Font color – sets the color for the text. If you select Automatic, the text color is set to 
black for light backgrounds and to white for dark backgrounds.

• Relief – select a relief effect to apply to the text. The Embossed relief makes the 
characters appear as if they are raised above the page. The Engraved relief makes the 
characters appear as if they are pressed into the page.

• Outline – displays the outline of the characters. This effect does not work with every font.

• Shadow – adds a shadow that casts below and to the right of the characters.

• Overlining – select the overlining style that you want to apply. To apply the overlining to 
words only (not the spaces between them), select Individual words.

• Overline color – select the color for the overlining. Automatic matches the font color.

• Strikethrough – select a strikethrough style for the selected text.

• Underlining – select the underlining style that you want to apply. To apply the underlining 
to words only (not the spaces between them), select Individual words.

If you apply underlining to a superscript text, the underlining is raised to the level of the 
superscript. If the superscript is contained in a word with normal text, the underlining is not 
raised.

• Underline color – select the color for the underlining. Automatic matches the font color.

• Individual words – applies the selected effect only to words and ignores spaces.

• Preview – displays a preview of the current selection.
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Alignment tab

Figure 10: Cell Style dialog – Alignment tab

• Text Alignment – sets the alignment options for the contents of the current cell, or the 
selected cells.

• Horizontal – select the horizontal alignment option that you want to apply to the cell 
contents.

• Default – aligns numbers to the right and text to the left.

• Left – aligns the contents of the cell to the left.

• Center – horizontally centers the contents of the cell.

• Right – aligns the contents of the cell to the right.

• Justified – aligns the contents of the cell to the left and to the right cell borders.

• Filled – repeats the cell contents (number and text) until the visible area of the cell is
filled. This feature does not work on text that contains line breaks.

• Distributed – aligns contents evenly across the whole cell. Unlike Justified, it also 
justifies the very last line of text.

• Indent – indents from the left edge of the cell by the amount that you enter.

• Vertical – select the vertical alignment option that you want to apply to the cell contents.

• Default – aligns the cell contents to the bottom of the cell.

• Top – aligns the contents of the cell to the upper edge of the cell.

• Bottom – aligns the contents of the cell to the lower edge of the cell.

• Middle – vertically centers the contents of the cell.

• Justified – aligns the contents of the cell to the top and to the bottom cell borders.

• Distributed – aligns contents evenly across the whole cell. Unlike Justified, it also 
justifies the very last line of text.
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• Text Orientation – defines the text direction of cell contents.

• ABCD wheel – click anywhere in the wheel to define the text orientation. The characters
"ABCD" on the wheel correspond to the new setting.

• Vertically stacked – assigns vertical text orientation for cell contents.

• Degrees – allows you to manually enter the orientation angle.

• Reference edge – specify the cell edge from which to write the rotated text.

• Text Extension From Lower Cell Border – writes the rotated text from the bottom cell
edge outwards.

• Text Extension From Upper Cell Border – writes the rotated text from the top cell 
edge outwards.

• Text Extension Inside Cell – writes the rotated text only within the cell.

• Properties – determine the text flow in a cell.

• Wrap text automatically – wraps text onto another line at the cell border. The number of 
lines depends on the width of the cell. To enter a manual line break, press Ctrl+Enter in 
the cell.

• Hyphenation active – enables word hyphenation for text wrapping to the next line.

• Shrink to fit cell size – reduces the apparent size of the font so that the contents of the 
cell fit into the current cell width. You cannot apply this command to a cell that contains 
line breaks.

• Text direction – choices are Left-to-right, Right-to-left, and Use superordinate object
settings (the settings applied to the preceding cell).

Borders tab

Figure 11: Cell Style dialog – Borders tab
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Sets the border attributes for the selected cells.

• Line Arrangement – select a preset border style or define your own combination by 
clicking in the diagram.

• Line – select the line style, width, and color that you want to apply. The style is applied to 
the borders selected in the preview.

• Padding – specify the amount of space that you want to leave between the border and the 
contents of the cell. You can set each distance (left, right, top, bottom) individually or select 
Synchronize to apply the same padding to all four borders when you enter a new distance.

• Shadow Style – applies a shadow effect to borders. You can specify the position of the 
shadow (top, bottom, right, or left side), the distance it extends, and its color.

Background tab
Click Color to select a color to use as a background for the formatted cells. You can choose from 
several palettes. To change the color, select another one. To remove the background color, select 
None.

Figure 12: Cell Style dialog – Background tab

Cell Protection tab
Protection

• Hide all – hides formulas and contents of the selected cells.

• Protected – prevents the selected cells from being modified. This cell protection only takes 
effect if you also protect the sheet.

• Hide formula – hides formulas in the selected cells.

Print

• Hide when printing – prevents the selected cells from being printed.
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Figure 13: Cell Style dialog – Cell Protection tab

Resetting cell style attributes
The buttons at the bottom of the Cell Style dialog have the following functions:

• Reset – returns to last saved settings for all tabs of this dialog.

• Standard – returns to the settings in the template for the current dialog tab only.

• Cancel – cancels any changes made (to all tabs in the dialog) since the last save of this 
dialog (by clicking OK).

• OK – saves all changes made (to all tabs in the dialog).

Page style attributes
The following attributes are available on the tabs of the Page Style dialog (Figure 14).

Organizer tab
This tab is similar to the Organizer tab for the Cell Style dialog.

• Name – displays the name of the selected style. If you are creating or modifying a custom 
style, you can enter or change a name of the style. You cannot change the name of a 
predefined style.

• Category – displays the category of the current style. If you are creating a new style, select
Custom Styles from the list.  You cannot change the category for a predefined style.

• Contains – describes the formatting used in the current style.

Page tab
You can define page layouts for single and multiple-page spreadsheets, as well as page 
numbering and paper formats.

• Paper Format – select from a list of predefined paper sizes, or define a custom paper 
format.

• Format – select a predefined paper size, or create a custom format by entering the 
dimensions for the paper in the Height and Width boxes.

• Width – displays the width of the selected paper format. To define a custom (user) 
format, enter a width here.

• Height – displays the height of the selected paper format. To define a custom (user) 
format, enter a height here.

• Orientation: 

• Portrait – displays and prints the spreadsheet with the paper oriented vertically.
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• Landscape – displays and prints the spreadsheet with the paper oriented 
horizontally.

Figure 14: Page Style dialog

• Paper tray – select the paper source for your printer. You can assign different paper 
trays to different page styles. For example, you can assign a different tray for the first 
page style in the spreadsheet and load the tray with your company letterhead paper.

• Margins – specify the amount of space to leave between the edges of the paper and the 
spreadsheet contents.

• Left/Inner – the space between the left edge of the page and the spreadsheet. If you 
are using Mirrored page layout, the space between the inner edge of the paper and the 
spreadsheet. You may want to have a wider space as the Left/Inner margin if you will be
punching or binding the pages.

• Right/Outer – the space between the right edge of the paper and the spreadsheet. If 
you are using Mirrored page layout, the space between the outer edge of the paper and
the spreadsheet.

• Top – the space between the upper edge of the paper and the spreadsheet.

• Bottom – the space between the lower edge of the paper and the spreadsheet.

• Layout settings – select the page layout style to use for the spreadsheet.

• Page layout:

• Right and left – both odd (right) and even (left) pages have the same margins on all 
four sides.

• Mirrored – odd and even pages with inner and outer margins as specified. Use this 
layout if you want to bind the printed pages like a book. Enter the binding space as 
the Inner margin.
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• Only right – To specify different (but not mirrored) layouts for odd and even pages, 
define separate page styles. This one is for right (odd) pages.

• Only left – To specify the layout for left (even) pages, choose this setting.

• Page numbers – select the page numbering format to use for the page style. Typically 
this will be 1,2,3 or a,b,c or i,ii,iii.

• Table alignment:

• Horizontal – centers the cells horizontally on the printed page.

• Vertical – centers the cells vertically on the printed page.

Borders and Background tabs
See “Borders tab” and “Background tab” in “Cell style attributes” above for information on how to 
set the borders and background for page styles. Page styles can have a bitmap background or a 
color.

Header and Footer tabs
Adds a header or footer to the page style. A header is an area in the top page margin where you 
can add text or graphics. A footer is a similar area in the bottom page margin. See Chapter 6, 
Printing, Exporting, and Emailing, for details.

Sheet tab
Specifies the elements to be included in the printout of all sheets with the page style. Additionally, 
you can set the print order, the first page number, and the page scale. See Chapter 6, Printing, 
Exporting, and Emailing, for details.

Managing styles

Modifying styles
1) Go to the Styles deck in the Sidebar and click the icon for the type of style you want to 

modify.

2) Right-click on the name of the style and select Modify from the context menu to open 
either the Cell Style dialog (Figure 6) or the Page Style dialog (Figure 14).

3) Make the necessary changes to the style attributes. For more information on style 
attributes, see “Cell style attributes” on page 9 and “Page style attributes” on page 16.

4) Click OK to save the changes and close the dialog.

Note

The Modify command is unavailable if one or more sheets are protected, even if the 
style to be modified is being used in an unprotected sheet.

Renaming styles
You can rename custom styles, but not the styles supplied with Calc.

 1) Go to the Styles panel in the Sidebar (Figure 2) and click the icon for the type of style you 
want to rename.

 2) Right-click on the style you want to rename and select Modify from the context menu. The 
Cell Styles or Page Styles dialog opens.

 3) On the Organizer tab, rename the style and click OK.
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Deleting styles
You can delete custom styles, but not the styles supplied with Calc.

 1) Go to the Styles deck in the Sidebar (Figure 2) and click the icon for the type of style you 
want to delete.

 2) Right-click on the style you want to delete and select Delete from the context menu.

 3) Select Yes on the warning message, if displayed. Any data in a cell or a sheet in the 
spreadsheet that used the deleted style will revert to the Default style.

Hiding and showing cell styles
You can shorten the list of cell styles by hiding some of them. Only styles that are not being used in
the spreadsheet can be hidden.

 1) Go to the Styles deck in the Sidebar and click on the Cell Styles icon.

 2) Right-click on an unused cell style and select Hide from the context menu. The style is then
moved to the Hidden Styles category in the Styles deck.

To show hidden cell styles:

 1) Go to the Styles deck in the Sidebar.

 2) Click on the drop-down list at the bottom of the panel and select Hidden Styles from the 
list.

 3) Right-click on the hidden style you want to show and select Show from the context menu.

Filtering the list of styles
You can filter the list of styles as follows:

 1) Go to the Styles deck in the Sidebar.

 2) Click on the drop-down list at the bottom of the panel.

 3) Select the category of styles to display in the Styles deck:

• Hierarchical – lists the styles in their hierarchical relationship, for example Heading 1 
and Heading 2 under Heading, or Accent 1, Accent 2, Accent 3 under Accent.

• All Styles – lists all the styles that are available in Calc and in the spreadsheet, except 
for hidden styles.

• Hidden Styles – lists all the styles that have been hidden in the spreadsheet.

• Applied Styles – lists only the styles that have been applied to the spreadsheet.

• Custom Styles – lists only the user-defined styles defined for the spreadsheet.

What is a template? Why use one?

A template is a model that you use to create other documents in a standard format. For example, 
you can create a template for invoices that has your company logo and address at the top of the 
page. This means that any new spreadsheets (invoices) created from this template will then have 
the company logo and address on the first page of the spreadsheet.

Templates can contain anything that regular documents can contain, such as text, graphics, styles, 
and user-specific setup information such as measurement units, language, default printer, and 
toolbar and menu customization.

All documents in LibreOffice are based on templates. You can create, or download and install, as 
many templates as you wish. If you do not specify a template when you start a new spreadsheet, 
that new spreadsheet is then based on the default template for spreadsheets that is included with 
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Calc. This default template consists of a blank spreadsheet which you can customize to your 
needs and then, if you wish, use as a basis to create a custom default template.

Using a template to create a spreadsheet

A new installation of LibreOffice may not include any spreadsheet templates, but you can create 
your own (see “Creating a template” on page 21) or install templates obtained from other sources 
(see “Adding templates obtained from other sources” on page 23).

When you do have a spreadsheet template available, you can create a new spreadsheet from it 
using either the Templates dialog or the LibreOffice Start Center.

Creating a spreadsheet from the Templates dialog
To use a template to create a spreadsheet:

 1) From the Menu bar, choose File > New > Templates, or click the small arrow next to the 
New icon and select Templates, or press Ctrl+Shift+N. The Templates dialog (Figure 15) 
opens.

 2) From the Filter lists at the top of the Templates dialog, select Spreadsheets and the 
category of template you want to use. All the templates in that category are then listed on 
the page, as shown in Figure 15.

 3) Select the required template and click Open, or double-click the selected template. A new 
spreadsheet based on the template opens in Calc.

In the spreadsheet, the template it is based upon is listed in File > Properties > General. The 
connection between the template and the spreadsheet remains until the template is modified and, 
the next time that the spreadsheet is opened, you choose not to update it to match the template.

Figure 15: Templates dialog, showing a selected template

Creating a spreadsheet from a template in the Start Center
You can create a spreadsheet from the Template view of the LibreOffice Start Center, which is 
visible when no other document is open. (See Chapter 1, Introduction.)

Click the Templates button in the left pane and icons are displayed in the Start Center for all 
available LibreOffice templates. The button also offers a drop-down list to select the templates of a 
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given type of document. If you select the Calc Templates option on the list, the available 
spreadsheet templates are displayed in the Start Center. Click on the required template to create a 
new document based on that template.

Creating a template

You can easily create a template from any spreadsheet:

 1) Open a new or existing spreadsheet that you want to use as a base for the template.

 2) Add any necessary pre-defined content that you want to appear in a spreadsheet each time
you use the new template, for example company logo and name, company information, 
page numbers, and so on. Delete any information that you do not want in the template.

 3) Create or modify the cell and page styles that you want to use in the template.

 4) From the Menu bar, choose File > Templates > Save as Template, or press Shift+F11. The
Save As Template dialog (Figure 17) opens, displaying the existing template categories and
a name box.

 5) Type a name for the new template and select the required template category. You can also 
choose to make this the default template (see “Setting the default template” on page 24 for 
more information).

 6) Click Save to save the new template.

Figure 16: Save As Template dialog

Note

Although the Save as Template dialog shows no document type when saving a new 
template of any type, the template will appear on the correct tab (Spreadsheets, in this
case) when you return to the Templates dialog.

It is unnecessary to save or do anything further with the spreadsheet file you have 
been using to create the new template. It can be safely closed without saving.
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Editing a template

You can edit a template’s styles and content, and then, if you wish, you can reapply the template’s 
styles to spreadsheets that were created from that template. You cannot reapply content.

Figure 17: Templates dialog – Editing templates

To edit a template:

 1) From the Menu bar, choose File > Templates > Manage Templates, or press Ctrl+Shift+N, 
to open the Templates dialog.

 2) Navigate to the template that you want to edit. Right-click to open the context menu and 
choose Edit (see Figure 17). The template opens in Calc.

 3) Edit the template as you would edit any other spreadsheet. To save the changes, choose 
File > Save from the Menu bar, or choose File > Save As Template to save the edited 
template as a new template.

Updating styles from a changed template
If you make any changes to a template and its styles, the next time you open a spreadsheet that 
was created before you changed the template, a confirmation message is displayed.

 1) Click Update Styles to apply the changed styles in the template to the spreadsheet.

 2) Click Keep Old Styles if you do not want to apply the changed styles in the template to the 
spreadsheet.

Caution

If you select Keep Old Styles, the confirmation message will not appear again the 
next time you open the spreadsheet using the same changed template. Although the 
template is still listed under File > Properties > General, the spreadsheet is no longer
connected to the template, so it will not update. You can still import styles manually 
from the template, but to reconnect the spreadsheet to the template, you will have to 
copy it into an empty document based on the template.
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Adding templates obtained from other sources

You can get to the official LibreOffice template repository by using the Browse online templates 
button in the lower left of the Templates dialog, as shown in Figure 18, or by typing 
https://extensions.libreoffice.org/templates in your browser’s address bar.

On other websites you may find collections of templates that have been packaged into extension 
(.OXT) files. These are installed a little differently, as described below.

Figure 18: Getting more templates for LibreOffice

Installing individual templates
You can import and add templates to your collection as follows:

 1) Find and download the template you want to use, as described in the previous section.

 2) Open the Templates dialog and click the Import icon near the bottom right.

 3) In the pop-up dialog, select the category where you want to store the template. (You can 
change this later, as described in “Moving a template” on page 26.)

 4) A file browser opens. Navigate to the location of the downloaded template on your 
computer.

 5) Select the template and click Open. After import, the template becomes available in the 
Templates dialog.

Tip

You can manually copy new templates into the template folders. The location varies 
with your computer’s operating system. To learn where the template folders are stored 
on your computer, go to Tools > Options > LibreOffice > Paths.

Installing collections of templates
The Extension Manager provides an easy way to install collections of templates that have been 
packaged as extensions. Follow these steps:

 1) Download the extension package (.OXT file) and save it anywhere on your computer.

 2) In LibreOffice, select Tools > Extension Manager from the Menu bar, or press Ctrl+Alt+E. 
In the Extension Manager dialog, click Add to open a file browser window.

 3) Find and select the package of templates you want to install and click Open. The package 
begins installing. You may be asked to accept a license agreement.

 4) When the package installation is complete, restart LibreOffice. The templates are available 
for use through File > Templates > Manage Templates and File > New > Templates and 
the extension is listed in the Extension Manager.

See Chapter 14, Setting up and Customizing, for more about the Extension Manager.

Tip

Some extensions are packaged as .ZIP files.
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Setting the default template

If you create a new spreadsheet using File > New > Spreadsheet on the Menu bar, Calc creates 
the document from the default template for spreadsheets. You can set any template as the default 
template. You can also reset the default template to the Calc default template.

Setting a template as the default
Most default settings, such as page size and page margins, can be changed but those changes 
normally apply only to the spreadsheet you are working on. To make those changes the default 
settings for spreadsheets, you need to replace the default Calc template with a new one.

You can set any template displayed in the Templates dialog to be the default for that document 
type:

 1) From the Menu bar, choose File > Templates > Manage Templates or press Ctrl+Shift+N.

 2) In the Templates dialog, open the category containing the template that you want to set as 
the default.

 3) Right-click on the template and click the Set As Default option (see Figure 17). The 
template is now indicated by a green check mark in the upper left.

The next time you create a spreadsheet by choosing File > New, by clicking the New icon in the 
Standard toolbar, or by pressing Ctrl+N, it will be created from this template.

Resetting the default template
To set the default spreadsheet template back to the default template supplied with Calc:

 1) In the Templates dialog, click the Settings icon on the bottom left (Figure ).

 2) Point to Reset Default Template on the drop-down menu, and click Spreadsheet. The 
green check mark is removed from the template.

This choice does not appear unless a custom template has been set as the default, as described in
the previous section.

Figure 19: Resetting the default template for spreadsheets

You can also reset the default template as follows:

 1) Go to the Templates dialog and open the category containing the template you set as 
default. It is indicated by a green check mark.

 2) Right-click on this template and select Reset Default from the context menu. The next time
that you create a new spreadsheet, it will be created using the Calc default template.
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Note

Resetting the default template back to the Calc default template is only available if the 
default has been changed previously.

Organizing templates

LibreOffice can manage only templates that are in its template folders (categories), although you 
can create a spreadsheet from a template that is not in one of these folders. You can create new 
template folders and use them to organize your templates and import templates into these folders. 
For example, you might have one template folder for sales templates and another for invoice 
templates. You can also export templates.

Tip

The location of template folders in LibreOffice depends on the operating system of 
your computer. If you want to know where the template folders are located, go to 
Tools > Options > LibreOffice > Paths.

To begin, choose File > Templates > Manage Templates, or press Ctrl+Shift+N, to open the 
Templates dialog.

Creating a template category
1) Click the Settings button in the lower left of the Templates dialog.

2) Click New Category on the context menu (see Figure 20).

3) In the pop-up dialog (not shown), type a name for the new category and click OK.  The new
category now appears in the list of categories.

Figure 20: Creating a new category

Note

You cannot create a sub-category inside a template category.

Deleting a template category
You cannot delete template categories supplied with LibreOffice. Nor can you delete any 
categories added by the Extension Manager unless you first remove the extension that installed 
them.

However, you can delete a category that you created:
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 1) Click the Settings button on the Templates dialog and select Delete Category from the 
context menu (see Figure 20).

 2) Select the category to be deleted in the Delete Category dialog (not shown) and click OK.

 3) Select Yes in the confirmation dialog to confirm the deletion.

 4) Calc displays a warning dialog if it is unable to delete the category.

Moving a template
To move a template from one template category to another:

 1) Open the Templates dialog and select the template you want to move.

 2) Click the Move icon near the bottom of the dialog, select the destination category from the 
popup dialog (Figure 21), and click OK. The selected template is moved to the folder. You 
can also create a new category into which to move the template.

Figure 21: Moving a template to another category

Deleting a template
You cannot delete templates supplied with LibreOffice. Nor can you delete any templates installed 
by the Extension Manager except by removing the extension that installed them. You can only 
delete templates that you have created or imported.

 1) From the Filter drop-down lists at the top of the Templates dialog, select the category that 
contains the template you want to delete.

 2) Right-click on the template that you want to delete to open the context menu and click 
Delete (Figure 17).

 3) A message box appears and asks you to confirm the deletion. Click Yes.

Exporting a template
The easiest way to send a template to someone else, or to store it on a network, is to export it:

 1) Open the Templates dialog and find the template that you want to export.

 2) Select the template and click the Export icon.

 3) The Select Folder dialog opens. Navigate to the location where you want to export the 
template and click Select Folder. You can also rename the template.
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Note

Exporting a template does not remove it from the Templates dialog. The action places 
a copy of the template in the location you specify.
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