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Introduction

This chapter describes some common customization that you may wish to carry out.

You can customize menus, toolbars, and keyboard shortcuts in LibreOffice, add new menus and 
toolbars, and assign macros to events. However, you cannot customize context (right-click) menus.

Other customization are made easy by extensions that you can install from the LibreOffice website 
or from other providers.

Note

Since LibreOffice 5.1, the menu bars in Writer, Calc, and Impress have been 
reorganized to improve the usability of the application. The most used application 
commands were put together in the Styles, Sheets, and Slide menus, respectively.

Note

Customization to menus and toolbars can be saved in a template or file. To do so, first 
save them in a document and then save the document as a template as described in 
Chapter 3, Using Styles and Templates.

Customizing menu content

In addition to changing the menu font (described in Chapter 2, Setting up LibreOffice), you can add
and rearrange categories on the menu bar, add commands to menus, and make other changes.

To customize menus:

 1) Choose Tools > Customize to display the Customize dialog. Choose the Menus page 
(Figure 1).

Figure 1: The Menus page of the Customize dialog
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 2) In the upper left drop-down list, choose whether to save this changed menu for the 
application (for example, LibreOffice Writer) or for a selected document (for example, 
SampleDocument.odt).

 3) In the section LibreOffice [name of the program (example: Writer)] Menus, select from 
the Menu drop-down list the menu that you want to customize. The list includes all the main
menus as well as submenus (menus that are contained under another menu). For example,
in addition to File, Edit, View, and so on, there is File | Send and Edit | Changes. The 
commands available for the selected menu are shown in the left part of the dialog.

 4) To customize the selected menu, browse the left part of the dialog, where each line is a 
command. You can narrow the search by either typing the command in the upper left 
Search box or selecting the Category in the drop-down list.

 5) Once the command found click on the right arrow at the center of the dialog box to add the 
command to the selected menu on the right. Use the up and down arrows on the far right to
move the selected menu item to a different position.

 6) When you have finished making all your changes, click OK to save them.

Creating a new menu
In the Menus page of the Customize dialog, click on the plus sign (+) to display the New Menu 
dialog (Figure 2).

 1) Type a name for your new menu in the Menu name box.

 2) Use the up and down arrow buttons to move the new menu into the required position on the
menu bar.

 3) Click OK to save.

The new menu now appears on the list of menus in the Customize dialog. (It will appear on the 
menu bar itself after you save your customizations.)

After creating a new menu, you need to add some commands to it, as described in “Adding a 
command to a menu” on page 6.

Figure 2: Adding a new menu

Modifying existing menus
To modify an existing menu, either user-made or inbuilt, select it in the Menu list and click the 
Modify button to drop down the Rename command. Proceed to enter a new name for the 
command to be displayed in the menu. To move a menu (such as File), use the up and down 
arrows on the right.
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To move submenus (such as File | Send), select the main menu (File) in the Menu list and then, in 
the Menu Content section of the dialog, select the submenu (Send) in the Entries list and use the 
arrow keys to move it up or down in the sequence. Submenus are easily identified in the Entries list
by a small black triangle on the right hand side of the name.

In addition to renaming, you can allocate a letter in a custom menu’s name, which will become 
underlined, to be used as a keyboard shortcut, allowing you to select that menu by pressing Alt+ 
that letter. Existing submenus can be edited to change the letter which is used to select their 
default shortcut.

 1) Select a custom menu or a submenu in the Menu drop-down list.

 2) Click the Menu button and select Rename.

 3) Add a tilde (~) in front of the letter that you want to use as an accelerator. For example, to 
select the Send submenu command by pressing S (after opening the File menu using 
Alt+F), enter ~Send. This changes it from the default d.

Note

It is possible to use a letter already in use in the menu list (for example, in the Insert 
menu, the letter v is used in Envelope and in Movie and sound as an accelerator). 
However, you should use an unused letter if possible, to make it simpler to navigate.

Adding a command to a menu
You can add commands to both the supplied menus and menus you have created. On the 
Customize dialog, select the menu in the Menu list.

Start choosing the command in the left pane of the Customize dialog (Figure 1) and click on the 
Right arrow to add it to the menu. Use the up and down arrows on the right to position the 
command in the menu list. To remove an unwanted entry of the current menu, select it in the right 
pane and click on the left arrow. Click OK to save your menu customization.

Modifying menu entries
In addition to changing the sequence of entries on a menu or submenu, you can add submenus, 
rename or delete the entries, and add group separators.

To begin, select the menu or submenu to be modified from the Menu list on the right. Click the 
Modify button to rename the entry. Click on the Let arrow to remove from the menu.

You can add menu separators, a horizontal line that takes the place of a command and is useful to 
group many related commands in a pseudo-section in the menu. To add a separator, highlight the 
command just below the position of the separator and then click on the Insert drop-down and 
choose Insert separator. The horizontal line will appear in the right pane of the menu.

Use the Insert submenu of the Insert button to add a submenu to your menu.

Customizing context menu contents

Context menus are a dynamic set of menus that displays different commands and options 
depending on the selected object in you document. For instance, the context menu of a table 
object is different from the context menu of a frame object.

To customize context menus:

 1) Choose Tools > Customize to display the Customize dialog. Choose the Context Menus 
page (Figure 1, and the context menu tab is identical).

 2) All procedures and options of the LibreOffice menus applies to the contexts menu.
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Customizing toolbars

You can customize toolbars in several ways, including choosing which icons are visible and locking
the position of a docked toolbar (as described in Chapter 1, Introducing LibreOffice), and adding or 
deleting icons (commands) in the list of those available on a toolbar.  You can also create new 
toolbars. This section describes how to create new toolbars and add or delete icons on existing 
ones.

To get to the toolbar customization dialog (Figure 3), do any of the following:

• On the toolbar, right-click in the toolbar and choose Customize Toolbar.

• Choose View > Toolbars > Customize from the menu bar.

• Choose Tools > Customize from the menu bar and go to the Toolbars page.

Figure 3: The Toolbars page of the Customize dialog

Modifying existing toolbars
You will recognize the same dialog layout as for the menus. Indeed, the procedures for creating, 
modifying and deleting a toolbar are very similar (Figure 3).

To modify an existing toolbar:

 1) In the upper right drop-down list, choose whether to save this changed toolbar for the 
application (for example, Writer) or for a selected document.

 2) Just below, select from the Toolbar drop-down list the toolbar that you want to customize. 
The current toolbar content is displayed in the right pane below.

 3) Select the commands on the right. You can narrow your search by performing a search on 
the top left search box or choosing a category in the drop-down list just below.

 4) Click on the right arrow to add the command to the toolbar. Use the up and down arrows in 
the far right to position the command in the bar.

 5) When you have finished making all your changes, click OK to save them.
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Creating a new toolbar
To create a new toolbar:

 1) Choose Tools > Customize > Toolbars from the menu bar.

 2) Click on the plus sign (+) on the top right part of the dialog. 

 3) On the Name dialog (Figure 4), type the new toolbar’s name and choose from the Save In 
drop-down list where to save this changed menu: for the application (for example, Writer) or
for a selected document. 

 4) Click OK.

The new toolbar now appears on the list of toolbars in the Customize dialog. After creating 
a new toolbar, you need to add some commands to it, as described above.

Figure 4: Naming a new toolbar

Choosing icons for toolbar commands
Toolbar buttons usually have icons, not words, on them, but not all of the commands have 
associated icons.

To choose an icon for a command, select the command and click Modify > Change icon. On the 
Change Icon dialog, you can scroll through the available icons, select one, and click OK to assign 
it to the command (Figure 5).

Figure 5: Change Icon dialog

To use a custom icon, create it in a graphics program and import it into LibreOffice by clicking the 
Import button on the Change Icon dialog. Custom icons should be 16 x 16 pixels in size to achieve
the best quality and should not contain more than 256 colors.
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Assigning shortcut keys
In addition to using the built-in keyboard shortcuts (listed in Appendix A), you can define your own. 
You can assign shortcuts to standard LibreOffice functions or your own macros and save them for 
use with the entire LibreOffice suite.

Caution

Be careful when reassigning your operating system’s or LibreOffice’s predefined 
shortcut keys. Many key assignments are universally understood shortcuts, such as 
F1 for Help, and are always expected to provide certain results. Although you can 
easily reset the shortcut key assignments to the LibreOffice defaults, changing some 
common shortcut keys can cause confusion, especially if other users share your 
computer.

To adapt shortcut keys to your needs, use the Customize dialog, as described below.

 1) Select Tools > Customize > Keyboard. The Customize dialog (Figure 6) opens.

 2) To have the shortcut key assignment available in all components of LibreOffice, select 
LibreOffice in the upper right.

 3) Next select the required function from the Category and Function lists.

 4) Now select the desired shortcut keys in the Shortcut keys list and click the Modify button.

 5) Click OK to accept the change. Now the chosen shortcut keys will execute the function 
chosen in step 3 above whenever they are pressed.

Note

All existing shortcut keys for the currently selected Function are listed in the Keys 
selection box. If the Keys list is empty, it indicates that the chosen key combination is 
free for use. If it were not, and you wanted to reassign a shortcut key combination that 
is already in use, you must first delete the existing key.

Shortcut keys that are grayed-out in the listing on the Customize dialog, such as F1 
and F10, are not available for reassignment.

Example: Assigning styles to shortcut keys
You can configure shortcut keys to quickly assign styles in your document. Some shortcuts are 
predefined, such as Ctrl+0 for the Text body paragraph style, Ctrl+1 for the Heading 1 style, and 
Ctrl+2 for Heading 2. You can modify these shortcuts and create your own.

 1) Click Tools > Customize > Keyboard. The Keyboard page of the Customize dialog opens.

 2) To have the shortcut key assignment available only with one component (for example, 
Writer), select that component’s name in the upper right corner of the page; otherwise 
select LibreOffice to make it available to every component.

 3) Choose the shortcut keys you want to assign a style to. In this example, we have chosen 
Ctrl+9. This enables the Modify button.

 4) In the Functions section at the bottom of the dialog, scroll down in the Category list to 
Styles. Click the expansion symbol (usually a + sign or triangle) to expand the list of styles.

 5) Choose the category of style. (This example uses a paragraph style, but you can also 
choose character styles and others.) The Function list will display the names of the 
available styles for the selected category. The example shows some of LibreOffice’s 
predefined styles.

Example: Assigning styles to shortcut keys | 9



 6) To assign Ctrl+9 to be the shortcut key combination for the List 1 style, select List 1 in the 
Function list, and then click Modify. Ctrl+9 now appears in the Keys list on the right, and 
List 1 appears next to Ctrl+9 in the Shortcut keys box at the top.

 7) Make any other required changes, and then click OK to save these settings and close the 
dialog.

Figure 6: Defining keyboard shortcuts for applying styles

Warning

If you assign a custom style to a shortcut key, the shortcut will be effective only in 
documents that contains a custom style with the same name and family (paragraph, 
character, frame...). As consequence, a new default document may not have the 
custom style defined and the shortcut will apply a non-existing style.

Saving changes to a file
Changes to the shortcut key assignments can be saved in a keyboard configuration file for use a 
later time, thus permitting you to create and apply different configurations as the need arises, or in 
another way, create a standard keyboard configuration file to be distributed among many users in a
company. To save keyboard shortcuts to a file:

 1) After making your keyboard shortcut assignments, click the Save button at the right of the 
Customize dialog (Figure 6).

 2) In the Save Keyboard Configuration dialog, select All files from the Save as Type list.

 3) Next enter a name for the keyboard configuration file in the File name box, or select an 
existing file from the list. If you need to, browse to find a file from another location.

 4) Click Save. A confirmation dialog appears if you are about to overwrite an existing file, 
otherwise there will be no feedback and the file will be saved.
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Loading a saved keyboard configuration
To load a saved keyboard configuration file and replace your existing configuration, click the Load 
button at the right of the Customize dialog, and then select the configuration file from the Load 
Keyboard Configuration dialog.

Resetting the shortcut keys
To reset all of the keyboard shortcuts to their default values, click the Reset button near the bottom
right of the Customize dialog. Use this feature with care as no confirmation dialog will be displayed;
the defaults will be set without any further notice or user input.

Assigning macros to events

In LibreOffice, when something happens, we say that an event occurred. For example, a document
was opened, a key was pressed, or the mouse moved. You can associate a macro with an event, 
so the macro is run when the event occurs. A common use is to assign the “open document” event 
to run a macro that performs certain setup tasks for the document.

To associate a macro with an event, use the Events page of the Customize dialog. For more 
information, see Chapter 13, Getting Started with Macros.

Adding functionality with extensions

An extension is a program that can be installed into LibreOffice to add new functionality and 
improve your productivity with LibreOffice. Template sets, spelling dictionaries, clipart galleries, 
macros, and dialog libraries can be packaged as LibreOffice extensions.

Several extensions are shipped bundled with LibreOffice and are installed with the program. These
can only be removed by changing the installation options. Others can be downloaded from various 
websites. The official extension repository is located at https://extensions.libreoffice.org/. These 
extensions are free of charge.

Some extensions from other sources are free of charge; others are available for a fee. Check the 
descriptions to see what licenses and fees apply to the ones that interest you.

Download the extension to your computer in any folder that you want (Usually folder Download).

Installing extensions
Extensions can be installed in any of these ways:

• Directly from the *.oxt file in your system’s file browser: double-click the file.

• From your web browser, if it can be configured to open this file type from a web page 
hyperlink: select the hyperlink, and then select to Open the file.

In both cases, after the Extension Manager opens, a warning dialog opens for you to verify 
the installation and then continue. The file is installed as a “user only” file in a multi-user 
system.

• Directly from Tools > Extension Manager, as follows:

 1) In LibreOffice, select Tools > Extension Manager from the menu bar. The option to view 
the extensions bundled with LibreOffice can be deselected to view more easily those 
installations that have been added by a user.

 2) In the Extension Manager dialog (Figure 10), click Add.

 3) A file browser window opens. Find and select the extension you want to install and click 
Open.
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 4) Users with administrator or root privileges will see a dialog where they can choose to install 
extensions “for all users” (shared) or “only for me” (user). Normal users without those 
privileges can install, remove, or modify extensions only for their own use (user).

In all cases, during the process you may be asked to accept a license agreement. When the 
installation is complete, the extension is listed in the Extension Manager dialog.

Tip

To get extensions that are listed in the repository, you can open the Extension 
Manager and click the Get more extensions online link. You do not need to 
download them separately.

Figure 7: Extension Manager Main Window

Update extensions
Using the Check For Updates on the bottom of the main window of the Extension Manager, you 
can look for updates for the installed extensions, if there is any new version (Figure 8)

Figure 8: Extension Update Window
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Removing and disabling extensions
You can remove whatever extension that you had installed. For this, select the extension in the 
main windows of Extension Manager and click the Remove button.

Finally you can disable an extension without uninstalling it, byselecting the extension in the main 
window of Extension Manager and clicking the button Disable. After that, the button Disable 
changes to Enable.
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