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Introduction

A template is a document model that you use to create other documents. For example, you can 
create a template for business reports that has your company’s logo on the first page. New 
documents created from this template will all have your company’s logo on the first page.

Templates can contain anything that regular documents can contain, such as text, graphics, a set 
of styles, and user-specific setup information.

All documents in LibreOffice are based on templates. If you do not specify a template when you 
start a new Writer document, then the document is based on the default template for text 
documents. You can create, download, and install as many templates as you wish. You can set a 
default template for each type of document (text, spreadsheet, drawing, presentation). Writer uses 
the built-in blank template for text documents if a default template is not set. See “Setting a default 
template” on page 8.

In Writer, you can create templates for master documents as well as for ordinary documents.

Using a template to create a document

Creating a document from the Templates dialog
To use a template to create a document:

 1) Choose File > New > Templates or File > Templates > Manage Templates from the 
Menu bar, or press Ctrl+Shift+N, or click the small arrow next to the New icon on the 
Standard toolbar and select Templates. You can filter the templates from the Filter list at 
the top of the Templates dialog.

Figure 1: Templates dialog

 2) Find and double-click the required template, or select the template and click Open. A new 
document based on the selected template opens in Writer. You can then edit and save the 
new document.

The template the document is based on is listed in File > Properties > General.
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Note

The connection between a template and a document remains until the template is 
modified and you do not update the document to match the template.

If you copy or move the document to a different computer which does not have a copy 
of that template installed, the connection is broken even though it continues to be 
listed in the document’s properties. See “Associating a document with a different 
template” on page 9 for a way to reconnect a template to a document.

Creating a document from a template in the Start Center
You can create a document from the template view of the Start Center, which is visible when no 
other document is open.

To open the Templates dialog from the Start Center, click the Templates icon in the left pane. The 
icon is also a drop-down list to select the templates of a given type of document. The Manage 
Templates option on the list opens the Templates dialog.

Creating a template

You can create templates in two ways: by saving a document as a template or by using a wizard.

Creating a template from a document
Any settings that can be added to or modified in a document can be saved within a template. For 
example:

• Printer settings.

• General behaviors set from Tools > Options, such as paths and colors.

• Menu and toolbar customizations; see Chapter 21.

Templates can also contain predefined text, saving you from having to type it every time you create
a new document. For example, a letter template may contain your name, address, and salutation.

To create a template from a document:

 1) Open a new or existing text (Writer) document.

 2) Add any content that you want to appear in any document you create from the new 
template, for example company logo or a copyright statement.

 3) Create or modify any styles or formatting choices like Autotext that you want to use in the 
new template.

 4) From the Menu bar, choose File > Templates > Save as Template. The Save as Template 
dialog (Figure 2) opens, displaying the existing categories and a box for the name for the 
new template.

 5) Select a category, for example My Templates or Business Correspondence. You can also 
set this template as a default template at this time.

 6) Click Save.
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Figure 2: Save as Template dialog

Creating a template using a wizard
You can use wizards to create templates for letters, faxes, and agendas. To create a template 
using a wizard:

 1) From the Menu bar, choose File > Wizards > [type of template required] (see Figure 3).

 2) Follow the instructions on the pages of the wizard. This process is slightly different for each 
type of template, but the format is similar.

 3) In the last section of the wizard, you can specify the template name that will show in the 
Templates dialog and the file name and location for saving the template. The two names 
can be different but this may cause confusion. The default location is your user templates 
folder but you can choose a different location.

 4)

 5) Finally, you can choose whether to create a new document from the template or to change 
it manually. Click Finish to save the template. For future documents, you can re-use the 
template created by the wizard.

Figure 3: Creating a template using a wizard

Editing a template

You can edit a template’s styles and content and then reapply the template’s styles to documents 
that were created from that template. You cannot reapply content.
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To edit a template:

 1) Open the Templates dialog, as described on page 4.

 2) In the Templates dialog, find the template that you want to edit. Right-click on it to open the 
context menu, then click Edit. The template opens in Writer.

 3) Edit the template as you would edit any other document. To save your changes, choose 
File > Save from the Menu bar.

Updating a document from a changed template
If you make any changes to a template and its styles, a confirmation message is displayed the next
time you open a document that was created from the template before the changes.

To update the document:

 1) Select Update Styles to apply the changed styles in the template to the document.

 2) Select Keep Old Styles if you do not want to apply the changed styles in the template to 
the document.

Caution

If you choose Keep Old Styles, the document is no longer connected to the template, 
even though the template is still listed under File > Properties > General. To 
reconnect the document to the template, you will have to copy it into an empty 
document based on the template, as described in “Associating a document with a 
different template” on page 9.

Adding templates obtained from other sources

LibreOffice refers to sources for templates as repositories. A repository can be local (a directory on 
your computer to which you have downloaded templates) or remote (a URL from which you can 
download templates).

You can get to the official template repository by using the Browse online templates icon in the 
lower left of the Templates dialog, as shown in Figure 4, or by visting 
https://extensions.libreoffice.org/templates.

On other websites, you may find collections of templates that have been packaged into extension 
(.oxt) files. These are installed a little differently, as described below.

Figure 4: Getting more templates for LibreOffice

Installing individual templates
To install a template:

 1) Download the template and save it anywhere on your computer.

 2) In the Templates dialog, click the Import button on the bottom right. The Select Category 
dialog appears.

 3) Find and select the category where you want to import the template and click OK. A 
standard file browser window opens.
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 4) Find and select the template that you want to import and click Open. The file browser 
window closes and the template appears in the selected category.

Tip

(For advanced users) You can manually copy new templates into the template folders. 
The location varies with your computer’s operating system. To learn where the template 
folders are stored on your computer, go to Tools > Options > LibreOffice > Paths.

Installing collections of templates
The Extension Manager provides an easy way to install collections of templates that have been 
packaged as extensions. Follow these steps:

 1) Download the extension package (.oxt or .zip file) and save it anywhere on your computer.

 2) In LibreOffice, select Tools > Extension Manager from the Menu bar. In the Extension 
Manager dialog, click Add to open a file browser window.

 3) Find and select the package of templates you want to install and click Open. The package 
begins installing. You may be asked to accept a license agreement.

 4) When the package installation is complete, the templates are available for use through the 
Templates dialog and the extension is listed in the Extension Manager.

See Chapter 21, Customizing Writer, for more about the Extension Manager.

Setting a default template

If you create a document by choosing File > New > Text Document from the Menu bar, or by 
clicking the Text Document button in the Start Center, Writer creates the document from the 
default template for text documents. You can set a custom template to be the default. You can 
reset the default later, if you choose.

Note for Microsoft Word users

You may know that Microsoft Word employs a normal.dot or normal.dotx file for its 
default template and how to regenerate it.

LibreOffice does not have a similar default template file; the “factory defaults” are 
embedded within the software.

Setting a template as the default
Most default settings, such as page size and page margins, can be changed, but those changes 
apply only to the document you are working on. To make the changes the default settings for that 
document type, you need to replace the default template with a new one.

To set any template in the Templates dialog to be the default for that document type:

 1) Open the Templates dialog as described on page 4.

 2) In the Templates dialog, open the category containing the template that you want to set as 
the default, then select the template.

 3) Right-click the selected template and select Set as Default from the context menu (see 
Figure 5).

A document will be created from this template the next time that you create a document of that type
by choosing File > New.
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Figure 5: Setting a template as the default template for documents

Resetting Writer’s default template as the default
To re-enable Writer’s original default template as the default:

 1) Open the Templates dialog as described on page 4.

 2) In the Templates dialog (Figure 6), click the Settings icon on the bottom left.

 3) Point to Reset Default Template on the drop-down menu, and click Text Document.

This choice does not appear unless a custom template had been set as the default, as 
described in the previous section.

Figure 6: Resetting the default template for text documents

The document will be created from Writer’s default template the next time that you create a 
document by choosing File > New > Text Document.

Associating a document with a different template

At times you might want to associate a document with a different template, or perhaps you’re 
working with a document that did not start from a template.

One of the major advantages of using templates is the ease of updating styles in more than one 
document, as described in Chapter 9, Working with Styles. If you update styles in a document by 
loading a new set of styles from a different template (as described in Chapter 9), the document has
no association with the template from which the styles were loaded. Instead, you need to associate
the document with the different template.

For best results, the names of styles should be the same in the existing document and the new 
template. If they are not, you need to replace old styles with new ones. See Chapter 2, Working 
with Text: Basics, for more about replacing styles. To associate a document with a different 
template:
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 1) Open the Templates dialog as described on page 4. 

 2) In the Templates dialog, double-click the template you want to use. A new document opens,
containing any text or graphics that were in the template.

 3) Delete any unwanted text or graphics from this new document.

 4) Open the document you want to change. (It opens in a new window.)

 4) Use Edit > Select All, or press Ctrl+A, to select everything in the document.

 5) Use Edit > Copy, or press Ctrl+C, to copy the contents of the document to the clipboard.

 6) Click in the blank document created in step 1. Use Edit > Paste, or press Ctrl+V, to paste 
the contents from the old document into the new one.

 7) Update the table of contents if there is one. Close the old file without saving. Use File > 
Save As to save this new file with the name of the file from which content was taken. When
asked, confirm you wish to overwrite the old file. Alternatively, you can save the new file 
under a new name and preserve the old file under its original name.

Caution

Any changes recorded (tracked) in the document will be lost during this process. The 
resulting document will contain only the changed text.

Organizing templates

Writer can only lists templates that are in LibreOffice template categories. You can create new 
template categories and use them to organize your templates. For example, you might have one 
category for report templates and another for letter templates. You can also import and export 
templates.

To begin, choose File > Templates > Manage Templates to open the Templates dialog.

Creating a template category
To create a template category:

 1) Click the Settings icon on the Templates dialog.

 2) Click New category on the context menu (see Figure 7).

 3) In the pop-up dialog, type a name for the new category and click OK.

Note

You cannot create a sub-category inside a template category in LibreOffice.

Figure 7: Creating a new category
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Deleting a template category
You cannot delete template categories supplied with LibreOffice. Nor can you delete categories 
added by the Extension Manager unless you first remove the extension that installed them.

However, you can delete a category that you created. To delete a category, click the Settings icon,
select the category from the pop-up Category list, and then click OK. When a message box 
appears asking you to confirm the deletion, click Yes.

Moving a template
To move a template from one template category to another, select it in the Templates dialog, and 
click the Move icon in the bottom center of the dialog (see Figure 8). In the popup dialog, select the
required category and click OK.

Figure 8: Moving templates to another category

Renaming a template
You can also rename a template if the current name does not match its purpose. To rename a 
template, right click a template and select Rename in the pop up menu. The Enter New Name 
dialog opens. Type a name in the Enter New Name text box and click OK.

Deleting a template
You cannot delete templates supplied with LibreOffice. Nor can you delete any templates installed 
by the Extension Manager except by removing the extension that installed them.

However, you can delete templates that you have created or imported:

 1) In the Templates dialog, select the category that contains the template you want to delete.

 2) Select the template to delete.

 3) Right-click to open the context menu of the template and click Delete. A message box 
appears and asks you to confirm the deletion. Click Yes.

Exporting a template
To export a template to another location in your computer or network:

 1) In the Templates dialog, locate the category that contains the template to export.

 2) Select the template that you want to export.
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 3) Click the Export icon in the bottom right of the dialog. A file browser window opens.

 4) Find the folder into which you want to export the template and select Save or OK.

Note

Exporting a template does not remove it from the Templates dialog. The action places 
a copy of the template in the location you specify.
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