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Introduction

Draw is a vector graphics drawing tool, although it can also perform some operations on raster 
graphics (pixels) such as photographs. Using Draw, you can quickly create a wide variety of 
graphical images.

Vector graphics store and display a picture as simple geometric elements such as lines, circles, 
and polygons rather than as a collection of pixels (picture elements or points on the screen). This 
permits simpler storage and supports precise scaling of the picture elements.

Draw is fully integrated into the LibreOffice suite and this simplifies exchanging graphics with all 
components of the suite. For example, if you create an image in Draw, reusing it in a Writer 
document is as simple as copying and pasting the image. You can also work with drawings directly 
from within Writer or Impress using a subset of the functions and tools from Draw.

The functionality of LibreOffice Draw is extensive and, even though it was not designed to rival 
high-end graphics applications, it possesses significantly more functionality than the drawing tools 
that are generally integrated with most office productivity suites.

A few examples of the drawing functions are: layer management, magnetic grid-point system, 
dimensions and measurement display, connectors for making organization charts, 3D functions 
that enable small three-dimensional drawings to be created (with texture and lighting effects), 
drawing and page-style integration, and Bézier curves.

This Draw Guide is not a course book to be worked through from beginning to end. Rather, it is a 
reference work in which you can browse for guidance on particular topics.

This document describes only the functions associated with Draw. Some concepts, such as file 
management or the way the LibreOffice environment works, are mentioned only briefly; they are 
covered in more detail in the Getting Started Guide.

Draw workplace

The main components of the Draw interface or workspace are shown in Figure 1.

The large area in the center of the window is where you make the drawings. You can surround the 
drawing area with toolbars and information areas. The number and position of the visible tools vary
with the task in hand and user preferences. Therefore your setup may look different. For example, 
many users put the main Drawing toolbar on the left-hand side of the workspace and not at the 
bottom, as shown in Figure 1.

You can split drawings in Draw over several pages. Multi-page drawings are used mainly for 
presentations. The Pages pane, on the left side of the Draw workspace in Figure 1 gives an 
overview of the pages that you create. If the Pages pane is not visible on your setup, you can 
enable it by going to View > Page Pane on the main menu bar. To make changes to the page 
order, just drag and drop one or more pages into a new position.

In LibreOffice Draw, the maximum size of a drawing page is 300 cm by 300 cm.

Rulers
You should see rulers (bars with numbers) on the upper and left-hand sides of the workspace. If 
they are not visible, you can enable them by selecting View > Ruler in the main menu bar. The 
rulers show the size of a selected object on the page using double lines (highlighted in Figure 2). 
When no object is selected, they show the location of the mouse pointer, which helps to position 
drawing objects more accurately.

You can also use the rulers to manage object handles and guide lines, making it easier to position 
objects.
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Figure 1: LibreOffice Draw workspace

Figure 2: Rulers showing size of a selected object

The page margins in the drawing area are also represented on the rulers. You can change the 
margins directly on the rulers by dragging them with the mouse. The margin area is indicated by 
the grayed out area on the rulers as shown in Figure 2.

To modify the measurement units of the rulers, which can be defined independently, right-click on 
the desired ruler, as illustrated for the horizontal ruler in Figure 3.
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Figure 3: Ruler units

The default position of the zero for each of the rulers is located in the top left corner of the page 
where the left and top margins start. This zero position can be adjusted by holding down the Ctrl 
key and clicking in the top left corner of the workspace (Figure 2) where the horizontal and vertical 
rulers meet and dragging to a new zero position.

Status bar
The Status bar is located at the bottom of the Draw window and includes several Draw-specific 
fields.

Figure 4: Draw status bar

• Information area shows which action is being carried out, or which object type is selected. 
Position and Object size show different information depending on whether objects are 
selected or not.

– When no object is selected, the position numbers show the current position (X and Y 
coordinates) of the mouse cursor.

– When an object is selected and being resized with the mouse, the object size numbers 
show the size of the object (width and height).

Note
The sizes are given in the current measurement unit (not to be confused with the ruler 
units). This measurement unit is defined in Tools > Options > LibreOffice Draw > 
General.

– If an object is selected, the position numbers shows the X and Y coordinates of the 
upper-left corner and the object size number pair displays the size of the object. These 
numbers do not relate to the object itself, but to the selection outline, which is the 
smallest possible rectangle that can contain the visible part or parts of the object; see 
Chapter 3 Working with Objects and Object Points for more information.
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– When an object is selected, a double-click in either of these areas opens the Position 
and Size dialog; see Chapter 4 Changing Object Attributes for more information.

• Unsaved changes are indicated whenever any change is made to the document but not 
yet saved to disk.

• Digital signature indicates if the document has been digitally signed. A double-click or 
right-click in this area opens the Digital Signatures dialog. A document must be saved at 
least once before it can be digitally signed. After a document is digitally signed, an indicator
appears in this area.

• Slide number shows the sequence number for the current drawing page and the total 
number of pages created for the drawing. If you select an object, the information enclosed 
by parentheses indicates on which layer the object is placed within the drawing. In the 
example shown in Figure 4, the object is on the Layout layer of Slide 1 and there is a total 
number of one slide in the drawing.

• Page style shows which template is being used for the drawing.

• Zoom slider changes the zoom percentage of how the drawing appears on the computer 
display. Clicking on the plus (+) sign increases zoom and on the minus (-) sign decreases 
zoom. You can also drag the slider to increase or decrease the zoom percentage. The 
vertical bar in the middle of the Zoom slider represents a zoom percentage of 100%.

• Zoom percentage shows the level of zoom as a percentage. Double-clicking on the zoom 
percentage opens the Zoom & View Layout dialog. Right-clicking on the zoom percentage
opens a menu where you can select a zoom level. See Chapter 3 Working with Objects 
and Object Points for more information on working with the zoom functions.

Toolbars
You can display or hide the various Draw toolbars, according to your needs. To display or hide a 
toolbar, click View > Toolbars. On the menu that appears, select which toolbars you want to 
display.

You can also select the icons or buttons that you want to appear on the toolbars. To change the 
visible icons or buttons on any toolbar, right-click in an empty area on the toolbar and select 
Visible Buttons from the context menu. Visible icons or buttons are indicated by a shaded outline 
around the icon. Icons or buttons not visible are indicated by a plain icon as shown by the lower 
three icons in Figure 5. Click on an icon to hide or show it in the toolbar.

Figure 5: Selection of visible toolbar icons
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Standard toolbar
The Standard toolbar (Figure 6) is the same for all LibreOffice components and is described in 
detail in the Getting Started Guide.

Figure 6: Standard toolbar

Drawing toolbar
The Drawing toolbar (Figure 7) is the most important toolbar in Draw. It contains all the necessary 
functions for drawing various geometric and freehand shapes, and for organizing them in the 
drawing. It is described in detail in Chapter 2, Drawing Basic Shapes.

Figure 7: Drawing toolbar

Line and Filling toolbar
The Line and Filling toolbar (Figure 8) lets you modify the main properties of a drawing object. The 
icons and pull-down lists vary according to the type of object selected. For example, to change the 
style of a line, click on the up and down arrows for Line Style and select the required style.

The functions on the Line and Filling toolbar let you change the color, style, and width of the line 
drawn, the fill color and style, and other properties of an object. The object must first be selected 
with a mouse click. If the selected object is a text frame, the Line and Filling toolbar changes to the 
Text Formatting toolbar (Figure 9).

Figure 8: Line and Filling toolbar

Text Formatting toolbar
The Text Formatting toolbar (Figure 9) is similar to the Formatting toolbar in Writer. For an 
explanation of the functions on this toolbar, see Chapter 4 Changing Object Attributes. For 
information on adding and formatting text, see Chapter 9 Adding and Formatting Text.

Figure 9: Text Formatting toolbar

Options toolbar
Use the Options toolbar (Figure 10) to activate or deactivate various drawing aids. The Options 
toolbar is not displayed by default. To display it, go to View > Toolbars > Options on the main 
menu bar. The tools available on this toolbar are shown in Figure 10 and described in greater 
detail in other chapters of this Draw Guide.
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Figure 10: Options toolbar

Floating and moving toolbars

Available toolsets
Many icons have a small triangle pointing downward to the right side of the icon. This triangle 
indicates that the icon has additional tools available. Click on the triangle to display the full set of 
tools (Figure 11).

You can “tear off” this toolset so it becomes a floating toolbar. Click the area at the bottom of the 
toolset, drag it across the screen to a location you want and then release the mouse button. To 
close a floating toolbar, click on the X on the right of the toolbar title.

Figure 11: Available toolset and floating toolbar

Note
When a toolset is made into a floating toolbar, the icon on the existing toolbar 
remains in the toolbar and always shows the last tool you used. This means that the 
icon you see on your screen may differ from the icon shown in this guide.
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Tip

When you double-click on an icon on a toolbar, the command corresponding to that 
icon will become active and remain active. You can then repeat this action as often 
as you like. To exit from this mode, press the Esc key or click on another icon. 
Please note that this may not work for every icon on every toolbar.

Default toolbars
When you open Draw, the default set of toolbars are already docked or fixed in their positions at 
the top and bottom of the workspace. This default set of toolbars normally are the Standard, Line 
and Filling, and Drawing toolbars. These toolbars can be undocked and become floating toolbars.

• To undock a toolbar, move the mouse cursor to the far left of the toolbar and over the 
toolbar handle (Figure 12). The cursor will change shape, normally to a grabbing hand, but 
this is dependent on computer setup and operating system.

Click and drag on the toolbar handle to move the toolbar until it becomes a floating toolbar. 
This floating-toolbar capability is common to all components of LibreOffice.

• To dock a floating toolbar at the top of the Draw workspace, press and hold the Ctrl key 
then double click on the title of the toolbar. The toolbar will move into available space at the
top of the Draw workspace.

• An alternative method of docking a toolbar is to click in the toolbar title and drag the toolbar
to the docked position that you require. This can be the top, bottom or one of the sides of 
the Draw workspace.

Figure 12: Toolbar handles

Customizing toolbars
You can customize toolbars in several ways:

• To show or hide icons defined for a toolbar, see “Toolbars” and Figure 5 on page 7.

• To add functions to a toolbar, move tools between toolbars, or create new toolbars:

1) Select View > Toolbars > Customize on the main menu bar to open the Customize 
dialog (Figure 13).

2) Select the Toolbars tab and the toolbar you want to change from the Toolbar drop 
down list.

3) Select the desired function for that toolbar from the Commands list.

4) If necessary, reposition the new function on the Commands list using the up and down 
arrows.

5) Click Toolbar and select how you want the toolbar to appear in Draw from the context 
menu – Icons Only, Text Only, Icons & Text, or Restore Default Settings.

6) Click OK to save your changes and close the dialog.

• To add a new function, or modify a toolbar, see the Getting Started Guide for more 
information.
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Figure 13: Customize dialog – Toolbars page

Choosing and defining colors

The Color bar (Figure 14) displays the current color palette. It lets you rapidly select the color of the
various objects (lines, areas, and 3D effects) in your drawing. The first box in the panel 
corresponds to invisible (no color). If the Color bar is not displayed go to View > Toolbars > Color 
Bar. The toolbar appears by default at the bottom of the workspace and displays the current color 
palette.

You can access several specialized color palettes in Draw, as well as change individual colors to 
your own taste. This is done using the Colors page in the Area dialog by selecting Format > Area 

on the main menu bar or clicking the Area icon  on the Line and Filling toolbar, then selecting 
the Colors tab (Figure 15).

Figure 14: Color bar
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Figure 15. Area dialog – Colors page

To load another palette, click on the Load Color List icon . The file selector dialog asks you to 
choose one of the standard LibreOffice palettes (files with the file extension *.soc). For example,
web.soc is a color palette that is adapted to creating drawings for placing in web pages. These 
colors will display correctly on workstations with screens capable of at least 256 colors.

The color selection box also lets you individually change any color by modifying the numerical 
values in the fields provided to the right of the color palette. You can use the color schemes known 
as CMYK (Cyan, Magenta, Yellow, Black) or RGB (Red, Green, Blue).

Click on the Edit button to open the Color dialog, where you can set individual colors. See the 
Getting Started Guide Chapter 2 Setting Up LibreOffice for more information. A more detailed 
description of color and options can also be found in Chapter 10 Advanced Draw Techniques in 
this guide.

Grid, snap, and help lines

Draw provides a grid and snap lines as drawing aids and these can be turned on or off by clicking 

on the Display Grid  or Display Snap Lines  icons on the Options toolbar. The grid and 
snap lines are displayed only on the screen and are not shown on a printed drawing or when the 
drawing is used in another LibreOffice program. The color, spacing and resolution of the grid points
can be individually chosen for each axis.

Help lines when moving objects can be displayed and these are turned on or off by clicking on the 

Helplines While Moving  icon on the Options toolbar. Showing the position of the object while 
moving it makes positioning the object much easier. If this function is activated, pairs of vertical and
horizontal lines enclosing the object are shown while moving the object. These lines extend to the 
edges of the drawing area.

Draw also offers several snap functions to help you can position objects exactly in a drawing.

For more information on the grid, snap lines, snap functions, and help lines, see Chapter 3 
Working with Objects and Object Points.
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