LibreOffice كيفية الإبلاغ عن العلل في

From The Document Foundation Wiki
< QA‎ | BugReport(Redirected from BugReport/ar)
Jump to: navigation, search

خطوة رائعة

انت على وشك القيام باسهام كبير في LibreOffice, تقرير العلل الواضح والمتكامل مهم جدا للمطورين فشكرا لك لقيامك بهذه الخطوه. من أجل جعل حياة اللذين يتعاملون مع تقارير العلل اسهل, يوجد لدينا بعض الخطوات البسيطه لمساعدتك. من المهم جدا تقديم العلل التي لم تتعرف من قبل, لاحتمال وجود تقرير مسبق عنها وفي هذه الحاله من الأفضل اضافة المعلومات الاضافيه الهامه الى التقرير لاثرائه, ولعمل هذا ننصحك بزيارة تقارير العلل الأكثر انتشارا في LibreOffice

ويمكن الاستفادة من :

معلومات عامة

هل المشكلة حقاً علَّة ؟

اذا احتجت لمساعدة في استخدام LibreOffice, يمكنك كتابة استفسارك في قائمة مستخدمين LibreOffice او Ask.Libreoffice.

إبحث في البلاغات عن العلة أو ماشابهها

قبل كتابة بلاغ جديد, فضلاً تأكد ما إذا كان قد تم الإبلاغ عن المشكلة من قبل. في حال تم, فقد يكون بإمكانك المساهمة بمعلومات إضافية للبلاغ نفسه؟

اطلب المساعدة من أحد ما في إعادة إحداث العلة

يُفضل أن تطلب من شخص آخر إعادة إحداث العلة اذا لم يستعرض احد تقريرك خلال المده الزمنيه المناسبه (24 ساعه للعلل الحرجه و 14 يوم لطلبات التحسين). ستجد أُناس مستعدين لتقديم المساعدة في القائمة البريدية users@global.libreoffice.org, أو في قناةالآي آر سي #libreoffice.

الإبلاغ عن علة

علل حزم LibreOffice يجب أن يُبلغ عنها في bugzilla. يمكنك الإبلاغ عن علة بشكل مباشر بالدخول على الرابط التالي "LibreOffice" product

باختلاف نوع العلة, يمكنك اختيار مكونات مختلفة: 

  • لموقع LibreOffice.org اختر المكون WWW.
  • للعلل العامة في التطبيقات, استخدام المكون Writer, Presentation, Spreadsheet Database, أو مكون Drawing وفقاً للعلة.

لأي مشكلة أخرى, اختر مكونات أخرى, بالنقر على component من القائمة المنسدلة التي ستوفر لك تلميحات في حال لم تكن متأكداً من المكون المتعلق بمشكلتك, اختر مكون LibreOffice. وسيقوم شخص آخر بتحديد المكون الصحيح.

رجاءاً! افتح ملف جديد لكل مشكلة أو علة, ولا تبلغ عن أكثر من مشكلة أو علة في نفس الملف (البلاغ)

اذا بدا لك نظام تتبع العلل معقد بكل أقسامه وشروطه, فيجب عليك الإبلاغ عن مشكلتك فيالقائمة البريدية users@global.libreoffice.org أو المنتدى libreofficeoforum.org; وستجد المساعدة هناك.

الإبلاغ عن العلل المتعلقة بأوبنتو لينُكس

القائمة الحالية للمشاكل المختصة بأوبنتو متوفرة هنا


يجب أن تبلغ عن العلل المختصة بأوبنتو فقط إذا كنت قد ثبَّت LibreOffice من الـPPA المخصص.

اصدار أوبنتو 10.04 واصدار 10.10 لا يدعم LibreOffice
اذا كنت تستعمل اصدار أوبنتو 11.04 او أعلى افتح شاشة الاوامر ( تحت التطبيقات > الملحقات > شاشة الأوامر ) وقم بكتابة الأمر ubuntu-bug libreoffice[ادخال] ثم اتبع الاوامر لتكملة التقرير او استخدم هذا النموذج

تذكر ان تضيف التفاصيل مثل طريقة تثبيت LibreOffice , في اي بيئة عمل تعمل (32-bit or 64-bit) والخطوات لاعادة اصدارالمشكله

للإبلاغ عن علة مختصة بأوبنتو, اضطلع على قائمة المشاكل الحالية, ثم استخدمهذا النموذج وحدد libreoffice أسفلIn what package did you find this bug?. وتذكر أيضاً أن تكتب lo33 كوسم "tag" للبلاغ. 

الإبلاغ عن العلة في FreeDesktop.org كما وُضِحَ أعلاه مفيد أيضاً كي يتم التأكد ما اذا كانت المشكلة موجود في المنبع (وفحصها ثم حلها إن أمكن) لنسخ LibreOffice الأخرى.

مالذي تتضمنه في البلاغ

المعلومات التالية تساعدنا في إعادة إحداث العلة أو تشخيص المشكلة ما قد يساهم في حلها بشكل أسرع:

  • اذ لم تكن لديك خبرة كافية في الإبلاغ عن العلل, فضلاً اقرأتوجيهات كتابة العلل, ستجد الرابط أعلى صفحة التبليغ. 
  • من الأمور المهمة الاختيار الصحيح للمكونات, الاصدار, الحاله الابتدائيه, الخطوره, ومن الأفضل الأخذ بعين الاعتبار تفاصيل تقارير العلل
  • بالاضافه الى الاختيارات المفصله المنسدله التي تتعلق باصدار النظام وهندسته, مثال: openSUSE 11.2 on x86_64, 32-bit Windows 7
    • في لينكس, سطح المكتب, مثال : KDE or GNOME
  • نسخة LibreOffice على سبيل المثال: 3.2.0. نستخرجها من مربع الحوار "Help/About LibreOffice" . واذا كنت تستعمل LibreOffice مسبق البناء , في لينكس يجب ان تخبر بنوع الاصدار لحزمه LibreOffice في نظام ادارة الحزم.

لنظام تشغيل ويندوز اسم الملف الفعلي للمثبت ومن اين تم تحميله.

    • بالاضافه لذلك المعلومات التي تتعلق بالتثبيت و استخدام التعريب ( لغة واجهة المستخدم , مستندات اللغه) من الممكن ان تكون مفيده جدا
    • سواء كان LibreOffice 32 بايت ويستعمل في 64 بايت من نظام لينكس
    • حزم المصدر اذا لم تكن من بناء LibreOffice الرسمي
  • الرجاء المساهمه بشكل ذا معنى ومختصر للمشكله اللتي ترغب بكتابه تقرير عنها.
    • لا: تكسر واجهة المستخدم
    • لكن: قائمة > ملف > حفظ باسم > غير متوفر
  • الخطوات لاعادة كتابه العله, الرجاء الاشاره الى كافة التفاصيل الدقيقه التي من الممكن ان تكون مهمه
    • لا تكتب: "فتح ملف ."
    • لكن: "في انشاء ورقة عمل جديده من نوع LibO, استعمل من القائمه: ملف > فتح > نوع الملف > مستند نصي > قم باختيار اضافة مرفقات > نموذج مستند > نقر مزدوج "
    • قم باضافه شرح وافي ودقيق ومحدد لمشكلتك
      • لا: "تهمل تهمل التنسيق والصياغه "
      • لكن: "انا اقبل xxx بسبب yyy ولكني أرى zzz"
  • تفاصيل اخرى مفيده (صوره للشاشه, نموذج مستند, تتبع معاكس, تتبع). فضلا اذكر ان نموذجط النصي من الممكن ان لا يظهر مشكلتك اذا استعمله بعض المستخدمين بانظمة تشغيل مختلفه, او باعدادت برنامج مختلفه او ماشابه ذلك فقد لا تتوجد المشكله في جميع الاحوال. لذلك صورة الشاشه تكون مفيده جدا في هذه الحالات. غالبا صورة الشاشه تكون مفيده اكثر اذا عدلتها ببرامج التعديل كالرسام وغيره لتضيف بعض الملاحظات او لتحدد مكامن المشكله والنقاط المهمه.
  • المرفقات (نماذج مستندات, ... )
  • اذا كنت تريد ارفاق اكثر من صورة للشاشه عليك جمعهم جميعا في مستند واحد (نسخ / لصق في مستند رسم)ثم قم بارفاقها كملف من صغيه PDF. فضلا قم باضافه شرح مختصر لكل صوره على حده لتوضيح ماذا تعني بها.
  • اذا كنت تريد ارفاق اكثر من مستند (نتائج عدة اختبارات) يجب عليك انشاء مستند ضغط يحتوي على جميع الملفات ثم تقوم بارفاق مستند الضغط
  • اذا كان حجم المرفق كبير جدا لارفاقع في بقزيلا (أكبر من 1 ميغا بايت) يمكنك استعمال صفحة التحميل التجريبيه.

ملاحظه: اذا انشئت صورللشاشات, سوف تساعد المطورين بشكل أكبر اذا حولت واجهة المستخدم الى اللغه الانجليزيه أولا. ويمكنك فعل ذلك عن طريق: أدوات > خيارات > اعدادات اللغه > لغات.


توفير معلومات اضافيه للمطورين

كيفية عمل تتبع عكسي (في ويندوز)

اقرا عن كيفية عمل تتبع عكسي عن طريق مقالات WinDbg وشاهد فديو لمجموعة الصور التي تشرح كيف يمكنك ان تستخرج مجموعة من المعلومات للمطورين فضلا تذكر ان تعمل نسخه من النص في المستند الجديد وقم بارفاقها لتقرير العله. هذا سوف يبقي العله مقروئه وسوف يحمي من النتائج الغير مستخدمه في استعلامات البقزيلا.

كيف يمكن عمل تتبع عكسي (في لينكس)

التتبع العكسي مفيد في حالة ان التطبيق حدث له خطأ او تجمد , ومن الممكن استعمال الخطوات التاليه:


  1. قم بتحميل حزمة libreoffice*-debuginfo, اذا كانت متوفرة. اذا لم تتوفر, التتبع العكسي يصبح اقل فاعليه, ولكن يبقى مفيد الى حد ما حيث من الممكن ان يوفر بعض المعلومات الاضافيه.
  2. ابدأ المصحح بالاعداد الحقيقيه الثنائيه واعمل على تسجيل المخرجات:
    cd /opt/libreoffice/program
    
    gdb ./soffice.bin 2>&1 | tee /tmp/gdb.log
    
  3. داخل المصحح, ابدا التطبيقات:
    run
    
    هل تحتاج لتحديد الخصائص لأوامر LibreOffice, استخدمrun <options>, مثل. run -writer, او run /path/to/document.odt
  4. اعمل الخطوات لاعادة تشغيل التطبيق بعد حدوث الخطأ او بعد التجمد, وفي حالة التجمد تحتاج للضغط على CTRL-C في gdb للحصول على gdb الأوامر مره أخرى.
  5. القيام بعمل التتبع العكسي:
    backtrace
    
  6. القيام بعمل التتبع العكسي لجميع المواضيع:
    thread apply all bt
    
  7. الخروج من المصحح
    quit
    
  8. ارفاق جميع gdb.log لتقرير العله.

كيفية عمل strace log (في لينكس)

في أغلب الحالات, يمكن البدء في التطبيق بهذه الطريقه:

strace -o /tmp/strace.log -f -tt -s 512 libreoffice

بعد ذلك قم بعمل هذه الخطوات لاعاده اصدار المشكله والخروج من التطبيق. الأمر libreoffice من الممكن تبديله /opt/libreoffice/program/soffice خاصة اذا لم يتم تحمل عملية التكامل لسطح المكتب . فضلا اضغط السجل قبل ارفاقه في تقرير العله :

bzip2 /tmp/strace.log

اذا كان 32 بايت LibreOffice يعمل في نظام تشغيل 64 بايت, يجب عليك تحميل حزمة strace-32bit والبدء في 32 بايت مباشرة:

cd /opt/libreoffice/program
strace32 -o /tmp/strace.log -f -tt -s 512 ./soffice.bin

كيفية عمل valgrind log (في لينكس)

valgrind log مفيد عندما يحصل خطأ في التطبيق او تجمد وعملية التتبع العكسي تكون غير كافيه, يمكنك استعمال الخطوات التاليه:

  1. قم بتحميل حزمة libreoffice*-debuginfo . (اذا كانت متوفره, و/او من موزع لينكس)
  2. ابدأ المصحح بالاعداد الثنائيه الصحيحه وسجل المخرجات:
  3. cd /opt/libreoffice/program
    
  4. valgrind --tool=memcheck --num-callers=128 --trace-children=yes ./soffice.bin 2>&1 | tee /tmp/valgrind.log
    
  5. قم بعمل الخطوات لاعادة اصدار التطبيق بعد الخطأ او التجمد. لاحظ انه في الغالب سوف تعمل جيدا باستخدام valgrind لانها تساعد بابقاء الذاكرة نظيفة. على اي حال, يجب ان تسيطر على الخطر ويجب ان تضع ايضا بعض المعلومات المفيدة في السجل. لاحظ ان valgrind سوف يقوم بطباعة الكثير من رسائل التحذير في اغلب الأوقات.

ويجب فعلا ان تفعل الخطوات التي يوجد فيها اشكاليات لكي تضع المعلومات المهمه في السجل.

  1. اخرج من LibreOffice
  2. فضلا قم بضغط valgring.log اذا كان اكبر من 10 كيلوبايت
  3. bzip2 /tmp/valgrind.log
    
  4. ارفق السجل في تقرير العله.