Dependências de compilação no Linux

From The Document Foundation Wiki
Jump to: navigation, search

Os comandos abaixo devem preparar um sistema regular capaz de compilar o LibreOffice, é de longe a maneira mais fácil de usar o pacote existente para iniciar a sua dependências de compilação.

sudo apt-get build-dep openoffice.org
sudo apt-get install git libgnomeui-dev gawk junit4

No Debian unstable (11/06 2010)

sudo apt-get install libgsf-1-dev

antes de rodar o "sudo apt-get build-dep openoffice.org".

Ubuntu

Natty

sudo apt-get build-dep libreoffice

Maverick/Lucid

sudo apt-get build-dep openoffice.org

Ou, depois habilitando o PPA do libreoffice de https://launchpad.net/~libreoffice/+archive/ppa:

sudo apt-get build-dep libreoffice

Para testes subsequentes atualmente é mais fácil baixar o jar completo do junit de: https://github.com/downloads/KentBeck/junit/junit-4.9b2.jar

Se não são necessários os testes subsequentes use --without-junit para o autogen.sh . O conjunto exato de dependências depende das funcionalidades habilitadas e desabilitadas com o autogen.sh.

Se isso falhar, em alguns sistemas Ubuntu (10.10, talvez versões anteriores) tente isso:

sudo apt-get install git build-essential gawk libxml2-dev libfontconfig1-dev \
libpam0g-dev libpng12-dev flex bison libgtk2.0-dev openjdk-6-jdk libcups2-dev \
gperf libxaw7-dev libgnomeui-dev libgstreamer-plugins-base0.10-dev \
libgl1-mesa-dev libglu1-mesa-dev
sudo perl -MCPAN -e 'CPAN::Shell->install(Archive::Zip)'

OpenSUSE

sudo zypper si -d OpenOffice_org-bootstrap 

Fedora/RedHat

sudo yum-builddep libreoffice 
sudo yum-builddep openoffice.org
sudo yum install gcc-c++ ant java-devel junit4 flex bison  perl-Archive-Zip \
gtk2-devel freetype-devel gstreamer-devel autoconf gperf libXaw-devel \
GConf2-devel gnome-vfs2-devel cups-devel  gstreamer-plugins-base-devel

Veja também Fedora Rawhide Build Notes (em inglês)