Documentatie/Calc-functies/ISFOUT2

From The Document Foundation Wiki
Jump to navigation Jump to search
This page is a translated version of the page Documentation/Calc Functions/ISERR and the translation is 100% complete.
Other languages:
English • ‎Nederlands



Functienaam:

ISFOUT2

Categorie:

Informatie

Samenvatting:

Bepaalt of een opgegeven cel of expressie resulteert in een ander fouttype dan #N/B.

Syntaxis:

ISFOUT2(Waarde)

Retourneert:

Retourneert WAAR als het argument resulteert in een andere foutwaarde dan de waarde Niet beschikbaar (#N/B) en retourneert anders ONWAAR.

Argumenten:

Waarde is een uitdrukking of een verwijzing naar een cel die een uitdrukking bevat, die moet worden getest op een foutconditie (anders dan #N/B).

Aanvullende details:

  • ISFOUT2 verspreidt geen fouten. Als Waarde resulteert in een andere fout dan #N/B, dan geeft ISFOUT2 WAAR terug. Als Waarde resulteert in de fout #N/B, retourneert ISFOUT2 ONWAAR.

ISFOUT om te testen op eventuele fouten, inclusief #N/B. De formule =ISFOUT2(X) komt overeen met de formule =ALS(ISNB(X); ONWAAR(); ISFOUT(X)).

  • Gebruik ISFOUT2 in combinatie met de functie ALS om te testen op fouten en verschillende acties te ondernemen in normale en foutcondities.

Voorbeelden:

Formule Beschrijving Retourneert
=ISFOUT2(12,34) Hier retourneert de functie de logische waarde ONWAAR. ONWAAR
=ISFOUT2("Hallo wereld!") Hier retourneert de functie de logische waarde ONWAAR. ONWAAR
=ISFOUT2(WAAR()) Hier retourneert de functie de logische waarde ONWAAR. ONWAAR
=ISFOUT2(21-12-2018) Hier retourneert de functie de logische waarde ONWAAR. ONWAAR
=ISFOUT2(D1) waarbij cel D1 de formule =1/0 bevat. Hier bevat cel D1 de fout #DIV/0! en dus retourneert de functie de logische waarde WAAR. WAAR
=ISFOUT2(D2) waarbij cel D2 de formule =WORTEL(-7) bevat. Hier bevat cel D2 de fout Ongeldig argument (Fout:502) en dus retourneert ISFOUT2 de logische waarde WAAR. WAAR
=ISFOUT2(D3) waarbij cel D3 de formule =NB() bevat. Hier bevat cel D3 de fout #N/B en dus retourneert ISFOUT2 de logische waarde ONWAAR. ONWAAR

Gerelateerde LibreOffice-functies:

TYPE.FOUT

ISFOUT

ISGETAL

ISTEKST

NB

ODF standaard:

Section 6.13.15, part 2

Gelijkwaardige Excel-functies:

ISFOUT2