Překlad uživatelské příručky do češtiny pomocí OmegaT

From The Document Foundation Wiki
Jump to: navigation, search

Překlad příručky Getting Started with LibreOffice do češtiny byl zahájen počátkem roku 2014, poté co byla slovenským týmem připravena infrastruktura využívající překladatelský program OmegaT. Později tento systém převzala pro překlady do více jazyků The Document Foundation, nadace zastřešující vývoj LibreOffice. Tato stránka popisuje, jak celý systém po technické stránce zprovoznit a používat.

Jedná se o projekt zajišťovaný dobrovolníky, jehož cílem je poskytnout kvalitní, obsáhlou, pravidelně aktualizovanou a pod otevřenou licencí zveřejněnou příručku zabývající se všemi programy z balíku LibreOffice – taková literatura v češtině zatím chybí.

Důležité odkazy

Gnome-system-help.svg

Zapojte se!
Budeme rádi za jakoukoliv pomoc, a to nejen při překládání – přeložený text je třeba zkontrolovat a také vytvořit obrázky (snímky obrazovky s českým rozhraním a kresby v Draw).

Jak se připojit

Pokud se chcete připojit, přihlaste se do diskusní skupiny na Google Groups a pošlete mail na její adresu sk-libreoffice-guides (na) googlegroups.com (případně na adresu administrátora projektu: msramek22 (na) gmail.com (slovenština) anebo stanislav.horacek (na) gmail.com (čeština)). Dokumentace je zveřejněná pod otevřenou licencí GNU General Public License, verze 3 nebo novější, a nebo Creative Commons Attribution License, verze 4 nebo novější. Ve svém mailu vyjádřete souhlas s publikováním svého překladu pod těmito licencemi.

Použitý SW

V postupu byly použity programy těchto verzí:

  • LibreOffice >= 4.2.8
  • OmegaT >= 3.5 (nejspíš platí i pro 3.0)

Instalace OmegaT

Stručný návod, jak si nainstalovat CAT program OmegaT

Na stránce http://omegat.org/ postupně zvolíme:

  1. Čeština
  2. Stáhnout OmegaT
  3. Průvodce stažením
  4. Tradiční
  5. Windows nebo Linux nebo Mac OS X
  6. S JRE nebo Bez JRE
  7. Latest
  8. Uložíme soubor s instalací
  • Dále pro Windows: následuje instalace OmegaT: vícekrát kliknout na Ano, Další... Dokončit
  • Dále pro Linux: rozbalit stáhnutý zip soubor, spustit program OmegaT pomocí ./OmegaT; případně nainstalovat OmegaT do /opt/ spuštěním skriptu ./linux-install.sh (poté lze program spouštět příkazem omegat)

OmegaT a Subversion na Linuxu

Spolupráci na projektu umožňuje sdílené úložiště systému Subversion. Na Linuxu (Ubuntu, asi i jinde) si však OmegaT nepamatuje přístupové heslo, resp. ho po chvíli zapomene.

Obejití chyby

Hesla systému Subversion se ukládají v domovském adresáři ve složce .subversion/auth/svn.simple. V ní máme minimálně jeden soubor s dlouhým názvem. Je-li jich víc, podíváme se do nich. Hledáme ten, ve kterém se nachází řetězec <https://github.com:443> GitHub.

Postup

  1. Pokud se v souboru nachází heslo, zkopírujeme soubor do nového souboru:
    cp dlouhy_nazev dlouhy_nazev.1
  2. Pokud v něm heslo není, dlouhy_nazev.1 vytvoříme s tímto obsahem (čísla udávají počet znaků řetězce, příslušně je proto upravíme pro jméno a heslo uživatele):
    K 8
    passtype
    V 6
    simple
    K 8
    password
    V 12
    HESLO_UZIVATELE
    K 15
    svn:realmstring
    V 31
    <https://github.com:443> GitHub
    K 8
    username
    V 9
    JMENO_UZIVATELE
    END
  3. Pro spuštění OmegaT si připravíme vlastní příkaz, který přidáme na konec souboru .bashrc v domovském adresáři (pro ty, kdo používají bash, pro ostatní budou příkaz a soubor jiné)..
    function otg () { (ff=dlouhy_nazev; cd ~/.subversion/auth/svn.simple; chmod 644 $ff; cp $ff.1 $ff); omegat ~/GettingStarted & }
    ~/GettingStarted je adresář, do kterého jsme si stáhli týmový projekt.
  4. OmegaT spustíme z příkazového řádku zadáním
    otg

Překládání v OmegaT

Překládání s pomocí nástroje OmegaT

Předpokládáme, že týmový projekt máme stáhnutý do složky LOGuides.

Typická překladatelská relace

Postup:

  1. Spustíme program OmegaT.
  2. Otevřeme projekt volbou Projekt ▸ Otevřít.... Otevře se dialogové okno správce souborů, v kterém vybereme složku LOGuides.
  3. Následně se otevře okno Soubory projektu, ve kterém vybereme soubor pro překlad a klikneme na Open.
  4. Postupně překládáme jednotlivé části - věty, dbáme při tom na zachování značek.
  5. Po skončení překládání zkontrolujeme správnost značek pomocí Nástroje ▸ Ověření tagů….
  6. Program OmegaT zavřeme pomocí Projekt ▸ Konec.

Na konci práce není třeba nic ukládat (můžeme tak ovšem provést pomocí Projekt ▸ Uložit), neboť OmegaT překládané části průběžně ukládá do překladové paměti. Její obsah se ve stanovených intervalech a při ukončení programu automaticky přenese do úložiště na serveru. Je to poznat podle toho, že po zvolení Konec... se vlevo dole objeví text Týmová synchronizace.

Poznámka: To, jak často se bude projekt ukládat do úložiště na serveru, můžeme určit v Možnosti ▸ Uložení a výstup. Při každém uložení přibude do úložiště commit s označením Translated by JMENO, kde JMENO lze v OmegaT nastavit v Možnosti ▸ Tým.

Zobrazení přeloženého dokumentu

Při výše uvedeném postupu se s překládaným dokumentem nepracuje přímo. Při otevírání projektu ho OmegaT rozloží na segmenty – věty, se kterými se pracuje. Pokud chceme zobrazit výsledek, zvolíme Projekt > Vytvořit přeložené dokumenty nebo, pokud stačí pouze aktuálně překládaný dokument, použijeme Projekt > Create Current Translated Document. Ty najdeme jako soubory ODT v složce LOGuides/target na našem lokálním disku ve složce projektu. Zdrojové soubory, které překládáme, jsou ve složce LOGuides/source, což znamená, že se nikdy nepřepíší. Vytvořené dokumenty se nepřenášejí na server.

Upozornění: Pokud potřebujeme provést úpravy v překladu, neděláme to v přeloženém dokumentu, ale v příslušné části v OmegaT. Jinak se změny nezachovají.

Překlad segmentů

Překlad textu pomocí OmegaT

Přehled

OmegaT načítaný soubor rozloží na věty – segmenty, které se postupně překládají. Jakmile program při načítání najde v překladové paměti část přeloženou, zobrazí překlad, jinak zobrazí originál.

Víc se o postupu překládání dočtete v návodě, který je dostupný po spuštění OmegaT.

Překlad prvků GUI pomocí slovníku

Většina řetězců, které se nacházejí v GUI LibreOffice, je uložená v slovníku OmegaT. Pokud text vypadá jako řetězec z GUI (File > Save a podobně), je podtržený modrou čárou. Potom ho kliknutím pravým tlačítkem můžeme z místní nabídky přenést do psaného textu (viz obrázek). Je dobré se sem vždy podívat, abychom zjistili skutečný překlad v GUI, případně se můžeme podívat rovnou do LibreOffice.

Pokud se podtržení modrou barvou nezobrazí, je třeba aktivovat tzv. TransTips (Možnosti > TransTips > Povolit TransTips). Podtržení se zobrazí až po přejití na další větu.

Poznámka: Soubor se slovníkem se nachází v adresáři glossary a jeho název odpovídá verzi LibreOffice, které se týká (například soubor ui_lo5001.txt obsahuje řetězce pro verzi 5.0.0 RC1).

Aktuální slovník se vytvoří podle tohoto návodu.

Prvky uživatelského rozhraní

OmegaT sk.png

Zabarvení segmentů

Pokud nemáte pracovní část pro překlady zabarvenu jako na obrázku výše, lze to provést s pomocí podnabídek v hlavní nabídce Zobrazit.

Vybrané podnabídky pro zabarvení jsou:

  • Označit přeložené segmenty - zabarví text, který je již přeložen, žlutým podbarvením řádku.
  • Označit nepřeložené segmenty - text, který zbývá pro přeložení, je podbarven modrou barvou.
  • Ukázat zdrojové segmenty - přidá nad všechny, jak přeložené, tak nepřeložené řádky, zeleně podbarvený zdrojový anglický text.

Užitečné klávesové zkratky

Pro práci s OmegaT lze pro urychlení práce používat i klávesové zkratky.

  • ENTER - přeskočí na další položku směrem dolů (jak přeloženou, tak i nepřeloženou).
  • CTRL-U - přejde na další nepřeloženou položku směrem dolů.
  • CTRL-ENTER - přeskočí na minulou položku směrem nahoru (jak přeloženou, tak i nepřeloženou).
  • CTRL-R - přepíše originální [ENG] text překladem z překladové paměti, který je umístěn na prvním místě.

Značky v textu

Značky v překládaném textu

Značkovaný text

Formátování textu a vkládání různých prvků (odkazy, položky indexu a pod.) se v ODT souborech provádí pomocí značek (angl. tags). Značky jsou uzavřené v špičatých závorkách a můžou být párové (<tucne>text</tucne>) a nebo nepárové (<novyradek />). Lomítko označuje koncovou značku, v případě párové značky je za <, v případě nepárové je před >.

Tyto značky je třeba v překládaném textu zachovat. Pokud to neprovedeme, v lepším případě se ztratí formátování, v horším případě bude vytvořený soubor nečitelný.

Překlad segmentů se značkami

OmegaT zobrazuje značky zjednodušeně, např.

Click <f0>OK</f0> to save your settings and close the dialog

Poznámka: OmegaT rozděluje překlady na věty, a tak se může stát, že úvodní značka je v jedné části a koncová v následující.

Vkládání značek

Značky můžeme přímo zapisovat. Jednodušeji je ale vložíme tak, že kurzor umístíme na požadované místo a stiskneme CTRL-T (nebo Upravit > Vložit další chybějící tag). Opakované stisknutí CTRL-T vkládá následující značku.

Poznámka: Může se stát, že značka je umístěná uvnitř slova. V tom případě je vhodné slovo v překladě nerozdělovat, ale celé ho uvést uvnitř anebo mimo pár značek.

Poznámka: U překladů odkazů na obrázek, např. (<t4>Figure 16</t4>), je vhodné ponechat mezi značkami pouze číslo obrázku, tj. (obrázek <t4>16</t4>). V opačném případě bude ve výstupním souboru ODT chybně pouze číslo bez textu „obrázek“.

Kontrola značek

Před ukončením práce je potřebné zkontrolovat správnost značek pomocí Nástroje > Ověřit značky. Zobrazí se okno se seznamem chybných segmentů. Vlevo je odkaz na číslo a vpravo je typ chyby. Pokud klikneme na Opravit, OmegaT se pokusí chybu opravit. Obvykle jen vloží chybějící značky na konec segmentu; na správnou pozici je potřeba je přesunout ručně. Proto se této možnosti raději vyhněme.

Práci ukončíme až po odstranění všech chybných značek – jinak by se tyto chyby přenesly do úložiště na server.

Týmový projekt

Co je týmový projekt OmegaT

Týmový projekt umožňuje spolupráci více překladatelů prostřednictvím sdílených souborů překladové paměti a slovníku. Při otevírání projektu se tyto soubory aktualizují z úložiště, během překladu při zavírání se z nich odesílají změny do úložiště.

Projekt je uložený na serveru https://github.com/LibreOffice/OmegaT/tree/master/cs/LOGuides v úložišti typu subversion (SVN).

Člen týmového projektu

Jak získat přístup k úložišti

  • Je potřeba mít vytvořený účet na github.com, takže se zde zaregistrujeme.
  • Poté kontaktujeme administrátora, aby nás přidal do týmu dle jazykové verze.
  • Následně si stáhneme buď český, nebo slovenský týmový projekt a již můžeme začít s překladem.

Stáhnutí projektu

Postup při úvodním stahování týmového projektu z úložiště

Postup:

Vlevo dole se zobrazí zpráva Kontrola projektu.... Projekt se stáhne ze serveru a otevře se okno. V okně můžeme vybrat soubor, pokud projekt obsahuje víc souborů. Okno zavřeme kliknutím na tlačítko Zavřít.

Upozornění: Projekt se stáhne jen jednou, pro další práci se otevírá lokální kopie projektu s pomocí Projekt > Otevřít...

Snímky obrazovky

Postup pro vytváření snímků obrazovky a jiných obrázků

Z postupu práce s programem OmegaT vyplývá, že původní obrázky je třeba nahradit přeloženými už ve zdrojových dokumentech, které se nacházejí ve složce source. Pokud změna obrázku změní stránkování, segment se změněným odkazem je třeba ručně opravit. Je tomu tak proto, že překládané soubory se při jejich vytváření vždy přepisují. Je na to dost času, stačí to provést až těsně před vydáním přeložené kapitoly.

Nastavení LibreOffice

V zásadě je třeba:

  • Nainstalovat si LibreOffice v příslušné verzi (aktuálně 5.0) ze stránky ke stažení.
  • V Nástroje ▸ Možnosti ▸ LibreOffice ▸ Zobrazení nastavit Velikost a styl ikon na Galaxy a nastavit Ikony v nabídkách na Zobrazit.
    • Pokud však chceme vyrobit snímky jednotlivých ikon, nastavíme jejich zobrazení na velké (jen pro tento případ, jinak malé).

Tvorba snímků obrazovky a grafiky

Grafiku v jednotlivých souborech nenahrazujeme přímo, ale pro každou kapitolu vytvoříme soubor s obrázky v programu Draw a až z něho obrázky přeneseme do textových souborů (provede administrátor). Tím se zabezpečí lepší přehled a sníží se riziko omylů.

Postup

  • Před začátkem práce je třeba si na stránce se stavem překladu ověřit, co už je hotové anebo na čem se už pracuje.
  • Pro každou kapitolu vytvoříme samostatný soubor s grafikou (pro češtinu prozatím neexistují).
    • například pro kapitolu GS4003-StylesAndTemplates.odt vytvoříme soubor GS4003.odg
  • Do grafického souboru z textového souboru (převedeného ze složky source) zkopírujeme všechnu grafiku – jsou to rastrové obrázky, vektorové se nepoužívají. Nejlépe tak, že větší obrázky umístíme na snímku podle čísla strany (necháme prázdné stránky, pokud je třeba).
  • Vytvoříme odpovídající snímky obrazovky a vložíme je do grafického souboru pod originál (a nebo vedle, pokud jde o malé obrázky, např. ikony).
    • Snažíme se dodržet vzhled a velikost originálu.
    • Pokud je třeba, obrázek ořežeme v externím editoru obrázků.
    • Dáváme pozor na to, abychom nenasnímali (v pozadí) nějaké osobní záležitosti.
  • Doplníme kresby, pokud je třeba.
    • Snažíme se dodržet vzhled a velikost originálu.
  • Soubor pošleme administrátorovi, který ho přidá k ostatním grafickým souborům a grafiku zkopíruje do zdrojových textových dokumentů.

Důležité odkazy

Diskusní skupina SK + CS komunit LibreOffice Guide

Hlavní repositář pro překlady

Hotové LibreOffice Guide (slovenská verze)

Odkaz pro přihlášení v OmegaT

Oficiální konference LibreOffice komunity pro CS (doporučuji se přihlásit minimálně na lokalizace@cz.libreoffice.org)

Oficiální slovníček se schválenými termíny (překlady termínů dohodnuté v konferenci lokalizace@cz.libreoffice.org):

  • Pro stažení - v Linuxu lze příkazem po2csv převést stažený *.po soubor na *.csv, který můžeme naimportovat do LibreOffice Calc a následně vytisknout.

Stav překladů do češtiny

Stav přípravy anglického originálu LibreOffice Guides (Eng)