Documentation/Development/zh-hans

From The Document Foundation Wiki
Jump to: navigation, search

中文用户指南的主要工作是翻译,所以这里只对文档制作流程进行翻译,而具体的英文文档制作工作就没有翻译了。翻译工作的流程和工作将陆续补上。

文档开发

第一版的LibreOffice用户指南是在OpenOffice.org项目用户指南的基础上编写的,这个LibreOffice的指南很大程度上是由社区撰写并在著佐权(copy-left,另一种形式的版权)许可下发布。文档经过重新命名及更新,已经作为LibreOffice的正式文档发布。文档的英文团队和许多本地化团队正通过使用作为ECM(Enterprise Content Management,企业目录管理系统)进行文档开发。

如果您希望加入我们共同为LibreOffice文档做出贡献,请向 文档团队邮件列表发送一封邮件,介绍您自己并申请Alfresco平台的帐号。我们期待您的加入。

若想注册这个邮件列表,请向 documentation+subscribe@global.libreoffice.org 发送一封空邮件,之后您将得到一封回复邮件,按照回复邮件中的说明进行操作即可加入。


成为文档团队的第一步

我们为文档团队撰写了《贡献者指南》,指南中的一些章节的草案可在下面获得(简体中文版正在翻译当中,贡献者指南将不再翻译,若您对《贡献者指南》的理解有困难,那么将很难参与到LO文档翻译的工作中。):

用户指南模板:

LibreOffice 3.4 and 3.5

LibreOffice 3.3

指南User Guides

ODFAuthors工作流程(此表格需要更新;Alfresco的工作流程与之有些不同))

下面的是使用Alfresco的工作流程。Alfresco的工作流程目前没什么用,我们在使用ODFAuthors站点进行开发。首先,这里有使用ODFAuthors的说明,其后有使用Alfresco的说明。

使用ODFAuthors站点e

  1. 创建文档草案,将其上传至相关书目的草案文件夹中。
    1. 根据以下方式创建文档草案:
      1. 最新的文档模板(目前为currently LO_3_4_chapter_template.ott)
      2. 制作LO用户指南的odt.格式。
        1. 命名约定:名称_缩略信息_日期.odt
          1. 多词组命名:多个词组中,词组间无空格,每个单词首字母大写(GettingStartedWithCalc)
          2. 日期格式:YYYYMMDD (20120511)
          3. 缩略信息:
            1. 草案:作者名字缩写
            2. 审阅者信息:作者名字缩写后以下划线跟上审阅者名字缩写。(_DEL_JHW_)
            3. 作者的批准变更:移除审阅者信息
    2. 将草案上传至相应的草案文件夹:
      1. 首先您需要用于从文档团队邮件列表中获得的ODFAuthors网站的账户和密码。(documentation@global.libreoffice.org)
      2. 登录ODFAuthors网站。
        1. 选择LibreOffice > English > (对应的文档文件夹) > Drafts。找到相应的文件夹作为上传目的地。
        2. 点击 "Add new"选项,并点击下拉菜单中的File。
        3. 输入标题以便描述文档。
        4. 点击Browse按钮来告知网站对应的文件在您硬盘上的位置。
          1. 点击Save按钮上传文件。
        5. 提交文档以供审阅。
          1. 点击"State: Internal draft"并选择"Submit for publication"。(其状态会改为 "State: Pending review"。)
          2. 注销。
          3. 向文档团队邮件列表报告你的工作(documentation@global.libreoffice.org)
      3. 下载文档以便审阅:
        1. 登录到ODFAuthors。
        2. LibreOffice > English > (对应的文档文件夹) > Drafts.
        3. 点击需要下载的文件。此时浏览器会打开一个对话框来下载文件。
        4. 改变文件状态:
          1. 点击 "Check out"后面的"Actions"。
          2. 点击"State: Pending review" 并选择Retract。(其状态会改为"State: Internal draft"。
      4. 上传审阅后的文件:
        1. 登录到ODFAuthors.
        2. LibreOffice > English > (对应的文档文件夹) > Feedback.
        3. 点击"Add new"并点击其下拉菜单中的File。
        4. 输入标题以便描述文档。
        5. 点击Browse按钮来告知网站对应的文件在您硬盘上的位置。
          1. 点击Save按钮上传文件。
        6. 提交文档以供审阅。
          1. 点击"State: Internal draft"并选择"Submit for publication"。(其状态会改为 "State: Pending review"。)
        7. 更改已审阅文档的状态。
          1. 转至包含有你审阅过的文件的草案文件夹。
          2. 点击 "Check in"后面的"Actions"。.
        8. 注销。
          1. 向文档团队邮件列表报告你的工作(documentation@global.libreoffice.org)。通常,作者审阅您做出的更改,并自行决定是否接受这些更改。

: 下面是一Alfresco站点的工作流程与之相同。

使用 Alfresco 站点

  1. 创建文档草案,将其上传至相应的地方。
    1. 根据以下方式创建文档草案:
      1. 最新的文档模板(目前为currently LO_3_4_chapter_template.ott)
      2. 制作LO用户指南的odt格式。新制作的文档需要使用相应的命名约定,命名约定可在所有文档的第20页发现。
    2. 将草案上传至相应的草案文件夹:
      1. 首先您需要用于从文档团队邮件列表中获得的Alfresco网站的账户和密码。(documentation@global.libreoffice.org)
      2. 登录Alfresco站点。
        1. Repository (在顶部) > English (在左边) > Documentation > (对应的文档文件夹) > Drafts。这些步骤能找到您文件上传的目的文件夹。
      3. 点击Upload按钮(在顶部),然后会弹出一个窗口。
        1. 点击内容为一张纸和放大镜的图标来浏览您计算机上的草案文档。
        2. 点击“Upload file(s)”按钮开始上传。(上传过程中将显示文件名)
        3. 当上传完毕Upload file(s)按钮将变为OK。点之。
        4. 如果上传失败,重试。(有时需要将文件上传2-3次才能成功。)
        5. 此时文件将出现在草案文件夹中。
    3. 提交文档以供审阅。
      1. 在文件的右边找到“+More”
      2. 点之以打开一个下拉列表。
      3. 选择Submit for review。(文件将转至校对文件夹中)
        1. 向文档团队邮件列表报告你的工作(documentation@global.libreoffice.org)
  2. 审阅者检查草案文档,对草案进行跟进、检查并提出修改意见等校对工作。
  3. 作者(或其他人,这取决于撰写情况)修订草案,移除修订中的更改,将文件转至Drafts space。——或跳至第五步。
  4. 根据需要重复2、3两步。
  5. 当一切完成了,作者(或其他人)将文件从Reviewed space提至Copyediting/Proofing space.
  6. 编审将跟进文件的修改,并将其反馈至Feedback。
  7. 作者(或其他人)接受或拒绝做出的修改,将文件放至Indexing/Final下的文件夹,并将其标记为可供进一步进行处理。
  8. 书的索引制作人员或任意的协调员进行最终的检查并将这些文件放至Published文件夹(或打回做进一步处理)。
  9. 书的协调与/出版者/或其他人将文件输出成多种格式(PDF等)以供出版,并将其复制到工作文件夹中以便进行下一次修订。

如果您有任何问题,请使用Documentation Team mailing list#documentfoundation connect via webchat.

如果您正在处理一个章节,请将您名字的缩写(或您的wiki用户ID)放至下表中对应的行。当完成了相应的工作,请将你把文件提交给Alfresco的日期也填上。

若想得到更多关于审阅和更新For more information on how to review and update LibreOffice用户指南的信息(包括创建图片、交叉引用、索引和出版),请参见Producing LibreOffice User Guides


入门指南

LO v3.3英文版已经出版。 LO v3.4英文版正在进行最后的校对。(本文根据对应的英文wiki翻译,可能与实际情况有些延迟)

待办事项 将指南更新到LO 3.5。详见3.5 New Features and Fixes以获得更多信息。 此页面上的信息可能有些混乱,注意自己判断。

下面是列出的正在进行的工作。请随意自己添加项目。

常规: 每个章节的版权页:

  • 更改LO版本号及出版日期。

Chapter 1 (Intro)

Chapter 2 (Setup)

Chapter 3 (Styles & Templates)

Chapter 4 (Writer)

  • Better UI for Header and Footers handling
  • Better page breaks indicators (may not be needed in GS)
  • Word count dialog
  • Bundled LightProof grammar checkers; other grammar checking improvements

Chapter 5 (Calc)

  • New multiline input bar
  • New option to specify the initial number of sheets in new documents

Chapter 6 (Impress)

Chapter 7 (Draw)

Chapter 8 (Base)

Chapter 9 (Math)

Chapter 10 (Printing etc)

Chapter 11 (Graphics)

Chapter 12 (Web Pages)

Chapter 13 (Macros)

Chapter 14 (Customizing)

Appendix A (Shortcuts)

Appendix B (Open Source)


Status of tasks

Chapter Draft/updated Reviewed Edit/proof Published Checkout
1 Introducing LO
2 Setting Up LO
3 Styles & Templates  
4 Writer
5 Calc
6 Impress
7 Draw
8 Base
9 Math
10 Printing
11 Graphics
12 Web Pages
13 Macros
14 Customizing
A Shortcuts
B Open Source


Writer Guide

The first edition of this book, for LO 3.3, has been published.

The second edition of this book, for LO 3.4, has been published.

TO DO: Update to LO 3.5, replace screenshots and other figures as needed. Include any enhancements or corrections that have been identified.

General:

Chapter 1 (Intro)

Chapter 2 (Setup)

Chapter 3 (Text)

Chapter 4 (Page Layout)

Chapter 5 (Printing etc)

Chapter 6 (Intro to Styles)

Chapter 7 (Working with Styles)

Chapter 10 (Templates)

Appendix A (Keyboard Shortcuts)

Status of tasks

Chapter Draft/updated Reviewed Edit/proof Published Checkout
1 Intro
2 Setup
3 Text
4 Format Pages
5 Printing
6 Intro Styles
7 Work with Styles  
8 Graphics
9 Tables
10 Templates
11 Mail Merge
12 TOCS, Indexes
13 Master Docs
14 Fields
15 Forms
16 Customizing
A Shortcuts

Calc Guide

The first edition of this book, for LO 3.3, has been published.

TO DO: Update to LO 3.4, replace screenshots and other figures as needed.

General:

  • Use files in Drafts folder for the book. Use the Template Changer extension to apply the v3.4 chapter template (LO_3_4_chapter_template.ott, available from the Documentation > Resources folder in Alfresco).
  • Check screenshots for changes. Use silver/gray theme for any replacements needed. Use LO Galaxy icon set (Tools > Options > LO > View).
  • If the same topic is covered here as in Getting Started with Calc, use the same text in both places unless it should be discussed in more detail in this book.
  • Change arrows in menu paths to > (to match most other books).
  • Replace any references to "DataPilot" with "Pivot Table".
  • Improve indexing in all chapters. Many topics should be indexed that are not.

Chapter 1 (Intro)

  • Redesigned Move/Copy Sheet dialog (Edit->Sheet->Move/Copy) - put in section on "working with sheets". Reuse what is written for Getting Started.
  • When the document is encrypted with a password, you can now change the password while the document is open, from File->Properties->General->Change Password. The button is enabled only when the document is encrypted with a password.

Chapter 2 (Data Entry etc.)

  • Support for autofilter per sheet: It is now possible to set autofilter per sheet without manually creating named database ranges prior to setting autofilter. Previously Calc only supported one autofilter per document, which caused the previous autofilter to disappear when setting another one even on a different sheet unless a named database range was created beforehand.
  •  ?Expand section on filtering a bit? Also refer to Chapter 13 (Calc as D/B) for examples of use.
  • See [Bug 42339] EDITING and VIEWING cell borders differs from expected and PRINTING -- does any of this belong in this chapter, and/or in another chapter?

Chapter 3 (Charts and Graphs)

  • Mention ability to add & remove color charts and refer to info in Chapter 14.Chapter 8 (DataPilot)* DataPilot is now named Pivot Table.
  • Support for unlimited number of fields: Previously DataPilot only supported up to 8 column/row/data fields and up to 10 page fields. 3.4 has lifted this restriction to allow unlimited number of fields in each field type.
  • Named range as data source: With 3.4 it is now possible to use a named range as the data source for DataPilot. This allows, for example, addition of new rows to the data source and update of the DataPilot table to reflect the new data, without manually changing the data source range in the DataPilot dialog.

Chapter 4 (Styles & Templates)

  • Check info (especially Templates) against Chapter 3 of Getting Started and revise here as needed.

Chapter 9 (Data Analysis)

  • Multiple subtotals on a single sheet: It is now possible to define more than one subtotal range in a single sheet via Data->Subtotals. Previously, setting a second subtotal range removed the first one if they were on the same sheet.

Chapter 10 (Linking)

  • Preserve OLE links to other Excel documents when importing an Excel document. OLE links get converted to external references upon import. Previously, Calc ignored OLE links and cells containing OLE links resulted in error upon import.

Chapter 13 (Calc as D/B)

  • Named ranges in sheet-local scope: Previously, Calc only supported named ranges in global scope, that is, all named ranges were made available for the entire document regardless of the current sheet. In 3.4 Calc now supports named ranges that are local to a sheet. The named range dialog (Insert->Names->Define) has been modified to reflect this change.

Chapter 14 (Setup & Customizing)

  • Color Charts: Adding and Removing color charts is now possible from Tools->Options->Charts->Default Colors.


Status of tasks

Chapter Draft/updated Reviewed Edit/proof Published Checkout
1 Intro GX 1 Dec 2011
GX 14 Dec
JHW 5 Dec;
returned to GX
GX 5 Dec
2 Enter Edit Format Data GX 1 Dec
3 Charts & Graphs
4 Styles & Templates
5 Graphics
6 Printing
7 Formulas & Functions
8 DataPilot (now Pivot Tables) Martin Fox
9 Data Analysis
10 Linking Calc Data
11 Sharing & Reviewing
12 Calc Macros
13 Simple Database
14 Customizing
A Shortcuts
B Function Descr
C Error Codes


Impress Guide

The first edition of this book, for LO 3.3, has been published.

To do: update to LO 3.4, replace screenshots and other figures as needed.

General:

  • Use files in Drafts folder for the book. Use the Template Changer extension to apply the v3.4 chapter template (LO_3_4_chapter_template.ott, available from the Documentation > Resources folder in Alfresco).
  • Check screenshots for changes. Use silver/gray theme for any replacements needed. Use LO Galaxy icon set (Tools > Options > LO > View).
  • If the same topic is covered here as in Getting Started with Impress, use the same text in both places unless it should be discussed in more detail in this book.
  • Improve indexing in all chapters. Many topics should be indexed that are not.

Chapter 2 (Slide masters, style & templates))

  • Check info (especially Templates) against Chapter 3 of Getting Started and revise here as needed.

Chapter 7 (Spreadsheets, Charts, etc)

  • Mention ability to add & remove color charts and refer to info in Chapter 11.

Chapter 10 (Printing, Exporting, etc)

  • Improved HTML export with an image thumbnail gallery of the slides on the contents page.

Chapter 11

  • Color Charts: Adding and Removing color charts is now possible from Tools->Options->Charts->Default Colors.

Status of tasks

Chapter Draft/updated Reviewed Edit/proof Published Checkout
1 Intro Feb 2012
2 Slide Masters Feb 2012
3 Text Feb 2012
4 Pictures Feb 2012
5 Manage Objects Feb 2012
6 Format Objects Mar 2012 (v3.5)
7 Spreadsheets
8 Slides Notes Handouts
9 Slide Shows
10 Customizing
A Shortcuts


Draw Guide

The first edition of this book, for LO 3.3, has been published.

TO DO:

  • update to LO 3.4, replace screenshots and other figures as needed.
  • update to LO 3.5

Update to 3.4

General:

  • Use the Template Changer extension to apply the v3.4 chapter template (LO_3_4_chapter_template.ott, available from the Documentation > Resources folder in Alfresco).
  • Check screenshots for changes. Use silver/gray theme for any replacements needed. Use LO Galaxy icon set (Tools > Options > LO > View).
  • If the same topic is covered here as in Getting Started with Impress, use the same text in both places unless it should be discussed in more detail in this book.
  • Improve indexing in all chapters. Many topics should be indexed that are not.
  • Martin Fox has identified some other differences, which will be added to this page.

Chapter 6 (Pictures)

  • Eyedropper is now called Color Replacer. New pix needed as well as name change in text.


Chapter Draft/updated Reviewed Edit/proof Published Checkout
1 Intro
2 Basic Shapes
3 Objects
4 Object Attributes
5 Combining
6 Edit Pictures
7 3D Objects
8 Tips & Tricks
9 Flowcharts
10 Advanced


Update to 3.5

General: see above (3.4)

Actual Software Updates: see Wiki (ReleaseNotes/3.5#Impress.2FDraw) and Website (http://www.libreoffice.org/download/3-5-new-features-and-fixes/)

Math Guide

The first edition of this book, for LO 3.3, has been published.

TO DO: Update to LO 3.4, as needed.


General: Use files in Drafts folder for the book. Use the Template Changer extension to apply the v3.4 chapter template (LO_3_4_chapter_template.ott, available from the Documentation > Resources folder in Alfresco).


Chapter Draft/updated Reviewed Edit/proof Published Checkout
Full book


Base Guide

General: Use files in Drafts folder for the book. Use the Template Changer extension to apply the v3.4 chapter template (LO_3_4_chapter_template.ott, available from the Documentation > Resources folder in Alfresco).

To Do:

Chapter Draft/updated Reviewed Edit/proof Published Checkout
1 Introducing Base DEL 10 Nov 2011,
DEL 29 Nov 2011
HZ 17 Nov 2011,
JHW 28 Nov 2011
JHW 1 Dec 2011
2 Planning/Designing your Database DEL
3 Data Input and removal
4 Data Output
5 Exchanging Data
6 Customizing your Database Design
7 More Customization
8 Using Base at Work
Appendix I Build the Example Database
Appendix II Overview of a Database
Appendix III Further Reading on Database Design
Appendix IV Editing the Base Document File


Other Documents

Below are a few of the other documents to be developed.

Administrators' Guide

Could be based on the OpenOffice.org Admin Guide.

Basic Programmers' Guide

Could be based on the OpenOffice.org BASIC Programmers' Guide.

Developers' Guide

Could be based on the OpenOffice.org Developers' Guide.

What To Do When Rebranding

Below is a summary of the things to do during rebranding of an OOo doc to LO. See How to rebrand documents from OpenOffice.org to LibreOffice for details.

  • Apply LibO3.3 chapter template.
  • Change OpenOffice.org and OOo to LibreOffice, but be careful of places where this may be wrong (e.g., "In earlier versions of ...") and need rewriting.
  • Change formatting of Tip/Note/Caution tables to match those in the LibO3.3 template.
  • Check the links and fix as needed (if they refer to OOo). Refer to Chapter 1 of Getting Started for correct links.
  • Change the style for referring to other chapters from "Chapter X (Title of chapter)" to "Chapter X, Title of chapter,".
  • Change table formatting to: Borders horizontal only, below rows only, except above heading; heading row background gray 10%. No change to line color/width.
  • Check index entries (especially for "OpenOffice.org") and change if required.