Remover o apóstrofo de valores numéricos interpretados como textos no Calc

From The Document Foundation Wiki
Jump to: navigation, search


O uso frequente de procedimentos de cópia e colagem de conteúdos, em especial de origens variadas como páginas da Internet, arquivos texto ou outros aplicativos, pode resultar numa interpretação equivocada de valores numéricos como textos.

Em alguns casos, essa interpretação pode prejudicar os resultados dos cálculos na planilha.

Observe o exemplo abaixo:

A apostrofo 0.PNG

Note que, na célula B4, temos uma fórmula =SOMA(B2:B3), cujo resultado momentâneo é 20. Ou seja, o valor 10, da célula B2, não está sendo incluído no cálculo. Ao posicionarmos na célula B2, podemos observar que há um apóstrofo antes do número. Esse apóstrofo faz com que o valor numérico 10 seja interpretado como um texto e, por isso, não seja contabilizado.

Para resolver o problema, basta uma simples operação de remoção do apóstrofo.

No entanto, caso você tenha muitas células com esse problema, você pode utilizar a função Editar > Localizar e substituir:

  1. no campo Pesquisar por coloque ^.
  2. no campo Substituir por coloque &
  3. clique no botão Mais opções e marque a opção Expressões regulares



A apostrofo 2.PNG

  1. clique no botão Substituir todos para, então, eliminar os apóstrofos em todas as células da planilha.

Ao eliminar os apóstrofos das células com valores numéricos, os cálculos passarão a considerar esses valores. Como no nosso exemplo inicial, agora corrigido:

A apostrofo 3.PNG

Dica: uma maneira fácil e visual de identificarmos valores numéricos com o apóstrofo é a função Exibir > Realce de valor. Ao utilizá-la:

  1. os números serão apresentados em azul (inclusive datas);
  2. os textos serão apresentados em preto;
  3. as fórmulas serão apresentadas em verde.

Caso você encontre valores numéricos apresentados em preto, é provável que a interpretação esteja sendo feita como texto através do apóstrofo na primeira posição da célula.



Autor: Gustavo Pacheco, fevereiro/2011.