Documentation/RecentStringChanges

From The Document Foundation Wiki
Jump to: navigation, search

This page will keep track of user-visible strings that were updated for a certain release in order to help documentation maintainers update the help pages and manuals.

5.3

Other

  • Bullet & Numbering dialog
    • Numbering Type → Numbering (tab)
    • at: → Tab stop at: (tab)
    • core commit
  • "Hyperlink" has been changed to "Link"

5.2

Writer

  • Insert ▸ Table of Contents and Index ▸ Table of Contents, Index or Bibliography
    • Insert Index or Table of Contents → Table of Contents, Index or Bibliography (dialog title)
    • Index or Table of Contents → Type (tab)
    • core commit
    • Help commit
  • Compress Image dialog
    • Original size → Actual dimensions
    • View size → Apparent dimensions
    • Image capacity → Image size
    • New capacity → New size
    • core commit
    • Help missing (tdf#95490)
  • Find & Replace dialog (Edit ▸ Find & Replace)
    • Search for Paragraph Styles → Paragraph Styles
    • Help commit

Calc

  • Find & Replace dialog (Edit ▸ Find & Replace)
    • Search for Cell Styles → Cell Styles
    • Search Formatted Display String → Formatted Display (also on the Find toolbar)
    • Search in all sheets → All sheets
    • core commit
    • Help commit
  • File ▸ Properites:
    • Number of ... → ... (Pages, Cells, Sheets, Formula groups)
    • Help commit

Impress

  • Slide Show ▸ Slide Show Settings
    • dialog title: Slide Show → Slide Show Settings
    • Type → Presentation Mode
    • Default → Full screen
    • Window → In a window
    • Auto → Loop and repeat after
  • core commit
  • Help commit

Options

  • LibreOffice ▸ Memory: Graphics Cache → Image Cache
  • LibreOffice ▸ View: Icon size and style → Icon size + Icon style
  • LibreOffice ▸ Accessibility: Allow animated graphics → Allow animated images
  • LibreOffice ▸ Advanced:
    • Optional (Unstable) Options → Optional Features
    • Expert Configuration → Open Expert Configuration
  • LibreOffice ▸ Online Update: Send OS version & simple hardware info → Send OS version and basic hardware information
  • LibreOffice Writer ▸ View + LibreOffice Writer ▸ Print: Graphics and objects → Images and objects
  • Load/Save ▸ HTML Compatibility: Copy local graphics to Internet → Copy local images to Internet

Dialog Designer

Templates


Other

  • Termchange: Graphic → Image [4]
    • toolbar name: Graphic Filter → Image Filter
    • Presentation Minimizer in Impress:
      • Graphics → Images
      • Delete cropped graphic areas -> Delete cropped image areas
      • Break links to external graphics → Embed external images
      • Create static replacement graphics for OLE objects → Create static replacement images for OLE objects
      • Help missing and decided to be not needed tdf#39306

5.1

See also: Comparison between menus in LO 4.4.7.2 and 5.1.0.2

Writer

  • Insert ▸ Indexes and TablesInsert ▸ Indexes and Tables of Contents
  • dialog title Insert Index/Table → Insert Index or Table of Contents
  • Create Index/Table → Create Index or Table of Contents (section title in the previous dialog)
    • no need to update Help
  • View ▸ Web LayoutView ▸ Normal and View ▸ Web
  • Insert ▸ Footnote/EndnoteInsert ▸ Footnote and Endnote ▸ Footnote or Endnote
  • View ▸ Hide ImagesView ▸ Images and Charts
  • Table ▸ AutoFormatTable ▸ AutoFormat Styles

Tools toolbar

  • Hide Images → Images and Charts
  • Direct Cursor On/Off → Toggle Direct Cursor Mode

Table toolbar

Context menus

  • Update/Edit/Delete Index or Table → Update/Edit/Delete Index or Table of Contents

Calc

  • Window ▸ FreezeView ▸ Freeze Rows and Columns
  • View ▸ Page Break PreviewView ▸ Page Break
  • Format ▸ Sheet ▸ Tab ColorSheet ▸ Sheet Tab Color
  • Edit ▸ Sheet ▸ Move/Copy SheetSheet ▸ Move or Copy Sheet

Context menus

  • Export as graphic -> Export as image (Calc)
  • Delete Selected Rows/Columns → Delete Rows/Columns
  • Delete Row/Column Contents → Clear Contents (however, dialog Delete Contents is invoked)
  • Delete Contents → Clear Contents (for cells)
  • Hide → Hide Rows/Columns
  • Show → Show Rows/Columns
  • no need to update Help for these commands

Draw/Impress

  • 3D Effects dialog: icon Convert to Lathe Object → Convert to Rotation Object
  • toolbar names:
    • Circles and Ovals → Legacy Circles and Ovals
    • Rectangles → Legacy Rectangles
  • Insert ▸ SlideSlide ▸ New Page/Slide
  • Insert ▸ Duplicate SlideSlide ▸ Duplicate Page/Slide
  • Edit ▸ Delete SlideSlide ▸ Delete Page/Slide
  • View ▸ Notes PageView ▸ Notes

Math

  • Tools ▸ CatalogTools ▸ Symbols

5.0

  • Hyperlink dialog (Insert ▸ Hyperlink): Mail & News → Mail (radio buttons removed)
  • Find & Replace dialog (Edit ▸ Find & Replace): ... → Similarities, ... → Sounds...
  • Drawing Object Styles → Graphic Styles (style category in Draw and Impress)

Writer

  • Table ▸ AutoFit ▸ Distribute Columns Evenly renamed to Table ▸ AutoFit ▸ Distribute Columns Equally.

Frame toolbar

  • Borders, add lines; SHIFT to add and remove → Borders (Shift to overwrite)
  • Line Style → Border Style
  • Line Color (of the border) → Border Color

Tools toolbar

Formatting toolbar

  • Increase Font → Increase Font Size
  • Reduce Font → Decrease Font Size

(also in Text Formatting toolbar in Impress)

Chart

  • View ▸ Chart Data TableView ▸ Data Table

Formatting toolbar

  • Horizontal Grid Major/Major&Minor/Off → Horizontal Grids
  • Vertical Grid Major/Major&Minor/Off → Vertical Grids

Basic

  • Edit ▸ Goto Line Number... renamed to Edit ▸ Go to Line.... Similarly, the corresponding dialog's title was renamed from Goto Line to Go to Line.

Options

  • Internet ▸ E-mail: ... → Browse...
  • LibreOffice Writer ▸ Tables: Default → New Table Defaults

4.4

  • Optional/Custom Hyphens → Soft Hyphens
    • Insert ▸ Formatting Mark
    • Tools ▸ Options ▸ LO Writer ▸ Formatting Aids
    • Help commit

File Menu

Edit Menu > Changes core commit d61c55b4d11f4a4ffdf4fb75ba2e950de8ae2beb

  • Changes → Track Changes
  • Accept or Reject Changes → Manage Changes
  • Accept or Reject → Manage Changes
  • Comments → Comment on Change
  • Protect Records → Protect Changes
  • Record → Record Changes
  • Show → Show Changes
  • Help commit

Insert Menu

Toolbar buttons

Toolbar drop-downs

Dialogs

  • In Tools ▸ Options ▸ LibreOffice ▸ Personalization: Personas → Firefox Themes core commit I2505df2fb810fa7de51d28f5704bc1178671c3ac
  • In Tools ▸ Outline Numbering ▸ Position tab: “Minimum space numbering <-> textlabel” → “Minimum space between numbering and text”. core commit 9aba60c0f0f99d0a7c31bf291040f21bdd0e5b18
  • template*.ui: “Font Effect” (typo) → “Font Effects”
  • impswfdialog.ui: “Export All Slides (Uncheck exports current slide)” → “Export all slides (uncheck to export current slide)”;
    “Macromedia Flash (SWF) Options” → “Flash (SWF) Options”
  • addresstemplatedialog.ui (Writer: Tools ▸ Address Book Source): no dialog title → Templates: Address Book Assignment
  • symdefinedialog.ui (Math: Tools ▸ Catalog ▸ Edit): Typeface → Style
  • compressgraphicdialog.ui (Compress Image on an image): no dialog title → Compress Image
  • findreplacedialog.ui (Edit ▸ Find & Replace): Find → Find Next
  • headerfooterdialog.ui (Impress: Insert ▸ Header and Footer): no dialog title → Header and Footer
  • File ▸ Properties ▸ Statistics: Number of XXX → XXX
    • Help commit
    • still remains "Number of Pages/Sheets/Cells" in this dialog for a Calc document
  • File ▸ Export as PDF ▸ General: Embed OpenDocument file → Hybrid PDF (embed ODF file), PDF/A-1a → Archive PDF/A-1a