Rubrique générale - Étape 4

From The Document Foundation Wiki
Jump to: navigation, search
Environnement LibreOffice Module O Étape 4
Étape 4 Objectif opérationnel
Personnalisation
Durée : 1h30
Savoir personnaliser les barres d'outils et le clavier, créer ses propres barres d'outils
Fonctions mises en oeuvre QCM
  • Personnalisation du clavier
  • Personnalisation des barres d'outils
  • Création de sa propre barre d'outils
  1. Puis-je créer un raccourci vers les styles ?
  2. Une barre d'outils peut-elle contenir une autre barre d'outils ?
  3. Puis-je afficher, masquer des icônes d'une barre d'outils que j'ai créée ?

Maintenant que nous connaissons notre environnement de travail, nous allons apprendre à l’optimiser pour les travaux que nous réalisons. En effet, chacun a sa propre manière de travailler et la façon dont les barres d’outils ou le clavier sont paramétrés par défaut peut ne pas vous convenir.

Personnalisation du clavier

Une liste complète des raccourcis clavier est disponible dans l’aide. Pour y accéder :

  • Sélectionnez Aide de LibreOffice dans le menu Aide ou appuyez sur F1
  • Dans la fenêtre qui s’ouvre, cliquez sur le lien Raccourcis clavier de LibreOffice Writer
  • Un tableau regroupant tous les raccourcis s’ouvre

L’aide de LibreOffice vous apportera une foule de précisions et possède des exemples pour toutes les fonctionnalités. N’hésitez donc pas à y faire appel.

Création d'un raccourci

Lorsqu’un raccourci clavier existe, il est noté à côté de l’entrée de menu correspondante. Mais il est fréquent que celui dont on a le plus besoin ne soit pas défini ! Nous devons donc le créer. Nous allons donc ajouter un raccourci clavier pour insérer une image à partir d’un fichier.

1. Dans le menu Outils, sélectionnez Personnaliser

2. Dans la fenêtre qui s’ouvre sélectionnez l’onglet Clavier

G1S4 1.png

3. La fenêtre de cet onglet est décomposée en plusieurs parties :

  • la partie supérieure liste toutes les combinaisons possibles de touches et en regard, les fonctions auxquelles elles sont attribuées
  • la partie inférieure est décomposée en :
    • une première partie listant les catégories de fonctions. Vous retrouvez donc la plupart des menus de la barre des menus.
    • la seconde partie affiche les fonctions,
    • la troisième le raccourci que vous aurez attribué.

4. Dans Catégorie, sélectionnez Insérer

5. Dans Fonction, sélectionnez À partir d’un fichier

6. Dans la fenêtre du haut, sélectionnez le raccourci clavier que vous allez ajouter, pour notre exemple Ctrl+7. Choisissez un raccourci qui est libre. Les entrées qui sont grisées ne peuvent être utilisées, ce sont des raccourcis utilisés par LibreOffice ou le système et ils ne peuvent donc être choisis.

G1S4 2.png


7. Une fois le raccourci sélectionné, cliquez sur le bouton Modifier

8. Le raccourci s’est inscrit dans la partie Clavier en bas de la fenêtre.

9. Cliquez sur Ok pour refermer la boîte de dialogue et enregistrer la modification.

10. Le raccourci apparaît maintenant en face de la fonction correspondante dans le menu Insertion

G1S4 3.png

Nous avons attribué ce raccourci à Writer, c’est le choix proposé par défaut dans la fenêtre de dialogue, mais nous aurions pu appliquer ce raccourci à toute la suite (donc le rendre disponible sous Calc, Impress et Draw) en sélectionnant le bouton radio LibreOffice.

G1S4 4.png

Suppression d'un raccourci

Vous n’avez plus besoin d’un raccourci et souhaitez le libérer pour l’attribuer à une autre fonction ?

  1. Dans le menu Outils, sélectionnez Personnaliser
  2. Dans la fenêtre qui s’ouvre, sélectionnez l’onglet Clavier
  3. Sélectionnez la Catégorie et la fonction correspondante, le raccourci attribué s’affiche dans la partie Clavier
  4. Appuyez sur le bouton Supprimer
  5. Appuyez sur Ok pour refermer la boîte de dialogue et enregistrer la modification
  6. Vérifiez dans le menu que le raccourci n’apparaît plus

Enregistrement/Chargement

Ces options de la boîte de dialogue vont permettre d’enregistrer une configuration de raccourci et d’y faire appel quand vous le souhaitez.

  1. Affectez tous les raccourcis qui doivent l’être pour le module avec lequel vous travaillez
  2. Appuyez sur le bouton Enregistrer. Dans la fenêtre qui s’ouvre, sélectionnez le répertoire dans lequel doit être enregistré le fichier.
  3. Nommez-le et cliquez sur le bouton Ok pour refermer la boîte de dialogue.

Lorsque vous aurez à nouveau besoin de cette configuration, vous pourrez alors appuyer sur le bouton Charger, naviguer jusqu’au fichier et cliquer sur Ok pour qu’il s’affiche et que les raccourcis soient activés.

Personnalisation des barres d'outils

Les barres d’outils contiennent des icônes qui sont des raccourcis vers les fonctions les plus utilisées dans les modules. Bien sûr, celles que vous utilisez ne sont, là encore, peut-être pas celles qui sont affichées. Nous allons voir comment afficher des icônes supplémentaires ou au contraire en masquer. Chaque barre d’outils est constituée de la même façon.

Lorsqu’elle est ancrée :

G1S4 5.png

  • une poignée représentée par des points verticaux à gauche, cette poignée permet de déplacer la barre lorsqu’elle est ancrée,
  • des icônes regroupées par thèmes et séparées par des traits fins grisés
  • un bouton tout à fait à droite qui ouvre un menu comportant des options pour la personnalisation ou l’ancrage de la barre.

Lorsqu'elle est flottante :

G1S4 6.png

  • Son nom est inscrit dans la partie haute
  • Un double clic sur cette partie en maintenant la touche Ctrl, permet de l’ancrer,
  • Le triangle correspond au bouton et affiche le menu comportant des options pour la personnalisation ou l’ancrage de la barre.

Ce bouton qui comporte des options pour ancrer la barre, ou ancrer toutes les barres ou encore fermer la barre d'outils, regroupera les barres d’outils en haut de votre écran. L’espace nécessaire à l’ancrage se créera naturellement. Si vous souhaitez les déplacer en les glissant avec la poignée, un rectangle gris matérialisera son emplacement dans l’espace.

G1S4 7.png

Les barres principales sont affichées en permanence, les autres sont contextuelles. Par exemple, la barre Puces et Numérotations ne s’affiche que lorsque vous activez cette fonction, tout comme celle des tableaux.


Certaines barres contiennent d’autres barres, par exemple la barre Outils comprend aussi la barre Insérer. À chaque fois qu’un petit bouton en forme de flèche apparaît à côté d’une icône, c’est que cela cache quelque chose !

G1S4 8.png

Bien sûr, il vous est tout à fait possible d’ancrer cette barre ou de la laisser flotter, il suffit pour cela de la glisser.

Affiche/masquer des icônes dans les barres d'outils

Nous venons de le voir, les barres d’outils comportent un bouton qui permet d’accéder à des options de personnalisation, nous allons nous y attarder.

  1. Cliquez sur le bouton tout à fait à droite de la barre et sélectionnez Boutons visibles dans le menu qui s’affiche
  2. Une liste de toutes les icônes que contient la barre d’outils ainsi que leur nom s’affichent,
  3. Seules celles qui sont cochées sont visibles.
  4. Pour afficher ou masquer des icônes de la barre d’outils, ajouter une coche ou au contraire, retirez-la, en cliquant sur l’icône ou son explication
  5. La fenêtre se ferme immédiatement après que vous ayez cliqué, l’icône est maintenant présente ou absente suivant votre choix.

G1S4 9.png

Voilà déjà de quoi personnaliser votre environnement ! N’oubliez pas, si des barres d’outils vous manquent, elles se trouvent toutes sous Affichage ▸ Barre d’outils.

Ajouter des icônes complémentaires

Vous souhaitez avoir accès aux fonctions de dessin à travers la barre Outils, mais l’icône ne figure pas dans la liste. Pas de problème, nous allons donc l’ajouter.

1. Cliquez sur le bouton tout à fait à droite de la barre d’outils Outils, celui qui permet de la personnaliser 2. La fenêtre qui s’ouvre est identique à celle de personnalisation du clavier, mais elle s’est positionnée sur l’onglet Barre d’outils et affiche la barre Outils

G1S4 10.png

3. Cliquez sur le bouton Ajouter,une nouvelle fenêtre s’ouvre 4. Dans la partie Catégorie,descendez jusqu’à l’entrée Dessin et sélectionnez-la

G1S4 11.png

5. Dans la partie Commande, sélectionnez Afficher les fonctions de dessin 6. Cliquez sur le bouton Ajouter 7. L’icône apparaît maintenant dans la première fenêtre

G1S4 12.png

8. Fermez la fenêtre Ajouter des commandes en cliquant sur le bouton Fermer

Nous allons maintenant organiser la barre Outils et ajouter des séparateurs à l’icône Dessin

1. La fenêtre Personnaliser est toujours ouverte à l’écran, sélectionnez l’entrée Insérer dans la partie Commandes, le séparateur s’insérant en dessous de la sélection.

2. Cliquez sur le bouton Modifier et sélectionnez Début de groupe dans le menu

3. Une barre s’insère en dessous et la barre Dessin est bien maintenant dans un groupe à part

G1S4 13.png

4. Vous pouvez refermer la fenêtre de dialogue en cliquant sur le bouton Ok

Création de sa propre barre d'outils

Nous avons vu comment naviguer dans les catégories à la recherche des entrées et icônes souhaitées. Faisons un petit test en créant complètement notre barre d’outils de A à Z !

Nous souhaitons avoir sous la main différents outils pour traiter les images.

  1. Ouvrez la fenêtre Outils ▸ Personnaliser ▸ Barre d’outils
  2. Cliquez sur le bouton Nouveau. Une fenêtre s’ouvre vous demandant de nommer la nouvelle barre. Nous l’appelons Image.
  3. Refermez cette fenêtre

Maintenant, vous n’avez plus qu’à suivre la procédure que nous avons vue ci-dessus. Dans la barre d’outils que nous avons créée, certaines entrées n’ont pas d’icône, nous allons donc en ajouter.

G1S4 14.png

  1. Sélectionnez l'entrée sans icône
  2. Cliquez sur le bouton Modifier et sélectionnez Modifier l'icône
  3. Dans la fenêtre qui s’ouvre, choisissez une icône correspondant à la fonction, ou encore celle que vous préférez (mais évitez d’utiliser les icônes les plus courantes déjà utilisées)
  4. Cliquez dessus pour la sélectionner et appuyez sur Ok

G1S4 15.png

Elle s’est maintenant insérée là où vous le souhaitiez dans la barre d’outils. Refermez la boîte de dialogue, la nouvelle barre d’outils est disponible dans la fenêtre de travail.

Vous noterez la présence du bouton Importer. Vous pouvez donc importer un jeu d’icônes pour l’ajouter ou remplacer celles qui sont déjà présentes. Enfin, les entrées auxquelles vous n'avez pas ajouté d'icônes gardent leur nom.

En résumé

Vous maîtrisez maintenant complètement votre environnement de travail puisque vous savez paramétrer des raccourcis clavier, adapter les barres d’outils ou encore en créer. Vous avez donc toute liberté d’utiliser au mieux l’espace de travail qui vous entoure afin qu’il vous soit rationnel et productif.