Installation de LibreOffice

From The Document Foundation Wiki
Jump to: navigation, search

Systèmes supportés : MS-Windows (XP, Vista, Seven, Windows 8, Windows 10), GNU/Linux (rpm / deb), MacOS-X (x86 et ppc).

Audio-cassette.png This page (may) contain content that is old and/or out of date.

If you have experience in this area, please review this page for accuracy. Reason: This pages talks about "MacOSX 10.4 (Tiger) ou supérieure Processeur Intel ou PowerPC" which is a very long time not supported any more by the TDF


Avant d'installer LibreOffice, consultez la page Prérequis logiciels et matériels qui apporte des informations importantes sur LibreOffice et sur les pré-requis à l'installation.


OpenGL

Depuis septembre 2015, notre dernière version est installée avec le rendu OpenGL activé par défaut. Cette configuration peut causer des problèmes avec certaines combinaisons matériels ↔ pilotes, générant des erreurs et des plantages.

Se reporter à la page OpenGL si vous êtes concernés.


Pré-requis Java

LibreOffice a besoin d'un environnement d'exécution Java (JRE) pour bénéficier de toutes ses fonctions.

Pour installer un environnement d'exécution Java ou pour vérifier si vous en disposez déjà, visitez le site officiel de Java

Il faut installer l'environnement d'exécution Java avant d'installer LibreOffice. Sous MS-Windows 64 bits, pour utiliser une version de LibreOffice 32 bits, installez Java en 32 bits (installation possible hors ligne ou en ligne); pour utiliser une version de LibreOffice 64 bits (à partir de LibreOffice 5.0), installez Java 64 bits (installation requise hors ligne après avoir téléchargé le fichier JRE).

Pour vérifier les autres pré-requis avant d'installer LibreOffice, voyez la page Lisez-moi.

La version 7 du JRE semble poser des problèmes suivant les configurations. Si vous rencontrez des comportements anormaux (blocage intempestifs,...) essayez d'installer à la place la version 6 disponible ici.

Pour d'autres informations (en anglais), voyez les pages sur le développement et sur la configuration.


Télécharger LibreOffice en français

Téléchargement de la version "Évolution"

Téléchargement de la version "Stable"


Installation

Installation sur OS GNU/Linux

Besoins système

En règle générale, il est recommandé d'installer LibreOffice via les méthodes d'installation préconisées par votre distribution GNU/Linux particulière (telle que Ubuntu Software Center, dans le cas de Ubuntu). Ceci parce que c'est habituellement la façon la plus simple d'obtenir une installation dont l'intégration au système est optimisée. En fait, LibreOffice a sans doute été installé par défaut lorsque vous avez installé votre système d'exploitation GNU/Linux à l'origine. Cet installeur LibreOffice "autonome" est fourni pour les utilisateurs ayant besoin d'un aperçu, ayant des besoins spécifiques ou encore pour des besoins non ordinaires.

   Noyau Linux version 2.6.18 ou supérieure
   glibc2 version 2.5 ou supérieure
   gtk version 2.10.4 ou supérieure
   PC compatible Pentium (Pentium III ou Athlon recommandé)
   256 Mo de RAM (512 Mo de RAM recommandés)
   Jusqu'à 1,55 Go d'espace disponible sur le disque dur
   Un serveur X ayant une résolution de 1024x768 (une résolution supérieure est recommandée), avec au moins 256 couleurs
   Gnome 2.16 ou supérieur, avec les packages gail 1.8.6 et at-spi 1.7 (requis pour le support des outils de technologie assistive [AT]) ou une autre GUI compatible (telle que KDE, parmi d'autres).

Il y a une grande variété de distributions GNU/Linux et au sein de la même distribution, il peut également y avoir différentes options d'installation concernant les environnement de bureau ou interfaces (KDE vs Gnome, LXDE etc.). Certaines distributions fournissent leur propre version "native" de LibreOffice, qui peut avoir des fonctionnalités différentes de cette version LibreOffice communautaire. Il vous est possible d'installer la version LibreOffice communautaire à côté d'une version native. Cependant, il est en général plus sûr de supprimer la version "native" avant d'installer cette version communautaire. Consultez la documentation de votre distribution pour plus de détails ainsi que sur la manière de procéder.

Il est recommandé de toujours faire une sauvegarde de votre système et de vos données avant de supprimer ou d'installer des logiciels.

Assurez-vous d'avoir suffisament de mémoire libre alloué pour le répertoire temporaire du système et que vous disposez des droits suffisant en lecture, écriture et exécution.


Installation de LibreOffice sur les systèmes GNU/Linux basés sur Ubuntu ou Debian

Si vous avez une version précédente de LibreOffice déjà installée, alors vous devez d'abord la désinstaller avant d'aller plus loin. Pour des instructions sur la manière de procéder, veuillez lire la section ci-dessous intitulée Désinstallation d'une version précédente de LibreOffice. Pour des instructions sur la manière d'installer un pack de langue (après avoir installé la version anglaise de LibreOffice), veuillez lire la section ci-dessous intitulée Installation d'un pack de langue.

Lorsque vous décompressez l'archive téléchargée, le contenu a été décompressé dans un sous-répertoire. Ouvrez une fenêtre de gestionnaire de fichiers et changez de répertoire pour celui commençant par \, suivi par le numéro de version et des informations sur la plateforme. Ce répertoire contient un sous répertoire appelé "DEBS". Changez de répertoire pour le répertoire "DEBS".

Faites un clic avec le bouton droit de la souris dans le répertoire et choisir dans le menu contextuel "Ouvrir dans un terminal". Une fenêtre de terminal s'ouvre. À partir de la ligne de commande de la fenêtre de terminal, saisissez la commande suivante (il vous sera demandé de saisir votre mot de passe root avant que la commande ne soit exécutée) :

   sudo dpkg -i *.deb

Pour les versions de numéro inférieur à 4.1.0 uniquement : La commande dpkg ci-dessus réalise la première partie du processus d'installation. Pour compléter ce processus, vous devez également installer les packages d'intégration à l'environnement de bureau. Pour ce faire, changez de répertoire pour le répertoire "desktop-integration" qui est à l'intérieur du répertoire "DEBS", en utilisant la commande suivante :

   cd desktop-integration

Maintenant, exécutez la commande dpkg de nouveau :

   sudo dpkg -i *.deb

Le processus d'installation est maintenant achevé et vous devez avoir les icônes de toutes les applications LibreOffice dans le menu Bureautique des applications de l'environnement de bureau.


Installation de LibreOffice sur les systèmes GNU/Linux Fedora, Suse, Mandriva, Mageia et autres utilisant les packages RPM

Si vous avez une version précédente de LibreOffice déjà installée, vous devrez alors la désinstaller avant de pouvoir aller plus loin. Pour des instructions sur la manière de procéder, veuillez lire la section ci-dessous intitulée Désinstallation d'une version précédente de LibreOffice. Pour des instructions sur l'installation d'un pack de langue (après avoir installé la version anglaise US de LibreOffice), veuillez lire la section ci-dessous intitulée Installation d'un pack de langue.

Décompressez l'archive téléchargée, peu importe l'endroit et le nom du dossier dans lequel vous la décompressez. Dans le gestionnaire de fichier, allez sur celui contenant le dossier contenant les fichiers d'installation décompressés de LibreOffice.

Ce répertoire contient un sous-répertoire appelé "RPMS", allez dessus pour le sélectionner.

Faites un clic avec le bouton droit de la souris et dans le menu contextuel choisir "Ouvrir un terminal". Une fenêtre de terminal s'ouvre. À partir de la ligne de commande de la fenêtre de terminal, saisissez la commande suivante (il vous sera demandé de saisir votre mot de passe root avant que la commande ne soit exécutée) :

   Pour les systèmes basés sur Fedora : su -c 'yum install *.rpm'
   Pour les systèmes basés sur Mandriva : sudo urpmi *.rpm
   Pour les autres systèmes basés sur RPM (Suse, Mageia etc.) : rpm -Uvh *.rpm

Si vous n'êtes pas loggé en tant qu'administrateur (root), il faudra commencer par faire la commande : su et entrer votre mot de passe administrateur, puis entrer l'une des commandes indiquées ci-dessus en fonction de votre système.

Jusqu'à la version 4.1, il fallait également installer les packages d'intégration à l'environnement de bureau pour compléter le processus. Pour ce faire, changez de répertoire pour le répertoire "desktop-integration" qui est dans le répertoire "RPMS", en utilisant la commande suivante :

   cd desktop-integration

Le répertoire "desktop-integration" n'existe plus à partir cette version 4.1, l'intégration au bureau se fait donc à l'installation du reste.

Maintenant, exécutez de nouveau la commande d'installation :

   Pour les systèmes basés sur Fedora : su -c 'yum install *redhat*.rpm'
   Pour les systèmes basés sur Mandriva : sudo urpmi *mandriva*.rpm
   Pour les autres systèmes basés sur RPM (Suse, etc) : rpm -Uvh *suse*.rpm

Le processus d'installation est maintenant terminé et vous devez avoir les icônes de toutes les applications LibreOffice dans le menu Bureautique des applications de l'environnement de bureau.

Si vous désirez ajouter l'aide intégrée de LibreOffice, procédez exactement de la même façon à partir du dossier RPMS du pack "libreoffice-help".


Notes concernant l'intégration à l'environnement de bureau pour les distributions GNU/Linux non couvertes par les instructions d'installation ci-dessus.

Il doit être possible d'installer facilement LibreOffice sur d'autres distributions GNU/Linux non spécifiquement couvertes par ces instructions d'installation. Le principal aspect dans lequel peut résider une différence est l'intégration à l'environnement de bureau.

Le répertoire d'intégration à l'environnement de bureau contient aussi un pack nommé libreoffice3.3-freedesktop-menus-3.3.1.noarch.rpm (ou similaire). C'est un pack pour toutes les distributions GNU/Linux qui prennent en charge les recommandations/spécifications Freedesktop.org (Freedesktop.org Wikipedia logo v3.svg) et est fourni pour l'installation sur d'autres distributions GNU/Linux non couvertes par les instructions mentionnées ci-dessus.


Installation d'un pack de langue

Téléchargez le pack langue de la langue et de la plateforme souhaitées. Ils sont disponibles au même endroit que l'archive d'installation principale. À partir du gestionnaire de fichiers, extrayez l'archive téléchargée dans un répertoire (votre bureau par exemple). Assurez-vous que vous avez quitté toutes les applications LibreOffice (incluant le démarrage rapide, s'il est activé).

Changez de répertoire pour celui dans lequel vous avez extrait le pack de langue téléchargé.

Maintenant changez de répertoire pour le répertoire qui a été créé pendant le processus d'extraction. Par exemple, pour le pack de langue française pour un système 32-bit Ubuntu ou basé sur Debian, le répertoire est nommé LibO_ plus des informations de version, plus Linux_x86_langpack-deb_fr.

Maintenant changez de répertoire pour celui qui contient le pack à installer. Sur une distribution Ubuntu ou basé sur Debian, le répertoire sera DEBS. Sur les distributions Fedora, Suse, Mageia ou Mandriva, le répertoire sera RPMS.

À partir du gestionnaire de fichiers, faites un clic avec le bouton droit dans le répertoire et choisissez la commande "Ouvrir un terminal". Dans la fenêtre de terminal qui vient de s'ouvrir, exécutez la commande pour installer le pack langue (à l'aide de toutes les commandes ci-dessous, il vous sera demandé de saisir votre mot de passe root) :

   Pour les systèmes Ubuntu ou basés sur Debian : sudo dpkg -i *.deb
   Pour les systèmes basés sur Fedora : su -c 'yum install *.rpm'
   Pour les systèmes basés sur Mandriva : sudo urpmi *.rpm
   Pour les autres systèmes utilisant RPM (Suse, Mageia, etc.) : rpm -Uvh *.rpm

Maintenant, démarrez l'une des applications LibreOffice - Writer, par exemple. Allez dans le menu Outils et choisissez Options. Dans la boîte de dialogue Options, cliquez sur "Paramètres linguistiques", puis cliquez sur "Langues". Déroulez la liste "Interface utilisateur" et sélectionnez la langue que vous venez d'installer. Si vous le souhaitez, vous pouvez faire la même chose pour la "touche séparateur de décimales", la "monnaie par défaut" et la "langue par défaut des documents".

Après avoir réglé ces paramètres, cliquez sur OK. La boîte de dialogue se fermera et vous verrez apparaître un message d'informations indiquant que vos modifications ne seront activées qu'après avoir quitté et redémarré LibreOffice (rappelez-vous de quitter également le démarrage rapide s'il était actif).

La prochaine fois que vous lancerez LibreOffice, il démarrera dans la langue que vous venez d'installer.


Désinstallation d'une version précédente de LibreOffice

Les instructions données ci-dessous utilisent le gestionnaire de paquets Synaptic. Bien que Synaptic soit installé en standard sur de nombreuses distributions GNU/Linux, il ne l'est pas sur toutes. Vous devrez donc peut-être l'installer avant de continuer. Même si Synaptic n'est pas installé, il est en général disponible dans les dépôts logiciels du fournisseur de votre distribution GNU/Linux.

Pour installer Synaptic, utilisez le logiciel d'installation fourni par votre distribution GNU/Linux (comme la logithèque d'Ubuntu) ou bien ouvrez un terminal et saisissez la commande suivante (vous devrez fournir votre mot de passe administrateur) :

   sudo apt-get install synaptic

Il est possible que vous deviez confirmer votre accord pour installer des paquets supplémentaires dont Synaptic dépend.

Note pour les utilisateurs de KDE : si apt-get proteste que Synaptic n'est pas disponible, lancez KPackageKit et activez tous les dépôts logiciels en cochant les cases appropriées dans la page Préférences ("Settings"). Ensuite mettez à jour les dépôts en saisissant la commande sudo apt-get update dans un terminal (vous devrez fournir votre mot de passe administrateur pour que la commande soit exécutée). Ceci fait vous pouvez reprendre l'installation de Synaptic.

Une fois que vous vous êtes assuré que Synaptic est installé sur votre système, procédez de la la façon suivante pour désinstaller une version existante version de LibreOffice :

1.) Lancez le gestionnaire de paquet Synaptic.

2.) Cliquez dans le champ de recherche.

3.) Saisissez la chaîne de caractères "libreoffice3.6-ure" en remplaçant "3.6" par le numéro de version convenable. Il est possible que vous ayez à cliquer sur le bouton Résultats de recherche (Search Results) avant de voir ce critère de filtrage appliqué.

4.) Cette recherche va montrer un seul paquet correspondant. Faites un clic droit sur le nom de ce paquet et choisissez "Sélection pour suppression". Synaptic va alors vous proposer de marquer pour désinstallation d'autres paquets qui ont besoin de celui-ci pour fonctionner. Cela donne environ 60 paquets à désinstaller.

5.) Chercher ensuite le paquet qui s'occupe d'installer les icônes et lanceurs dans le menu principal. Pour les systèmes basés sur Debian, ce paquet s'appelle libreoffice-debian-menus, pour les distributions utilisant le système de paquets RPM, il s'appelle libreoffice3.6-freedesktop-menus-3.6.1-2.noarch.rpm (ou un nom équivalent pour une version différente ; si nécessaire remplacez freedesktop par mandriva ou suse) . Sélectionnez ce paquet pour désinstallation.

6.) Cliquez sur Appliquer et confirmez dans la boîte de dialogue qui apparait.

7.) Une fois que vous avez récupéré la main dans Synaptic, LibreOffice a été complètement désinstallé de votre système. Vous pouvez fermer Synaptic.


Désinstallation d'une version précédente de LibreOffice dans Mageia

Vous pouvez désinstaller la version de LibreOffice installée sur votre ordinateur en passant par le Centre de contrôle de Mageia, il vous sera demandé d'entrer votre mot de passe administrateur (root). Il suffit ensuite de décocher LibreOffice que vous trouverez dans la catégorie Bureautique/Suite des applications graphiques et de cliquer sur Appliquer. Il est possible, toutefois, que cela ne suffise pas et que, notamment, le pack de langue de la version précédente reste installé empêchant la nouvelle version d'utiliser le sien vous aurez un message d'erreur du style : "paquet libreoffice5.0-dict-fr-5.0.0.5-5.i586 déjà installé".

Votre LibreOffice, dans ce cas, restera en anglais. Pour l'avoir en français (ou dans toute autre langue de votre choix que vous aurez téléchargé), vous devez ouvrir une fenêtre de terminal (voir dans les Outils du Gestionnaire d'applications).

Si vous n'êtes pas loggé en tant qu'administrateur, commencez par entrer la commande : su

Puis entrez la commande :

  sudo urpme libreoffice5.0-dict-fr-5.0.0.5-5.i586

"libreoffice5.0-dict-fr-5.0.0.5-5.i586" étant le nom du fichier à supprimer (ici donné comme exemple, vous pouvez avoir un nom différent). Le plus simple consiste à copier-coller ce nom à partir du message d'erreur obtenu au moment de l'installation.


Installation sur Macintosh

Besoins système
   LibreOffice 4.3 peut fonctionner encore sur OS X 10.6 (Snow) ou supérieure
   LibreOffice 4.4.+ nécessite Mac OS 10.7 ou supérieure
   LibreOffice 5.+ nécessite Mac OS 10.8 ou supérieure
   Processeur Intel
   512 Mo de RAM
   Jusqu'à 800 Mo d'espace disponible sur le disque dur
   Périphérique graphique avec une résolution de 1024x768 et 256 couleurs (résolution supérieure recommandée)

Assurez-vous qu'il y ait assez de mémoire libre dans le répertoire temporaire du système et que vous bénéficiez des droits de lecture, d'écriture et d'exécution. Fermez tous les autres programmes avant de commencer l'installation.

Important, si la session n'a pas été ouverte en tant qu'administrateur, il faudra entrer l'identifiant et le mot de passe d'administrateur pour installer l'application.

  • toujours ouvrir l'image disque (extension .dmg) par ctrl+clic et confirmer l'ouverture
  • d'abord copier l'application LibreOffice dans le dossier Applications (celle qui apparait après avoir ouvert le gros fichier .dmg) ; il ne contient pas la traduction.
  • ouvrir LibreOffice une première fois via un ctrl+clic et accepter la question posée par le système (la vérification peut être assez longue, patienter le temps nécessaire)
  • quitter LibreOffice
  • lancer l'application de traduction (celle qui apparait après avoir ouvert le fichier .dmg du langpack)
  • lui indiquer le chemin de l'application LibreOffice, cliquer sur Terminer quand la fenêtre l'indique
  • lancer LibreOffice, une première fois par ctrl+clic, désormais traduit


Installation sur Windows

Sur MS-Windows, LibreOffice peut être installé sans problème à côté de MS-Office.

Pré-requis

Les Pré-requis logiciels et matériels pour l'installation de LibreOffice sur un système Windows sont les suivants:

  • Microsoft Windows 2000 (Service Pack 4 ou supérieur) : cette version n'est plus supportée à partir de la version 4.0 de LibreOffice
  • Microsoft, XP, Vista, Windows 7, Windows 8, Windows 10
  • Pentium-compatible PC (Pentium III, Athlon ou système plus récent recommandé)
  • 256 Mo de RAM (512 Mo de RAM recommandés)
  • Jusqu'à 1,5 Go d'espace disque disponible
  • Une résolution de 1024x768 (résolution supérieure recommandée), avec au moins 256 couleurs.


Des droits d'administrateur sont nécessaires pour le processus d'installation de la version officielle. Cependant, les versions LibreOffice Portable mis en paquet par PortableApps.com permettent d'installer le logiciel sans disposer de droit d'administration, sur une clé USB ou sur le disque dur.


Le programme d'installation permet de choisir d'utiliser LibreOffice comme application par défaut pour les formats de Microsoft Office. Il est possible de passer outre ce choix et définir directement cette option à l'aide des commutateurs de ligne de commande au lancement du programme d'installation :

  • /Msoreg = 1 forcera l'enregistrement de LibreOffice comme application par défaut pour les formats de Microsoft Office
  • /Msoreg = 0 supprimera l'enregistrement de LibreOffice comme application par défaut pour les formats de Microsoft Office

Le choix peut être fait aussi avec l’installeur en choisissant le mode « personnalisé », un écran permettra alors de choisir d’associer ou non LibreOffice à chacun des 3 principaux formats de fichier MS-Office (MS-Word, MS-Excel et MS-PowerPoint).


Il est recommandé de sauvegarder votre système et vos données avant de retirer ou d'installer des logiciels.


Installation

Vous n'avez pas à désinstaller toute version précédemment installée de LibreOffice ou OpenOffice.org. Si vous avez une installation existante de LibreOffice, tous vos paramètres seront préservés et l'ancienne installation sera tout simplement écrasée.


En revanche, aucune instance de cette application ne peut être ouverte au lancement de l'installation.


Quitter l'application (menu Fichier), qu'il s'agisse d'une version de LibreOffice ou OpenOffice.org. Vérifiez également que le démarrage rapide n'est pas activé. Si c'est le cas fermer également ce programme.

Parcourir le répertoire dans lequel vous avez téléchargé le programme d'installation, faire un clic droit sur ce dernier.

  • Pour les versions antérieures à la 3.5 choisir Éxécuter en tant qu'administrateur
  • Pour les versions à partir de la 3.5 choisir Installer.

L'installation démarre.

  • Pour les versions antérieures à la 3.5 le programme passe par une phase de "décompression" des fichiers d'installation et propose pour cela un dossier (choix modifiable).
  • Pour les versions à partir de la 3.5 l'installation proprement dite commence immédiatement.

Votre pare-feu peut éventuellement vous demander d'autoriser l'exécution du programme d'installation : accepter l'exécution chaque fois que vous y êtes invité.

Suivre les différentes étapes :

  • Choisir si vous voulez une installation par défaut, ou une installation personnalisée. L'installation personnalisée permet de choisir :
    • Quels composants LibreOffice installer,
      • L'installation de tous les modules est vivement conseillée, sous peine de rencontrer des dysfonctionnements.
      • Cette option n'est plus proposée à partir de la version 4.2.
    • Les packages de langue (le français est sélectionné par défaut),
    • Les dictionnaires (ne sélectionner que ceux dont vous avez réellement besoin permet d'améliorer les performances, voir également la FAQ Comment supprimer les dictionnaires que je n'utilise pas ?),
    • Les extensions.
  • Choisir si vous souhaitez ouvrir les documents Microsoft Office avec LibreOffice.
  • Choisir si un raccourci pour ouvrir LibreOffice doit être créé sur le bureau.

Une boîte de dialogue s'ouvre pour afficher la progression du processus d'installation qui peut prendre quelques minutes.


Installation de l'aide

Si vous n'installez pas l'aide, LibreOffice accèdera automatiquement au site Internet de l'aide quand vous utiliserez le menu Aide de LibreOffice. Il est possible d'installer l'aide sur le PC en téléchargeant le programme sur le site de téléchargement.


Déploiement / Migration

Se reporter à la page dédiée Déploiement / Migration