Frequently asked questions - Base

From The Document Foundation Wiki
< Faq‎ | Base
Jump to: navigation, search

Contents

Tutorial on using the Report Designer

The Report Designer tutorial, including screenshots, is available in a printable or downloadable format here (currently in French only, pending translation) : Tutoriel de l'Assistant de création de rapport.

If you choose to display the document in your browser, please wait a few moments for it to load.

Why should I use a Report ?

Some people feel that the only point in having a report is to format data from a database so that it can be printer.

A report designer, however, provides the user with a slew of essential tools to exploit the data stored in a database. It allows data to be presented in detail in various ways. One example might be for following time spent on a projet, displaying profits for the last week, or checking to see which is one's most profitable client. Reports can, for example, be used to create invoices ready to be sent. If you are studying a foreign language, they can be used to print a list of vocabulary relating to a given field, or to register your progress in learning that vocabulary. Another idea might be to follow your creations or designs, through the use of a simple database, and then via the Report Designer, creating a type of catalogue or brochure document containing illustrations and text. In other words, Reports can be used for many varied purposes.

The Report Designer gives access to a host of useful tools allowing elaborate reports to be created : advanced sorting and grouping options are present, as well as the possibility to use SQL queries, statements and functions. The Report Designer makes it significantly simpler to conceive and design complex reports with the help of drag and drop functionality. Additionally, the Report Designer also allows a user to insert graphs and images.

Required Configuration

The Report Designer is integrated into LibreOffice by default. It is however written in the Java programming language, and thus requires that the computer on which it is run have not only a pre-installed Java Runtime Environment (JRE), but that LibreOffice be configured to recognize that JRE in order to be able to use it.

In the Tools -> Options -> LibreOffice -> Java submenu (on Mac, this is in the LibreOffice -> Preferences submenu), check that a Java runtime environment has been found and recognized, and that the corresponding radio button has been ticked / activated, for the JRE of your choice. If no JRE appears in the window dialog, then either your version of the JRE is not recognized by LibreOffice, or else you do not have a JRE installed, and will have to download and install one accordingly JRE download site .

Installing the Report Designer

The Report Designer is actually an extension provided with the default installation of LibreOffice, at least for Windows and Mac. Some Linux distributions, for their own versions of LibreOffice, still supply this extension as a separate component that may have to be installed with the package management system of that distribution.


The Report Designer Interface

The sample database used for the present tutorial was obtained by using the default provided Table Creation Wizard and choosing HouseholdInventory from the Personal list of suggested databases.

Report Designer Toolbars

Report Controls Toolbar

The Report Controls Toolbar contains a range of buttons which can be used to add fields, labels, images (pictures, logos, photos, etc) and graphs to the report.

Main Toolbar

The Main Toolbar enables the addition of fields to a report, the switching on or off of the Report Navigator and the management of sorting and grouping options.*

Alignment Toolbar

The Alignment Toolbar is used for positioning fields and other elements within the report.*

Menu

The menu gives access to the other modules of LibreOffice. Two functions will be mentioned here in more detail : Insert for inserting images into the report and Format in order to use the conditional formatting possibilities for a given field.

Default Report Page

The default page that is displayed on starting the Report Designer is divided into 3 parts : Page Header, Detail, and Page Footer.

Floating Tool Panels

Add Field Panel

This panel is used to add a database field to the report via drag and drop or via the Insert menu.

Sorting and Grouping Panel

This panel is used to manage sorting and grouping options for the various elements of the report.

Report Navigator Panel

This panel enables a user to navigate the report document via a tree oriented list hierarchy of objects. Double-clicking on one of the entries in the navigator list will select that item on the report document for selection or editing.

Properties Panel

This panel enables a user to edit the properties of the control, element or object which is currently selected.

For example, when you select a field in a report, you can use the Properties Panel to define the data source for that field, and also other properties such as the element's height and width, its position, formatting, etc...

This panel also allows you to choose the type of document to be used as the output format for the report : either a Writer document (ODT) or a Calc document (ODS).

Creating a Report

Creating a Grouping

In order to create a report that groups data, you need to a add a new Grouping Header section, by choosing the field on which to group via the "Sorting and Grouping" button, panel, or corresponding entry in the Report Navigator (in the present example, we have used the DatePurchased field). Choose the desired sorting options (ascending or descending) and then Present in both the Group Header and Group Footer dropdown lists. Use the Add Field panel to place the grouped field within the Group Header section. You can then use the various available formatting options under the General entry of the Properties panel to format the field as you wish.

Detail Section

The Detail Section is designed to display a list of data from the database. Using the Add Field panel, add the fields that you want to use in your report to the Detail Section. Field and Label alignment can be slightly arduous, so use the Alignment Toolbar to help out. You can see what your final report will look like by clicking on the Execute Report button in the main toolbar.

Creating a Calculated Field

in the page footer :

Whilst it is possible to use the report as you have just created it, it can also be improved. For example, you might want to add a field that calculates the sum of the values for each data group or to obtain a grand total.

In order to get a Grand Total, click on the button Text area in the Report Controls Toolbar and draw an area with the mouse in the Page Footer section of the report. In Properties panel of this new report element, click on the Data tab and set the following options :

Field Data Type

Function

Field

PurchasePrice

Function

Accumulation

Extent

Report

in the Group Footer section :

In order to add a field that will calculate the sum of the values for each group, you must first, if you haven't done so already, insert a Group Footer section. Then draw a field in the Group Footer section and choose the following options :

Data Field Type

Function

Data Field

PurchasePrice

Function

Accumulation

Extent

Group DatePurchased

Inserting a diagram

It is also possible to insert a diagram, for example, to show a trend line of the data indexed to the grouping. In order to do this, you first need to create a query to extract the required data from the database to be able to provide it for the chart diagram.

Close the report, then click on Query in your open ODB database file. Create a new query. Choose the table or tables containing the data to be extracted and add the fields to the query. In the present example, we have used the DatePurchased and PurchasePrice fields. In the function criteria of your query, choose Group for the DatePurchased field and Sum for the PurchasePrice field.

Save the query and then open your report in Edit mode to change it. Click on the Diagram button in the main toolbar and draw an area with the mouse in the Footer section to contain the chart. In the Properties panel, on the Data tab, choose the query you just created as the data source. If the corresponding default histogram graph is not what you want, you change its properties by double-clicking on the graph, thereby entering edit mode for the graph. You can then change the default histogram graph to one more suited to your needs, for example, a 3D graph.

Example of a chart in a report

Inserting an image or logo into the Report Header

This is achieved via the Insert menu. An image inserted in this way will appear on every page of the report.

Conditional Formatting of a Calculated Field

In order to do this, you first need to select your field in the report while in Edit mode. Then, from the main menu, click on Format > Conditional Formatting.

In our present example, the alias for the query used to create the report is displayed within parentheses for the purposes of conditional formatting.

Example of a database report with conditional field formatting

Once you have mastered the fundamental principles of using the Report Designer, you will be able to use all of its functionality to format the data provided by your database to make stunning reports.

Report Navigator

This can be reached by either using the F5 function key, or by clicking on the corresponding button in the main toolbar. It displays all of the elements and objects contained within a report. Contextual help is also available for the various entries in the tree list hieararchy, simply by pressing the F1 function key after having selected an entry.

The complete list of hierarchical elements contained within a report can be displayed by clicking on the small "plus sign" or arrow that appears in front of an entry. If there is no such sign or arrow, then that element has no daughter elements.

Report Navigator -> Report

Tab : General

The following elements allow you to configure the display parameters for your report :

Name This is the name you have given to your report, it will appear in the Report Navigator once you press enter after typing in the name and validating.
Page Header here, you have the choice of enabling/disabling printing from the dropdown menu of the content inserted into the Page Header
Page Footer here, you have the choice of enabling/disabling printing from the dropdown menu of the content inserted into the Page Footer
Print repeated values yes

Tab : Data

The following elements let you configure the data source parameters for your report :

Content Type

Choose the type of data to be used : table, saved query or straight SQL query

Content

Choose the data source name

Analyse SQL

yes, or no, depending on how you are accessing your data. Choosing 'yes' is equivalent to activating the native SQL parser functionality when in Query design mode. Choosing 'no' deactivates LO's native SQL parser and passes the query instruction directly to the database driver. This is required for some advanced database functions and server backends and is dependent on the database engine used.

Filter

choose yes or no depending on the data source

Report output format

Choose ODF Spreadsheet if you need to apply more advanced mathematical handling of your data results in your report, otherwise choose ODF Text.

Navigateur du rapport -> Fonctions

Vous allez pouvoir créer les fonctions que vous utiliserez ensuite dans le rapport. Pour créer une nouvelle fonction, cliquez sur Fonction puis clic droit Nouvelle fonction. Pour accéder à d'autres exemples, suivre les liens à la fin de cette page.

Nom Nommez votre fonction, sans espace entre les mots, de façon explicite (ex : SommeAchats)
Formule Le clic sur les 3 petits points déclenche l’Assistant de création de formules.

Vous pouvez aussi entrer votre propre formule directement. Par exemple, pour calculer une somme de plusieurs valeurs, la syntaxe sera : [NomDeLaValeurInitiale]+[NomDeLaFonction] (ex : [PrixAchat]+[SommeAchats]

Valeur initiale Vous saisissez entre crochets le nom du champ sur lequel la fonction va s'appliquer( ex : [PrixAchat])
Parcours en profondeur Action non renseignée dans le guide original
Pré-évaluation En choisissant oui, le rapport sera calculé pendant sa création. Cette action consomme de la ressource, et vous pouvez préférer non de façon à attendre la fin de la création du rapport pour effectuer tous les calculs

Navigateur du rapport -> En-tête de page

Onglet : Général

Les éléments suivants vous permettent de paramétrer la présentation du rapport :

Nom

Vous pouvez conserver En-tête de page ou nommez différemment

Visible

Choisissez oui pour visualiser le contenu de l'en-tête

Hauteur Vous pouvez saisir la dimension de la hauteur ou la modifier à l'aide de la souris directement dans la page du rapport en mode Édition
Expression d'impression conditionnelle Choisissez les conditions s'il y a lieu
Transparence d'arrière-plan

En choisissant non, vous pourrez paramétrer une couleur d'arrière-plan pour l'en-tête de page

Navigateur du rapport -> En-tête de rapport

Onglet : Général

Les éléments suivants vous permettent de paramétrer la présentation de l'en-tête du rapport :

Nom

Vous pouvez conserver En-tête de rapport ou nommez différemment

Forcer une nouvelle page Choisissez Aucun(e) si vous ne voulez pas créer une page différente par donnée ou groupement de données. Autrement, choisissez la création d'une nouvelle page selon vos paramètres de mise en page souhaitée, par exemple Après la section
Conserver ensemble Permet l'impression des données d'un groupe sur une deuxième page si nécessaire
Visible En général, vous répondrez oui
Hauteur Vous pouvez saisir la dimension de la hauteur ou la modifier à l'aide de la souris directement dans la page du rapport en mode Édition
Expression d'impression conditionnelle Choisissez les conditions s'il y a lieu
Transparence d'arrière-plan En choisissant non, vous pourrez paramétrer une couleur d'arrière-plan pour l'en-tête de rapport

Navigateur du rapport : Groupes -> Panneau Tri et groupement

Vous pouvez paramétrer comment grouper des données de la base de données dans le rapport en utilisant le panneau Tri et groupement (voir plus haut : La création d'un groupement). Par défaut, le nom du groupe est celui du champ que vous avez choisi pour le Groupement.

Navigateur du rapport : Groupes -> "Nom du groupe" -> onglet Général

Conservez ensemble Choisissez oui
Démarrez une nouvelle colonne Choisissez non
Restaurer le numéro de page Choisissez non

Navigateur du rapport : Groupes -> "Nom du groupe" -> Fonctions

Voir plus haut, au chapitre Navigateur du rapport : Fonctions

Navigateur du rapport : Groupes -> "Nom du groupe" -> Grouper l'en-tête

L'onglet Général reprend les paramètres vus plus haut.

Navigateur du rapport -> Détail

C'est le corps principal du rapport. Il peut contenir d'autres composantes comme les champs d'étiquettes qui permettent de saisir un texte dans le rapport, les zones de texte qui permettent l'affichage des données, les contrôles pour afficher des images (bien pratique pour faire un trombinoscope ou un catalogue), les graphiques, les lignes, les formes que vous dessinerez et placerez en arrière-plan d'une zone de texte, etc... En résumé, cette section contient les données de la base de données que vous voulez voir dans votre rapport.

Navigateur du rapport -> Pied de page de rapport

Onglet : Général

Les éléments vus plus haut vous permettent de paramétrer la présentation de l'en-tête du rapport.

Navigateur du rapport -> Pied de page

Onglet : Général

Les éléments vus plus haut vous permettent de paramétrer la présentation du pied de page.

Les composants communs à toutes les sections.

Barre d'outils des Contrôles de rapport -> Champ d'étiquette

Onglet : Général

Nom

Vous pouvez conserver celui proposé ou le nommer différemment pour le distinguer dans le Navigateur

Étiquette

C'est le nom qui va apparaître dans l'édition du rapport. Vous pouvez lui donner un nom plus explicite que celui proposé (le nom du champ de la base de données)

Conserver ensemble Permet l'impression des données d'un groupe sur une deuxième page si nécessaire
Position X Indique la distance en cm entre le bord gauche du contrôle et la marge gauche de la page
Position Y Indique la distance en cm entre le haut du contrôle et le haut de la section
Largeur Indique en cm la dimension de la largeur du contrôle
Hauteur Indique en cm la dimension de la hauteur du contrôle
Imprimer les valeurs répétées Choisir oui ou non
Expression d'impression conditionnelle Choisissez les conditions s'il y a lieu
Imprimer lorsque le groupe change Choisissez oui
Transparence d'arrière-plan En choisissant non, vous pourrez paramétrer une couleur d'arrière-plan pour l'en-tête de rapport
Police Choisissez les paramètres
Alignement horizontal Choisissez les paramètres
Alignement vertical Choisissez les paramètres

Barre d'outils des Contrôles de rapport -> Champ formaté (Zone de texte)

Onglet : Général

Nom

Vous pouvez conserver celui proposé ou le nommer différemment pour le distinguer dans le Navigateur

Position X Indique la distance en cm entre le bord gauche du contrôle et la marge gauche de la page
Position Y Indique la distance en cm entre le haut du contrôle et le haut de la section
Largeur Indique en cm la dimension de la largeur du contrôle
Hauteur Indique en cm la dimension de la hauteur du contrôle
Imprimer les valeurs répétées Choisir oui ou non
Expression d'impression conditionnelle Choisissez les conditions s'il y a lieu
Imprimer lorsque le groupe change Choisissez oui
Transparence d'arrière-plan En choisissant non, vous pourrez paramétrer une couleur d'arrière-plan pour l'en-tête de rapport
Police Choisissez les paramètres
Alignement horizontal Choisissez les paramètres
Alignement vertical Choisissez les paramètres
Formatage Choisissez les paramètres, en particulier si vous voulez un affichage de la monnaie, ou de la date, particulier

Onglet : Données

Type de Champ de données Choisissez le type de champ des données :

Champ ou formule : vous aurez ensuite à choisir le champ ou la formule Fonction : vous aurez ensuite à choisir le type de fonction Compteur : vous aurez ensuite à choisir si celui-ci s'applique au groupe ou à tout le rapport Fonction définie par l'utilisateur : vous aurez ensuite à choisir une fonction parmi celles que vous avez créées

Champ de données Choisissez le champ de données de la base ou la formule. Par exemple, pour imprimer les champs booléens sous la forme de cases cochées/décochées, la formule sera IF([Booléen];"U+E531";"U+E470") pour les champs booléens Booléen de la table ou de la requête qui a servi à la création du rapport
Fonction Choisissez la fonction :

Accumulation fera la somme des données du champ que vous avez sélectionné

Étendue Appliquera la fonction à un Groupe ou à tout le rapport selon votre choix

Barre d'outils des Contrôles de rapport -> Image

Onglet : Général

Nom Vous pouvez conserver celui proposé ou le nommer différemment pour le distinguer dans le Navigateur
Direction du texte

Vous pouvez conserver celui proposé ou le modifier

Conserver comme lien En choisissant non l'image est intégrée dans le document (avantage : portabilité; inconvénient : augmentation du poids)
Visible Choisissez oui ou non selon ce que vous désirez
Position X Indique la distance en cm entre le bord gauche du contrôle et la marge gauche de la page
Position Y Indique la distance en cm entre le haut du contrôle et le haut de la section
Largeur Indique en cm la dimension de la largeur du contrôle
Hauteur Indique en cm la dimension de la hauteur du contrôle
Imprimer les valeurs répétées Choisir oui ou non
Expression d'impression conditionnelle Choisissez les conditions s'il y a lieu
Imprimer lorsque le groupe change Choisissez oui
Transparence d'arrière-plan En choisissant non, vous pourrez paramétrer une couleur d'arrière-plan pour l'en-tête de rapport
Alignement vertical Choisissez les paramètres
Images Sélectionnez l'image que vous voulez insérer
Adapter la taille

Sélectionnez le paramètre pour que l'image s'adapte ou non à la taille du contrôle

Onglet : Données

Type de Champ de données Choisissez Champ ou formule si vous souhaitez avoir une image différente pour chaque donnée de la section Détail (ex : catalogue, trombinoscope)
Champ de données Choisissez le champ de données de la base qui contient les images <OBJET>
Fonction
Étendue

Barre d'outils des Contrôles de rapport -> Diagramme

Onglet : Général

Nom Vous pouvez conserver celui proposé ou le nommer différemment pour le distinguer dans le Navigateur
Position X Indique la distance en cm entre le bord gauche du contrôle et la marge gauche de la page
Position Y Indique la distance en cm entre le haut du contrôle et le haut de la section
Largeur Indique en cm la dimension de la largeur du contrôle
Hauteur Indique en cm la dimension de la hauteur du contrôle
Imprimer les valeurs répétées Choisir oui ou non
Expression d'impression conditionnelle Choisissez les conditions s'il y a lieu
Imprimer lorsque le groupe change Choisissez oui
Type de diagramme

Vous pouvez modifier le type Histogramme par défaut pour choisir un autre type de diagramme

Aperçu des lignes Choisissez les paramètres
Police Vous pourrez paramétrer une police de caractère et ses styles
Alignement horizontal/Vertical Sélectionnez les paramètres pour positionner le diagramme

Onglet : Données

Type de contenu Choisir le type de la source des données
Contenu Choisir le nom de la source
Analyser l'instruction SQL Oui ou non en fonction de la source
Filtre Activer si vous souhaitez paramétrer un filtre
Tri Choisissez le champ et le type de tri souhaité
Champ de lien maîtres

Choisissez le champ souhaité

Lier les champs esclaves Choisissez le champ souhaité

Barre d'outils des Contrôles de rapport -> Ligne fixe

Onglet : Général

Nom Vous pouvez conserver celui proposé ou le nommer différemment pour le distinguer dans le Navigateur
Visible Choisissez oui ou non selon ce que vous désirez
Position X Indique la distance en cm entre le bord gauche du contrôle et la marge gauche de la page
Position Y Indique la distance en cm entre le haut du contrôle et le haut de la section
Largeur Indique en cm la dimension de la largeur du contrôle
Hauteur Indique en cm la dimension de la hauteur du contrôle
Alignement vertical Choisissez les paramètres
Orientation Choisissez si vous voulez une ligne horizontale entre les deux marges, ou verticale entre deux sections


Syntax Help

see here page

Built-in Functions

see here page.

Examples of using the Report Builder

Several examples of using the Report Builder are available here forum as proposed by various users of both OpenOffice.org and LibreOffice. You can use a search within the forum to look for a given word, expression or term. For example, you could search here bool in the section of the forum dedicated to Base questions.