Часто задаваемые вопросы - LibreOffice Calc

From The Document Foundation Wiki
< Faq‎ | Calc‎ | 027
Jump to: navigation, search

Как создать свои списки сортировки?

Calc обладает одним очень полезным свойством. Когда, например, вы пишете в ячейке день недели, а затем перетаскиваете маркер в правом нижнем углу этой ячейки, остальные дни недели пишутся автоматически в следующих ячейках.

Вы можете создать свой собственный список сортировки следующим образом:

  1. Выберите пункт меню Сервис ▸ Параметры ▸ LibreOffice Calc ▸ Списки сортировки
  2. Нажмите кнопку Создать.
  3. В поле Элементы введите слова из вашего списка, из которых должен состоять ваш список, разделяя их нажатием на клавишу ↵ Enter.
  4. Когда закончите составление списка, нажмите кнопку Добавить и затем OK.

Другой быстрый способ:

  1. В открытой таблице введите слова вашего списка в рядом расположенные ячейки.
  2. Выделите ячейки, содержащие слова.
  3. Выберите пункт меню Сервис ▸ Параметры ▸ LibreOffice Calc ▸ Списки сортировки.
  4. В нижней части окна в поле Копировать список из содержатся координаты выделенной области. Если они правильные, нажмите кнопку Копировать; если нет, исправьте координаты на правильные перед нажатием на кнопку.
  5. Нажмите OK.

Теперь вы можете ввести слово из списка и, когда вы перетащите маркер в правом нижнем углу ячейки, последующие слова из вашего списка заполнят соседние ячейки.

Порядок слов в вашем списке может быть использован для сортировки данных:

  1. Выберите данные для сортировки.
  2. Откройте диалог сортировки, используя пункт меню Данные ▸ Сортировка.
  3. На вкладке Параметры отметьте опцию Порядок сортировки, определенный пользователем и выберите из выпадающего списка ниже нужный вам.

Если список больше вам не нужен, вы можете удалить его:

  1. Выберите пункт меню Сервис ▸ Параметры ▸ LibreOffice Calc ▸ Списки сортировки
  2. Щелкните на списке, который требуется удалить.
  3. Нажмите на кнопку Удалить.
  4. Подтвердите удаление и нажмите OK.