Preguntas frecuentes: Calc

From The Document Foundation Wiki
< Faq‎ | Calc‎ | 141
Jump to: navigation, search

Cómo utilizar conjuntos de iconos de formato condicional

Queremos representar gráficamente la posición de un valor relativa a ciertos umbrales.

El menú Formato ▸ Formato condicional le permite establecer una condición del tipo Todas las celdas ▸ Conjunto de iconos para indicar umbrales mediante iconos apropiados.

Los conjuntos de iconos disponibles son:

  • 3, 4 o 5 flechas
  • 3, 4 o 5 flechas grises
  • 3 banderas
  • 3 luces de semáforo (dos diseños distintos)
  • 3 símbolos (cuadrado, triángulo y círculo)
  • 3 emoticonos
  • 3 estrellas
  • 4 círculos de rojo a negro
  • 4 o 5 clasificaciones
  • 5 cuartos
  • 5 cajas

Las condiciones para mostrar cada uno de los iconos se pueden especificar en relación a un valor (Valor), un porcentaje del número de valores en el intervalo (Porcentaje), como un porcentaje de los valores del intervalo ​​(Percentil[nota 1]) o fórmula (Fórmula).


El ejemplo siguiente ilustra cómo implementar tres flechas:

Iconos condicionales: resultado esperado

Los iconos de la columna B representan la posición de la nota relativa al promedio redondeado de la columna, calculada en B12 con la fórmula:

=REDONDEAR(PROMEDIO($B$2:$B$10))

Para los umbrales que hacen referencia al resultado de una celda (y no directamente a un valor) utilizaremos el tipo Fórmula:

Iconos condicionales: umbrales calculados mediante Fórmula

En la columna C representamos la evolución de la nota en la columna B, relativa a la de la columna A. ¿La nota es mayor, igual o menor que A?

Introducimos en la columna C una fórmula que calcule la diferencia entre las notas. Por ejemplo:

=B2-A2

El resultado será negativo (la segunda nota es menor que la primera), equivalente (notas idénticas) o positivo (la segunda nota es mayor que la primera).

Los umbrales, pues, hacer referencia directamente a un valor y, por ende, utilizamos este tipo:

Iconos condicionales: umbrales con referencia a un valor


Notas:

  1. Un percentil es cada uno de los 99 valores que dividen los datos ordenados en 100 partes iguales, de tal suerte que cada parte represente 1⁄100 de la muestra de población. Un percentil devuelve el valor correspondiente a una serie de datos que va desde el valor más pequeño hasta el más grande en un conjunto de datos. Para Alfa = 25, el percentil significa el primer cuartil; Alfa = 50 es la MEDIANA.

Descargar un libro de ejemplo