Faq/General/110/fr

From The Document Foundation Wiki
< Faq‎ | General‎ | 110
Jump to: navigation, search

Comment purger son profil[1] ?

La configuration du logiciel est stockée dans des fichiers de configuration. Ces fichiers sont modifiés, parfois de manière évidente (via le menu Outils ▸ Options par exemple), parfois sans que l'utilisateur en ait conscience (mémorisation des dimensions et positions des fenêtres ou barre d'outils par exemple).

Lors de la réécriture de ces fichiers de configuration il peut arriver que certains soient corrompus : élément mal enregistré, XML non valide, etc.

La cause est difficilement identifiable car il va de soi que le logiciel ne devrait pas permettre que ces erreurs se produisent. Certaines peuvent s'expliquer par des micro-coupures de courant lors de l'enregistrement, ou un problème de gestion de mémoire, voire par des modifications hasardeuses des options, l'installation d'extensions défectueuses, la manipulation directe de ces fichiers, etc.

Pour vérifier s'il s'agit d'un bogue propre à LibreOffice ou d'un défaut de paramétrage, il est conseillé dans un premier temps de purger son profil pour retrouver les options par défaut.

Démarche globale

Il suffit de renommer le dossier comportant les informations du profil. Renommer ce dossier correspond en fait à le rendre invisible pour le programme. La démarche à suivre est la suivante :

  1. Fermez LibO et le démarrage rapide en bas, près de l'horloge (sous MS-Windows).
  2. Renommez le répertoire du profil (cf. détails plus bas).
  3. Relancez LibO Writer par exemple.
  4. Vous êtes considéré comme un nouvel utilisateur.

À l'ouverture du document Sans nom 1, vous avez un profil tout neuf qui s'est créé dans un nouveau répertoire LibreOffice).

Si le problème persiste, il s'agit peut-être d'un bogue à faire remonter sur la liste discuss@fr.libreoffice.org

Renommer le répertoire de profil

Nous faisons ici référence à un répertoire profil car c'est sa fonction (regrouper ces informations) mais il se nomme LibreOffice.

Changer le nom de ce répertoire en l'appelant OldLibreOffice par exemple. La localisation de ce répertoire dépend du système d'exploitation.

Sous MS-Windows

Sous 2000, XP

Le dossier se trouve dans :

C:\Documents and Settings\Nom_de_l’utilisateur\Application Data\LibreOffice

Note : le dossier Application Data est un dossier caché. Pour le faire apparaître, le plus simple :

  • ouvrir un dossier avec l'explorateur ;
  • sélectionner le menu Outils ▸ Options des dossiers ▸ [onglet] Affichage ;
  • dans le cadre Paramètres avancés ▸ Fichiers et dossiers cachés, cocher Afficher les fichiers et dossiers cachés ;
  • cliquer sur Appliquer.
Sous Vista, 7

Le dossier se trouve dans :

C:\Utilisateurs\Nom_de_l’utilisateur\AppData\Roaming\LibreOffice

ou

C:\Users\Nom_de_l’utilisateur\AppData\Roaming\LibreOffice

Note : le dossier AppData est un dossier caché. Pour le faire apparaître, le plus simple :

  • ouvrir un dossier avec l'explorateur ;
  • sélectionner le menu Organiser ▸ Options des dossiers et de recherche ▸ [onglet] Affichage ;
  • dans le cadre Paramètres avancés ▸ Fichiers et dossiers cachés, cocher Afficher les fichiers et dossiers cachés ;
  • cliquer sur Appliquer.
Simplification toutes versions de Windows

Quelle que soit la version de Windows il est possible d'utiliser la variable d'environnement %appdata% comme raccourci pour accéder au répertoire concerné.

Ci-dessous en images :

Accès au répertoire du profil
copie d'écran explorateur après ouverture
Explorateur (ici Windows 7)
copie d'écran saisie du raccourci
Taper %appdata%\Libreoffice puis valider
copie d'écran
Explorateur ouvert sur le répertoire profil


Sous Linux

Cela peut dépendre des distributions, mais a priori vous devriez le trouver sous :

/home/Nom_de_l'utilisateur/.LibreOffice

NB : à partir de LibreOffice 3.5.0 le profil se trouve dans /home/Nom_de_l'utilisateur/.config/libreoffice c'est à dire dans ~/.config/libreoffice

Si vous ne voyez pas .libroffice ou .config (le point signale un dossier caché), cochez le menu Affichage ▸ Afficher les fichiers cachés.

Sous Mac OS X

Le dossier se trouve dans :

~/User/Nom de l'utilisateur/Library/Application Support/LibreOffice

ou

Macintosh HD > Utilisateur > Bibliothèque > Application Support > LibreOffice

Récupération d'un ancien profil

Le dossier renommé OldLibreOffice est une sauvegarde qui sert à y récupérer les dossiers de votre environnement antérieur. Il comprend dans le dossier user :

  • les modèles (template),
  • les autotextes (autotext),
  • les sauvegardes (backup),
  • la galerie (gallery),
  • les autocorrections (autocorr)
  • les bases de données (database)

Si vous souhaitez récupérer une partie de votre profil, il suffit de placer les répertoires correspondant dans le nouveau profil.


Notes :

  1. Voir aussi la page Profil utilisateur LibreOffice