Frequently asked questions - General

From The Document Foundation Wiki
< Faq‎ | General
Jump to navigation Jump to search
Other languages:
English • ‎dansk • ‎español • ‎français • ‎italiano • ‎čeština

If, when you type a word with a spelling mistake, it is not underlined by a red wave, here are the things to check by order. It can result from an issue with the general configuration or from the document formatting.

Note: under macOS, the menu Tools used in this page is to be replaced by Preferences.

Remember that the language where the cursor is located is displayed in the status bar, bottom of the LibreOffice window: Status bar

General configuration

The dictionary

A dictionary must be installed for your language. The installation is done by an extension as explained in the FAQ. You must close LibreOffice completely, including the quick starter, in order for the new dictionary to be taken into account. The default dictionary for your language should already be installed with factory settings.

Check that the dictionary is installed:

  • Go to the menu Tools ▸ Options ▸ Language Settings ▸ Languages ▸ Writing Aids
  • Make sure that the feature is enabled (in the Options section bottom right of the dialog): Check spelling as you type must be checked (this option is also directly accessible in the Standard toolbar or with Tools ▸ Automatic Spell Checking or with ⇧ Shift+F7).
  • Click the Edit... button (top right of the dialog).
Writing Aids section
  • In the Language drop-down box, select Your_language, which must be preceded by the checkmark (✓) icon.
If you don't see it, then the dictionary is not installed or not recognized by LibreOffice. Try to install it again. Just click the link Get more dictionaries online....
  • In the Spelling module, a dictionary must be checked (by default Hunspell SpellChecker).
Edit modules


The language global setting

Check that the default language is correctly set:

  • Got to the menu Tools ▸ Options ▸ Language Settings ▸ Languages​​
  • In the section Default language for Documents, Western field, select Your_language in the drop-down list.
Note again the checkmark (✓) icon that should be visible.
Languages section


Document formatting

At paragraph level

In Writer, first check the Default Paragraph Style:

  • Display the Styles window with F11 or the menu View ▸ Styles, in the Paragraph Styles list, right click the Default Paragraph Style then Modify.
Styles pane
  • Go to the Font tab and make sure the language is correct in the Language field (above the font preview). If you expand the drop-down list, again, a checkmark (✓) should be visible.
Default Paragraph style

In Calc, display the Styles window with F11 or the menu View ▸ Styles, in the Cells Styles list, right click the Default then Modify and check the language in the Font tab.

In Impress or Draw, display the Styles window with F11 or the menu View ▸ Styles, in the Drawing Styles list, right click the Default Drawing Style then Modify and check the language in the Font tab.


At character level

The previous configuration may still have no effect on the language displayed in the status bar. Meaning that another formatting layer remains.

In Writer, go to the menu Format ▸ Character... and in the Fonts tab, check the Language field.

  • Note that in Writer:
    • A character style may have been applied, with a different language setting, it will override the paragraph style setting. Thus, in the Styles panel, click the Character Styles button and check the entry highlighted. If different from Default Character Style, then check the font properties of that character style.
    • A direct formatting may have been applied on top of that. Check the language displayed in the status bar, bottom of the Writer window. Click it and select Reset to Default Language.

In Calc, go to the menu Format ▸ Cells... and in the Fonts tab, check the Language field.

In Impress or Draw, go to the menu Format ▸ Character... and in the Fonts tab, check the Language field.


Still no luck

Changing the default language to another one, then changing back to the desired language per following steps may help:

  • Go to the menu Tools ▸ Options ▸ Language Settings ▸ Languages​​ and in the section Default language for Documents, Western field, specify a different language than your language.
  • Confirm and close LibreOffice completely, including the quick starter.
  • Restart LibreOffice, open that same menu again and select Your_language.
  • Confirm and close LibreOffice completely, including the quick starter.
  • Restart LibreOffice and check if the language is correct.


Last chance

Try to reset your LibreOffice user profile to go back to factory settings. Rename it so that you can retrieve parts of your customization if needed.