Frequently asked questions - General

From The Document Foundation Wiki
< Faq‎ | General
Jump to: navigation, search
This page is a translated version of the page Faq/General/a11y/Java and the translation is 94% complete.

Other languages:
čeština • ‎dansk • ‎English


Java Access Bridge používá archivní detaily nastavení (použitelné pro LibreOffice 4.2.0 a dřívější)

Nadcházející buildy LibreOffice (> 4.2.0.0 dev, > 4.1.0.4, > 4.0.5.0 dev) mají implementovanou podporu pro Oracle Java SE 7, Java Runtime Environment (JRE) 1.7.u45 s implementovaným Java Access Bridge (JAB) v2.0.3 (aktivováno pomocí příkazu jabswitch -enable). Uživatelé mohou i nadále používat Java SE 6 a JRE 1.6u45 s instalovaným JAB 2.0.2 - 2013-07-24.

Buildy LibreOffice vydané před 4.0.5 (např. 3.5.7, 3.6.7, 4.0.4) nepodporují Java SE 7 Java Accessibility API vystavené v JRE a tyto verze stále vyžadují použití JRE 1.6 a JAB 2.0.2.

LibreOffice build 3.6.4 obnovil podporu AT nástrojů pro role Java Accessibility pomocí mapování rolí UNO Acessibility API. Buildy 3.6.0, 3.6.1 a 3.6.3 nepodporovaly AT nástroje. LibreOffice build 3.5 přes buildy 3.5.7, 3.6.4 - 3.6.7 a nyní build 4.0.4 umožňují použití funkcionalitu AT se správně nakonfigurovaným Java 6 Runtime Environment a Java Access Bridge v2.0.2

Oracle "Java Accessibility Bridge" a JRE konfigurace

Nainstalujte (vyčistěte a znovu nainstalujte) v tomto pořadí:

  1. Java Runtime Environment (1.6u45 nebo 1.7u45)
  2. Java Ccess Bridge (instalujte 2.0.2 nebo zapněte 2.0.3)
  3. LibreOffice (3.5.7 < nebo > 3.6.4 včetně > 4.1.0)

Lidé by měli pochopit, že pro buildy pro Windows OS je Java Accessiblity Bridge pro LibreOffice Assistive Technology a Accessibility Tools jednou z primárních komponent zcela závislých na funkčním systému JRE (úplný seznam Java závislostí je zde).

Navíc pro operační systémy Windows vyžadují Java Access Bridge, LibreOffice AT a Java komponenty LibreOffice na Windows použití 32bitové JRE . Volání na 64bitový JRE selže.

Pro uživatele Windows jsou JRE 1.6u45 nebo JRE 1.7u45, nejnovější verze příslušných větví Oracle, plně funkční s LibreOffice, pokud jsou správně nakonfigurovány. Poznámka: JRE 1.7 builds> 6 nyní instaluje Java Access Bridge verze 2.0.3 ve výchozím nastavení, ale je zakázán a musí být povolen pro použití - pomocí příkazu "jabswitch-enabled". Full instructions from Oracle here.

  • Obě JRE budou podporovat Oracle Java Accessibility Bridge a Assistive Technology a Accessibility Tools v LibreOffice.
  • Obě JRE mají nejnovější bezpečností záplaty od Oracle, které umožňují používat bezpečně pluginy v prohlížeči.

Problémy s použitím LibreOffice na Windows se objeví, pokud není JRE správně nakonfigurován. Pro uživatele LibreOffice, kteří měli instalaci JRE 1.6 a mají problémy s instalací JRE 1.7. Provádění aktualizace na JRE 1.7 nevymaže uživatelskou konfiguraci JRE 1.6, kterou LibreOffice používal. Musíte ručně smazat soubor javasettings_Windows_x86.xml v každé složce uživatelského profilu C:\Users\<userName>\AppData\Roaming\LibreOffice\4\user\config.


Bohužel i uživatelé Windows 64-bit Windows mají také problém s instalátorem Oracle JRE (nebo Ninite instalátor) a dostávají instalaci obou verzi JRE - 32bitové i 64bitové.

Tyto JRE instalátory pro Windows končí svou instalací zkopírováním spouštěcího programu do složek C:\Windows\System32 and C:\Windows\SysWOW64. Toto způsobuje problémy uživatelům závislým na LibreOffice Java Access Brdige. Jednoduše řečeno, volá se špatná verze JRE.


Pro uživatele 64bitové verze Windows existují dva způsoby, jak tento problém odstranit:

  • nainstalujte pouze 32bitovou verzi JRE. Proveďte manuální „offline“ instalaci pouze 32bitové verze JRE. Zde najdete verzi JRE 1.7u45 ke stažení nebo zde verzi JRE 1.6u45 ke stažení.
  • vynuťte použití 32bitové verze JRE odstraněním zkopírovaného spouštěcího programu ze systémové složky Windows a vytvořte záznam v systémové proměnné PATH obsahující informaci o místě instalace 32bitové verze JRE.
Konvence říká, abyste použili proměnnou JAVA_HOME, ale přidání úplné cesty do bin adresáře JRE je stejně efektivní, např. do proměnné PATH přidejte ";C:\Program Files (x86)\Java\jre7\bin".

Zní to jednoduše, ale pokud spustíte správně nakonfigurovanou instalací 32bitovou verzí JRE, JAB bude bez problémů nainstalován -- pro JRE 1.6u45 povolte vestavěný JAB v2.0.3, který je nyní sočuástí výchozí instalace JRE > 1.7.u6, ale není povolený, jak je zmíněno v článku od Oracle.

Aktivace pomocných technologií v LibreOffice na operačních systémech Windows Jsou 3 možnosti aktivace

  • Jestliže máte nainstalované LibreOffice 3.5.7, aktivujete pomocné technologie spuštěním LibreOffice - přejděte do Nástroje ▸ Možnosti ▸ Pokročilé/Možnosti jazyka Java a následně také nastavte v Nástroje ▸ Možnosti ▸ Zpřístupnění.
nebo
  • Pokud instalujete verzi 3.6, LibreOffice 3.6.4 nebo novější, je nyní možnost v rámci instalace zaškrtnout volbu Podpora nástrojů pomocných technologií (pro všechny uživatele na systémech Windows). Toto zaškrtávací políčko povolí podporu JRE v LibreOffice a zároveň povolí pomocné technologie. Poznámka: při použití této možnosti instalace musíte před instalací nejprve povolit Java Access Bridge, jak je uvedeno výše. A po dokončení instalace se musíte odhlásit a poté přihlásit k uživatelskému profilu ve Windows, aby byla provedena aktualizace a byly povoleny funkce usnadnění přístupu.
nebo
  • A konečně, pro jakékoliv sestavení LibreOffice, pokud vyžaduje aktivaci pomocných technologií pouze jeden uživatel, může být následující text uložen jako dávkový soubor konfigurace registru --. REG-- a spuštěn každým jednotlivým uživatelem.
:Windows Registry Editor Version 5.00
:
:[HKEY_CURRENT_USER\Software\LibreOffice\Accessibility\AtToolSupport]
:"SupportAssistiveTechnology"="true"

Více informaci o přístupnosti LibreOffice najdete na těchto odkazech