Faq/General/a11y/Java/da

From The Document Foundation Wiki
< Faq‎ | General
Jump to: navigation, search
This page is a translated version of the page Faq/General/a11y/Java and the translation is 100% complete.

Other languages:
čeština • ‎dansk • ‎English


Java Access Bridge opsætning af arkiveringsdetaljer (gælder for LibreOffice < 4.2.0 og tidligere)

Forestående LibreOffice-builds (> 4.2.0.0 dev, > 4.1.0.4, > 4.0.5.0 dev) har implementeret understøttelse af Oracle Java SE 7, Java Runtime Environment (JRE) 1.7u45 med sin indlejrede Java Access Bridge (JAB) v2.0.3 (aktiveret med en "jabswitch -enable"-kommando). Eller brugere, der foretrækker dette kan fortsætte med at bruge Java SE 6 og JRE 1.6u45 med en JAB 2.0.2-installation. -- 2013-07-24

LibreOffice udgivelses-builds før 4.0.5 (i.e. 3.5.7, 3.6.7, 4.0.4) understøtter ikke Java SE 7 Java Accessibility API-roller overfor JRE, og de versioner kræver stadig brug af en JRE 1.6-version og en JAB 2.0.2-installation.

LibreOffices 3.6.4-build genoprettede understøttelse af AT-funktion til Java Accessibility roller med JRE og JAB-mappinger af UNO Accessibility API-roller.

Oracle "Java Accessibility Bridge" og JRE konfiguration

Installer (rens og geninstaller) i denne rækkefølge:

  1. Java Runtime Environment (1.6u45 eller 1.7u45)
  2. Java Access Bridge (installer 2.0.2 eller aktiver 2.0.3)
  3. LibreOffice (3.5.7 < eller > 3.6.4 inklusive > 4.1.0)

Man må forstå, at under Windows OS-builds er Java Accessibility Bridge (JAB) grundlaget for LibreOffices Assistive Technology og Accessibility Tools er et af de primære komponenter, der er helt afhængig af et funktionelt system-omfattende JRE (en fuldstændig liste over JAVAs afhængigheder findes her).

Derudover kræver Windows OS-erne, Java Access Bridge, LibreOffice AT, og LibreOffices Java komponent under Windows brug af et 32-bit JRE for at fungere. Kald til et 64-bit JRE vil mislykkes.

For Windows-brugere fungerer enten JRE 1.6u45 eller JRE 1.7u45, Oracle's seneste udgave af de respektive grene, fuldt funktionelle under LibreOffice, når de er korrekt konfigureret. Bemærk: JRE 1.7 builds > 6 installerer nu som standard Java Access Bridge version 2.0.3, men den deaktiveresnog skal reaktiveres til brug -- med en "jabswitch -enable"-kommando. Udførlig instruktion fra Oracle her.

  • Begge JRE'er vil understøtte Oracle's Java Accessibility Bridge og Assistive Technology samt tilgængelighedsfunktionerne i LibreOffice.
  • Begge JRE'er har de seneste Oracle sikkerhedsopdateringer, der tillader sikker brug af alle de indbyggede browser-udvidelser.

Der vil opstå problemer med brug af LibreOffice under Windows, når JRE ikke er konfigureret korrekt. En "opgraderings" installation af JRE 1.7 fjerner ikke den JRE-bruger-konfiguration, som LibreOffice anvendte. Du skal manuelt slette javasettings_Windows_x86.xml-filen i hver bruger-konfigureret C:\Users\<userName>\AppData\Roaming\LibreOffice\4\user\config-mappe.


Desværre bliver brugere af 64-bit Windows udsat for en pinagtighed fra Oracle JRE-installationspakkerne (eller Ninite installationsindpakning) og modtager installationer af både 32-bit og 64-bit JREer.

Disse Windows JRE-installationspakker afslutter en installation med at kopiere program-kørbare filer til mapperne C:\Windows\System32 og C:\Windows\SysWOW64. Dette giver problemer for LibreOffice-brugere, der afhængige af Java Access Bridge. Simpelt formuleret: den forkerte version af JREen bliver kaldt.


Dette problem for en 64-bit Windows-bruger kan rettes på to måder:

Det lyder minimalistisk, men hvis du begynder med en korrekt konfigureret JRE-installation, bliver JAB fint installeret -- til JRE 1.6u45 aktiver den indbyggede JAB v2.0.3, der nu er bundtet og installeret sammen JRE > 1.7.u6 -- men ikke aktiveret som dukumenteret af Oracle her.

Activering af LibreOffice Assistive Technologies under Windows OSer Der kan aktiveres på 3 måder

  • Hvis du installerer LibreOffice 3.5.7, aktiverer du Assistive Technology ved at starte LibreOffice og navigere til indstillingsmenuen Funktioner ▸ Indstillinger ▸ Avanceret/Java og derefter også til menuen Funktioner ▸ Indstillinger ▸ Tilgængelighed for at sætte indstillingerne.
eller
  • Hvis du installerer 3.6-udgivelsen, LibreOffice 3.6.4 eller nyere, er der nu et afkrydsningsfelt på installationspanelet med "Understøt Assisterende teknologi-funktioner"under installationen -- for ALLE brugere under Windows-systemet. Dette afkrydsningsfelt vil aktivere JRE-understøttelse i LibreOffice samtidig med aktivering af de assisterende teknologier. OBS:

hvis du bruger denne installationsmulighed, skal du først have aktiveret Java Access Bridge før installationen som ovenfor. Og ved afslutningen af installationen skal du logge Windows-brugerprofilen af og så på, så den bliver opfrisket og understøttelsen af tilgængelighedsfunktionerne bliver aktiveret.

eller
  • Endelig, i ethvert LibreOffice-build, hvis blot en enkelt bruger kræver aktivering af Assisterende Teknologier, kan den følgende tekst gemmes som en registreringskonfigurations batch-fil -- med .REG-udvidelse og køres individuelt.
:Windows Registry Editor Version 5.00
:
:[HKEY_CURRENT_USER\Software\LibreOffice\Accessibility\AtToolSupport]
:"SupportAssistiveTechnology"="true"

Se yderligere detaljer om LibreOffice Tilgængelighed i disse links