Faq/General/a11y/Java/es

From The Document Foundation Wiki
< Faq‎ | General
Jump to navigation Jump to search
This page is a translated version of the page Faq/General/a11y/Java and the translation is 100% complete.
Other languages:
English • ‎dansk • ‎español • ‎italiano • ‎čeština


Detalles de archivo de configuración de Java Access Bridge (aplicable para LibreOffice <4.2.0 y anteriores)

Las próximas compilaciones de LibreOffice (> 4.2.0.0 dev,> 4.1.0.4,> 4.0.5.0 dev) han implementado soporte para Oracle Java SE 7, Java Runtime Environment (JRE) 1.7u45 con su Java Access Bridge (JAB) v2. 0.3 (activado con un comando "jabswitch -enable"). Los usuarios que lo prefieran pueden seguir usando Java SE 6 y JRE 1.6u45, con una instalación de JAB 2.0.2. - 2013-07-24

Las compilaciones de lanzamiento de LibreOffice anteriores a 4.0.5 (es decir, 3.5.7, 3.6.7, 4.0.4) no son compatibles con los roles de la API de accesibilidad Java de Java SE 7 expuestos al JRE, y esas versiones aún requieren su uso con una versión JRE 1.6 y una instalación de JAB 2.0.2

LibreOffice 3.6.4 construyó el soporte de herramientas AT restauradas para roles de accesibilidad de Java utilizando asignaciones JRE y JAB de los roles de API de accesibilidad de UNO. Las compilaciones 3.6.0, 3.6.1 y 3.6.3 no proporcionaron soporte para herramientas AT. LibreOffice 3.5 se compila a través de 3.5.7, 3.6.4 - 3.6.7, y ahora 4.0. 4 compilaciones proporcionan AT funcional con un Java 6 Runtime Environment correctamente configurado y Java Access Bridge, v2.0.2. }}

Configuración de Oracle "Java Accessibility Bridge" y JRE

Instale (limpie y reinstale) en este orden:

  1. Entorno de ejecución de Java (1.6u45 o 1.7u45)
  2. Java Access Bridge (instalar 2.0.2 o habilitar 2.0.3)
  3. LibreOffice (3.5.7 <o> 3.6.4 incluyendo> 4.1.0)

Los usuarios deben entender que para las compilaciones del sistema operativo Windows, la base de Java Accessibility Bridge (JAB) para la tecnología de asistencia y las herramientas de accesibilidad de LibreOffice es uno de los componentes principales que depende por completo de un JRE funcional en todo el sistema (puede ver una lista completa de las dependencias de Java aquí).

Además, para los sistemas operativos Windows, Java Access Bridge, LibreOffice AT y los componentes Java de LibreOffice en Windows dependen del uso de un JRE de 32 bits para funcionar. Las llamadas a un JRE de 64 bits fallarán.

Para los usuarios de Windows, ya sea JRE 1.6u45 o JRE 1.7u45, la última versión de Oracle de las respectivas ramas, son completamente funcionales con LibreOffice cuando se configuran correctamente. Nota: JRE 1.7 builds> 6 ahora instala Java Access Bridge versión 2.0.3 de forma predeterminada, pero está deshabilitado y debe habilitarse para su uso, con un comando "jabswitch -enable". Vea las instrucciones completas de Oracle aquí.

  • Ambos JRE serán compatibles con Java Accessibility Bridge y Assistive Technology de Oracle y las herramientas de accesibilidad en LibreOffice.
  • Ambos JRE tienen los últimos parches de seguridad de Oracle para permitir que los complementos de navegador incluidos se utilicen de forma segura.

Se producirán problemas en el uso de LibreOffice en Windows cuando el JRE no esté configurado correctamente. Para usuarios de LibreOffice que han tenido una instalación de JRE 1.6 y tienen problemas después de una instalación de JRE 1.7. Hacer una instalación de "actualización" a JRE 1.7 no borra la configuración por usuario de JRE 1.6 que había estado usando LibreOffice. Debe eliminar manualmente el archivo javasettings_Windows_x86.xml en cada carpeta de C:\Users\<userName>\AppData\Roaming\LibreOffice\4\user\config por usuario.


Desafortunadamente, los usuarios de Windows de 64 bits también se tropiezan con los instaladores de Oracle JRE (o el paquete del instalador Ninite) y reciben instalaciones de JRE de 32 y 64 bits.

Estos instaladores de JRE en Windows hacen la instalación copiando los ejecutables del programa en las carpetas C:\Windows\System32 y C:\ Windows\SysWOW64. Lo que causa problemas a los usuarios dependientes de LibreOffice Java Access Bridge. En pocas palabras, la versión incorrecta del JRE


Hay dos métodos para corregir el problema para los usuarios de Windows de 64 bits:

  • instale solo un JRE de 32 bits. Realice una instalación manual "sin conexión" de solo el JRE de 32 bits. Que puede encontrar JRE 1.7u45 aquí para su descarga. O bien en la Descarga directa de JRE 1.6u45.
  • Forzar el uso de un JRE de 32 bits eliminando los ejecutables copiados de las carpetas del sistema de Windows y haciendo una entrada para establecer la ubicación de instalación del JRE de 32 bits en la variable PATH del sistema.
La convención dice que use una variable JAVA_HOME,

pero agregar la ruta completa al directorio bin de JRE es igual de efectivo, por ejemplo, agregue ";C:\Program Files (x86)\Java\jre7\bin" a la variable PATH.

Parece simplista, pero si comienza con una instalación JRE de 32 bits correctamente configurada, JAB se instalará limpiamente--para JRE 1.6u45 habilite el JAB v2.0.3 integrado, ahora incluido e instalado de forma predeterminada con JRE> 1.7.u6 -pero no habilitado, como se menciona por Oracle aquí.

Activación de tecnologías de asistencia de LibreOffice en sistemas operativos Windows Hay 3 opciones para activarlas

* Si está instalando LibreOffice 3.5.7, active la tecnología de asistencia iniciando LibreOffice y navegando a los menús de opciones Herramientas ▸ Opciones ▸ Avanzado/Java,

y luego también al menú Herramientas ▸ Opciones ▸ Accesibilidad para hacer selecciones.

o
* Si instala la versión 3.6, LibreOffice 3.6.4 o más reciente, ahora hay una opción de casilla de verificación en el panel de instalación para "Admitir herramientas de tecnología de asistencia" durante la instalación, para TODOS los usuarios del sistema Windows.

Esta casilla de verificación habilitará la compatibilidad con JRE en LibreOffice al tiempo que habilita las tecnologías de asistencia. Nota: al utilizar esta opción de instalación, primero debe haber habilitado Java Access Bridge como se indicó anteriormente antes de la instalación. Y al finalizar la instalación, debe cerrar la sesión y luego iniciar sesión para que se actualice el perfil de usuario de Windows y se active la compatibilidad con las funciones de accesibilidad.

o
* Finalmente, para cualquier compilación de LibreOffice, si solo un usuario requiere la activación de tecnologías de asistencia,

el siguiente texto se puede guardar como un archivo por lotes de configuración del registro (extensión .REG) y ejecutarlo porcada individuo.

:Windows Registry Editor Version 5.00
:
:[HKEY_CURRENT_USER\Software\LibreOffice\Accessibility\AtToolSupport]
:"SupportAssistiveTechnology"="true"

Para obtener detalles adicionales sobre la accesibilidad de LibreOffice, consulte estos enlaces