Domande Frequenti - Generale

From The Document Foundation Wiki
< Faq‎ | General
Jump to: navigation, search
This page is a translated version of the page Faq/General/a11y/Java and the translation is 100% complete.

Other languages:
čeština • ‎dansk • ‎English • ‎italiano


Dettagli dell'archivio della configurazione di Java Access Bridge (applicabile per LibreOffice <4.2.0 e precedenti)

Le prossime build di LibreOffice (> 4.2.0.0 dev,> 4.1.0.4,> 4.0.5.0 dev) hanno implementato il supporto per Oracle Java SE 7, Java Runtime Environment (JRE) 1.7u45 con il suo Java Access Bridge (JAB) v2 incorporato. 0.3 (attivato con un comando "jabswitch -enable"). Oppure gli utenti che lo preferiscono possono continuare a utilizzare Java SE 6 e JRE 1.6u45, con un'installazione di JAB 2.0.2. -- 24-07-2013

Le versioni di rilascio di LibreOffice precedenti alla 4.0.5 (ovvero 3.5.7, 3.6.7, 4.0.4) non supportano i ruoli dell'API di Java Accessibility Java SE 7 esposti in JRE, e quelle versioni richiedono ancora l'uso con una versione JRE 1.6 e un'installazione JAB 2.0.2.

LibreOffice 3.6.4 costruisce il supporto di strumenti AT ripristinati per i ruoli di accessibilità Java usando i mapping JRE e JAB dei ruoli API di accessibilità UNO. Build 3.6.0, 3.6.1 e 3.6.3 non hanno fornito supporto per gli strumenti AT. LibreOffice 3.5 costruisce attraverso 3.5.7, 3.6.4 - 3.6.7 e ora le versioni 4.0.4 forniscono AT funzionale con un Java Runtime Environment correttamente configurato e Java Access Bridge, v2.0.2. }}

Oracle "Java Accessibility Bridge" e configurazione di JRE

Installate (pulite e reinstallate) in questo ordine:

  1. Java Runtime Environment (1.6u45 o 1.7u45)
  2. Java Access Bridge (installate 2.0.2 o abilitate 2.0.3)
  3. LibreOffice (3.5.7 < o > 3.6.4 incluso > 4.1.0)

La gente dovrebbe capire che per i build del sistema operativo Windows, la base JAB (Java Accessibility Bridge) per LibreOffice Assistive Technology e gli strumenti di accessibilità è uno dei componenti principali interamente dipendente da un JRE a livello di sistema funzionale (un elenco completo di dipendenze Java è qui).

Inoltre, per i sistemi operativi Windows, Java Access Bridge, LibreOffice AT e Java componenti di LibreOffice su Windows richiedono l'uso di un "JRE a 32 bit" per funzionare. Le chiamate a un JRE a 64 bit non funzioneranno.

Per gli utenti Windows JRE 1.6u45 o JRE 1.7u45, l'ultima versione di Oracle dei rispettivi rami, sono completamente funzionanti con LibreOffice se configurati correttamente. Nota: JRE 1.7 build> 6 ora installa Java Access Bridge versione 2.0.3 per impostazione predefinita, ma è disabilitato e deve essere abilitato per l'uso - con un comando "jabswitch -enable". Istruzioni complete da Oracle qui.

  • Entrambi i JRE supporteranno il ponte di accessibilità Java Oracle e la tecnologia assistiva e gli strumenti di accessibilità in LibreOffice.
  • Entrambi i JRE dispongono delle ultime patch di sicurezza Oracle per consentire l'utilizzo sicuro dei plug-in per i browser inclusi.

Problemi per l'uso di LibreOffice su Windows si verificano quando JRE non è configurato correttamente. Per gli utenti di LibreOffice che hanno avuto un'installazione JRE 1.6 e hanno problemi a seguito di un'installazione JRE 1.7. Fare un'installazione di "aggiornamento" su JRE 1.7 non cancella la configurazione utente di JRE 1.6 che LibreOffice stava usando. Per ogni utente è necessario eliminare manualmente il file javasettings_Windows_x86.xml da ogni cartella C:\Users\<nomeutente>\AppData\Roaming\LibreOffice\4\user\config.


Sfortunatamente, gli utenti di Windows a 64 bit vengono anche bloccati dai programmi di installazione Oracle JRE (o dal pacchetto di installazione Ninite) e ricevono installazioni di JRE sia a 32 che a 64 bit.

Questi programmi di installazione di Windows JRE completano l'installazione copiando gli eseguibili del programma nelle cartelle C:\Windows\System32 e C:\Windows\SysWOW64. Ciò causa problemi agli utenti dipendenti da LibreOffice Java Access Bridge. In parole povere, viene chiamata la versione sbagliata di JRE.


Esistono due metodi per correggere il problema per un utente di Windows a 64 bit:

La convenzione dice che usa una variabile JAVA_HOME, ma aggiungere il percorso completo alla directory bin JRE è altrettanto efficace, ad es. aggiungete alla variabile PATH "; C:\Programmi(x86)\Java\jre7\bin".

Sembra semplicistico, ma se iniziate con un'installazione JRE a 32 bit correttamente configurata, il JAB verrà installato in modo pulito - per JRE 1.6u45 abilitare il JAB integrato v2.0.3, ora raggruppato e installato di default con JRE > 1.7.u6 - ma non abilitato, come indicato /technotes/guides/access/enable_and_test.html da Oracle qui

Attivazione di LibreOffice Assistive Technologies su sistemi operativi Windows Ci sono 3 opzioni per l'attivazione

  • Se installate LibreOffice 3.5.7, attivate la tecnologia assistiva avviando LibreOffice e navigando nei menu delle opzioni Strumenti ▸ Opzioni ▸ Avanzate/Java, quindi anche nel menu Strumenti ▸ Opzioni ▸ Accessibilità per effettuare selezioni.
oppure
  • Se si installa la versione 3.6, LibreOffice 3.6.4 o successive, sul pannello di installazione è ora disponibile un'opzione per "Supportare gli strumenti di tecnologia assistiva" durante l'installazione -- per TUTTI gli utenti del sistema Windows. Questa casella abiliterà il supporto di JRE in LibreOffice mentre abiliterà le tecnologie assistive. Nota: quando si utilizza questa opzione di installazione, è necessario aver abilitato Java Access Bridge come sopra prima dell'installazione. E al termine dell'installazione è necessario disconnettersi, quindi accedere per aggiornare il profilo utente di Windows e attivare il supporto per le funzioni di accessibilità.
oppure
  • Infine, per qualsiasi build di LibreOffice, se solo un singolo utente richiede l'attivazione di Assistive Technologies, il seguente testo può essere salvato come file batch di configurazione del registro con esentesione --.REG-- ed eseguito da ciascun individuo.
:Windows Registry Editor Version 5.00
:
:[HKEY_CURRENT_USER\Software\LibreOffice\Accessibility\AtToolSupport]
:"SupportAssistiveTechnology"="true"

Per maggiori dettagli su LibreOffice Accessibility, si vedano questi link