Faq/Writer/046

From The Document Foundation Wiki
< Faq‎ | Writer
Jump to navigation Jump to search
This page is a translated version of the page Faq/Writer/046 and the translation is 100% complete.
Other languages:
English • ‎dansk • ‎français • ‎italiano • ‎čeština • ‎русский


Jak automaticky aktualizuji záhlaví a zápatí dokumentu po úpravě šablony?

Je potřeba vytvořit odkaz na zdrojový soubor a poté požádat o aktualizaci. Následující pokyny se týkají aktualizace záhlaví, ale můžete se jimi řídit i při aktualizaci jiných prvků, například zápatí nebo těla textu.

  1. vytvořte nový soubor Writeru, který bude sloužit jako zdrojový soubor pro záhlaví;
  2. zadejte text, který se zobrazí v záhlaví těla souboru;
  3. uložte soubor jako textový dokument Writeru;
  4. vytvořte novou šablonu Writeru, kterou použijete k vytvoření všech dalších souborů se stejným záhlavím;
  5. zvolte Vložit ▸ Záhlaví a zápatí ▸ Výchozí styl;
  6. s kurzorem v záhlaví vyberte nabídku Vložit ▸ Sekce…;
  7. zaškrtněte pole Odkaz a po kliknutí na tlačítko Procházet… vyberte zdrojový soubor;
  8. klikněte na tlačítko Vložit; a
  9. uložte soubor jako šablonu:
    • vyberte nabídku Soubor ▸ Šablony ▸ Uložit jako šablonu…;
    • zadejte název šablony; a
    • klikněte na OK.

Pokud chcete vytvořit více odkazů, je potřeba pro každý z nich vytvořit sekci odkazující na příslušný soubor.

Můžete buď:

  • vytvořit soubor pro každý odkaz; nebo
  • vytvořit jen jeden externí soubor obsahující různé sekce a v dialogovém okně zadat sekci, která se má vložit.

Pokud pracujete v síti, buďte při správě odkazů opatrní. Zkontrolujte, že k vloženému odkazu budou mít všechny počítače stejný přístup.

Aktualizace zápatí:

  1. pomocí šablony vytvořte soubor:
    • vyberte nabídku Soubor ▸ Nový ▸ Šablony… (nebo stiskněte Ctrl+⇧ Shift+N);
    • vyberte šablonu (ve výchozím nastavení se uložila ve složce Moje šablony v rozbalovací nabídce);
    • stiskněte OK; a
  2. jakmile vás program vyzve k aktualizaci odkazů, zvolte Ano.

Tímto způsobem se veškeré změny provedené ve zdrojovém souboru projeví při aktualizaci v souborech vytvořených pomocí této šablony.