Faq/Writer/046/fr

From The Document Foundation Wiki
< Faq‎ | Writer‎ | 046
Jump to: navigation, search

Je voudrais que les en-têtes et pieds de page de mes documents soient automatiquement mis à jour lors de la modification d'un modèle.

Il suffit de créer une liaison avec un fichier source et demander l'actualisation. La suite d'instructions suivantes est pour une mise à jour de l'en-tête mais peut être appliquée à d'autres éléments comme le pied de page ou le corps du texte :

  1. créez un nouveau fichier Writer qui sera le fichier source pour les en-têtes ;
  2. tapez le texte qui apparaitra dans l'en-tête dans le corps du fichier ;
  3. enregistrez le fichier comme texte Writer ;
  4. créez un nouveau modèle Writer qui servira à construire tous les autres fichiers qui devront avoir le même en-tête ;
  5. sélectionnez le menu Insertion ▸ En-tête ▸ Standard ;
  6. le curseur étant dans l'en-tête, sélectionnez le menu Insertion ▸ Section ;
  7. cochez la case Lier et cliquez sur le bouton [...] pour sélectionner le fichier source ;
  8. validez par Insérer ;
  9. enregistrez le fichier en tant que modèle :
    • sélectionnez le menu Fichier ▸ Modèle de document ▸ Enregistrer ;
    • renseignez le nom du modèle ;
    • validez par OK.

Si vous voulez faire d'autres liens, vous devez à chaque fois créer une section liée à un fichier. Deux options :

  • soit créer un fichier par lien,
  • soit ne créer qu'un seul fichier externe contenant différentes sections et spécifier la section à insérer dans la boite de dialogue.

Attention cependant à la gestion des liens si vous travaillez en réseau : vérifiez bien que le lien inséré sera accessible par toutes les machines de la même manière.

Pour disposer de l'en-tête actualisable :

  1. créez un fichier à l'aide du modèle :
    • sélectionnez le menu Fichier ▸ Nouveau ▸ Modèles et documents ;
    • sélectionnez le modèle (par défaut il a été enregistré dans Mes modèles) ;
    • validez par OK ;
  2. répondez Oui à la question sur l'actualisation des liens.

Ainsi toute modification du fichier source sera répercutée dans les fichiers créés avec ce modèle lors de leur actualisation.