Frequently asked questions - Writer

From The Document Foundation Wiki
< Faq‎ | Writer
Jump to: navigation, search
This page is a translated version of the page Faq/Writer/167 and the translation is 44% complete.

Outdated translations are marked like this.
Other languages:
dansk • ‎English • ‎français • ‎italiano

Comment affecter un raccourci-clavier à un caractère spécial ?

Le menu Outils ▸ Personnaliser ▸ [onglet] Clavier ne permet d'affecter que le lancement de la commande Insertion ▸ Caractères spéciaux.

Il existe toutefois 3 manières différentes d'obtenir le résultat souhaité.

Utilisation d'une AutoCorrection

  • Lancer la commande Outils ▸ Options d'AutoCorrection
  • Indiquer dans la zone Remplacer les caractères devant être remplacés par le caractère spécial.
  • Cliquer droit dans la zone Par puis Insérer des caractères spéciaux pour choisir le caractère concerné (il est aussi possible de coller ce caractère s'il figure dans le presse-papiers).
  1. go to Tools ▸ AutoCorrect Options;
  2. enter in the Replace box the characters that you want to replace by the special character; and
  3. right-click in the With box, then choose Special character and select the character you want (it is also possible to paste this character in if it is present on the clipboard).

Nota : L'AutoCorrection impose que le texte à remplacer soit "isolé" par des espaces avant/après lors de la saisie.

Création d'un AutoTexte

  • Insérer le caractère spécial dans un document.
  • Sélectionner le caractère puis lancer Édition ▸ AutoTexte.
  • Choisir la catégorie où "ranger" l'AutoTexte (Mes AutoTextes par exemple).
  • Donner un nom et un raccourci.
  • Cliquer sur le bouton AutoTexte puis Nouveau.
  • Fermer le dialogue.
  1. insert the special character into a document
  2. select the character and go to Tools ▸ AutoText
  3. choose the category in which the AutoText will be stored (My AutoText for example)
  4. give it a name and a shortcut
  5. click on the AutoText button followed by New and
  6. close the dialog

Nota : De même que pour l'AutoCorrection la saisie du "raccourci" doit en principe être précédée/suivie par une espace pour que le code soit reconnu. L'autoTexte permet toutefois de s'affranchir de cette limite en sélectionnant le raccourci avant l'appui sur F3 (cf. la note de cette FAQ).

Si vous souhaitez en savoir davantage sur les autotextes, consultez le how-to sur les autotextes.

Utilisation d'une macro

Il est possible de mémoriser l'insertion du caractère dans une macro enregistrée (menu Outils ▸ Macros ▸ Enregistrer une macro) c'est-à-dire sans connaissance particulière de la programmation.[1].

It is possible to record the insertion of a character in a macro (menu Tools ▸ Macros ▸ Record macro) without requiring any particular knowledge of programming.[2]. Then allocate the macro to the keyboard shortcut concerned.

Puis affecter la macro au raccourci clavier concerné. Les avantages de la solution macro affectée au raccourci-clavier sont :

  • L'insertion est effectivement liée au raccourci : il n'est pas nécessaire d'insérer un texte "à remplacer" (AutoCorrection ou AutoTexte).
  • Le raccourci peut être défini pour plusieurs modules.

Exemple de macro enregistrée :

sub InsertCharSpec
rem ----------------------------------------------------------------------
rem define variables
dim document as object
dim dispatcher as object
rem ----------------------------------------------------------------------
rem get access to the document
document   = ThisComponent.CurrentController.Frame
dispatcher = createUnoService("com.sun.star.frame.DispatchHelper")
rem ----------------------------------------------------------------------
dim args1(1) as new com.sun.star.beans.PropertyValue
args1(0).Name = "Symbols"
args1(0).Value = "©"
args1(1).Name = "FontName"
args1(1).Value = "Times New Roman"

dispatcher.executeDispatch(document, ".uno:InsertSymbol", "", 0, args1())

end sub
Notes:
  1. Si cette commande n'est pas disponible, il faut l'activer par Outils ▸ Options ▸ LibreOffice ▸ Général ▸ Activer les fonctions expérimentales ou à partir de la version 4 par Outils ▸ Options ▸ LibreOffice ▸ Avancé
  2. If this command is not available, you will need to activate it by using Tools ▸ Options ▸ LibreOffice ▸ General ▸ Enable experimental (unstable) features or from version 4 by Tools ▸ Options ▸ LibreOffice ▸ Advanced