ReleaseNotes/26.8
TDF LibreOffice Document Liberation Project Community Blogs Weblate Nextcloud Redmine Ask LibreOffice Spende
Writer
- Die Absatzrichtung für RTL-Text wird beim Öffnen oder Einfügen von Klartext nun automatisch erkannt. (Jonathan Clark, TDF) tdf#157037
- Lesen und erneutes Exportieren der Eigenschaften "hidden" (ausgeblendet) und "show in gallery" (in der Galerie anzeigen) von Formatvorlagen in DOCX-Dateien. Dies ermöglicht es, die Liste der Formatvorlagen auf die relevanten zu beschränken. (Szymon Kłos, Collabora) 5bee91d5
- "Anfang" ist jetzt die Standardeinstellung für die Absatzausrichtung in neuen Dokumenten. (Jonathan Clark, TDF) tdf#169035
- Das Ändern der Absatzrichtung spiegelt nicht mehr die Ausrichtung links- oder rechtsbündiger Absätze wider. Für Absätze, die automatisch anhand der Schreibrichtung ausgerichtet werden, verwenden Sie bitte die Ausrichtung am "Anfang" oder am "Ende". (Jonathan Clark, TDF) tdf#165206
- Verbesserte Behandlung von Bereichen mit gelöschtem, auskommentiertem Text im DOCX-Filter von Writer.
blog post (Miklos Vajna, Collabora)
- Neue Option zur Anzeige des Grundlinienrasters für den Zeilenabstand der Seite hinzugefügt: ▸ ▸ . (blog post) (Tamás Zolnai) tdf#169806
- Die Farbe des Rasters kann geändert werden: ▸ ▸ ▸ ▸ ▸
-
Neue Funktion für ein Grundlinienraster in Writer
- Der Zeilenabstand funktioniert nun innerhalb von Writer-Rahmen ordnungsgemäß. Der Text im Rahmen ist korrekt am Grundlinienraster ausgerichtet. (blog post) (Tamás Zolnai) tdf#93785
-
Die Formatierung des Zeilenabstands innerhalb von Rahmen wurde korrigiert.
- Bei der Anzeige von Feldnamen in Writer wird nun im Fall von Dokumentstatistiken eine Beschreibung des Feldtyps angezeigt. (Andreas Heinisch) tdf#45048
-
Feldnamen enthalten jetzt eine Beschreibung des Untertyps.
- Funktionalität für den direkten Vergleich von Dokumenten nebeneinander. blog post (Miklos Vajna, Collabora)
- Absatz-Ausgleich: Der neue Absatz-Composer gleicht die Wortabstände in aufeinanderfolgenden Zeilen aus und behebt damit einen grundlegenden Mangel des "gierigen" Zeilen-Ausgleichs herkömmlicher Textverarbeitungsprogramme. (blog post). (László Németh) tdf#38159
-
Absatz-Ausgleich.
- Entwurfsansicht für ablenkungsfreies Bearbeiten ▸ (László Németh) tdf#168705
-
Entwurfs Ansicht.
-
Normal Ansicht.
- Beim Drucken eines Serienbriefs behält der Dialog "Seriendruck" nun die Ausgabeoptionen bei: einzelnes Dokument/einzelne Dokumente sowie Dateiformat. (Laurent Balland) tdf#144771
- Die Seitenleiste "Schnellsuche" ermöglicht die Suche in Kommentaren. (Vojtěch Doležal) tdf#170192
- Verbesserter Zeilenumbruch für bidirektionalen Text. Leerzeichen am Zeilenende werden nun in der Schreibrichtung des Absatzes platziert, anstatt in der Leserichtung. (Jonathan Clark, TDF) tdf#146572
-
Leerzeichen am Zeilenende werden nun in der Schreibrichtung des Absatzes platziert, anstatt in der Leserichtung.
- Eine Option hinzugefügt, um zu verhindern, dass eingegebener Text die aktuelle Auswahl ersetzt ▸ ▸ ▸ (Andreas Heinisch) tdf#169913
- Die Ziehpunkte zur Größenänderung von Objekten in RTL- und vertikalen CTL-Dokumenten wurden korrigiert. Die Größenänderung von Objekten sollte sich nun intuitiver verhalten. (Jonathan Clark, TDF) tdf#56412
-
Das Ändern der Größe von Objekten in RTL-Dokumenten funktioniert jetzt korrekt.
- "Formatierungszeichen anzeigen" macht jetzt auch Formatierungszeichen für bidirektionalen Text sichtbar. (Jonathan Clark, TDF) tdf#63929
-
BiDi-Steuerzeichen werden jetzt zusammen mit anderen Steuerzeichen angezeigt.
- In Writer ist es nun möglich, Bereiche alphabetisch nach ihren Überschriften zu sortieren. (Jim Raykowski) tdf#167491
- Die Änderung der Optionen für die Schnellsuche-Seitenleiste erfolgt nun innerhalb des Seitenleistenbereichs anstatt in einem modalen Dialog. (Vojtěch Doležal) tdf#170980
- Die Seitennavigation mittels Alt + Bild↓ und Alt + Bild↑ positioniert die Ansicht nun so, dass sich der Seitenanfang am oberen Rand des Sichtbereichs befindet. Auch der Dialog "Zur Seite springen" wurde entsprechend angepasst. (Jim Raykowski) tdf#171259
- Es wurde eine Absatz-Eigenschaft für eine Mindestzeichenanzahl hinzugefügt, um die Silbentrennung vor den Grenzen von Bestandteilen zusammengesetzter Wörter zu beschränken. (László Németh) tdf#170177
- Der Dialog "Wortzählung" enthält nun Angaben zur Anzahl der "Wörter vor/nach dem Cursor". (Tien Nguyen Minh) tdf#123083
- Das Zeichenformat für die Komponente "Link-Ende-Index/Tabelleneintrag" entspricht nun standardmäßig dem für "Link-Anfang". (Manish Bera) tdf#50050
- Seitenvorlagennamen werden innerhalb der Seitenumbruch-Markierungen angezeigt. (Heiko Tietze, TDF) tdf#128616
- Die Liste der Formatvorlagen im Auswahl-Menü "Formatvorlagen" lässt sich über die Experten-Konfigurationsoptionen
ShowDefaultStyles,ShowUsedStyles,ShowFavouriteStylesundShowUserDefinedStylesunterorg.openoffice.Office.Commonkonfigurieren. (Jim Raykowski) tdf#171727 - Eine Infoleiste wird angezeigt, wenn durch die automatische Formatierung führende oder nachgestellte Leerzeichen oder Tabulatoren entfernt wurden. (Heiko Tietze, TDF) tdf#171343
-
Infoleiste mit der Option, die Einstellung zu akzeptieren und nicht mehr anzuzeigen oder die Optionen zu ändern.
- Der Writer Navigator zeigt jetzt Indexeinträge an. (Jim Raykowski) tdf#164864
- Überschriften können mitsamt ihrem Inhalt über den Navigator sortiert werden (erfordert die Aktivierung experimenteller Funktionen). (Jim Raykowski) tdf#169674
Leistung
- Die Öffnungszeit sehr großer Writer-Dokumente mit Bildern wurde verbessert. (Noel Grandin, Collabora) tdf#170595
Calc
- Die Datenvalidierung ermöglicht es nun, ungültige Werte stillschweigend zu verwerfen (womit auch das Verhalten von vor Version 24.2 wiederhergestellt ist). (Heiko Tietze, TDF) tdf#160096
- Es wurde ein Shuffle-Befehl hinzugefügt, um die Reihenfolge der Zellen in einem Bereich zufällig anzuordnen. (Tomaž Vajngerl, Collabora) tdf#158196
- Calc verhält sich nun besser bei der Eingabe und Bearbeitung von RTL-Text. Die Eingabe von RTL-Text in eine leere Zelle stellt die Zellrichtung nun automatisch auf RTL um. (Jonathan Clark, TDF) tdf#65563 tdf#144296
-
Das Bearbeiten von RTL-Tabellen sollte sich nun ausgereifter anfühlen.
-
Die Ausrichtung der Zellen wird nun – sofern möglich – automatisch gehandhabt.
- Berechnetes Feld in einer Pivot-Tabelle (Balazs Varga, Collabora) tdf#78486 (Olivier Hallot, TDF) tdf#172107
-
Dialog "Berechnetes Feld"
- Die XLSX-Kompatibilität bei Zeilenumbrüchen in referenzierten Zellen wurde verbessert. (Bayram Çiçek, Collabora) tdf#169326
- Die Benutzeroberfläche zum Ändern der Textformatierung im Dialog für Kopf- und Fußzeilen in Calc wurde verbessert. (Viraj Parmar) tdf#103035
- Relative Schriftgrößen werden jetzt in Calc-Zellvorlagen unterstützt. (Paolo Benvenuto) tdf#92144
- Strg + Pos1 bewegt den Cursor zur ersten nicht fixierten Zelle im Tabellenblatt. (Andreas Heinisch) tdf#107994
- XLSX-Formularsteuerelemente werden jetzt im Navigator angezeigt. (Jim Raykowski) tdf#167766
- Die Schaltfläche für Umrandung in der Symbolleiste "Formatierungen" wurde in eine Schaltfläche mit Auswahl-Menü (Split-Button) umgewandelt, die sich den zuletzt verwendeten Umrandungsstil merkt und diesen erneut anwendet. (Andreas Heinisch) tdf#58349
-
Auswahl-Menü für den Umrandungsstil
- Links zu ausgeblendeten Tabellenblättern zeigen jetzt einen Hinweis an. (Heiko Tietze, TDF) tdf#118866
Impress
- Der Wechsel von einer nummerierten Liste zu einer Liste mit Aufzählungszeichen ist jetzt möglich. blog post (Miklos Vajna, Collabora)
- Impress und Draw unterstützen jetzt unterschiedliche Seitengrößen in einem Dokument. blog post (Mohit Marathe, Collabora) tdf#49787
-
Größe aller Seiten ändern
- Integrierte Vorlagen: Für einige Vorlagen (Blueprint Plans, Beehive, DNA, Lights, Nature Illustration) werden nun sowohl das 16:9- als auch das 4:3-Format angeboten (wobei 16:9 die Standardeinstellung ist). Dies verhindert, dass Hintergrundgrafiken beim Ändern des Seitenformats verzerrt werden. (Laurent Balland) tdf#170789
- Präsentations-Abschnitte hinzugefügt (Pranam Lashkari, Collabora)
-
Abschnitte der Präsentation, verfügbar über das Kontextmenüs im Folienbereich
- Das Folien- und das Seiten-Bedienfeld zeigen nun neben der Foliennummer über jeder Miniaturansicht benutzerdefinierte Foliennamen an. (Andreas Heinisch) tdf#37654
-
Benutzerdefinierte Foliennamen
- Die Symbole in der optionalen Navigationsleiste von Diashows skalieren nun automatisch bei Änderungen der Fenstergröße. (Vladislav Tarakanov) tdf#158394
- Die Folienauswahl in der Gliederungsansicht folgt nun der Cursorposition. (Andreas Heinisch) tdf#99079
Draw
- Zoomen und Scrollen mit dem Mausrad tauschen: Wenn diese Option in Draw aktiviert ist, zoomt das Mausrad, anstatt zu scrollen, und die Kombination aus Strg-Taste und Mausrad scrollt, anstatt zu zoomen. (Lucas Negrea) tdf#171291
Base
- Beibehaltung von SQL-Kommentaren in der Entwurfsansicht: Ein Problem wurde behoben, bei dem Kommentare innerhalb einer SQL-Abfrage beim Wechsel in die Entwurfsansicht automatisch gelöscht wurden.
⚠️ Warnung: Kommentare gehen weiterhin verloren, wenn die Abfrage in der Entwurfsansicht aktiv bearbeitet wird, da der visuelle Editor den zugrundeliegenden SQL-Code neu generiert. (Vissarion Fysikopoulos, TDF) tdf#42713 - Die Filterung von Spalten mit Datums-, Zeit- und Zeitstempelwerten wird in Base nun bei Verwendung der eingebetteten Firebird-Datenbank unterstützt. (Vissarion Fysikopoulos, TDF) tdf#153057
Chart
- LibreOffice bietet nun eine grundlegende Unterstützung für den Import und Re-Export neuer Diagrammtypen (sogenannte "chartex"-Diagramme), die in Microsoft Office erstellt und in OOXML-Formaten gespeichert wurden. Zu den Diagrammtypen mit dieser grundlegenden Round-Trip-Unterstützung gehören Box-Whisker-, Trichter-, Pareto-, Sunburst-, Treemap- und Wasserfalldiagramme. Regionale Kartendiagramme enthalten umfangreiche geografische Informationen, die nicht unterstützt werden; daher bleibt zwar der Diagrammtyp bei der Round-Trip-Verarbeitung erhalten, jedoch kaum dessen wesentlicher Inhalt. Für die Anzeige oder Bearbeitung dieser Diagrammtypen gibt es bislang keine Unterstützung. Stattdessen wird eine Meldung angezeigt, die darauf hinweist, dass der Diagrammtyp in LibreOffice noch nicht unterstützt wird. (Kurt Nordback, Collabora) tdf#165742
Math
- Für die N’Ko- und Adlam-Schriften wurden benannte Funktionen und Operatoren hinzugefügt. (Neil S. Patel) tdf#170259
- Für RTL-Formeln wurden nach links gerichtete Vektorpfeile und Harpunen hinzugefügt. (Neil S. Patel) tdf#158727
- Für Math gibt es jetzt einen Dialog zum Erstellen von Matrizen. (Jan Rheinländer) tdf#170787
Kern / Allgemein
- Der Reiter "Allgemein" im Formatvorlagen-Dialog zeigt nun für jede Eigenschaft, die von der übergeordneten Formatvorlage abweicht, interaktive „Chips“ an. Jeder Chip zeigt den Namen und den Wert der Eigenschaft an und enthält eine Schaltfläche (mit einem „X“), um die Eigenschaft auf die Vererbung von der übergeordneten Vorlage zurückzusetzen. Alle Eigenschaften werden im Volltext und ohne Auslassungszeichen dargestellt. (Paolo Benvenuto) tdf#89826
-
Schaltflächen „Bearbeiten“ und „Anzeigen“, um Stileigenschaften auf den übergeordneten Stil zurückzusetzen.
- LibreOffice akzeptiert nun zusätzlich zur aktuellen Benutzeroberflächensprache auch Schriftartnamen in anderen Sprachen. Dokumente, die mit einer anderen Benutzeroberflächensprache erstellt wurden, werden nun mit den vom Autor vorgesehenen Schriftarten angezeigt, sofern diese auf dem System installiert sind. (Jonathan Clark, TDF) tdf#63011
- Tastaturkürzel lassen sich für ein einzelnes Dokument über den Dialog zur Anpassung der Tastaturbelegung konfigurieren. (Neil Roberts, TDF) tdf#94522
-
Dialog zum Speichern von Tastenkombinationen in einem Dokument.
- Wenn die generischen VCL-UI-Widgets verwendet werden (zum Beispiel, wenn kein Desktop-Integrationspaket wie
libreoffice-kf6installiert wurde), wird eine Infoleiste angezeigt, die auf die Situation hinweist und erklärt, wie sie behoben werden kann. (Heiko Tietze, TDF) tdf#172256 - OpenType-Schriftvariationen werden jetzt nativ unterstützt. (Khaled Hosny, Alif Type) tdf#171624 tdf#153368 tdf#118792 tdf#152206
- Unicode-Escape-Sequenzen funktionieren jetzt bei der Suche und Ersetzung mit regulären Ausdrücken. (Anamay Narkar) tdf#106137
Benutzeroberfläche
- Neue weitere Auswahlen im Dialog "Seitenvorlage", sowie in der Seitenleiste/Seite ( Alt + 5 ) für die Papierformate (A0, A1, A2, B0, B1, B2, B3) wurden hinzugefügt. (Samuel Mehrbrodt, Collabora) tdf#106889
- Verwenden Sie eine deterministische Liste von Formatvorlagen, die in der Notebook-Bar, der Symbolleiste "Formatierung" und dem Auswahl-Menü für Formatvorlagen im Bereich "Eigenschaften" der Seitenleiste einheitlich ist. Dabei wird beim Hinzufügen einer neuen benutzerdefinierten Formatvorlage keine Standardvorlage ausgeblendet, wodurch der Eindruck einer willkürlichen Zusammenstellung vermieden wird. (Szymon Kłos, Collabora) tdf#108239
-
Formatvorlagen-Vorschau in der Notebook-Bar und im Auswahl-Menü der Seitenleiste
- Änderungen an den Farben des Anwendungsthemas erfordern keinen Neustart mehr. (Heiko Tietze, TDF) tdf#170678
- Auf die Designfarben kann in Impress über die Notebookbar-Benutzeroberfläche zugegriffen werden. (Samuel Mehrbrodt, Collabora, Heiko Tietze, TDF) tdf#170485
-
Designfarben in der Impress-Notebookbar
- Dem Hyperlink-Dialog wurde eine Option zum Entfernen der Abfragezeichenfolge (Query-String) hinzugefügt. (Siddhi Salunkhe) tdf#170592
- Für in der Größe veränderbare Dialoge unter Windows wird nun eine Schaltfläche zum Maximieren angezeigt. (Thomas Rogenmoser) tdf#141381
- Es ist nun möglich, mithilfe des Mausrads oder des Touchpads zwischen den Registerkarten der Notebookbar zu blättern. (Jonas Greifenhain) tdf#103033
- Vorhandene Tabellenvorlagen in Writer und Calc können nun bearbeitet werden. Das interne Format wurde von einem Binärformat auf XML umgestellt. (Karthik Godha) tdf#105933 tdf#49437
- Die macOS-spezifischen Menüpunkte "Emojis & Symbole", "Diktierfunktion" und "Automatisch ausfüllen" sind jetzt verfügbar. (Dan Williams, TDF) tdf#94251
- Benutzerdefinierte Wörterbücher verfügen jetzt über einen Suchfilter. (Shlok Kanani) tdf#170978
-
Suchfilter
- Die Optionsseite ▸ wurde neu strukturiert. (Sahil Gautam, Collabora) tdf#151144
- Der Hintergrund der Notebookbars ist je nach Modul unterschiedlich gefärbt. Diese Farben sind derzeit fest im Code hinterlegt und werden mit dem Hintergrund kombiniert, damit sie sowohl bei dunklen als auch bei hellen Themes funktionieren; die Steuerung erfolgt über die Expertenkonfiguration
NotebookbarColorTransparency, wobei der Wert 0 der exakt definierten Farbe und 255 der Hintergrundfarbe entspricht. Der Standardwert ist 150. (Heiko Tietze, TDF) tdf#121174
-
Benutzeroberfläche mit Registerkarten und aktivierten Modulfarben
- Die Benutzeroberfläche der Registerkarten-Notebookbar verfügt nun über Kategoriebezeichnungen. (Heiko Tietze, TDF) tdf#166641
- Die Auswahl für Absatzvorlagen in der Notebookbar-Benutzeroberfläche zeigt nur eine (formatierte) Bezeichnung an, und das Raster der Formatvorlagen erweitert sich, um den verfügbaren Platz der Anwendung auszufüllen. (Heiko Tietze, TDF) tdf#169763 tdf#168657
-
Vorlagenauswahl 26.8 vs. 26.2
- Formatvorlagen-Filter in der Seitenleiste bei Formatvorlagen lassen sich unabhängig voneinander anwenden. (Jim Raykowski) tdf#167949
Barrierefreiheit
- Das Auswahl-Menü (Split-Button) für Sonderzeichen ist jetzt per Tastatur bedienbar (Pfeiltasten+Eingabe). (Michael Weghorn, TDF) tdf#168594
- Writer-Tabellen geben nun Texte für Zeilen- und Spaltenindizes gemäß ARIA-Spezifikation aus.
Dies ist sichtbar in der Berechnungsleiste. (Michael Weghorn, TDF) tdf#171086
Änderungen in den UI-Strings
- Das Feld "Unternehmen" wurde in den Optionen für Benutzerdaten in das allgemeinere "Organisation" umbenannt. (Aleksi Kallio) tdf#169121
- Das Kontrollkästchen "Systemeingabesprache ignorieren" ist nun deutlicher bezeichnet als "Systemeingabesprache auf neuen Text anwenden". (Prajwal Shelar; Isha Desai) tdf#134628
- Der bisherige "Safe Mode" heißt jetzt "Rücksetzen in Troubleshoot Mode", um seinen Verwendungszweck widerzuspiegeln und Missverständnisse über seine Funktion zu vermeiden. (Adolfo Jayme-Barrientos) tdf#171916
- Die Option "Quadratischen Seitenmodus für Textraster verwenden" (im Original: "Use square page mode for text grid") heißt nun "CJK-Manuskriptraster verwenden"; auch der ausführliche Tooltip und der Hilfetext wurden entsprechend aktualisiert. Diese Option aktiviert das "Genkō-Yōshi"-Raster. (Olivier Hallot, TDF) tdf#171455
- Die Bezeichnungen zwei Befehle "Neu" wurden präzisiert: "Neues Dokument" und "Neue Formatvorlage aus Auswahl". (Heiko Tietze, TDF) tdf#169766
- Die Optionen für "Erneut anzeigen" wurden in "Nicht erneut anzeigen" geändert. (Heiko Tietze, TDF) tdf#169313
Skripterstellung
Python
Benutzer können Python-Skripte direkt im Dialogfeld des Makro-Managers erstellen und bearbeiten, ohne APSO installieren zu müssen; die Schaltflächen für die entsprechenden Aktionen sind nun aktiv. Die Python-Skripte werden unter allen Betriebssystemen im Standard-Texteditor geöffnet. (Neil Roberts, TDF) tdf#56289
Skripte können Instanzen von UNO-Diensten mithilfe eines Konstruktors erstellen, anstatt einen String verwenden zu müssen. (Neil Roberts, TDF) tdf#171122
Zum Beispiel:
from com.sun.star.awt import Toolkit
toolkit = Toolkit.create(self.xContext)
Das Gleiche gilt für Singletons:
from com.sun.star.frame import theDesktop
desktop = theDesktop.get(ctx)
Prozesse, die zur Fehlersuche in LibreOffice gestartet wurden – beginnend mit `officehelper.py` – können aus dem Arbeitsspeicher entfernt werden. Informationen dazu finden sich im Kapitel "Getting started" des LibreOffice Developer's Guide unter [Developer's Guide - Getting started]. (Alain Romedenne) tdf#163465
from officehelper import SessionManager
def my_script():
# Hier kommt der Benutzercode hin.
g_exportedScripts = (my_script,) # LibreOffice-Einstiegspunkte
if __name__ == "__main__": # Einstiegspunkt für IDEs
with SessionManager() as ctx: # Remote-Python-Kontext
my_script()
Die ScriptForge-Bibliotheken
Eine erweiterbare und robuste Sammlung von Makro-Skripting-Ressourcen für LibreOffice, die von Benutzer-Basic- oder Python-Skripten aus aufgerufen werden können. (Jean-Pierre Ledure)
Die Bibliotheken stellen insgesamt 35 Dienste mit jeweils einer Reihe von Methoden und Eigenschaften zur Verfügung.
Neu in LibreOffice 26.8:
- Die neue Methode „ui.EnterValue(...)“ zeigt dem Benutzer ein Eingabefeld für einen bestimmten Datentyp an (vgl. die Basic-Funktion „InputBox()“) und gibt den eingegebenen Wert als Skalar des gewünschten Typs zurück – oder „Empty/None“, wenn der Benutzer das Eingabefeld abbricht. Unterstützt werden folgende Typen: STRING, PASSWORD, BOOL, INTEGER, FLOAT, DATE, TIME, DATETIME, COMBO, LIST und RADIO.
- (Nur Basic) Die neuen Methoden „array.Map()“, „array.Filter()“ und „array.Reduce()“ führen Techniken der funktionalen Programmierung für Basic-Arrays ein. Sie orientieren sich an ihren Pendants in Python. Diese Methoden ermöglichen es dem Programmierer, einfacheren und kürzeren Code zu schreiben, ohne sich zwangsläufig mit Details wie Schleifen, Verzweigungen und Fehlerbehandlung auseinandersetzen zu müssen.
- Die neuen Methoden „session.GetUnoProperty()“ und „session.GetPropertyByName()“ geben den Eigenschaftswert eines UNO-Objekts beziehungsweise einer ScriptForge-Service-Instanz zurück, wenn der Eigenschaftsname als Zeichenkette angegeben wird.
- (Nur für Python) Python-Skripte können entweder (1) innerhalb des LibreOffice-Prozesses (dem üblichen Modus) oder (2) als Client eines LibreOffice-Servers über eine „Pipe“ oder einen „Socket“ ausgeführt werden. Der Vorteil von (2) ist die Freiheit, die bevorzugte IDE für die Bearbeitung und das Debugging des Skripts zu wählen. Der Nachteil ist der Verweis auf die Pipe bzw. den Socket im Quellcode des Skripts. Dies lässt sich durch die Verwendung einer Standard-Pipe namens PIPE2LIBREOFFICE vermeiden. Derselbe Code läuft dann unverändert sowohl im Modus (1) als auch im Modus (2).
Der gesamte Funktionsumfang (sofern er nicht besser durch native, integrierte Funktionen abgedeckt wird) steht Python-Skripten mit identischer Syntax und identischem Verhalten wie in Basic zur Verfügung.
ScriptForge im Wiki: lesen Macros/ScriptForge (Lobaluna).
Die englische Version der Dokumentation der ScriptForge-Bibliotheken (26.8) ist teilweise in die LibreOffice-Hilfeseiten (https://help.libreoffice.org/26.8/en-US/text/sbasic/shared/03/lib_ScriptForge.html?DbPAR=BASIC) integriert. Die Fertigstellung und Übersetzung in weitere Sprachen sind im Gange. (Alain Romedenne, Lobaluna)
Android Viewer
Lokalisierung
- Die Autokorrektur ersetzt nun automatisch x durch Zirkumflexe in Esperanto-Texten. Zum Beispiel wird aus "sxangxigxi" "ŝanĝiĝi". (Neil Roberts, TDF) tdf#172042
-
Demonstration der automatischen Korrektur von x-Zeichen zu Zirkumflexen in einem Esperanto-Text
LibreOffice Hilfe
Die Hilfe akzeptiert MathML-Inhalte mit dem Namensraum-Präfix "m". (O. Hallot, TDF)
<m:math xmlns:m="http://www.w3.org/1998/Math/MathML" display="block">
<m:semantics>
<m:mrow>
<m:mi>cot</m:mi>
<m:mrow>
...
</m:math>
Aktualisierungen und Korrekturen der Hilfeinhalte:
Entfernte / Veraltete Funktionen
- Veraltete Konfigurationseinstellungen für Java-Applets aus den Registrierungsschemata für NetAccess und Security entfernt. (Shlok Kanani) (Gabor Kelemen, Collabora) tdf#162563
- Das veraltete
OfficeBean-Beispiel (das auf Java-Applet-Funktionalität basierte) wurde aus dem SDK entfernt. (Stephan Bergmann, Collabora) 05ba63c6 - Die veralteten Schriftarten Gentium Basic und Gentium Book Basic (v.1.102, SIL) sind nicht mehr im Lieferumfang enthalten. Hinweis: Falls Sie diese Schriftarten weiterhin benötigen, können sie hier heruntergeladen werden: our site. Alternativ können Sie versuchen, auf die neuen Schriftarten Gentium und Gentium Book umzusteigen; diese lassen sich hier herunterladen: SIL site. (Xisco Faulí, TDF) tdf#167563
- Die AppletShape-API ist veraltet und wird in einer zukünftigen Version entfernt.
API Änderungen
- Die veraltete Profile-API wurde entfernt und durch einen manuellen .ini-Datei-Parser ersetzt. (Shlok Kanani) tdf#49602
FunctionAccess::callFunctionakzeptiert nun fehlende Argumente. (Neil Roberts, TDF) tdf#168267
Code-Qualität
- VeraPDF wurde als PDF-Validator für automatisierte Tests hinzugefügt. (Xisco Faulí, TDF) tdf#136822








