LibreOffice 4.4: Note di rilascio

From The Document Foundation Wiki
Jump to: navigation, search

Contents

Riguardo questa pagina

Questa pagina contiene le note di rilascio di LibreOffice 4.4 e dovrebbe essere la stesura definitiva ora che la versione 4.4 è stata rilasciata. Nel caso riteneste che abbiamo tralasciato qualche novità, saremmo felici di saperlo. Grazie in anticipo per il vostro aiuto!


Writer

Template per i documenti master

Writer ha da lungo tempo i Documenti Master. Un documento master consente di gestire grandi documenti, come un libro con vari capitoli. Il documento master può essere visto come un contenitore per singoli file di LibreOffice Writer. LibreOffice 4.4 introduce i Master Document Template. Questi template per i documenti master possono essere aggiunti al Template Manager e creando un nuovo documento basato su un Master Document Template si crea un documento master con lo stesso contenuto di partenza del template su cui è basato. (Caolan McNamara - Red Hat)

Le figure possono avere un box di testo

Le forme di Writer ora possono avere un box di testo, per cui è possibile avere in una figura il contenuto complesso di Writer e la completa geometria drawinglayer allo stesso tempo. tdf#70942 post del blog (Miklos Vajna, Collabora)

Tabella inserita nel testo di una figura con i bordi arrotondati.

Miglioramenti alle revisioni

  • I comandi "Accetta modifica" e "Rifiuta modifica" ora si spostano automaticamente alla prossima modifica. tdf#83953 (Samuel Mehrbrodt)
  • Aggiunti nuovi pulsanti alla barra Modifiche per le revisioni, insieme ad un nuovo set di icone. tdf#83955, tdf#84405 (Yousuf Philips)
Nuove icone per la toolbar Modifiche.
  • La voce nel menu Modifica per le revisioni è stata rinominata da "Modifiche" a (???). tdf#85046 (Yousuf Philips)
  • La scorciatoia da tastiera Ctrl+⇧ Shift+E è stata associata alla registrazione delle modifiche. tdf#86183 (Yousuf Philips)

Elenco degli Stili

Il menu a tendina degli Stili ora ha un sotto-menu per modificare lo stile corrente o aggiornarlo in base al testo selezionato. tdf#62081 (Szymon Kłos and Samuel Mehrbrodt)

Split-menu per l'elenco degli Stili.

Numerazione delle righe più facile per Intestazioni e Piè di pagina

La numerazione delle righe per intestazioni e piè di pagina (usando lo stile di paragrafo proprio di intestazioni/piè di pagina) si può ora attivare dallo stesso posto dove si applica la numerazione delle righe Strumenti ▸ Numerazione righe, in aggiunta al metodo già esistente nella finestra dello stile. tdf#84504 (Charu Tyagi, Ericsson)

Numerazione delle righe per intestazione e piè di pagina.

Miglioramenti alla barra di stato

  • Il numeri di pagina nella status bar sono più facilmente comprensibili quando si usano gli stili del numero di pagina. tdf#80617 (Yousuf Philips e Samuel Mehrbrodt)
Prima (a sinistra) e dopo (a destra) come i numeri di pagina della status bar sono stati migliorati.
  • La spaziatura tra gli elementi è stata migliorata per funzionare meglio su schermi a bassa risoluzione e finestre piccole, e il doppio click nello spazio vuoto della status bar non apre più la finestra "Comando di campo". tdf#86018 (Yousuf Philips and Samuel Mehrbrodt)
  • Il comportamento al click è stato unificato così che il click sinistro esegue un'azione oppure fa apparire una finestra, e il click destro mostra il menu contestuale. tdf#82707 (Yousuf Philips e Samuel Mehrbrodt)
  • Aggiunti i suggerimenti per tutti gli elementi della barra di stato. tdf#82708 (Yousuf Philips and Samuel Mehrbrodt)
  • Il conteggio delle parole e dei caratteri ora ha il separatore delle migliaia. tdf#83308 (Yousuf Philips e Matthew J. Francis)

Miglioramenti alle barre degli strumenti

  • Le toolbar "Standard" e "Formattazione" sono state riorganizzate per rimuovere le funzionalità meno utili e sostituirle con funzioni più comunemente usate, riducendo la necessità per gli utenti di andare a cercarle nei menu o dover personalizzare le loro toolbar. Altri pulsanti utili sono stati aggiunti alle toolbar, ma nascosti di default e possono essere attivati usando l'opzione "Personalizza". tdf#81475 (Yousuf Philips e Samuel Mehrbrodt)
Prima (sopra) e dopo (sotto) a confronto di come le toolbar sono state migliorate.

Segnalibri del navigatore

I segnalibri nel navigatore possono essere nominati usando qualsiasi carattere che sia un nome di ancoraggio accettato dall'HTML. In particolare, LibreOffice ora accetta punto (.) e due punti (:). tdf#56116 (Brij Mohan Lal Srivastava)

Miglioramenti alla correzione automatica

Sostituzione dei trattini fra i numeri, regole per caratteri jolly nei modelli di default di correzione automatica e nuove regole di autocorrezione per caratteri jolly interposti, anche in Impress, Calc e Draw (László Németh):

  • Migliorata la funzione di autocorrezione "Sostituisci trattini": i doppi trattini fra numeri sono sostituiti con un trattino corto (–) invece di uno lungo (—), in accordo all'ortografia per il tipo di valori (anni, numeri di pagine, etc...), per esempio 1:15--2:15 p.m., pg. 38--55, per l'età 3--5, Il presidente Jimmy Carter (1977--81) verranno sostituiti con 1:15–2:15 p.m., per l'età 3–5, pg. 38–55, Il presidente Jimmy Carter (1977–81). (Vedere anche Lineetta), tdf#62923
  • Semplificato l'inserimento di caratteri speciali tramite modelli di autocorrezione di default:
    • Trademark, copyright, simboli di marchio registrato: battere e cancellare gli spazi prima dei modelli di correzione predefiniti come (tm), (C) e (R) non è più necessario; LibreOffice(tm) sarà sostituito con LibreOffice™. tdf#81571
    • Frecce: battere gli spazi intorno al modello di correzione predefinito della "freccia ASCII" come (->, <-) non è più necessario; A->B->C diventerà A→B→C.
    • Caratteri in pedice/apice (nei modelli di autocorrezione predefiniti per Francese e Ungherese ): input per caratteri in pedice/apice stile Tex verranno corretti come cm^2cm², H_2OH₂O, H^+H⁺. (Nota: questi caratteri sono solitamente migliori tipograficamente quando si usa una dimensione piccola per la font di pedice/apice, sopratutto con Linux Libertine G, la font Graphite di default di LibreOffice). [Francese (Olivier R.) e Ungherese]
  • Modelli di autocorrezione per caratteri jolly interposti: i modelli di correzione per caratteri jolly (text.* e .*text) introdotti in LibreOffice 4.2 consentivano sostituzioni auto-corrette di suffissi e prefissi a piacere. Ora in LibreOffice 4.4 è possibile aggiungere modelli stile .*text.* per correggere errori di battitura comuni all'interno delle parole. tdf#55292
Per esempio, una singola voce di autocorrezione con il modello .*laod.*load correggerà tutte le parole contenenti quella specifica sequenza di lettere:
uplaoding → uploading
uplaoded → uploaded
downlaoding → downloading
downlaoded → downloaded
...
Inoltre il modello .*text.* può essere usato anche per scrivere caratteri speciali, ad esempio per sostituire una legatura f semplice:
.*fi.* -> fi (U-FB01)
.*fl.* -> fl (U-FB02)
(Nota: alcune font Graphite e OpenType in LibreOffice hanno la sostituzione automatica della legatura f).

Calc

Vedere anche: Cambiamenti alle schede nella GUI

Funzioni di statistica (alternativa all'Add-in "Analysis ToolPak" di Excel)

Nelle funzioni di statistica in Dati ▸ Statistica:

  • Aggiunto il quartile nella Statistiche descrittive. tdf#81801 (Tomaž Vajngerl, Collabora)
  • Aggiunto il test Z. tdf#74669 (Tomaž Vajngerl, Collabora)
  • Aggiunto il test Chi quadrato. tdf#76868 (Tomaž Vajngerl, Collabora)

Conversione diretta delle formule in valori statici

E' stata aggiunta una funzione per convertire le celle con formule in valori statici (tramite il menu Strumenti ▸ Contenuti celle ▸ Formula in valore). Precedentemente era necessario tagliare le celle e incollarle di nuovo al loro posto per ottenere lo stesso effetto. (Kohei Yoshida, Collabora)

Engine delle formule

  • Aggiunta la funzione AGGREGATE per l'interoperabilità con Excel. tdf#73148 (Winfried Donkers, Eike Rathke)

Miglioramenti alle barre degli strumenti

  • Le toolbar "Standard" e "Formattazione" sono state riorganizzate rimuovendo i comandi usati meno comunemente e sostituendoli con le funzioni usate spesso, riducendo la necessità per gli utenti di andare a caccia nei menu o dover personalizzare le toolbar. Altri pulsanti sono stati aggiunti alle toolbar, ma sono nascosti di default e possono essere attivati usando l'opzione "Personalizza" dal menu contestuale del click destro oppure Strumenti ▸ Personalizza.... tdf#85594 (Yousuf Philips)
Prima (sopra) e dopo (sotto) a confronto di come le toolbar sono state migliorate.
  • Aggiunto il pulsante di "Scorrimento testo" alla toolbar di formattazione. tdf#60349 (Yousuf Philips)

Menu contestuale dei fogli

  • Il menu contestuale del click destro che appare per gestire i fogli ora ha delle icone per le operazioni sui fogli. tdf#86476 (Yousuf Philips)

Impress e Draw

Vedere anche: Cambiamenti alle schede nella GUI

Anteprime degli oggetti testo della Vista master

  • Nella Vista master (o Vista sfondo) della presentazione, le anteprime degli oggetto testo della presentazione sono ora in sola lettura. Cambiare il testo di queste anteprime non ha mai influenzato gli oggetti basati sugli stili tranne che quelli mostrati nell'anteprima. Per aggiungere o nascondere un livello nell'anteprima della struttura di numerazione, ora fare click destro sull'ultima riga per visualizzare un menu per aggiungere/nascondere un altro livello. (Caolan McNamara - RedHat)
Nascondi/mostra i livelli di struttura dal menu contestuale
  • Settare gli elenchi puntati o meno nell'anteprima della slide master nell'anteprima struttura tramite "Elenchi puntati e numerati" ora abilita/disabilita veramente gli elenchi puntati degli stili di struttura. In passato questo influenzava solo l'anteprima stessa, lasciando gli stili di struttura inalterati. Ora imposta correttamente i livelli struttura nella vista normale. (Caolan McNamara - RedHat)

Selezionare e disattivare gli elementi master cancellandoli direttamente

  • Nella Vista master (o Vista sfondo), gli elementi master che Impress consente all'utente di rimuovere tramite Vista ▸ Sfondo ▸ Elementi sfondo possono ora essere rimossi cancellando direttamente i corrispondenti riquadri nell'anteprima della Vista master. In altre parole, per rimuovere un'intestazione, piè di pagina, numero di diapositiva o data/ora selezionare il box corrispondente nella Vista master e premere Canc. (Caolán McNamara, Red Hat)
Selezionare e disattivare gli elementi master direttamente cancellandoli.

Transizioni OpenGL

  • Implementate e abilitate per Windows. (Markus Mohrhard - Collabora)
  • Migliore implementazione basata su un nuovo framework OpenGL in VCL per Linux, Windows e OSX. (Markus Mohrhard - Collabora)

Comando di campo per il Titolo

Nuovo comando di campo: Titolo della pagina in Inserisci ▸ Comando di campo ▸ Titolo. tdf#47302 (Jennifer Liebel)

Eredita lo stile di cella corrente inserendo una nuova riga/colonna in una tabella

Quando si ha una tabella in Impress, modificare uno stile di cella e poi aggiungere una nuova riga o colonna ora eredita lo stile della riga/colonna corrente nella nuova invece di usare i valori di default. tdf#60712 (Hideki Ikeda)

Password per la modifica

Ora è possibile salvare un file di sola lettura in Impress/Draw e richiedere una password per modificarlo. tdf#63483 (Katarína Behrens)

Stampa: usare la dimensione specificata della pagina

Draw ora usa per la stampa la dimensione del foglio specificata nella formattazione della pagina. tdf#63905 (Eilidh McAdam)

Tasto modalità dello zoom

Creato un nuovo pulsante per la modalità dello zoom che permette di zoomare avanti, indietro e spostarsi con l'uso di Ctrl e ⇧ Shift. tdf#55903, tdf#83572 (Maxim Monastirsky e Yousuf Philips)

Miglioramenti alle barre degli strumenti

  • Le toolbar di default sono state riorganizzare per offrire le funzioni usate di frequente. tdf#84909 (Yousuf Philips)
Prima (sopra) e dopo (sotto) a confronto di come le toolbar di Impress sono state migliorate.

Miglioramenti alla barra dei menu

  • Il menu Visualizza è stato riorganizzato per unificare meglio le sue voci con quelle simili in Writer e Calc. tdf#86209 (Yousuf Philips)

Math

Supporto ai colori

Nuovi colori supportati da Math.

Core

Font incluse

LibreOffice 4.4 aggiunge le font con licenza libera Caladea e Carlito (di Huerta Tipográfica). Hanno la stessa metrica e proporzioni rispettivamente delle font Cambria e Calibri di Microsoft, quindi possono essere usati come sostituti. (András Tímár, Collabora)

Export di PDF con firma digitale

I PDF generati da LibreOffice ora possono essere firmati digitalmente direttamente da LibreOffice durante l'export. Funziona su Windows, Mac e Linux, e su Windows la gestione dei certificati integrata nel sistema è usata per memorizzare i propri certificati per la firma. (Gökçen Eraslan - GSoC 2012, Markus Wernig - Wilhelm Tux, fund raising, Tor Lillqvist - Collabora)

Selezione di un certificato per la firma su Windows.
La scheda Firma digitale nella finestra dell'export PDF.

Oggetti disegnati

E' possibile spostare anche il punto vicino al rettangolo nelle figure "Legenda riga", tenendo premuto il tasto ⇧ Shift. (Matúš Kukan - Collabora)

Dizionario tecnico

  • Aggiornamenti vari sono stati fatti al dizionario tecnico. I nomi dei nuovi rilasci di Debian e Ubuntu sono stati aggiunti, come i nomi di più sistemi operativi. In aggiunta, i nomi dei rilasci obsoleti di Ubuntu (prima di Ubuntu 10.04 LTS) sono stati rimossi dal dizionario tecnico.

LibreOfficeKit

Impress supporta il Tiled rendering⁠Wikipedia logo v3.svg con prestazioni migliorate per la fruizione dei documenti sui dispositivi mobili. (Andrzej Hunt - GSoC 2014)

Guida d'aiuto

Qualita' del codice

Traduzione di commenti dal tedesco

Moltissimi altri commenti nel codice sorgente sono state tradotti in Inglese. (Daniel Sikeler; Christian M. Heller; Tobias Madl; Thomas Viehmann; Philipp Riemer; Michael Jaumann; Laurent Balland-Poirier; Chris Sherlock; Philipp Weissenbacher; e Jennifer Liebel)

Coverity

Migliorata la qualità del codice basandosi sulle analisi di scansione di Coverity.

Risultati basati sulle analisi di Coverity Scan. (Dati disponibili dopo la registrazione)

Refactoring

Revisionato gran parte del codice di Writer, dividendo le grandi classi in interfacce di programmazione più piccole. (Valentin Kettner - GSoC 2014)

Filtri

Vedere anche: Document Liberation libraries

Formati multimediali

Sono disponibili più tipi di file multimediali da Inserisci ▸ Audio e video: Real Audio (.ra), Real Media (.rm), Digital Video (.dv), Audio Codec (.ac3), Ogg Opus (.opus), Advanced Systems (.asf), MPEG Audio (.m4a). tdf#82994 (Daniel Sikeler e Caolán McNamara)

Nuovi filtri di import

  • Draw ora può importare i file di Adobe PageMaker (v. 6-7), tramite libpagemaker. (Anurag Kanungo - GSoC 2014)
Documento di esempio aperto in PageMaker 7.0
Lo stesso documento aperto in LibreOffice 4.4
Un ebook di esempio aperto in LibreOffice.

Connessione a SharePoint e OneDrive

  • E' possibile connettersi a SharePoint 2010/2013 direttamente da LibreOffice. post del blog (Mihai Varga - GSoC 2014)
Scelta della versione
Controllo
Caricamento
Caricamento completato
  • E' possibile connettersi a OneDrive direttamente da LibreOffice. blog entry (Mihai Varga - GSoC 2014)
Setup del server
Autenticazione
Scelta del file
Salvataggio

Migliorato il supporto ad OOXML

  • I metadati sono ora importati dai PPTX. (Miklós Vajna, Collabora)
  • I poligoni dalla forma personalizzata sono ora esportati in DOCX. (Miklós Vajna, Collabora)
  • Supporto per le bitmap durante l'export in DOCX di immagini tagliate. (Miklós Vajna, Collabora)

Migliorato il supporto a Visio

  • I metadati sono ora importati dai file VSDX. tdf#86664 (Miklós Vajna, Collabora)
  • I metadati sono ora importati dai file VSD. tdf#86729 (Miklós Vajna, Collabora)

Migliorato l'export HTML del sommario

E' possibile esportare i puntini guida CSS2 abilitando Layout di stampa in Strumenti ▸ Opzioni ▸ Carica/salva ▸ Compatibilità HTML, e selezionando il tipo di file 'Documento HTML' nella finestra 'Salva come' di Writer. (László Németh)
Testato su Firefox 32, Google Chrome 39 e Internet Explorer 11.

Il vecchio sommario HTML.
Il nuovo sommario HTML con punti guida CSS2.

Anteprime dei documenti

Le anteprime dei documenti sono ora compresse in PNG-8, che richiede molto meno spazio del PNG-24 senza molta perdita di qualità. Mediamente le anteprime si riducono al 35% della dimensione dell'anteprima di un documento salvato con LibreOffice 4.3. tdf#62104 (Tomaž Vajngerl, Collabora)

Migliorato il supporto a MS Publisher

  • Le font integrate sono ora importate. (David Tardon)
  • Le tabelle sono ora importate. (David Tardon)
  • I metadati sono ora importati. (Miklós Vajna, Collabora)

Supporto migliorato ad Abiword

  • La lingua del testo è ora settata correttamente. (David Tardon)
  • La modalità di scrittura definita globalmente è ora usata. (David Tardon)
  • I titoli sono ora riconosciuti. (David Tardon)
  • I metadati sono ora importati. (David Tardon)

Migliorato il supporto a MS Works Spreadsheet

Una vecchia codifica dei caratteri Lotus LICS è ora riconosciuta e convertita. (Laurent Alonso)

Migliorato il supporto a FictionBook

  • La lingua del testo è ora settata (purché il file di input la specifichi correttamente). (David Tardon)
  • I titoli sono ora importati. (David Tardon)

GUI

Finestre di dialogo completamente convertite a WidgetLayout

LibreOffice 4.0 introdusse una nuova infrastruttura per costruire interfacce grafiche delle finestre di dialogo nel formato .ui basato su XML di GtkBuilder/Glade. Tutte le finestre di dialogo originali (basate su .src) sono ora convertite nel nuovo formato. post del blog (Caolán McNamara - Red Hat, Palenik Mihály - GSoC 2014, Szymon Kłos - GSoC 2014, e molti altri eroi)

Cambiamenti ai righelli

  • I righelli hanno numeri più piccoli e ora sono nascosti di default. (Jan Holešovský, Collabora)
I righelli di LO 4.4 (a destra) hanno un aspetto più discreto e meno fonte di distrazione.
  • I righelli possono essere attivati o nascosti con la combinazione di tasti Ctrl+⇧ Shift+R. tdf#87042 (Mattias Põldaru)
  • Writer ora nasconde il righello verticale di default, ma l'utente può riabilitarlo in Strumenti ▸ Opzioni ▸ LibreOffice Writer ▸ Vista. tdf#87923 (Jan Holešovský, Collabora)

Start Center

I template ora appaiono direttamente nello Start Center e possono essere utilizzati da lì. (Efe Gürkan Yalaman - GSoC 2014, Jan Holešovský - Collabora)

I template nello Start Center.

Nuovi template di default

Sono stati creati nuovi template ed inclusi nell'installazione di default. (Alexander Wilms, Edmund Laugasson, Jun NOGATA, Michael Kovarik, Péter Szathmáry, Zirk)

I nuovi template visibili nello Start Center.

Nuova tavolozza dei colori

  • Mostra i colori recenti usati nel documento
  • Supporta diverse palette colori e il formato .gpl delle palette di GIMP
  • Consente di aprire direttamente il selettore colori per scegliere un altro colore

(Krisztian Pinter, GSoC 2014; Tomaž Vajngerl - Collabora; Maxim Monastirsky; e Adolfo Jayme Barrientos)

La nuova tavolozza colori facilita l'accesso ai colori personalizzati ed evita di navigare fra i menu.

Rielaborato il pannello a cascata dell'interlinea

Il pannello a cascata dell'interlinea che era presente solo nella sidebar è stato rielaborato per poter essere usato anche nella toolbar principale, e lì è stato aggiunto. tdf#83076 (Jan Holešovský, Collabora; Yousuf Philips)

Il nuovo pannello dell'interlinea.

Pannelli per elenchi numerati e puntati

  • I pulsanti "Punti" e "Numerazione" delle toolbar ora hanno pannelli a tendina ed è quindi più facile cambiare lo stile di un elenco senza aprire la finestra di dialogo degli elenchi. tdf#85804 (Maxim Monastirsky; Yousuf Philips)
Il nuovo pannello per gli elenchi.

Cambiamenti alla Sidebar

La sidebar sta continuando a ricevere miglioramenti graduali dalla nostra community di sviluppatori dopo l'import iniziale del codice da Symphony:

  • E' stata abilitata di default in Writer, in aggiunta ad Impress (dove è già attiva dalla 4.2) ed inoltre ora integra le funzionalità dei vecchi pannelli "Galleria" e "Stili & formattazioni", rimuovendo molta ridondanza della UI. tdf#73151 (Samuel Mehrbrodt)
  • Le icone delle schede ora funzionano anche come interruttori per aprire/chiudere i pannelli della sidebar. tdf#67627 (Thomas Arnhold)
  • Il menu della sidebar ora ha la voce "Chiudi sidebar". tdf#85937 (Samuel Mehrbrodt)
  • La sidebar è aperta di default in Writer, Calc e Draw mostrando solo le icone delle schede. tdf#85935 (Jan Holešovský, Collabora)
  • Le schede degli Stili hanno icone nuove. (Miroslav Mazel)
Nuove icone per le schede degli Stili.

Cambiamenti al menu contestuale

  • Le azioni Taglia, Copia e Incolla sono ora in cima al menu contestuale. tdf#71770 tdf#84293 (Jeffrey Stedfast - Xamarin; Yousuf Philips)
  • Writer ora ha l'abilità di accedere alla finestra Incolla speciale tramite il menu contestuale, come in Calc. tdf#62947 (Babu Vincent; Yousuf Philips)
  • Le opzioni Tipo di carattere, Dimensione e Allineamento sono state rimosse dal menu contestuale: secondo le statistiche erano ampiamente inutilizzate e la loro rimozione riduce il disordine visivo. tdf#81132 (Yousuf Philips e Samuel Mehrbrodt)
Taglia, copia e incolla spostati in cima al menu contestuale.
Incolla speciale è ora disponibile tramite il menu contestuale.
Rimosse alcune opzioni di formattazioni inutilizzate.
  • Writer ora ha un'opzione per cambiare l'immagine selezionata con un'altra tramite il menu contestuale, come in Impress e Draw. tdf#82496 (Jennifer Liebel)
Cambia Immagine dal menu contestuale

Modalità di sola lettura/modifica

LibreOffice ora visualizza un'infobar per indicare chiaramente quando un documento è stato aperto in modalità di sola lettura. Questa infobar sostituisce l'icona "Modifica file" nella toolbar principale, che è stata rimossa perché si è visto che il suo nome e il suo funzionamento confonde alcuni utenti. L'attivazione e disattivazione della modalità di sola lettura è anche possibile dal menu Modifica ▸ Modifica file o tramite la scorciatoia da tastiera Ctrl+⇧ Shift+M. tdf#80538 tdf#80536 (Yousuf Philips, Samuel Mehrbrodt e Joren De Cuyper)

L'infobar fornisce indicazioni più chiare agli utenti in questo caso d'uso.

Cambiamenti alle schede

  • Le schede dei fogli (in Calc) e dei layer (in Draw) sono state spostate su una riga indipendente e non sono più visualizzate in parte alla scrollbar orizzontale. Visto che molti temi visivi sotto Linux (in aggiunta alla configurazione di default su OSX) usano barre di scorrimento molto sottili, questi renderizzavano le schede troppo piccole per essere cliccabili e, sopratutto, leggibili. tdf#36772 (Tomaž Vajngerl - Collabora, e Samuel Mehrbrodt)
  • Le schede hanno un look più moderno e flat. (Tomaž Vajngerl, Collabora)
Prima.
Dopo.

Temi di Firefox

  • Nuovo browser per i temi di Firefox con ricerca e anteprima. (Rachit Gupta, GSoC 2014)
La nuova finestra per cercare e applicare i temi Firefox.
  • I temi Firefox ora sono applicati anche alle toolbar inferiori. tdf#59299 (Michael Jaumann, LHM)
I temi Firefox ora sono applicati sia alle toolbar superiori che inferiori.

Ridimensionamento delle immagini

Le immagini sono ora ridimensionate in modo proporzionale di default in Calc e Impress/Draw, come già avviene in Writer. tdf#83808 (Samuel Mehrbrodt)

Semplificazione della finestra dei Caratteri speciali

I caratteri speciali ora sono aggiunti in un campo editabile quindi possono essere inseriti/rimossi nel punto del cursore del mouse nel campo. tdf#64302 tdf#85907 (Szymon Kłos; Adolfo Jayme Barrientos)

Finestra semplificata dei Carattere speciali con un campo di input.

Miglioramenti alle icone

  • Aggiunte icone nuove e migliorate ai temi Tango, Sifr e Oxygen. tdf#75256 tdf#75359 (Mirek Mazel; Yousuf Philips; Matthias Freund; Alexander Wilms; e Adolfo Jayme Barrientos)
  • Le icone grandi sono di default su Windows, come lo sono su Linux e OSX. tdf#82309 (Jan Holešovský, Collabora; e Yousuf Philips)

Localizzazione nella finestra Informazioni

La finestra Informazioni su LibreOffice ora mostra all'utente il locale⁠Wikipedia logo v3.svg in uso in quel momento. tdf#85432 (Brij Mohan Lal Srivastava)

Le informazioni di localizzazione, mostrate sotto il build ID, posso essere utili per il debug di problemi correlati alla lingua.

Miglioramenti al testo dell'interfaccia

Vedere anche: Documentation/RecentStringChanges#4.4

Un certo numero di stringhe della UI sono state modificare per essere meglio comprensibili dagli utenti:

  • Filmati e suoni → Audio e video
  • Copia formato → Clona formattazione
  • Inserisci ▸ Comando di campo ▸ Altro...Inserisci ▸ Comando di campo ▸ Più campi.... Cambiato anche l'ordine dei campi. Lo stesso vale per il menu a tendina nella barra degli strumenti.
  • Extra → Più stili (nell'elenco degli Stili)
  • Extra → Più opzioni (nel pannello della Tabella)
  • Extra → Più campi (nell'elenco dei comandi di campo)

Localizzazione

Nuove lingue/locales con dati di localizzazione

Disponibili come lingue predefinite per i documenti e per la formattazione specifica localizzata.

  • Aggiunti i locale data del Catalano Valenziano [ca-ES-valencia]. tdf#83292 (Andras Timar)

Migliorati gli strumenti linguistici (controllo ortografico, thesaurus, sillabazione)

  • Aggiornato il dizionario del controllo ortografico in Portoghese.
  • Aggiornato il dizionario del controllo ortografico in Francese. (Olivier R.)
  • Aggiornato il thesaurus Sloveno. (Martin Srebotnjak)
  • Aggiornate le regole di correzione (Lightproof) del Russo. (Yakov Reztsov)
  • La correzione automatica dello Spagnolo include molti più errori di ortografia e sono state aggiunte molte regole tipografiche. (Adolfo Jayme Barrientos)

Prestazioni

  • Il caricamento degli elenchi di correzione automatica di grandi dimensioni è almeno due volte più veloce ora, perché gli elenchi sono elaborati in un thread da FastParser ed è evitata l'analisi ripetuta di file non modificati. tdf#79761 (Daniel Sikeler)
  • Lo swap out/in ridondante delle immagini è stato significativamente ripulito per evitare inutili caricamenti/salvataggi delle immagini in memoria. (Tamas Zolnai, Collabora)
  • Le classi FastSerializer usati da tutto l'export OpenXML sono significativamente molto più veloci ed efficienti, riducendo le chiamate di sistema. (Matus Kukan, Collabora)
  • LibreOffice ora usa e integra la libreria JPEG-Turbo che fornisce performance migliori di almeno 2 volte per il caricamento e la decompressione delle immagini JPEG. (Matúš Kukan, Collabora)
  • La Stampa guidata in serie in Writer dovrebbe ora essere significativamente più veloce quando si elaborano un numero elevato di record. (Luboš Luňák, Collabora)

Scripting / Basic

  • E' ora possibile esportare una libreria Basic da un documento di Excel. tdf#60904 (Caolán McNamara, Red Hat)
  • Modificato il valore che si ottiene da GetSolarVersion. Prima di questo cambiamento il valore ottenuto era un unico numero per la versione major, minor e micro. Quindi per la 4.4.0 il valore ottenuto era 440. Ora usiamo due decimali per la versione major, due per la versione minor e uno per la versione micro. Il nuovo formato è 40400, per la versione 4.4.0. tdf#60689 (Marcos Paulo de Souza)
  • Aggiunto un metodo (un-published: fare attenzione) processEventsToIdle() al servizio com.sun.star.awt.Toolkit - chiamarlo fa sì che tutto il rendering in attesa sia completato. (Michael Meeks, Collabora)

Access2Base aggiornato

La libreria Basic integrata Access2Base è stata aggiornata alla versione 1.2.0. (Jean-Pierre Ledure)

  • Tutti i metodi che possono essere utilizzati di per sé senza una connessione al database (gestione degli errori, manipolazioni delle finestre di dialogo, gestione della barra di stato e della finestra, comandi di lancio...) sono stati rivisti per diventare eseguibili prima di ogni chiamata OpenConnection.
  • E' stato aggiunto un metodo CloseConnection per liberare risorse.
  • Per passare valori da un documento aperto ad un altro, usare la collezione di TempVars degli oggetti TempVar.
  • Nuove proprietà aggiunte per forms e subforms: OrderBy e OrderByOn.
  • Le azioni ApplyFilter e SetOrderBy sono ora applicabili ai datasheet di tabelle o query, nonché a forms o subforms.
  • Il metodo GoTorecord è stato esteso ai datasheet di tabelle e query.

Per maggiori informazioni, visitare questo sito.

Funzioni rimosse / deprecate

La funzionalità per integrare LibreOffice in alcuni browser web tramite il deprecato NPAPI⁠Wikipedia logo v3.svg (abilitato tramite l'opzione Internet ▸ Plugin del browser ▸ Mostra i documenti nel browser) è stata rimossa. (Bryan Quigley, post dal blog)

Cambiamenti alle API

Removed configuration options

C++ UNO language binding and URE libraries

OSL macro clean-up

IReference and ReferenceObject

core commit 0c6c66b64a9572a8e474f6dfdedcbebfe54758af

Java UNO language binding

  • Add extra constructors for UNO Java exception classes that take a "Throwable cause" parameter, allowing us to store the original cause when rethrowing exceptions.

Java Office Bean

Cambiamenti alle API di UNO

The following UNO interfaces and services were changed:

Compatibilità dei sistemi

Windows

  • Problema noto: ci sono difficoltà nell'eseguire la versione per Windows sulle CPU più vecchie che mancano del supporto per le istruzioni SSE2, vedere tdf#82430. Le CPU affette includono i Pentium III e precedenti, e tutte le CPU AMD a 32bit (Athlon XP e precedenti).

OS X

  • LibreOffice 4.4 richiede OSX 10.8 o superiore. I pacchetti binari disponibili saranno solo a 64-bit.