LibreOffice 5.2: Notas da versão

From The Document Foundation Wiki
Jump to: navigation, search

Sobre esta página

Esta é uma página de rascunho com anotações sobre os desenvolvimentos até a liberação da versão. Não inclua aqui as modificações que já foram implementadas na versão 5.1 ou em outra anterior!

O que deve constar nesta página:

  • Uma descrição, e uma maneira adequada para um revisor encontrar e conferir a nova característica. Considere que pessoas são bastante ocupadas e com conhecimento modesto do produto. Assim, se um elemento da interface do usuário for importante, seja bastante explícito sobre onde encontrá-lo. Por exemplo, caminhos do tipo Menu ▸ Formatar ▸ Caractere ▸ Guia Posição ▸ 90 graus para achar o elemento novo. Claro que você considera sua contribuição importante e todos deveriam estar cientes de sua “caixa de diálogo de Propriedades avançadas das autoformas”, porém nem sempre as pessoas que gravam imagens de tela e que escrevem sobre o LibreOffice entendem exatamente o novo recurso.
  • Dê os créditos aos autores principais, as pessoas que trabalharam na novidade – Coloque seus nomes entre parênteses.
  • Se uma novidade pode ser apresentada com um exemplo ou arquivo de teste – particularmente para arquivos contendo as novidades, será muito bom ter um atalho para carregar um arquivo de teste que possa ser utilizado para mostrar de forma bem clara a nova característica. Isso ajuda muito para gravar imagens da tela para mostrar as novidades, e permite aos revisores fazerem seus próprios testes.

Obrigado por nos ajudar a completar esta página!


Writer

Novas características podem ser observadas neste vídeo:

  • Novas ferramentas de desenho, antes disponibilizadas apenas no Draw, foram adicionadas, incluindo Curva Cheia, Polígono, Desenho livre e Polígono (45°). tdf#89646 (Gülşah Köse)
  • Adicionado um filtro à aba Inserir ▸ Campos ▸ Outros campos ▸ Referências. O usuário pode digitar poucos caracteres para chegar à referência. tdf#32364 (Akshay Deep)
Guia Referência: seleção de filtro na interface.
  • O botão curva tornou-se um botão de divisão e relacionado com uma caixa de ferramentas a qual inclui cinco novos utilitários de desenho. tdf#89646 e tdf#90505 (Gülşah Köse)
Novos utilitários na barra de ferramentas.
  • O atalho para Fonte de dados foi alterado de F4 para Ctrl+⇧ Shift+F4 para unificá-lo com o Calc. tdf#97906 (Yousuf Philips)
  • A caixa de diálogo para incluir marcadores foi refeita Incluir ▸ Marcador. tdf#90855 (Jakub Trzebiatowski e Yousuf Philips)
A nova caixa de diálogo.

Calc

Novas características podem ser observadas neste vídeo:

  • Novas ferramentas de desenho, antes disponibilizadas apenas no Draw, foram adicionadas, incluindo Curva Cheia, Polígono, Desenho livre e Polígono (45°). tdf#89646 (Gülşah Köse)
  • Todos os botões da barra de ferramentas de formatação condicional foram unificados em um único botão do grupo Formatação condicional. tdf#86567 (Maxim Monastirsky)
  • Forma mais fácil de congelar a primeira coluna ou a primeira linha de uma planilha através da barra de ferramentas ou do menu Exibir ▸ Congelar células. tdf#91013 (Gülşah Köse, Maxim Monastirsky e Yousuf Philips)
  • O botão para abrir múltiplas linhas foi redimensionado em todos os ambientes. tdf#99701 (Samuel Mehrbrodt – CIB)
  • Pressionando-se ⇧ Shift+Return na entrada de múltiplas linhas incluirá uma linha no lugar de mover as células. tdf#63994 (Samuel Mehrbrodt – CIB)
  • O atalho para Referências de célula ⇧ Shift+F4 foi modificado para F4, mas ainda está disponível no legado do OpenOffice.org. tdf#97906 (Dennis Francis e Yousuf Philips)
  • O atalho para Selecionar coluna Ctrl+⇧ Shift+Space foi modificado para Ctrl+Space. tdf#96969 (Yousuf Philips)
  • O atalho Ctrl+, para incluir data e Ctrl+⇧ Shift+, para incluir hora está disponível nos leiautes de teclado europeu. tdf#88027 (Yousuf Philips)
  • Adicionada opção para excluir as bordas de células na guia Bordas da caixa de diálogo Formatar células. tdf#34449 (Dennis Francis)
A nova opção pare remover bordas de células.
Esquerda — remove borda de células com a opção não selecionada, direita — a opção está selecionada.
  • Múltiplas funções da barra de estado podem ser ativadas ao mesmo tempo. tdf#42629 (Dennis Francis e Dag Wieers)
As funções na barra de estado Somar e Quantos estão ativas ao mesmo tempo.
  • Uma lista suspensa de moedas foi anexada ao ícone da barra de ferramentas da moeda torna mais fácil escolher o formato de moeda desejado. tdf#82641 (Mohammed Abdul Azeem e Michael Meeks)
Lista suspensa para escolher moeda.
  • O botão para congelar linhas e colunas tornou-se um botão de divisão e acrescentou as opções Congelar primeira linha e Congelar primeira coluna. tdf#91013 (Gülşah Köse e Maxim Monastirsky)
Congelar primeira coluna.
  • O botão curva tornou-se um botão de divisão e relacionado com uma caixa de ferramentas a qual inclui cinco novos utilitários de desenho. tdf#90505 (Gülşah Köse)
Novos utilitários na barra de ferramentas.
  • Formatos de data e hora com minuto e mês tendo o mesmo código M, tiveram melhorias na desambiguação. tdf#95339 tdf#101147 (Laurent BP)
  • Agora é possível utilizar um nome definido com um escopo local para uma planilha na fórmula de qualquer outra planilha. tdf#96915 (Eike Rathke – Red Hat)
    • Por exemplo, um intervalo nomeado NomeLocal definido com escopo na Planilha1 pode ser usado em uma fórmula na Planilha2 como =SOMA(Planilha1.NomeLocal), eventuais restrições de nome da planilha para as referências se aplicam, por exemplo, se o nome da planilha contiver um espaço em branco é necessário ser colocado entre aspas simples, como em =SOMA('Outra Planilha'.NomeLocal)
  • Ao copiar planilhas inteiras, expressões nomeadas e intervalos, os quais apontem para a planilha (escopo local), utilizados por qualquer fórmula em qualquer célula serão copiados para a nova planilha com escopo local. tdf#75372 (Eike Rathke – Red Hat)
Por exemplo, um documento com a planilha Planilha1 e os nomes definidos
Nome Expressão Escopo
global $Planilha1.$A$1 Documento (Global)
global_global glocal * 100 Documento (Global)
global_local local * 1000 Documento (Global)
local $Planilha1.$A$2 Planilha1
local_global mundial * 10000 Planilha1
local_local locais * 100000 Planilha1

e células de fórmulas usando os nomes global_global, global_local, local_global e local_local, copiadas da Planilha1 para a NovaPlanilha, resultará em nomes definidos (Caixa de diálogo Gerenciar nomes em NovaPlanilha)

Nome Expressão Escopo
global $Planilha1.$A$1 Documento (Global)
global $NovaPlanilha.$A$1 NovaPlanilha
global_global global * 100 Documento (Global)
global_global global * 100 NovaPlanilha
global_local $Planilha1.local * 1000 Documento (Global)
global_local local * 1000 NovaPlanilha
local $Planilha1.$A$2 Planilha1
local $NovaPlanilha.$A$2 NovaPlanilha
local_global global * 10000 Planilha1
local_global global * 10000 NovaPlanilha
local_local $Planilha1.local * 100000 Planilha1
local_local local * 100000 NovaPlanilha

assim as fórmulas continuarão a funcionar e os nomes apontarão para as células copiadas como esperado.

  • A dica foi estendida às funções. tdf#95878 (Keigo Kawamura)
A dica descreve a função e seus argumentos.

Novas funções

  • SUBTRAÇÃOPONTOFLUTUANTE subtrai números sem cancelar os erros de arredondamento do ponto flutuante. tdf#71459 (Eike Rathke – Red Hat)
    • =SUBTRAÇÃOPONTOFLUTUANTE(a,b,c) é como =a-b-c, mas o operador menos - cancela os erros de arredondamento do ponto flutuante que são devidos ao fato de um número decimal não ser exatamente representado binariamente. SUBTRAÇÃOPONTOFLUTUANTE usa a operação prevista em compiladores e sistemas definidos na norma IEEE754. Por exemplo, =0.3-0.2-0.1 resulta em 0, entretanto =SUBTRAÇÃOPONTOFLUTUANTE(0.3,0.2,0.1) resulta em 2.77555756156289E-17.
    Observação: Desmarque esta opção Ferramentes ▸ Opções ▸ LibreOffice Calc ▸ Calcular ▸ Limitar decimais para o formato de número geral para obter esta característica de ponto flutuante.
    • Isto pode ser usado para comparar se o resultado esperado é o mesmo do obtido em expressões numéricas, ou seja, se =SUBTRAÇÃOPONTOFLUTUANTE(resultado,esperado) é igual a 0.0.
  • PREVISÃO.ETS é um conjunto de funções de previsão que usam suavização exponencial dupla e tripla para lidar com os efeitos sazonais. tdf#94635 (Winfried Donkers)
    • São utilizados os algoritmos de Holt-Winters. Ambos os métodos adicionais e multiplicativos são suportados para suavização exponencial tripla.
    • O conjunto consiste nas funções PREVISÃO.ETS.ADIC, PREVISÃO.ETS.MULT, PREVISÃO.ETS.SAZONALIDADE, PREVISÃO.ETS.PI.ADIC, PREVISÃO.ETS.PI.MULT, PREVISÃO.ETS.STAT.ADIC e PREVISÃO.ETS.STAT.MULT.
Exemplo do intervalo previsto com intervalos de predição para 95% de confiança.
  • DIA.DA.SEMANA prevê novos valores no argumento Tipo. tdf#100396 (Eike Rathke – Red Hat)
    • Para a interoperabilidade com outros programas, novos valores para Tipo são aceitos e a função retorna entre 1 e 7:
      • 11: segunda-feira 1 a domingo 7
      • 12: terça-feira 1 a segunda-feira 7
      • 13: quarta-feira 1 a terça-feira 7
      • 14: quinta-feira 1 a quarta-feira 7
      • 15: sexta-feira 1 a quinta-feira 7
      • 16: sábado 1 a sexta-feira 7
      • 17: domingo 1 a sábado 7
    • Versões anteriores do Calc aceitavam qualquer valor inteiro no argumento Tipo, mas qualquer número sem ser 1, 2 ou 3 era tratado como 3, retornando valores com segunda-feira=0. Agora, qualquer valor que não esteja no conjunto [1,2,3,11,12,13,14,15,16,17] fará com que a função retorne erro.
  • Adicionadas novas funções para interoperabilidade com o MSExcel. (Winfried Donkers)
    • PREVISÃO.ETS.ADIC
    • PREVISÃO.ETS.SAZONALIDADE
    • PREVISÃO.ETS.PI.ADIC
    • PREVISÃO.ETS.STAT.ADIC
    • CONCAT é uma versão aprimorada da função CONCATENAR, permite intervalos, colunas e referências como argumentos tdf#97831
    • UNITEXTO concatena cadeia de caracteres através de delimitadores. tdf#97831
    • SES é a função SE em cascata. tdf#97831
    • PARÂMETRO é a seleção em mútliplas escolhas. tdf#97831
    • MÍNIMOSES e MÁXIMOSES são funções estatísticas que retornam o valor num dado intervalo. tdf#97831

Impress & Draw

Novas características podem ser observadas neste vídeo:

  • Uma lista Animação Personalizada possui mais detalhes que podem ser vistos de relance. tdf#87812 (Akshay Deep e Yousuf Philips)
  • Menus de velocidade foram substituídos por caixas de combinação com valores editáveis. tdf#98037 (Akshay Deep)
  • Dicas Adicionais nos itens do menu na barra principal. tdf#91857 (Yousuf Philips)
  • Ajustes adicionais nos itens de menu para a barra de ferramentas principal. tdf#91857 (Yousuf Philips)
  • A nova guia da barra lateral permite acesso mais rápido às propriedades do slide e da página. Para mais detalhes, acesse esta página. tdf#89466 (Rishabh Kumar – GSoC 2015, Katarina Behrens – CIB, Susobhan Ghosh – GSoC 2016 e Yousuf Philips)
Acesso mais rápido.

Gráfico

  • Escala logarítmica automática de Y não mais fixa no 1. tdf#96871 (Laurent BP)
  • Linha de tendência: melhorada a renderização da equação polinomial. (Laurent BP)
    • antes f(x) = 2x^2 - x + 1
    • depois f(x) = 2x² - x + 1
  • A equação de linha de tendência fica edentada se ela for maior do que a largura do gráfico. tdf#94004 (Laurent BP)
Gráfico distorcido, antes do LibreOffice 5.2.
A equação de linha de tendência fica edentada para encaixar na largura do gráfico.

Núcleo & Geral

Assinatura de documentos

Descrição da assinatura.
  • Adicionado suporte à importação e à exportação da assinatura digital em arquivos OOXML. (Miklós Vajna – Collabora)

Classificação conforme padrões TSCP

  • No Writer, Calc e Impress há a barra de ferramentas Classificação que permite escolher o nível de classificação e gerenciar documentos seguros.
  • Esta barra de ferramentas existe para os casos onde o usuário necessita seguir uma política ao editar documentos. O LibreOffice pode ajudar o usuário a respeitar essas regras se informado sobre elas. A associação Transglobal Secure Collaboration Participation (TSCP) fornece normas para descrever classificação de documentos: o Business Authentication Framework (BAF) descreve como especificar uma política para esta barra de ferramentas, e o Business Authorization Identification and Labeling Scheme (BAILS) descreve como referenciar esta política em documentos. A classificação é armazenada em propriedades do documento.
  • Na implementação atual existem três categorias para escolher. A primeira, chamada de propriedade intelectual conforme o padrão TSCP_BAILSv1, define o cabeçalho/rodapé e a marca d'água (para determinados níveis de segurança). Esta configuração é susceptível de ser modificada em versões futuras.
  • Procure pela barra de ferramentas Classificação na ajuda local ou na internet. Para mais detalhes, acesse esta página. (Miklós Vajna – Collabora)

Leiaute de texto

  • Agora é possível o alinhamento vertical de texto em tabela. tdf#101729 (Mark Hung)

Conteúdo da ajuda

  • Páginas de ajuda atualizadas e adicionadas. (Adolfo Jayme Barrientos, Stanislav Horáček, Eike Rathke, Maxim Monastirsky, Yousuf Philips e Olivier Hallot)
Im-jabber.svg

No caso de você encontrar algum texto de ajuda em falta ou desatualizado, ele pode ser relatado no bugzilla; favor acrescentar a questão ao chamado tdf#80430. Este chamado também mostra problemas conhecidos na ausência ou erro do tópico Ajuda que precisam ser resolvidos.

Filtro

  • Arquivos do MSWord para DOS agora podem ser importados, via libwps. (Sean Young)
  • As linhas tracejadas e pontilhadas são exibidas corretamente para arquivos EMF. tdf#79679 (Chris Sherlock)
  • O topo e as junções de linhas são importados corretamente para arquivos EMF. (Stephan Van Den Akker)
  • A resolução (DPI) de arquivos JPEG é exportada corretamente. tdf#85761 (Chris Sherlock)
  • A importação do filtro SVGIO foi aperfeiçoada em Inserir ▸ Imagem. Para mais detalhes, acesse esta página. (Xisco Faulí)
  • Para o formato PDF, é possível exportar apenas as notas de página . tdf#39271 (David Tardon)

Adequação dos curingas ao padrão ODF 1.2 e OpenFormula

  • Os curingas, como são conhecidos a partir de outros aplicativos de planilha, agora podem ser usados em expressões de fórmula. (Eike Rathke – Red Hat)
    • * (asterisco) qualquer sequência de caracteres, inclusive vazia.
    • ? (interrogação) qualquer caractere, mas somente um.
    • ~ (til) escapa o significado especial do asterisco, ponto de interrogação ou til.
  • Curingas são suportados em todas as funções que possuem expressões regulares como parâmetro.
    • Funções de banco de dados: BDMÉDIA, BDCONTAR, BDCONTARA, BDEXTRAIR, BDMÁX, BDMÍN, BDMULTIPL, BDDESVPA, BDEST, BDSOMA, BDVAREST e BDVARP.
    • Demais funções: CONT.SE, COUNTIFS, PROC, PROCH, PROCV, CORRESP, SOMASE, MÉDIASE, AVERAGEIFS e PESQUISAR.
  • Foram criadas opções em Menu ▸ Ferramentas ▸ Opções ▸ Calc ▸ Calcular; há agora uma opção Ativar curinga em fórmulas que está agrupada com Permitir expressões regulares em fórmulas e Não há curingas ou expressões regulares em fórmulas. Ao ler documentos de planilha ODF com a diretiva table:use-wildcards habilitada ou ao importar planilha do MSExcel a opção é definida com os curingas ativados.

Desempenho

  • Melhorado o desempenho do despachador do VLC. (David Tardon)

Infraestrutura

  • Toda compilação oficial da TDF para Windows e Linux conterá um relatório de acidente com uma análise do problema. Para mais detalhes, acesse esta página.

Programação & Suporte

  • O utilitário de linha de comando regcompare do SDK foi substituído pelo unoidl-check.
    • Ao executar o unoidl-check, sem qualquer argumento, este imprime informações de utilização.
    • O unoidl-check já havia sido utilizado como um substituto para o regcompare dentro do ambiente de compilação do LibreOffice, uma vez que suporta mais formatos de entrada do que apenas o velho formato de estilo binário RDB, de modo que isto é novamente uma ação para consolidar apenas a utilização de uma única ferramenta.

Características removidas ou descontinuadas

  • O suporte para extensões embutidas NPAPI em navegadores foi removido.
  • O suporte ActiveX foi considerado obsoleto e será descontinuado no futuro. Se esta mudança afetar negativamente alguma aplicação no Windows, é importante enviar uma mensagem para a lista de desenvolvimento do LibreOffice relatando detalhadamente o problema. A equipe de desenvolvedores deseja um retorno se há o uso de ActiveX para incorporar componentes do LibreOffice em alguma aplicação.
  • No Impress, a possibilidade de exibir o Navegador durante a apresentação foi removida. tdf#96414 (Bryan Quigley)
  • No Impress, o botão Ponteiro e o seu comando uno:NavigatorPen foram removidos do Navegador. (Bryan Quigley)
  • A implementação não documentada com.sun.star.comp.framework.TabWindowService do serviço com.sun.star.ui.dialogs.TabContainerWindow foi removida.
  • O módulo com.sun.star.plugin e as interfaces relacionadas ao plugin NPAPI com.sun.star.mozilla.XPluginInstance, com.sun.star.mozilla.XPluginInstanceNotifySink, com.sun.star.mozilla.XPluginInstancePeer, com.sun.star.mozilla.XPluginInstanceSyncPeer e com.sun.star.mozilla.XPluginWindowPeer foram removidos conforme esta e esta compilação.

Reformulação do código

  • O comando .uno:TaskPane e o código TaskPane foram removidos. O comando usado para mostrar o painel de tarefas que era utilizado anteriormente no Impress foi substituído pela Barra lateral. Extensões legadas usando .uno:TaskPane ainda são suportadas pela barra lateral. (Samuel Mehrbrodt – CIB)
  • O serviço PathSubstitution foi substituído para $(nome do usuário) o qual representa o usuário em sessão. tdf#98407 (Samuel Mehrbrodt – CIB)
  • É possível manipular o menu de contexto com a API com.sun.star.ui.UIConfigurationManager, usando endereços como private:resource/popupmenu/menu_name. tdf#93837 (Maxim Monastirsky)
  • Usuários da API com.sun.star.ui.XContextMenuInterceptor podem capturar o recurso do endereço do corrente menu de contexto, assim como o atributo ActionTriggerContainer da estrutura com.sun.star.ui.ContextMenuExecuteEvent implementado pela interface com.sun.star.container.XNamed, que retornava vazio. tdf#93837 (Maxim Monastirsky)

Interface do usuário

Novas características podem ser observadas neste vídeo:

  • Adicionada a possibilidade para editar parâmetros de inicialização da JVM. tdf#97425 (Akshay Deep)
  • As abas, no Editor Basic, foram movidas para uma linha própria que independe da altura da barra de rolamento. tdf#96683 (Samuel Mehrbrodt – CIB)
  • Vídeos, gráficos e objetos OLE serão, por padrão, redimensionados proporcionalmente. tdf#97919 (Samuel Mehrbrodt – CIB)
  • Aperfeiçoado o redimensionamento para imagens, vídeos e objetos OLE; arrastando o canto, redimensionará proporcionalmente enquanto que arrastar a borda redimensionará sem manter a proporção entre altura e largura. tdf#84953 (Samuel Mehrbrodt – CIB)
  • Simplificação na opção Espaçamento entre caracteres. tdf#89953 (Samuel Mehrbrodt – CIB e Oliver Specht – CIB)
  • No Windows, Alt+F12 foi associada Ferramentas ▸ Opções. tdf#98290 (Yousuf Philips)
  • No Windows, a mudança de leiaute do teclado é detectada. tdf#98924 (Juergen Funk – CIB)
  • No Mac OS, ⌘ Cmd+G foi associado ao Localizar próximo, ⌘ Cmd+: ao Corretor ortográfico, e ⌘ Cmd+Ctrl+F à Tela cheia. (Yousuf Philips)

Janela

  • Imprimir para arquivo está disponível na lista de impressoras da caixa de diálogo Imprimir. tdf#94097 (Katarina Behrens – CIB)
  • Adicionado o botão Achar anterior. tdf#98417 (Akshay Deep e Yousuf Philips)
  • Novo leiaute da caixa de diálogo Achar/Substituir. tdf#98539 (Akshay Deep e Yousuf Philips)
Caixa de diálogo Achar/Substituir condensada.
Caixa de diálogo Achar/Substituir expandida.

Menu

  • No Writer, botão adicionado à barra de ferramentas Padrão para exibir ou esconder a barra de registro de alterações. tdf#90187 (Gülşah Köse)
Nova barra de registro de alterações.
  • No Writer e no Calc, a barra de ferramenta Padrão (Modo Exibição) foi criada para ser usada como uma alternativa simples à barra de ferramentas com o arranjo de duas barras de ferramentas padrão e que contém a função muito utilizada de inserção, além de outras operações para formatação. É possível ativá-la pelo menu Exibir ▸ Barra de Ferramentas ▸ Padrão (Modo de Exibição) e desativá-la em Exibir ▸ Barra de Ferramentas ▸ Padrão e Exibir ▸ Barra de Ferramentas ▸ Formatação. tdf#92218 (Yousuf Philips)
Writer: nova barra de ferramentas permite modo de exibição.
Calc: nova barra de ferramentas permite modo de exibição.
  • Lista de efeitos do Draw foi movida da caixa de diálogo para a guia da barra lateral Animação Personalizada. tdf#87813 (Rishabh Kumar – GSoC 2015 e Yousuf Philips)
  • No Draw e no Impress, botão adicionado que esconde ou exibe as funções. tdf#89540 (Gülşah Köse)
Botão para esconder ou exibir as funções.
Botão para esconder ou exibir as funções.
  • Salvar como modelo está disponível no menu suspenso do botão Salvar da barra de ferramentas. tdf#99926 (Samuel Mehrbrodt – CIB)
  • Ajustes adicionais nos itens de menu para a barra de ferramentas principal. tdf#91781 (Yousuf Philips)
  • Barra de menu nativa com GTK3. (Caolán McNamara – Red Hat)
  • Menus de contexto, dicas e menus suspensos nativos no GTK3. (Caolán McNamara – Red Hat)
  • Ícones de visualização foram adicionados na caixa de diálogo Arquivo remoto, além de botões para alteração entre os modos de visualização. (Szymon Kłos, Yousuf Philips e Heiko Tietze)
Caixa de diálogo com os ícones de visualização.
  • Compatibilidade com a autenticação em duas etapas (2FA), para o Google Drive. tdf#87938 (Szymon Kłos)
Autenticação 2FA do GDrive: chave é solicitada.
  • Nova interface para Gerenciar Modelos. Para mais detalhes, acesse esta página. (Akshay Deep – GSoC 2016, Yousuf Philips e Samuel Mehrbrodt)
    • Menu de Contexto para funções não-navegação
    • Controles de fundo para funções de navegação
    • Filtros de pesquisa e caixa de combinação para a filtragem de modelos
Leiaute do gerenciador de modelos.

Configuração

  • Nova opção de configuração avançada RecentDocsThumbnail para desabilitar a lista de imagens na Tela Inicial. tdf#74834 (Pierre Sauter)
  • A caixa de diálogo Ferramentas ▸ Personalizar… tem uma nova guia Menu de contexto, na qual é possível personalizar os menus de contexto. tdf#93837 (Maxim Monastirsky)

Localização

  • As ferramentas de correção para o idioma Português da Europa (pt-PT) foram melhoradas.
    • A autocorreção possui 168 novas entradas. tdf#97439 (Marco A. G. Pinto, Olivier Hallot e Raimundo Moura)
    • O corretor ortográfico foi atualizado. (Alberto Simões)
    • Novo glossário para a versão 5.2.3 tem como referência o projeto Onto.pt. tdf#101616 (Tiago Santos)
      • O número de palavras reconhecidas tem 37.924 novas entradas.
  • O acento no nome das funções do Calc no idioma espanhol (DÍA(), MÁX() etc.) foi removido na versão 5.2.3, de forma a compatibilizar sua utilização com outras implemetações. tdf#101981 (Adolfo Jayme Barrientos e Johnny_M)

Novos corretores ortográficos

Incorporação de outros idiomas

Nosso objetivo é prover o suporte ao maior número de idiomas possível. Gostaríamos de agradecer às seguintes pessoas pela tradução voluntária para o LibreOffice e ajuda na preservação de suas línguas nativas:

Im-jabber.svg

Se você fala uma língua ameaçada e quer nos ajudar a alcançar nossos objetivos de fornecer ferramentas livres para cada pessoa no planeta, favor juntar-se a nós.