LibreOffice 5.3: Notas da versão

From The Document Foundation Wiki
Jump to: navigation, search

Sobre esta página

Esta é uma página de rascunho com anotações sobre os desenvolvimentos até a liberação da versão. Não inclua aqui as modificações que já foram implementadas na versão 5.2 ou em outra anterior!

O que deve constar nesta página:

  • Uma descrição, e uma maneira adequada para um revisor encontrar e conferir a nova característica. Considere que pessoas são bastante ocupadas e com conhecimento modesto do produto. Assim, se um elemento da interface do usuário for importante, seja bastante explícito sobre onde encontrá-lo. Por exemplo, caminhos do tipo Menu ▸ Formatar ▸ Caractere ▸ Guia Posição ▸ 90 graus para achar o elemento novo. Claro que você considera sua contribuição importante e todos deveriam estar cientes de sua “caixa de diálogo de Propriedades avançadas das autoformas”, porém nem sempre as pessoas que gravam imagens de tela e que escrevem sobre o LibreOffice entendem exatamente o novo recurso.
  • Dê os créditos aos autores principais, as pessoas que trabalharam na novidade – Coloque seus nomes entre parênteses.
  • Se uma novidade pode ser apresentada com um exemplo ou arquivo de teste – particularmente para arquivos contendo as novidades, será muito bom ter um atalho para carregar um arquivo de teste que possa ser utilizado para mostrar de forma bem clara a nova característica. Isso ajuda muito para gravar imagens da tela para mostrar as novidades, e permite aos revisores fazerem seus próprios testes.

Obrigado por nos ajudar a completar esta página!


Writer

Diálogo Ir para Página

  • O Writer tem uma nova caixa de diálogo para ir rapidamente para uma outra página disponível de forma simples. Edit ▸ Ir para página and Ctrl+G. tdf#83054 (Akshay Deep, Yousuf Philips)
Go to Page Dialog
  • Nova propriedade da barra lateral Página, com quatro painéis: Formato da página, Estilos, Cabeçalho e Rodapé. Para mais detalhes, acesse esta página. tdf#83830 (Susobhan Ghosh – GSoC 2016, Katarina Behrens – CIB e Yousuf Philips)
Página é a nova propriedade da barra lateral.
  • A característica Autoformatação de tabela foi ampliada e não somente manipula a formatação como trabalha completamente com estilo.
  • A tabela utiliza o estilo, sendo este preservado ao se editar a tabela, seja com inclusão ou exclusão de linhas, colunas ou dados.
  • A importação e exportação de estilo de tabela está no padrão ODF.
  • Estilo de tabela pode ser criado e associado a tabelas através da barra lateral Estilos e Formatação.
  • Criadas rotinas UNO API para manipular estilo de tabela.
  • O Desfazer e Refazer suportam estilo de tabela.
Para mais detalhes, acesse esta página. (Jakub Trzebiatowski – GSoC 2016, Miklós Vajna – Collabora, Jan Holešovský – Collabora e Yousuf Philips)
Novo item Estilos de tabela na seção Estilos e Formatação.
  • O espaçamento de conteúdo para páginas, parágrafos, caracteres, cabeçalhos, quadros e imagens agora afetará o próprio leiaute se as bordas não estiverem definidas, permitindo a compatibilidade com outros arquivos no formato ODF produzidos por outros programas. A capacidade de definir o preenchimento sem borda virá no ramo 5.4. tdf#41542 (Justin Luth – SIL)

Calc

  • O nome na interface EFETIVO foi modificado para EFEITO de forma a ser compatível com outros programas. tdf#100641 (Eike Rathke – Red Hat)
  • Versões anteriores ao LibreOffice 5.1 salvam NÚM.SEMANA erradamente como NÚM.SEMANAISO no ODF. A versão 5.3 resolve definitivamente o problema, que veio com uma solução provisória introduzida pela versão 5.1 (ver ReleaseNotes/5.1#Compatibility with ODF 1.2). (Eike Rathke – Red Hat)
    • Ao importar NÚM.SEMANAISO, se a chamada utilizar um parâmetro este é mantido como um uso correto de NÚM.SEMANAISO.
    • Se a chamada usar dois parâmetros, é verificado se o segundo argumento modo é um valor numérico literal diferente de 1. Neste caso ele é mapeado para NÚM.SEMANAISO com um argumento, como a antiga função NÚM.SEMANA era implementada.
    • Se o segundo argumento é um valor numérico 1 ou uma expressão, a chamada é mapeada para a função de compatibilidade NÚM.SEMANA_OOO introduzida no LibreOffice 5.1.
    • NÚM.SEMANA_OOO está agora armazenada como ORG.LIBREOFFICE.NÚM.SEMANA_OOO para compatibilidade com as versões 5.1 e 5.2.
  • Formato de números fracionários (Laurent BP)
    • Qualquer dos formatadores #, ? ou 0 pode ser usado para inteiro, numerador ou denominador de texto.
Para o exemplo # ?/#00 será exibido 3,5 como 3 1/02 e PI como 3 16/113. tdf#100755 tdf#31449
  • qualquer texto pode ser usado como delimitador entre a parte inteira e a parte fracionária:
#" mais fração "?/? exibirá PI valendo como 3 mais fração 1/7. tdf#100834
  • representação de fração mais acurada com um novo algoritmo. tdf#99996 (Wolfgang Jäger)
  • novos formatos implícitos com denominador forçado. tdf#100592
  • Se o denominador tiver menos dígitos do que posições, ficará alinhado à esquerda tdf#102507: com o formato # ?/??? o valor 3,5 será mostrado da seguinte forma
3 1/2 (com dois espaços depois da fração), no lugar de
3 1/ 2 (situação anterior)
  • opções de formato estão disponíveis pelo menu Formatar ▸ Células ▸ Números e pela barra lateral.
Novas opções para formato de fração.
  • Mesclar células não vazias Formatar ▸ Mesclar células ▸ Mesclar células traz novas opções: tdf#30456 (Laurent BP)
    • Antes do ramo 5.3, se um conteúdo foi detectado, ele possivelmente moveria o conteúdo como texto para a primeira célula. Caso contrário, o conteúdo escondido não seria removido.
Caixa de diálogo anterior quando mesclava células vazias.
  • A partir do ramo 5.3, uma nova opção está disponível: célula vazia escondida de modo que as fórmulas a que se referem a estas células serão atualizadas.
Nova opção para mesclar células vazias.
  • Funções ( Inserir ▸ Função ) podem ser pesquisadas a partir de uma lista disponível. tdf#67974
Digite na área marcada para pesquisar na lista de funções disponíveis.
  • Em novas instalações a configuração implícita para novos documentos será Habilitar curingas em fórmulas no lugar de expressões regulares. tdf#88581 (Eike Rathke – Red Hat)
    • Isto é para uma melhor interoperabilidade com outros aplicativos de planilha e uma melhor experiência para os usuários que não estão familiarizados com expressões regulares. Curingas possuem o uso mais generalizado e o grande conjunto de metacaracteres de expressões regulares muitas vezes acarreta perguntas muito complicadas para eventuais usuários.
    • Para mais detalhes, acesse esta página.
  • Os estilos implícitos para célula foram aperfeiçoados. tdf#90937 (Jaskaran Singh – equipe UX)
  • Os estilos implícitos para célula são carregados de um arquivo no perfil do usuário. (Jaskaran Singh – GSoC 2016)
    • A sintaxe é baseada em ODF e carregada através do orcus.
    • Ficou mais fácil definir estilos personalizados para célula.
  • Foi adicionada a funcionalidade Mediana às tabelas dinâmicas, útil para campos de dados, linhas ou colunas, sendo somente suportada em arquivo ODS. tdf#61700 (Tamás Zolnai)
Usando a mediana em uma tabela dinâmica.

Novas funções

  • Adicionadas novas funções para interoperabilidade com o MSExcel. (Winfried Donkers)

Assistente de estatísticas (alternativa ao pacote complementar de análise do MSExcel)

  • Acesse o assistente em Dados ▸ Estatísticas

Impress & Draw

  • A imagem inserida pela opção Inserir ▸ Mídia ▸ Álbum de Foto tem a possibilidade de ser vinculada. tdf#65356 (Samuel Mehrbrodt – CIB)
  • Novos modelos foram disponibilizados: Vivid e Pencil.
Modelo Vivid.
Modelo Pencil.
  • A guia propriedades da barra lateral permite configurar o conteúdo do tema Mestre. tdf#89466 (Susobhan Ghosh – GSoC 2016, Katarina Behrens – CIB e Yousuf Philips)
  • Novos conectores de seta, incluindo a notação pé de galinha, muito utilizada em diagramas MER. tdf#93782, tdf#92152 (Yan Pashkovsky e Dipankar Niranjan)
Novos conectores.

Gráfico

  • Na equação de regressão (Linha de tendência), as descrições da variável dependente (o valor implícito é f(x)) e da variável independente (o valor implícito é x) podem ser substituídas por valores personalizados pelo usuário. tdf#100547 (Laurent BP)
Personalizando a descrição de X e Y na equação de linhas de tendência.

Base

  • Firebird foi atualizado para a versão 3. Ele não é capaz de ler dados gerados no Firebird 2.5, portanto, arquivos ODB incorporados ao Firebird criados na versão LibreOffice até 5.2 não podem ser abertos com o LibreOffice 5.3. Em uma versão futura do Firebird haverá um módulo de compatibilidade com versões anteriores, alguma versão futura do LibreOffice (quando a versão futura do Firebird tiver essa característica) também será capaz de abrir esses arquivos mais antigos.
  • Firebird incorporado chaveado para o formato de Firebird arquivo, que for independente de versão e ordenação, de modo que este problema não acontecerá novamente.
  • Arquivos ODB criados por ramos do LibreOffice anteriores ao 5.3 podem ser convertidos manualmente para o formato LibreOffice 5.3 usando o Firebird 2.5 para converter os dados do antigo formato de arquivo (FDB), e substituindo-os dentro do ODB pelo formato de arquivo mais novo (FBK). Para fazer isso, deve-se instalar Firebird 2.5, e usar sua ferramenta gbak para converter o arquivo database.fdb para database.fbk dentro do arquivo ODB. Não esquecer de remover o arquivo FDB.

Math

Interno

Núcleo & Geral

  • O encerramento do LibreOffice não encerrará as conexões ativas do UNO. tdf#102274 (Samuel Mehrbrodt – CIB)
  • Todo mundo pode agora melhorar a acessibilidade (a11y) pois quase todas as relações de acessibilidade agora são facilmente editáveis com o Glade. tdf#87026 (Muhammet Kara – Pardus Linux)

Assinatura de documentos

  • Suporte na importação e exportação da assinatura de PDF. (Miklós Vajna – Collabora)
Uma assinatura de PDF verificada.

Modo de segurança

  • O modo de segurança foi adicionado à inicialização temporária com um perfil inicial de usuário e ajuda a restaurar uma configuração problemática. (Armin Le Grand – CIB e Samuel Mehrbrodt – CIB)
  • Pode ser acessado da seguinte forma:
  • através do menu Ajuda ▸ Reinicializar em modo de segurança…
  • passando por parâmetro a opção de linha de comando --safe-mode
  • apenas no Windows, através da entrada do menu LibreOffice (Modo de Segurança)
Caixa de diálogo do Modo de Segurança.

Execução no navegador

Esta versão apresenta o primeiro lançamento do código-fonte do LibreOffice Online — que fornece edição colaborativa básica de documentos em um navegador, reutilizando o núcleo do LibreOffice. A fidelidade de renderização deve ser excelente, e a interoperabilidade corresponde à do LibreOffice. No entanto, isso é fundamentalmente um serviço de servidor, melhor instalado e configurado por alguém com bastante experiência na criação de certificados SSL, e sendo mais útil quando integrado com outra solução.

Contêiner público do LibreOffice Online

  • Você pode pegar o contêiner mais recente do LibreOffice Online no Docker Hub ou baixá-lo:
$ docker pull libreoffice/online
$ docker run -t -d -p 127.0.0.1:9980:9980 -e "domain=<your-dot-escaped-domain>" --cap-add MKNOD libreoffice/online
  • Esta imagem não funciona no Ubuntu 14.04 LTS, porque a opção de compilação do kernel CONFIG_AUFS_XATTR=y não foi ativada, fazendo com que o setcap não armazene os arquivos AUFs do contêiner.

Esquema URI do MSOffice

  • LibreOffice agora suporta os esquemas URI do MSOffice registrados: 1 e 2 (Mike Kaganski – Collabora)
    • ms-word:
    • ms-powerpoint:
    • ms-excel:
    • ms-visio:
    • ms-access:
  • Também um esquema específico do LibreOffice foi criado:
    • vnd.libreoffice.command:
  • Atualmente, o parâmetro para a pasta implícita é ignorado.
  • O gerenciador de esquemas é registrado pelo instalador no Windows. Os esquemas específicos da MS são registrados somente se os arquivos Open MS estiverem marcados nas caixas de seleção do LibreOffice.
  • Isso permite, por exemplo, uma melhor integração com o SharePoint.

Leiaute de texto

  • Novo mecanismo de leiaute de texto, que usa a biblioteca HarfBuzz em todas as plataformas. tdf#89870 (Akash Jain – GSoC 2016 e Khaled Hosny)
    • Leiaute OpenType é suportado em todas as plataformas com suas características habilitadas de forma implícita.
    • Leiaute Graphite é suportado no Mac, bem como no Linux e Windows.
    • As características do leiaute OpenType podem ser controladas usando antiga sintaxe suportada pelas fontes Graphite.
    • O alinhamento justificado Kashida foi melhorado para a escrita Arábica.
    • A escrita vertical para CJK foi melhorada pois utiliza o HarfBuzz no lugar de soluções caseiras.
    • Todo o leiaute de texto passa agora pelo HarfBuzz, não havendo mais nenhuma distinção entre as tarefas simples e complexas.
    • Muitas falhas de leiaute de texto ocorridas apenas no Windows e no Mac foram corrigidas.
A fonte Graphite Awami Nastaliq usada no Mac OS X.
Fonte STIX Two Text mostrando minúsculas, números proporcionais e frações ativadas.
  • Cálculo do espaçamento entre linhas entre plataformas foi melhorado de forma consistente. tdf#55469 (Khaled Hosny)
  • Implementado o sentido da esquerda para direita na direção vertical do texto, necessário para o Mongoliano tradicional e o Manchu. tdf#33278 (Khaled Hosny)
Nova opção para direção de texto vertical da esquerda para a direita.
Leiaute de texto vertical da esquerda para a direita no Mongoliano tradicional.

Conteúdo da ajuda

  • O texto da ajuda agora será renderizado na fonte da plataforma padrão, se possível (isto é, Segoe UI em Windows, Ubuntu em Ubuntu e Cantarell em Fedora), para maior consistência. (Adolfo Jayme Barrientos)
Im-jabber.svg

No caso de você encontrar algum texto de ajuda em falta ou desatualizado, ele pode ser relatado no bugzilla; favor acrescentar a questão ao chamado tdf#80430. Este chamado também mostra problemas conhecidos na ausência ou erro do tópico Ajuda que precisam ser resolvidos.

Filtro

  • Melhorias no filtro OpenXML, com modificações na importação e na exportação de arquivos XLS e XLSX.
    • Correção na perda da largura para colunas agrupadas (expandidas ou escondidas) após exportação. tdf#51524 (Bartosz Kosiorek)
    • Orientação paisagem devidamente salva após exportação, garantindo a compatibilidade com o MSExcel. tdf#48767 (Bartosz Kosiorek)
    • Linhas ocultas e vazias tornam-se ocultas na exportação. tdf#98106 (Bartosz Kosiorek)
    • Contorno de colunas e linhas é salvo após exportação. tdf#100347 (Bartosz Kosiorek)
    • Durante a exportação, as chaves XML_outlineLevelRow e XML_outlineLevelCol são salvas, garantindo a compatibilidade com o MSOffice 365. tdf#101135 (Bartosz Kosiorek)
    • A largura da coluna é salva, garantindo a compatibilidade com o MSExcel para Mac OS X. tdf#100946 (Bartosz Kosiorek e Markus Mohrhard)
    • Correção na largura da coluna. tdf#101363 (Bartosz Kosiorek)
    • Correção para a Formatação definida pelo usuário na importação de arquivo XLSX. tdf#70565 (Bartosz Kosiorek)
    • Durante a exportação, as células vazias coloridas foram corrigidas nos arquivos XLS e XLSX. tdf#46738 (Bartosz Kosiorek)
    • Correção na exportação do formato XLSX, que gerava incompatibilidade com o MSExcel 2007. tdf#101059 (Bartosz Kosiorek)
    • Correção na lentidão na importação de tabelas dinâmicas em arquivos XLSX. tdf#102694 (Tamás Zolnai)
    • Para o formato de números:
      • foram preservados os caracteres escapados. tdf#81939 (Laurent BP)
      • o formato fracionário 0 é aceito além de # e ?. tdf#100755 (Laurent BP)
      • o identificador de localidade (LCID) estendido pode ser importado. O LCID é usado para exportar calendário e números locais. tdf#36038 (Laurent BP)
  • O arquivo PDF pode ser inserido como imagem em um documento. Para mais detalhes, acesse esta página. (Miklós Vajna – Collabora)
  • A importação de arquivos DOC e XLS foi aperfeiçoada.
    • A criptografia RC4 CryptoAPI de documento binário do padrão do MSOffice é suportada. (Caolán McNamara – Red Hat)

Extensão

Desempenho

Características experimentais

  • Novos recursos não finalizados podem ser acessados para testes. Esta configuração pode ser habilitada em Ferramentas ▸ Opções… ▸ LibreOffice ▸ Avançado ▸ Ativar funcionalidades experimentais.
  • Foram adicionados quatro novos modos para a barra de ferramentas de forma a facilitar os usuários entre a alternância de visibilidade das barras. Estes modos podem ser acessado através da opção Visualizar ▸ Leiaute da barra de ferramentas. tdf#101249 (Szymon Kłos – GSoC 2016 e Yousuf Philips)
  • Implementação de um ambiente integrado de desenvolvimento estendido para a barra de ferramentas. Para mais detalhes, acesse esta página. (Szymon Kłos – GSoC 2016, Jan Holešovský – Collabora, Samuel Mehrbrodt – CIB e Yousuf Philips)
  • Implementação de três leiautes para a barra de ferramentas. (Szymon Kłos – GSoC 2016, Yousuf Philips e Heiko Tietze)
  • A barra de ferramenta Padrão (Modo unificado) foi adicionada para fornecer uma única alternativa ao arranjo da dupla barra de ferramentas implícitas e contém as operações de função, de inserção, e formatação mais usadas. Ela pode ser ativada pelo menu Exibir ▸ Modos da barra de ferramentas ▸ Único. tdf#92218 (Yousuf Philips)
Nova barra de ferramentas no Impress 5.3.
  • Adicionada a seção Gerenciar alterações na barra lateral.
Nova seção na barra lateral para gerenciar alterações.
  • Um controle na barra de ferramentas para incluir Emojis foi adicionado. tdf#100100 (Akshay Deep – GSoC 2016 e Samuel Mehrbrodt – CIB)
Caixa de diálogo Emoji.

Infraestrutura

Programação & Suporte

  • Algumas propriedades foram adicionadas aos serviços relacionados à tabela dinâmica. (Tamás Zolnai)
    • DataPilotField: Function2, Subtotals2
    • DataPilotSourceLevel: Subtotals2
    • DataPilotSourceDimension: Function2
    • Além disso, algumas constantes foram adicionadas como GeneralFunction2
  • Alterada a interface do Selecionador de Arquivos (com.sun.star.ui.dialogs.TemplateDescription). (Samuel Mehrbrodt – CIB)
  • Para extensões, agora é possível invocar XNotifyingDispatch para verificar os resultados, por exemplo, quando uno.Save foi executado corretamente ou não. tdf#99815 (Juergen Funk – CIB)
  • O empacotador do formato Windows (MSI) agora suporta um Gerenciador de Reinicialização, característica disponível no Windows Vista e posterior. Isso permite fechar e reinicializar automaticamente os processos com arquivos bloqueados que o instalador precisa substituir. Anteriormente, apenas a lista desses processos era mostrada e o usuário precisava fechá-los e reabri-los manualmente. Sem este procedimento, a reinicialização do sistema após a instalação era obrigatória. (Mike Kaganski – Collabora)

Características removidas ou descontinuadas

  • O esquema de configuração /org.openoffice.Office/Substitution foi removido, e o serviço com.sun.star.util.PathSubstitution não suporta mais substituições definidas através da configuração /org.openoffice.Office/Substitution/SharePoints. tdf#102630
  • A interface com.sun.star.mozilla.XRemoteServiceManagerProvider, relacionada ao complemento NPAPI, foi removida pois estava presente no LibreOffice 5.2.
  • A interface com.sun.star.xml.crypto.sax.XSecurityController foi removida. (Miklós Vajna – Collabora)
  • Os simplificados modelos para gradiente VerdeAbstrato, VermelhoAbstrato e AmareloAbstrato foram removidos. (Yousuf Philips)

Reformulação do código

  • As várias plataformas baseadas no GCC não definem a macro HAVE_GCC_VISIBILITY_FEATURE C/C++ em settings/settings.mk, mas ainda definem o sinalizador de compilação -fvisibility=hidden.

Access2Base

Access2Base, a biblioteca básica para usuários do Base, está agora disponível em sua versão 1.6.0 (Jean-Pierre Ledure).

As principais melhorias estão relacionadas ao gerenciamento de campos binários (long) com os métodos GetChunk e AppendChunk.

Também o escopo do método CopyObject foi estendido para a duplicação de tabelas completas entre bancos de dados distintos. Como um recurso experimental, as tabelas podem pertencer a bancos de dados construídos acima de diferentes sistemas de banco de dados, por exemplo, de HSQLDB para MySql ou vive-versa.

Além disso, uma tradução espanhola da interface do usuário foi fornecida por Iñigo Zuluaga.

A documentação completa está disponível neste sítio.

Interface do usuário

  • O tema de ícones Humano foi removido. (Samuel Mehrbrodt – CIB)
  • Removido o suporte para fontes do tipo bitmap (FON), no Windows. tdf#103514 (Khaled Hosny)

Janela

  • Writer tem uma nova caixa de diálogo que permite o deslocamento para uma determinada página através da opção Editar ▸ Vá para a página ou da tecla Ctrl+G. tdf#83054 (Akshay Deep e Yousuf Philips)
Caixa de diálogo Vá para a página.
  • Barra de ferramentas de desenho (setas), antes disponibilizadas no Impress e no Draw, foram adicionadas ao Writer e ao Calc. tdf#101390 (Gülşah Köse)
Setas agora estão disponíveis no Writer.
Barra de ferramentas também disponível no Calc.
  • Agora é possível definir a propriedade Capitular para caracteres via barra de ferramentas. Para mais detalhes, acesse esta página. (Miklós Vajna – Collabora)
  • O item Arquivo ▸ Assistente ▸ Apresentação foi removido. Foi adicionada uma caixa de diálogo para a seleção do modelo que está disponível na inicialização do Impress. (Akshay Deep – GSoC 2016 e Samuel Mehrbrodt – CIB)
Seletor de modelos.
  • Adicionada a funcionalidade Importar Bitmap para o Painel de conteúdo Área encontrado no item Propriedades. tdf#90078 (Susobhan Ghosh – GSoC 2016, Katarina Behrens – CIB e Yousuf Philips)
Botão Importar Bitmap no Painel de conteúdo Área.
  • Adicionada uma previsão de estilos nas propriedades Estilo e Formatação. tdf#93845 (Susobhan Ghosh – GSoC 2016, Katarina Behrens – CIB e Yousuf Philips)
Previsão de estilos.
  • Modificado o Painel Tocar Mídia quando a mídia estiver selecionada. Para mais detalhes, acesse esta página. tdf#87794 (Susobhan Ghosh – GSoC 2016, Katarina Behrens – CIB e Yousuf Philips)
Alteração do Painel Tocar Mídia.
  • Incluído o painel implícito de formas na propriedade, ainda experimental, Formas para o Draw. Para mais detalhes, acesse esta página. tdf#87643 (Susobhan Ghosh – GSoC 2016, Katarina Behrens – CIB e Yousuf Philips)
Novo painel implícito no item Formas.
  • As abas Cores, Gradientes, Explosão e Bitmap da caixa de diálogo Área foram remodeladas e adicionada uma aba Padrões. tdf#94551 (Rishabh Kumar – GSoC 2016, Katarina Behrens – CIB, Heiko Tietze e Yousuf Philips)
Aba Cores nos ramos 5.1 (esquerda) e 5.3 (direita).
Aba Gradientes nos ramos 5.1 (esquerda) e 5.3 (direita).
Aba Explosão nos ramos 5.1 (esquerda) e 5.3 (direita).
Aba Bitmaps nos ramos 5.1 (esquerda) e 5.3 (direita).
Nova aba Padrões.
  • Na caixa de diálogo Área foi criado um conjunto implícito de padrões. tdf#94547 (Yousuf Philips)
  • A IDE do BASIC usará as cores definidas para Cor da fonte e Fundo do documento em Ferramentas ▸ Opções… ▸ LibreOffice ▸ Cores da aplicação. tdf#103209 (Takeshi Abe)
  • Caixa de diálogo para recuperação de documentos foi simplificada. tdf#99341 (Muhammet Kara – Pardus Linux)
Simplificada a caixa de diálogo na recuperação de documento.
  • A caixa de diálogo Gerenciador de Extensão foi renovada; botões foram substituído, comportamentos propensos a erros foram implementados de forma personalizada com rotinas padronizadas e várias falhas do processo foram corrigidas. O procedimento agora oferece melhor experiência e acessibilidade ao usuário. tdf#103146 tdf#102004 (Muhammet Kara – Pardus Linux e Yousuf Philips)
A caixa de diálogo Gerenciador de Extensão renovada.
  • A caixa de diálogo Personalização está mais acessível e fácil de usar, uma vez que agora mostra as opções que estavam ocultas com os antigos botões de divisão. tdf#82840 tdf#103160 (Muhammet Kara – Pardus Linux e Yousuf Philips)
As abas Menus and Ferramentas da caixa de diálogo Personalização.
  • A caixa de diálogo Temas do Firefox foi corrigida, e a caixa de pesquisa e os botões de categoria voltaram a funcionar. Agora você pode colorir seu ambiente do LibreOffice de acordo com seu gosto, através da opção de menu Ferramentas ▸ Opções… ▸ LibreOffice ▸ Personalização ▸ Temas do Firefox. tdf#87597 (Muhammet Kara – Pardus Linux)
A caixa de diálogo Temas do Firefox.

Menu

  • Nova entrada Ajuda ▸ Guias do usuário…. Ligação direta para os guias de usuário e a documentação colaborativa. (Olivier Hallot, Christian Lohmaier, Heiko Tietze, Yousuf Philips, Samuel Mehrbrodt – CIB e Katarina Behrens – CIB)
  • Nova entrada Ajuda ▸ Buscar ajuda colaborativa…. Ligação direta para os fóruns de suporte da comunidade e da base de conhecimento. (Olivier Hallot, Christian Lohmaier, Heiko Tietze e Yousuf Philips)
Ligação para fóruns de suporte da comunidade e guias do usuário.
|
  • Os atalhos do teclado agora aparecem nos menus de contexto e a visibilidade pode ser configurada em Ferramentas ▸ Opções… ▸ LibreOffice ▸ Exibir ▸ Menu). tdf#74377 (Maxim Monastirsky)
Atalhos no menu de contexto, à esquerda estão desabilitados e à direita estão habilitados.
  • A opção Abrir Modelo está disponível no menu Abrir. (Samuel Mehrbrodt – CIB)

Configuração

Localização

  • Fonte Emoji I foi embutida para suporte ao Emoji. (Akshay Deep)
  • O acento no nome das funções do Calc no idioma espanhol (DÍA(), MÁX() etc.) foi removido na versão 5.2.3, de forma a compatibilizar sua utilização com outras implementações. tdf#101981 (Adolfo Jayme Barrientos e Johnny_M)
  • Os arquivos de correção do idioma Português da Europa foram sincronizados com os arquivos do Português do Brasil. tdf#97439 (Tiago Santos)
    • Adicionadas 1.936 entradas de substituição automática, 11 exceções de palavras em maiúsculas e 1.726 abreviaturas.
  • A lista de exceções para o idioma Croata foi atualizada.
    • Adicionadas 66 abreviaturas.

Novos corretores ortográficos

  • Idiomas adicionados com suporte à verificação ortográfica. (Eike Rathke – Red Hat)

Novas localidades

Incorporação de outros idiomas

Nosso objetivo é prover o suporte ao maior número de idiomas possível. Gostaríamos de agradecer às seguintes pessoas pela tradução voluntária para o LibreOffice e ajuda na preservação de suas línguas nativas:

Im-jabber.svg

Se você fala uma língua ameaçada e quer nos ajudar a alcançar nossos objetivos de fornecer ferramentas livres para cada pessoa no planeta, favor juntar-se a nós.