The Gallery in LibreOffice

From The Document Foundation Wiki
Jump to navigation Jump to search
Other languages:
Deutsch • ‎English

Foreword

The video shows the application ″The Gallery LibreOffice" and links to this page here, which provides further information and details.

Basis of this description and the video:

The LibreOffice Online-Help enter the word "Gallery" in the search bar.

FAQ-Draw in the LibreOffice-Wiki.

Link to the Video

Link to the Video (in German [DE]):

The Gallery LibreOffice 7.0

What is the Gallery?

Gallery in Sidebar

The Gallery is a library containing objects (pictures or sounds), which you can easily insert into your documents.

It is available in all modules of LibreOffice.

To open the Gallery, select View ▸ Sidebar menu ( Ctrl + F5 ) and click on the sidebar tab "Gallery" 202009 LOEN Seitenleiste Symbol Gallery.png.

- Differences in Draw and Writer -

Themes

On the top of the Gallery, all available themes bundled with LibreOffice are listed.

Included themes of LibreOffice are:

Objects of the Gallery are gathered by themes, Arrows, BPMN, Bullets, Diagrams, Flow chart, Icons, Network, Shapes and Sounds.

Click on a theme to see its content in the main window of the Gallery.

You can also create your own themes, as much as you need.

- To the top -

How do I use the Gallery?

Theme Context Menu

Display

The Gallery can be displayed either as Icon View or Detailed View by clicking on buttons 741DE Seitenleiste GalleryButtonViews.png.

Add a new theme to the Gallery

Create a new theme with your own files

  • Click New… button at the top of the Gallery.
  • Enter a name for your topic in the "General" tab, e.g. "My Theme".
  • Click on the "Files" tab and there on the Find Files… button.

Dialog "Select folder" is open, (Figure right: Select folder for files).

Select folder for files
  • Browse to directory containing the drawing files you want to add to your theme and then click Select folder.
  • Click on the arrow of "File type" and select a file type to restrict the selection to this file type and accept this with Yes.
  • Select files you want to add:
    • click Add All to install all files contained in the list,
    • or Ctrl + Click on specific files you want to add, and then validate with Add button.
  • Click OK when you have done.
Selected file list for the new Theme
 Note: 
 You can add or remove drawings at any time later, even from different directories (see below).

Context menu of own Themes

With a right click on a own theme the Context menu with the selection appears:

  • Update in relation to the previously defined source directory, the theme will be updated with the contents from the directory.
  • Delete the theme is deleted.
  • Rename the theme can be renamed.
  • Properties… opens the "Properties of <Theme>" dialog.

Context menu of own Objects

Draw Gallery Own Theme

With a right click on a own object the Context menu with the selection appears:

  • Insert
  • Preview
  • Title
  • Delete
  • Copy
  • Paste

Add an object to the Gallery

You can only add images to your own themes.

By file selection

  • Right click on theme's name in themes list ("My Theme" for instance) and select Properties in context menu.
  • Click on "Files" tab.
  • Click Add.
  • Select a directory and the desired file and click Open.

The object is added to the theme.

By drag & drop

Select an object in your document.

Click + hold the left mouse button on your object for approx. 2 seconds without moving it.

The mouse pointer is modified and you can now drag the object to the Gallery and drop it to the right of the bottom last object of the topic.

See also "How can I reuse a drawing with the help of the Gallery?"

Remove objects in the Gallery

You can remove images only for your own themes.

To remove an object in a theme:

  • Select the theme where you want to remove an object.
  • Right click on the object and select  ▸ Delete.
  • Confirm you really want to delete this object by clicking Yes.
 Note: 
 The file which object refers to is not deleted, only the object in the Gallery is removed.

Remove a theme in the Gallery

You can remove only for your own themes.

To remove a theme from the Gallery:

  • Click on "Gallery" tab in the sidebar.
  • Right click on the theme you want to remove.
  • Select  ▸ Delete in context menu.
  • Confirm you really want to delete this theme by clicking Yes.

- To the top -

How can I reuse a drawing with the help of the Gallery?

The Gallery is a very convenient way to make available to all modules (Draw, Impress, Writer, and so on) some customized objects and more particularly drawings made with Draw, such as logos for instance.

Once your drawings are created, you will add them to a theme of the Gallery and they will instantaneous be available in all modules, to be inserted with a simple drag & drop.

Finalize the drawing

Once the drawing is done:

  • Select all objects belonging to the drawing, with a click and drag surrounding all these objects, or type Ctrl + A if there is no other objects on this page.
  • Group these objects with a right click on one and select Group or select menu Shape ▸ Group ▸ Group or type ⇧ Shift + Ctrl + G.

This first step is not compulsory but it will ease handling of the drawing as a whole when it will be inserted.

Add the drawing to the Gallery

You can add images or drawings only for your own themes.

Example of user theme

Show the Gallery

  • Click on the "Gallery" Tab in the sidebar or choose the menu View ▸ Gallery.

Choose a theme where to add the drawing

The Gallery is organized with different themes, which list is displayed at the top of the Gallery:

You can:

  • either click on theme's name where you want to insert your drawing, My theme for instance
  • or create a new empty theme by clicking on New Theme… button; type its name and validate with OK.
 Note: 
 If you don't have administration rights, you must choose a theme you created and not a bundled one.

Drag the drawing in the Gallery

This is obviously the most sensitive step of the whole procedure.

To let LibreOffice knows that you do not want to move your drawing on your page, but to copy it in the Gallery, a simple drag and drop does not work.

You must proceed as follow:

  • Click once on the drawing to select it.
  • Click + hold the left mouse button on your drawing for approx. 2 seconds without moving it.
  • The mouse pointer is modified, and you can now drag the drawing to the Gallery and drop it to the right of the bottom last object of the topic.
 Note: 
 * If the drawing is simply moved on the page and cannot be dropped in the Gallery,
   it probably means that you have not wait long enough before moving the mouse.
 * If you cannot drop the drawing in the Gallery, it probably means that you are not allowed to modify this theme.
   Then choose one of your own themes (right click should show several entries if it is a user theme).

Insert a drawing from the Gallery

In the document where you want to insert the drawing:

  • Click on "Gallery" tab in the sidebar or select menu View ▸ Gallery.
  • Select the theme where the drawing has been added.
  • Click + hold + drag the drawing and place it on your document.
 Note 
 You may have to reformat shapes pasted from the Gallery,
 if they were previously saved with a style, but the new document does not have that style (Draw).
 If you had used direct formatting, the shape retains the formatting.

- To the top -

Differences in Draw and Writer

Gallery - in Writer

To insert a Gallery object into the document, right-click on it first.

For the included objects, you can choose between Insert, Preview and Copy in the context menu.

Select the "Process" object in the "Flowchart" theme.

Context menu - in Writer

If you select Insert, the object will be pasted as an image (texts of objects cannot be edited).

If you choose Preview, the object will be displayed larger in the sidebar.

If you choose Copy and then Ctrl + V, the object will be pasted editable.

You can then double-click on object texts, for example, and then edit the text.

Drag & Drop - in Writer

Drag & Drop = drag and drop

An easy way to bring objects from the Gallery onto the sheet is with Drag & Drop.

With the left mouse button click-hold-drag an object from the Gallery onto the sheet and then release the mouse button.

The texts of the objects are editable.

Gallery - in Draw

To insert a Gallery object into the document, right-click it first.

For the supplied objects, you can choose between Insert, Preview and Copy in the context menu.

Select the "Process" object in the "Flowchart" theme.

Context menu - in Draw

If you choose Insert, the object will be inserted as a metafile as a shape (texts of objects cannot be edited immediately).

Right click on the object and choose "Break" from the context menu.

The metafile is broken up into three shapes.

You can now double-click on the text from the object, for example, and then edit the text.

If you choose Preview, the object will be displayed larger in the sidebar.

If you choose Copy and then Ctrl + V, the object will be pasted editable.

You can then double-click on object texts, for example, and then edit the text.

Drag & Drop - in Draw

Drag & Drop = drag and drop

An easy way to bring objects from the Gallery onto the sheet is with Drag & Drop.

With the left mouse button click-hold-drag an object from the Gallery onto the sheet and then release the mouse button.

The texts of the objects are editable.

- To the top -

Where are the files in the Gallery?

Locating the Gallery

Dialog to display the path of the Gallery
Dialog for editing the Gallery path
New directory of the Gallery

The location of your Gallery is specified in Tools ▸ Options ▸ LibreOffice ▸ Paths.

This path obviously depends on your operating system:

  • On Windows:
    • Before Vista: C:\DocumentsandSettings\UserName\Application\Data\libreoffice\4\user\gallery
    • Vista: C:\Users\UserName\AppData\Roaming\libreoffice\4\user\gallery
    • 7 or 8: C:\Users\UserName\AppData\Roaming\Libreoffice\4\user\gallery
    • 10: C:\Users\UserName\AppData\Roaming\Libreoffice\4\user\gallery
  • On GNU/Linux:
    • /home/UserName/.config/libreoffice/4/user/gallery
  • On MacOS:
    • /Users/UserName/Library/Application Support/libreoffice/4/user/gallery
 Note: 
 These directories are hidden; you must set the option from your operating system
 to be able to see these hidden directories.

Storage of the objects of the Gallery

All graphical objects and sounds which are present in the Gallery can be located anywhere on your hard disk, or a network system, or an external disk, or an USB key.

If you add objects to the Gallery, corresponding files won't be moved nor copied: only the location of each new object will be added as a reference.

 Note: 
 In case of a network workgroup, you can have access to a shared theme on a server,
 but you cannot modify its contents if you have no administration rights.

Define a new location for the Gallery

You may require a new location for the future themes of your Gallery?

  • Select menu Tools ▸ Options ▸ LibreOffice ▸ Paths, then "Gallery" in "Type" column.
  • Click Edit.
  • In dialog "Edit Paths: Gallery", click Add.
  • Go to a desired directory on your system and click - OK or select folder - depending on your operating system.
  • Check the radio button corresponding to the new path.
  • Validate with OK.
  • Close the dialog Tools ▸ Options ▸ LibreOffice ▸ Paths by clicking again OK.
 Note: 
 A restart of all LibreOffice components is required to take into account these new parameters. (bevore: all modules closed)
 Warning: 
 Choose a directory where you have Read/Write access.

- To the top -

Further Informations

To go further

If you want to share your Gallery's theme, an easy way is to create an extension which will facilitate its installation.

Please check this how-to How to create an extension - Application to the creation of a theme for the Gallery for more information.

Add themes through extensions

On LibreOffice extensions website, you can search for extensions providing themes for the Gallery.

Simply install the chosen extension (you can check this entry for details) and restart LibreOffice.

List of keyboard shortcuts in the Gallery

List of keyboard shortcuts in the Gallery

Where are the image galleries from previous LibreOffice versions?

The previous image galleries were moved to extensions.libreoffice.org.

Documentation / Manuals

Here you will find the Documentation / Manuals:

Documentation / Manuals

Any questions?

For questions on this topic go to:

Ask.LibreOffice

Get Involved

Join us today and help us to make it even better!

Get Involved

LibreOffice is Free Software and is made available free of charge.

Your donation, which is purely optional, supports our worldwide community.

If you like the software, please consider a Donation.

- To the top -