Videos/6.3 New Features Script

From The Document Foundation Wiki
Jump to: navigation, search
Other languages:
čeština • ‎dansk • ‎English • ‎español • ‎français • ‎עברית • ‎italiano • ‎日本語 • ‎Nederlands • ‎português do Brasil • ‎slovenščina • ‎中文(中国大陆)‎

This page contains the scripts for the LibreOffice 6.3 New Features video, which will be made public on release day.

English Original (en-GB)

  1. Thanks to our worldwide community and certified developers, LibreOffice 6.3 is smarter, faster and easier to use.
  2. A new version of the NotebookBar user interface, introduced in LibreOffice 6.2, is now available. The Tabbed Compact mode, in the View menu, provides more space for your documents, spreadsheets and presentations.
  3. You can now redact your documents to remove or hide sensitive information. This can help your company or organisation to comply with regulations. Open a document, then go to Tools > Redact in the menu. Now you can use the tools to hide specific information before exporting and sharing the document.
  4. Documents can be exported as .dotx and .xltx templates, for better compatibility with Microsoft Office, while support for PDF/A-2 has been implemented. In addition, enhancements were made to Tagged PDF export in order to improve accessibility of produced documents.
  5. On Windows, a proper console mode was added, with better output and error codes. This helps when you're using LibreOffice to perform batch operations, such as printing or converting many documents.
  6. Finally, help pages for Python macro programming were added, while an optional "Tip of the day" box appears when you start LibreOffice, helping you to get more from the software.
  7. Page backgrounds now cover the entire page, rather than just up to the margins.
  8. When you're copying data from a Calc spreadsheet into Writer, and have applied a filter to the data, only the visible cells from the filter will be copied.
  9. The AutoCorrect feature has been updated to recognise words that start with a small letter. When you type them at the start of a sentence, Writer won't try to correct them.
  10. Performance has been improved, especially for documents with many bookmarks, tables and embedded fonts.
  11. Spreadsheet tabs have been changed to improve visibility.
  12. A new drop-down widget in the formula bar replaces the old Sum tool, giving you quick access to more options.
  13. For better performance, a new checkbox in the Data > Statistics > Moving Average dialog lets you trim the input range to the actual data content before computing the moving-average.
  14. The Rework Data > Statistics > Sampling dialog now has extra options: "With replacement" and "Keep order".
  15. A new FOURIER() function was added, which computes the discrete Fourier transform of an input array. Features of this function are available in the Data > Statistics > Fourier analysis dialog.
  16. In the presentation tool, you can now drag-and-drop multiple animations to reorder them.
  17. And in Draw, the graphics tool, the tabs to switch between images are now much more visible.
  18. In LibreOffice Online, the cloud-based version of the suite, selection and rotating of images in Writer is now easier and faster.
  19. LibreOffice Online already supports a wide range of document formats - and in this release, you can view Microsoft Visio files.
  20. In Calc, you now have the full power of the conditional formatting features.
  21. Watermarks are important for secure collaboration - and this release introduces a dialog to add and change them.
  22. A big thanks to our worldwide community and commercial partners for their work on this release!
  23. Deploying LibreOffice in a business? Get a long-term supported version from our partners here: tdf.io/business