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Saving slide shows
Slide shows created in Impress are, by default, saved in the Open Document Presentation (ODP)
format. However, Impress can open and save a slide show in other widely used and recognized 
presentation formats.

New slide show
1) Create a new slide show. For more information, see Chapter 1, Introducing Impress and 

Chapter 9, Slide Shows and Photo Albums.
2) Save the new slide show using one of the following methods to open a file browser 

window (Figure 1).
– Click on Save on the Standard toolbar.
– Go to File > Save on the Menu bar.
– Use the keyboard shortcut Ctrl+S.

3) Navigate to the folder where the slide show is to be saved.
4) Enter a filename in the Name text box.
5) Select a file format from the drop-down list at the bottom of the file browser window. By 

default, the file format is ODF Presentation (.odp).
6) Click on Save to save the slide show and close the file browser window.

Figure 1: File browser for saving new slide show

4| Chapter 10, Saving Slide Shows, Printing, Emailing, and Exporting



Figure 2: Confirm File Format dialog

Note
If the slide show is not being saved in the ODP presentation format, a Confirm File 
Format dialog (Figure 2) opens asking confirmation of the file format selected.

ODP format
1) Open a slide show in Impress and make all the required changes. Impress opens slide 

shows that have been saved in a presentation format that Impress recognizes.
2) Save the slide show in ODP format using one of the following methods:

– Click on Save on the Standard toolbar.
– Go to File > Save on the Menu bar.
– Use the keyboard shortcut Ctrl+S.

Other presentation formats
1) Open a slide show in Impress and make all the required changes. Impress opens slide 

shows that have been saved in a presentation format that Impress recognizes.
2) Save the slide show in a presentation format that Impress recognizes, use one of the 

following methods:
– Click the small triangle ▼ to the right of Save on the Standard toolbar and select 

Save As from the drop-down menu.
– Go to File > Save As on the Menu bar.
– Use the keyboard shortcut Ctrl+Shift+S.

3) In the file browser window that opens, navigate to the folder where the slide show is to be
saved.

4) Enter a filename in the Name text box.
5) Select a presentation file format from the drop-down list at the bottom of the file browser 

window. By default, the file format is ODF Presentation (.odp).
6) Click on Save to save the slide show and close the file browser window.
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Figure 3: Print dialog - General page

Printing
Impress provides many options for printing slides or a complete presentation. For example 
multiple slides on one page, single slide per page, slides with notes, as an outline, with date and 
time, with page name, and so on. For more information on printing LibreOffice documents, see 
the Getting Started Guide.

Any printing options selected in Impress using the General page (Figure 3) and LibreOffice 
Impress page (Figure 4) in the Print dialog only apply to the printing of the current document. To 
specify default printing settings for Impress, go to Tools > Options > LibreOffice > Print and 
Tools > Options > LibreOffice Impress > Print.

Note
Any print options selected with the Print dialog when printing from Impress overrides 
the default printer settings that have been set using Tools > Options > LibreOffice 
> Print and Tools > Options > LibreOffice Impress > Print.

6| Chapter 10, Saving Slide Shows, Printing, Emailing, and Exporting



Figure 4: Print dialog - LibreOffice Impress page

Printing slides
The following printing procedure is an example only. Actual printing procedure does depend on 
computer operating system and how the computer has been setup.

1) Open the Print dialog using one of the following methods:
– Go to File > Print on the Menu bar.
– Use the keyboard shortcut Ctrl+P.
– Click on Print on the Standard toolbar.

2) Click on General to open the page for general print options and, if necessary, select a 
printer from the Printer drop-down list of printers available.

3) If necessary, in Printer click on Properties to display a properties dialog for the selected 
printer and select the options required. Click OK to save the Properties selection and 
close the dialog. Actual printer properties available depend on the printer selected and 
computer operating system being used. An example of a printer properties dialog is 
shown in Figure 5.

4) In Range and Copies, select which slides to print, odd or even pages, the paper sides to 
print on (simplex or duplex), number of copies, collate multiple copies, and the print order.

5) In Page Layout, select the paper size, orientation, pages per sheet, and, if necessary, 
brochure printing.
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Figure 5: Example dialog for printer properties

6) Click on LibreOffice Impress to open the page for LibreOffice Impress print options.
7) In Document, select the document type, slides per page and the printing order from the 

drop-down lists 
8) In Contents, select whether to print slide name, date and time, or hidden pages.
9) In Color, select the type of color to print.

10) In Size, select the printed size, to fit on a printable page, to distribute on multiple sheets 
of paper, or tile sheet of paper with repeated slides.

11) Click OK to print the slides and close the Print dialog.

Brochure printing
Slides can be printed so that, when printed, the slides are in the correct order to form a booklet or
brochure.
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The printer procedures below are only examples. Actual printing procedure depends on the 
computer operating system and type of printer being used. It is best to experiment to find the 
correct method for brochure printing.

Single sided printing
The following procedure is an example of how to create a brochure or booklet using a printer that
is only capable of printing single sided.

1) Open the Print dialog using one of the following methods:
– Go to File > Print on the Menu bar.
– Use the keyboard shortcut Ctrl+P.
– Click on Print on the Standard toolbar.

2) Click on General to open the page for general print options and, if necessary, select a 
printer from the Printer drop-down list of printers available.

3) Click on Properties to open the printer properties dialog for the printer being used and 
check the printer is set to the same page orientation as specified for the page setup for 
the slides. Usually page orientation does not matter, but it is important for brochures.

4) Click OK to close the properties dialog and return to the Print dialog.
5) In Range and Copies, select All Slides. A minimum of four slides is required to create a 

brochure.
6) In Range and Copies, select the Number of copies required to match the required 

number of brochures.
7) In Layout, select Brochure.
8) In Range and Copies, select Even slides option in Include.
9) Click OK to print the even slides in the presentation.

10) Take the printed slides out of the printer and put them back into the printer in the correct 
orientation to print on the other side of the paper. It maybe necessary to experiment and 
find out what the correct arrangement is for the printer being used.

11) In Range and Copies, select Odd slides option in Include.
12) In Range and Copies, select the same Number of copies used for printing the even 

slides.
13) Click OK to print the odd slides in the presentation and close the Print dialog.
14) Assemble the brochures and bind them, if necessary.

Double sided or duplex printing
Printing a brochure on a printer that is capable of double sided or duplex printing makes the task 
of creating brochures a lot simpler.

1) Open the Print dialog using one of the following methods:
– Go to File > Print on the Menu bar.
– Use the keyboard shortcut Ctrl+P.
– Click on Print on the Standard toolbar.

2) Click on General to open the page for general print options and, if necessary, select a 
printer from the Printer drop-down list of printers available.

3) Click on Properties to open the printer properties dialog for the printer being used and 
check the printer is set to the same page orientation as specified for the page setup for 
the slides. Usually page orientation does not matter, but it is important for brochures.

4) Click OK to close the properties dialog and return to the Print dialog.
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5) In Range and Copies, select All Slides. A minimum of four slides is required to create a 
brochure.

6) In Range and Copies, select Print on both sides (duplex long edge) or Print on both 
sides (duplex short edge) option. Normally, long edge binding is used for portrait printing 
and short edge binding is used for landscape printing.

7) In Range and Copies, select the Number of copies required to match the required 
number of brochures.

8) In Range and Copies, select the Collate option. This option is only active when printing 
multiple copies of the same document.

9) In Layout, select Brochure.
10) Click OK to close to the Print dialog and print the required number of pages for the 

brochures.
11) If necessary, bind the brochures to match either long edge or short edge binding.

Emailing
LibreOffice provides two methods of emailing an Impress slide show as an attachment in ODP 
format or PDF format directly from the Impress module. For more information on emailing 
LibreOffice documents, see the Getting Started Guide.

ODP format
1) Make sure the presentation file is open in Impress.
2) Go to File > Send > Email Document on the Menu bar and the default email program 

opens with the presentation file already attached to the email.
3) Enter the name of the recipient, subject line, and message then send the email.
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Figure 6: PDF Options dialog

PDF format
1) Make sure the presentation file is open in Impress.
2) Go to Format > Send > Email as PDF on the Menu bar and the PDF Options dialog 

(Figure 6) opens.
3) If necessary, select the required PDF options to create a PDF version of the slide show. 

Normally, the default options already selected are sufficient to create a PDF file that the 
email recipient will be able to open.

4) Click on Send to close the PDF Options dialog and the default email program opens with 
the PDF file already attached to the email.

5) Enter the name of the recipient, subject line, and message then send the email.

Exporting
Impress can export slide shows in the PDF format as well as other file formats. The PDF format 
is a standard file format for file viewing and is ideal for sending the file to someone who can only 
view a slide show file using a PDF viewer.

For more information on exporting LibreOffice documents, see the Getting Started Guide.

Quick PDF export
1) Make sure the slide show file is open in Impress.
2) Use one of the following methods to export the file as a PDF file and open a file browser 

window.

Chapter 10, Saving Slide Shows, Printing, Emailing, and Exporting | 11



– Click on Export Directly as PDF on the Standard toolbar.
– Go to File > Export As > Export Directly as PDF on the Menu bar.

3) In the file browser window, navigate to the folder where the PDF file is to be saved.
4) In the Name text box, enter a filename for the PDF file or use the filename that is 

displayed in this text box. The file format is fixed as PDF and cannot be changed.
5) Click on Save to save the slide show file as a PDF file and close the file browser window.

PDF export
For more control over the content and quality of a PDF file, it is recommended to use the PDF 
Options dialog. For more information on the options available when exporting a slide show as a 
PDF file, see the Getting Started Guide.

1) Make sure the slide show file is open in Impress.
2) Go to File > Export as PDF on the Menu bar to open the PDF Options dialog.
3) Using the various pages in the PDF Options dialog, select the options required for the 

PDF file. For more information, see the Getting Started Guide.
4) Click on Export to open a file browser window.
5) In the file browser window, navigate to the folder where the PDF file is to be saved.
6) In the Name text box, enter a filename for the PDF file or use the filename that is 

displayed in this text box. The file format is fixed as PDF and cannot be changed.
7) Click on Export to save and export the file to the selected location.

Figure 7: HTML Export dialog – Assign Design page
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Web pages (HTML) export
Slide shows can be exported as a series of web pages (HTML format) that can be viewed in any 
browser.

Note
Exporting slide shows as web pages (HTML) does not retain any animation effects or
slide transitions.

1) Make sure the slide show file is open in Impress.
2) Create a folder to contain the HTML pages that are generated and select the folder as the

destination for the HTML pages.
3) Go to File > Export on the menu bar to open a file browser window and navigate to 

where the HTML version of the slide show is going to be saved.
4) Enter a name for the HTML file in the Name text box at the top of the file browser window.
5) At the bottom of the file browser window, select HTML Document (Impress) (.html; .htm) 

format from the drop-down list.
6) Click on Save and the HTML Export dialog opens at the Assign Design page (Figure 7).
7) Select a design for all of the HTML pages, either from an existing design or by creating a 

new design. If there is no previously saved design available, the Existing Design option is 
not available.

Figure 8: HTML Export dialog - Publication Type page

8) Click on Next to select the publication type to use for creating the web pages, as shown 
in Figure 8. The available options change depending on publication type selected.
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– Standard HTML format – one page for each slide with navigation links to move from 
slide to slide.

– Standard HTML with frames – one page with a navigation bar on the left-hand side 
and uses slide title as navigation links. Click on links to display pages in right-hand 
side.

– Single-document HTML – creates one HTML document from the slide show.
– Automatic – one page for each slide with each page set with the refresh meta tag so 

a browser automatically cycles from one page to the next.
– WebCast – generates an ASP or Perl application to display the slides. Currently, 

LibreOffice has no direct support for PHP.
9) Click on Next> to select the format for saving images (PNG, GIF or JPG) and the monitor

resolution used, as shown in Figure 9. When selecting a monitor resolution, consider 
what type of display users may have. For example, if a high resolution is selected, then a 
user with a medium-resolution display has to scroll sideways to see the entire slide.

10) Click on Next> and enter the details for a title page (Figure 10), such as name of the 
author, e-mail address and home page, along with any additional information that maybe 
required. This page does not display if the Create title page option was not selected when
selecting Publication Type.

11) Click on Next> to select the style of navigation buttons to use when moving from one 
page to another (Figure 11). If buttons are not being used, make sure Text only is 
selected.

Figure 9: HTML Export dialog - Save Images As page
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Figure 10: HTML Export dialog - Title page

Figure 11: HTML Export dialog - Select Button Style page
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Figure 12: HTML Export dialog - Select Color Scheme page

12) Click on Next> to select the color scheme for the web pages (Figure 12). Available 
schemes include the existing scheme for the presentation, one based upon browser 
colors, and a user-defined scheme. A new scheme can be saved so that it appears on the
first page of the HTML export wizard.

13) Click on Create to generate the HTML files. If this is a new design, a dialog opens to save
the design for future use.

Export in other formats
1) Make sure the slide show file is open in Impress.
2) Go to File > Export on the menu bar to open a file browser window and navigate to 

where the HTML version of the slide show is going to be saved.
3) Enter a name for the exported file in the Name text box at the top of the file browser 

window.
4) At the bottom of the file browser window, select the required format from the drop-down 

list.
5) Click on Save to export the file to the selected location. Depending on the format 

selected, an options dialog may open allowing further options to be selected for the file 
format selected.

6) Click on OK to save the exported file and close the options dialog. For more information 
on exporting files, see the Getting Started Guide.
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