Chapter 3
Adding and Formatting Text
Copyright

This document is Copyright © 2010–2012 by its contributors as listed below. You may distribute it and/or modify it under the terms of either the GNU General Public License (http://www.gnu.org/licenses/gpl.html), version 3 or later, or the Creative Commons Attribution License (http://creativecommons.org/licenses/by/3.0/), version 3.0 or later.

All trademarks within this guide belong to their legitimate owners.

Contributors

Michele Zarri  
T. Elliot Turner  
Jean Hollis Weber

Low Song Chuan  
Peter Schofield

Feedback

Please direct any comments or suggestions about this document to: documentation@global.libreoffice.org

Acknowledgments

This chapter is based on Chapter 3 of the OpenOffice.org 3.3 Impress Guide. The contributors to that chapter are:

Nicole Cairns  
Martin J Fox  
Peter Hillier-Brook

Jean Hollis Weber  
Michele Zarri

Publication date and software version

Published 19 May 2012. Based on LibreOffice 3.5.

Note for Mac users

Some keystrokes and menu items are different on a Mac from those used in Windows and Linux. The table below gives some common substitutions for the instructions in this chapter. For a more detailed list, see the application Help.

<table>
<thead>
<tr>
<th>Windows or Linux</th>
<th>Mac equivalent</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tools &gt; Options menu selection</td>
<td>LibreOffice &gt; Preferences</td>
<td>Access setup options</td>
</tr>
<tr>
<td>Right-click</td>
<td>Control+click</td>
<td>Opens context menu</td>
</tr>
<tr>
<td>Ctrl Control</td>
<td>% (Command)</td>
<td>Used with other keys</td>
</tr>
<tr>
<td>F5</td>
<td>Shift+F5</td>
<td>Opens the Navigator</td>
</tr>
<tr>
<td>F11</td>
<td>%T</td>
<td>Opens Styles and Formatting window</td>
</tr>
</tbody>
</table>

Documentation for LibreOffice is available at http://www.libreoffice.org/get-help/documentation
Creating a table........................................................................................................................................ 22
Modifying a table.................................................................................................................................. 24
  Task pane options.......................................................................................................................... 24
  Table toolbar.................................................................................................................................. 25
  Position and size.............................................................................................................................. 27
Deleting a table....................................................................................................................................... 27

Using fields........................................................................................................................................ 28
  Inserting a field............................................................................................................................... 28
  Customizing fields......................................................................................................................... 28

Using hyperlinks................................................................................................................................ 29
  Editing text hyperlinks....................................................................................................................... 31
  Working with hyperlink buttons......................................................................................................... 31
Introduction

Any text used in slides is contained in text boxes. This chapter describes how to create, modify, use, and delete text boxes. It also discusses the various types of text that can be inserted and explains how to format the text. Finally, it provides information on how to insert special forms of text such as numbered or bulleted lists, tables, fields, and hyperlinks.

Working with text boxes

There are two ways of adding text boxes to slides:

- Choose a predefined layout from the Layouts section of the Tasks pane, containing text elements as described in Chapter 1. These text boxes are called AutoLayout text boxes.
- Create a text box using the text tool in the Drawing toolbar or the Text toolbar.

Using text boxes created from the Layout section

Make sure Normal view is selected:

1) Click in the text box that reads Click to add text.
2) Type or paste your text in the text box.

These text boxes are known as AutoLayout text boxes. See also “Creating bulleted and numbered lists” on page 18.

Using text boxes created from the text tool

Make sure Normal View is selected:

1) Click on the Text icon on the Drawing toolbar (Figure 1). The default position of the drawing toolbar is towards the bottom of the screen. If the Drawing toolbar with the text icon is not visible, choose View > Toolbars > Drawing.

   Figure 1: Drawing Toolbar

2) Click and drag to draw a text box on the slide. This sets the width. Do not worry about the height because the text box will expand as you type.
3) To reposition the text box to a different part of the slide, see “Moving a text box” on page 7; to change the width, see “Resizing a text box” on page 7.
4) Release the mouse button when finished. The cursor appears in the text box, which is now in edit mode (a hashed border; see Figure 2).
5) Type or paste your text in the text box.
6) Click outside the text box to deselect it.

Note

In addition to the normal text boxes where text is horizontally aligned, it is possible to insert text boxes where the text is aligned vertically. Click on the icon in the drawing toolbar (Figure 1) to create a vertical text box. This choice is available only when Asian languages are enabled in Tools > Options > Language Settings > Languages.
Using text boxes created from the Text toolbar

Make sure Normal view is selected:

1) Click on the Text icon on the Text toolbar (Figure 3). If the Text toolbar with the text icon is not visible, choose View > Toolbars > Text.
2) Click and drag to draw a text box on the slide. This sets the width. Do not worry about the height because the text box will expand as you type.
3) To reposition the text box to a different part of the slide, see “Moving a text box” on page 7; to change the width, see “Resizing a text box” on page 7.
4) Release the mouse button when finished. The cursor appears in the text box, which is now in edit mode (a hashed border; see Figure 2).
5) Type or paste your text into the text box.
6) Click outside the text box to deselect it.

**Note**

If you want to use vertical text, click on the icon in the Text toolbar (Figure 3) to create a vertical text box. This choice is available only when Asian languages are enabled in Tools > Options > Language Settings > Languages.
Moving a text box

In Normal view, notice how the pointer changes from an arrow to an I-beam as you move it over the text in a text box.

1) Click when the pointer becomes an I-beam. The text box is now in edit mode. In this mode a hashed border is visible around the text box edges.

2) Move the I-beam (or pointer) over the hashed border. Notice how the I-beam changes shape, becoming the usual "move" symbol for your operating system (for example, a hand).

3) When the “move” symbol appears, click once and colored selection handles appear.

4) Click anywhere in the text box or on the hashed border (except for the colored handles) and drag to move the text box. A semi-transparent copy of the text box shows where your text box will be placed (Figure 4).

5) Release the mouse button when the text box is in the desired position. To return to edit mode, click outside the text box area and then repeat step 1) of this procedure.

Resizing a text box

In Normal view, enter edit mode by clicking on the text box, then move the mouse to the edge of the text box (Figure 5). When the cursor shape changes, click the left mouse button again. The text box now displays colored resizing handles. Move the pointer over any handle. Notice how the pointer changes shape, indicating in which direction the text box will be resized.

The corner handles change the two dimensions of the text area simultaneously, while the four handles at the center of each side modify only one dimension. When the two-headed arrow is displayed, click and drag to resize the text box.

Tip

To maintain the proportions of a text box while resizing, press and hold the Shift key, then click and drag. Make sure to release the mouse button before releasing the Shift key.

For more accurate control over the shape, size and position of the text box, instead of using the mouse, use the Position and Size dialog. Select the text box, then press F4 or select Format > Position and Size from the menu bar. The use of this dialog is explained in Chapter 2 Using Slide Masters, Styles, and Templates.
Deleting a text box

1) Click the text once to display the hashed border.
2) Move the cursor to the edge of the text box and click the left mouse button. The hashed border now shows colored selection handles.
3) Press Delete.

Tip

Sometimes it is faster to delete a text box by dragging a selection rectangle around the text box and then hitting the Delete key. Take care to avoid selecting and accidentally deleting other text boxes or shapes.

Inserting text

Pasting text

Text may be inserted into the text box by copying it from another document and pasting it into Impress. However, the pasted text will probably not match the formatting of the surrounding text or that of the other slides in the presentation. This may be what you want on some occasions; however in most cases you want to make sure that the presentation style is consistent. There are several ways to ensure consistency; these methods are explained below.

Pasting unformatted text

It is normally good practice to paste text without formatting and apply the formatting later. To paste without formatting, either press Control+Shift+V and then select Unformatted text from the dialog that appears, or click on the small black triangle next to the paste symbol in the standard toolbar and select Unformatted text. The unformatted text will be formatted with the outline style at the cursor position in an AutoLayout text box or with the default graphic style in a normal text box.

Formatting pasted text

If pasting the text into an AutoLayout area, then to give the pasted text the same look and feel of the rest of the presentation apply the appropriate outline style to the text. To do so:
Figure 6: Text formatting toolbar

1) Paste the text in the desired position. Do not worry if it does not look right: it will in a minute.
2) Select the text you have just pasted (see “Selecting text” on page 11 for details on how to do that).
3) Select Format > Default formatting from the menu bar. This operation will assign one of the nine Presentation styles to the text (depending on where the insertion is made).
4) Use the four arrows on the Text Formatting toolbar (highlighted in Figure 6) to move the text to the appropriate position and give it the appropriate outline level. The left arrow promotes the list entry by one level (for example from Outline 3 to Outline 2), the right arrow demotes the list entry by one level, the up and down arrows move the list entry.
5) Apply manual formatting as required to sections of the text (to change font attributes, tabs, and so on).

If you are pasting text into a text box, you can still use styles to quickly format the text. Note that only one graphic style can be applied to the copied text. To do this:
1) Paste the text in the desired position.
2) Select the text you have just pasted (see “Selecting text” on page 11 for details).
3) Select the desired graphic style.
4) Apply manual formatting as required to sections of the text.

Tip
Presentation styles are very different from Writer styles and are applied in quite a different way. Refer to “Using styles to format text” on page 11 for details.

Inserting special characters

To insert special characters, such as copyright, math, geometric, or monetary symbols, or characters from another language:
1) Click in the place in the text where you want to insert the character.
2) Choose Insert > Special Character. The Special Characters dialog appears (Figure 7). Alternatively if the text formatting toolbar has been customized and the special character icon is visible, you can click this to bring up the Special Characters dialog.
3) Choose the font and character subset from the Font and Subset drop-down menus.
4) Click the character you want to insert. You may have to scroll to find the one you want.
5) Click OK.

Characters you select will be inserted in the order they were selected, even if you accidentally click on the wrong character. Clicking on another character will only add it to the ones being inserted. Click Delete and all the characters selected will be deleted, then click on the correct characters. Alternatively, you can also insert all the selected characters and delete any unwanted ones from the document because special characters behave like any other character.
Inserting non-breaking spaces and hyphens

Where it is not desirable for words that are separated by a space or a hyphen to span over two lines, or where an optional hyphen is desired, you can insert a special formatting mark. To access the Formatting marks options, select Insert > Formatting marks. Impress supports three formatting marks:

- **Non-breaking space**: a non-breaking space between two words prevents these two words being separated over two lines. The keyboard shortcut is Control+Shift+Spacebar to insert a non-breaking space.
- **Non-breaking hyphen**: a non-breaking hyphen keeps the two words separated by the hyphen on the same line.
- **Optional hyphen**: an optional hyphen is only activated (thus breaking the word) when the word is too long to fit on one line.

Introduction to formatting text

The appropriate use of text formatting can give a presentation a consistent look and a dynamic feel and it can even enhance the understanding of an audience by preventing any distracting elements in your message.

When you enter text, either in an AutoLayout text box or in a normal text box, it is formatted with a set of predefined attributes known as a style. The style used depends on the outline level of the point where the text was entered for AutoLayout text boxes. For example, if you are entering a level 2 item, Impress will format it either according to the Outline 2 presentation style or the Default Graphic style for text boxes.

Tip

Sometimes, as seen also in the “Pasting text” section on page 8, it is very useful to re-apply the baseline style to a selection of text eliminating any manual formatting applied to it, especially if you made a mistake and you do not know how to undo it. To the baseline style, select the manually formatted text and then select Format > Default formatting from the menu bar.

Formatting text may require some intervention in three areas:

- Character attributes (for example font color)
- Paragraph attributes (for example alignment)
- List attributes (for example type of bullet)
In some cases it is quicker and more efficient to apply manual formatting; but in situations where you need to perform the same modifications to many different parts of the presentation, the use of styles is recommended. Both these techniques are described here.

### Note

Unlike LibreOffice Writer, where it is recommended to use styles whenever possible, in Impress manual formatting has to be used more often. This is because presentation styles are fixed in Impress; therefore it is not possible, for example, to have two different level 1s or different types of bullet points for the same outline level. Also, the lack of support for character styles forces the use of manual formatting to modify sections of the text.

### Selecting text

Text must be selected before it can be formatted.

- To format *all* the text in a text box, click once on the text, then click once on the border of the text box. The colored resizing handles are displayed. Now any formatting changes will apply to all the text in the text box.
- To format only *part* of the text, click once on the text, then select the text to be formatted by clicking and dragging over it (highlighting). You can also use keyboard combinations to select text: move the cursor where you want to begin your selection, press Shift and then use the arrow keys to extend your selection. Formatting changes will apply only to the selected text.

### Tip

To select text word by word, instead of by character, press the Control key and Shift key together. To speed up the selection even further, you can combine the Shift key with the Home key or the End key to extend the selection up to the start or end of the line in which the cursor is positioned, respectively.

### Using styles to format text

Impress has two categories of styles: presentation styles and graphics styles. Presentation styles are used on text inserted into an AutoLayout area, slide master backgrounds, and background objects. However, for text inserted in a text box or a graphic object, you need to apply a graphic style.

In this chapter we focus mostly on Presentation styles. For information on graphic styles, see Chapter 6, Formatting Graphic Objects.

### Modifying a presentation style

To modify a presentation style, follow these steps:

1) Open the Styles and Formatting window (Figure 8) by pressing F11 or selecting Format > Styles and Formatting from the menu bar.

2) Make sure the Presentation Styles icon is selected.

3) Right-click on the style to be modified and select Modify from the pop-up menu. The top portion of the dialog for modifying a presentation style is shown in Figure 9.
This modifying dialog consists of fifteen tabbed pages, which can be divided into two groups: pages that determine formatting of the text, and pages that determine the properties of slide master background and background objects.

There is no difference between attributes that determine a style and attributes used manually on portions of text. In fact, the pages that open when manually applying formatting are the same that you use when configuring styles in the styles and formatting dialog. Therefore, once you master the formatting of text, you will know how to create and modify a style. In particular:

- For the Font and Font Effects style pages, refer to “Formatting characters” on page 13.
- For the Indents and Spacing, Alignment, and Tabs style pages, refer to “Formatting paragraphs” on page 15.
- For the Bullet and numbering type, Graphics, Customize style pages, refer to “Creating bulleted and numbered lists” on page 18.

Some of the pages in the modifying dialog relate to formatting presentation styles and some pages relate to formatting the background and background objects, which are described in detail in Chapter 6 Formatting Graphic Objects.

**Updating a style from a selection**

To update a style from a portion of text that you have just modified or would like to use:

1) Select an item in a text box that has the format you want to adopt as a style.

2) In the Styles and Formatting dialog (Figure 8), select the style you want to update and then click the Update Style icon.

**Applying a presentation style**

To apply a presentation style, move the paragraph to the appropriate outline level as described in “Changing the order or the outline level” on page 22. This is different from Writer, where you select the desired style from the Styles and Formatting window.
Formatting characters

To view the character formatting options, select Format > Character or click the Character icon on the Text Formatting toolbar (Figure 6) and the Character dialog opens (Figure 10). If Text Formatting toolbar is not visible, choose View > Toolbars > Text Formatting. Note that character styles do not exist in Impress.

Font page

Use the Font page to select the desired font type, its base attributes (Italic, Bold, etc.) as well as the size. A sample of the font is displayed in the lower part of the dialog. You can also specify the language of this style. This font page is also available when creating or modifying a presentation style or a graphics style.

Tip

When writing a presentation in multiple languages, you can use the language setting to create two styles that only differ in the language but are otherwise the same. This allows you to check the spelling of all of the contents without affecting appearance.

If support for Asian language and Complex Text Layout (CTL) font has been enabled (Tools > Options > Language Settings > Languages), the Font page changes to look like Figure 11. The page is divided into three parts for Western text font, Asian text font and CTL text font. Each part has the same functionality as the Character dialog shown in Figure 10, whilst allowing you to specify the Asian and CTL text fonts and their attributes.

Font Effects page

Use the Font Effects page (Figure 12) to apply special effects to the text, such as over lining and underlining, color, shadow and so on. As for the Font page, a sample of the text is displayed in the lower part of the dialog, providing a quick visual check of the effects applied. This page is also available when creating or modifying a presentation style or a graphics style.
Position page

The Position page (Figure 13) has advanced options to customize text. Use this page to set the text position relative to the baseline when you need to insert subscripts or superscripts. This page is not available when creating or modifying a presentation style or a graphics style.

To create a superscript or a subscript do the following:

1) Select Superscript or Subscript as applicable.
2) Specify the amount by which the text should be raised (superscripts) or lowered (subscripts).
3) Specify the dimensions of the character relative to the baseline character size (in percentage).
The amount by which the text is raised or lowered can be set to automatic by selecting **Automatic**.

Two more position attributes can be set on this page:

- The (width) scaling of the text, which specifies the percentage of the font width by which to compress or expand the individual characters of the selected text.
- The spacing between the characters of the font, which can be defined in number of points. Selecting **Pair kerning** causes LibreOffice to automatically adjust the spacing between certain pairs of characters to visually improve the appearance. For example, when writing a V followed by an A (VA) the spacing between the two letters is reduced (strong kerning) as can be easily seen when compared with, say, VS which is not a kerning pair.

**Formatting paragraphs**

To view the paragraph formatting options, select **Format > Paragraph** or click the **Paragraph** icon on the Text Formatting toolbar (Figure 6) and the Paragraph dialog opens (Figure 14). If this toolbar is not visible, choose **View > Toolbars > Text Formatting**. Normally the paragraph formatting dialog contains three pages: **Indents and Spacing**; Alignment and Tabs. However, if Asian language support has been enabled in **Tools > Options > Language Settings > Languages**, a page called **Asian Typography** is also displayed.

**Indents and Spacing page**

The **Indents and Spacing** page is shown when the Paragraph dialog opens and has four sections. This page is also available in Presentation Styles dialog and Graphics Styles dialog.

- **Indent**: modifies the indentation of the text (before and after) as well as the indentation of the first line.
- **Spacing**: defines the space before and after each paragraph formatted with the style.
- **Line spacing**: determines the spacing between two lines formatted with the style. Note that selecting **Proportional** spacing requires specifying the percentage of a line to be used as spacing; 100% corresponds to a single line, 200% to a double line, 50% to half a line. If **Leading** is selected, specify the amount of line spacing in your default unit of measurement.
• **Preview area**: provides a visual representation of the settings before you apply them.

**Tip**

Setting the line spacing to less than 100% is a good method to cram a lot of text into a text box, however care must be taken as too small a value will make the text hard to read.

**Tip**

You can change the default unit of measurement, for example from inches to centimeters, from **Tools > Options > LibreOffice Impress > General**.

**Figure 15: Alignment in Paragraph formatting dialog**

**Alignment page**

Click on the Alignment tab to display the **Alignment** page (Figure 15). Use this page to determine the paragraph alignment: Left, Right, Center, or Justified. A preview shows the effects of the changes. This page is also available in Presentation Styles dialog and Graphics Styles dialog.

**Note**

If you have **Complex Text Layout** enabled in **Tools > Options > Language Settings > Languages**, an extra selection — **Text Direction** — appears at the bottom of the dialog; you can choose Left-to-right or Right-to-left.
The same alignment options can be accessed using the alignment icons on the Text Formatting toolbar (Figure 6).

**Tabs page**

Click on the Tabs tab to display the Tabs page (Figure 16). Use this page to determine the tab stops. This page is also available in Presentation Styles dialog and Graphics Styles dialog. To delete an existing tab stop, select it in the list and click the **Delete** button. To delete all the tab stops, click the **Delete All** button.

![Figure 16: Tabs in Paragraph formatting dialog](image)

To create a new tab stop:

1) Set the size of the tab stop in the edit box on the left.
2) Select the type. If you set the type to *Decimal*, specify in the box below the character to be regarded as the decimal point.
3) Select a fill character which will be drawn from the tab insertion point up to the tab stop. You can choose any character to act as fill character.
4) Click the **New** button to apply the new tab stop.

**Asian Typography page**

Use the Asian Typography page (Figure 17) to set the following properties relative to line changes. This page is also available in Presentation Styles dialog and Graphics Styles dialog.

- Apply list of forbidden characters to the beginning and end of lines.
- Allow hanging punctuation.
- Apply spacing between Asian, Latin and Complex text.

![Figure 17: Asian Typography in Paragraph formatting dialog](image)
Creating bulleted and numbered lists

The procedure to create a bulleted or numbered list varies depending on the type of text box used, although the tools to manage the list and customize the appearance are the same.

In text boxes created automatically by Impress (called AutoLayout), the outline styles available are by default bulleted lists. For normal text boxes an additional step is required to create a bulleted list.

Creating lists in AutoLayout text boxes

Every text box included in the available layouts is already formatted as a bulleted list, therefore to create a bulleted list the only necessary steps are:

1) From the Layout pane, choose a slide design that contains a text box. Those are easily recognizable from the thumbnail.
2) Click in the text box that reads Click to add an outline.
3) Type the text, then press Enter to start a new bulleted line.

The default list type is a bulleted list. To customize the list appearance or to change from bulleted to numbered or numbered to bulleted, refer to “Changing the appearance of the list ” on page 19.

Tip

Press Shift+Enter to start a new line without creating a new bullet or number. The new line will have the same indentation as the previous line. Click the bullets icon on/off on the text formatting toolbar for a line without bullet. If the text formatting toolbar is not showing, enable it by selecting View > Toolbars > Text Formatting in the menu bar.

Creating lists in other text boxes

To create a list in a text box, follow these steps:

1) Place the cursor in the text box.
2) Click the Bullets On/Off button in the text formatting toolbar (Figure 6).
3) Type the text and press Enter to start a new bulleted line.

The way to change the appearance of a list is explained on page 19.

Creating a new outline level

1) If necessary, press Enter to begin a new line.
2) Press Tab or click the indentation arrows in the text formatting toolbar. Each time you press Tab or click the right arrow, the line indents to the next outline level. Pressing Enter creates a new line at the same level as the previous one. To return to the previous level, press Shift+Tab or click the left arrow.

In the AutoLayout text boxes, promoting or demoting an item in the list corresponds to applying a different outline style, so the second outline level corresponds to Outline 2 style, the third to Outline 3 style and so on. As a consequence, a change in the level also produces other changes (for example font size, bullet type, and so on).
Caution

Do not try to change the outline level by selecting the text and then clicking the desired outline style as you would in Writer. Due to the way that presentation styles work in Impress it is not possible to apply them in this way.

Changing the appearance of the list

You can fully customize the appearance of a list, changing the bullet type or numbering for the entire list or for single entry. All the changes can be made using the Bullets and Numbering dialog, which is accessed by selecting Format > Bullets and Numbering or by clicking on the Bullets and Numbering icon on the text formatting toolbar.

Selecting the entries

For the entire list:

1) Select the entire list or click on the gray border of the text box so that just the colored resizing handles are displayed.

2) Select Format > Bullets and Numbering or click on the Bullets and Numbering icon on the text formatting toolbar.

3) The Bullets and Numbering dialog (Figure 18) contains five tabs: Bullets, Numbering type, Graphics, Position, and Customize.
   • If a bulleted list is needed, select the desired bullet style from the six default styles available on the Bullets page.
   • If a graphics style is needed, select one from those available on the Graphics page.
   • If a numbered list is needed, select one of the six default numbering styles on the Numbering type page.

Later in this section is an explanation on how to add further bullets and numbering styles to the existing ones.

Creating bulleted and numbered lists
For a single line in the list, click anywhere in the line to place the cursor in it and follow steps 2 and 3 above.

If the list was created in an AutoLayout text box, then an alternative way to change the entire list is to modify the Outline styles. Changes made to the outline style will apply to all the slides using them, so be careful before using this command. The pages related to list management are described below.

**Position page**

Use the Position page (Figure 19) to adjust the indentation and spacing of the bullet point and its text. This page is particularly effective when used in combination with the Customize page.

To set up an outline level, first select it from the list on the left hand side of the page. Select level 1 – 10 to modify all levels simultaneously. Then set the Indent, which is the spacing between the bullet or number and the text. If you select the Relative option, the indent value will be measured relative to the previous level and not from the margin.

![Figure 19: Bullets and Numbering – Position page](image)

The numbering alignment is only useful when creating a numbered list; use it to specify the alignment of numbers. For example, you may want to align them to the right to line up one and two-digit numbers.

**Tip**

To fully appreciate how the Numbering alignment works, try to create a numbered list with more than ten elements and make sure that enough room has been made for a two (or more) digit number using the Width of numbering field.

The Position page is not available if you are modifying a presentation style or graphics style, however the same effects can be obtained by using the Indents and Spacing page of the Paragraph dialog (Figure 14 on page 16) for creating or modifying a slide.

**Customize page**

Use the Customize page (Figure 20) to alter the style of all the outline levels.
The options available on this page depend on the type of marker selected for the list. Select first the level you want to modify on the left hand side of the box. To modify all levels at once, select 1 – 10 as the level. With these levels being arranged in a hierarchical structure, changing, for example, the font attribute of one of the levels ripples through all the lower levels.

Depending on the bullet style selected (bullet, numbering; graphic), some of the following options may become available on the Customize page:

- **Before**: enter any text to appear before the number (for example, Step).
- **After**: enter any text to appear after the number (for example, a punctuation mark).
- **Color**: pick the color for the list marker (number or bullet character).
• **Relative size**: specify the size of the number relative to the size of the characters in the paragraph of the list.

• **Start at**: enter the first value of the list (for example, you might want the list to start at 4 instead of 1).

• **Character button**: click this button to select the special character for the bullet.

• **Graphics**: opens a gallery of available graphics or allows the selection of a file on the hard disk to be used as a marker.

• **Width** and **Height**: specify the dimensions of the graphic marker.

• **Keep ratio checkbox**: if selected, the ratio between the width and the height of the graphic marker is fixed.

The right hand side of the screen shows a preview of the modifications made. To revert to the default values, click the **Reset** button in the bottom right corner.

Using the Customize page, you can create complex structured layouts, for example a nested list with numbering followed by bullets (Figure 21).

**Changing the order or the outline level**

Click once in a line of text to place the cursor in it, then click on the Outline tab (to the right of the Normal tab) in the Workspace and use the arrow icons in the Text Formatting toolbar (Figure 6) to move the text to the appropriate position and give it the appropriate outline level.

The arrow icon pointing left promotes the list entry by one level (for example from Outline 3 to Outline 2), the arrow icon pointing right demotes the list entry by one level, the up and down arrow icons move the list entry either up or down. Any numbering used adjusts automatically.

| Tip | You can also use the *Tab* key and *Shift + Tab* keys to promote and demote the outline level of a line in a list. |

**Using tables**

Tables are a powerful mechanism to convey structured information quickly, so they represent an important tool when creating a presentation. You can create tables directly in Impress eliminating the need to embed a Calc spreadsheet or a Writer text table in your presentation. However, in some circumstances, it makes sense to embed a Calc spreadsheet, especially when you require greater functionality in the table. The tables provided by Impress do have a limited functionality. Many predefined table designs are available in the Table design section of the Tasks pane (Figure 22).

**Creating a table**

When working with tables, it is useful to know the number of rows and columns needed as well as the appearance. The parameters can be adjusted later, but this is more laborious than setting the correct table dimensions from the beginning.

To insert a table, proceed as follows:

1) Select the slide which will contain the table and, if necessary, modify the slide layout to create space for the table.

2) Select **Table Design** (Figure 22) in the task pane. If the task pane is not visible, select **View > Task pane**.
3) Select one of the predefined styles, which only differ in the color scheme. You will be able to change the table colors later on. However, it is recommended that you select a color scheme similar to the one you want. Selecting a style opens the Insert Table dialog (Figure 23) where you can specify the number of rows and columns.

The table is placed initially at the center of the slide, but you can move it by selecting it and then dragging it to the new position, or by using the method described in “Position and size” on page 27.

You can also create a table directly by selecting Insert > Table from the main menu or with the Insert Table icon in the Standard toolbar. This opens the Insert Table dialog where you can specify the number of columns and rows.

Click on the small black triangle next to the Insert Table icon to open a graphic tool for inserting a table (Figure 24). To use this tool, move the mouse to the right and down in the grid until you have the required number of columns and rows and then click the left mouse button to insert your table.
Using either **Insert > Table**, the **Insert Table** icon, **Insert Table** graphic tool inserts a table with the default style and settings already applied. This table can be modified to your requirements.

A newly inserted table is given a set of default attributes such as color scheme, banded rows, header row and so on. Currently these defaults are hard coded in LibreOffice and cannot be changed.

---

**Modifying a table**

Once the table is added to the slide, you can control its appearance, size, position and so on using a combination of the Task Pane options, the Table toolbar and the Table properties dialog.

**Task pane options**

The following options are available in the Show section of the task pane:

- **Header Row**: selected by default, it adds a first row with a different background from the rest of the table.
- **Total Row**: the opposite of Header row; if selected, it changes the background of the last row to make it stand out from the other rows.
- **Banded Rows**: selected by default, this option colors alternate rows with different backgrounds making it easier to ready data presented in rows.
- **First Column**: highlights the first column of the table by allocating a darker background to it.
- **Last Column**: does the same to the last column.
- **Banded Columns**: when selected, alternate columns are colored differently.
**Table toolbar**

When a table is selected, eight colored selection handles appear around the edges and the Table toolbar (Figure 25) is displayed. If necessary, you can open the toolbar using View > Toolbars > Table. The Table toolbar contains the majority of the tools you need to manipulate a table and these are described below.

![Table toolbar](image)

**Table**

Use to create a new table in the selected slide. Opens the Insert Table dialog (Figure 23) where you can select the desired number of rows and columns. Alternatively, click on the small black triangle next to the icon to open an Insert Table graphic tool (Figure 24). To use this tool, move the mouse to the right and down in the grid until you have the columns and rows you require and click the left mouse button.

**Line style**

Use to change the style of the line of the selected cells. Opens a new dialog where you can choose from a range of predefined styles.

**Line color (border)**

Open a color selection dialog where you can choose the color of the lines around the selected cells.

**Borders**

Use to select among some predefined border configurations. The borders are applied to the selected cells. If the desired border pattern is not available, you will need to use the Table properties dialog.

**Area style/filling**

In the drop-down menu, first choose how the selected cells should be filled: Invisible, Color, Gradient, Hatching, or Bitmap. Depending on the selection, the Available Fillings drop-down menu is populated with the available schemes. Refer to Chapter 6 Formatting Graphic Objects for details on how to manage area filling styles.

**Color area style/filling**

Color selection of an area style/filling from a drop down menu.
Merge cells
Merges the selected cells into one cell. Note that the contents of the merged cells are also merged.

Split cells
The opposite operation of merge cells. Make sure that the cursor is positioned on the cell you want to split, then click to open the Split Cells dialog (Figure 26). Select the number of cells required from the split as well as whether the cell should be split horizontally or vertically. When splitting horizontally, you can select the “into equal proportions” option to get all cells of equal size. The contents of the split cell are kept in the original cell (the one on the left or top).

Optimize
Evenly distributes the selected cells either horizontally or vertically. If you want to optimize the whole table, you can evenly distribute rows or columns by right-clicking on the table edge and selecting Row > Space Equally or Column > Space Equally from the pop-up menu.

Vertical text cell alignment
You can select the vertical alignment of text in a cell by selecting the required cells and choosing Top, Center or Bottom. The alignment commands can be applied to all the cells of the table by right-clicking on the edge of the table, choosing Cell from the pop-up menu and then choosing the required alignment.

Insert or delete rows and columns
Use the Table toolbar to insert or delete rows and columns of your table. Rows and columns are inserted/deleted below and to the right of the selected cell. You can insert rows and columns at the end of the table using the pop up menu that opens by right clicking on the edge of the table. The insert and delete commands are in the Row or Column menus.

Table design
The only purpose of this icon is to open the Table Design pane in the task pane.

Table properties
Click the Table Properties icon on the Table toolbar (Figure 25) to open the Format Cells dialog (Figure 27), which contains the following pages:

- Font: use to select the desired font type, its base attributes (Italic, Bold, etc.) as well as the size. A sample of the font is displayed in the lower part of the dialog. You can also specify the language. See Font page on page 13 for more information on the available options.
**Figure 27: Format Cells dialog**

- **Font Effects**: use to apply special effects to the text, such as over lining and underlining, color, shadow and so on. As for the **Font** page, a sample of the text is displayed in the lower part of the dialog, providing a quick visual check of the effects applied. See Font page on page 13 for more information on the available options.

- **Borders**: use to set advanced properties not available from the Table Toolbar, such as the spacing between the text and the border as well as setting the style of each individual border of the table separately. This page also provides the same options as the line style and line color buttons of the Table toolbar.

<table>
<thead>
<tr>
<th>Note</th>
<th>It is currently not possible to define diagonal borders for Impress tables.</th>
</tr>
</thead>
</table>

- **Background**: changes the background of the selected cells and provides the same functions as the Area style/filling and Color area style/filling on the Table Toolbar.

<table>
<thead>
<tr>
<th>Note</th>
<th>The Table Properties dialog can also be accessed from the pop-up menu that opens when right-clicking on the table.</th>
</tr>
</thead>
</table>

**Position and size**

Impress treats tables just like any other graphic object. You can change table position and size on the slide by using the mouse or, for more accurate control, with the Position and Size dialog (Figure 28). When the table is selected right-click on the edge of table and select **Position and Size** from the pop-up menu or use **Format > Position and Size** on the main menu bar. Only the Position and Size page is available for tables. For more information on this dialog see Chapter 6 **Formatting Graphic Objects**.

<table>
<thead>
<tr>
<th>Note</th>
<th>Unlike other graphic objects, tables cannot be rotated.</th>
</tr>
</thead>
</table>

**Deleting a table**

To delete a table use one of the following methods:

- Click in the slide and drag a box over the table to select it. Then press the delete key.
- Select all the rows in the table and use the Delete Row icon on the table toolbar (Figure 25).

*Using tables*
Using fields

Fields allow the automatic insertion of text into the slide. You can think of a field as a kind of formula which is calculated when the document is loaded or printed and the result is written in the document. Fields are commonly used when creating templates and slide masters, as explained in Chapter 2 Using Slide Masters, Styles, and Templates.

Inserting a field

To insert a field into a slide, move the cursor where the field will be and then select from the menu bar Insert > Fields followed by one of these choices:

- **Date (fixed)**: inserts the date at the date of inserting the field.
- **Date (variable)**: inserts a field that is updated with the date at the time of opening the file.
- **Time (fixed)**: inserts a field displaying the time at the time of insertion.
- **Time (variable)**: inserts a field which is updated with the time at the time of opening the file.
- **Author**: inserts the author of the presentation. This information is derived from the value recorded in the general options. To modify this information go to Tools > Options > LibreOffice > User Data.
- **Page Number**: inserts the page number of the slide.
- **Page Count**: inserts the total number of slides.
- **File Name**: inserts a field that contains the name of the file.

Customizing fields

The appearance of all the fields, excluding the page number field, can be customized from the corresponding field editor. To access the field editor (Figure 29):

1) Move the cursor to the field and select it.
2) Select Edit > Fields from the menu bar or right click on the field data.
3) Select the desired format in the dialog that appears.
4) Click OK.

**Tip**
A similar list of format choices can be accessed by selecting the field and right-clicking.

Modifications to the page number fields can be done in two ways:

- Select the field and apply the formatting manually.
- Switch to the slide master editing mode (**View > Master > Slide Master**), then modify the Background object style as desired. Once back in Normal view, insert page numbers from **Insert > Page Number** in the main menu. See Chapter 2 Using Slide Masters, Styles, and Templates for more information about editing a slide master.

### Using hyperlinks

When inserting text (such as a website address or URL) that can be used as a hyperlink, Impress formats it automatically, creating the hyperlink and applying color and underlining. If you do not want Impress to do that, select **Edit > Undo Insert** from the menu bar or press **Control+Z** immediately after the formatting has been applied.

You can also insert hyperlinks manually.

**Tips**

To prevent LibreOffice from automatically turning website addresses (URLs) into hyperlinks, go to **Tools > AutoCorrect > Options** and deselect the **URL Recognition** checkbox.

To change the color of hyperlinks, go to **Tools > Options > LibreOffice > Appearance**, scroll to **Unvisited links** and/or **Visited links**, select the checkboxes, pick the new colors and click **OK**. Caution: this will change the color for all hyperlinks in all components of LibreOffice which may not be what you want.

To insert a hyperlink, or to customize the appearance of a hyperlink, select **Insert > Hyperlinks** from the menu bar. The Hyperlink dialog opens (Figure 30).
On the left hand side, select one of the four types of hyperlinks. The top right part of the dialog changes according to the choice made for the hyperlink type. A full description of all the choices, and their interactions, is beyond the scope of this chapter. A summary of the most common choices used in presentation are given below.

- **Internet**: choose whether the link is Web, FTP or Telnet. Enter the required web address (URL).
- **Mail & News**: choose whether the link is an E-mail or news link. Enter the receiver address and for email, also the subject.
- **Document**: creates a hyperlink to another document or to another place in the presentation, commonly referred to as a bookmark. Enter the document path, or click on the Open File icon to open a file browser; leave this blank if you want to link to a target in the same presentation. Optionally, you can specify a target if (for example a specific slide). Click on the Target icon to open the Navigator where you can select the target, or if you know the name of the target, you can type it into the box.
- **New Document**: creates a hyperlink to a new document. Choose whether to edit the newly created document immediately (Edit now) or just create it to edit later (Edit later). Choose the type of document to create (text, spreadsheet, etc.). For a presentation, Edit now is the more likely choice. The Select path button opens a file browser so that you can choose the directory for the new document.

Note

For navigation within a presentation, it is generally better to use the object interaction menu that you can find either in the Drawing toolbar or in the pop-up menu that opens when right-clicking on an object.

The Further settings section on the Hyperlink dialog is common to all the hyperlink types, although some choices are more relevant to some types of links.

- Set the value of Frame to determine how the hyperlink will open. This applies to documents that open in a Web browser.
- Form specifies if the link is to be presented as text or as a button. See “Working with hyperlink buttons” on page 31 for more information.
- Text specifies the text that will be visible to the user.
• **Name** is applicable to HTML documents. It specifies text that will be added as a NAME attribute in the HTML code behind the hyperlink.

**Editing text hyperlinks**

To edit a text hyperlink, select it (by dragging across the text, not clicking on it), then choose **Edit > Hyperlink** from the main menu bar. Make changes as needed and click **Apply** when done. If you need to edit several hyperlinks, you can leave the Hyperlink dialog open until you have edited all of them. Be sure to click **Apply** after each one. When you are finished, click **Close**.

**Working with hyperlink buttons**

A hyperlink button is inserted in the center of the current slide. In most cases, that is not where you want it to appear. To edit the text or size of a hyperlink button, or to move it to another place on the slide, first display the Form Controls toolbar (**View > Toolbars > Form Controls**) (Figure 31). Select the **Design Mode On/Off** icon (highlighted).

![Form Controls toolbar](image)

*Figure 31: Form Control toolbar*

Now you can click on the hyperlink button and drag it to another position, or right-click to open a dialog where you can change the text on the button, the size of the button, and other properties. When you have finished editing the button, click the **Design Mode On/Off** icon again to make the button inactive. For a detailed description of the properties and how to work with Form Controls, refer to the **Writer Guide**.