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Introduction
You can use Calc without a pointing device, such as a mouse or touchpad, by using keyboard
shortcuts. This appendix provides a comprehensive reference list of the available built-in
shortcuts, which you can browse to find ones that may be useful in your daily work.
When you first install LibreOffice, a default set of Calc keyboard shortcuts is available. These are
described in this chapter, assuming no customization. When using Calc, you can discover
shortcuts for common interactions by observing the key sequences identified on the menu
options and in the tooltips of toolbar icons. You can also explore a more comprehensive list of
shortcuts by viewing the Keyboard tab of the Customize dialog (Tools > Customize).
Further information about many individual key combinations can be found throughout the
chapters of this guide and in the Help system.
You can define your own shortcuts or change existing shortcuts by going to Tools > Customize
> Keyboard on the Menu bar. See Chapter 14, Setting up and Customizing, for further
instructions. Some shortcuts cannot be re-assigned; these are identified in the “Keyboard
shortcuts that cannot be modified” sections on pages 12 (Windows / Linux) and 20 (macOS).

Caution
Be careful when reassigning predefined shortcuts. Although you can reset shortcut
keys back to LibreOffice defaults, changing common hotkeys, such as F1 for Help,
can cause confusion and frustration, especially if other users share your computer.

Note
Different operating systems may allocate particular keys to operating system
functions and, in such cases, those keys may not perform the Calc functions
described in this appendix.
For example, the F1 function key may be used to put your Windows computer into a
sleep / hibernation mode and so cannot be used to access the Calc Help system.
For some macOS versions, the Cmd+F5 key sequence is used by macOS to display
its VoiceOver dialog and so cannot be used to control the display of Calc’s Sidebar.
Similarly the Shift+F11 key sequence may be used by macOS to show its desktop
and so cannot be used to access Calc’s Save as Template dialog.
Check your computer system’s documentation to determine which key presses are
used by the operating system and hence cannot carry out Calc functions.
The remainder of this chapter is in two main sections, one listing the keyboard shortcuts available
in the Windows and Linux environments, and the other listing the macOS keyboard shortcuts.

Windows / Linux keyboard shortcuts
Note
Many of the keyboard shortcuts in this section use the Ctrl key. Some keyboards
have two Ctrl keys and in that case you may need to experiment to identify which of
the two keys to use.
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Keyboard shortcuts for Menu bar options and toolbars
Tables 1 to 4 list Calc keyboard shortcuts that can be used instead of the options on the Menu
bar, the Standard toolbar, or the Formatting toolbar. The toolbars are assumed to contain the
initial default set of icons, without any user customization.
Table 1: Function key shortcuts for menu and toolbar options
Windows / Linux

Equivalent Menu bar / toolbar option

F1

Help > LibreOffice Help.

F2

Edit > Cell Edit Mode.

Ctrl+F2

Insert > Function.

Ctrl+F3

Sheet > Named Ranges and Expressions > Manage.

Shift+F3

Format > Text > Cycle Case.

F4

Sheet > Cycle Cell Reference Types.

Ctrl+Shift+F4

View > Data Sources.

F5

View > Navigator.

Ctrl+F5

View > Sidebar.

Shift+F5

Tools > Detective > Trace Dependents.

F7

Tools > Spelling.
Spelling icon on the Standard toolbar.

Ctrl+F7

Tools > Thesaurus.

Ctrl+Shift+F7

Tools > Language > Hangul/Hanja Conversion. The availability of this
menu option depends on selections on Tools > Options > Language Setting
> Languages.

Shift+F7

Tools > Automatic Spell Checking.

Ctrl+F8

View > Value Highlighting.

F9

Data > Calculate > Recalculate.

Shift+F9

Tools > Detective > Trace Precedents.

Ctrl+Shift+F9

Data > Calculate > Recalculate Hard.

F11

View > Styles.
Styles > Manage Styles.

Shift+F11

File > Templates > Save as Template.
Via drop-down menu on Save icon on the Standard toolbar.

F12

Data > Group and Outline > Group.

Ctrl+F12

Data > Group and Outline > Ungroup.

Alt+F12

Tools > Options.

Table 2: Number key shortcuts for menu and toolbar options
Windows / Linux

Equivalent Menu bar / toolbar option

Ctrl+1

Format > Cells.

Ctrl+Shift+1

Format > Number Format > Number (use the “1” key on the main
keyboard).
Format as Number icon on the Formatting toolbar.
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Windows / Linux

Equivalent Menu bar / toolbar option

Ctrl+Shift+2

Format > Number Format > Scientific (use the “2” key on the main
keyboard).

Ctrl+Shift+3

Format > Number Format > Date (use the “3” key on the main keyboard).
Format as Date icon on the Formatting toolbar.

Ctrl+Shift+4

Format > Number Format > Currency (use the “4” key on the main
keyboard).
Format as Currency icon on the Formatting toolbar.

Ctrl+Shift+5

Format > Number Format > Percent (use the “5” key on the main keyboard).
Format as Percent icon on the Formatting toolbar.

Ctrl+Shift+6

Format > Number Format > General (use the “6” key on the main
keyboard).

Note
The Format > Spacing menu appears to provide shortcuts for Line Spacing: 1.5
(Ctrl+5) and Line Spacing: 2 (Ctrl+2). However these options are never active in
Calc 7.1 and so the shortcuts are not included in Table 2.
Table 3: Letter key shortcuts for menu and toolbar options
Windows / Linux

Equivalent Menu bar / toolbar option

Ctrl+B

Format > Text > Bold.
Bold icon on the Formatting toolbar.

Ctrl+Shift+B

Format > Text > Subscript.

Ctrl+C

Edit > Copy.
Copy icon on the Standard toolbar.

Ctrl+Shift+C

Edit > Track Changes > Record.

Ctrl+Alt+C

Insert > Comment.
Sheet > Cell Comments > Edit Comment.
Insert Comment icon on the Standard toolbar.

Ctrl+D

Sheet > Fill Cells > Fill Down.
Via drop-down menus on Row or Column icons on the Standard toolbar.

Ctrl+E

Format > Align > Centered.
Align Center icon on the Formatting toolbar.

Ctrl+Alt+E

Tools > Extension Manager.

Ctrl+F

Edit > Find.

Ctrl+H

Edit > Find and Replace.
Find and Replace icon on the Standard toolbar.

Ctrl+I

Format > Text > Italic.
Italic icon on the Formatting toolbar.

Ctrl+J

Format > Align > Justified.

Ctrl+Shift+J

View > Full Screen.

Ctrl+K

Insert > Hyperlink.
Insert Hyperlink icon on the Standard toolbar.
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Windows / Linux

Equivalent Menu bar / toolbar option

Ctrl+L

Format > Align > Left.
Align Left icon on the Formatting toolbar.

Ctrl+M

Format > Clear Direct Formatting.
Clear Direct Formatting icon on the Standard toolbar.

Ctrl+Shift+M

Edit > Edit Mode.

Ctrl+N

File > New > Spreadsheet.
New icon on the Standard toolbar.

Ctrl+Shift+N

File > New > Templates.
File > Templates > Manage Templates.
Via drop-down menu on New icon on the Standard toolbar.

Ctrl+O

File > Open.
Open icon on the Standard toolbar.

Ctrl+Shift+O

File > Print Preview.
Toogle Print Preview icon on the Standard toolbar.

Ctrl+P

File > Print.
Print icon on the Standard toolbar.

Ctrl+Shift+P

Format > Text > Superscript.

Ctrl+Q

File > Exit LibreOffice.

Ctrl+R

Format > Align > Right.
Align Right icon on the Formatting toolbar.

Ctrl+S

File > Save.
Save icon on the Standard toolbar.

Ctrl+Shift+S

File > Save As.
Via drop-down menu on Save icon on the Standard toolbar.

Ctrl+U

Underline icon on the Formatting toolbar.

Ctrl+V

Edit > Paste.
Paste icon on the Standard toolbar.

Ctrl+Shift+V

Edit > Paste Special > Paste Special.

Ctrl+Alt+Shift+V

Edit > Paste Special > Paste Unformatted Text.

Ctrl+W

Window > Close Window.

Ctrl+X

Edit > Cut.
Cut icon on the Standard toolbar.

Ctrl+Y

Edit > Redo.
Redo icon on the Standard toolbar.

Ctrl+Shift+Y

Edit > Repeat.

Ctrl+Z

Edit > Undo.
Undo icon on the Standard toolbar.
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Table 4: Other shortcuts for menu and toolbar options
Windows / Linux

Equivalent Menu bar / toolbar option

Ctrl+Shift+Pg up

Edit > Select > Select to Previous Sheet.

Ctrl+Shift+Pg down

Edit > Select > Select to Next Sheet.

Backspace

Sheet > Clear Cells.

Ctrl+Tab

Sheet > Navigate > To Next Sheet.

Ctrl+Shift+Tab

Sheet > Navigate > To Previous Sheet.

Ctrl+Space

Edit > Select > Select Column.

Shift+Space

Edit > Select > Select Row.

Ctrl+Shift+Space

Edit > Select All.

Ctrl++

Sheet > Insert Cells (use the + key on the numeric keypad).

Ctrl+-

Sheet > Delete Cells.

Ctrl+*

Edit > Select > Select Data Area (use the * key on the numeric keypad).

Ctrl+;

Insert > Date.

Ctrl+Shift+;

Insert > Time.

Ctrl+`

View > Show Formula. The grave (`) character can be found to the left of
the “1” key on many English keyboards. In the Windows build of LibreOffice
Calc 7.1, the grave character is omitted from the menu option.

Other Calc keyboard shortcuts
Tables 5 to 10 provide lists of additional Calc keyboard shortcuts that may be less obvious to
users because they are not indicated on Menu bar items or in tooltips associated with icons on
the Standard and Formatting toolbars.
Table 5: Other function key shortcuts
Windows / Linux

Description

Shift+F1

Display context sensitive help.

Ctrl+F1

Display the comment attached to the current cell.

Ctrl+Shift+F2

Moves the cursor to the Input line where you can enter a formula for the
current cell.

Ctrl+Shift+F5
Ctrl+Shift+T

Moves the cursor to the Name Box field on the Formula bar.

Table 6: Other letter key shortcuts
Windows / Linux

Description

Ctrl+A

Selects all cells in the current sheet.

Ctrl+Shift+R

Redraws the document view.

Ctrl+Shift+Z

Reverses the action of the last undo command.
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Table 7: Arrow key shortcuts
Windows / Linux

Description

↑

Moves the cell focus up.

Ctrl+↑

Moves the cursor in the up direction to the edge of the current data range (if
the cell adjacent to the cursor is empty, the cursor moves to the next cell that
contains data).

Shift+↑

Selects the adjacent cell or cells located in the up direction.

Ctrl+Shift+↑

Selects in the up direction to the edge of the current data range (if the cell
adjacent to the cursor is empty, the cursor moves to the next cell that
contains data).

Alt+Shift+↑

Optimizes the row height based on the current cell.

→

Moves the cell focus right.

Ctrl+→

Moves the cursor in the right direction to the edge of the current data range
(if the cell adjacent to the cursor is empty, the cursor moves to the next cell
that contains data).

Shift+→

Selects the adjacent cell or cells located in the right direction.

Ctrl+Shift+→

Selects in the right direction to the edge of the current data range (if the cell
adjacent to the cursor is empty, the cursor moves to the next cell that
contains data).

Alt+→

Increases the width of the current column.

Alt+Shift+→

Optimizes the column width based on the current cell.

↓

Moves the cell focus down.

Ctrl+↓

Moves the cursor in the down direction to the edge of the current data range
(if the cell adjacent to the cursor is empty, the cursor moves to the next cell
that contains data).

Alt+↓

Opens a drop-down selection list of text items that have been previously
typed into other cells in the same column.

Shift+↓

Selects the adjacent cell or cells located in the down direction.

Ctrl+Shift+↓

Selects in the down direction to the edge of the current data range (if the cell
adjacent to the cursor is empty, the cursor moves to the next cell that
contains data).

Alt+Shift+↓

Optimizes the row height based on the current cell.

←

Moves the cell focus left.

Ctrl+←

Moves the cursor in the left direction to the edge of the current data range (if
the cell adjacent to the cursor is empty, the cursor moves to the next cell that
contains data).

Shift+←

Selects the adjacent cell or cells located in the left direction.

Ctrl+Shift+←

Selects in the left direction to the edge of the current data range (if the cell
adjacent to the cursor is empty, the cursor moves to the next cell that
contains data).

Alt+←

Decreases the width of the current column.

Alt+Shift+←

Optimizes the column width based on the current cell.
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Table 8: Home and End key shortcuts
Windows / Linux

Description

Home

Moves the cursor to the first cell of the current row.

Ctrl+Home

Moves the cursor to the first cell (A1) in the current sheet.

Shift+Home

Selects cells from the cursor to the first cell of the current row.

Ctrl+Shift+Home

Selects all cells from the cursor to the first cell (A1) in the current sheet.

End

Moves the cursor along the current row to the cell in the last column
containing data in the sheet.

Ctrl+End

Moves the cursor to the cell in the last column and row that contain data in
the current sheet.

Shift+End

Selects cells along the current row from the cursor to the cell in the last
column containing data in the sheet.

Ctrl+Shift+End

Selects all cells from the cursor to the cell in the last column and row that
contain data in the current sheet.

Table 9: Other Page Up and Down key shortcuts
Windows / Linux

Description

Pg up

Moves up one screen page.

Ctrl+Pg up

Moves to the previous sheet.

Shift+Pg up

Selects cells from the cursor to the row one page up.

Alt+Pg up

Moves one screen page to the left.

Alt+Shift+Pg up

Selects cells from the cursor to the column one page to the left.

Pg down

Moves down one screen page.

Ctrl+Pg down

Moves to the next sheet.

Shift+Pg down

Selects cells from the cursor to the row one page down.

Alt+Pg down

Moves one screen page to the right.

Alt+Shift+Pg down

Selects cells from the cursor to the column one page to the right.

Table 10: Other miscellaneous key shortcuts
Windows / Linux

Description

Escape

Cancels the current cell edit.

Insert

After making a selection, opens the Paste Special dialog.

Ctrl+Insert

Copies the selected cell or cell range to the clipboard in preparation for a
later paste operation.

Shift+Insert

Pastes the contents of the clipboard into the selected cells.

Delete

Deletes cell contents without a dialog (does not remove formatting).

Shift+Delete

Removes and copies the selection to the clipboard.

Ctrl+Backspace

Refocuses the view back on the cursor if it is not currently in view.

Shift+Backspace

Deselects the current cell selection without deleting contents.

Alt+Backspace

Reverses the last command or the last entry you typed.

Ctrl+[

Selects the cells on which the current cell is dependent.

Ctrl+]

Selects the cells that are dependent on the current cell.
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Windows / Linux

Description

Ctrl+/

Selects the cells in the matrix formula range that contains the cursor.

Ctrl+’

Copies the contents of the cell above the cursor into the current cell, but
remains in cell edit mode so that you can make further changes.
Use the single apostrophe key.

Enter

Moves the cursor to the next cell in the selected range, from top to bottom,
then left to right. To specify in which direction the cursor moves, go to Tools >
Options > LibreOffice Calc > General on the Menu bar.

Ctrl+Enter

Inserts a manual line break in the current cell while editing a cell.

Ctrl+Shift+Enter

Creates a matrix in the current range using the information entered on the
input line.

Alt+Enter

Fills the selected cell range with the formula that you entered on the input
line.

Alt+=

Equivalent to selecting Select Function > Sum on the Formula bar.

Chart keyboard shortcuts
Table 11 lists some shortcuts that are available within a Calc chart.

Tip
You can use the Alt key with the arrow keys and plus (+) and minus (-) keys to move
elements with a finer degree of movement for more accuracy.
Table 11: Chart shortcuts
Windows / Linux

Effect

Tab

Selects the next chart element.

Shift+Tab

Selects the previous chart element.

Home

Selects the first chart element.

End

Selects the last chart element.

Esc

Cancels selection.

Arrow keys

Moves the element in the direction of the arrow.

Arrow keys in pie
charts

Moves the selected pie segment in the direction of the arrow.

F2 in titles

Enters text input mode.

F3 in legends and
data series

Opens groups so that you can edit the individual components.

Ctrl+F3 in legends
and data series

Exits groups.

+/-

Enlarges or shrinks the chart (use the + / - keys in the numeric keypad).

+/- in pie charts

Moves the selected pie segment off or into the pie chart (use the + / - keys in
the numeric keypad).
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Outline keyboard shortcuts
Table 12 lists shortcuts that are available in an outline window. To use these shortcuts, press F6
or Shift+F6 until the vertical or horizontal outline window has the focus.
Table 12: Outline shortcuts
Windows / Linux

Effect

Tab

Cycles through each outline indicator from top to bottom or left to right.

Shift+Tab

Cycles through each outline indicator in the opposite direction.

Ctrl+1 to Ctrl+8

Show all levels up to the specified number while hiding all higher-numbered
levels in the outline.

+/-

Shows (+) or hides (-) the focused outline group (use the + / - keys in the
numeric keypad).

Enter

Activates the focused indicator button.

Arrow keys

Cycles through indicator buttons in the direction of the arrow.

Keyboard shortcuts that cannot be modified
Table 13 identifies the key combinations that are grayed out (not available for modification) in the
Shortcut Keys list on the Keyboard tab of the Tools > Customize dialog with Calc selected.
Table 13: Grayed key combinations in Tools > Customize > Keyboard
Operating
system

Key combinations grayed in Customize dialog

Windows 10

F1, Ctrl+F1, Shift+F1
Shift+F2
Ctrl+F4, Alt+F4, Ctrl+Alt+F4
F6, Ctrl+F6, Shift+F6, Ctrl+Shift+F6
F10

Linux

F1, Ctrl+F1, Shift+F1
Shift+F2
Ctrl+F4, Alt+F4, Ctrl+Alt+F4
F6, Ctrl+F6, Shift+F6, Ctrl+Shift+F6
F10
Ctrl+Shift+0, Ctrl+Shift+1, Ctrl+Shift+2, Ctrl+Shift+3, Ctrl+Shift+4, Ctrl+Shift+5,
Ctrl+Shift+6, Ctrl+Shift+7, Ctrl+Shift+8, Ctrl+Shift+9
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macOS keyboard shortcuts
macOS keyboard symbols
Keys on many macOS keyboards use symbols rather than text labels. Table 14 identifies some
common macOS keyboard symbols with their meanings. In the tables that follow, the key names
are used rather than symbols, since the latter may not appear on all macOS keyboards.
Table 14: Common macOS keyboard symbols
Key name

Symbol

Command (shortened to “Cmd” in the tables that follow)
Control (shorted to “Ctrl” in the tables that follow)
Option
Shift
Page Up (shortened to “Pg Up” in the tables that follow)
Page Down (shortened to “Pg Dn” in the tables that follow)
Home
End
Delete
Forward Delete (shortened to “Fwd Del” in the tables that follow)

Keyboard shortcuts for Menu bar options and toolbars
Tables 15 to 18 list Calc keyboard shortcuts that can be used instead of the options on the Menu
bar, the Standard toolbar, or the Formatting toolbar. The toolbars are assumed to contain the
initial default set of icons, without any user customizations.
Table 15: Function key shortcuts for menu and toolbar options
macOS

Equivalent Menu bar / toolbar option

F1

Help > LibreOffice Help.

F2

Edit > Cell Edit Mode.

Cmd+F2

Insert > Function.

Cmd+F3

Sheet > Named Ranges and Expressions > Manage.

Shift+F3

Format > Text > Cycle Case.

F4

Sheet > Cycle Cell Reference Types.

Shift+Cmd+F4

View > Data Sources.

F5

View > Navigator.

Cmd+F5

View > Sidebar.

Shift+F5

Tools > Detective > Trace Dependents.

Cmd+F7

Tools > Thesaurus.

Shift+Cmd+F7

Tools > Language > Hangul/Hanja Conversion. The availability of this menu
option depends on selections in LibreOffice > Preferences > Language
Setting > Languages.
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macOS

Equivalent Menu bar / toolbar option

Shift+F7

Tools > Automatic Spell Checking.

Cmd+F8

View > Value Highlighting.

F9

Data > Calculate > Recalculate.

Shift+F9

Tools > Detective > Trace Precedents.

Shift+Cmd+F9

Data > Calculate > Recalculate Hard.

Shift+F11

File > Templates > Save as Template.
Via drop-down menu on Save icon on Standard toolbar.

F12

Data > Group and Outline > Group.

Cmd+F12

Data > Group and Outline > Ungroup.

Table 16: Number key shortcuts for menu and toolbar options
macOS

Equivalent Menu bar / toolbar option

Cmd+1

Format > Cells.

Ctrl+Shift+1

Format > Number Format > Number (use the “1” key on the main keyboard).
Format as Number icon on Formatting toolbar.

Ctrl+Shift+2

Format > Number Format > Scientific (use the “2” key on the main
keyboard).

Ctrl+Shift+3

Format > Number Format > Date (use the “3” key on the main keyboard).
Format as Date icon on Formatting toolbar.

Ctrl+Shift+4

Format > Number Format > Currency (use the “4” key on the main
keyboard).
Format as Currency icon on Formatting toolbar.

Ctrl+Shift+5

Format > Number Format > Percent (use the “5” key on the main keyboard).
Format as Percent icon on Formatting toolbar.

Ctrl+Shift+6

Format > Number Format > General (use the “6” key on the main keyboard).

Note
The Format > Spacing menu appears to provide shortcuts for Line Spacing: 1.5
(Cmd+5) and Line Spacing: 2 (Cmd+2). However, these options are never active in
Calc 7.1 and so the shortcuts are not included in Table 16.
Table 17: Letter key shortcuts for menu and toolbar options
macOS

Equivalent Menu bar / toolbar option

Cmd+B

Format > Text > Bold.
Bold icon on the Formatting toolbar.

Shift+Cmd+B

Format > Text > Subscript.

Cmd+C

Edit > Copy.
Copy icon on the Standard toolbar.

Shift+Cmd+C

Edit > Track Changes > Record.

Option+Cmd+C

Insert > Comment.
Sheets > Cell Comments > Edit Comment.
Insert Comment icon on the Standard toolbar.
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macOS

Equivalent Menu bar / toolbar option

Cmd+D

Sheet > Fill Cells > Fill Down.

Cmd+E

Format > Align > Centered.
Align Center icon on the Formatting toolbar.

Option+Cmd+E

Tools > Extension Manager.

Cmd+F

Edit > Find.

Option+Cmd+F

Edit > Find and Replace.
Find and Replace icon on the Standard toolbar.

Ctrl+Cmd+F

View > Full Screen.

Cmd+H

LibreOffice > Hide LibreOffice.

Cmd+I

Format > Text > Italic.
Italic icon on the Formatting toolbar.

Cmd+J

Format > Align > Justified.

Cmd+K

Insert > Hyperlink.
Insert Hyperlink icon on the Standard toolbar.

Cmd+L

Format > Align > Left.
Align Left icon on the Formatting toolbar.

Ctrl+M

Format > Clear Direct Formatting.
Clear Direct Formatting icon on the Standard toolbar.

Shift+Cmd+M

Edit > Edit Mode.

Cmd+N

File > New > Spreadsheet.
New icon on the Standard toolbar.

Shift+Cmd+N

File > New > Templates.
File > Templates > Manage Templates.
Via drop-down menu on New icon on the Standard toolbar.

Cmd+O

File > Open.
Open icon on the Standard toolbar.

Shift+Cmd+O

File > Print Preview.
Toogle Print Preview icon on the Standard toolbar.

Cmd+P

File > Print.
Print icon on the Standard toolbar.

Shift+Cmd+P

Format > Text > Superscript.

Cmd+Q

LibreOffice > Quit LibreOffice.

Cmd+R

Format > Align > Right.
Align Right icon on the Formatting toolbar.

Cmd+S

File > Save.
Save icon on the Standard toolbar.

Shift+Cmd+S

File > Save As.

Cmd+T

View > Styles.
Styles > Manage Styles.

Cmd+U

Underline icon on the Formatting toolbar.

Cmd+V

Edit > Paste.
Paste icon on the Standard toolbar.
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macOS

Equivalent Menu bar / toolbar option

Shift+Cmd+V

Edit > Paste Special > Paste Special.

Option+Shift+Cmd+V

Edit > Paste Special > Paste Unformatted Text.

Cmd+W

Window > Close Window.

Cmd+X

Edit > Cut.
Cut icon on the Standard toolbar.

Cmd+Y

Edit > Redo.
Redo icon on the Standard toolbar.

Shift+Cmd+Y

Edit > Repeat.

Cmd+Z

Edit > Undo.
Undo icon on the Standard toolbar.

Table 18: Other shortcuts for menu and toolbar options
macOS

Equivalent Menu bar / toolbar option

Shift+Cmd+Pg Up

Edit > Select > Select to Previous Sheet. (In Calc 7.1, the menu option
indicates an up arrow symbol rather than a page up symbol).

Shift+Cmd+Pg Dn

Edit > Select > Select to Next Sheet. (In Calc 7.1, the menu option
indicates a down arrow symbol rather than a page down symbol).

Delete

Sheet > Clear Cells.

Ctrl+Space

Edit > Select > Select Column.

Shift+Space

Edit > Select > Select Row.

Ctrl+Shift+Space
Cmd+A

Edit > Select All.

Cmd++

Sheet > Insert Cells (use the + key on the numeric keypad).

Cmd+-

Sheet > Delete Cells.

Cmd+*

Edit > Select > Select Data Area.

Cmd+;

Insert > Date.

Shift+Cmd+;

Tools > Spelling.
Spelling icon on the Standard toolbar.

Cmd+,

LibreOffice > Preferences.

Other Calc keyboard shortcuts
Tables 19 to 24 provide lists of additional Calc keyboard shortcuts that may be less obvious to
users because they are not indicated on Menu bar items or in tooltips associated with icons on
the Standard and Formatting toolbars.
Table 19: Other function key shortcuts
macOS

Description

Shift+F1

Display context sensitive help.

Cmd+F1

Display the comment attached to the current cell.

Shift+Cmd+F2

Moves the cursor to the Input line where you can enter a formula for the
current cell.

Shift+Cmd+F5
Shift+Cmd+T

Moves the cursor to the Name Box field on the Formula bar.
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macOS

Description

F8

Toggles between the standard and extending selection modes.

Shift+F8

Toggles between the standard and adding selection modes.

Table 20: Other letter key shortcuts
macOS

Description

Cmd+G

Repeat search forwards.

Shift+Cmd+R

Redraws the document view.

Shift+Cmd+Z

Reverses the action of the last undo command.

Table 21: Arrow key shortcuts
macOS

Description

↑

Moves the cell focus up.

Cmd+↑

Moves the cursor in the up direction to the edge of the current data range (if
the cell adjacent to the cursor is empty, the cursor moves to the next cell that
contains data).

Shift+↑

Selects the adjacent cell or cells located in the up direction.

Shift+Cmd+↑

Selects in the up direction to the edge of the current data range (if the cell
adjacent to the cursor is empty, the cursor moves to the next cell that contains
data).

Option+Shift+↑

Optimizes the row height based on the current cell.

→

Moves the cell focus right.

Cmd+→

Moves the cursor in the right direction to the edge of the current data range (if
the cell adjacent to the cursor is empty, the cursor moves to the next cell that
contains data).

Shift+→

Selects the adjacent cell or cells located in the right direction.

Shift+Cmd+→

Selects in the right direction to the edge of the current data range (if the cell
adjacent to the cursor is empty, the cursor moves to the next cell that contains
data).

Option+→

Increases the width of the current column.

Option+Shift+→

Optimizes the column width based on the current cell.

↓

Moves the cell focus down.

Cmd+↓

Moves the cursor in the down direction to the edge of the current data range (if
the cell adjacent to the cursor is empty, the cursor moves to the next cell that
contains data).

Option+↓

Opens a drop-down selection list of text items that have been previously typed
into other cells in the same column.

Shift+↓

Selects the adjacent cell or cells located in the down direction.

Shift+Cmd+↓

Selects in the down direction to the edge of the current data range (if the cell
adjacent to the cursor is empty, the cursor moves to the next cell that contains
data).

Option+Shift+↓

Optimizes the row height based on the current cell.

←

Moves the cell focus left.
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macOS

Description

Cmd+←

Moves the cursor in the left direction the edge of the current data range (if the
cell adjacent to the cursor is empty, the cursor moves to the next cell that
contains data).

Shift+←

Selects the adjacent cell or cells located in the left direction.

Shift+Cmd+←

Selects in the left direction to the edge of the current data range (if the cell
adjacent to the cursor is empty, the cursor moves to the next cell that contains
data).

Option+←

Decreases the width of the current column.

Option+Shift+←

Optimizes the column width based on the current cell.

Table 22: Home and End key shortcuts
macOS

Description

Home

Moves the cursor to the first cell of the current row.

Cmd+Home

Moves the cursor to the first cell in the current sheet (A1).

Shift+Home

Selects cells from the cursor to the first cell of the current row.

Shift+Cmd+Home

Selects all cells from the cursor to the first cell in the current sheet (A1).

End

Moves the cursor along the current row to the cell in the last column
containing data in the sheet.

Cmd+End

Moves the cursor to the cell in the last column and row that contain data in the
current sheet.

Shift+End

Selects cells along the current row from the cursor to the cell in the last
column containing data in the sheet.

Shift+Cmd+End

Selects all cells from the cursor to the cell in the last column and row that
contain data in the current sheet.

Table 23: Other Page Up and Down key shortcuts
macOS

Description

Pg Up

Moves up one screen page.

Cmd+Pg Up

Moves to the previous sheet.

Shift+Pg Dn

Selects cells from the cursor to the row one page up.

Option+Pg Dn

Moves one screen page to the left.

Option+Shift+Pg Dn

Selects cells from the cursor to the column one page to the left.

Pg Dn

Moves down one screen page.

Cmd+Pg Dn

Moves to the next sheet.

Shift+Pg Dn

Selects cells from the cursor to the row one page down.

Option+Pg Up

Moves one screen page to the right.

Option+Shift+Pg Up

Selects cells from the cursor to the column one page to the right.

Table 24: Other miscellaneous key shortcuts
macOS

Description

Esc

Cancels the current cell edit.

Fwd Del

Deletes cell contents without a dialog (does not remove formatting).
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macOS

Description

Cmd+Delete

Refocuses the view back on the cursor if it is not currently in view.

Option+Delete

Reverses the last command or the last entry you typed.

Cmd+[

Selects the cells on which the current cell is dependent.

Cmd+]

Selects the cells that are dependent on the current cell.

Cmd+/

Selects the cells in the matrix formula range that contains the cursor.
Use the forward slash key on the main keyboard or the numeric keypad.

Cmd+’

Copies the contents of the cell above the cursor into the current cell, but
remains in cell edit mode so that you can make further changes.
Use the single apostrophe key.

Enter

Moves the cursor to the next cell in the selected range, from top to bottom,
then left to right. To specify in which direction the cursor moves, go to
LibreOffice > Preferences > LibreOffice Calc > General on the Menu bar.

Cmd+Enter

Inserts a manual line break in the current cell while editing a cell.

Shift+Cmd+Enter

Creates a matrix in the current range using the information entered on the input
line.

Option+Enter

Fills the selected cell range with the formula that you entered on the input line.

Chart keyboard shortcuts
Table 25 lists some shortcuts that are available within a Calc chart.

Tip
You can use the Option key with the arrow keys and plus (+) and minus (-) keys to
move elements with a finer degree of movement for more accuracy.
Table 25: Chart shortcuts
macOS

Effect

⇥

Selects the next chart element.

Shift+⇥

Selects the previous chart element.

Home

Selects the first chart element.

End

Selects the last chart element.

Esc

Cancels selection.

Arrow keys

Moves the element in the direction of the arrow.

Arrow keys in pie
charts

Moves the selected pie segment in the direction of the arrow.

F2 in titles

Enters text input mode.

F3 in legends and
data series

Opens groups so that you can edit the individual components.

Cmd+F3 in legends
and data series

Exits groups.
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Outline keyboard shortcuts
Table 26 lists shortcuts that are available in an outline window. To use these shortcuts, press F6
or Shift+F6 until the vertical or horizontal outline window has the focus.
Table 26: Outline shortcuts
macOS

Effect

⇥

Cycles through each outline indicator from top to bottom or left to right.

Shift+⇥

Cycles through each outline indicator in the opposite direction.

Cmd+1 to
Cmd+8

Show all levels up to the specified number while hiding all higher-numbered
levels in the outline.

+/-

Shows (+) or hides (-) the focused outline group (use the + / - keys in the
numeric keypad).

Enter

Activates the focused indicator button.

Arrow keys

Cycles through indicator buttons in the direction of the arrow.

Keyboard shortcuts that cannot be modified
Table 27 identifies the key combinations that are grayed out (not available for modification) in the
Shortcut Keys list on the Tools > Customize > Keyboard dialog with Calc selected.
Table 27: Grayed key combinations in Tools > Customize > Keyboard
Operating
system

Key combinations grayed in Customize dialog

macOS

F1, Cmd+F1, Shift+F1
Shift+F2
Cmd+F4, Option+F4, Cmd+Option+F4
F6, Cmd+F6, Shift+F6, Shift+Cmd+F6
F10
Shift+Cmd+0, Shift+Cmd+1, Shift+Cmd+2, Shift+Cmd+3, Shift+Cmd+4,
Shift+Cmd+5, Shift+Cmd+6, Shift+Cmd+7, Shift+Cmd+8, Shift+Cmd+9
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