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What is Impress?
Impress is the presentation (slide show) program included in LibreOffice. Impress creates
presentations in the Open Document Presentation (ODP) format, which can be opened by other
presentation software or can be exported in different presentation formats.
Slides can be created that contain many different elements, including text, bulleted and
numbered lists, tables, charts, and a wide range of graphic objects such as clipart, drawings, and
photographs. Impress also includes a spelling checker, a thesaurus, text styles, and background
styles.
This chapter introduces some features of Impress and does not attempt to cover all of the
features available in Impress that can be used to create presentations. See the Impress Guide
and LibreOffice Help for more information.
To use Impress for more than very simple presentations requires some knowledge of the
elements which the slides contain. Slides containing text use styles to determine the appearance
of that text. Creating drawings in Impress is similar to the Draw module included in LibreOffice.
For more information, refer to Chapter 3, Using Styles and Templates, and Chapter 7, Getting
Started with Draw, in this guide. It is recommended to consult the Draw Guide for more details on
how to use the drawing tools.

Starting Impress
Start Impress using any of the methods described in Chapter 1, Introducing LibreOffice. The
main Impress window opens and, by default, the Select a Template dialog (Figure 1) is displayed.
Templates included with Impress are designed to fit the two standard sizes of presentation slides:
4:3 and 16:9 ratios. However, templates will adapt to other available sizes, which can be selected
by going to Slide > Slide Properties > Paper Format on the Menu bar or Format in the Slide
panel in the Properties deck on the Sidebar.

Figure 1: Select a Template dialog
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Tip
To start Impress without the Select a Template dialog, deselect Show this dialog box
at startup in the lower left of the dialog.
In Windows or Linux, go to Tools > Options > LibreOffice Impress > General on
the Menu bar and deselect Start with Template Selection under New Document.
In macOS, go to LibreOffice > Preferences > LibreOffice Impress > General on
the Menu bar and deselect Start with Template Selection under New Document.

Main Impress window
The main Impress window (Figure 2) has three main sections: Slides pane, Workspace, and
Sidebar. At the top is the Menu bar and toolbars. Toolbars can be displayed, hidden, locked in
position, or floating during the creation of a presentation.

Tip
The Slides pane and/or Sidebar can be closed by clicking the X in the upper right
corner of each pane, or go to View > Slide Pane or View > Sidebar on the Menu
bar to deselect. To reopen a pane, select View > Slide Pane or View > Sidebar on
the Menu bar.

Tip
To maximize the Workspace area, click on the Hide/Show marker in the middle of
the vertical separator line (highlighted in Figure 2). Using the Hide/Show marker
hides, but does not close, the Slides pane or Sidebar. To restore a pane, click again
on its Hide/Show marker.

Figure 2: Impress main window
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Menu bar
The Impress Menu bar, at the top of the main window, provides several menus common to all
LibreOffice modules. The commands may differ between each LibreOffice module for File, Edit,
View, Insert, Format, Tools, Window, and Help. Impress has two extra menus for Slide and
Slide Show. When a menu item is selected, a submenu drops down to show commands. The
Menu bar can be customized; see Chapter 14, Customizing LibreOffice.

Workspace
The Workspace (normally the center of the main window) opens in Normal view. It has four
standard views of Normal, Outline, Notes, and Slide Sorter. For more information, see
“Workspace views” on page 13.
If master slides are being used, then master views become available: Master Slide, Master
Notes and Master Handout. There are no tabs for master views, which are selected by going to
View on the Menu bar. For more information on master slides, see the Impress Guide.

Slides pane
The Slides pane contains thumbnail images of slides in a presentation in the order in which the
slides are shown. Clicking on a slide image in the Slides pane selects it and places the slide in
the Workspace where changes are made to the displayed slide.
•

To display or close the Slides pane, go to View > Slide Pane on the Menu bar.

•

To close the Slides pane, click on the X in the right top corner of the Slides pane.

•

To display or hide the Slides pane, use the Hide/Show marker on the left of the
Workspace.

Several additional operations can be carried out on one or more slides in the Slides pane. Also,
these additional operations are available from a context menu when right-clicking on a slide in
the Slides pane.
•

Add new slides to a presentation.

•

Hide a slide so that it will not show in a presentation.

•

Delete a slide from a presentation.

•

Rename a slide.

•

Duplicate a slide (copy and paste).

•

Move a slide to another position in the slide order by dragging and dropping it to the
desired position.

Also, the following operations can be carried out, although there are more efficient methods than
using the Slides pane:
•

Change the slide transition following the selected slide or after each slide in a group.

•

Change the sequence of slides in the presentation.

•

Change the slide design.

•

Change slide layout for a group of slides simultaneously.
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Sidebar
The Impress Sidebar, normally located on the right side of the Workspace, is similar to the
Sidebar in the other LibreOffice modules. It consists of seven decks, as described below. To
open a deck, use one of the following methods:
•

Click on its icon on the right side of the Sidebar.

•

Click on Sidebar Settings at the top of the Sidebar and select a deck in the drop-down
list.

•

Go to View on the Menu bar and select the deck required in the submenu.

Properties
The Properties deck has ten panels, allowing the slide layout to be changed and the formatting of
any objects on a slide.
•

When a slide is selected and appears in the Workspace, the Properties deck opens with
the Slide and Layouts panels available.

•

When an object on a slide is selected, the Properties deck has the following panels
available: Character, Lists, Paragraph, Area, Shadow, Line, Position and Size,
Columns, Effect, and Image. Actual panels displayed depends on the type of object
selected.

Styles
On the Styles deck, drawing and presentation styles can be applied to a selected object, new
styles created for drawing and presentation, and both types of styles can be modified. When
saving changes to a style, the changes are applied to all of the elements formatted with that style
in the presentation. For more information on styles, see “Styles” on page 35 and the Impress
Guide.

Gallery
On the Gallery deck, an object can be inserted into a presentation either as a copy or as a link. A
copy of an object is independent of the original object. Changes to the original object have no
effect on the copy. A link remains dependent on the original object. Changes to the original object
are also reflected in the link. See the Impress Guide for more information.

Navigator
The Navigator deck displays all objects contained in a presentation. It provides a convenient way
to move between slides in a presentation or select an object on a slide. It is recommended to
give slides and objects in a presentation meaningful names so that they are easily identified
when using the Navigator. For more information, see “Navigator” on page 12 and the Impress
Guide.

Shapes
The Shapes deck provides panels quick selection of most items that are available on the
Drawing toolbar: Lines and Arrows, Curves and Polygons, Connectors, Basic Shapes,
Symbol Shapes, Block Arrows, Flowchart, Callout Shapes, Stars and Banners, and 3D
Objects.

Slide transition
The Slide Transition deck provides a selection of slide transitions available in Impress, also
controls to adjust transition speed, automatic or manual transition, and how long a selected slide
is shown (automatic transition only). For more information on transitions, see “Slide transition” on
page 48 and the Impress Guide.
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Animation
The Animation deck provides an easy way to add, change, or remove animations to different
elements or objects on a slide and how they appear during a slide show. For more information on
animation, see “Animation effects” on page 49 and the Impress Guide.

Master slides
Using the Master Slides deck, the slide design can be selected for a presentation. Impress
includes several designs of master slides. The default master slide is blank, but the remaining
master slides have backgrounds and styled text. For more information on master slides, see
“Working with master slides” on page 35 and the Impress Guide.

Rulers
Rulers are positioned on the upper and left-hand sides of the Workspace. If they are not visible,
go to View > Rulers on the Menu bar. The rulers show the size of a selected object on the slide
using double lines (highlighted in Figure 3). Rulers are also used to manage object handles and
guide lines when positioning objects.
To change the measurement units of the rulers, right-click on a ruler and select the measurement
unit from the drop-down list, as shown in Figure 4 for the horizontal ruler. The horizontal and
vertical rulers can be set to different measurement units.
The page margins in the drawing area are also represented on the rulers. The margins can be
changed directly on the rulers by dragging them with the mouse. The margin area is indicated by
either a grayed out area on the rulers or borders around the unused area of the ruler. This
margin indication depends on computer setup and operating system.

Figure 3: Rulers showing object size

Figure 4: Changing ruler units
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Note
The sizes are given in the current measurement unit and might not be the same as
the ruler units. The measurement unit on the Status bar is defined in Tools >
Options > LibreOffice Impress > General.

Status bar
The Status bar (Figure 5), located at the bottom of the Impress window, contains information that
may be useful when working on a presentation. Several of the fields are the same as those in
other components of LibreOffice. Some Impress-specific fields are described briefly below.
For details on the contents and use of these fields, see Chapter 1, Introducing LibreOffice, in this
guide and the Impress Guide. To hide the Status bar, go to View on the Menu bar and deselect
Status Bar.

Figure 5: Status bar
Slide number
The slide number currently displayed in the Workspace and the total number of slides in the
presentation.
Information area
This changes depending on the object selected on the slide. Examples are shown in
Table 1.
Table 1: Examples of information
Example selection
Examples of information shown
Text area
Text Edit: Paragraph x, Row y, Column z
Charts, spreadsheets
Embedded object (OLE) “ObjectName” selected
Graphics
Bitmap with transparency selected
Master slide name
The master slide associated with the slide or notes page displayed in the Workspace.
Right-click to pop up a list of available master slides and select one to apply it to the
selected slide. Double-click to open the Available Master Slides dialog. For more
information on master slides, see “Working with master slides” on page 35 and the Impress
Guide.
Cursor position/Object size
Shows different information depending on whether objects are selected or not.
– When no object is selected, the position numbers show the current position (X and Y
coordinates) of the mouse cursor.
– When an object is selected and being resized with the mouse, the object size
numbers show the size of the object (width and height).
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– If an object is selected, the position numbers shows X and Y coordinates of the
upper-left corner and the object size number pair displays the size of the object.
These numbers do not relate to the object itself, but to the selection outline, which is
the smallest possible rectangle that can contain the visible parts of the object.
– When an object is selected, clicking in either of these areas opens the Position and
Size dialog.
Unsaved changes
Indicates if there are any unsaved changes in the presentation. Clicking this icon saves the
document. If the presentation has not been saved before, the Save As dialog opens giving
the opportunity to save the presentation.
Digital signatures
Indicates if the presentation has a digital signature.
Text language
Indicates the language used for any text on a presentation.
Fit slide
When this icon is clicked on, the slide in the workspace zooms to fit in the Workspace.
Zoom slider
When moved, the slide changes its viewing zoom in the Workspace.
Zoom percentage
Indicates the zoom level of the slide displayed in the Workspace. Clicking on zoom
percentage opens the Zoom & View Layout dialog where the settings for zoom factor and
view layout are adjusted.

Navigator
The Navigator displays all objects contained in a presentation. It provides another convenient
way to move around a presentation and find items in it.
To open the Navigator dialog (Figure 6) go to View > Navigator on the Menu bar, or use the
keyboard shortcut Ctrl+Shift+F5 (macOS ⌘+Shift+F5). Alternatively, click on Navigator in the
Sidebar to open the Navigator deck that is similar in appearance and function as the Navigator
dialog.

Figure 6: Navigator dialog
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The Navigator is more useful if slides and objects (pictures, spreadsheets, and so on) are given
meaningful names, instead of leaving them with default names, such as “Slide 1” and “Shape 1”
and so on (as shown in Figure 6). Using meaningful names allows for a slide or object to be
easily located in a presentation.

Toolbars
Many toolbars can be used during slide creation. To display or hide the various toolbars in
Impress, go to View > Toolbars on the Menu bar and select the required toolbar in the submenu
that appears. For example, the Standard and Drawing toolbars are displayed by default, but the
Line and Filling, and Text Formatting toolbars are not shown. For more information on toolbars
and how to use them, see Chapter 1, Introducing LibreOffice, and the Impress Guide.

Note
The icons used on toolbars vary depending on the computer operating system and
the selection of icon size and style in Tools > Options > LibreOffice > View.

Workspace views
The Impress workspace has four standard views selected using tabs: Normal, Outline, Notes,
and Slide Sorter. These tabs are normally displayed the top of the Workspace. If the tabs are
not displayed, then go to View > Views Tab Bar on the Menu bar. Also, different workspace
views can be selected by going to View on the Menu bar and selecting a view in the submenu.
Each of the workspace views is designed to ease the completion of certain tasks.
Master views only become available in the Workspace when Master Slide, Master Notes or
Master Handout are selected. There are no tabs for master views and can only be selected by
going to View on the Menu bar.

Note
Each workspace view displays a different set of toolbars when selected. To
customize these toolbar sets, go to View > Toolbars on the Menu bar, then check or
uncheck the toolbars to add or remove.

Normal view
Normal view is the main standard view for creating individual slides in a presentation. In Normal
view slides are designed, text or graphics added and formatted, and any animation effects added
to text or graphics.
To place a slide in Normal view of the Workspace, either click on the slide thumbnail in the Slide
Pane or click on the slide name in the Navigator.

Outline view
Outline view (Figure 7) contains all the slides of the presentation in their numbered sequence. It
shows topic titles, bulleted lists, and numbered lists for each slide in outline format. Only the text
contained in the default text boxes in each slide is shown. If you have added text boxes or
graphic objects to the slides, then these objects are not displayed. Slide names are not included.
•

Use Outline view for the following tasks:
– Make changes in the text of a slide:
– Add or delete text in a slide as in Normal view.
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•

– Move a paragraph in a slide up or down by using the movement arrows on the Outline
toolbar (Figure 8).
– Change the outline level of a paragraph in a slide using the left and right arrow
buttons on the Outline toolbar.
Compare slides with in an outline. If it is noticed in an outline that another slide is
required, create it directly in Outline view, or return to Normal view to create it.

Figure 7: Example of Outline view in Workspace

Figure 8: Outline toolbar

Notes view
Use Notes view (Figure 9) to add notes to a slide. These notes are not seen when the
presentation is shown to an audience using an external display connected to a computer. Click
on the words Click to add Notes and begin typing.
The Click to add notes text box can be resized using the resizing handles which appear when the
edge of the notes box is selected. Move or change the size of the box by clicking and dragging
on the box border.

Figure 9: Example Notes in Workspace
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When text is inserted in the Click to add notes text box, it is automatically formatted using the
predefined Notes style in Presentation Styles in the Styles deck on the Sidebar. The Notes style
can be formatted to the presentation requirements. For more information on editing styles, see
Chapter 3, Styles and Templates, in this guide and the Impress Guide.

Slide sorter view
Slide Sorter view (Figure 10) contains all the thumbnails of slides used in a presentation. Use
this view to work with one slide or a group of slides.

Customizing Slide Sorter view
To change the number of slides per row in Slide Sorter view:
1) Go to View > Toolbars > Slide View on the Menu bar to show the Slide View toolbar
(Figure 11).
2) Adjust the number of slides, up to a maximum of 15, in the Slides per Row box.

Changing slide order
To change the slide order of one or a group of slides in a presentation using Slide Sorter view:
1) Select a slide or a group of slides.
2) Drag and drop the slide or group of slides at the location required.

Selecting a group of slides
To select a group of slides, use one of these methods:
•

Ctrl key – click on the first slide and, while holding the Ctrl key (macOS ⌘), select the
required slides. The selected slides do not have to be next to each other.

•

Shift key – click on the first slide, and while holding the Shift key, select the final slide for
the group. This selects all of the slides between the first and the last slide selected.

•

Mouse – position the cursor slightly outside the first slide, then click and hold the left
mouse button and drag the cursor until all of slides required for the group are selected.

Figure 10: Example of Slide Sorter view in Workspace

Figure 11: Slide View toolbar
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Working in Slide Sorter view
Working with slides in Slide Sorter view is similar to working with slides in the Slide Pane. To
make changes, right-click on a slide in Slide Sorter view and choose one of the following in the
context menu:
•

Cut – removes the selected slide and saves it to the clipboard.

•

Copy – copies the selected slide to the clipboard without removing it.

•

Paste – inserts a slide from the clipboard after the selected slide.

•

New Slide – adds a new slide after the selected slide.

•

Duplicate Slide – creates a duplicate of the selected slide and places the new slide
immediately after the selected slide.

•

Rename Slide – renames the selected slide.

•

Hide Slide – any slides that are hidden are not shown in the slide show.

•

Delete Slide – deletes the selected slide.

•

Layout – allows changes to the layout of the selected slide.

•

Move – allows moving or repositioning the slide in the presentation order.

Creating presentations
By default, Impress opens with the Select a Template dialog displayed to select a template for a
new presentation. To create a new presentation without a template, click on Cancel in the Select
a Template dialog and a blank slide opens in the Workspace and Slides pane. For more
information on creating presentations, slide show options, and presentation settings, see the
Impress Guide.
To prevent the Select a Template dialog from opening, go to Tools > Options > LibreOffice
Impress > General on the Menu bar to open Options LibreOffice Impress General dialog
(Figure 12) and deselect the option Start with New Template Selection.

Figure 12: Options LibreOffice Impress General dialog

Tip
The first thing to do is decide on the purpose of a presentation and plan accordingly.
Having an idea of the audience type, the structure, the content, and how the
presentation will be delivered, will save a lot of time from the start.
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New presentation
When creating a new presentation, Impress shows only one slide in the Slides pane and
Workspace.

Inserting new slide
To insert a new slide into a presentation, use one of the following methods.
•

Go to Slide > New Slide on the Menu bar.

•

Right-click in the Slides pane and select New Slide in the context menu.

•

Use the keyboard shortcut Ctrl+M.

•

Go to Slide Sorter view in the Workspace, right-click on a slide and select New Slide in
the context menu.

•

Click on New Slide in the Presentation toolbar (Figure 13). If the Presentation toolbar is
not visible, go to View > Toolbars on the Menu bar and select Presentation in the
drop-down list.

Figure 13:
Presentation toolbar

Note
A new slide is inserted after the selected slide in the presentation. If a slide is not
selected, then the new slide is inserted as the last slide in the presentation.

Duplicating slides
To duplicate a slide, select a slide for duplication in the Slides pane and use one of the following
methods. A duplicate slide is inserted after the selected slide in the presentation.
•

Right-click on a slide in the Slides pane and select Duplicate Slide in the context menu.

•

Go to Slide Sorter view in the Workspace, right-click on a slide and select Duplicate
Slide in the context menu.

•

Go to Slide > Duplicate Slide on the Menu bar.

•

Click on the Duplicate Slide icon on the Presentation toolbar.

Slide format
Click on Properties on the Sidebar and open the Slide panel (Figure 14) to display the format
options available for a presentation. The Slide panel allows for quick formatting of all slides
included in a presentation and selecting master slides for a presentation. For more information
on formatting slides and using master slides, see the Impress Guide.

Slide layout
By default in Impress, the Title Slide layout is used for the first slide when a new presentation is
created. The layouts included in Impress range from a blank slide to a slide with six contents
boxes and a title. For more information on slide layouts and slide contents, see the Impress
Guide.
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Figure 14: Slide and Layouts panels in
Properties deck on Sidebar
The first slide in a presentation is normally a title slide. The layouts Title Slide, which also
contains a section for a subtitle, or Title Only are the most suitable layouts for the first slide in a
presentation. For the remaining slides, select the most suitable layout to use for the slide
contents.
Impress does not have the functionality to create custom layouts. However, the different
elements in a slide layout can be resized and moved. For more information, see the Impress
Guide.

Selecting slide layout
The available layouts are shown in the Layouts panel on the Properties deck on the Sidebar.
After selecting a slide, select the slide layout using one of the following methods:
•

Go to the Properties deck on the Sidebar to open the Layouts panel (Figure 14).

•

Click on Slide Layout on the Presentation toolbar to open a pop-up Layouts panel.

•

Click on Slide > Layout on the Menu bar to open a drop-down list showing the layouts by
name.

•

Right-click on the selected slide and select Layout in the context menu to open a
drop-down list of slide layouts.

Tip
To view the names for slide layouts, use the tooltip feature. Position the cursor on an
icon in the Layouts panel (or on any other tool icon) in the Properties deck on the
Sidebar and its name is displayed in a small rectangle.
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Changing slide layout
Change the slide layout for a slide in a presentation as follows:
1) Select a slide in the presentation.
2) Select a new layout for the slide using one of the methods described in “Selecting slide
layout” above.

Slide contents
Several layouts can contain one or more content boxes. Each of these content boxes can be
configured to contain the following elements. For more information on layout content boxes, see
the Impress Guide.
•

Slide title – click on Click to add Title and type a title in the text box. Impress enters text
editing mode and the Text Formatting toolbar automatically opens.

•

Text – click on Click to add Text and type the contents into the text box. Impress enters
text editing mode and the Text Formatting toolbar automatically opens.

•

Table – go to Insert > Table on the Menu bar and the Insert Table dialog opens. Enter
the number of columns and rows, then click OK. The dialog closes and a table is inserted
into the slide. Impress enters text editing mode and the Text Formatting and Table
toolbars automatically open.

•

Chart – go to Insert > Chart on the Menu bar and the Impress default chart is inserted in
the slide. The Chart Type panel opens in the Properties deck on the Sidebar allowing
editing of the chart to the presentation requirements.

•

Image – go to Insert > Image on the Menu bar and a file browser opens. Navigate to
where the required image is located. Select the file and click on Open. The image is
placed into the slide and the file browser closes. The Image panel opens in the
Properties deck on the Sidebar allowing editing of the image file.

•

Audio or video – go to Insert > Audio or Video on the Menu bar and a file browser
opens. Navigate to where the required audio or video file is located. Select the file and
click on Open. The audio or video file is inserted into the slide and the file browser
closes. The Media Playback toolbar opens allowing operation of the audio or video file.

Note
Text and graphic elements can be readjusted at any time during the preparation of a
presentation. However, changing slide layout that already has contents can have a
dramatic effect. If the layout is changed after contents have been added, the
contents are not lost, but they may need to be reformatted.

Modifying slide elements
When a slide is inserted into a presentation, it contains elements that were included in the
selected slide layout. However, it is unlikely that the predefined layouts will suit all requirements
for a presentation. Elements required maybe removed or objects inserted such as text and/or
graphics.
Although Impress does not have the functionality to create new layouts, it allows for the resizing
and moving of the slide elements. It is also possible to add slide elements without being limited
to the size and position of content boxes.
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Note
It is recommended that changes to slide elements in the layouts included in Impress
are only made using Normal view, which is the default. Attempting any changes to a
slide element when in Master view is possible, but may produce unpredictable
results and requires extra care as well as a certain amount of trial and error.

Moving contents box
1) Click on the outer frame of the contents box so that the selection handles are displayed.
2) Place the cursor on the frame so the cursor changes shape. This is normally a clenched
hand, but depends on the computer setup.
3) Click and drag the contents box to its new position on the slide, then release the mouse
button.

Resizing contents box
1) Click on the outer frame of the contents box so that the selection handles are displayed.
2) Place the cursor on the frame so that the cursor changes shape.
3) Click and drag the selection handle on the frame to resize the contents box, then release
the mouse button.
– Top and bottom selection handles change the height of a contents box.
– Left and right selection handles change the width of a contents box.
– Corner selection handles change width and height of a contents box.

Removing elements
1) Click a contents box or an element to highlight it and the selection handles are displayed.
2) Press the Delete or Backspace key to remove the contents box or element.

Adding text
There are two ways of adding text to a slide – contents box or text box. For more information,
see “Adding and formatting text” on page 22 and the Impress Guide.
•

Contents box – click Click to add Text in the contents box and type the text. Outline
styles are automatically applied to the text as it is inserted. If required, change the outline
level of each paragraph as well as its position within the contents box by using the arrow
buttons on the Outline toolbar and Workspace Outline view.

•

Text box – click on Insert Text Box on the Standard toolbar or Drawing toolbar to select
text mode, then click on the slide. A text box is created and the Text Formatting toolbar
automatically opens. Type the text and click outside the text box to end text mode.

Adding images or objects
To add images or objects to a slide, for example a picture, clipart, drawing, photograph, or
spreadsheet, click on Insert on the Menu bar and select in the drop-down menu the image or
object type required. See “Inserting images, tables, charts, or media” on page 30 and the
Impress Guide.

Modifying slide appearance
To change the background and other characteristics of all slides in the presentation, the master
slide has to be modified or a different master slide selected, as explained in “Working with master
slides” on page 35.
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Figure 15: Slide Properties dialog - Background page
A master slide has a specified set of characteristics that acts as a template and is used as the
starting point for creating other slides. These characteristics include slide background, objects in
the background, formatting of any text used, and any background graphics.
Impress has a range of master slides, which are found in the Master Slides deck on the Sidebar.
Additional master slides can be created or and saved, or added from other sources. See the
Impress Guide for more information.
For example, to change the background of an individual slide or a master slide:
1) Right click on a slide or master slide and select Slide Properties in the context menu to
open the Slide Properties dialog (Figure 15).
2) Select the Background tab and then select the type of background to use from None,
Color, Gradient, Bitmap, Pattern and Hatch.
3) Make a selection from the various properties that are available for each type of
background.
4) Click OK to save the change and close the dialog.
For more information on inserting, formatting, and changing a background, see the Impress
Guide or Draw Guide.

Modifying presentations
By default, a presentation displays all the slides in the same order as they appear in Slide Sorter
view on the Workspace. It is recommended to review the entire presentation and answer some
questions. Run the presentation at least once, then answer the following questions. Also there
maybe more questions after running a presentation for the first time, for example:
•

Are the slides in the correct order? If not, some of the slides have to be moved.

•

Is the information well spaced and visible to members of an audience at the back of a
large room? The audience may not be able to see information at the bottom of a slide, so
redesign the presentation to fit the top three-quarters of a screen.
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•

Would an additional slide make a particular point clearer? If so, create another slide.

•

Are some of the slides unnecessary? Hide or delete the slides not required.

•

Would animations help some of the slides? This is considered an advanced technique.

•

Should some of the slides have a different slide transition than others? The transition of
those slides should be changed.

Once the questions have been answered, make the necessary changes. Making changes can be
carried out in Slide Sorter view on the Workspace. For more information on running a
presentation, see the Impress Guide.

Adding and formatting text
Most of the slides in a presentation are likely to contain some text. This section gives some
guidelines on how to add text and change its appearance. Text used in slides is contained in text
boxes. For more information on adding and formatting text, see the Impress Guide.
Two types of text boxes (AutoLayout text box and text box) are available in Impress for use on
slides. Both types of text boxes can be moved, resized, and deleted.
•

Choose a predefined layout from the Layouts panel on the Properties deck on the
Sidebar and do not select any special content type. These text boxes are called
AutoLayout text boxes.

•

Use Insert Text Box for horizontal text, or Insert Vertical Text for vertical text on the
Standard toolbar, Drawing toolbar, or Text toolbar (Figure 16) to create text boxes on a
slide.

•

Use the keyboard shortcut F2 to create text boxes on a slide for horizontal text.

When adding and formatting text, the Text Formatting toolbar (Figure 17) normally opens,
automatically providing a range of tools to add and format text.

Note
If the toolbars are not visible, go to View > Toolbars on the Menu bar and select the
required toolbars in the drop-down list.

Note
The area fill and borders in AutoLayout text boxes and text boxes can be edited
using the same methods that are used for graphic objects. For more information, see
the Impress Guide.

Figure 16: Text toolbar

Figure 17: Text Formatting toolbar
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AutoLayout text boxes
AutoLayout text boxes are automatically created when one of the slide layouts available in
Impress is selected.
1) Make sure Normal view is selected in the Workspace.
2) Select the slide where text is to be added into an AutoLayout text box.
3) Click on Click to add Title or Click to add text in an AutoLayout text box. The text
automatically disappears and is replaced by a flashing text cursor. The Text Formatting
toolbar automatically opens replacing the Line and Filling toolbar.
4) Type or paste text into the AutoLayout text box and, if necessary, format the text to the
presentation requirements.
5) Click outside the AutoLayout text box to deselect it.

Text boxes
1) Make sure Normal view is selected in the Workspace.
2) Select the slide where the text is to be added.
3) For horizontal text: click on the selected slide and create a text box using one of the
following methods:
– Single line text box: select Insert Text Box, click on the slide and then type or paste
the text. The width of the text box increases as text is added creating a single line of
horizontal text.
– Single line text box: use the keyboard shortcut F2, click on the slide and then type or
paste the text. The width of the text box increases as text is added creating a single
line of horizontal text.
– Multiple line text box: select Insert Text Box, or use the keyboard shortcut F2, click
on the slide and drag to the approximate width required for the text box, then type or
paste the text into the text box. The width of the text box is fixed and the height of the
text box increases automatically as text is added creating multiple lines of horizontal
text.
– Multiple line text box from a single line text box: use the Enter key to create a new
paragraph, or the keyboard combination Shift+Enter to create a line break in the text.
4) Release the mouse button and the cursor appears in the text box, which is now in edit
mode and indicated by a colored border (Figure 18). The width and final position of the
text box can be adjusted after adding text into the text box.
5) Click outside the text box to deselect it.

Figure 18: Example of a text
box in edit mode

Vertical text
In addition to normal text boxes where text is horizontally aligned, it is possible to insert text
boxes where the text is vertically aligned. Vertical text is available only when Asian languages are
enabled in Tools > Options > Language Settings > Languages.
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Creating vertical text boxes is similar to creating horizontal text boxes. Use the Insert Vertical
Text tool on the Standard, Drawing, or Text toolbars to create a vertical text box with single or
multiple lines. The height of the text box is fixed and the width of a vertical text box increases
automatically as text is added to a multi-line text box.

Quick font resizing
To quickly increase or decrease the font size of selected text by using the tools Increase Font
Size (Ctrl+]) (macOS ⌘+]) and Decrease Font Size (Ctrl+[) (macOS ⌘+[) on the Text Formatting
toolbar. The amount by which the font size changes depends on the standard sizes available for
the font in use.

Note
AutoLayout text boxes automatically adjust font size of any text inserted into the box.
For example, if a long piece of text is inserted into an AutoLayout text box, the font
size may decrease in size to fit into the box.

Pasting text
Text can be added to an AutoLayout or normal text box by copying it from another document and
pasting it into Impress. However, the formatting of the pasted text will probably not match the
formatting of the surrounding text or that of the other slides in the presentation. This may be what
is required on some occasions. However, to make sure that the presentation style is consistent
and does not become a patchwork of different styles, font types, bullet points, and so on, the text
has to be formatted to match the rest of the presentation.

Unformatted text
It is good practice to paste text without formatting and apply the formatting later.
1) Highlight and copy the text from another document or slide.
2) Create a text box on a slide and make sure the text cursor is flashing in the text box.
Alternatively, select an AutoLayout text box on a slide. See “Text boxes” on page 23 and
see “AutoLayout text boxes” on page 23 and the Impress Guide for more information.
3) Paste unformatted text into the text box using one of the following methods. Text is
pasted at the cursor position in the text box formatted using the Default Drawing Style or
Presentation Style if text was pasted into an AutoLayout text box.
– Go to Edit > Paste Special > Paste Unformatted Text on the Menu bar.
– Click on the triangle ▼to the right of the Paste tool on the Standard toolbar and select
Unformatted Text in the context menu.
– Use the keyboard shortcut Ctrl+Shift+V (macOS ⌘+Shift+V) and select Unformatted
text on the dialog that opens.
4) Format the text to the presentation requirements using the tools on the Text Formatting
toolbar or the options in Format on the Menu bar.

Note
The Presentation style used in AutoLayout text boxes cannot be changed by
selecting another presentation style. Make sure the AutoLayout text box uses the
presentation style required. Change outline levels and outline styles using the Tab
key or Shift+Tab key combination. See the Impress Guide for more information.
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AutoLayout text box formatting of pasted text
If text is being pasted into an AutoLayout text box, the appropriate outline style has to be applied
to the text giving it the same look and feel as the rest of the presentation.
1) Highlight and copy the text from another document or slide.
2) Paste the text into the AutoLayout text box, then select the pasted text.
3) Select Format > Clear Direct Formatting on the Menu bar, or use the keyboard shortcut
Ctrl+Shift+M (macOS ⌘+Shift+M) to make sure any formatting is removed from the
pasted text.
4) Use the four arrow buttons on the Outline toolbar to move the text to the appropriate
position and give it the appropriate outline level.
– Left arrow promotes a list entry by one level (for example from Outline 3 to Outline 2).
Alternatively, place the cursor at the beginning of the paragraph and use the Shift+Tab
keys.
– Right arrow demotes a list entry by one level. Alternatively, place the cursor at the
beginning of the paragraph and use the Tab key.
– Up arrow moves a list entry up in the list order.
– Down arrow moves a list entry down in the list order.
5) If necessary, modify the presentation style to format the text to the presentation
requirements to change font attributes, tabs, and so on. See the Impress Guide for more
information. Alternatively, apply any necessary manual or direct formatting to the text.

Text box formatting of pasted text
Pasting formatted text into a text box overwrites any formatting and replaces the text box style.
1) Highlight and copy the text from another document or slide.
2) If necessary, create a text box on a slide and make sure the text cursor is flashing in the
text box. See “Text boxes” on page 23 and the Impress Guide for more information.
3) Paste formatted text into the text box. Text is pasted at the cursor position in the text box
and the text formatting of the pasted text overwrites any style formatting of the text box.
4) Select Format > Clear Direct Formatting on the Menu bar or use the keyboard shortcut
Ctrl+Shift+M (macOS ⌘+Shift+M) to make sure any formatting is removed from the
pasted text.
5) Select the required drawing style to format the text from the available drawing styles.
6) If necessary, modify a drawing style or create a new drawing style to format the text to the
presentation requirements. See the Impress Guide for more information.

Note
Drawing styles can be created in Impress and are only available for the presentation
which is being created and has been saved. Templates can also be created that
include any drawing styles required. For more information, see the Impress Guide.

Creating lists
The procedure to create an unordered (bulleted) or ordered (numbered) list varies depending on
the type of text box used. The tools to manage and format a list are the same. To change the
appearance of a list, see Changing list type” on page 27.
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Figure 19: Example of outline levels in AutoLayout text
box

AutoLayout text boxes
In AutoLayout text boxes and by default, the outline styles available are unordered lists. An
example of these outline styles is shown in Figure 19. These outline styles are presentation
styles and cannot be deleted, but can be modified or updated to the presentation requirements.
See the Impress Guide for more information.
Create a slide using an AutoLayout text box with an unordered list as follows:
1) Go to View > Normal on the Menu bar to open Normal view.
2) Select a layout for the slide using one of the following methods:
– Right-click in a blank area on the slide and select a layout in the context menu.
– Go to Slide > Layout on the Menu bar and select a layout in the drop-down list.
– Select a layout in the Layouts panel on the Properties deck in the Sidebar.
3) Click on the text ● Click to add Text and start typing the first list item.
4) Press Enter to start a new list point or use the keyboard combination Shift+Enter to start a
new line without creating a new list point. The new line will have the same indentation as
the list point.

Tip
To switch off bullets altogether, click on Toggle Unordered List on the Text
Formatting toolbar.

Changing outline level
In AutoLayout text boxes, change the outline level as follows:
1) To demote the outline level of a list point, use one of the following methods:
– Press the Tab key.
– Click on Demote on the Outline toolbar.
– Click on Demote in the Lists panel on the Properties deck in the Sidebar.
– Go to Format > Lists on the Menu bar and select Demote in the submenu.
– Use the keyboard shortcut Alt+Shift+Right Arrow (macOS ⎇+Shift+Right Arrow)
2) To promote the outline level of a list point, use one of the following methods:
– Use the keyboard shortcut Shift+Tab.
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– Click on Promote on the Outline toolbar.
– Click on Promote in the Lists panel on the Properties deck in the Sidebar.
– Go to Format > Lists on the Menu bar and select Promote in the submenu.
– Use the keyboard shortcut Alt+Shift+Left Arrow (macOS ⎇+Shift+Left Arrow)
3) To move a list point lower or higher in the list order without changing the outline level, use
one of the following methods:
– Click on Move Down or Move Up on the Outline toolbar.
– Click on Move Down in the Lists panel on the Properties deck in the Sidebar.
– Go to Format > Lists on the Menu bar and select Move Down or Move Up in the
submenu.
– Use the keyboard shortcut Alt+Shift+Down Arrow (macOS ⎇+Shift+Down Arrow) or
Alt+Shift+Up Arrow (macOS ⎇+Shift+Up Arrow).

Note
In AutoLayout text boxes, promoting or demoting an item in the list corresponds to
applying a different outline style. The second outline level corresponds to Outline 2
style, the third outline level to Outline 3 style, and so on. A change in level and style
produces other changes, for example, to font size, bullet type, and so on.

Text boxes
Create an unordered or ordered list in a text box as follows:
1) Create a text box on a slide and make sure the cursor is flashing in the text box. See
“Text boxes” on page 23 on how to create a text box.
2) Create a list using one of the following methods:
– Click on Toggle Unordered List or Toggle Ordered List on the Text Formatting
toolbar.
– Click on Toggle Unordered List or Toggle Ordered List in the Lists panel on the
Properties deck in the Sidebar.
– Go to Format > Lists on the Menu bar and select Unordered List or Ordered List in
the submenu.
3) Type the text and press Enter to start a new list point or use the keyboard combination
Shift+Enter to start a new line without creating a new list point. The new line will have the
same indentation as the list point.
4) To increase or decrease the indent level of a list point, or move a list point up or down,
see “Changing outline level” on page 26.

Changing list type
The list type can be changed for an unordered or ordered type for the entire list or for a single
point only as follows:
1) Select a point in a list, or select the entire list in the text box. Alternatively, click on the
border of the text box so that the resizing handles are displayed to select the entire list.
2) Change the list type from unordered to ordered list, or ordered to unordered as described
in “Text boxes” above.
3) If required, change the type of bullet or number used for the list:
a) Click on the triangle ▼ to the right of the Toggle Unordered List or Toggle Ordered
List on the Text Formatting toolbar or the Lists panel on the Properties deck in the
Sidebar.
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b) Select a bullet or number type from the options available in the drop-down window as
shown in Figure 20.
c) If necessary, click on More Bullets or More Numbering in the drop-down window to
open the Bullets and Numbering dialog for further options to change the list
appearance. See the Impress Guide for more information.

Figure 20: Available types for bullet and number lists

Changing bullet or number format
The bullet or number format used in a list can be changed for the entire list or for a single point
only as follows:
1) Select a point in a list, or select the entire list in the text box. Alternatively, click on the
border of the text box so that the resizing handles are displayed to select the entire list.
2) Click on the triangle ▼ to the right of the Toggle Unordered List or Toggle Ordered List
on the Text Formatting toolbar or the Lists panel on the Properties deck in the Sidebar to
open a drop-down dialog displaying the format options available.
3) Select a bullet or number type from the options available in the drop-down window as
shown in Figure 20.
4) If necessary, click on More Bullets or More Numbering in the drop-down window to
open the Bullets and Numbering dialog for further options to change the list appearance.
See the Impress Guide for more information.

Note
The Bullets and Numbering dialog can also be opened by going to Format > Bullets
and Numbering on the Menu bar, or by right-clicking on a list point and selecting
Bullets and Numbering in the context menu.

Note
If a list was created in an AutoLayout text box, then the Outline styles can be
modified to change the list type and/or format. Changes made to an Outline style
apply to all the slides that use that style. For details, see the Impress Guide.

Text columns
Text in a presentation can be formatted into columns inside text boxes and objects. However,
columns cannot be used on separate parts of text inside a text box or object. The whole of the
text box or object has to be used for columns.
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Figure 21: Text dialog - Text Columns page

Figure 22: Columns panel in Properties deck on
Sidebar
The type of columns used in Impress are continuous flow columns. This means that when text
reaches the bottom of a column, it automatically flows into the next column as text is added. This
type of columns is also known as newspaper columns.
Columns in text boxes and graphic objects are created as follows:
1) For text boxes – click the border of a text box to select it so that the selection handles are
displayed indicating that the text box is in edit mode.
2) For graphic objects – double-click on a graphic object to select it so that the selection
handles are displayed and the cursor flashes in the center of the object indicating that the
object is in text edit mode.
3) Open the options for text columns using one of the following methods:
– Right-click in the text box or graphic object and select Text Attributes in the context
menu to open the Text dialog, then click on the Text Columns tab to open the Text
Columns page (Figure 21),
– Click on Columns in Properties on the Sidebar to open the Columns panel
(Figure 22).
4) Set the number of columns required in the Number of columns box and the required
spacing between the columns in the Spacing box.
5) Save the changes and deselect the text box or graphic object using one of the following
methods:
– For the Text dialog, click OK to save the changes and close the dialog, then click
outside the text box to deselect it.
– For the Columns panel in the Properties deck on the Sidebar, click outside the text
box or graphic object to deselect it and save the changes.
6) Type in the required text or use copy and paste to enter the required text into the text box
or graphic object. Any text entered will be in column format.
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7) If necessary, format the text to the presentation requirements.
8) Click outside the text box or graphic object to deselect it and save the changes.

Note
Any text inside a text box or graphic object automatically flows into column format
when the changes are saved.

Inserting images, tables, charts, or media
A contents box on a slide can contain images, tables, charts, or media as well as text. The Insert
toolbar (Figure 23) provides quick access to relevant tools. This section provides an overview of
how to work with these objects. For more information, see the Impress Guide.

Inserting images
1) Open the slide in Normal view on the Workspace where the image is going to be
inserted.
2) Open the Insert Image file browser using one of the following methods:
– Go to Insert > Image on the Menu bar.
– Click on Insert Image on the Insert toolbar (Figure 23).
– Click on Insert Image on the Standard toolbar.
3) Navigate to the location of the file and select the image file required.
4) Click Open to place the image in the center of the slide.
5) Reposition and resize the image to the presentation requirements.

Figure 23: Insert toolbar

Inserting tables
When a table is inserted into a slide, the Table toolbar (Figure 24) automatically opens. This
toolbar in Impress offers the same functions as the Table toolbar in Writer, with the exception of
the calculation functions Sort and Sum. To use Sum and Sort in a presentation, a Calc
spreadsheet has to be inserted into the slide.

Note
If the Table toolbar does not automatically open, go to View > Toolbars on the Menu
bar and select the Table toolbar.

Figure 24: Table toolbar
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Entering data into table cells is similar to working with text box objects. Click in a cell and begin
typing. To move around cells quickly, use the following keyboard options:
•

Use the arrow keys to move the cursor to another cell if the cell is empty, or to the next
character if the cell already contains text.

•

Press the Tab key to move to the next cell on the right and press Shift+Tab to move to the
next cell on the left.

Using the Menu bar
1) Open the slide in Normal view on the Workspace and go to Insert > Table on the Menu
bar to open the Insert Table dialog (Figure 25).
2) Select the Number of columns and the Number of rows required for the table.
3) Click OK to place the table in the center of the slide and close the Insert Table dialog.
4) The Table Design panel on the Properties deck on the Sidebar opens (Figure 26). Select
a table design, the type of rows, and the type of columns required.
5) If necessary, reposition and format the table on the slide to the presentation
requirements.

Figure 25: Insert Table dialog

Figure 26: Table Design panel in
Properties deck on Sidebar

Inserting images, tables, charts, or media | 31

Figure 27: Insert Table grid

Using Insert or Standard toolbar
1) Open the slide in Normal view on the Workspace and click on Table on the Insert toolbar
or the Standard toolbar to open the Insert Table grid (Figure 27).
2) Click and drag the cursor to create the number of columns and rows required.
3) Click the mouse button to place the table in the center of the slide and the Insert Table
grid closes.
4) The Table Design panel on the Properties deck in the Sidebar opens (Figure 26). Select
a table design, the type of rows, and the type of columns from the options available.
5) If necessary, reposition and format the table on the slide to the presentation
requirements.

Note
Select More Options at the bottom of the Insert Table grid (Figure 27) to open the
Insert Table dialog (Figure 25) where the number of rows and columns required can
be selected.

Inserting charts
To insert a chart into a selected slide in Normal view on the Workspace, use one of the following
methods:
•

Go to Insert > Chart on the Menu bar.

•

Click on Insert Chart on the Insert toolbar.

•

Click on Insert Chart on the Standard toolbar.

Impress switches to chart view, the Formatting toolbar (Figure 28) automatically opens, and the
Chart Type panel on the Properties deck on the Sidebar opens (Figure 29). To change the chart
type, insert the required data, and change the formatting, see the Impress Guide and the Calc
Guide.
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Figure 28: Formatting toolbar

Figure 29: Chart Type panel in the
Properties deck on the Sidebar

Figure 30: Gallery deck on Sidebar
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Inserting audio or video
Using file browser
1) Go to Insert > Audio or Video on the Menu bar, or click on Insert Audio or Video on the
Insert toolbar and the Insert Audio or Video file browser opens.
2) Navigate to the folder where the file is located and select the audio or video file you want
to insert onto a slide. Only the audio and video files that are compatible with Impress will
be highlighted in the file browser.
3) Click Open to place the audio or video file in the center of the slide. The Media Playback
toolbar opens while the audio or video file is selected.
4) Reposition and/or resize the audio or video file. See the Impress Guide for more
information.

Using the Gallery
1) If the Gallery deck (Figure 30) is not already open, use one of the following methods:
– Go to View > Sidebar on the Menu bar to open the Sidebar, then select Gallery.
– Go to View > Gallery on the Menu bar.
2) Browse to a category containing media files, for example Sounds.
3) Click on the audio or video file required and drag it onto the slide. The Media Playback
toolbar automatically opens.
4) Reposition and/or resize the audio or video file. See the Impress Guide for more
information.

Inserting graphics, spreadsheets, and OLE objects
Graphics
Graphics, such as shapes, callouts, and arrows, are often useful to complement the text on a
slide. These objects are handled much the same way as graphics in Draw. For more information
on inserting graphics, see Chapter 7, Getting Started with Draw in this guide, the Impress Guide,
or the Draw Guide.

Spreadsheets
Spreadsheets embedded in Impress include most of the functionality of Calc spreadsheets and
are capable of performing complex calculations and data analysis. If the data has to be analyzed
or formulas applied, then these operations are best performed in a Calc spreadsheet and the
results displayed in an embedded Calc spreadsheet or in an Impress table. For more information
on spreadsheets, see the Impress Guide and the Calc Guide.

OLE objects
Object Linking and Embedding (OLE) is a software technology that allows linking and embedding
of spreadsheets, charts, drawings, formulas, and text files into an Impress presentation.
The major benefit of using OLE objects is that it provides a quick and easy method of editing the
object using tools from the software used to create the object. These file types can all be created
using LibreOffice and OLE objects can be created from new or from an existing file.
When inserting a new OLE object into a presentation, it is only available in that presentation and
can only be edited using Impress. For more information on inserting and formatting OLE objects,
see the Impress Guide.
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Working with master slides
A master slide is a slide that is used as the starting point for other slides. It is similar to a page
style in LibreOffice Writer as it controls the basic formatting of all slides based on it. A
presentation can have more than one master slide.
A master slide has a defined set of characteristics, including the background color, graphic, or
gradient. It also can include objects (for example, logos, decorative lines) in the background;
headers and footers; placement and size of text frames; and text formatting.

Styles
All of the characteristics of master slides are controlled by styles. The styles of any new slide
created are inherited from the master slide from which it was created. In other words, the styles
of the master slide are available and applied to all slides created from that master slide.
Changing a style in a master slide results in changes to all the slides based on that master slide.
It is possible to modify each individual slide without affecting the master slide.
Master slides have two types of styles: presentation styles and drawing styles. The presentation
styles included with Impress can be modified, but new presentation styles cannot be created or
deleted. The drawing styles included with Impress can be modified, but cannot be deleted.
However, new drawing styles can be created and these drawing styles can be deleted.

Note
It is highly recommended to use the master slides whenever possible. However,
there are occasions where manual changes are needed for a particular slide, for
example editing an individual slide to enlarge the chart area when the text and chart
layout is used.

Master slides
Impress comes with a collection of master slides, which are are shown on the Master Slides deck
of the Sidebar (Figure 31).

Figure 31: Master Slides deck on Sidebar
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Figure 32: Default master slide
This deck has three panels: Used in This Presentation, Recently Used, and Available for
Use. Click the expand marker on the title bar of a panel to expand it and show thumbnails of the
master slides, or click the collapse marker to collapse the panel to hide the thumbnails.
Each of the master slides shown in the Available for Use panel is from a template of the same
name. These presentation templates are included when LibreOffice is installed on a computer. If
templates have been created or added from other sources, master slides from those templates
also appear in this list.
If a new presentation is created without using one of the templates available, then a default
master slide is available. This default master slide is a good starting point for creating master
slides. An example of the default master slide is shown in Figure 32.

Creating master slides
1) Go to View > Master Slide on the Menu bar to open Master view in the Workspace. The
Master View toolbar also opens (Figure 33). If the Master View toolbar does not open, go
to View > Toolbars on the Menu bar and select Master View.
2) Create a new master slide using one of the following methods. The new master slide
appears in the Slides pane:
– Click on New Master in the Master View toolbar.
– Right-click on a master slide in the Slides pane and select New Master in the context
menu.
– Go to Slide > New Master on the Menu bar.
3) Rename the new master slide using one of the following methods to open the Rename
Master Slide dialog:
– Click on Rename Master on the Master View toolbar.
– Right-click on the new master slide in the Slides Pane and select Rename Master in
the context menu.

Figure 33: Master
View toolbar
4) Enter a memorable name for the new master slide, then click OK to save the changes
and close the dialog.
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5) Make sure the new master slide is selected in the Slides pane and add all the text,
graphics and master elements that are required. For more information on adding, editing,
formatting and managing the different types of objects on a master slide, see the Impress
Guide.
6) When the new master slide has been created, use one of the following methods to return
to Normal view:
– Click Close Master View on the Master View toolbar.
– Go to View > Normal on the Menu bar.
7) Save the presentation file before continuing.

Applying master slides
To apply a master slide to all slides or selected slides in a presentation:
1) Click on Master Slides on the right of the Sidebar to open the Master Slides deck.
2) Right-click on the required master slide in the Used in This Presentation panel.
3) Select Apply to All Slides or Apply to Selected Slides in the context menu.

Loading additional master slides
In a presentation, it may be necessary to mix multiple master slides that belong to different
templates (for more information on templates, see the Impress Guide). For example, a
completely different layout for the first slide of the presentation maybe required, or a slide from a
different presentation maybe added to the current presentation.
1) Select the slide or slides on the Slides pane where the master slide is to be changed.
2) Go to Slide > Change Slide Master on the Menu bar to open the Available Master Slides
dialog (Figure 34).

Figure 34: Available Master Slides dialog
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Figure 35: Load Master Slide dialog
3) To add master slides, click on Load to open the Load Master Slide dialog (Figure 35).
4) In the Load Master Slide dialog, select the template category and the template from
which to load the master slide
5) Click OK to close the Load Master Slide dialog and the master slides from the selected
template appear in the Available Master Slides dialog.
6) In the Available Master Slides dialog, select the master slide required in the Select a Slide
Design box.
7) To apply the selected master slide to all slides in the presentation, select the Exchange
background page check box. To apply the slide design to the selected slides only,
deselect the Exchange background page check box.
8) Click OK to apply the selection to the slides and close the dialog.

Note
The master slides in the template selected are now shown in the Available for use
panel on the Master Slides deck on the Sidebar.

Modifying master slides
The following items can be changed on a master slide. For more information, see the Impress
Guide:
•

Background (color, gradient, hatching, or bitmap).

•

Background objects (for example, adding a logo or decorative graphics).

•

Text attributes for the main text area and notes.

•

Size, placement, and contents of header and footer elements to appear on every slide.

•

Size and placement of default frames for slide titles and content.

To modify a master slide, follow these steps:
1) Select View > Master Slide on the Menu bar. This also opens the Master View toolbar.
2) Select a master slide for editing in the Slides pane so that it appears in the Workspace.
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Figure 36: Slide Properties dialog - Slide page
3) Go to Slide > Slide Properties on the Menu bar or right-click in the Workspace and
select Slide Properties in the context menu to open the Slide Properties dialog
(Figure 36).
4) Use the various options in the Slide, Background, and Transparency pages in the Slide
Properties dialog to make changes to the format of the master slide.
5) Click OK to save the changes and close the Slide Properties dialog.
6) Select an object on the master slide, then right-click on the object to open a context
menu.
7) Select one of the options in the context menu to edit the object. Selecting an option may
open another context menu, a dialog, an application or file browser window to make the
necessary changes to the selected object.
8) Click Close Master View on the Master View toolbar or go to View > Normal on the
Menu bar to exit from editing master slides.
9) Save the presentation file before continuing.

Note
Any changes made to one slide when in Master Slide mode appears on all slides
using this master slide. Always make sure to close Master Slide and return to
Normal view before working on any of the presentation slides.

Note
The changes made to an element on a slide in Normal view is not overridden by
subsequent changes to the master slide. There are cases, however, where it is
desirable to change a manually modified element of a slide to the style defined in the
master slide. To change to default formatting, select the element and select Format
> Clear Direct Formatting on the Menu bar.
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Adding text, footers, and fields to master slides
Text, footers, or fields can be added to a master slide so those elements appear on every slide in
a presentation. Headers are not normally added to slides.

Text
1) Go to View > Master Slide on the Menu bar to open Master View.
2) Insert a text box on the master slide, see “Text boxes” on page 23 for more information.
3) Type or paste the text into the text box.
4) Click outside the text box when finished adding text.
5) Go to View > Normal on the Menu bar or click Close Master View on the Master View
toolbar when finished.

Default footers
By default, a slide footer consists of three sections, each containing a default field:
•

Left section – date and time, labelled Date Area. Field name is <date/time>.

•

Center section – footer text, labelled Footer Area. Field name is <footer>. This section
could be the presentation title, file name, or other information.

•

Right section – slide number, labelled Slide Number Area. Field name is <number>.

The default footer fields are set up as follows using the Header and Footer dialog (Figure 37):
1) Go to View > Master Slide on the Menu bar to open Master View.
2) Go to Insert > Header and Footer on the Menu bar to open the Header and Footer
dialog.

Figure 37: Header and Footer dialog - Slides page
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3) Click on the Slides tab to open the options available for inserting footers onto a slide.
4) Select Date and Time for the date and time to appear in the left section of the footer.
– For a fixed date and time, select Fixed and enter the date required in the Fixed text
box.
– For a variable date and time, select Variable, then select the format and language in
the Format and Language drop-down lists. Using a variable date and time means that
each time the presentation is opened, the date and time are updated.
5) To place text in the footer center section, select Footer and then type or paste the text
into the Footer text input field.
6) To place the slide number in the right section of the footer, select Slide number.
7) If the footer is not going to appear on the first slide of a presentation, select Do not show
on the first slide. The first slide is normally the title slide of a presentation.
8) Click Apply to save the changes and close the Header and Footer dialog.
9) To format the text used for the default footer fields, see the Impress Guide.
10) Click Close Master View on the Master View toolbar or go to View > Normal on the
Menu bar when setting up the default footer fields is completed.

Note
The default sections in a footer can be formatted, resized, and repositioned. See
“Adding and formatting text” on page 22 for more information.

Custom footers
The default fields in a footer section can be replaced with text or manual fields as follows:
1) Go to View > Master Slide on the Menu bar to open the master slide view.
2) Highlight the default field in the footer section and press the Delete or Backspace key. A
flashing text cursor will appear in the footer section and the Text Formatting toolbar
automatically opens replacing the Line and Filling toolbar.
3) Type in the required text or insert a manual field into the footer section. For more
information, see “Manual fields” on page 41.
4) Format the text or manual field placed in the footer section. See “Adding and formatting
text” on page 22 and the Impress Guide for more information.
5) Click outside the footer section to close the Text Formatting toolbar and reopen the Line
and Filling toolbar.
6) Click Close Master View on the Master View toolbar or go to View > Normal on the
Menu bar when setting up a custom footer section is completed.

Manual fields
Manual fields can be added as text objects on a master slide or replace one of the default footer
fields and are as follows:
•
•
•
•
•
•
•

Date (fixed)
Date (variable) – updates automatically each time the presentation is opened.
Time (fixed)
Time (variable) – updates automatically each time the presentation is opened and each
time a slide is opened more than once during a presentation.
Author – first and last names listed in the LibreOffice user data.
Slide number – the sequence number of the slide, without the word “Slide”.
Slide Title – defaults to Slide 1, Slide 2, and so on if the slides have not been renamed.
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•
•

Slide Count – the number of slides in the presentation.
File Name

Tip
To change the author information, go to Tools > Options > LibreOffice > User Data
on the Menu bar.

Adding comments
Impress supports comments similar to those in Writer and Calc. For more about adding,
navigating, and replying to comments, see Chapter 4, Getting Started with Writer.
Before using comments, make sure that the user name and initials are entered into Tools >
Options > LibreOffice > User Data. The name and initials then appear in the comment marker
and in the Author field of the comment. If more than one person edits the document, each person
is automatically allocated a different background color.
1) In Normal View, go to Insert > Comment on the Menu bar or use the keyboard shortcut
Ctrl+Alt+C to open a blank comment (Figure 38).
A small box containing the user initials appears in the upper left-hand corner of the slide,
with a larger text box beside it. Impress automatically adds the user name and current
date at the bottom of the text box.
2) Type or paste the comment into the text box.
3) Move the small comment markers to the required position on the slide. Normally, this is
on or near the text or object being referred to in the comment.
4) To show or hide the comment markers, choose View > Comments on the Menu bar.
5) Select Tools > Options > LibreOffice > User Data to configure the name and initials
that appear in comments.

Figure 38: Adding a comment
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Figure 39: Example of Master Handout layout

Figure 40: Header and Footer dialog - Notes and Handouts page
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Figure 41: Example of Print dialog – LibreOffice Impress page

Printing handouts
Handouts are used for distributing copies of presentation slides to each member of the audience.
Handouts are only available in View > Handout on the Menu bar and are printed using the
printing options in Impress.
The printing of handouts depends on the printer, computer operating system, and how a
computer is set up. The following is only an example of how to print handouts.
1) Go to View > Master Handout on the Menu bar to open the Master Handout layout in the
Workspace. An example Master Handout is shown in Figure 39.
2) Go to Insert > Header and Footer on the Menu bar to open the Header and Footer
dialog (Figure 40).
3) Click on Notes and Handouts tab, the select the required header and footer options as
follows:
Select Header and then enter text in the Header text: text box.
Select Date and time and then select either Fixed or Variable for the date and time.
If a fixed date and time was selected, enter the date and/or in the text box.
If a variable date and time was selected, select the Format for the date and time in the
drop-down list.
– If a variable date and time was selected, select the Language to set the options for
the date and time format in the drop-down list.
– Select Footer and then enter text in the Footer text: text box.
– Select Page Number if you want the handout pages numbered.
4) Click on Apply to All to save the options for the handouts and close the Header and
Footer dialog.
–
–
–
–
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5) Go to File > Print on the Menu bar or use the keyboard shortcut Ctrl+P (macOS ⌘+P) to
open the Print dialog and click on the LibreOffice Impress tab to open the page for
printing options of handouts. An example Print dialog is shown in Figure 41.
6) In Document, select the required options in the drop-down lists as follows:
– Type: – select Handouts in the drop-down list.
– Slides per page: – select how many slides are printed on a sheet of paper.
– Order: – select the order in which the slides are printed on a sheet of paper.
7) In Contents, select Slide name, Date and time, and/or Hidden pages if these items are to
be printed.
8) In Color, select how the handouts are printed.
9) In Size, select the size for how the handouts are printed.
10) Click on Print to print the handouts and close the Print dialog.

Creating a photo album
Impress can create a photo album from a set of photographs and images. The photo album can
be a multimedia show with vacation pictures and/or graphics and images as a presentation file.
1) Create a new presentation or open an existing presentation.
2) Select the slide that is going to precede the photo album. In a new presentation, this will
be the first slide.
3) Go to Insert > Media > Photo Album on the Menu bar to open the Create Photo Album
dialog (Figure 42).
4) Click on Add to open a file browser and navigate to the folder where the images are
located.
5) Select the images required and click Open. This closes the file browser and the selected
files appear in the Create Photo Album dialog.

Figure 42: Create Photo Album dialog
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6) Select the number of images per slide in the Slide layout: drop-down list.
7) If required, select Add caption to each slide. This inserts a text box on each slide allowing
captions to be added to the images.
8) If required and there is only one image per slide, select Fill Screen for each image to fill
the entire slide.
9) Create the required sequence of photos or pictures by moving image files up or down in
the list of images.
10) When the sequence of images is ready, click Insert Slides to create the number of slides
required for the photo album. The sequence can be changed later.
11) If required, copy and paste images between slides as with any other elements that can be
placed on a slide.
12) If required, set up the photo album to run as a presentation. See “Presentations (slide
shows)” below, “Running presentations” on page 51, and the Impress Guide.

Presentations (slide shows)
Impress allocates reasonable default settings for presentations, while at the same time allowing
for customizing many aspects of the presentation experience. This section provides an
introduction to presentations. For more information on creating, formatting and running
presentations, see the Impress Guide.
Most of the tasks are best done in Slide Sorter view in the Workspace where the majority of the
slides in a presentation can be viewed. Go to View > Slide Sorter on the Menu bar or click on
the Slide Sorter tab at the top of the Workspace.

Multiple presentations – single set of slides
There may be more slides than the time available for a presentation, or only a brief overview is
required first and then a more detailed presentation at a later date. Impress provides two tools
for this: hiding slides and custom slide shows.

Hiding slides
1) Select slides for hiding in the Slides pane or Slide Sorter view in the Workspace.
2) Hide the selected slides using one of the following methods. Hidden slides are greyed out
in the Slides pane or Slide Sorter view in the Workspace.
– Go to Slide > Hide Slide on the Menu bar.
– Right-click on the slide thumbnail and select Hide Slide in the context menu.
– Click on Hide Slide in the Slide View toolbar.
3) To show a hidden slide, use one of the following methods.
– Go to Slide > Show Slide on the Menu bar.
– Right-click on the hidden slide thumbnail and select Show Slide in the context menu.
– Click on Show Slide in the Slide View toolbar.

Custom slide shows
1) Select the slides required for a custom slide show in the Slides pane or Slide Sorter
view in the Workspace.
2) Go to Slide Show > Custom Slide Show on the Menu bar to open the Custom Slide
Shows dialog (Figure 43).
3) Click on New and the Define Custom Slide Show dialog opens (Figure 44).
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Figure 43: Custom Slide Shows dialog

Figure 44: Define Custom Slide Show dialog
4) Type a name for the new custom slide show in the Name text box.
5) In the Existing slides list, select the slides to include in the show.
6) Click the >> button to include the slides in the Selected slides list. Several slides can be
selected and included at the same time. Hold down the Shift key and click the first and
last slide in a group to select that group, or hold down the Ctrl key (macOS ⌘)and click
on individual slides to select them.
7) If required, rearrange the slide order in the Selected slides list. Click on a slide name
and drag it to a new position in the list, then release the mouse button.
8) Click OK to save the custom slide show and return to the Custom Slide Shows dialog.
9) To activate a custom show, select it in the list in the Custom Slide Shows dialog and then
select the Use custom slide show option.
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10) Click Start to test the custom slide show or click OK to close the Custom Slide Shows
dialog.

Slide transition
Slide transitions are effects and/or sounds that take place between slides when slides change in
a presentation and can add a professional look to a presentation, smoothing the change over
between slides. For more information on how to setup slide transitions, modify slide transitions,
and to advance slides in a presentation, see the Impress Guide.
1) Click on Slide Transition in the Sidebar to open the Slide Transition deck (Figure 45).
2) In the Slides pane or Slide Sorter view in the Workspace, select the slides where slide
transitions are going to be applied.
3) Click on a transition to apply it to the selected slide.
4) To apply the same transition to all slides in the presentation, click Apply Transition to All
Slides at the bottom of the Slides Transition deck.

Figure 45: Slide Transition deck on the
Sidebar
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5) To check how the transition looks, click Play at the bottom of the Slides Transition deck.
Alternatively, to automatically preview how the transition looks when it is applied, select
Automatic Preview at the bottom of the Slides Transition deck.
6) In the Advance Slide section, select how the slides change in a presentation.
– On mouse click – each time the mouse is clicked, the presentation advances to the
next slide.
– Automatically after – enter a time in box to elapse before the next slide in the
presentation advances into view.

Playing sounds or music
Sound or music can be played during a presentation as a transition effect. When using music in
a presentation, make sure any copyright or license for the music is not being infringed.
1) Click on Slide Transition on the Sidebar to open the Slide Transition deck.
2) In the Slides pane or Slide Sorter view in the Workspace, select the slide to add sound
or music.
3) In the Modify Transition section, select a sound in the Sound drop-down list.
4) To play music, use the following steps to select a music file:
a) Select Other sound in the Sound drop-down list.
b) In the file browser window that opens, navigate to where the music file is located.
c) Select the music file required and click Play to check if the music is suitable.
d) If the music is suitable, click Open to add the music to the selected slide and close
the file browser window.
5) To play a sound or music file continuously in the slide show, select the option Loop until
next sound. The sound or music file restarts once it is finished until the next sound or
music file that is inserted in the slide show.

Note
Do not select the Apply Transition to All Slides option, otherwise the selected music
file restarts at every slide.

Note
The sound or music file is linked to a presentation rather than embedded. If the
presentation is going to be displayed on a different computer, remember to make
sure that the music file is available on the computer where the presentation will be
played. The link to the sound or music file must be established before starting the
presentation.

Animation effects
Slide animations are similar to transitions, but they are applied to individual elements in a single
slide, such as title, chart, shape, or individual bullet point. Animations can make a presentation
more lively and memorable. However, as with transitions, heavy use of animations can be
distracting and even annoying for an audience expecting a professional presentation.
Animations are best applied using Normal view in the Workspace so that you can easily select
individual objects on a single slide.
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Figure 46: Animation deck in Sidebar
On a slide, an element such as a graphic or an entire text box has selection handles around it
when selected. If you select only a portion of the text in a text box, any selection handles may
not be visible. For more information on animation effects, see the Impress Guide.
1) Go to View > Normal on the Menu bar to open Normal view in the Workspace.
2) Select an element on a slide for animation.
3) On the Sidebar, select Animation to open the Animation deck (Figure 46).
4) Select a slide in the Animation panel and then click on Add Effect (+ plus sign) in the
Effects panel to open the animation options.
a) Select an animation category in the Category drop-down list.
b) Select an animation effect from the available options in the Effect list.
c) Select how the animation starts in the Start drop-down list.
d) Select the direction of the animation in the Direction drop-down list.
e) Enter a time for the duration of the animation in the Duration box.
f) Enter a time for the delay of when the animation starts in the Delay box.
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5) If required, select Automatic Preview so that how the animation looks can be checked
when applied to a slide element.
6) Click Play to check how the animation looks when applied to a slide element.

Running presentations
1) Open the presentation and start the slide show using one of the following methods:
– Use the keyboard shortcut F5 to start from the first slide or Shift+F5 to start from the
current slide.
– Go to Slide Show > Start from First Slide or Start from Current Slide on the Menu
bar.
– Click on Start from First Slide on the Slide Sorter toolbar.
2) If the slide transition is set to Automatically after x sec, the slide show starts and runs
after the set time has elapsed.
3) If the slide transition is set to On mouse click, click the left mouse button, or press the
down arrow key, the right arrow key, the page down key, or the spacebar.
4) To navigate backwards through a slide show one slide at a time, press the up arrow key,
the left arrow key, or the page up key.
5) To access more navigation options during a slide-show, right-click on a slide and use the
options available in the context menu.
6) When the last slide has displayed, the message Click to exit presentation... is displayed
on screen. Press the Esc key or click the left mouse button to exit the slide show.
7) To exit the slide show and return to the Impress workspace at any time, press the Esc key
during the slide show.

Note
During the presentation, any animations on a slide are run in the specified order as
the slide is displayed.

Presenter Console
The Presenter Console provides extra control over slide shows when using dual displays, such
as a laptop and a large display or projector for an audience. The view seen on a laptop display
includes the current slide that can be seen by the audience, the next slide in the presentation,
any slide notes, and a presentation timer.

Note
The Presenter Console only works with operating systems that support two displays.
When two displays are being used, one display can be a laptop.
The Presenter Console has to be enabled in Impress before use. Go to Tools > Options >
LibreOffice Impress > General (Figure 47) and select Enable Presenter Console in
Presentation.
The Presenter Console provides the following views for making a presentation:
•

Default view – displays the current slide, including any effects and the next slide in the
presentation (Figure 48). Click on the Previous and Next arrows to navigate through the
presentation.

•

Notes view – click on Notes to switch to display any notes that accompany each slide in
the presentation (Figure 49). Click on Notes again to return to the default view.
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•

Slides view – click on Slides to switch to display the slide thumbnails that are being used
for the presentation (Figure 50). Click on Slides again to return to the default view.

•

Exchange – click on this icon to switch the Presenter Console between displays.

Figure 47: Options LibreOffice Impress General dialog

Figure 48: Presenter Console - Default view
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Figure 49: Presenter Console - Notes view

Figure 50: Presenter Console - Slides view
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