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Using LibreOffice on macOS
Some keystrokes and menu items are different on macOS from those used in Windows and Linux.
The table below gives some common substitutions for the instructions in this document. For a
more detailed list, see the application Help.
Windows or Linux

macOS equivalent

Effect

Tools > Options menu

LibreOffice > Preferences

Access setup options

Right-click

Control +click or right-click
depending on computer setup

Open a context menu

Ctrl (Control)

⌘ (Command)

Used with other keys

F5

Shift + ⌘ + F5

Open the Navigator

F11

⌘ +T

Open the sidebar Styles deck
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Introduction
You can use LibreOffice without requiring a pointing device, such as a mouse or trackball, by using
its built-in keyboard shortcuts. Tasks as varied and complex as docking and un-docking toolbars
and windows, or changing the size or position of objects can all be accomplished with only a
keyboard. Although LibreOffice has its own extensive set of keyboard shortcuts, each component
provides others which are specific to its work.
For help with LibreOffice keyboard shortcuts, or using LibreOffice with a keyboard only, search the
LibreOffice Help using the “shortcut” or “accessibility” keywords.
In addition to using the built-in keyboard shortcuts (listed in this Appendix), you can also define
your own. You can assign shortcuts to standard Draw functions or your own macros and save them
for use with Draw only, or with the entire LibreOffice suite.
To adapt shortcut keys to your needs, use the Customize dialog as described in this section.

Tips on using macOS
Some keystrokes and menu items are different on macOS from those used in Windows and Linux.
The table below gives some common substitutions for the instructions in this book. For a more
detailed list, see the application Help.
Windows or Linux

macOS equivalent

Effect

Tools > Options
menu selection

LibreOffice > Preferences

Access setup options

Right-click

Control+click and/or rightclick depending on computer
setup

Open a context menu

Ctrl (Control)

⌘ (Command)

Used with other keys

F5

Shift+⌘+F5

Open the Navigator

F11

⌘+T

Open the Styles deck in the Sidebar

Note
Some of the shortcut keys in this appendix may be assigned to your desktop system.
Keys that are assigned to the desktop system are not available to LibreOffice. Try to
assign different keys either for LibreOffice in Tools > Customize > Keyboard, or in
your computer system. For more information on customizing LibreOffice, see the
Getting Started Guide.
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Draw-specific function keys and keyboard shortcuts
Function keys
Shortcut keys

Effect

F1

Opens LibreOffice Draw Help

F2

Enters text mode, to add or edit text.

F3

Enters group to edit individual objects.

Shift+F3

Opens the Duplicate dialog.

Ctrl+F3

Exits a group.

F4

Opens the Position and Size dialog.

F5

Opens the Navigator.

F7

Check spelling.

Ctrl+F7

Opens the thesaurus.

F8

Turns Edit Points on/off.

Ctrl+Shift+F8

Fits text to frame.

Shift+F10

Opens context menu of a selected object.

F11

Opens the Styles and Formatting dialog.

Shortcut keys for drawings
Shortcut Keys

Effect

Plus (+) key

Zooms in.

Minus (-) key

Zooms out.

Multiple (×) Key (number
pad)

Zooms to fit entire page in screen.

Divide (÷) Key (number
pad)

Zooms in on the current selection.

Ctrl+Shift+G

Groups selected objects.

Shift+Ctrl+Alt+A

Ungroups selected group.

Ctrl+Shift+K

Combines selected objects.

Ctrl+Alt+Shift+K

Un-combines selected objects.

Ctrl+Shift+Plus (+) key

Brings current selection to front.
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Shortcut Keys

Effect

Ctrl+Plus (+) key

Brings current selection forward.

Ctrl+Minus (-) key

Sends current selection backward.

Ctrl+Shift+Minus (-) key

Sends current selection to back.

Page Up

Switches to previous page.

Page Down

Switches to next page.

Ctrl+Page Up

Switches to previous layer.

Ctrl+Page Down

Switches to next layer.

Arrow Key

Moves the selected object in the direction of the arrow key.

Ctrl+Arrow Key

Moves the page view in the direction of the arrow key.

Ctrl+click while dragging
an object.

Creates a copy of the object being dragged when mouse button is
released. Note that this shortcut key works only when the Copy when
moving option in LibreOffice > Preferences > LibreOffice Draw >
General is enabled (this option is enabled by default).

Ctrl+Enter with keyboard
focus (F6) on a drawing
object icon on Tools bar .

Inserts a drawing object of default size into the center of the current
view.

Shift+F10

Opens the context menu for the selected object.

F2

Enters text mode.

Enter

Enters text mode if a text object is selected.

Ctrl+Enter

Enters text mode if a text object is selected. If there are no text
objects or if you have cycled through all of the text objects on the
page, a new page is inserted.

Alt

Press the Alt key and drag with the mouse to draw or resize an
object from the center of the object outward.

Alt + click on an object

Selects the object behind the currently selected object.

Alt+Shift + click on an
object

Selects the object in front of the currently selected object.

Shift key while selecting
an object

Adds or removes object to or from the selection.

Shift key while moving
an object

Constrains the movement of the selected object by multiples of 45
degrees.

Shift key while dragging
to create or resize an
object

Constrains the size to keep the object aspect ratio.
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Shortcut Keys

Effect

Tab

Cycles through the objects on the page in the order in which they
were created.

Shift+Tab

Cycles through the objects on the page in the reverse-order in which
they were created.

Esc

Exits current mode.

Page Pane navigation
Shortcut Keys

Effect

Home/End

Sets the focus to the first/last page.

Left/Right arrow keys or
Page Up/Page Down

Sets the focus to the next/previous page.

Enter

Creates a new page.

General function keys and keyboard shortcuts
Opening menus and menu items
Shortcut Keys

Result
Opens a menu where <?> is the underlined character of the menu
you want to open. For example, Alt+F opens the File menu.

Alt+<?>

With the menu open, menu items have underlined characters. To
access these menu items directly, press the underlined character key.
Where two menu items have the same underlined character, press
the character key again to move to the next item.
If an item in a menu has no underlined character, you need to click it
directly.

Esc

Closes an open menu.

F6

Repeatedly pressing F6 switches the focus and circles through the
following objects:
Menu bar
Every toolbar from top to bottom and from left to right
Every free window from left to right
Document

Shift+F6

Switches through objects in the opposite direction.

Ctrl+F6

Switches the focus to the document.

F10 or Alt

Switches to the Menu bar and back.
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Accessing menu commands
Press Alt or F6 or F10 to select the first item on the menu bar (the File menu). With the
right- arrow , the next menu to the right is selected; with the left-arrow , the previous menu. The
Home and End keys select the first and the last item on the Menu bar.
The down-arrow opens a selected menu. An additional down-arrow or up-arrow moves the
selection through the menu commands. The right-arrow opens any existing submenus.
Press Enter to execute the selected menu command.

Accessing toolbar commands
Press F6 repeatedly until the first icon on the toolbar is selected. Use the right and left arrows
to select an icon on a horizontal toolbar. Similarly, use the up and down arrows to select an icon
on a vertical toolbar. The Home key selects the first icon on a toolbar and the End key, the last.
Press Enter to activate the selected icon. If the selected icon normally requires a consecutive
mouse action, such as inserting a rectangle, then pressing the Enter key is not sufficient; in these
cases, press Ctrl+Enter .
•

Press Ctrl+Enter on an icon to create a draw object. The draw object will be placed into
the middle of the view, with a predefined size.

•

Press Ctrl+Enter on the Selection tool to select the first draw object in the document. If you
want to edit, size, or move the selected draw object, first use Ctrl+F6 to move the focus
into the document.

Navigating and selecting with the keyboard
You can navigate through a document and make selections with the keyboard.
•

To move the cursor, press the key or key combination given in the following table.

•

To select the characters under the moving cursor, additionally hold down the Shift key
when you move the cursor.

Key

Function

Plus Ctrl key

Right, left
arrow keys

Moves the cursor one character to
the left or to the right.

Moves the cursor one word to the left
or to the right.

Up, down
arrow keys

Moves the cursor up or down one
line.

(Ctrl+Alt) Moves the current
paragraph up or down.

Home

Moves the cursor to the beginning of
the current line.

Moves the cursor to the beginning of
the document.

End

Moves the cursor to the end of the
current line.

Moves the cursor to the end of the
document.

PgUp

Scrolls up one page.

Moves the cursor to the header.

PgDn

Scroll down one page.

Moves the cursor to the footer.
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Controlling dialogs
When you open any dialog, one element (such as a button, an option field, an entry in a list box, or
a checkbox) is highlighted or indicated by a dotted box around the field or button name. This
element is said to have the focus on it.
Shortcut Keys

Result

Enter

Activates selected button. In most cases where no button is selected,
Enter is equivalent to clicking OK.

Esc

Closes dialog without saving any changes made while it was open. In
most cases, Esc is equivalent to clicking Cancel. When an open
drop-down list is selected, Esc closes the list.

Spacebar

Checks an empty checkbox. Clears a checked checkbox.

Up, down arrow keys

Moves focus up and down a list. Increases or decreases value of a
variable. Moves focus vertically within a section of dialog.

Left, right arrow keys

Moves focus horizontally within a section of a dialog.

Tab

Advances focus to the next section or element of a dialog.

Shift+Tab

Returns focus to the previous section or element in a dialog.

Alt+Down Arrow

Shows items in a drop-down list.

Getting help
Shortcut Keys

Result

F1

Opens the LibreOffice Help dialog. In LibreOffice Help: jumps to the
first help page of the selected tab.

Shift+F1

Turns the cursor into the What’s This? question mark. Shows the tip
for an item underneath the cursor.

Shift+F2

Shows tip for a selected item.

Esc

In LibreOffice Help: goes up one level.

Managing documents
Shortcut Keys

Result

Ctrl+F4 or Alt+F4

Closes the current document. Closes LibreOffice when the last open
document is closed.

Ctrl+O

Launches the Open dialog to open a document.

Ctrl+S

Saves the current document. If you are working on a previously
unsaved file, the shortcut launches the Save As dialog.

Ctrl+N

Creates a new document.
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Shortcut Keys

Result

Shift+Ctrl+N

Opens the Templates and Documents dialog.

Ctrl+P

Opens the Print dialog to print the document.

Ctrl+Q

Closes the application.

Del

In the Save and Open dialogs, deletes the selected files or folders.
Items can be retrieved from the Recycle Bin (Trash).

Shift+Del

In the Save and Open dialogs, deletes the selected files or folders.
Items are permanently deleted: they can not be retrieved from the
Recycle Bin (Trash).

Backspace

In the Save and Open dialogs, shows contents of the parent folder of
the current directory.

Editing
Shortcut Keys

Result

Ctrl+X

Cuts selected items.

Ctrl+C

Copies selected items to the clipboard.

Ctrl+V

Pastes copied or cut items from the clipboard.

Ctrl+Shift+V

Opens the Paste Special dialog.

Ctrl+A

Selects all.

Ctrl+Z

Undoes last action.

Ctrl+Y

Redoes last action.

Ctrl+Shift+Y

Repeats last command.

Ctrl+F

Opens the Find dialog

Ctrl+H

Opens the Find & Replace dialog.

Ctrl+Shift+F

Searches for the last entered search term.

Ctrl+Shift+R

Refreshes (redraws) the document view.

Ctrl+Shift+I

Shows or hides the cursor in read-only text.

Selecting rows and columns in tables
Shortcut keys

Result

Spacebar

Toggles row selection, except when the row is in edit mode.
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Shortcut keys

Result

Ctrl+Spacebar

Toggles row selection.

Shift+Spacebar

Selects the current column.

Ctrl+Page Up

Moves pointer to the first row.

Ctrl+Page Down

Moves pointer to the last row.

Defining keyboard shortcuts
In addition to using the built-in keyboard shortcuts listed in this Appendix, you can define your own
keyboard shortcuts. See the Getting Started Guide for more information on defining keyboard
shortcuts.

Further reading
For help with LibreOffice keyboard shortcuts, or using LibreOffice with a keyboard only, search the
LibreOffice Help using the key words “shortcut keys” or “accessibility”.
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