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Multi-page documents

Draw documents, like Impress presentation documents, can consist of multiple pages. This allows 
you to create a drawing that has several sections that are stored as one file on a computer.

When pages are inserted into a drawing, they are automatically named as Slide 1, Slide 2, and so 
on in the Navigator. As you change page order, the pages are automatically renumbered. However,
if you want to easily identify each page, then it is recommended to give each page a memorable 
name.

Using the page pane
By default the Page Pane (Figure 1) appears docked on the left of the workspace when you open 
Draw and shows every page in the drawing as a thumbnail. If the Page Pane is not displayed, go 
to View > Page Pane on the main menu bar.

Figure 1: Page Pane, Workspace, and Sidebar

Note
The Page Pane is called Pages when it is in its docked position on the left of the 
workspace.

• Select a thumbnail in the Page Pane and the corresponding page is loaded in the 
workspace. Click on a page in the Workspace to activate it for editing.

• Alternatively, click on the Navigator icon  on the Standard toolbar or press the F5 key 
or go to View > Navigator on the main menu bar to open the Navigator dialog (Figure 2) 
and select pages using this dialog.

• Alternatively,  click on the Navigator icon  on the Sidebar to open the Navigator section 
(Figure 3) and select pages using the Sidebar.
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Figure 2: Navigator dialog

Figure 3: Navigator section on Sidebar

• Select a thumbnail in the Page pane, then drag and drop the thumbnail to change the order
of pages in the document.

• Click and drag on the separator line between the Page pane and workspace to change the 
width of the Page pane.

• Click on the middle of this line to show or hide the Page pane (highlighted in Figure 1).

• Press and hold the Ctrl key, then double-click in the title bar of the Page pane to undock it 
and turn it into a floating window.

• Press and hold the Ctrl key, then double-click in the title bar of the undocked Page pane to 
dock it back into its default position on the left of the workspace.

• Right-click in the Page pane and, using options in the context menu, you can insert, delete 
or rename pages and cut, copy, and paste pages.

• Go to Insert > Slide on the main menu bar to insert a new page or Insert > Duplicate 
Slide to insert a duplicate page.

Master pages
A master page is a page that is used as the starting point for other pages in your drawing. It is 
similar to a page style in Writer and controls the basic formatting of all pages based upon it. A 
drawing can have more than one master page so that you can assign a different look to pages in 
your drawing, for example title page, contents page, and drawing pages.

A master page has a defined set of characteristics, including the background color, graphic, or 
gradient; objects (such as logos, decorative lines, and other graphics) in the background, the 
formatting of text, blocks of standard text, and insert fields such as page numbering, date, and 
filename.
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Note

LibreOffice uses interchangeable terms for one concept: slide master, master slide,
and master page. All refer to a page which is used to create other pages. When 
searching for information in Draw Help, it may be necessary to use alternative 
search terms.

Master page view
To add objects and fields to a master page, go to View > Master on the main menu bar to open the
master page view. The Master View toolbar (Figure 4) also opens when you switch to master view.
If this toolbar does not appear, go to View > Toolbars > Master View on the main menu bar.

To return to normal page mode, click on Close Master View in the Master View toolbar or go to 
View > Normal on the main menu bar.

Figure 4: Master View toolbar

Creating master pages
Each drawing you create already has a default master page, but you can create extra master 
pages to change the look of some of the pages in your multi-page drawing.

1) Go to View > Master on the main menu bar to open the master page view.

2) Click on the New Master icon  in the Master View toolbar to create a new master page. 
The new master page is automatically selected allowing you to add a new set of items to 
create a new look for your pages.

Renaming master pages
Each new master page created has the default name of Default 1, Default 2, and so on. It is 
recommended to rename your new master page with a more meaningful name. The default master
page that was created when you first created your drawing can also be renamed.

1) Go to View > Master on the main menu bar to open the master page view.

2) Right-click on a master page in the Page pane and select Rename Page from the context 

menu or click on the Rename Master icon  on the Master View toolbar. This opens a 
dialog where you can type a new name.

3) Click OK to save the master page with its new name.

Deleting master pages
1) Go to View > Master on the main menu bar to open the master page view.

2) Select the master page you want to delete.

3) Right-click on a master page that you created in the Page pane and select Delete Page 

from the context menu or click on the Delete Master icon  on the Master View toolbar.

Note
The Delete option and Delete icon are only available when there is more than one 
master page in your drawing. You cannot delete the default master page that was 
created when you first created your drawing.
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Inserting fields
You can insert fields on each master page by going to Insert > Fields on the main menu bar and 
selecting a field from the context menu. The following fields can be inserted into a master page.

• Date (fixed) – inserts the current date into the master page as a fixed field. The date is not 
automatically updated.

• Date (variable) – inserts the current date into the master page as a variable field. The date 
is automatically updated when you reload the file.

• Time (fixed) – inserts the current time into the master page as a fixed field. The time is not 
automatically updated.

• Time (variable) – inserts the current time into the master page as a variable field. The time
is automatically updated when you reload the file.

• Author – inserts the first and last names listed in the LibreOffice user data into the active 
page.

• Page Number – inserts the page number into every page of the drawing. To change the 
number format, go to Format > Page on the main menu bar and select a format from the 
drop-down list in Layout Settings.

• File name – inserts the name of the active file. The name only appears after you save the 
file.

Assigning master pages
When your drawing has more than one master page, you can assign different master pages to 
different pages.

1) Make sure you are in normal page view by going to View > Normal on the main menu bar 
and select the page you want to assign a new master page to it.

2) Right-click on the page in the workspace area and select Page > Slide Design from the 
context menu to open the Slide Design dialog (Figure 5).

Figure 5: Slide Design dialog
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Figure 6: Load Slide Design dialog

3) If necessary, click Load to open the Load Slide Design dialog and use any predefined 
Draw master pages or templates (Figure 6).

4) If necessary, select the Exchange background page option to use the selected master 
page for all pages in the drawing.

5) If necessary, select the Delete unused backgrounds option to delete any master pages 
shown in the Slide Design dialog that have not been assigned to a page.

6) Click OK to assign the selected master page to your page.

Templates

A template is a special type of document that you use as a basis for creating other documents. For 
example, you can create a template for company drawings so that any new drawing has your 
company logo and name on the first page and any remaining pages in your drawing only show the 
company name.

Templates can contain anything that regular documents can contain, such as text, graphics, a set 
of styles, and user-specific setup information such as measurement units, language, the default 
printer, and toolbar and menu customization.

All documents created using LibreOffice are based on templates. You can create a specific 
template for any document type (text, spreadsheet, drawing, or presentation). If you do not specify 
a template when you start a new document, then the document is based on the default template for
that type of document. If you have not specified a default template, LibreOffice uses the blank 
template for that type of document that is installed with LibreOffice. This default template can be 
changed, see “Setting default template” on page 11 for more information.

For more information on templates, see the Getting Started Guide Chapter 3 Using Styles and 
Templates.

Note
Draw does not have any predefined templates when it is installed on a computer. 
However, you can install templates from other sources or create your own 
templates; these methods are described in the following sections.
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Templates from other sources
You can download templates for LibreOffice from many sources, including the official template 
repository at http://templates.libreoffice.org/, and install them on your computer. On other websites 
you may find collections of templates that have been created using OpenDocument format that 
Draw uses as its default format. These templates from other sources are installed using the 
Extension Manager, as described in “Importing template collections using the Extension Manager” 
on page 14.

Some of these templates are free of charge; others are available for a fee. Check the descriptions 
to see what licenses and fees apply to the ones that interest you. To import individual templates, 
see “Importing templates” on page 14 for more information and to import a template collection, see 
“Importing template collections using the Extension Manager” on page 14 for more information.

Creating templates
1) Open the drawing that you want to use for a template, or open a template that you want to 

use as a basis for your template.

2) Add any extra content and styles or edit the content and styles in your drawing.

3) Go to File > Templates > Save As Template on the main menu bar to open the Template 
Manager (Figure 7).

4) Open the My Templates folder as your destination folder to activate the Save icon , 
then click the Save icon.

Alternatively, click on the New Folder icon  and create your own folder for your Draw 

templates, then open your own folder to activate the Save icon  and click the Save 
icon.

5) Type a name for the new template in the Enter template name text box.

6) Click OK to save the new template in the destination folder.

7) Close the Template Manager.

Figure 7: Template Manager as it appears when saving a template

Note

When you are saving a new template, the Template Manager shows only one tab, 
Documents, as shown in Figure 7. However, when you are creating a document 
from a template, as described in "Using templates" below, four tabs are shown in 
the Template Manager (see Figure 8). The new template is automatically displayed
on the tabbed page corresponding to that type of template. For example, Draw 
templates are located on the Drawings page.
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Figure 8: Template Manager when creating a document from a template, showing 
Drawing templates located in two folders, one of which is user-created. See note below.

Note

The Drawings tab shows all Drawing templates, regardless of their location in 
folders.

In Figure 8, the user has created a separate folder for My Drawings and has saved
one Drawing template in it. If you have not created a separate folder for drawings 
and saved or moved a template into it, all of your templates will be displayed in the
My Templates folder; the example shows one Drawing template there.

Using templates
1) Click on Templates in the LibreOffice Start Center, or go to File > New > Templates on the

main menu bar, to open the Template Manager (Figure 8).

2) Click on the Drawings tab to open the page containing all the templates for use in Draw.

3) Navigate to the folder that contains the selection of drawing templates you want to use.

4) Select the template you want to use.

5) Click on the Open icon  on the Template Manager toolbar or double-click on the 
template. A new drawing will be created using the selected template and the Template 
Manager dialog will close.

Setting default template
If you create a presentation by using File > New > Drawing on the main menu bar and do not 
select a template, LibreOffice creates the drawing from the default Draw template, which is 
normally a blank template. However, you can set any drawing template to be the default template, 
even a template that you have created, so long as it is located in a folder displayed in the Template
Manager dialog. You can always reset the default template back to the blank template later if you 
so choose.

Setting a custom template as default
To set a template that you have created or imported as default instead of using the Draw default 
template:

1) Click on Templates in the LibreOffice Start Center or go to File > New > Templates to 
open the Template Manager and select the Drawing tab (Figure 8).

2) Double-click on the My Templates folder or the folder that contains the template you want 
to use to open the folder.
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3) Select the template you want to use as the default template.

4) Click the Set as default icon  and your selected template becomes the default 
template. The next time that you create a new drawing using Draw, the drawing will be 
created from the default template you have just set.

Resetting default template
To reset the default template for a new drawing to use the Draw default template:

1) Click on Templates in the LibreOffice Start Center or go to File > New > Templates to 
open the Template Manager (Figure 8).

2) Select the Action Menu icon  and choose Reset Default Template from the drop-
down menu. This command does not appear unless the default template has been 
previously changed to a template of your choosing.

3) Select Drawing from the drop-down list to reset the default template. If other modules in 
LibreOffice have had their default template changed, then these modules will also appear in
this drop-down list.

4) The next time that you create a new drawing using Draw, the drawing will be created from 
the default Draw template.

Editing templates
You can edit template styles and content, and then, if you wish, you can reapply the template 
styles to drawings that were created from that template. 

Note You can only reapply styles. You cannot reapply content.

Editing
1) Click on Templates in the LibreOffice Start Center or go to File > New > Templates to 

open the Template Manager (Figure 8).

2) Navigate to the folder where the template you want to edit is located and click once on it to 
activate the file handling controls.

3) Select the Edit icon  and the template opens in Draw. Edit the template just as you 
would any other drawing.

4) To save your changes, go to File > Save on the main menu bar.

Updating documents from a modified template
The next time that you open a drawing that was created from the changed template, you will be 
asked to confirm whether you want to update the styles in your drawing to the formatting used in 
the modified template.

Click Update Styles to update any styles in the template that have been changed in the document.
Click Keep Old Styles if you do not want to update any styles in the template that have been 
changed in the document. Whichever option you choose, the message box closes and the drawing
opens in Draw.

Note
If you select Keep Old Styles, then this message will not appear again the next time
you open the document after changing the template it is based on. You will not get 
another chance to update the styles from the template.

Templates 12



Organizing templates
LibreOffice can only use templates that are in LibreOffice template folders. You can create new 
LibreOffice template folders and use them to organize your templates. For example, separate 
template folders for different projects or clients. You can also import and export templates.

Tip
The location of LibreOffice template folders varies with your computer operating 
system. To learn where the template folders are stored on your computer, go to 
Tools > Options > LibreOffice > Paths.

Creating template folders
To create a template folder:

1) Go to File > New > Templates on the main menu bar to open the Template Manager.

2) Select the Drawings tab to open the tab for drawings (Figure 8).

3) Click the New Folder icon  and enter a name for the new folder in the Enter folder 
name box, then click OK.

4) Alternatively, click on the template you want to move to a new folder and the file handling 
controls are displayed.

5) Click the Move to folder icon  and select New folder from the drop list that appears.

6) Type a name for the new folder in the Enter folder name box, then click OK. The selected 
template is then moved to the new folder you have just created.

Deleting template folders
You cannot delete the template folders supplied with LibreOffice or installed using the Extension 
Manager. You can only delete folders that you have created.

To delete a template folder that you have created:

1) Go to File > New > Templates on the main menu bar to open the Template Manager.

2) Select the Drawings tab to open the tab for drawings (Figure 8).

3) In the Template Management dialog select the folder that you want to delete.

4) Select the Delete icon  and a message box appears asking you to confirm the deletion.
Click Yes.

Moving templates
To move a template from one template folder to another template folder:

1) Go to File > New > Templates on the main menu bar to open the Template Manager.

2) Select the Drawings tab to open the tab for drawings (Figure 8).

3) Navigate to the template that you want to move and then select it.

4) Click the Move to folder icon  and select the folder from the drop-down list to move 
your selected template.

Deleting templates
You cannot delete the templates supplied with LibreOffice or installed using the Extension 
Manager. You can only delete templates that you have created or imported.
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To delete a template:

1) Go to File > New > Templates on the main menu bar to open the Template Manager.

2) Select the Drawings tab to open the tab for drawings (Figure 8).

3) Navigate to the template that you want to delete and then select it.

4) Click the Delete icon  and a message box appears and asks you to confirm the 
deletion. Click Yes.

Importing templates
If the template that you want to use is in a different location, you must import it into an LibreOffice 
template folder.

To import a template into a template folder:

1) In the Template Manager (Figure 8), navigate to and select the folder into which you want 
to import the template.

2) Click the Import icon  and a standard file browser dialog opens.

3) Navigate to the template on your computer that you want to import, select it and click 
Open. The file browser window closes and the template appears in the selected folder.

4) Alternatively, click the Get more templates from LibreOffice icon  on the right of the 
Template Manager toolbar to open your web browser at the LibreOffice template page.

5) Locate the template you want to import and select it.

6) Download the template to your computer, then repeat Steps 1 to 3 above to import the 
template into LibreOffice.

Importing template collections using the Extension Manager

Figure 9: Extension Manager
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The Extension Manager provides an easy way to install collections of templates that have been 
packaged as extensions. For more about the Extension Manager, see the Getting Started Guide.

1) Download the extension package (.OXT file) and save it anywhere on your computer. You 
can find several templates at http://templates.libreoffice.org/template-center that have been
developed for use with LibreOffice.

2) Go to Tools > Extension Manager on the main menu bar to open the Extension Manager 
dialog (Figure 9).

3) Click Add to open a file browser window.

4) Find and select the template package you want to install and click Open. The package 
begins installing. You may be asked to accept a license agreement.

5) When the package installation is complete, the templates are available for use through File
> New > Templates and the extension is listed in the Extension Manager.

Exporting templates
To export a template from a template folder to another location:

1) Go to File > New > Templates on the main menu bar to open the Template Management 
dialog.

2) Select the Drawings tab to open the tab for drawings (Figure 8).

3) Navigate to the template that you want to export and then select it.

4) Click the Export icon  and a standard file browser dialog opens.

5) Navigate to the folder into which you want to export the template and click OK.

Multiple layers

Layers in LibreOffice Draw allow you to assemble elements on a drawing page that are related. 
Think of layers as individual workspaces that you can hide from view, hide from printing, or lock. 
Any layers that do not contain any objects are transparent.

Layers do not determine the stacking order of objects on your drawing page, except for the 
Controls layer which is always in front of all other layers. The stacking order of objects on your 
drawing page is determined by the sequence in which you add the objects. You can rearrange the 
stacking order by going to Modify > Arrange on the main menu bar.

Note

You can lock a layer to protect its contents, or hide a layer and its contents from 
view or from printing. When you add a new layer, the layer is added to all of the 
pages in your drawing. However, when you add an object to a layer, it is only 
added to the current drawing page.

If you want the object to appear on all of the pages (for example, a company logo),
add the object to the master page by going to View > Master. To return to your 
drawing, go to View > Normal.

Default layers
LibreOffice Draw provides three default layers and these default layers cannot be deleted or 
renamed.

• Layout – is the default workspace and determines the location of title, text and object 
placeholders on your drawing page.

Multiple layers 15
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• Controls – used for buttons that have been assigned an action, but should not be printed 
and the layer properties are set to not printable. Objects on this layer are always in front of 
objects on other layers.

• Dimension Lines – is where the dimension lines are drawn. By switching the layer to show
or hide, you can easily switch dimension lines on and off.

Figure 10: Insert Layer dialog

Inserting layers
1) Right-click the layer tab area at the bottom left of the Workspace area and select Insert 

Layer from the context menu, or go to Insert > Layer on the main menu bar to open the 
Insert Layer dialog (Figure 10).

2) Type meaningful names for the layer in the Name and Title text boxes.

3) If necessary, type a description for the layer in the Description text box.

4) Select Visible if you want the layer to be visible in your drawing. When Visible is not 
selected, a layer is hidden and the title in the layer tab changes color to blue.

5) Select Printable if you want the layer to print when you print your drawing. Not printing is 
useful if you want use a draft layer for guides or annotations that you use in making the 
drawing, but do not want to appear in the final output.

6) Select Locked to prevent any objects on this layer from deletion, editing, or moving. No 
additional objects can be added to a locked layer. Locking a layer is useful, for example, 
when a base plan is to be protected while adding a new layer with other details.

7) Click OK and the new layer automatically becomes active.

Modifying layers
1) Right-click on the name tab of the layer and select Modify Layer from the context menu or 

double-click on the name tab to open the Modify Layer dialog. This dialog is similar to the 
Insert Layer dialog in Figure 10.

2) Make your changes to the layer, then click OK to save the changes and close the dialog.
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Working with layers

Selecting a layer
To select a layer, click on the name tab of the layer at the bottom of the drawing workspace.

Hiding layers
1) Right-click on the name tab of the layer and select Modify Layer from the context menu or 

double-click on the name tab to open the Modify Layer dialog.

2) Clear the Visible check box and click OK. The text on the name tab changes color to blue. 
Any objects placed on a hidden layer will no longer be visible on the other layers in your 
drawing.

3) Alternatively, hold down the Shift key and click on the name tab to hide the layer.

Showing hidden layers
1) Right-click on the name tab of the layer and select Modify Layer from the context menu or 

double-click on the name tab to open the Modify Layer dialog.

2) Check the Visible check box and click OK. The text for the name tab changes to the default
color for text for your computer setup. Any objects placed on a hidden layer will now 
become visible on the other layers in your drawing.

3) Alternatively, hold down the Shift key and click on the name tab to make the layer visible.

Locking layers
1) Right-click on the name tab of the layer and select Modify Layer from the context menu or 

double-click on the name tab to open the Modify Layer dialog.

2) Check the Locked check box and click OK to prevent any modification of the layer.

Unlocking layers
1) Right-click on the name tab of the layer and select Modify Layer from the context menu or 

double-click on the name tab to open the Modify Layer dialog.

2) Uncheck the Locked check box and click OK to allow modification of the layer.

Renaming layers
1) Right-click on the name tab of the layer and select Rename Layer from the context menu.

2) Type a new name for the layer and click outside the tab area to save the change.

3) Alternatively, follow the procedure in “Modifying layers” above to rename the layer.

Deleting layers
1) Right-click on the name tab of the layer and select Delete Layer from the context menu.

2) Confirm the deletion and the layer and all its objects are deleted.

Note
You can only delete layers that you have added to a drawing. The default layers, 
Layout, Controls, and Dimensioning, cannot be deleted.
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Dimensioning

Draw allows you to dimension objects and display these dimensions to make your drawing look 
more like an engineering drawing. When you create dimensions, they are automatically placed on 
the Dimension Lines layer (see “Default layers” on page 15 for more information).

Configuring dimensioning
Two ways are available to access the options to configure dimensioning. Both methods use a 
similar dialog where you can change the length, measurement, and guide properties of a 
dimension line.

Figure 11: Image Styles dialog – Dimensioning page

Drawing object styles
1) Go to Format >Styles and Formatting on the main menu bar, or click on the Styles and 

Formatting icon  on the Line and Filling toolbar, or press the F11 key on your keyboard
to open the Styles and Formatting dialog.

2) Alternatively, click on the Styles and Formatting icon   on the Sidebar to open the 
Styles and Formatting section.

3) Right-click on Dimension Line in the list of styles and select Modify from the context menu 
to open the Image Styles dialog (Figure 11).

4) Click on the Dimensioning tab to open the Dimensioning options page.

5) Make the changes you want to use for dimensioning using the various options on this page.

6) Click OK to save your changes and close the dialog.

7) To reset the dimensioning options to the default properties of the template, click Standard.

Dimensioning 18



Context menu
1) Draw a dimension line. See “Dimensioning objects” on page 20 for more information.

2) Right-click on the dimension line and select Dimensions from the context menu to open 
the Dimensioning dialog (Figure 12).

Figure 12: Context menu Dimensioning dialog

3) Make the changes you want to use for dimensioning using the various options on this 
dialog.

4) Click OK to save your changes and close the dialog.

Dimensioning dialog
With reference to Figure 11 and Figure 12, the dimensioning options are as follows.

• Line – sets the distance properties of the dimension line and the guides with respect to 
each other and to the baseline.

– Line distance – specifies the distance between the dimension line and the baseline (line
distance = 0).

– Guide overhang – specifies the length of the left and right guides starting at the 
baseline (line distance = 0). Positive values extend the guides above the baseline and 
negative values extend the guides below the baseline.

– Guide distance – specifies the length of the right and left guides starting at the 
dimension line. Positive values extend the guides above the dimension line and 
negative values extend the guides below the dimension line.

– Left guide – specifies the length of the left guide starting at the dimension line. Positive 
values extend the guide below the dimension line and negative values extend the guide
above the dimension line.

– Right guide – specifies the length of the right guide starting at the dimension line. 
Positive values extend the guide below the dimension line and negative values extend 
the guide above the dimension line.

– Measure below object – reverses the properties set in the Line options.

– Decimal places – specifies the number of decimal places used for the display of line 
properties.
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• Legend – sets the properties of the dimension text.

– Text position – determines the position of the dimension text with respect to the 
dimension line and the guides. The AutoVertical and AutoHorizontal checkboxes must 
be cleared before you can assign a text position.

– AutoVertical – determines the optimal vertical position for the dimension text.

– AutoHorizontal – determines the optimal horizontal position for the dimension text.

– Parallel to line – displays the text parallel to or at 90 degrees to the dimension line.

– Show measurement units – shows or hides the dimension measurement units. You can 
also select a measurement unit you want to display from the list.

Note

The dimensioning style Dimension Line is always linked and stored with the 
current work page. All the changes that you make apply only to this page. New 
drawings are started with the standard properties of Draw. If you want to use the 
amended style for future drawings, save your drawing as a template.

Tip

When dimensioning objects, it is recommended to use the zoom function, guide 
lines and snap functions so that you can accurately place dimension lines on an 
object. See Chapter 3 Working with Objects and Object Points for more 
information.

Dimensioning objects

1) Click on the small triangle next to the Lines and Arrows icon  on the Drawing toolbar to
open the Arrows pop-up toolbar. Note that this icon changes depending on the last Lines 
and Arrows tool used. Also, this toolbar can become a floating toolbar by clicking on the 
bottom of the pop-up toolbar and dragging it into the workspace.

2) Click on the Dimension Line icon  on the Arrows toolbar and the cursor normally 
changes to a cross. This depends on your computer setup.

3) Position the cursor at one corner of the object, then click and drag the cursor to the other 
corner of the object to draw the dimension line. To restrict drawing the dimension line in the 
horizontal or vertical direction, press and hold the Shift key while dragging the cursor.

4) Release the mouse button when you reach the other corner of the object and the 
dimension line is drawn with the dimension automatically added (Figure 13). The dimension
line is also placed automatically on the Dimension Lines layer; see “Default layers” on 
page 15 for more information.

5) To edit the text of the dimension, double-click on an unselected dimension line to enter text 
edit mode and make your changes. Click outside the dimension line to save the changes.

6) To configure the dimension line, see “Configuring dimensioning” on page 18.

Figure 13: Dimensioning objects
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Drawing to scale

In Draw a drawing is made on a predefined drawing area. This is normally Letter or A4 page size 
depending on your locale, computer setup, and the default printer connected to your computer. 
However, depending on the actual size of the drawn objects, it is often convenient to reduce or 
enlarge the drawing by scaling (for example 1:10 or 2:1).

You can specify a scale value by going to Tools > Options > LibreOffice Draw > General (Figure 
14) and selecting a value from the Drawing scale drop-down list. The default setting for this option 
is 1:1. When you make a change to the drawing scale, it is reflected in the rulers at the top and left 
side of your drawing.

Figure 14: Options LibreOffice Draw dialog -- General page

Any change in the drawing scale has no effect on the basic drawing operations. Draw automatically
calculates the necessary values (for example, dimension lines). The spacing of the grid points is 
independent of drawing scale as the grid is an optical drawing aid and not a drawing element.

An increase in scale (for example 1:4) allows you to draw objects that would not fit into the paper 
size for your drawing. A decrease in drawing scale (for example 4:1) allows you to draw small 
objects accurately at an increased size to make them easier to understand. An example of drawing
to scale is shown in Figure 15. All three rectangles are the same size.

• The left rectangle was drawn at the default 1:1 scale and dimensioned.

• The drawing scale was then changed to 1:4 and the dimensions were automatically 
increased by Draw to reflect the decrease in scale for the center rectangle.

• The drawing scale was then changed to 4:1 and the dimensions were automatically 
decreased by Draw to reflect the increase in scale for the right rectangle.

Figure 15: Examples of drawing to scale
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Gallery images

Draw includes several images in a Gallery. These images are grouped into themes: Bullets; 
Rulers; Homepage; Rulers; Sounds and so on. The left pane of the gallery window lists the 
available themes. Click on a theme to see its images displayed in the right pane of the Gallery 
dialog (Figure 16).

The default themes are read only; no images can be added to or deleted from these themes. The 
default themes are easily recognizable by right-clicking on each category and the only available 
option in the pop-up menu is Properties.

Any themes that you create are the only themes that are customizable allowing you delete or 
rename themes and add or delete your own graphics. For more information on creating themes, 
see “Creating themes and adding images” on page 22.

Figure 16. Gallery dialog

Using the Gallery

1) Click on the Gallery icon  on the Drawing toolbar or go to Tools > Gallery on the main 
menu bar to open the Gallery dialog (Figure 16).

2) Alternatively, click on the Gallery icon  on the Sidebar to open the Gallery section 
(Figure 17).

3) Choose a theme in the Gallery dialog or Sidebar Gallery section.

4) Click on an image in the Gallery dialog or Sidebar Gallery section and drag the image into 
your drawing.

Alternatively, right-click on a gallery image and select Insert from the context menu. The 
gallery image is pasted into your drawing.

5) Use the tools available in the Picture toolbar to edit the gallery image to your preferences. 
For more information on editing pictures, see Chapter 6 Editing Pictures.

Creating themes and adding images
1) Open the Gallery dialog (Figure 16) or the Sidebar Gallery section (Figure 17) and click 

New Theme to open the Properties of New Theme dialog (Figure 18).

2) Type a memorable name for your theme in the text box and click OK.

3) Right-click on the new theme name that you have created and select Properties from the 
context menu to open the Properties of New Theme dialog (Figure 19) and click on the 
Files tab.

4) Click on Find Files to open the Select Path dialog (Figure 20).

5) Browse to the folder that contains the images you want to use.
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Figure 17: Sidebar Gallery section

Figure 18. Properties of New Theme dialog – General page

Figure 19. Properties of New Theme dialog – Files page
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Figure 20. Selecting path for new images in themes

6) Click Select to select the files contained in the folder and the Select Path dialog closes. 
The list of files contained in the folder now appear in the Properties of New Theme dialog.

7) Select the files you want to use in for your new theme and click Add. The added files will 
disappear from the file list and the images will appear in the Gallery.

8) If you want to add all the files in the list, click Add All. All the files will disappear from the 
list and the images will appear in the Gallery.

9) Click OK when finished and the Properties of New Theme dialog will close.

Deleting gallery themes and images
You can only delete new themes that you have created and any images that you have added to a 
new theme.

1) Right-click on on a theme you have created or an image you have added to the Gallery.

2) Select Delete from the context menu.

3) A confirmation message appears, asking if you want to delete this object. Click Yes.

Note
The image is a linked file and is deleted from the Gallery only. The original image file 
is not deleted.

Updating the Gallery
All the images in a gallery are linked files. From time to time it is beneficial to update a theme you 
have created to make sure that all the files are still there. To do so, right-click on a theme you have 
created and you have added at least one file and then select Update from the context menu.

Note
If you wish, you can rename this new theme by manually by right-clicking the theme 
name and selecting Rename from the context menu.
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Colors and color palettes

Draw (like all LibreOffice components) uses color palettes for the representation of colors. You can 
customize the color palette to suit your own needs by modifying colors in a palette, adding other 
colors, or creating new color palettes.

Note
LibreOffice uses the RGB color model internally for printing in all of its software 
modules. The CMYK controls are provided only to ease the input of color values 
using CMYK notation.

Using colors
Two color dialogs are available where you can select, add, modify, edit, or delete colors. Go to 
Tools > Options > LibreOffice > Colors (Figure 21) or Format > Area > Colors (Figure 22) on 
the main menu bar to open these color dialogs. You can also right-click on a selected object and 
choose Area in the context menu, then click on the Colors tab to open the Area dialog (Figure 22).

Each color value has a numeric value, which can be input directly as numbers. The color values for
the RGB color model (Red, Green, and Blue) can be any integer value between 0 and 255. The 
color values for the CMYK color model (Cyan, Magenta, Yellow, and Black (K)) are percentages. 
When selecting between the RGB and CMYK color models in both dialogs, the value boxes 
automatically change to show RGB or CMYK.

When using CMYK values, the conversion to RGB values used in LibreOffice is made 
automatically. Any modifications made to colors apply only to the active palette in your drawing 
unless you save the modified color palette for future use.

Tip
More information on color models can be found at 

http://en.wikipedia.org/wiki/Color_model 

Figure 21: Options – LibreOffice – Colors dialog
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Figure 22: Area dialog – Colors page

Selecting colors
1) Go to Tools > Options > LibreOffice > Colors (Figure 21) or Format > Area > Colors 

(Figure 22) on the main menu bar to open a color dialog.

Alternatively, right-click on a selected object and select Area from the context menu, then 
click on the Colors tab to open the color dialog (Figure 22).

2) Select a color from the Color drop-down list, or select a color from the color table, or enter 
the RGB or CMYK values for the color you want to use.

3) Click OK to use the selected color and close the dialog.

Color palettes
Use the Colors page in the Area dialog (Figure 22) to load color palettes or create and save color 
palettes for future use.

• Click on the Load Color List icon  to open a dialog where you can select a color 
palette to use in Draw.

• If you have made any changes to the color palette, click on the Save Color List icon  to
open a dialog where you can save your color palette for future use in Draw. The file format 
used in LibreOffice for color palettes is .soc.

Note
The Load Color List and Save Color List icons are only available if you select the 
color dialog using the Format > Area > Colors command or right-click on a selected 
object and select Area from the context menu.

Creating colors

Using color values
1) Select either RGB or CMYK from the drop-down options on the color dialog.

Colors and color palettes 26



2) Enter integer values or percentage values in each of the RGB or CMYK boxes or use the 
spinners at the right of each box.

3) The original color is shown the top color sample and the new color is shown in the lower 
color sample.

4) Click Modify to apply and store the new setting in the color palette without changing the 
color name.

Or, click Add and you will be prompted to give the color a new name. Enter a new name 
and click OK to add the new color to the end of the color list and store it in the currently 
active palette.

5) Click OK to use the modified or new color and close the dialog.

Note
To store your new color in a color palette for future use in Draw, see “Color palettes” 
on page 26.

Using the Color Picker
You can define colors using the Color Picker dialog (Figure 23).

1) Go to Format > Area > Colors on the main menu bar, or right-click on a selected object 
and go to Area in the context menu to open the Area dialog and then click on the Colors 
tab to open the Colors page of the Area dialog (Figure 22).

2) Click Edit to open the Color Picker dialog, where you have three ways to select a color to 
create and use.

• Click on the colored bar to the right of the color sample area to select a color. The 
values in the RGB, HSB (Hue, Saturation, and Brightness) and CMYK boxes will 
change.

• Or, enter values in either the RGB, HSB, or CMYK boxes to create the color. Entering 
values in one set of value boxes will change the values in the other two sets of boxes.

• Or, click on the small circle in the color sample area and drag it to a new position to 
create a new color.

Figure 23: Color Picker dialog
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3) The color bar below the sample color area will show the new color on the left half of the bar
so that you can compare it with the original color on the right half of the bar.

4) If you are satisfied with the color created, click OK to use the color.

5) See “Using color values” on page 26 to save the color.

Deleting colors
1) To delete a color from a color palette, open the color dialog (Figure 21 or Figure 22).

2) Select the color from the Color drop-down list or the color table and click Delete.

3) Click Yes to confirm the deletion of the color.

4) Click OK to close the color dialog.

Bézier curves

In LibreOffice you can use Bézier curves in your drawing. A curve is defined by means of a start 
point P0, an end point P3, and two control points P1 and P2 (Figure 24). For points on the curve the 
terms nodes or anchors are often used. For the mathematical background of Bézier curves, see 
http://en.wikipedia.org/wiki/Bezier_curve.

Figure 24: Points in Bézier curves

Bézier curves are very useful for experimenting with the shape and form of curves. In point mode 
you can change the curve alignment by dragging the points with the mouse. The curve leaves the 
start point P0 in the direction of the control point P1 and arrives at the end point P3 from the 
direction of the control point P2. The more distant a control is from its start or end point the smaller 
the curvature at that point. If a control point lies directly on one of these points, it has no influence 
on the curve.

Drawing Bézier curves

1) Click on the small triangle to the right of the Curve icon  on the Drawing toolbar to open
the Lines toolbar (Figure 25). The Curve icon on the Lines toolbar is the last tool selected 
on the Lines toolbar. To make this toolbar a floating toolbar, click at the bottom of the pop-
up toolbar and drag it onto the workspace.

2) Click on the Curve icon  on the Lines toolbar.

Figure 25: Lines toolbar
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3) Click at the start point where you want to draw the curve and, keeping the mouse button 
pressed, drag the cursor to the approximate the position of the end point for the curve.

4) Release the mouse button, then drag the end point of the curve to its end position.

5) Double-click when you have reached the end position of the curve and a curve is drawn. 
The arc of the curve is determined by the distance you have dragged to create the end 
point.

6) Click on the Points icon  on the Drawing toolbar or press the F8 key to open the Edit 
Points toolbar (Figure 26).

Figure 26: Edit Points toolbar and tools

7) Click once on the curve to display the start and end points. The start point of the curve is 
larger than the end point.

8) Move the cursor over the start or end point and drag the control point to its correct position,
if necessary. As you drag a start or end point, a control point appears at the end of a 
dashed line connected to the point you have selected (Figure 27).

Figure 27: Control points on a curve

9) When you have the position for your start or end point, release the cursor and the control 
point remains active.

10) Click on the control point and drag it to change the shape of the curve.

11) When you have finished editing the curve, click anywhere on the workspace to deselect the
curve and stop editing points.
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Edit Points tools
With reference to Figure 26, the tools available on the Edit Points toolbar allow you to edit and 
change the shape of a Bézier curve and are explained as follows:

• Points – allows you to activate or deactivate the edit mode for Bézier objects. In the edit 
mode, individual points of the drawing object can be selected.

• Move Points – activates a mode in which you can move points. The mouse pointer 
displays a small empty square when resting on a point. Drag that point to another location. 
The curve on both sides of the point follows the movement; the section of the curve 
between points changes shape. Point at the curve between two points or within a closed 
curve and drag the mouse to shift the entire curve without distorting the form.

• Insert Points – activates the insert mode and allows you to insert points. You can also 
move points, just as in the move mode. If, however, you click at the curve between two 
points and move the mouse a little while holding down the mouse button you insert a new 
point. The point is a smooth point, and the lines to the control points are parallel and remain
so when moved. If you wish to create a corner point you must first insert either a smooth or 
a symmetrical point which is then converted to a corner point by using Corner Point.

• Delete Points – deletes one or several selected points. If you wish to select several points,
click the appropriate points while holding down the Shift key. First select the points to be 
deleted, and then click this icon or press Delete key.

• Split Curve – splits a curve into two or more curves. Select the point or points where you 
want to split the curve, then click.

• Convert To Curve – converts a curve into a straight line or converts a straight line into a 
curve. If you select a single point, the curve before the point will be converted. If two points 
are selected, the curve between both points will be converted. If you select more than two 
points, each time you click this icon, a different portion of the curve will be converted. If 
necessary, round points are converted into corner points and corner points are converted 
into round points. If a section of the curve is straight, the end points of the line have a 
maximum of one control point each. They cannot be modified to control points unless the 
straight line is converted back to a curve.

• Corner Point – converts the selected point or points into corner points (Figure 28). Corner 
points have two movable control points, which are independent from each other. A curved 
line, therefore, does not go straight through a corner point, but forms a corner.

Figure 28: Corner point

• Smooth Transition – converts a corner point or symmetrical point into a smooth point 
(Figure 29). Both control points of the corner point are aligned in parallel and can only be 
moved simultaneously. The control points may differ in length, allowing you to vary the 
degree of curvature.

Figure 29: Smooth transition point
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• Symmetric Transition – converts a corner point or a smooth point into a symmetrical point
(Figure 30). Both control points of the corner point are aligned in parallel and have the 
same length. They can only be moved simultaneously and the degree of curvature is the 
same in both directions.

Figure 30: Symmetric transition point

• Close Bézier – closes a line or a curve. A line is closed by connecting the last point with 
the first point, indicated by an enlarged square.

• Eliminate Points – marks the current point or the selected points for deletion. This 
happens when the point is located on a straight line. If you convert a curve or a polygon 
with the Convert to Curve tool into a straight line or you change a curve with the mouse so
that a point lies on the straight line, it is removed. The angle from which the point reduction 
is to take place can be set by going to Tools > Options > LibreOffice Draw > Grid.

Adding comments to a drawing

Draw supports comments similar to those in Writer and Calc.

1) Go to Insert > Comment the main menu bar. A comment box appears with a small marker 
box containing your initials in the upper left-hand corner of your drawing. Draw 
automatically adds your name and the date at the bottom of the comment (Figure 31).

2) Type or paste your comment into the text box.

3) To apply basic formatting to the text, right-click and select the formatting option from the 
context menu.

4) To delete a comment, right-click on the comment or marker box and select an option from 
the context menu or click on the small triangle in the bottom right of the comment and 
select an option from the context menu.

5) To move a comment, click on the small marker box and drag it to a new position.

6) To show or hide the comments, go to View > Comments.

Figure 31: Comment in a drawing

Note

For your initials and name to appear in a comment, you have to enter your user data. 
Go to Tools > Options > LibreOffice > User Data and enter all the necessary data. 
If more than one person edits the document, each author is automatically allocated a 
different background color.
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Connecting and breaking lines

It is possible in Draw to connect separate line elements together to make one line, or to break a 
line that is composed of separate elements.

To connect lines, select them and go to Modify > Connect on the main menu bar. The lines are 
converted to curves and adjacent end points are joined together. The resulting shape is a poly line,
not a closed shape.

To break a line that is composed of separate elements, select it and go to Modify > Break. Each 
separate element is now indicated with start and end points. Click on an element and drag it to a 
new position.
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