
Draw Guide 7.4

Appendix B, 
Toolbars



Copyright

This document is Copyright © 2023 by the LibreOffice Documentation Team. Contributors are 
listed below. This document maybe distributed and/or modified under the terms of either the GNU
General Public License (https://www.gnu.org/licenses/gpl.html), version 3 or later, or the Creative 
Commons Attribution License (https://creativecommons.org/licenses/by/4.0/), version 4.0 or later. 
All trademarks within this guide belong to their legitimate owners.

Contributors
Contributors for this edition:

Peter Schofield

Contributors for previous editions:
Dave Barton Kees Kriek Jean Hollis Weber Peter Schofield

Feedback
Please direct any comments or suggestions about this document to the Documentation Team 
mailing list: loguides@community.documentfoundation.org.

Note

Everything sent to a mailing list, including email addresses and any other 
personal information that is written in the message, is publicly archived and 
cannot be deleted.

Publication date and software version
Published January 2023. Based on LibreOffice 7.4 Community.
Other versions of LibreOffice may differ in appearance and functionality.

Documentation for LibreOffice is available at https://documentation.libreoffice.org/en/

https://documentation.libreoffice.org/en/
mailto:loguides@community.documentfoundation.org
https://creativecommons.org/licenses/by/4.0/
https://www.gnu.org/licenses/gpl.html


Contents
Copyright..........................................................................................................................2

Contributors................................................................................................................................2

Feedback....................................................................................................................................2

Publication date and software version........................................................................................2

Introduction......................................................................................................................5

Using toolbars..................................................................................................................5
Draw toolbars available..............................................................................................................5

Closing toolbars..........................................................................................................................5

Moving toolbars..........................................................................................................................5
Docked toolbars.....................................................................................................................5
Floating toolbars....................................................................................................................6
Floating sub-toolbars.............................................................................................................6
Docking a floating toolbar......................................................................................................7

Locking toolbars..........................................................................................................................7
Docked toolbars.....................................................................................................................7
Locking toolbars and sub-toolbars.........................................................................................7

Editing toolbars...........................................................................................................................8
Adding tools...........................................................................................................................8
Deleting tools.........................................................................................................................8
Customizing toolbars.............................................................................................................8

Toolbars............................................................................................................................8
3D-Objects..................................................................................................................................9

3D-Settings.................................................................................................................................9

Align Objects...............................................................................................................................9

Comments................................................................................................................................10

Distribute Selection...................................................................................................................10

Drawing.....................................................................................................................................10

Edit Points.................................................................................................................................14

Find...........................................................................................................................................15

Fontwork...................................................................................................................................15

Form Controls...........................................................................................................................16

Form Design.............................................................................................................................16

Form Navigation.......................................................................................................................17

Gluepoints.................................................................................................................................17

Image........................................................................................................................................18

Insert.........................................................................................................................................18

Legacy Circles and Ovals.........................................................................................................19

Legacy Rectangles...................................................................................................................19

Line and Filling..........................................................................................................................19

Master View..............................................................................................................................20

Media Playback........................................................................................................................20

Options.....................................................................................................................................21

Redaction..................................................................................................................................21

Standard...................................................................................................................................21

Appendix B, Toolbars | 3



Standard (Viewing Mode).........................................................................................................22

Table.........................................................................................................................................23

Text Formatting.........................................................................................................................23

Transformations........................................................................................................................24

Zoom.........................................................................................................................................24

4| Appendix B, Toolbars



Introduction

Draw provides several toolbars to help in creating drawings. Each toolbar has a default set of 
tools and the option to add additional tools.

Note

The icons displayed in the Draw toolbars illustrated in this appendix may differ 
from what is displayed on a computer screen. Toolbar icons depend on the 
computer operating system being used and how LibreOffice has been set up. For 
more information on customizing LibreOffice and the toolbars, see the Getting 
Started Guide.

Using toolbars

To display and make a toolbar active, go to View > Toolbars on the Menu bar. A submenu opens
with an alphabetical list of toolbars available for creating drawings in LibreOffice Draw. Click on a 
toolbar name to display it and make it active. Active toolbars are indicated by highlighting or a 
check mark next to the name.

Draw toolbars available
3D-Objects
3D-Settings
Align Objects
Comments
Distribute Selection
Drawing
Edit Points
Find
Fontwork
Form Controls

Form Design
Form Navigation
Gluepoints
Image
Insert
Legacy Circles and Ovals
Legacy Rectangles
Line and Filling
Master View
Media Playback

Options
Redaction
Standard
Standard (Viewing Mode)
Table
Text
Text Formatting
Transformations
Zoom

Note

Some toolbars, although selected in View > Toolbars on the Menu bar, will not 
display until an object of the correct type is selected in a drawing. For example, 
the Image toolbar only displays when an image is selected.

Closing toolbars
To close a toolbar, use one of the following methods:

• Go to View > Toolbars on the Menu bar and deselect the toolbar.

• Right-click on a tool on a toolbar and select Close Toolbar from the context menu.

• Click on the X in the right corner of the title bar of a floating toolbar.

Moving toolbars

Docked toolbars
By default, some toolbars are docked into position in the Draw main window. For example, the 
Standard toolbar is docked at the top of the main window. Docked toolbars can be undocked and
moved to a new docked position on the main window or left as a floating toolbar. Before moving a
toolbar, the toolbar must be unlocked.
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Figure 1: Toolbar handles highlighted

1) Move the cursor over the small vertical handle at the left end of the toolbar (highlighted in 
Figure 1). The cursor changes to a moving cursor for the computer system and setup.

2) Click and drag the toolbar to a new location. This can be a new docked position or a 
floating toolbar. A hashed border appears around the toolbar indicating the toolbar 
position as it is dragged.

3) Release the cursor when the required position is reached.

Note

If the small vertical bar is not visible at the left end of a docked toolbar, then the 
toolbar is locked into position. A docked toolbar must be unlocked before it can be
moved to a new position in the Draw main window. See “Locking toolbars” on 
page 7 for more information.

Floating toolbars
To move a floating toolbar, click on its title bar and drag it to a new floating location. Release the 
cursor when the toolbar is in the required position. A floating toolbar does not have to be 
positioned on the Draw main window for it to function.

Floating sub-toolbars
Some tools on a toolbar have a triangle ▼ to the right of the tool indicating that more tools are 
available on a sub-toolbar, for example Basic Shapes on the Drawing toolbar. Sub-toolbars can 
be turned into floating toolbars and moved into a new position as follows:

1) Move the cursor over the horizontal handle at the top of the toolbar (highlighted in 
Figure 2). The cursor changes to the moving cursor used for the computer system and 
setup.

2) Click and drag the toolbar to a new location to create a floating sub-toolbar.

3) Release the cursor when the required position is reached.

4) To close the floating sub-toolbar, right-click on the triangle ▼ in the sub-toolbar title bar 
and select Close Toolbar from the context menu.

Figure 2: Creating floating sub-toolbar
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Docking a floating toolbar
To dock a floating toolbar, use one of the following methods:

• Click on the title bar and drag it to the top, bottom, left side, or right side of the main 
window. When the toolbar reaches a docking position, a hashed border appears at the 
docked position. Release the cursor and the toolbar is docked.

• Right-click on the toolbar and select Dock Toolbar from the context menu. The toolbar 
moves into a docked position. If the position is not suitable, move the toolbar to a new 
docked position.

• To dock all floating toolbars that are active, right-click on the toolbar and select Dock All 
Toolbars from the context menu.

Locking toolbars

Docked toolbars
When a toolbar has been docked into position on the Draw main window, the toolbar can also be 
locked into position preventing the toolbar from becoming a floating toolbar.

• To lock a toolbar into a docked position, right-click in a blank area on the toolbar and 
select Lock Toolbar Position in the context menu. A check mark appears against this 
option indicating the toolbar is now locked.

• To unlock a toolbar, right-click in a blank area on the toolbar and click on Lock Toolbar 
Position in the context menu. The check mark next to this option disappears indicating 
the toolbar is now unlocked. A small vertical or horizontal bar appears at the left end or 
top of the toolbar indicating that the toolbar is unlocked. This bar is also is used to move 
the toolbar.

Note

Some toolbars cannot be docked or locked into position. This is indicated by the 
options Dock Toolbar and/or Lock Toolbar Position being grayed out, making 
the options unavailable.

Locking toolbars and sub-toolbars
To prevent toolbars and sub-toolbars from becoming floating toolbars, all toolbars and 
sub-toolbars have to be locked as follows:

1) Save the drawing that is open in Draw.

2) Go to View > Toolbars on the Menu bar and select Lock Toolbars from the context 
menu.

3) Select Restart Now in the Restart LibreOffice dialog that opens to activate the Lock 
Toolbars option.

4) To unlock toolbars and sub-toolbars so they can become floating sub-toolbars, repeat 
Steps 1 thru 3. The Lock Toolbars option is an on/off switch.

Note

Using the Lock Toolbars option affects all toolbars and sub-toolbars available in 
LibreOffice modules.
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Editing toolbars
When LibreOffice is installed on a computer, it includes a set of toolbars suitable for each 
LibreOffice component. Each toolbar has a default set of visible tools. Tools can be added or 
deleted, and toolbars can be customized.

Adding tools
1) Right-click in a blank area on a toolbar, or click on the triangle ▼ on the right of the 

toolbar title bar.

2) Select Visible Buttons from the context menu to display a list of available tools.

3) Click on the tool required and the tool appears in the toolbar. The list of available tools 
closes automatically. A highlight or check mark next to the tool indicates that the tool is 
already installed on the toolbar.

Note

When adding tools using Visible Buttons, the tool is added to the toolbar at the 
same position as the tool appears in the Visible Buttons list. That is, the top tool 
in Visible Buttons appears at the left end of the toolbar and the bottom tool 
appears at the right end of the toolbar. Tool positions cannot be changed using 
Visible Buttons.

Deleting tools
1) Right-click in a blank area on a toolbar, or click on the triangle ▼ on the right of the 

toolbar title bar.

2) Select Visible Buttons from the context menu to display a list of available tools.

3) Click on the tool no longer required and the tool is removed from the toolbar. The highlight
or check mark next to the tool is also removed. The list of available tools closes 
automatically.

Customizing toolbars
Extra tools and commands that are not available in Visible Buttons can be added to a toolbar 
using customization (View > Toolbars > Customize on the Menu bar). Customization also 
allows the creation of new toolbars if a specific set of tools are required for a specific task. For 
information on customizing toolbars, see the Getting Started Guide.

Toolbars

The available tools listed for each toolbar below are all available for installation on a toolbar when
Visible Buttons is opened in the context menu for each toolbar. The tools already installed on a 
toolbar are indicated in Visible Buttons either by the tool icon being highlighted or by a check 
mark. This install indication depends on computer setup and computer operating system being 
used.

On some toolbars, the icons have a triangle ▼ to the right of an icon. Click on this triangle to 
open further options that are available for use.

Some of the tools in the toolbars also have the option of using a keyboard shortcut instead of 
clicking on the tool. For a full list of keyboard shortcuts that are available in Draw, see Appendix 
A, Keyboard Shortcuts.
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3D-Objects
The 3D-Objects toolbar (Figure 3) provides tools to create 3D objects in a slide. It is activated by 
going to View > Toolbars > 3D-Objects on the Menu bar. Alternatively, click on the triangle ▼ 
next to the 3D-Objects icon displayed on the Drawing toolbar to open a submenu giving access 
to the available 3D objects.

Figure 3: 3D-Objects toolbar

3D-Objects tools numbered position from left to right
1) Cube
2) Sphere
3) Cylinder
4) Cone

5) Pyramid
6) Torus
7) Shell
8) Half Sphere

3D-Settings
The 3D-Settings toolbar (Figure 4) and its tools only become active when an object has been 
converted to 3D using the tool Toggle Extrusion and the converted object is then selected.

Figure 4: 3D-Settings toolbar

3D-Settings tools numbered position from left to right
1) Toggle Extrusion
2) Tilt Down
3) Tilt Up  
4) Tilt Left
5) Tilt Right

6) Depth
7) Direction
8) Lighting
9) Surface

10) 3D Color

The following tools on this toolbar have a triangle ▼ on the right of the icon. Click on this triangle 
to open a drop-down menu giving access to various options as follows:

• Depth –– 3D extrusion depth – 0cm; 1cm; 2.5cm; 5cm; 10cm; Infinity; Custom. The 
measurement unit depends on the settings in Tools > Options > LibreOffice Draw > 
General (macOS LibreOffice > Preferences > LibreOffice Draw > General).

• Direction –– 3D extrusion direction and type – Parallel; Perspective.

• Lighting –– lighting direction and lighting level of 3D extrusion – Bright; Normal; Dim.

• Surface –– surface type of 3D extrusion – Wire Frame; Matt; Plastic; Metal.

• 3D Color –– color of 3D extrusion. Select a color from one of the available color palettes.

Align Objects
The Align Objects toolbar (Figure 5) provides tools for aligning several objects in a drawing to 
improve the visual impact of a drawing.
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Figure 5: Align Objects toolbar

Align Objects tools numbered position from left to right
1) Left
2) Centered
3) Right

4) Top
5) Center
6) Bottom

Comments
The Comments toolbar (Figure 6) provides tool for adding, deletion, and navigation of comments 
in a drawing. To use comments, it is recommended to add the name and initials of all users in 
Tools > Options > LibreOffice > User Data (macOS LibreOffice > Preferences > LibreOffice 
> User Data) so that comments can be easily identified.

Figure 6: Comments toolbar

Comments tools numbered position from left to right
1) Comment
2) Previous Comment
3) Next Comment

4) Delete Comment
5) Delete All Comments

Distribute Selection
The Distribute Selection toolbar (Figure 7) provides tools to distribute three or more selected 
objects evenly along the horizontal axis or vertical axis. Also, the spacing between objects can be
evenly distributed.

Figure 7: Distribute Selection toolbar

Distribute Selection tools numbered position from left to right
1) Horizontally Left
2) Horizontally Center
3) Horizontally Spacing
4) Horizontally Right

5) Vertically Top
6) Vertically Center
7) Vertically Spacing
8) Vertically Bottom

Drawing
The Drawing toolbar (Figure 8) provides the majority of the tools normally used to create graphic 
objects in a drawing. By default, this toolbar is normally docked on the left side of the Workspace.
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Figure 8: Drawing toolbar

Available Drawing tools numbered position from left to right
1) Select
2) Zoom & Pan
3) Zoom
4) Text Box
5) Vertical Text
6) Insert Fontwork
7) Line Color
8) Fill Color
9) Line

10) Rectangle
11) Ellipse
12) Line Ends with Arrow
13) Lines and Arrows
14) Curves and Polygons
15) Connectors
16) Basic Shapes
17) Symbol Shapes
18) Block Arrows (Arrow Shapes in Visible 

Buttons))
19) Flowchart (Flowchart Shapes in Visible 

Buttons)
20) Callouts (Callout Shapes in Visible Buttons)

21) Stars and Banners (Star Shapes in Visible 
Buttons)

22) 3D Objects
23) Rotate
24) Flip
25) Align Objects
26) Arrange
27) Select at least three objects to distribute 

(Distribution in visible Buttons)
28) Shadow
29) Crop Image (Crop in Visible Buttons)
30) Filter
31) Points (Edit Points in Visible Buttons)
32) Show Gluepoints Function (Gluepoints in 

Visible Buttons)
33) To Curve
34) To Polygon
35) To 3D
36) T0 3D Rotation Object
37) Toggle Extrusion
38) Insert
39) Controls

Some tool shapes on the Drawing toolbar change depending on the last tool that had previously 
been selected and used.

• Click on the triangle ▼ to the right of a tool to open a pop-up toolbar. Select the required 
shape to add to a drawing.

• To create a sub-toolbar, click and drag at the top of the pop-up toolbar to an empty area 
on the main window. The sub-toolbars for each object type and the various shapes 
available are shown in Figures 9 to 18.

Figure 9: Lines and Arrows sub-toolbar

Lines and Arrows numbered position from left to right
1) Line Ends with Arrow
2) Line with Circle/Arrow
3) Line with Square/Arrow

4) Line with Arrows
5) Line Starts with Arrow
6) Line with Arrow/Circle
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7) Line with Arrow/Square
8) Line

9) Dimension Line
10) Line (45°)

Figure 10: Curves and Polygons sub-toolbar

Curves and Polygons numbered position from left to right
1) Curve, Filled
2) Polygon, Filled
3) Polygon (45°), Filled
4) Freeform Line, Filled

5) Curve
6) Polygon
7) Polygon (45°)
8) Freeform Line

Figure 11: Connectors sub-toolbar

Available Connectors numbered position from left to right
1) Connector Ends with Arrow
2) Straight Connector Ends with Arrow
3) Curved Connector Ends with Arrow
4) Line Connector Ends with Arrow
5) Connector
6) Straight Connector
7) Curved Connector
8) Line Connector
9) Connector with Arrows

10) Straight Connector with Arrows
11) Curved Connector with Arrows
12) Line Connector with Arrows
13) Connector Starts with Arrow
14) Straight Connector Starts with Arrow

15) Curved Connector Starts with Arrow
16) Line Connector Starts with Arrow
17) Connector Ends with Circle
18) Straight Connector Ends with Circle
19) Curved Connector Ends with Circle
20) Line Connector Ends with Circle
21) Connector Starts with Circle
22) Straight Connector Starts with Circle
23) Curved Connector Starts with Circle
24) Line Connector Starts with Circle
25) Connector with Circles
26) Straight Connector with Circles
27) Curved Connector with Circles
28) Line Connector with Circles

Figure 12: Basic Shapes sub-toolbar

Basic Shapes numbered position from left to right
1) Rectangle
2) Rectangle, Rounded
3) Square
4) Square, Rounded
5) Parallelogram
6) Trapezoid
7) Ellipse
8) Circle
9) Circle Pie

10) Circle Segment

11) Arc
12) Block Arc
13) Isosceles Triangle
14) Right Triangle
15) Diamond
16) Regular Pentagon
17) Hexagon
18) Octagon
19) Cylinder
20) Cube

12 | Appendix B, Toolbars



21) Folded Corner
22) Cross

23) Frame
24) Ring

Figure 13: Symbol Shapes sub-toolbar

Symbol Shapes numbered position from left to right
1) Smiley Face
2) Heart
3) Sun
4) Moon
5) Cloud
6) Lightning Bolt
7) Flower
8) Prohibited
9) Puzzle

10) Square Bevel
11) Octagon Bevel
12) Diamond Bevel
13) Double Bracket
14) Left Bracket
15) Right Bracket
16) Double Brace
17) Left Brace
18) Right Brace

Figure 14: Block Arrows sub-toolbar

Block Arrows numbered position from left to right
1) Right Arrow
2) Left Arrow
3) Down Arrow
4) Up Arrow
5) Left and Right Arrow
6) Up and Down Arrow
7) Circular Arrow
8) S-shaped Arrow
9) Split Arrow

10) Right or Left Arrow
11) 4-way Arrow
12) Corner Right Arrow
13) Chevron

14) Pentagon
15) Striped Right Arrow
16) Up, Right and Down Arrow
17) Notched Right Arrow
18) Up and Right Arrow
19) Right Arrow Callout
20) Left Arrow Callout
21) Down Arrow Callout
22) Up Arrow Callout
23) Left and Right Arrow Callout
24) Up and Down Arrow Callout
25) 4-way Arrow Callout
26) Up and Right /Arrow Callout

Figure 15: Flowchart sub-toolbar

Flowchart symbols numbered position from left to right
1) Flowchart: Process
2) Flowchart: Alternate Process
3) Flowchart: Decision
4) Flowchart: Data
5) Flowchart: Predefined Process

6) Flowchart: Internal Storage
7) Flowchart: Document
8) Flowchart: Multidocument
9) Flowchart: Terminal

10) Flowchart: Preparation
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11) Flowchart: Manual Input
12) Flowchart: Manual Operation
13) Flowchart: Connector
14) Flowchart: Off-page Connector
15) Flowchart: Card
16) Flowchart: Punched Tape
17) Flowchart: Summing Junction
18) Flowchart: Or
19) Flowchart: Collate

20) Flowchart: Sort
21) Flowchart: Extract
22) Flowchart: Merge
23) Flowchart: Stored Data
24) Flowchart: Delay
25) Flowchart: Sequential Access
26) Flowchart: Magnetic Disc
27) Flowchart: Direct Access Storage
28) Flowchart: Display

Figure 16: Callouts sub-toolbar

Callouts numbered position from left to right
1) Rectangular Callout
2) Rounded Rectangular Callout
3) Round Callout
4) Cloud

5) Line Callout 1
6) Line Callout 2
7) Line Callout 3

Figure 17: Stars and Banners sub-toolbar

Stars and Banners numbered position from left to right
1) 4-Point Star
2) 5-Point Star
3) 6-Point Star
4) 8-Point Star
5) 12-Point Star
6) 24-Point Star

7) Explosion
8) Vertical Scroll
9) Horizontal Scroll

10) Signet
11) Doorplate
12) 6-Point Star, Concave

Figure 18: 3D-Objects sub-toolbar

3D-Objects numbered position from left to right
1) Cube
2) Sphere
3) Cylinder
4) Cone

5) Pyramid
6) Torus
7) Shall
8) Half-Sphere

Edit Points
The Edit Points toolbar (Figure 19) provides tools for editing the points of a curve or an object 
that has been converted to a curve. The toolbar only becomes active when an object is selected 
and one of the following methods is used to open the toolbar:

• Click on Edit Points on the Drawing toolbar.

• Use the keyboard shortcut F8.
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Figure 19: Edit Points toolbar

Edit Points tools numbered position from left to right
1) Edit Points
2) Move Points
3) Insert Points
4) Delete Points
5) Convert to Curve
6) Close Bezier

7) Split Curve
8) Corner Point
9) Smooth Transition

10) Symmetric Transition
11) Eliminate Points

Find
The Find toolbar (Figure 20) opens by default in the bottom left corner of the Draw main window. 
This toolbar is normally docked at the bottom left of the Draw main window above the Status 
Bar. However, it can be undocked and made into a floating toolbar.

Figure 20: Find toolbar

Find tools numbered position from left to right
1) Close Find Bar
2) Find Values
3) Find Previous
4) Find Next

5) Find All
6) Match Case
7) Find and Replace
8) [place holder for message]

Fontwork
The Fontwork toolbar (Figure 21) is used to create graphical text objects in a drawing and 
provide the tools for editing the graphical text object. This toolbar only becomes active when a 
Fontwork graphical text object in the drawing has been selected.

Figure 21: Fontwork toolbar

Fontwork tools numbered position from left to right
1) Insert Fontwork Text 
2) Fontwork Shape
3) Fontwork Same Letter Heights

4) Fontwork Alignment
5) Fontwork Character Spacing
6) Toggle Extrusion

Some tools on the Fontwork toolbar have a triangle ▼ to the right of the tool. Click on the triangle
to open a pop-up toolbar or drop-down option list.

• Fontwork Shape –– select a shape for the Fontwork graphical text object from available 
options.

• Fontwork Alignment –– select paragraph alignment from available options.

• Fontwork Character Spacing –– select character spacing from available options.
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Form Controls
The Form Controls toolbar (Figure 22) provides the tools required to create an interactive form. 
This allows controls to be added to a form in a text, drawing, spreadsheet, presentation, or HTML
document (for example a button that opens another drawing or document).

Figure 22: Form Controls toolbar

Form Controls tools numbered position from left to right
1) Select
2) Design Mode
3) Toggle Form Control Wizards
4) Form Design
5) Control Properties
6) Form Properties
7) Label
8) Text Box
9) Check Box

10) Option Button
11) List Box
12) Combo Box
13) Push Button
14) Image Button

15) Formatted Field
16) Date Field
17) Numerical Field
18) Group Box
19) Time Field
20) Currency Field
21) Pattern Field
22) Table Control
23) Navigation Bar
24) Image Control
25) File Selection
26) Spin Button
27) Scrollbar

Form Design
The Form Design toolbar (Figure 23) opens a form in Design Mode so that it can be edited. 
Controls of the form cannot be activated, or its contents edited, when in Design Mode. However, 
the position and size of the controls can be changed, other properties edited, and added or 
deleted controls in Design Mode.

Figure 23: Form Design toolbar

Form Design tools numbered position from left to right
1) Select
2) Control Properties
3) Form Properties
4) Position and Size
5) Form Navigator
6) Activation Order
7) Add Field
8) Automatic Control Focus
9) Bring to Front

10) Send to Back

11) Group
12) Ungroup
13) Enter Group
14) Exit Group 
15) Align Objects
16) Open in Design Mode
17) Display Grid
18) Snap to Grid
19) Helplines While Moving
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Form Navigation
The Form Navigation toolbar (Figure 24) provides tools to edit a database table or control the 
data view. It is normally displayed at the bottom of a document that contains fields linked to a 
database. Also, it is only active when forms are connected to a database and an inactivate 
toolbar is shown in Figure 24.

The Form Navigation toolbar also allows movement within records as well as inserting and 
deleting records. If data is saved in a form, the changes are transferred to the database. This 
toolbar also provides tools providing sort, filter, and search functions for data records.

Figure 24: Form Navigation toolbar

Form Navigation tools numbered position from left to right
1) Find Record
2) Record
3) Absolute Record
4) Text -> Record
5) Total No. of Records
6) First Record
7) Previous Record
8) Next Record
9) Last Record

10) New Record
11) Save Record
12) Undo: Data entry

13) Delete Record
14) Refresh
15) Refresh Control
16) Sort
17) Sort Ascending
18) Sort Descending
19) AutoFilter
20) Apply Filter
21) Form-Based Filters
22) Reset Filter/Sort
23) Data source as Table

Gluepoints
The Gluepoints toolbar (Figure 25) provides tools to insert a gluepoint or modify the properties of 
a gluepoint. A gluepoint is a point where a connector is attached to an object. By default, 
LibreOffice automatically places a gluepoint at the center of each side of the bounding rectangle 
for every object created.

Figure 25: Gluepoints toolbar

Gluepoint tools numbered position from left to right
1) Insert Gluepoint
2) Exit Direction Left
3) Exit Direction Top
4) Exit Direction Right
5) Exit Direction Bottom
6) Gluepoint Relative

7) Gluepoint Horizontal Left
8) Gluepoint Horizontal Center
9) Gluepoint Horizontal Right

10) Gluepoint Vertical Top
11) Gluepoint Vertical Center
12) Gluepoint Vertical Bottom
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Image
The Image toolbar (Figure 26) provides tools to edit, modify, align, reposition and resize images. 
The toolbar only becomes active and available when an image is selected in a drawing. The 
Image toolbar automatically replaces the Line and Filling toolbar when it becomes active.

Figure 26: Image toolbar

Available Image tools numbered position from left to right
1) Position and Size
2) Align Objects
3) Left
4) Centered
5) Right
6) Top
7) Center
8) Bottom
9) Arrange

10) Bring to Front
11) Bring Forward 
12) Send Backward
13) Send to Back 
14) In Front of Object
15) Behind Object
16) Reverse

17) Line Style
18) Line Width
19) Line Color
20) Area Style/Filling
21) Fill Color
22) Shadow
23) Filter
24) Image Mode
25) Crop
26) Vertically
27) Horizontally
28) Transformations
29) Transparency
30) Color
31) Line
32) Area

Insert
The Insert toolbar (Figure 27) provides tools to insert different types of objects into a drawing.

Figure 27: Insert toolbar

Insert tools numbered position from left to right
1) New Page
2) Floating Frame
3) Insert Page from File
4) Table
5) Image

6) Insert Audio or Video (Media in Visible 
Buttons)

7) Formula Object
8) Chart
9) OLE Object
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Legacy Circles and Ovals
The Legacy Circles and Ovals toolbar (Figure 28) provides tools to insert different types of circles
and ovals into a drawing.

Figure 28: Legacy Circles and Ovals toolbar

Legacy Circles and Ovals tools numbered position from left to right
1) Insert Ellipse
2) Circle
3) Ellipse Pie
4) Circle Pie
5) Ellipse Segment
6) Circle Segment
7) Ellipse, Unfilled

8) Circle, Unfilled
9) Ellipse Pie, Unfilled

10) Circle Pie, Unfilled
11) Ellipse Segment, Unfilled
12) Circle Segment, Unfilled
13) Arc
14) Circle Arc

Legacy Rectangles
The Legacy Rectangles toolbar (Figure 29) provides tools to insert different types of rectangles 
and squares into a drawing.

Figure 29: Legacy Rectangles toolbar

Legacy Rectangles tools numbered position from left to right
1) Insert Rectangle
2) Square
3) Rectangle, Rounded
4) Rounded Square

5) Rectangle, Unfilled
6) Square, Unfilled
7) Rounded Rectangle, Unfilled
8) Rounded Square, Unfilled

Line and Filling
The Line and Filling toolbar (Figure 30) provides tools and drop-down lists for editing lines, 
arrows, and object borders. The tools available vary depending on the type of object selected for 
editing.

Figure 30: Line and Filling toolbar

Available Line and Filling tools numbered position from left to right
1) Position and Size
2) Align Objects

3) Left
4) Centered
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5) Right
6) Top
7) Center
8) Bottom
9) Arrange

10) Bring to Front
11) Bring Forward
12) Send Backward
13) Send to Back
14) In Front of Object
15) Behind Object
16) Reverse
17) Line Style
18) Line Width
19) Line Color
20) Area Style/Filling

21) Fill Color
22) Shadow
23) Arrow Style
24) Vertically
25) Horizontally
26) Transformations
27) Line
28) Area
29) 3D Effects
30) Image Map
31) Animation
32) Interaction
33) Show the Styles Sidebar
34) Display Grid
35) Helplines While Moving

Master View
The Master View toolbar (Figure 31) provides tools to create a new master page, rename a 
master page, delete a master page, and close master view. This toolbar is only active when Draw
is in master view.

Figure 31: Master View toolbar

Master View tools from numbered position left to right
1) New Master
2) Rename Master

3) Delete Master
4) Close Master View

Media Playback
The Media Playback toolbar (Figure 32) provides the standard tools required to insert, view, play, 
and listen to audio and video files. The toolbar only becomes active when an audio or video file is
selected. Draw supports many different media formats depending on the computer operating 
system being used.

Figure 32: Media Playback toolbar

Media Playback tools numbered position from left to right
1) Insert Audio or Video
2) Play
3) Pause
4) Stop
5) Repeat

6) Position
7) Mute
8) Volume
9) View
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Options
The Options toolbar (Figure 33) provides tools for editing various settings for newly created 
drawings, for example how objects snap to the grid when being moved or resized.

Figure 33: Options toolbar

Options tools numbered position from left to right
1) Rotation Mode after Clicking Object
2) Display Grid
3) Display Snap Guides
4) Helplines While Moving
5) Snap to Grid
6) Snap to Snap Guides
7) Snap to Page Margins

8) Snap to Object Borders
9) Snap to Object Points

10) Allow Quick Editing
11) Select Text Area Only
12) Double-click to edit Text
13) Modify Object with Attributes
14) Exit All Groups

Redaction
The Redaction toolbar (Figure 34) is used to block portions of a drawing protecting sensitive 
information and helps enterprises and organizations to comply with regulations on confidentiality 
or privacy.

When a redacted drawing is exported to a new drawing, any redacted portions are removed from 
the new drawing and replaced by redaction blocks of pixels. This prevents any attempt to restore 
or copy the original contents. A redacted drawing is often exported to PDF for publication or 
sharing.

Figure 34: Redaction toolbar

Redaction tools numbered position from left to right
1) Rectangle
2) Freeform
3) Redacted Export (White)

4) Redacted Export (Black)
5) PDF

Standard
The Standard toolbar (Figure 35) is common to all LibreOffice components and provides the most
common tools when creating and editing documents using LibreOffice. The Standard toolbar 
differs between LibreOffice components to allow for different toolsets used in creating the 
different types of documents.

Figure 35: Standard toolbar
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Available Standard tools numbered position from left to right
1) Load URL
2) New
3) Templates
4) Open
5) Open Remote
6) Save
7) Save As
8) Email
9) Edit Mode

10) Export
11) Export Directly as PDF
12) Print Directly
13) Print
14) Cut
15) Copy
16) Paste
17) Clone Formatting (Clone in Visible Buttons)
18) Clear
19) Undo
20) Redo
21) Spelling
22) Auto Spellcheck
23) Display Grid (Grid in Visible Buttons)
24) Helplines While Moving
25) Zoom & Pan
26) Object Zoom
27) Zoom
28) Table
29) Insert Image (Image in Visible Buttons)
30) Insert Chart (Chart in Visible Buttons)

31) Insert Text Box (Text Box in Visible Buttons)
32) Insert Special Characters (Symbol in Visible 

Buttons)
33) Vertical Text
34) Insert Fontwork Text
35) Insert Hyperlink (Hyperlink in Visible Buttons)
36) Transformations
37) Flip
38) Position and Size
39) Align Objects
40) Distribution
41) Shadow
42) Crop
43) Filter
44) 3D Effects
45) Edit Points
46) Gluepoints
47) Toggle Extrusion
48) Show Draw Functions (Draw Functions in 

Visible Buttons)
49) LibreOffice Help
50) What’s That
51) Go to First Page
52) Go to Previous Page
53) Go to Next Page
54) Go to Last Page
55) Move Page to Start
56) Move Page Up
57) Move Page Down
58) Move Page to End

Standard (Viewing Mode)
The Standard (Viewing Mode) toolbar (Figure 36) provides tools to save, edit, and distribute a 
drawing.

Figure 36: Standard (Viewing Mode) toolbar

Standard (Viewing Mode) tools numbered position from left to right
1) Save As
2) Toggle Edit Mode (Edit Mode in Visible 

Buttons)
3) Toggle Read Only Mode (Read Only Mode in

Visible Buttons)
4) Attach to Email (Email in Visible Buttons)
5) Export Directly as PDF

6) Export as EPUB (EPUB in Visible Buttons)
7) Print Directly
8) Print
9) Copy 

10) Find and Replace
11) Zoom
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Table
The Table toolbar (Figure 37) provides tools and options to edit and format a table placed in a 
drawing. This toolbar only becomes active when a table is selected.

Figure 37: Table toolbar

Table tools numbered position from left to right
1) Table
2) Border Style
3) Border Color
4) Borders (Shift to overwrite)
5) Area Style/Filling
6) Fill Color
7) Merge Cells
8) Split Cells
9) Optimize

10) Align Top (Top in Visible Buttons)
11) Center Vertically (Center in Visible Buttons)
12) Align Bottom (Bottom in Visible Buttons)

13) Insert Row Above
14) Insert Row Below
15) Insert Column Before
16) Insert Column After
17) Delete Row
18) Delete Column
19) Delete Table
20) Select Table
21) Select Column
22) Select Row
23) Table Design
24) Table Properties

Text Formatting
The Text Formatting toolbar (Figure 38) provides tools for formatting text and alignment 
commands. This toolbar becomes active when text in a text box or graphic object has been 
selected and it automatically replaces the Line and Filling toolbar.

Figure 38: Text Formatting toolbar

Available Text Formatting tools numbered position from left to right
1) Font Name
2) Font Size
3) Increase Font Size (Increase in Visible 

Buttons)
4) Decrease Font Size (Decrease in Visible 

Buttons)
5) Bold
6) Italic
7) Underline

8) Double Underline
9) Strikethrough

10) Overline
11) Superscript
12) Subscript
13) Toggle Shadow (Shadow in Visible Buttons)
14) Apply outline attribute to font. Not all fonts 

implement this attribute. (Outline Font Effect 
in Visible Buttons)
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15) Clear
16) lowercase
17) UPPERCASE
18) Small capitals
19) Font Color
20) Character Highlighting Color
21) Toggle Unordered List (Unordered List in 

Visible Buttons)
22) Toggle Ordered List (Ordered List in Visible 

Buttons)
23) Outline Format
24) Align Left (Left in Visible Buttons)
25) Align Center (Center in Visible Buttons)
26) Align Right (Right in Visible Buttons)
27) Justified
28) Align Top (Top in Visible Buttons)

29) Center Vertically (Center in Visible Buttons)
30) Align Bottom (Bottom in Visible Buttons)
31) Set Line Spacing (Line Spacing in Visible 

Buttons)
32) Character Spacing
33) Increase Paragraph Spacing (Increase in 

Visible Buttons)
34) Decrease Paragraph Spacing (Decrease in 

Visible Buttons)
35) Text direction from left to right
36) Text direction from top to bottom
37) Left-To-Right
38) Right-To-Left
39) Select All
40) Character
41) Paragraph

Transformations
The Transformations toolbar (Figure 39) provides tools to modify the shape, orientation, or fill of 
selected objects.

Figure 39: Transformations toolbar

Transformations tools numbered position from left to right
1) Rotate
2) Flip
3) In 3D Rotation Object
4) Set in Circle (perspective)
5) Set to circle (slant)

6) Distort
7) Interactive transparency tool (Transparency 

tool in Visible Buttons)
8) Interactive gradient tool (Gradient tool in 

Visible Buttons)

Zoom
The Zoom toolbar (Figure 40) provides tools to reduce or enlarge the screen display of the 
current drawing.

Figure 40: Zoom toolbar

Zoom tools numbered position from left to right
1) Zoom In
2) Zoom Out
3) 100%
4) Zoom Previous
5) Zoom Next
6) Entire Page

7) Page Width
8) Optimal View (Optimal in Visible Buttons)
9) Object Zoom

10) Zoom & Pan
11) Shift
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