Chapter 7
Including Spreadsheets, Charts, and Other Objects
Copyright

This document is Copyright © 2010–2014 by the LibreOffice Documentation Team. Contributors are listed below. You may distribute or modify it under the terms of either the GNU General Public License (http://www.gnu.org/licenses/gpl.html), version 3 or later, or the Creative Commons Attribution License (http://creativecommons.org/licenses/by/4.0/), version 4.0 or later.

All trademarks within this guide belong to their legitimate owners.

Contributors
Michele Zarri T. Elliot Turner Jean Hollis Weber
Peter Schofield

Feedback
Please direct any comments or suggestions about this document to the Documentation Team’s mailing list: documentation@global.libreoffice.org

Note: Everything you send to a mailing list, including your email address and any other personal information that is written in the message, is publicly archived and cannot be deleted.

Acknowledgments
This chapter is based on Chapter 7 of the OpenOffice.org 3.3 Impress Guide. The contributors to that chapter are:
Peter Hillier-Brook Hazel Russman Jean Hollis Weber
Claire Wood Michele Zarri

Publication date and software version
Published 26 July 2014. Based on LibreOffice 4.2.

Note for Mac users
Some keystrokes and menu items are different on a Mac from those used in Windows and Linux. The table below gives some common substitutions for the instructions in this chapter. For a more detailed list, see the application Help.

<table>
<thead>
<tr>
<th>Windows or Linux</th>
<th>Mac equivalent</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tools &gt; Options</td>
<td>LibreOffice &gt; Preferences</td>
<td>Access setup options</td>
</tr>
<tr>
<td>menu selection</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Right-click</td>
<td>Control+click and/or right-click</td>
<td>Open a context menu</td>
</tr>
<tr>
<td></td>
<td>depending on computer setup</td>
<td></td>
</tr>
<tr>
<td>Ctrl (Control)</td>
<td>⌘ (Command)</td>
<td>Used with other keys</td>
</tr>
<tr>
<td>F5</td>
<td>Shift+⌘+F5</td>
<td>Open the Navigator</td>
</tr>
<tr>
<td>F11</td>
<td>⌘+T</td>
<td>Open the Styles and Formatting window</td>
</tr>
</tbody>
</table>

Documentation for LibreOffice is available at http://www.libreoffice.org/get-help/documentation
Contents

Copyright .................................................................................................................................................. 2
Note for Mac users .................................................................................................................................. 2

OLE objects ................................................................................................................................................. 5
  Inserting new OLE objects ....................................................................................................................... 5
  Inserting OLE objects from files ............................................................................................................. 6
  Editing OLE objects .................................................................................................................................. 7

Spreadsheets ................................................................................................................................................ 7
  Resizing and moving spreadsheets .......................................................................................................... 7
    Resizing ................................................................................................................................................. 7
    Moving ................................................................................................................................................... 8
  Editing spreadsheets ................................................................................................................................ 8
    Spreadsheet organization ...................................................................................................................... 8
    Inserting sheets .................................................................................................................................... 9
    Renaming sheets ................................................................................................................................... 9
    Moving and copying sheets .................................................................................................................. 9
    Deleting sheets .................................................................................................................................... 10
    Cell navigation ...................................................................................................................................... 10
    Entering data ....................................................................................................................................... 11
    Formatting cell data ............................................................................................................................. 11
  Formatting spreadsheets .......................................................................................................................... 12
    Manual formatting ............................................................................................................................... 12
    Using formatting styles .......................................................................................................................... 12
    Inserting rows, columns or cells ......................................................................................................... 13
    Deleting rows, columns or cells ........................................................................................................... 13
    Merging cells ........................................................................................................................................ 13
    Splitting cells ....................................................................................................................................... 13

Charts .......................................................................................................................................................... 13
  Inserting charts ....................................................................................................................................... 13
  Selecting chart type ................................................................................................................................. 14
  Chart types ............................................................................................................................................. 15
  Entering chart data .................................................................................................................................. 16
  Adding or removing chart elements ....................................................................................................... 17
  Chart formatting ..................................................................................................................................... 17
  Resizing and moving charts ..................................................................................................................... 17
    Resizing ............................................................................................................................................... 18
    Moving .................................................................................................................................................. 18
    Position and Size dialog ....................................................................................................................... 18
  Chart elements ....................................................................................................................................... 19
  Changing chart area background ............................................................................................................. 19
  Changing chart wall background ............................................................................................................ 20

Movies and sound .................................................................................................................................... 20
  Using media files ................................................................................................................................. 20
  Using the Gallery ................................................................................................................................. 21
  Media playback ..................................................................................................................................... 21
  Media player ......................................................................................................................................... 21
OLE objects

Object Linking and Embedding (OLE) is a software technology that allows embedding and linking of the following types of files or documents into an Impress presentation.

- LibreOffice spreadsheets
- LibreOffice charts
- LibreOffice drawings
- LibreOffice formulas
- LibreOffice text

The major benefit of using OLE objects is that it provides a quick and easy method of editing the object using tools from the software used to create the object. These file types can all be created using LibreOffice and OLE objects can be created from new or from an existing file.

Inserting new OLE objects

When you insert a new OLE object into your presentation, it is only available in your presentation and can only be edited using Impress.

1) Go to the slide where you want to insert the OLE object.
2) Select Insert > Object > OLE Object from the main menu bar.
3) On the Insert OLE Object dialog (Figure 1), select Create new.
4) Select the type of OLE object you want to create and click OK.
5) A new OLE object is inserted in the center of the slide in edit mode. The toolbars displayed in Impress will change providing the necessary tools for you to create the new OLE object.

Note

For computers operating Microsoft Windows there is an additional option of Further objects in the Object type list. Clicking on this option opens another Insert Object dialog allowing you to create an OLE object using other software that is compatible with OLE and LibreOffice. This option is available for new OLE objects and OLE objects from a file.
Inserting OLE objects from files

When you insert an existing file into your slide as an OLE object, by default any subsequent changes that are made to the original file do not affect the copy of the file inserted into your presentation. Similarly, changes to the file copy in your presentation do not change the original file. If you want any changes made to the file, either in the original or in your presentation, to appear in both versions you have to link the original file with your presentation when it is inserted.

![Figure 2: Inserting an OLE object from file](image)

To insert a file into your presentation as an OLE object:

1) Go to the slide where you want to insert the spreadsheet.
2) Choose Insert > Object > OLE Object from the menu bar.
3) On the Insert OLE Object dialog, select Create from file. The dialog changes to show a File text box (Figure 2).
4) Click Search and the Open dialog is displayed.
5) Locate the file you want to insert and click Open.
6) Select the Link to file option if you wish to insert the file as a live link so that any changes made are synchronized in both the original file and your presentation.
7) Click OK to insert the file as an OLE object.

![Figure 3: Example OLE object in edit mode](image)
Editing OLE objects

To edit an OLE object after it has been created or inserted from a file:

1) Double-click on the OLE object to open it in edit mode (Figure 3). The toolbars displayed in Impress will change to provide the tools necessary to edit the OLE object (Figure 4).

2) When finished editing the OLE object, click anywhere outside the OLE object to cancel editing.

3) Save your presentation. Any changes made to the OLE object are also saved.

![Example toolbars for OLE object editing](image)

Figure 4: Example toolbars for OLE object editing

Spreadsheets

To include a spreadsheet in an Impress slide, you can either insert an existing spreadsheet file or insert a new spreadsheet as an OLE object. See “OLE objects” on page 5 for more information.

Embedding a spreadsheet into Impress includes most of the functionality of a Calc spreadsheet. Impress is capable of performing complex calculations and data analysis. However, if you plan to use complex data or formulas, it is recommended to perform those operations in a separate Calc spreadsheet and use Impress only to display the embedded spreadsheet with the results.

You may be tempted to use spreadsheets in Impress for creating complex tables or presenting data in a tabular format. However, the Table Design feature in Impress is often more suitable and faster, depending on the complexity of your data; see Chapter 3 Adding and Formatting Text for more information.

The entire spreadsheet is inserted into your slide. If the spreadsheet contains more than one sheet and the one you want is not visible, double-click the spreadsheet and then select a different sheet from the row of sheet tabs at the bottom. See “Editing OLE objects” on page 7 for more information on editing the spreadsheet.

Resizing and moving spreadsheets

When resizing or moving a spreadsheet on slides, ignore the first row and first column (easily recognizable because of their light background color) and any horizontal and vertical scroll bars. They are only used for spreadsheet editing purposes and will not be included in the spreadsheet that appears on the slide.

Resizing

When selected, a spreadsheet OLE object is treated like any other object. However, resizing an embedded spreadsheet also changes the spreadsheet area that is visible on a slide.

To resize the area occupied by the spreadsheet on a slide:

1) Double-click the OLE object to enter edit mode, if it is not already active. Note the selection handles visible in the border surrounding the spreadsheet OLE object (Figure 3).

2) Move the mouse over one of the handles. The cursor changes shape to give a visual representation of the effects applied to the area.
3) Click and hold the left mouse button and drag the handle. The corner handles move the two adjacent sides simultaneously, while the handles at the midpoint of the sides modify one dimension at a time.

**Moving**

You can move a spreadsheet OLE object to change its position within the slide.

1) Select the spreadsheet OLE object so that the object selection handles are displayed.
2) Move the cursor over the object until the cursor changes shape (normally a hand, but this depends on your computer setup).
3) Click and drag the spreadsheet OLE object to the desired position.
4) Release the mouse button.

**Note**

Do not double click on the spreadsheet OLE object and enter into OLE object editing mode. Moving a spreadsheet OLE object in Impress is the same as moving any other object in Impress.

**Editing spreadsheets**

When a spreadsheet is inserted into a slide, it is in edit mode ready for inserting or modifying data or modifying the format (example shown in Figure 3). Note the position of the active spreadsheet cell and the small resizing handles on the object border.

When editing a spreadsheet, some of the toolbars change in Impress so that you can easily edit a spreadsheet (Figure 4). One of the most important changes is the presence of the Formula toolbar, just below the Formatting toolbar. The Formula toolbar contains (from left to right):

- The active cell reference or the name of a selected range of cells.
- The **Formula Wizard** icon.
- The **Sum** and **Function** icons or the **Cancel** and **Accept** icons, depending on the editing actions taken in the spreadsheet.
- A long edit box to enter or review the contents of the active cell.

If you are familiar with Calc, you will immediately recognize the tools and the menu items. See the Calc Guide for more information on how to create and edit spreadsheets in LibreOffice.

**Spreadsheet organization**

A spreadsheet consists of multiple tables called sheets, which in turn contain cells. However, in Impress, only one sheet can be shown at any one time in a slide when a spreadsheet with multiple sheets is embedded into an Impress slide. The default names for sheets are **Sheet 1**, **Sheet 2**, **Sheet 3** and so on, unless the sheets have been renamed, and the sheet names are shown at the bottom of the spreadsheet area (Figure 3).

Each sheet is organized into **cells**, which are the elementary units of the spreadsheet. They are identified by a row number (shown on the left hand side) and a column letter (shown in the top row). For example, the top left cell is identified as A1, while the third cell in the second row is C2. All data elements, whether text, numbers or formulas, are entered into a cell.

**Note**

If you have multiple sheets in your embedded spreadsheet, only the active sheet is shown on the slide after exiting edit mode.
**Inserting sheets**

If required, you can insert sheets to your embedded spreadsheet as follows:

1) Double-click on the embedded spreadsheet to open in edit mode (Figure 3).
2) Right-click on the sheet names and select **Insert > Sheet** from the context menu, or click on the plus sign to the right of the sheet names, or go to **Insert > Sheet** on the main menu bar to open the Insert Sheet dialog (Figure 5).
3) Select the sheet position, quantity of sheets to be inserted, sheet name or which spreadsheet file to use from the options available in the Insert Sheet dialog.
4) Click **OK** to close the dialog and insert the sheet.
5) When finished editing the embedded spreadsheet, click anywhere outside the border to cancel edit mode and save the changes.

![Insert Sheet dialog]

**Figure 5: Insert Sheet dialog**

**Renaming sheets**

If required, you can rename sheets in your embedded spreadsheet as follows:

1) Double-click on the embedded spreadsheet to open in edit mode (Figure 3).
2) Click on the sheet tab you want to rename to select the sheet.
3) Right-click on the sheet tab and select **Rename Sheet** from the context menu, or go to **Format > Sheet > Rename** on the main menu bar.
4) When finished editing the embedded spreadsheet, click anywhere outside the border to cancel edit mode and save the changes.

**Moving and copying sheets**

If required, you can move or copy sheets in your embedded spreadsheet as follows:

1) Double-click on the embedded spreadsheet to open in edit mode (Figure 3).
2) Right-click on the sheet names and select **Move/Copy Sheet** from the context menu, or go to **Edit > Sheet > Move/Copy** on the main menu bar to open the Move/Copy Sheet dialog (Figure 6).
3) Select whether to move or copy the sheet, the sheet location and position, and a new sheet name from the options available in the Move/Copy Sheet dialog.
4) Click **OK** to close the dialog and move or copy the sheet.
5) Alternatively, click on the sheet tab and drag it to a new position in the embedded spreadsheet.
6) When finished editing the embedded spreadsheet, click anywhere outside the border to cancel edit mode and save the changes.

![Move/Copy Sheet dialog](image)

**Figure 6: Move/Copy Sheet dialog**

### Deleting sheets

If required, you can delete sheets and remove them from your embedded spreadsheet as follows:

1) Double-click on the embedded spreadsheet to open in edit mode (Figure 3).
2) Click on the sheet tab you want to delete to select the sheet.
3) Right-click on the sheet tab and select **Delete Sheet** from the context menu, or go to **Edit > Sheet > Delete** on the main menu bar.
4) Click **Yes** to confirm the deletion of the sheet.
5) When finished editing the embedded spreadsheet, click anywhere outside the border to cancel edit mode and save the changes.

### Cell navigation

To move around the spreadsheet to select a **cell** to make it active, you can use one of the following methods. By default when open an embedded spreadsheet in Impress, the active cell is A1:

- The keyboard arrow keys.
- Position the cursor in a cell and left click on the mouse.
- **Enter** key to move one cell down and **Shift+Enter** key combination to move one cell up.
- **Tab** key to move one cell to the right and **Shift+Tab** key combination to move one cell to the left.

**Note**

Other keyboard shortcuts are available to navigate around a spreadsheet. Refer to **Getting Started Guide Chapter 5 Getting Started with Calc** for more information.
**Entering data**

Data input into a cell can only be done when a cell is active. An active cell is easily identified by a thickened and bolder border. The cell reference (or coordinates) for the active cell is displayed at the left hand end of the Formula toolbar (Figure 4).

1) Select the cell to make it active and start typing. The data input is also displayed in the large text box on the Formula toolbar making the data entry easier to read.

2) Use the **Formula Wizard** icon , **Sum** icon and **Function** icon to enter data, formula or function into a cell. If the input is not a formula (for example, a text or date entry), the **Sum** and **Function** icons change to the **Cancel** icon and **Accept** icon .

3) To confirm data input into a cell either select a different cell, or press the **Enter** key, or click on the **Accept** icon.

**Formatting cell data**

Impress normally recognizes the type of contents (text, number, date, time, and so on) entered into a cell and applies default formatting to it. However, if Impress wrongly recognizes the type of data you have entered into a cell:

1) Select the cell then right-click on the cell and select **Format Cells** from the context menu, or go to **Format > Cells** on the main menu bar, or use the keyboard shortcut **Ctrl+1** to open the Format Cells dialog (Figure 7).

2) Click on the appropriate tab to open the correct page in the dialog and use the options on that dialog page to format the cell data.

3) Click **OK** to close the dialog and save your changes.

![Formatting Cells dialog](image)

*Figure 7: Formatting Cells dialog*
Tip

Sometimes it is useful to treat numbers as text (for example, telephone numbers) and to prevent Impress from removing the leading zeros or right align them in a cell. To force Impress to treat numbers as text, type a single quotation mark (') before entering the number.

Formatting spreadsheets

For presentation purposes, it may be necessary to change the formatting of a spreadsheet to match the style used in the presentation.

When working on an embedded spreadsheet, you can also access any cell styles created in Calc and use them. However, if you are going to use styles, it is recommended to create specific cell styles for embedded spreadsheets, as Calc cell styles maybe unsuitable when working within Impress.

Manual formatting

To manually format an embedded spreadsheet:

1) Select a cell or a range of cells. See the Getting Started Guide Chapter 5 Getting Started with Calc for more information on selecting ranges of cells.
   a) To select the whole sheet, click on the blank cell at the top left corner between the row and column indexes, or use the keyboard shortcut Ctrl+A.
   b) To select a column, click on the column header at the top of the spreadsheet.
   c) To select a row, click on the row header on the left hand side of the spreadsheet.
2) Right-click on a cell and select Format Cells from the context menu, or go to Format > Cells on the main menu bar, or use the keyboard shortcut Ctrl+1 to open the Format Cells dialog (Figure 7).
3) Use the various dialog pages to format the embedded spreadsheet so that it matches the style of your presentation.
4) Click OK to close the dialog and save your changes.
5) If necessary, adjust the column width by hovering the mouse over the line separating two columns in the header row until the mouse cursor changes to a double-headed arrow; then click the left button and drag the separating line to the new position.
6) If necessary, adjust the row height by hovering the mouse over the line separating two rows in the row header until the mouse cursor changes to a double-headed arrow; then click the left button and drag the separating line to the new position.
7) When you are satisfied with the formatting changes, click outside the spreadsheet area to save your changes and cancel editing.

Using formatting styles

When using styles on an embedded spreadsheet and the spreadsheet is in edit mode, Impress displays the available styles for a spreadsheet in the Styles and Formatting dialog.

If style formatting you want to use is not available, then see the Writer Guide Chapter 6 Introduction to Styles on how to create a style. Styles used in an embedded spreadsheet are similar to paragraph styles used in LibreOffice Writer.

To use styles in your embedded spreadsheet:

1) Go to Format > Styles and Formatting on the main menu bar or press the F11 key to open the Styles and Formatting dialog.
2) Select data in a cell and double-click on a style in the Styles and Formatting dialog to apply that style.
**Inserting rows, columns or cells**
To insert rows, columns, or cells into an embedded spreadsheet:
1) Select the same number of rows, columns or cells on the embedded spreadsheet that you want to insert.
2) Go to **Insert > Rows** or **Insert > Columns** or **Insert > Cells** on the main menu bar or right-click on your selection and select **Insert...** from the context menu.
3) When inserting cells, select the insert option from the Insert Cells dialog that opens and click **OK**.

**Deleting rows, columns or cells**
To delete rows, columns or cells from an embedded spreadsheet:
1) Highlight the number of rows, columns or cells on the embedded spreadsheet you want to delete.
2) Go to **Edit > Delete Cells** on the main menu bar or right-click on the row or column headers and select **Delete Selected Rows** or **Delete Selected Columns** or **Delete...** from the context menu.

**Merging cells**
To merge multiple cells into a single cell:
1) Select the number cells to be merged.
2) Go to **Format > Merge cells** on the main menu bar and select either **Merge and Center Cells** or **Merge Cells** from the available options.
3) Alternatively, right-click on the selected cells and select **Merge Cells** from the context menu.

**Splitting cells**
To split a group of cells that have been merged into a single cell:
1) Select the cell that contains merged cells.
2) Go to **Format > Merge Cells > Split Cells** or right-click on the cell and select **Split Cells** from the context menu.

**Charts**
A chart is a graphical interpretation of information that is contained in a spreadsheet. More information about charts and the use of charts is described in the *Calc Guide Chapter 3 Creating Charts and Graphs*.

**Inserting charts**
You can insert a chart to your presentation as an OLE object or using the tools within Impress. See “OLE objects” on page 5 for more information on how to insert a chart as an OLE object.
To insert a chart using Impress tools:
1) Go to **Insert > Slide** on the main menu bar, or right-click on the Workspace and select **Slide > New Slide** from the context menu, or right-click on the Slides pane and select **New Slide** from the context menu to insert a new slide into your presentation.
2) Select the **Insert Chart** icon on the new slide (Figure 8), or use **Insert > Chart** on the main menu bar, or click the **Chart** icon on the Standard toolbar and a sample chart is inserted into the slide containing sample data (Figure 9). To change chart type, see “Selecting chart type” below and to enter data into the chart, see “Entering chart data” on page 16.

**Selecting chart type**

Your data can be presented using a variety of different charts. Impress contains several chart types that will help you convey your message to your audience. See “Chart types” on page 15 for an explanation of the different chart types available.

1) Make sure that your chart is selected. The chart has a border and selection handles when selected.
2) Click the Chart Type icon on the Formatting toolbar or go to Format > Chart Type on the main menu bar, or right-click on the chart and select Chart Type from the context menu to open Chart Type dialog (Figure 10).

3) As you change selections in the left-hand list, the chart examples on the right change. If you move the Chart Type dialog to one side, you can see the effect in your chart.

4) As you change chart types, other selections become available on the right-hand side. For example, some chart types have both 3D and 2D variants. When 3D charts are selected, more options become available for selection of shapes for the columns or bars.

5) Choose the chart characteristics you want and click OK. The Chart Type dialog closes and you return to the edit window.

6) Continue to format the chart, add data to the chart, or click outside the chart to return to normal view.

Chart types

The following summary of the chart types available will help you choose a type suitable for your data. Column, bar, pie and area charts are available as 2D or 3D types. For more information on charts, see the Calc Guide Chapter 3 Creating Charts and Graphs.

Column charts
Column charts displays data that shows trends over time and this the default type of chart used when a chart is inserted into your slide. It is recommended to use column charts where there is a relatively small number of data points. If you have a large time series as your data, it is recommended to use a line chart.

Bar charts
Bar charts give an immediate visual impact for data comparison where time is not important, for example comparing the popularity of products in a marketplace.

Pie charts
Pie charts give a comparison of proportions, for example, when comparing what different departments spent on different items or what different departments actually spent overall. They
work best with a small range of values, for example six or less. Using larger range of values, the visual impact of a pie chart begins to fade.

**Area charts**
Area charts are versions of line or column charts. They are useful when you want to emphasize volume of change. Area charts have a greater visual impact than a line chart, but the type of data you use does make a difference to the visual impact.

**Line charts**
Line charts are time series with progression. Ideal for raw data and useful for charts with data showing trends or changes over time where you want to emphasize continuity. On line charts, the X-axis is ideal for representing time series data. 3D lines confuse the viewer, so just using a thicker line gives a better visual impact.

**Scatter or XY charts**
Scatter charts are great for visualizing data that you have not had time to analyze and may be best for data where you have a constant value for comparison: for example weather data, reactions under different acidity levels, conditions at altitude, or any data which matches two numeric series. The X-axis usually plots the independent variable or control parameter (often a time series).

**Bubble charts**
Bubble charts are used to represent three variables. Two variables identify the position of the center of a bubble on a Cartesian graph, while the third variable indicates the radius of the bubble.

**Net charts**
Net charts are similar to polar or radar graphs and are useful for comparing data not in time series, but show different circumstances, such as variables in a scientific experiment. The poles of the net chart are the Y-axes of other charts. Generally, between three and eight axes are best; any more and this type of chart becomes confusing.

**Stock charts**
Stock charts are specialized column graphs specifically used for stocks and shares. You can choose traditional lines, candlestick, and two-column charts. The data required for these charts is specialized with a series for opening price, closing price, and high and low prices. The X-axis represents a time series.

**Column and line charts**
Column and line charts are a combination of two other chart types. It is useful for combining two distinct, but related data series, for example sales over time (column) and the profit margin trends (line).

**Entering chart data**

1) Make sure that your chart is selected and you have selected your chart type.

2) Click on the **Chart Data Table** icon, or select **View > Chart Data Table**, or right-click on the chart and select **Chart Data Table** from the context menu to open the Data Table dialog (Figure 11).

3) Type or paste information into the cells within the desired rows and columns to enter data into the Data Table dialog. You can also use the icons in the top left corner of the Data Table dialog to insert, delete or move data.
Adding or removing chart elements

The specimen chart inserted into a slide only includes two elements: a chart wall and a chart legend (also known as the key). You can add or remove elements to or from a chart as follows:

1) Make sure the chart is selected and in edit mode.
2) Go to Insert on the main menu bar and select from the submenu an element that you want to add to the chart, or right-click on the chart wall or a chart element and select an element you want to add from the context menu. Selecting an element opens a dialog where you can specify options for the element.

Note

Right-clicking on a chart element will give you more options to choose from when adding elements to your chart. The number of available insert options in the context menu depends on the type of element selected.

3) To remove an element from a chart, right-click on the chart element you want to remove and select the Delete option from the context menu. The type of element selected for removal will change the delete options in the context menu.
4) Select a chart element and press the Del or Backspace (←) key to remove it from your chart.

Chart formatting

To change the format of a selected chart:

1) Make sure the chart is selected and in edit mode.
2) Go to Format on the main menu bar and select from the submenu an element that you want to format, or right-click on a chart element and select a format option from the context menu. Selecting an element opens a dialog where you can specify format options for the element.

The formatting options available depend on whether the whole chart is selected or which chart element has been selected. For more information on chart formatting, see the Calc Guide Chapter 3 Creating Charts and Graphs.

Resizing and moving charts

You can resize or move a chart interactively or by using the Position and Size dialog. You can also use a combination of both methods.
**Resizing**

To resize a chart interactively:

1) Click on a chart to select it and selection handles appear around the chart.
2) To increase or decrease the height of a chart, click and drag on a selection handle at the top or bottom of the chart.
3) To increase or decrease the width of a chart, click and drag on a selection handle at the left or right of the chart.
4) To increase or decrease both the height and width of a chart at the same time, click and drag on a selection handle in one of the corners of the chart. To maintain the correct aspect ratio between height and width, hold the Shift key down while you click and drag.

**Moving**

To move a chart interactively:

1) Click on the chart to select it and selection handles appear around the chart.
2) Move the cursor anywhere on the chart other than on a selection handle.
3) When it changes shape, click and drag the chart to its new location.
4) Release the mouse button when the chart is in the desired position.

**Position and Size dialog**

To resize or move a chart using the Position and Size dialog box:

1) Click on the chart to select it and selection handles appear around the chart.
2) Go to Format > Position and Size on the menu bar, or right-click on the chart and select Position and Size from the context menu, or press F4 key to open the Position and Size dialog (Figure 12). For more information on the Position and Size dialog and how to use, see Chapter 6 Formatting Graphic Objects.

![Position and Size dialog](image)

*Figure 12: Position and Size dialog*
Chart elements

You can move or resize individual elements of a chart element independently of other chart elements. For example, you can move the chart legend to a different position. Pie charts allow individual wedges of the pie to be moved as well as "exploding" the entire pie.

1) Double-click the chart so that it is in edit mode.
2) Click any chart element to select it. Selection handles appear.
3) Move the cursor over the selected element and when the cursor changes shape, click and drag to move the element.
4) Release the mouse button when the element is in the desired position.

Note

If your chart is 3D, round selection handles appear; these control the three-dimensional angle of the chart. You cannot resize or reposition the chart while the round selection handles are showing. Shift + Click to get back to the square resizing handles. You can now resize and reposition your 3D chart.

Changing chart area background

The chart area is the area surrounding the chart graphic and includes the (optional) main title and key.

1) Double-click the chart so that it is in edit mode.
2) Go to Format > Format Selection on the main menu bar, or right-click in the chart area and select Format Chart Area, or double-click in the chart area to open the Chart Area dialog (Figure 13).
3) Click on the Area tab to open the page containing the area options.
4) Select from the Fill drop down list the type of background fill you want to use. The available options will change depending on the type of fill selected.
5) Click **OK** to close the dialog and save your changes.

**Changing chart wall background**

The chart wall is the area that contains the chart graphic.

1) Double-click the chart so that it is in edit mode.
2) Select **Format > Format Selection** on the main menu bar, or right-click in the chart wall and select **Format Wall**, or double-click in the chart wall to open the **Chart Wall** dialog.
3) Select the **Area** tab from the dialog that opens. This dialog has the same formatting options as described in “Changing chart area background” above.
4) Click **OK** to close the dialog and save your changes.

**Movies and sound**

**Using media files**

To insert a media file into your presentation:

1) Click the **Insert Movie** icon on the slide layout (Figure 8) or go to **Insert > Movie and Sound** on the menu bar to open the **Insert Movie and Sound** dialog (Figure 14).
2) Select the media file to insert and click **Open** to place the object on the slide.

![Figure 14: Insert Movie and Sound dialog](image)

**Note** Any media file will start playing as soon as the slide is shown during the presentation.
Tip
To see a list of audio and video file types supported by Impress, open the drop-down list of file types. This list defaults to All movie and sound files, enabling you to choose unsupported files such as .MOV.

Impress only links media files and does not embed a media file into a presentation. Therefore if a presentation is moved to a different computer, any links will be broken and the media files will not play. To prevent this from happening:

1) Place any media files which are included in a presentation in the same folder where the presentation is stored.
2) Insert the media file in the presentation.
3) Send both the presentation and any media files to the computer which is to be used for the presentation and place both files in the same folder on that computer.

Using the Gallery
To insert media clips directly from the Gallery:

1) If the Gallery is not already open, choose Tools > Gallery from the menu bar.
2) Browse to a theme containing media files (for example Sounds).
3) Click on the movie or sound to be inserted and drag it into the slide area.

Media playback
The Media Playback toolbar (Figure 15) is automatically opened when a media file is selected. The default position of the toolbar is at the bottom of the screen, just above the Drawing toolbar. However, this toolbar can be undocked from its fixed position and allowed to float on screen. If the toolbar does not open, go to View > Toolbars > Media Playback on the main menu bar.

![Figure 15: Media playback toolbar](image)

The Media Playback toolbar contains the following tools from left to right:

- **Movie and Sound** – opens the Insert Movie and Sound dialog where you can select a media file to be inserted.
- **Play, Pause, Stop** – controls media playback.
- **Repeat** – if selected, media will continuously repeat playing until this tool is de-selected.
- **Playback slider** – selects the position to start playing from within the media file.
- **Timer** – displays current position of the media clip and length of media file.
- **Mute** – when selected, the sound will be suppressed.
- **Volume slider** – adjusts the volume of the media file.
- **Scaling drop-down menu** – only available for movies and allows scaling of the movie clip.

Media player
Impress also has a media player so that you can preview any media files that are to be inserted into a presentation. To open it select Tools > Media Player on the main menu bar and its tools are the same as that of the Media Playback toolbar (Figure 15).
Formulas

Go to Insert > Object > Formula on the main menu bar to create a formula (Math object) in a slide. A formula can also be inserted as an OLE object; see “OLE objects” on page 5 for more information.

When editing a formula, the Math menu becomes available allowing you to create or edit a formula. When creating formulas, care should be taken about font sizes used to make sure they are similar in size to the font size used in the presentation. To change font attributes of a Math object, go to Format > Font Size on the main menu bar. To change font type, go to Format > Fonts on the main menu bar.

For information on how to create formulas, see the Getting Started Guide Chapter 9 Getting Started with Math or the Math Guide.

Note

Unlike formulas in Writer, a formula in Impress is treated as an object and will not be automatically aligned with the rest of the objects on the slide. The formula can be moved around like any other object but cannot be resized.

Drawings, text files, HTML files and other objects

You can insert into a presentation drawings, text files, HTML files and other objects, but only if these objects are compatible for insertion into an Impress presentation.

Go to Insert > File on the main menu bar to open a file selection dialog. Only files compatible with Impress will be available for selection.

Drawings, text files, HTML files and other objects can also be inserted as OLE objects; see “OLE objects” on page 5 for more information.

Note

For computers operating Microsoft Windows there is an additional option of Further objects. Clicking on this option opens an Insert Object dialog allowing you to create an OLE object using software that is compatible with OLE standards.