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Note for Mac users
Some keystrokes and menu items are different on a Mac from those used in Windows and Linux.
The table below gives some common substitutions for the instructions in this chapter. For a more
detailed list, see the application Help.
Windows or Linux

Mac equivalent

Effect

Tools > Options menu
selection

LibreOffice > Preferences

Access setup options

Right-click

Control+click

Opens context menu

Ctrl (Control)

z (Command)

Used with other keys

F5

Shift+z+F5

Opens the Navigator

F11

z+T

Opens Styles and Formatting window
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Introduction
This chapter describes how to manage graphic objects and in particular how to rotate, distort,
arrange, and position them on the slide. Though this chapter focuses on the shapes that can be
created with the available tools in Impress, some of the techniques described in this chapter are
also applicable to images imported into slides.

Drawing toolbar
Default drawing tools
The Drawing toolbar (Figure 1) contains the majority of the tools normally used to create graphic
objects. If this toolbar is not visible, select View > Toolbars > Drawing from the main menu bar.
Table 1 describes the default set of tools that are available on the Drawing toolbar.

Figure 1: Drawing toolbar
Your drawing toolbar may differ from the one shown in Figure 1 as this depends on
how many drawing tools have been placed on the toolbar. If you click on the black
triangle on the right of the drawing toolbar, then select Visible Buttons to display the
available tools. From this dialog you can install and remove tools to and from the
toolbar. Installed tools are indicated by a border around the icon.

Note

Table 1: Default set of drawing tools on the Drawing Toolbar
Tool
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Name

Purpose

Select

Selects objects. To select a group of objects, click above the top left object
and drag the mouse below the bottom right object of the intended selection
while keeping the mouse button pressed. A “marching ants” rectangle
identifying the selection area is displayed. You can also select several
objects by pressing and holding the Shift key while selecting the individual
objects.

Line

Draws a straight line from the point where you click the mouse to the point
where you drag the mouse pointer and release the mouse button. Press
the Shift key to restrict the angle of the line to multiples of 45°. Press the
Alt key to draw a line from its center. Press the Control key to detach the
end point of the line from the grid (see “Snapping objects to grid or snap
guides“ on page 18).

Line Ends
with Arrow

Draws a straight line ending with an arrowhead. The arrowhead is placed
at the end of the line where you release the mouse button. The Shift, Alt
and Control keys have the same effect as for the Line tool.

Rectangle

Draws a rectangle when you drag the mouse from the top left to the bottom
right corner. Press the Shift key to draw a square. Press the Alt key to draw
a rectangle or square from its center.

Ellipse

Draws an ellipse. Press the Shift key to draw a circle. Press the Alt key to
draw an ellipse or circle from its center.

Text

Creates a text box with text aligned horizontally.
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Tool

Name

Purpose

Vertical Text

Creates a text box with text aligned vertically. This tool is available only
when Asian language support has been enabled in Tools > Options >
Language Settings > Languages.

Curve

Draws a shape depending on the option that has been selected. Actual
icon shown will depend on the option that has been selected. Click on the
black triangle to show the available options Note that the title of this
submenu when undocked from the drawing toolbar is Lines.

Connector

Draws a connector line between two figures. Actual icon shown will depend
on the option that has been selected. Click on the black triangle to show
the available options. Each option is described in “Working with
connectors“ on page 20.

Lines and
Arrows

Draws a line ending in an arrow. Actual icon shown will depend on the
option that has been selected. Click on the black triangle to show the
available options. Note that the title of this submenu when undocked from
the drawing toolbar is Arrows.

Basic
Shapes

Click the black triangle to open a toolbar showing the available options.
Actual icon shown will depend on the option that has been selected. Select
the desired basic shape, then draw it by placing your cursor on the slide
and dragging your mouse to define an enclosing rectangle. Keep the Shift
key pressed to obtain a basic shape where the height and width are equal.
Press the Alt key to draw a basic shape from its center.

Drawing toolbar
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Tool
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Name

Purpose

Symbol
Shapes

Click the black triangle to open a toolbar showing the available options.
Actual icon shown will depend on the option that has been selected. Select
the desired symbol shape, then draw it by placing your cursor on the slide
and dragging your mouse to define an enclosing rectangle. Keep the Shift
key pressed to obtain a symbol shape where the height and width are
equal. Press the Alt key to draw a symbol shape from its center.

Block
Arrows

Click the black triangle to open a toolbar showing the available options.
Actual icon shown will depend on the option that has been selected. Select
the desired block arrow, then draw it by placing your cursor on the slide
and dragging your mouse to define an enclosing rectangle. Keep the Shift
key pressed to obtain a block arrow where the height and width are equal.
Press the Alt key to draw a block arrow from its center.

Flowcharts

Click the black triangle to open a toolbar showing the available options.
Actual icon shown will depend on the option that has been selected. Select
the desired flowchart shape, then draw it by placing your cursor on the
slide and dragging your mouse to define an enclosing rectangle. Keep the
Shift key pressed to obtain a flowchart where the height and width are
equal. Press the Alt key to draw a flowchart shape from its center.
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Tool

Name

Purpose

Callouts

Click the black triangle to open a toolbar showing the available options.
Actual icon shown will depend on the option that has been selected. Select
the desired callout, then draw it by placing your cursor on the slide and
dragging your mouse to define an enclosing rectangle. Keep the Shift key
pressed to obtain a callout where the height and width are equal. Press the
Alt key to draw a callout from its center.

Stars

Click the black triangle to open a toolbar showing the available options.
Actual icon shown will depend on the option that has been selected. Select
the desired star, then draw it by placing your cursor on the slide and
dragging your mouse to define an enclosing rectangle. Keep the Shift key
pressed to obtain a star where the height and width are equal. Press the
Alt key to draw a star from its center. Note that the title of this submenu
when undocked from the drawing toolbar is Starts and Banners.

Points

Edits the individual points that form the shape or line. Select this tool and
then select a shape or a line. You can also press the F8 key to select this
tool.

Glue Points

Edits the glue points of a graphic object. Glue points are the positions
where connector lines terminate or start. See “Managing glue points” on
page 21 for instructions.

Fontwork
Gallery

Opens the Fontwork gallery. See “Using Fontwork” on page 25 for further
information.

From File

Equivalent to Insert > Picture > From file on the main menu. See Chapter
4 for details.

Gallery

Opens the gallery. Equivalent to Tools > Gallery on the main menu. See
Chapter 4 for details.

Rotate

Select this tool to rotate an object. As rotation is considered a formatting
attribute and this is discussed in Chapter 6 of this guide.

Alignment

See “Aligning shapes“ on page 17. Click the black triangle to open a
toolbar showing the available options. Actual icon shown will depend on
the option that has been selected.

Arrange

See “Arranging objects“ on page 20. Click the black triangle to open a
toolbar showing the available options. Actual icon shown will depend on
the option that has been selected. Note that the title of this submenu when
undocked from the drawing toolbar is Position.

Extrusion
On/Off

Switches 3D effects on or off for the selected object. Clicking this button
also opens the 3D settings toolbar. See “Working with 3D shapes” on page
22 for details.

Interaction

Opens a dialog where you can specify the interaction between the user
and the object. See “Setting up interaction with an object” on page 24.

Drawing toolbar
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Additional drawing tools
In addition to the default set of drawing tools available on the drawing toolbar (Figure 1), you can
install additional tools. These additional tools are described in Table 2.
To install or remove additional tools onto or from the drawing toolbar:
1) Click on the black triangle on the right of the drawing toolbar.
2) Select Visible Buttons to display a list of the available tools.
3) To install a tool, click on it and the tool will appear in the drawing toolbar. The list of
available tools will close automatically.
4) To remove a tool, click on it and the tool is removed from the drawing toolbar. Installed tools
have a border around the tool icon. The list of available tools will close automatically.

Table 2: Additional drawing tools
Tool
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Name

Purpose

3D Objects

Click the black triangle to open a toolbar showing the available options.
Actual icon shown will depend on the option that has been selected. Select
the desired 3D shape, then draw it by placing your cursor on the slide and
dragging your mouse to define an enclosing rectangle. Keep the Shift key
pressed to obtain a 3D shape where the height and width are equal. Press
the Alt key to draw a 3D shape from its center.

To Curve

Converts the selected object to a Bézier curve.

To Polygon

Converts the selected object to a polygon (a closed object bounded by
straight lines). The appearance of the object does not change. If you want,
you can right-click and choose Edit Points to view the changes.

To 3D

Converts the selected 2D object to a 3D object.

To 3D
Rotation
Object

Converts the selected 2D object to a 3D rotation object.

Position
and Size

Opens the Position and Size dialog. You can also press the F4 key to
open this dialog.

Flip

Flips the selected object horizontally, or vertically.

Insert

Allows you to insert a slide, table, from file, movie and sound, formula, or
chart into your presentation. Click the black triangle to open the Insert
toolbar showing the available options. Actual icon shown will depend on
the option that has been selected.

Controls

Allows you to insert various form controls into your presentation. Click the
black triangle to open the Form Controls toolbar showing the available
options.
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Tool

Name

Purpose

Custom
Animation

Adds a new animation effect to an object selected in the slide, or changes
the animation of a selected element. Opens the Custom Animation
section in the Tasks pane.

Animated
Image

Adds animation to a selected object on a slide. Opens the Animation
dialog.

3D Effects

Specifies the properties of a 3D object or converts a 2D object to 3D.
Opens the 3D Effects dialog.

Creating lines and shapes
To create regular shapes and lines:
1) Select the desired line or shape tool from the drawing toolbar.
2) Position your cursor on the slide, then click and drag to create the object.
Drawing a freehand polygon is when you create a shape segment by segment using one of the
Curves tools on the drawing toolbar (see Table 1 and Figure 2).

Figure 2: Curve tool options
1)
2)
3)
4)

Click on the black triangle next to the Curve icon and select a tool.
Click once on the slide and move the cursor to draw the first segment.
Click once again and drawn the next segment of your freehand polygon.
To finish creating your freehand polygon, double-click when you have drawn the last
segment. If a closed polygon was selected, Impress draws the line connecting the last point
to the start point and fills the inside area with the default color.
5) Keep the Shift key pressed to restrict the angle between the segments to multiples of 45
degrees.
When drawing certain regular shapes, one or more colored dots are displayed in a different color to
the colored resizing handles. These dots perform a different function according to the shape they
are applied to and are as follows:
Basic Shapes

• Rounded rectangles and squares: use the dot to change the radius of the curve that
replaces the angled corners of a rectangle or square.

• Circle pie: use the yellow dots to change the size of the filled sector.
• Isosceles triangle: use the dot to modify the triangle type.
• Trapezoid, parallelogram, hexagon, or octagon: use the dot to change the angle between
the sides.

•
•
•
•
•
•

Cross: use the dot to change the thickness of the four arms of the cross.
Ring: use the dot to change the internal diameter of the ring.
Block arc: use the dot to change both internal diameter and size of the filled area.
Cylinder and cube: use the dot to change the perspective.
Folded corner: use the dot to change the size of the folded corner.
Frame: use the dot to change the thickness of the frame.

Creating lines and shapes
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Symbol Shapes

•
•
•
•

Smiley face: use the dot to change the smile on the face.
Sun, moon, heart: use the dot to change the shape of the symbol.
Prohibited symbol: use the do to change the thickness of the ring and the diagonal bar.
Double bracket, left bracket, right bracket, double brace: use the dot to change the
curvature of the bracket.

• Left brace, right brace: use the dots to change the curvature of the brace and the position
of the point.

• Square bevel, octagon bevel, diamond bevel: use the dot to change the thickness of the
bevel.
Block Arrows

•
•
•
•

Arrows: use the dot to change the shape and thickness of the arrows.
Pentagon, chevron: use the dot to change the angle between the sides.
Arrow callouts: use the dots to change the shape and thickness of the callouts.

Circular arrow: use the dots to change the thickness and area of the arrow.
Callouts

• Callouts: use the dots to change the length, position and angle of the pointer.
Stars

• 4-point star, 8 point star, 24 point star: use the dot to change the thickness and shape of
the star points.

• Vertical scroll, horizontal scroll: use the dot to change the width and shape of the scroll.
• Doorplate: use the dot to change the inward curvature of the corners.

Grouping objects together
It is often convenient to group objects together so that they are treated as a single object by
Impress. A group of objects can be formatted as if it was a single object, moved, rotated, deleted
and so on.
To group objects together:
1) Select the objects to be grouped. To do this, use the selection tool on the drawing toolbar
and draw a rectangle around the objects to be grouped, or click on each object to be added
to the group while pressing the Shift key.
2) When the colored selection handles show, select Format > Group > Group or press
Control+Shift+G on the keyboard or right-click within the group and select Group.
To edit or format a group of objects:
1) Once a group is defined, click on any of the objects in the group to select the group. Any
editing or formatting is then carried out on all the objects within the group.
2) To edit only individual objects in the group, press F3 when the group is selected or select
Format > Group > Enter Group from the menu bar or right-click and select Enter Group.
You can then select individual objects within the group for editing or formatting.
3) To exit from individual editing and formatting, press Control+F3 or select Format > Group
> Exit group from the menu bar or right-click and choose Exit Group. The whole group
then becomes selected.
To ungroup objects:
1) Select the group of objects.
10
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2) When the colored selection handles show, select Format > Group > Ungroup from the
menu bar or press Control+Alt+Shift+G or right-click on the group and choose Ungroup.
For more about working with grouped objects, see the Draw Guide Chapter 5, Combining Multiple
Objects.

Tip

If you use the group and ungroup commands often, why not add them to one of the
toolbars shown by default so that the commands are readily available? To do so, you
will need to customize the selected toolbar. See Chapter 11, Setting Up and
Customizing Impress.

Moving graphic objects
To move a graphic object:
1) Click on a graphic object and the colored selection handles will show.
2) Move the pointer over the graphic object until the pointer changes shape. On most
operating systems, the pointer associated with moving objects is a four-headed arrow, but it
may also be a hand or some other symbol.
3) Click and drag the graphic object to the desired position (you can also use the arrow keys).
4) Release the mouse button.

Tip

By default Impress makes the objects snap to the grid. If you need to position the
object between two points of the grid, hold down the Control key, then click on the
object and move it to the desired position. Alternatively, you can turn off snap to grid
or modify the grid resolution by going to Tools > Options > LibreOffice Impress >
Grid.

For a more accurate placement of the graphic object, use the Position and Size dialog (Figure 3).
With the graphic object selected and the colored selection handles displayed, either press F4 or
select Format > Position and Size from the menu bar, or right click on the selected object and
select Position and Size.

Figure 3: Adjustment of position and size of a graphic object
Moving graphic objects
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Use the Position section of the dialog to specify the X (horizontal) and Y (vertical) position of the
graphic object. The values represent the distance of the base point (selected on the right hand side
of the dialog) relative to the top left corner of the slide.
To prevent accidental modification of the position of the graphic object, select the Position option
in the Protect section (bottom left) of the dialog.
The unit of measurement for this dialog and other dialogs is set in Tools > Options > LibreOffice
Impress > General.

Resizing graphic objects
To resize a graphic object:
1) Click on a graphic object and the colored selection handles will show.
2) Position the pointer over one of the selection handles. The pointer changes shape giving a
graphical representation of the direction of the resizing.
3) Click and drag to resize the graphic object.
4) Release the mouse button to complete resizing.
The corner handles resize both the width and the height of the graphic object simultaneously, while
the other four handles resize only one dimension at a time.

Tip

To retain the original proportions of the graphic, Shift+click one of the corner handles,
then drag. Be sure to release the mouse button before releasing the Shift key.

For more accurate resizing of the graphic object, use the Position and Size dialog (Figure 3).
1) Select the graphic object and open the Position and Size dialog.
2) Select as the base point the part of the graphic object that you would like to anchor to the
page. The default setting (top left corner) means that when resizing, the position of the top
left corner of the object will not change.
3) Now modify either the Width value or the Height value of the object.
4) To maintain the proportions between width and height, select the Keep ratio option before
modifying any value. When Keep ratio is selected, changes to one of the dimension result
in automatic changes to the other.
5) To prevent accidental modifications of the size, make sure that the Size option is selected
in the Protect section in the bottom left part of the dialog.

Applying special effects
As well as the basic actions of moving and resizing an object, a number of special effects can also
be applied to objects in Impress. Several of these effects are readily available in the Mode toolbar
(Figure 4). If the Mode toolbar is not showing, select it from View > Toolbars > Mode.
This section describes how to rotate, flip, distort and two ways of setting an object in a circle. The
transparency and gradient tools are more specific to formatting and are discussed in Chapter 6.

Rotating graphic objects
Rotation of an object can be carried out manually or using a dedicated dialog, just like changing
object position and size. To rotate a graphic manually:
1) Click on a graphic object and the colored selection handles will show.
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Figure 4: Mode toolbar and available options

Figure 5: Object selected for rotation
2) Click the Rotate icon
in the Drawing or Mode toolbar.
3) The square selection handles change to a diamond shape and also change color (Figure
5).
4) Move the mouse over one of the corner handles and the mouse cursor shape will change.
Click the mouse and move in the direction in which you want to rotate the graphic object.
Only the corner selection handles are active for rotation.
5) When satisfied release the mouse button.

Note

The icons representing the functions in the toolbars maybe different depending on
the operating system used and on whether LibreOffice has been customized. When
in doubt, hover the mouse over an icon and wait for the tooltip to appear showing the
name of the icon.

When the Rotate icon is clicked, a circle appears in the middle of the selected object to indicate the
pivot point for rotation. Normally the center of an object will be just fine, but on some occasions you
may wish to rotate around a corner or even around a point outside the picture. To move the rotation
point, click on the circle and drag it to the desired position.

Applying special effects
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Figure 6: Rotation page of the Position and Size dialog
To restrict the rotation angles to multiples of 15 degrees, press and hold the Shift key while rotating
the graphic. This is very handy for rotating pictures through a right angle, for example from portrait
to landscape.
Instead of rotating a graphic object manually, you can use the Rotation dialog (Figure 6). To
display this dialog, select the graphic object so that the selection handles are shown, then press
F4 or select Format > Position and Size and select the Rotation page.
In the upper part of the dialog, select the position of the pivot point relative to the top left corner of
the page. The default position of the pivot point is the center of the figure.
In the lower part of the dialog select the angle by which to rotate the graphic object. To the right of
the Angle text box, eight default rotation values can be selected.

Flipping objects
The quickest and easiest method to flip an object horizontally or vertically is as follows:
1) Click on a graphic object and the colored selection handles will show.
2) Right click and select Flip > Horizontally or Flip > Vertically and the selected object will
be flipped to face the other direction.
The Flip tool on the Drawing or Mode toolbar can also be used. Using this tool also allows you to
change the position and angle that the object flips over (Figure 7).
1) Click on a graphic object and the colored selection handles will show.
2) Click on the Flip icon
and the axis of symmetry appears as a dashed line through the
middle of the object. The object will be flipped about this axis of symmetry.
3) Move one or both ends of the axis of symmetry with your mouse cursor to set the
orientation of the axis.
4) Place the mouse cursor over one of the object selection handles until it changes shape.
5) Click and hold, then move your cursor across the other side of the axis of symmetry. The
new position of the figure is shown faintly until the mouse is released.

14

Managing Graphic Objects

Figure 7: Using the Flip tool
6) Release the mouse button and the object will appear flipped over. Angle and position of the
flip will depend on the angle and position of the axis of symmetry.

Note

If you press the Shift key while moving the axis of symmetry and it will rotate in 45degree increments.

Mirror copies
At the moment there is no mirror command existing in Draw or Impress. However, mirroring an
object can be emulated by using the Flip tool as follows:
1)
2)
3)
4)
5)
6)
7)

Select the object you want to make a mirror copy of (Figure 8).
Copy the object to the clipboard.
Select the Flip tool on the Drawing or Mode toolbar.
Move the axis of symmetry to the desired location of the mirror axis.
Flip the object.
Click on an empty area of the page to deselect the object.
Paste from the clipboard to put a copy of the object in its original location and now you
have a mirror copy.

Applying special effects
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Figure 8: Making a mirror copy of an object

Distorting an image
Three tools on the Mode toolbar let you drag the corners and edges of an object to distort the
image. The Distort tool
Set in Circle (perspective)

distorts an object in perspective, and Set to Circle (slant)

and

tools both create a pseudo three-dimensional effect.

In all three cases you are initially asked if you want to transform the object to a curve. This is a
necessary first step, so click Yes. Then you can move the object handles to produce the desired
effect. The results of using these tools are shown in the following figures.

Distort tool
Select an object and click on the Distort icon
on the Mode toolbar. After converting to a curve
as requested, move the handles to stretch the object. The corner handles distort the corners, the
vertical midpoint handles distort the figure horizontally and the horizontal ones distort it vertically
(Figure 9).

Figure 9: Distorting an image

Set in circle (perspective) tool
Select an object and click on the Set in Circle (perspective) icon
in the Mode toolbar. After
converting to a curve , move the object handles to give a pseudo three-dimensional perspective)
(Figure 10).
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Figure 10: Setting an image to a circle with perspective

Set to circle (slant) tool
Select an object and click on the Set to Circle (slant) icon
in the mode toolbar. After
converting to a curve, move the object handles to give a pseudo three-dimensional slant
perspective (Figure 11).

Figure 11: Setting an image to a circle with slant

Note

Transforming an object into a curve is a safe operation, but it cannot be reversed
other than by clicking the Undo button.

Aligning shapes
Use the alignment tools to adjust the relative position of a graphic object compared to another
object. Click on the black triangle next to the Alignment icon
in the Drawing toolbar or go to
View > Toolbars > Align on the main menu bar to open the Align toolbar (Figure 12). These
alignment options are also available when you right-click on a selected object.

Aligning shapes
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Figure 12: Align toolbar and available options
The toolbar has six icons. The first three determine the horizontal alignment of the selected objects
(Left, Center, Right); the other three determine the vertical alignment of the selected objects (Top,
Middle, Bottom). Actual Alignment icon shown on the Drawing toolbar will depend on the option
that has been selected.
If only one object is selected, it is aligned to the page. If several objects are selected together, they
are aligned to the object that selected first.

Snapping objects to grid or snap guides
Sometimes it is important to align objects to specific points of the page or to make sure that objects
that appear on multiple slides are placed in exactly the same position. For this purpose Impress
provides two mechanisms: Grid and Snap Guides (also called Snap Lines).

Using the grid
Options for the grid are available by right-clicking on an empty part of the page in Normal view and
choosing Grid or by selecting View > Grid from the menu bar. In both cases a submenu with three
options opens:

• Visible Grid (right click) or Display Grid (menu): displays the grid.
• Snap to Grid: the anchor points of an object will be placed on a grid when the object is
moved or resized.

• Grid to Front: displays the grid in the foreground.
To set up the grid spacing and snapping options, go to Tools > Options > LibreOffice Impress >
Grid on the menu bar.

Using snap guides
Options for the guides are available by right clicking on an empty part of the page in Normal view
and choosing Snap Lines or by selecting View > Guides from the menu bar. A submenu with
three options opens:

• Snap Lines Visible (right click) or Display Guides (menu): the guides are shown on the
slide.

• Snap to Snap Lines (right click) or Snap to Guides (menu): the anchor points of the
objects snap to the guides when the object is moved or resized.
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• Snap Lines to Front (right click) or Guides to Front (menu): displays the guides in the
foreground.

Note

The main menu uses the term Guides, but the pop-up menu refers to Snap Lines.

To create a new guide:
1) Right-click on an empty part of the work area and select Insert Snap Point/Line from the
pop-up menu to open the New Snap Object dialog (Figure 13).

Figure 13: New Snap Object dialog
2) Specify the type of snap object. Depending on the choice made determines which field
becomes active: Point both X and Y fields become active, Vertical only X field becomes
active, Horizontal only Y field become active.
3) Enter the position of the guide.
4) Click OK to close the dialog.

Tip

When positioning the Snap Guides, it is useful to display the rulers. To do so, select
View > Rulers.
Drag a Snap Guide directly onto the slide by clicking on the ruler and then dragging
onto the slide.

To edit a guide:
1) Right-click next to or on the guide to be edited.
2) Select Edit Snap line from the pop-up menu.
3) Enter a new value in the X or Y field for the guide position and click OK.
To delete a guide:
1) Right-click next or on the guide to be deleted.
2) Choose Delete Snap line from the pop-up menu.

Snapping objects to grid or snap guides
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Arranging objects
Impress and Draw organize objects in a stack so that the objects on the top level of the stack cover
the objects on lower levels if any overlapping occurs. The stack level of each object can be
changed by arranging shapes on a slide or page.
To change the stack level of an object, select an object or objects and then click the small triangle
on the side of the Arrange icon on the Drawing toolbar to open the Position toolbar (Figure 14).
The arrange or position options are also available by right-clicking on a selected object.

Figure 14: Position toolbar for arranging objects
The first four tools determine the stack level of a selected object:

•
•
•
•

Bring to front: the selected object is moved in front of all other objects.
Bring forward: the selected object is moved one level up in the stack.
Send backwards: the selected object is moved one level down in the stack.
Send to back: the selected object is moved behind all other objects.

The other three tools determine the relative positions of the selected objects:

• In front of object: moves the first selected object in front of the second selected object.
• Behind object: moves the first selected object behind the second selected object.
• Reverse: swaps the stacking order of two selected objects.
To use the In front of object and Behind object tools:
1) Select the first object by clicking on it.
2) When the selection handles show, select the desired arrange action.
3) The mouse pointer changes to a pointing hand. Click on the second object.

Working with connectors
Connectors are lines that can be anchored to particular places, called glue points, on the graphic
object. The advantage of connectors is that when the graphic object to which the connector is
attached is moved or resized, the connector automatically adjusts to the change. When creating a
flowchart, organization chart, schematics or diagrams, it is highly recommended to use connectors
instead of simple lines.
Impress offers a wide variety of predefined connectors, which differ in the termination shape (none,
arrow, custom) and in the way the connector is drawn (straight, line, curved).
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When a connector is drawn or selected Impress displays selection handles which are not shown
for normal lines. The termination points of a connect are diamond shape and square handles are
used to modify the routing of a connector where applicable.
Draw a connector in a similar way to drawing any object.
1) First open the Connector toolbar by clicking on the black triangle next to the Connector icon
(the connector shown depends on the connector option previously selected).
2) Move the mouse cursor over one of the objects to be connected and small crosses appear
around the object edges which are the glue points to which a connector can be attached.
3) Click on the required glue point to attach one end of the connector, then hold the mouse
button down and drag the connector to another object.
4) When the cursor is over the glue point of the target object release the mouse button and
the connector is drawn.
5) If square handles appear on the connector, the path of the connector can be adjusted so
that the connector does not cover another object in its path.
For more instructions on how to format a connector, refer to the corresponding section in Chapter
6, Formatting Graphic Objects.

Managing glue points
A glue point is the attachment point for a connector on a shape or graphic object. Each shape has
a number of predefined glue points, but it is possible to define new ones, as well as edit them,
using the Gluepoints toolbar. Click on the Gluepoints icon
Gluepoints to open the toolbar (Figure 15).

or go to View > Toolbars >

The first tool to insert a new glue point onto an object. The next four tools determine the exit
direction of the connector terminating at the glue point.

Figure 15: Gluepoints toolbar and available options

Working with connectors
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To maintain the relative position of the glue point when resizing the object, make sure that the Glue
point relative icon is selected. Deselecting the Glue point relative icon activates the remaining
six icons on the toolbar. use these tools to fix the position of the glue point during the resizing of
the object.
To delete a custom glue point, select it with the mouse and press the Delete key.
Setting custom glue points is useful where multiple connectors terminate on the same side of a
shape or where the default glue point position is not satisfactory.
To move a predefined or newly inserted glue point:
1) Select the glue point tool from the drawing toolbar.
2) Click on the glue point you want to move. The glue point should now be highlighted.
3) Keep the mouse button pressed and drag the glue point to the desired position. Release
the mouse button.

Tip

Glue points are placed by default on the grid (see “Snapping objects to grid or snap
guides“ on page 18 for information). However it is sometimes necessary to fine tune
the position of a glue point depending on the shape of the object. To do this, press
the Control key to display guide lines and keep the Control key pressed while
dragging the glue point to the new position.

Working with 3D shapes
3D graphic objects can be created in different ways in Impress:

• From the 3D-Objects toolbar. If the 3D-Objects tool

is not included on the Drawing
toolbar, click on the small triangle at the end of the Drawing toolbar, select Visible Buttons,
and then select 3D-Objects from the list. On the Drawing toolbar, click on the small triangle
next to the 3D-Objects icon to display the 3D Objects toolbar (Figure 16).

Figure 16: 3D-Objects toolbar

• From the Convert sub-menu. Select a shape, right-click on it. In the Convert sub menu
choose either To 3D to add thickness to the object or To 3D Rotation Object to create a
3D shape resulting from the rotation of the object around an axis.

• From the Extrusion on/off icon

on the Drawing toolbar. Select the object to apply a
3D effect, then click the Extrusion on/off icon on the Drawing toolbar to open the 3DSettings toolbar (Figure 17).

Figure 17: 3D-Settings toolbar
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Table 3: 3D-Settings tools and their purpose
Tool

Name

Purpose

Extrusion On/Off

Adds thickness to an object and activates the 3D properties.

Tilt Down

Tilts the object downwards around an horizontal axis.

Tilt Up

Tilts the object up around an horizontal axis.

Tilt Left

Tilts the object left around a vertical axis.

Tilt Right

Tilts the object right around a vertical axis.

Depth

Determines the thickness of the shape. An extended toolbar opens
where some default values are given. If none of the values are
satisfactory, select Custom and then enter the desired thickness.

Direction

Opens an extended toolbar that lets you pick the direction of the
perspective as well as the type (parallel or perspective).

Lighting

Opens an extended toolbar that lets you specify the direction and
intensity of light.

Surface

Choose between Wire frame (useful when manipulating the object),
Matt, Plastic or Metal.

3D Color

Selects the color of the object thickness.

Although Impress offers advanced functions to manipulate 3D objects, this guide describes only
the 3D settings applicable to an object with Extrusion enabled. For additional information on how to
use advanced 3D effects such as geometry and shading, refer to the Draw Guide.

Caution

You cannot apply extrusion to rectangular and oval shapes created by using the
rectangle or oval tools. Instead, select the desired shape from the basic shapes
menu to create a rectangle or oval with 3D effects. Alternatively, right-click on the
object, then select Convert > To 3D. Note that in this case the Extrusion on/off
menu will not be enabled.

Select an object, then click on the Extrusion on/off icon
to activate the extrusion. The object
shape changes and a default thickness is added to it. At the same time the 3D-Settings toolbar
(Figure 17) opens. If this toolbar does not appear, select View > Toolbars > 3D-Settings. Use
these tools to change the appearance of the 3D object and these are listed in Table 3. An example
of an object converted to 3D is shown in Figure 18.
Most of the Fontwork shapes (see “Using Fontwork” on page 25) have 3D properties and can be
manipulated with the 3D-Settings toolbar.
Note that when rotating a 3D object, in addition to the corner selection handles, four selection
handles on the sides of the frame become available.

Working with 3D shapes
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Figure 18: Example object converted to 3D

Converting an object to a different type
You can convert an object into a different type. Right-click on the object and select Convert to
display a menu containing the following options:

• To Curve: converts the selected object to a Bézier curve. Click on the Points icon

on

the Drawing toolbar to edit the points after conversion to a Bézier curve.

• To Polygon: converts the selected object to a polygon. Click on the Points icon to edit the
object after conversion to a polygon. A polygon always consists of straight segments.

• To Contour: for basic shapes, this is equivalent to converting to polygon. For more
complex shapes (or for text objects) this conversion creates a group of polygons that you
can then manipulate by pressing F3 to enter the group.

• To 3D: converts the selected object to a 3D object.
• To 3D Rotation Object: creates a three-dimensional shape by rotating the selected object
around its vertical axis.

• To Bitmap: converts the selected object to a bitmap.
• To Metafile: converts the selected object to Windows Metafile Format (WMF), containing
both bitmap and vector graphic data.

Note

In most cases the conversion to a different type does not produce immediately visible
results.

Tip

To Curve, To Polygon, To 3D and To 3D Rotation Object can be added to the
Drawing toolbar as additional tools by clicking on the small triangle at the right of the
toolbar and selecting Visible Buttons.

Setting up interaction with an object
You can associate an object to an action that is performed when the user clicks on it. To create an
interaction:
1) Select the object for which an interaction will be created.
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Figure 19: Interaction dialog
2) Click on the Interaction icon
the Drawing toolbar or right-click on the object and select
Interaction from the pop-up menu and the Interaction dialog opens (Figure 19).
3) Select the interaction type and the parameters (if applicable). Click OK to close the dialog.
The interactions are explained in Table 4 and the Interaction dialog changes depending on
the type of interaction selected.
4) To remove an interaction from a graphic object follow Steps 1 to 2 and then select No
action as the interaction type at Step 3.
Table 4: Interaction types and their parameters
Interaction

Parameters

Go to previous slide

No parameters.

Go to next slide

No parameters.

Go to first slide

No parameters.

Go to last slide

No parameters.

Go to page or object

Specify the target from the list in the Target box. You can search for a
specific target in the Slide/Object box at the bottom of the screen.

Go to document

Select the document in the Document box. Use the Browse button to open
a File Open dialog. If the document to be opened is in Open Document
Presentation format, the target list will be populated allowing selection of
the specific target.

Play sound

Select the file containing the sound to be played. Use the Browse button to
open a File Open dialog.

Run program

Select the program to execute. Use the Browse button to open a File Open
dialog.

Run macro

Select a macro that will run during the presentation. Use the Browse button
to open the Macro Selector dialog.

Exit presentation

When the mouse is clicked over the object, the presentation will terminate.

Using Fontwork
Use Fontwork to obtain special text effects. For more about this topic, see Chapter 11, Graphics,
the Gallery, and Fontwork, in the Getting Started guide.

Using Fontwork
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Figure 20: Fontwork Gallery
To start using Fontwork:
1) To open the Fontwork Gallery (Figure 20) click on the Fontwork Gallery icon
on the
Drawing toolbar or on the Fontwork toolbar (Figure 21). If the Drawing toolbar is not
showing, you can go directly to the Fontwork toolbar by selecting View > Toolbars >
Fontwork from the main menu bar.
2) Select the preferred style from the Fontwork Gallery (Figure 20) and click OK. The text
Fontwork in the selected style appears on the slide. You can modify its shape and
properties after it has been placed on the slide.
3) Double-click the object to edit the Fontwork text. Type your own text to replace the word
Fontwork that appears over the object.
4) Press the Esc key or click outside the area with the colored resizing handles to exit.
5) You can edit some of its attributes by using the Fontwork toolbar or tools that are used to
change attributes of objects.

Using the Fontwork toolbar
Make sure that the Fontwork toolbar (Figure 21) is visible on the workspace. If not, select View >
Toolbars > Fontwork from the main menu bar.
In addition to the Fontwork Gallery tool, this toolbar contains the following tools:

• Fontwork Shape

: changes the shape of the selected object. Shapes are selected
from the toolbar (Figure 22) that opens when this tool is selected.

Figure 21: Fontwork toolbar
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Figure 22: Fontwork shape toolbar

• Fontwork Same Letter Heights

: changes the height of characters in the selected
object. Toggles between normal height where characters have different heights to where all
characters are the same height.

• Fontwork Alignment:

: specifies the text alignment within the frame from the choices

available.

• Fontwork Character Spacing

: selects the desired spacing between characters and
whether kerning pairs should be used. For custom spacing, input a percentage value:
100% is normal spacing; less than 100% is tight spacing; more than 100% is expanded
spacing.

Modifying Fontwork text as a shape
It is possible to treat Fontwork text as an object and therefore to apply to it all the formatting that
has been described in this chapter. Assign line properties only to Fontwork which does not have a
3D effect, otherwise the changes will not be visible.

Tip

You can change Fontwork color quickly using the Area fill color swatch on the Line
and Filling toolbar.

You can modify some of the Fontwork shapes just as you modify the angles of trapezoid and
parallelogram basic shapes by moving the dot that is displayed along with the colored resizing
handles.

Animations
Animated slide transitions can be added between slides to give your presentation a more
professional look when you change to the next slide (see Chapter 9 Slide Shows for more
information on transitions). However, Impress also allows you to add animations onto the slides to
create more interest in your presentation.
An animation consists of a sequence of images or objects called frames that are displayed in
succession when the animation runs. Each frame may contain one or more objects. For example,
make bullet points appear one by one; make pictures, shapes or other objects appear singly or as
a group onto a slide. Animations can be controlled using the keyboard or mouse click or
automatically in a timed sequence.
There are two ways to create an animation in Impress – Custom Animation (page 28) or Insert >
Animated Image (page 31) and both are described below.

Tip

Animations

Animations can look great in a presentation, but overuse of animations can make a
good presentation into a poor presentation. Always use discretion when adding
animations to your presentation.
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Figure 23: Custom Animation section on the Tasks pane

Custom Animation
Custom Animation (Figure 23) is located in the Tasks pane to the right of the Workspace in
Impress. It is used to add an animation effect to a selected object on a slide, or change the
animation effect of a selected object.

Note

Anything that can be placed onto a slide is an object. For example, an object can
include a picture, clip art drawing or text and so on.

The Custom Animation section contains the following:

• Add - opens the Custom Animation dialog (Figure 24) to add an animation effect to a
selected object on the slide.

• Change - opens the Custom Animation dialog to change the animation effect of a selected
object.

• Remove - removes any animation effects from a selected object.
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Figure 24: Custom Animation dialog

• Start - displays the start property of the selected animation effect. The following start
properties are available:

•
•
•

On click - the animation stops at this effect until the next mouse click.
With previous - the animation runs immediately.
After previous - the animation runs as soon as the previous animation ends.

• Property - selects additional properties of an animation. Click the … button to open the
Effect Options dialog (Figure 25), where you can select, adjust and apply properties.

Note

The name of this option will change depending on the type of effect that has been
selected, for example Property, Line Color, Direction, Font and so on. Also the
options offered in the Effect Options dialog will also change depending on the type of
effect and object that has been selected.

• Speed - specifies the speed or duration of the selected animation effect.
• Change order - click one of the buttons to move the selected animation effect up or down
in the order.

• Play - plays the selected animation effect in preview.
• Slide Show - starts the slide show from the current slide.
• Automatic preview - select to preview any new or edited effects on the slide while you
assign them.

Animations
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Figure 25: Effect Options dialog
The Custom Animation dialog (Figure 24) contains the following categories of effects in tabbed
pages:

•
•
•
•
•
•
•

Entrance – how an object appears on the slide.
Emphasis – how an object is emphasized when it appears on the slide.
Exit – how an object leaves the slide.
Motion Paths – how an object moves on the slide during animation.
Misc Effects – selects media effects from the miscellaneous effects.
Speed - specifies the speed or duration of the selected animation effect.
Automatic preview - previews any new or edited effects on the slide.

Creating an animation with Custom Animation
Create an animated object or objects using Custom Animation as follows:
1) To open the Custom Animation section (Figure 23), click on its name in the Tasks pane.
The Custom Animation section can also be opened by going to Slide Show > Custom
Animation or by using the Custom Animation tool on the Drawing toolbar.

Note

The Custom Animation tool
is an additional tool for the Drawing toolbar. It can
be installed onto the Drawing toolbar by clicking on the small triangle on the right of
the Drawing toolbar and clicking on Visible Buttons.

2)
3)
4)
5)

Select an object on a slide.
Click on Add in Custom Animation to open the Custom Animation dialog (Figure 24).
Select an effect category and the type of effect you want to apply to the selected object.
Select the speed (if available) of the effect from the drop down menu and then click on the
OK button.
6) Select the type of Property from the drop down menu.
7) If required, click on the … button to open the Effect Options dialog (Figure 25) to set the
effect options, then click on the OK button.

30

Managing Graphic Objects

Note

The name of this option will change depending on the type of effect that has been
selected, for example Property, Line Color, Direction, Font and so on. Also the
options offered in the Effect Options dialog will also change depending on the type of
effect and object that has been selected.

8) If required, adjust the animation speed using the Speed drop down menu.
9) If required, change the appearance order of the objects in the animation using the Change
order arrows.
10) If required, click on the Play button to check the animation effect.
11) When you are satisfied, click on the Slide Show button to check your presentation.

Insert animated images
You can create an animated image and then insert it into your presentation by going to Insert >
Animated Image on the main menu bar to open the Animation dialog (Figure 26). The animation
controls are explained in Table 5.

Figure 26: Animation dialog
Table 5: Animation dialog controls
Control

Animations

Control Name

Purpose

First image

Jumps to the first image in the animation sequence.

Backwards

Plays the animation backwards.

Stop

Stops playing the animation.

Play

Plays the animation.
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Control

Control Name

Purpose

Last image

Jumps to the last image in the animation sequence.

Image number

Indicates the position of the current image in the animation
sequence. If you want to view another image, enter its number
or click the up and down arrows.

Duration

Enter the number of seconds to display the current image. This
option is only available if you select Bitmap object in
Animation group.

Loop count

Sets the number of times that animation will play. If you want
the animation to play continuously, select Max.

Apply Object

Adds selected object or objects as a single image.

Apply Objects
Individually

Adds an image for each selected object. If you select a grouped
object, an image is created for each object in the group.
You can also select an animation, such as an animated GIF,
and click this icon to open it for editing. When you are finished
editing the animation, click Create to insert a new animation
into your slide.

Delete Current
Image

Deletes the current image from the animation sequence.

Delete All
Images

Deletes all images in the animation.

Number

Total number of images in the animation.

Group object

Assembles images into a single object so that they can be
moved as a group. You can still edit individual objects by
double-clicking the group in the slide.

Bitmap object

Combines images into a single image.

Create

Inserts the animation into the current slide.

Creating an animation using Animated Image
Create an animation using Insert > Animated Image as follows:
1) Create the object you intend to animate using the drawing tools.
2) Open the Animation dialog (Figure 26 and Table 5) by going to Insert > Animated Image
on the main menu bar.
3) Select the object and click on Apply Object icon to add it as the first frame of the
animation.
4) Apply a transformation or change to the object; for example, rotation, change color, add or
remove a character(s) and so on.
5) When you are ready, create the second frame of the animation and click Apply Object
again to add another frame to the animation.
6) Repeat steps 3, 4 and 5 until you have created all the desired frames of the animation.
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7) Select Bitmap object in the Animation group section of the Animator dialog to customize
the timing of each of the frames and the number of repetitions for the animation. Set the
number of repetitions to Max to obtain a continuous loop for your animation.
8) Click Create and the animated image is placed on the slide.

Note

Animations

If the image to be copied in the Animator consists of several objects, you can choose
to treat each object as a separate frame. In this case click on Apply objects
individually icon. Remember that each object will be centered in the animation.
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