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Quick printing

Click the Print File Directly icon to send the entire document to the default printer defined for your 
computer.

Note

You can change the action of the Print File Directly icon, to send the document to 
the printer defined for the document, instead of the default printer for the computer. 
Choose Tools > Options > Load/Save > General and select the Load printer 
settings with the document option.

Controlling printing

For more control over printing, use the Print dialog (File > Print or Ctrl+P).

Figure 1. The Print dialog

The Print dialog has four tabs, from which you can choose a range of options, as described in the 
following sections.

Note

The options selected on the Print dialog apply to this printing of this document only.

To specify default printing settings for LibreOffice, go to Tools > Options > 
LibreOffice – Print and Tools > Options > LibreOffice Calc – Print. For details, 
see Chapter 14 Setting Up and Customizing Calc.
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Selecting general printing options
On the General tab of the Print dialog (Figure 1), you can choose:

• The printer (from the printers available)

• Which sheets and pages to print, the number of copies to print, whether to print in reverse 
page order and whether to collate multiple copies (Range and copies section)

Click the Properties button to display a printer-specific dialog where you can choose portrait or 
landscape orientation, which paper tray to use, and the paper size to print on.

To print a range of pages, use the format 3-6 (pages 3 to 6). To print single pages, use the format 
7;9;11 (pages 7, 9, and 11). You can also print a combination of page ranges and single pages, by 
using a format like 3-6;8;10;12.

On the Options tab of the Print dialog (Figure 2), you can choose to print to a file (instead of to a 
printer) and to create a single print job containing several copies of the document (instead of a 
separate print job for each copy).

Figure 2: General print options

Printing multiple pages on a single sheet of paper
You can print multiple pages of a document on one sheet of paper. To do this:

1) In the Print dialog, select the Page Layout tab (Figure 3).

Figure 3: Printing multiple page per sheet of paper

2) In the Layout section, select the number of pages to print per sheet. The preview panel on 
the left of the Print dialog shows how the printed document will look.

When printing more than 2 pages per sheet, you can choose the order in which they are 
printing across and down the paper. The pictures above and below show the difference.
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3) You can choose to draw a border around each page.

4) In the From which print choices on the General tab (Figure 4), select whether to print all 
pages or only some pages.

5) Click the OK button to print.

Selecting sheets to print
In addition to printing a full document, you can choose to print individual sheets, ranges of sheets, 
or a selection of cells in a document.

Figure 4: Choosing what to print in Calc

Printing an individual sheet:

1) In the spreadsheet, click on the sheet tab to select the sheet you want to print.

2) Choose File > Print from the menu bar.

3) In the Ranges and copies section of the Print dialog, choose the Selected sheets option.

4) Click the OK button.

Printing a range of sheets:

1) In the spreadsheet, select the sheets to print.

a) Select the first sheet.

b) Hold down the Ctrl key.

c) Click on the additional sheet tabs.

d) Release the Ctrl key when all required sheets are selected.

2) Choose File > Print from the menu bar.

3) In the Ranges and copies section of the Print dialog, choose the Selected sheets option.

4) Click the OK button.

Printing a selection of cells:

1) In the document, select the section of cells to print.

2) Choose File > Print from the menu.

3) In the Ranges and copies section of the Print dialog, select the Selected cells option.

4) Click the OK button.

The Print in reverse page order option can be selected with any of the above options.

Caution After printing, be sure to deselect the extra sheets. If you keep them selected, the 
next time you enter data on one sheet, you enter data on all the selected sheets. 
This might not be what you want.
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Using print ranges

Print ranges have several uses, including printing only a specific part of the data or printing 
selected rows or columns on every page.

Defining a print range
To set a user-defined print range, which will replace any existing defined print range:

1) Highlight the range of cells that are to comprise the print range.

2) Choose Format > Print Ranges > Define from the menu bar.

The automatic page break lines are then displayed on the screen.

Tip

You can check the print range by using File > Page Preview in the menu bar, or 
by clicking the Page Preview icon in the Standard toolbar. Calc will only display 
the cells in the print range.

You can also use the View > Page break preview mode to see the print range 
without going to the page preview. See “Viewing print ranges” on page 9.

Adding to the print range
After defining a print range, you can add more cells to it. This allows multiple, separate areas of the 
same sheet to be printed, while not printing the whole sheet. After you have defined a print range:

1) Highlight the range of cells to be added to the print range.

2) Choose Format > Print Ranges > Add from the menu bar. This adds the extra cells to the 
print range.

The page break lines display on the screen around this new addition.

Note
The additional print range will print as a separate page, even if both ranges are on 
the same sheet.

Removing print ranges
It may become necessary to remove a user-defined print range, for example if the whole sheet 
needs to be printed later, or you no longer wish to print some of the added ranges.

Choose Format > Print Ranges > Remove from the menu bar. This removes all defined print 
ranges on the sheet, except those in named ranges. After the print range is removed, the default 
page break lines will appear on the screen.

To remove only certain print ranges, see “Editing a print range” below.

Editing a print range
At any time, you can directly edit the print range, for example to add to, remove, or resize part of 
the print range. Choose Format > Print Ranges > Edit from the menu bar. If you have already 
selected a print range, the Edit Print Ranges dialog looks something like Figure 5.

In this example, three rectangles are selected, each separated by a comma. The first is bounded 
by cell A3 ($A$3) in the top left and cell C9 ($C$9) in the bottom right corner. The others being 
D12:F23 and H24:I25.
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If only a single range is defined, then clicking anywhere in the text entry box shows the selected 
print range on the screen, bounded in blue, as shown in Figure 6.

To directly add new cells to the print range:

1) Type a comma in the text box as the separator for the ranges.

2) Select the cell range using the mouse cursor, or directly type in the cell references using 
the format of the selection already in the text box. Remember to separate the cell 
references with a colon.

To remove a print range, select the range in the text box and delete it. Make sure the remaining 
ranges only have a single comma as a separator and that there is not a comma at the end of the 
sequence.

To resize a print range, edit the data in the text box for the range.

Figure 5: Edit a print range

Figure 6: Print range marked by colored box; page break lines visible around the selection

Viewing print ranges
Because defined print ranges are formatted with automatic page breaks, they can be viewed by 
using the Page Break Preview screen, select View > Page Break Preview from the menu bar.
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Figure 7: The defined print range

Figure 8: The preview screen for the defined print range.

The print ranges are outlined by default with a blue border, and contain a centered page number in 
gray. The nonprinting area has a gray background.

To exit the Page Break Preview screen, select View > Normal from the menu bar.

Printing rows or columns on every page
If a sheet is printed on multiple pages, you can set up certain rows or columns to repeat on each 
printed page.

For example, if the top two rows of the sheet as well as column A need to be printed on all pages, 
do the following:

1) Choose Format > Print Ranges > Edit from the menu bar. On the Edit Print Ranges 
dialog, type the rows in the text entry box under Rows to repeat. For example, to repeat 
rows 1, 2 and 3, type $1:$3. This automatically changes Rows to repeat from - none - to 
- user defined -.

2) To repeat columns, type the columns in the text entry box under Columns to repeat. For 
example, to repeat column A, type $A. This automatically changes Columns to repeat from 
- none - to - user defined -.

3) Click OK.

Note

You can also use the mouse to select the rows or columns to repeat. To do this, 
click the corresponding text entry box and select the desired cell range in the 
sheet. You do not need to select the entire range of the rows to be repeated; 
simply select one cell in each row.

10 Printing, Exporting, and E-mailing



Figure 9: Specifying repeating rows

Rows to repeat and Columns to repeat can also be defined as named ranges using the method 
described below, but by selecting Repeat column or Repeat row, instead of selecting Print range
(see Figure 10). These may then be selected from the list box entries in the Edit Print Ranges 
dialog shown in Figure 9.

Defining a named print range
In addition to highlighting a print range for each print job, you can define a range of cells to be used 
repeatedly. This may be useful if different areas of a large spreadsheet need to be printed for 
different reports. Several named print ranges can be defined to meet this need.

1) To define a named print range, highlight the cells you want to define as a print range and 
select Insert > Names > Define from the menu bar, to open the Define Names dialog 
(Figure 10). Alternatively the cells can be highlighted after opening the Define Names 
dialog.

2) Type a name for the range in the Name box. The name of the range cannot contain any 
spaces.

3) Edit or set the cell selection range for the print range in the Range box if needed.

4) Ensure Document (Global) is selected in the Scope box.

Figure 10: Define Names dialog

5) Click the plus symbol by Range Options to show more choices. Select the Print range 
option to define the settings as a print range. Click the Add button to accept the data and 
close the dialog.
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To select this range to print:

1) Choose Format > Print Ranges > Edit from the menu bar (Figure 5). The previously 
defined name now appears in the Print range list box.

2) Select the defined print range and click OK.

This method can be useful to quickly change the print range without highlighting a large area of 
cells every time.

Deleting a named print range
To delete a named print range if it is no longer required:

1) Select Insert > Names > Manage from the menu bar or use Ctrl+F3.

2) In the Manage Names dialog which opens, select the named range you want to delete.

3) Click the Delete button.

4) Click OK to close the dialog.

You can click the Range Options button in the Manage Names dialog to confirm that the selected 
name is a print range before clicking Delete.

Page breaks

While defining a print range can be a powerful tool, it may sometimes be necessary to manually 
adjust Calc’s printout. To do this, you can use a manual break. A manual break helps to ensure that 
your data prints properly. 

You can insert a horizontal page break above, or a vertical page break to the left of, the active cell.

Inserting a page break
To insert a page break:

1) Navigate to the cell where the page break will begin.

2) Select Insert > Page Break from the menu bar.

3) Select Row Break or Column Break depending on your need.

The break is now set.

Row break

Selecting Row Break creates a page break above the selected cell. For example, if the active cell 
is H15, then the break is created between rows 14 and 15.

Column break

Selecting Column Break creates a page break to the left of the selected cell. For example, if the 
active cell is H15, then the break is created between columns G and H.

Tip
To see page break lines more easily on screen, you can change their color. 
Choose Tools > Options > LibreOffice > Appearance and scroll down to the 
Spreadsheet section.
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Deleting a page break
To remove a page break:

1) Navigate to a cell that is next to the break you want to remove.

2) Select Edit > Delete Manual Break.

3) Select Row Break or Column Break depending on your need.

The break is removed.

Removing multiple page breaks
Multiple manual row and column breaks can exist on the same page. When you want to remove all 
of them, do as follows:

1) On the menu bar, select View > Page Break Preview.

2) Right-click in the document and select Delete All Manual Breaks from the context menu.

All manual breaks are removed.

3) Select View > Normal to return to the standard document view.

Printing options setup in page styles

Several printing options are set in the page style for sheets. These include the page order, details, 
and scale to be printed, Because these options are set in the page style, different page styles can 
be set up to quickly change the print properties of the sheets in the spreadsheet. See Chapter 4 
Using Styles and Templates in Calc for more about page styles.

The Sheet tab of the Page Style dialog (Figure 11) provides the following options.

Figure 11. The Sheet tab of the Page Style dialog
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Page Order
You can set the order in which pages print. This is especially useful in a large document; for 
example, controlling the print order can save time if you have to collate the document a certain 
way.

Where a sheet prints to more than one piece of paper, it can be printed either by column, 
where the first column of pages prints, and then the second column and so on, or by row as 
shown in the graphic on the top right of the dialog in Figure 11.

Print
You can specify which details to print. These details include:

• Row and column headers

• Sheet grid—prints the borders of the cells as a grid

• Comments—prints the comments defined in your spreadsheet on a separate page, 
along with the corresponding cell reference

• Objects and graphics

• Charts

• Drawing objects

• Formulas—prints the formulas contained in the cells, instead of the results

• Zero values—prints cells with a zero value

Scale
Use the scale features to control the number of pages the data will print on.

• Reduce/Enlarge printout—scales the data in the printout either larger or smaller. For 
example, if a sheet would normally print out as four pages (two high and two wide), a 
scaling of 50% would print as one page (both width and height are halved).

• Fit print range(s) on number of pages—defines exactly how many pages the 
printout will take up. This option will only reduce a printout; it will not enlarge it. To 
enlarge a printout, the reduce/enlarge option must be used.

• Fit print range(s) to width/height—defines how high and wide the printout will be, in 
number of pages.

Headers and footers

Headers and footers are predefined pieces of text that are printed at the top or bottom of a sheet 
outside of the sheet area. Headers are set the same way as footers.

You can choose to have different content on left and right pages of the same page style.

Headers and footers are assigned to a page style. You can define more than one page style for a 
spreadsheet and assign different page styles to different sheets. For more about page styles, see 
Chapter 4.

Setting a header or a footer
To set a header or footer:

1) Navigate to the sheet for which you want to set the header or footer. Select Format > Page
from the menu bar.

2) Select the Header (or Footer) tab.

3) Select the Header on option.

4) Make other selections according to your requirements, using the More button to reveal 
other options. Click OK.
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Figure 12: Header dialog

You can set the margins, the spacing, and height for the header or footer. To automatically adjust 
the height of the header or footer, select the AutoFit height box. You can also select to have 
different content for left and right pages.

Margin
Changing the size of the left or right margin adjusts how far the header or footer is from that 
side of the page.

Spacing
Spacing affects how far above or below the sheet the header or footer will print. So, if spacing 
is set to 1.00", then there will be 1 inch between the header or footer and the sheet.

Height
Height affects how big the header or footer will be.

Header or footer appearance
To change the appearance of the header or footer, click the More button in the dialog. This opens 
the Border/Background dialog.

From this dialog you can set the background and border style of the header or footer. See 
Chapter 4 Using Styles and Templates in Calc for more information.
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Figure 13: Header/Footer Border/Background dialog

Setting the contents of the header or footer
The header or footer of a Calc spreadsheet has three columns for text. Each column can be empty 
or have different contents.

To set the contents of the header or footer, click the Edit button in the header or footer dialog 
shown in Figure 12 to display the dialog shown in Figure 14.

Figure 14: Edit contents of header or footer

Areas
Each area in the header or footer is independent and can have different information in it.

Header
You can select from several preset choices in the Header drop-down list, or specify a custom 
header using the buttons below the area boxes. (To format a footer, the choices are the same.)
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Custom header
Click in the area (Left, Center, Right) that you want to customize, then use the buttons to add 
elements or change text attributes.

 Opens the Text Attributes dialog.

 Inserts the File Name field.

 Inserts the Sheet Name field.

 Inserts the current page number.

 Inserts the total number of pages.

 Inserts the Date field.

 Inserts the Time field.

Exporting to PDF

Calc can export documents to PDF (Portable Document Format). This industry-standard file format 
is ideal for sending the file to someone else to view using Adobe Reader or other PDF viewers.

Quick export to PDF

Click the Export Directly as PDF icon  to export the entire document using your default PDF 
settings. You are asked to enter the file name and location for the PDF file, but you do not get a 
chance to choose a page range, the image compression, or other options.

Controlling PDF content and quality
For more control over the content and quality of the resulting PDF, use File > Export as PDF from 
the menu bar. The PDF Options dialog opens. This dialog has five pages (General, Initial View, 
User Interface, Links, and Security). Select the appropriate settings on each page, and then click 
Export. You are then asked to enter the location and file name of the PDF to be created. Click 
Save to export the file.

General page of PDF Options dialog
On the General page, you can choose which pages to include in the PDF, the type of compression 
to use for images (which affects the quality of images in the PDF), and other options.

Range section
• All: Exports the entire document if no print range has been defined or otherwise the print 

range content.

• Pages: To export a range of pages, use the format 3-6 (pages 3 to 6). To export single 
pages, use the format 7;9;11 (pages 7, 9, and 11). You can also export a combination of 
page ranges and single pages, by using a format like 3-6;8;10;12.

Caution The numbers used above are related to the page numbers and not the sheet 
numbers in your spreadsheet. To find these page numbers, select all the sheets in 
your spreadsheet and click the Preview button.

• Selection: Exports whatever content is selected.
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Figure 15: General page of PDF Options dialog

Images section
• Lossless compression: Images are stored without any loss of quality. Tends to make 

large files when used with photographs. 

• JPEG compression: Allows for varying degrees of quality. A setting of 90% works well with 
photographs (small file size, little perceptible loss).

• Reduce image resolution: Lower DPI (dots per inch) images have lower quality. Higher 
DPI settings greatly increase the size of the exported file. The end-purpose of the file will 
dictate the resolution you find acceptable.

Note
EPS (Encapsulated PostScript) images with embedded previews are exported only 
as previews. EPS images without embedded previews are exported as empty 
placeholders.

Watermark section
• Sign with Watermark: When this option is selected, a transparent overlay of the text you 

enter into the Watermark Text box will appear on each page of the PDF file.

General section
• Embed OpenDocument file: This setting enables you to export the document as a PDF 

file containing two file formats: .pdf and .odf. In PDF viewers it behaves like a normal .pdf 
file and it remains fully editable in LibreOffice. Selecting this option inhibits the use of the 
Range options and grays them out.

• PDF/A-1a: PDF/A is an ISO standard for long-term preservation of documents, by 
embedding all the information necessary for faithful reproduction (such as fonts) while 
forbidding other elements (including forms, security, and encryption). PDF tags are written. 
If you select PDF/A-1a, the forbidden elements are grayed-out (not available).

• Tagged PDF: Tagged PDF contains information about the structure of the document’s 
contents. This can help to display the document on devices with different screens, and 
when using screen reader software. Some tags that are exported are table of contents, 
hyperlinks, and controls. This option can increase file sizes significantly.
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• Create PDF form - Submit format: Choose the format for submitting forms from within the 
PDF file. This setting overrides the control’s URL property that you set in the document. 
There is only one common setting valid for the whole PDF document: PDF (sends the 
whole document), FDF (sends the control contents), HTML, and XML. Most often you will 
choose the PDF format.

• Export bookmarks: Exports sheet names in Calc documents as “bookmarks” (a table of 
contents list displayed by most PDF readers, including Adobe Reader).

• Export comments: Exports comments in Calc documents as PDF notes. You may not 
want this.

• Export automatically inserted blank pages: Not available in Calc.

• Embed standard fonts: Enable this option to embed the standard fonts that are installed 
on your system and that are used in the document. Use this option if you expect to have a 
better looking or more useful standard font than the font that is available in the recipients' 
PDF reader software.

Initial View page of PDF Options dialog
On the Initial View page (Figure 16), you can choose how the PDF opens by default in a PDF 
viewer. The selections are self-explanatory.

Figure 16: Initial View page of PDF Options dialog

User Interface page of PDF Options dialog
On the User Interface page (Figure 17), you can choose more settings to control how a PDF 
viewer displays the file. Some of these choices are particularly useful when you are creating a PDF 
to be used as a presentation or a kiosk-type display.

Window options section
• Resize window to initial page: Causes the PDF viewer window to resize to fit the first 

page of the PDF.

• Center window on screen: Causes the PDF viewer window to be centered on the 
computer screen.

• Open in full screen mode: Causes the PDF viewer to open full-screen instead of in a 
smaller window.

• Display document title: Causes the PDF viewer to display the document’s title in the title 
bar.
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Figure 17: User Interface page of PDF Options dialog

User interface options section
• Hide menubar: Causes the PDF viewer to hide the menu bar.

• Hide toolbar: Causes the PDF viewer to hide the toolbar.

• Hide window controls: Causes the PDF viewer to hide other window controls.

Transitions
• Not available in Calc.

Bookmarks
Only one bookmark level (sheet names) is available in Calc, regardless of the setting selected 
here.

Links page of PDF Options dialog
On this page you can choose how links are exported to PDF.

Figure 18: Links page of PDF Options dialog

Export bookmarks as named destinations
If you have defined Writer bookmarks, Impress or Draw slide names, or Calc sheet names, this 
option exports them as “named destinations” to which Web pages and PDF documents can 
link.

Convert document references to PDF targets
If you have defined links to other documents with OpenDocument extensions (for example,
.odt, .ods, and .odp), this option converts the extensions of file names to .pdf in the exported 
PDF document.

Export URLs relative to file system
If you have defined relative links in a document, this option exports those links to the PDF.

Cross-document links
Defines the behavior of links clicked in PDF files.
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Security page of PDF Options dialog
PDF export includes options to encrypt the PDF (so it cannot be opened without a password) and 
apply some digital rights management (DRM) features.

• With an open password set, the PDF can only be opened with the password. Once opened, 
there are no restrictions on what the user can do with the document (for example, print, 
copy, or change it).

• With a permissions password set, the PDF can be opened by anyone, but its permissions 
can be restricted. See Figure 19. After you set a password for permissions, the other 
choices on the Security page become available.

• With both the open password and permission password set, the PDF can only be opened 
with the correct password, and its permissions can be restricted.

Note
Permissions settings are effective only if the user’s PDF viewer respects the 
settings.

Figure 20 shows the dialog displayed when you click the Set passwords button on the Security 
page of the PDF Options dialog.

Figure 19: Security page of PDF Options dialog

Figure 20: Setting a password to encrypt a PDF
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Exporting to other formats

LibreOffice uses the term “export” for some file operations involving a change of file type. Select 
File > Save As from the menu bar, look in the File type list box in the Save As dialog for a wide 
range of file types.

Exporting to XHTML
Calc can export spreadsheets to XHTML. Choose File > Export from the menu bar. On the Export 
dialog, specify a file name for the exported document, then select the XHTML in the File format list 
and click the Export button.

E-mailing spreadsheets

LibreOffice provides several quick and easy ways to send spreadsheets as an e-mail attachment in 
one of three formats: OpenDocument Spreadsheet (LibreOffice’s default format), Microsoft Excel, 
or PDF.

To send the current document in OpenDocument format:

1) Choose File > Send > Document as E-mail from the menu bar. LibreOffice opens your 
default e-mail program with the spreadsheet (*.ods) document attached.

2) In your e-mail program, enter the recipient, subject, and any text you want to add, then 
send the e-mail.

File > Send > E-mail as OpenDocument Spreadsheet has the same result.

If you choose E-mail as Microsoft Excel, LibreOffice first creates a file in Excel format and then 
opens your e-mail program with the (*.xls) file attached.

If you choose E-mail as PDF, LibreOffice opens the PDF Options dialog for you to select the 
parameters you want, as previously described for exporting to PDF, clicking Send on the dialog 
then opens your email program with the PDF file attached.

E-mailing a spreadsheet to several recipients
To e-mail a document to several recipients, you can use the features in your e-mail program or you 
can use LibreOffice Writer’s mail merge facilities to extract email addresses from an address book.

For details, see Chapter 10 Printing, Exporting, and E-mailing in the Getting Started guide.

Digital signing of documents

To sign a document digitally, you need a personal key, also known as a certificate. A personal key 
is stored on your computer as a combination of a private key, which must be kept secret, and a 
public key, which you add to your documents when you sign them. You can get a certificate from a 
certification authority, which may be a private company or a governmental institution.

When you apply a digital signature to a document, a checksum is computed from the document’s 
content plus your personal key. The checksum and your public key are stored together with the 
document. 

When someone later opens the document on any computer with a recent version of LibreOffice, 
the program will compute the checksum again and compare it with the stored checksum. If both 
are the same, the program will signal that you see the original, unchanged document. In addition, 
the program can show you the public key information from the certificate. You can compare this 
key with the public key that is published on the web site of the certificate authority.
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Whenever someone changes something in the document, this change breaks the digital signature.

On Windows operating systems, the Windows features of validating a signature are used. On Linux 
systems, files that are supplied by Mozilla Thunderbird or Firefox are used. For a more detailed 
description of how to get and manage a certificate, and signature validation, see “Using Digital 
Signatures” in the LibreOffice Help.

To sign a document:

1) Choose File > Digital Signatures.

2) If the document contains comments, a warning dialog appears stating this and asking if you 
wish to continue. Click Yes if you wish to continue, or click No to exit and take appropriate 
action to remove them and restart this procedure from step 1.

3) If you have not saved the document since the last change, a message box appears. Click 
Yes to save the file. If you click No, the procedure exits.

4) After saving, you see the Digital Signatures dialog. Click Add to add a public key to the 
document.

5) In the Select Certificate dialog, select your certificate and click OK. 

6) You see again the Digital Signatures dialog, where you can add more certificates if you 
want. Click OK to add the public key to the saved file.

A signed document shows an icon  in the status bar. You can double-click the icon to view the 
certificate.

Removing personal data

You may wish to ensure that personal data, versions, notes, hidden information, or recorded 
changes are removed from files before you send them to other people or create PDFs from them.

In Tools > Options > LibreOffice > Security > Options, you can set Calc to remind (warn) you 
when files contain certain information and remove personal information automatically on saving.

To remove personal and some other data from a file, go to File > Properties. On the General tab, 
uncheck Apply user data and then click the Reset button. This removes any names in the created 
and modified fields, deletes the modification and printing dates, and resets the editing time to zero, 
the creation date to the current date and time, and the version number to 1.

To remove version information, either go to File > Versions, select the versions from the list and 
click Delete, or use Save As and save the file with a different name.
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