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Note for Mac users
Some keystrokes and menu items are different on a Mac from those used in Windows and Linux.
The table below gives some common substitutions for the instructions in this chapter. For a more
detailed list, see the application Help.
Windows or Linux

Mac equivalent

Effect

Tools > Options
menu selection

LibreOffice > Preferences

Access setup options

Right-click

Control+click and/or right-click
depending on computer setup

Open a context menu

Ctrl (Control)

⌘ (Command)

Used with other keys

F5

Shift+⌘+F5

Open the Navigator

F11

⌘+T

Open the Styles and Formatting window

Documentation for LibreOffice is available at http://www.libreoffice.org/get-help/documentation

Contents
Copyright.............................................................................................................................. 2
Contributors................................................................................................................................. 2
Feedback..................................................................................................................................... 2
Acknowledgments........................................................................................................................ 2
Publication date and software version......................................................................................... 2

Note for Mac users...............................................................................................................2
What is Calc?........................................................................................................................5
Spreadsheets, sheets, and cells.........................................................................................5
Calc main dialog...................................................................................................................5
Title bar........................................................................................................................................ 5
Menu bar..................................................................................................................................... 6
Toolbars....................................................................................................................................... 7
Formula Bar................................................................................................................................. 7
Spreadsheet layout...................................................................................................................... 8
Individual cells......................................................................................................................... 8
Sheet tabs............................................................................................................................... 8
Status bar................................................................................................................................ 9

Creating, opening and saving spreadsheets.................................................................. 10
Creating and opening................................................................................................................. 10
Using templates......................................................................................................................... 10
Opening CSV files..................................................................................................................... 10
Saving spreadsheets................................................................................................................. 12
Saving in other formats.............................................................................................................. 12

Password protection..........................................................................................................14
Navigating within spreadsheets....................................................................................... 14
Cell navigation........................................................................................................................... 14
Sheet navigation........................................................................................................................ 15
Keyboard navigation.................................................................................................................. 16
Customizing the Enter key......................................................................................................... 17

Selecting items in a sheet or spreadsheet...................................................................... 17
Selecting cells............................................................................................................................ 17
Single cell.............................................................................................................................. 17
Range of contiguous cells..................................................................................................... 17
Range of non-contiguous cells.............................................................................................. 18
Selecting columns and rows...................................................................................................... 18
Single column or row............................................................................................................. 18
Multiple columns or rows....................................................................................................... 18
Entire sheet........................................................................................................................... 19
Selecting sheets........................................................................................................................ 19
Single sheet.......................................................................................................................... 19
Multiple contiguous sheets.................................................................................................... 19
Multiple non-contiguous sheets............................................................................................. 19
All sheets.............................................................................................................................. 19
Introducing Calc

3

Working with columns and rows......................................................................................20
Inserting columns and rows....................................................................................................... 20
Single column or row............................................................................................................. 20
Multiple columns or rows....................................................................................................... 20
Deleting columns and rows........................................................................................................ 20
Single column or row............................................................................................................. 20
Multiple columns or rows....................................................................................................... 21

Working with sheets.......................................................................................................... 21
Inserting new sheets.................................................................................................................. 21
Moving and copying sheets....................................................................................................... 21
Dragging and dropping.......................................................................................................... 22
Using a dialog....................................................................................................................... 22
Deleting sheets.......................................................................................................................... 23
Renaming sheets....................................................................................................................... 23

Viewing Calc....................................................................................................................... 23
Changing document view........................................................................................................... 23
Freezing rows and columns....................................................................................................... 23
Freezing rows or columns..................................................................................................... 24
Freezing rows and columns.................................................................................................. 24
Unfreezing............................................................................................................................. 24
Splitting the screen.................................................................................................................... 24
Splitting horizontally or vertically........................................................................................... 24
Splitting horizontally and vertically......................................................................................... 25
Removing split views............................................................................................................. 25

Using the Navigator........................................................................................................... 25
Using document properties.............................................................................................. 27
General...................................................................................................................................... 27
Description................................................................................................................................. 28
Custom Properties..................................................................................................................... 28
Internet...................................................................................................................................... 28
Security...................................................................................................................................... 29
Statistics.................................................................................................................................... 29

4

Introducing Calc

What is Calc?
Calc is the spreadsheet component of LibreOffice. You can enter data (usually numerical) in a
spreadsheet and then manipulate this data to produce certain results.
Alternatively, you can enter data and then use Calc in a ‘What if...’ manner by changing some of
the data and observing the results without having to retype the entire spreadsheet or sheet.
Other features provided by Calc include:

•
•
•
•

Functions, which can be used to create formulas to perform complex calculations on data.
Database functions to arrange, store, and filter data.
Dynamic charts giving a wide range of 2D and 3D charts.
Macros for recording and executing repetitive tasks; scripting languages supported include
LibreOffice Basic, Python, BeanShell, and JavaScript.

• Ability to open, edit, and save Microsoft Excel spreadsheets.
• Import and export of spreadsheets in multiple formats, including HTML, CSV, PDF, and
PostScript.

Note

If you want to use macros written in Microsoft Excel using the VBA macro code in
LibreOffice, you must first edit the code in the LibreOffice Basic IDE editor. For
more information, see Chapter 12 Calc Macros in this guide or Getting Started
Guide Chapter 13 Getting Started with Macros.

Spreadsheets, sheets, and cells
Calc works with elements called spreadsheets. Spreadsheets consist of a number of individual
sheets, each sheet containing cells arranged in rows and columns. A particular cell is identified by
its row number and column letter.
Cells hold the individual elements – text, numbers, formulas, and so on – that make up the data to
display and manipulate.
Each spreadsheet can have many sheets, and each sheet can have many individual cells. In Calc,
each sheet can have a maximum of 1,048,576 rows and a maximum of 1024 columns.

Calc main dialog
When Calc is started, the main window opens and the various parts of this dialog are explained
below (Figure 1).

Note

If any part of the Calc window in Figure 1 is not shown, you can display it using the
View menu. For example, View > Status Bar will toggle (show or hide) the Status
Bar. It is not always necessary to display all the parts, as shown; you can show or
hide any of them, as desired.

Title bar
The Title bar, located at the top, shows the name of the current spreadsheet. When the
spreadsheet is newly created, its name is Untitled X, where X is a number. When you save a
spreadsheet for the first time, you are prompted to enter a name of your choice.

Calc main dialog
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Figure 1: Calc main dialog

Menu bar
Under the Title bar is the Menu bar. When you choose one of the menus, a sub-menu appears with
other options. You can also modify Menu bar, see Chapter 14 Setting Up and Customizing Calc in
this guide and Getting Started Guide Chapter 14 Customizing LibreOffice for more information.

• File – contains commands that apply to the entire document; for example Open, Save,
Wizards, Export as PDF, Print, Digital Signatures and so on.

• Edit – contains commands for editing the document; for example Undo, Copy, Changes,
Fill, Plug-in and so on.

• View – contains commands for modifying how the Calc user interface looks; for example
Toolbars, Column & Row Headers, Full Screen, Zoom and so on.

• Insert – contains commands for inserting elements into a spreadsheet; for example Cells,
Rows, Columns, Sheets, Picture and so on.

• Format – contains commands for modifying the layout of a spreadsheet; for example Cells,
Page, Styles and Formatting, Alignment and so on.

• Tools – contains various functions to help you check and customize your spreadsheet, for
example Spelling, Share Document, Gallery, Macros and so on.

• Data – contains commands for manipulating data in your spreadsheet; for example Define
Range, Sort, Consolidate and so on.

• Window – contains commands for the display window; for example New Window, Split and
so on.

• Help – contains links to the help system included with the software and other
miscellaneous functions; for example Help, License Information, Check for Updates and so
on.
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Toolbars
The default setting when Calc opens is for the Standard and Formatting toolbars to be docked at
the top of the workspace (Figure 1).
Calc toolbars can be either docked and fixed in place, or floating allowing you to move a toolbar
into a more convenient position on your workspace. Docked toolbars can be undocked and moved
to different docked position on the workspace or undocked to become a floating toolbar. Toolbars
that are floating when opened can be docked into a fixed position on your workspace.
To display, hide, move, create floating toolbars and for more information on toolbars, see the
Getting Started Guide Chapter 1 Introducing LibreOffice.
The default set of icons (sometimes called buttons) on toolbars provide a wide range of common
commands and functions. You can also remove or add icons to toolbars, see the Chapter 14,
Setting Up and Customizing Calc in this guide and the Getting Started Guide Chapter 14
Customizing LibreOffice for more information.
Placing the mouse cursor over any of the icons displays a small box called a tooltip. It gives a brief
explanation of the icon function. For a more detailed explanation, go to Help > What’s This? On
the main menu bar and hover the mouse pointer over the icon. To turn a tooltip, click once away
from the icon or press the Esc key. Tips and extended tips can be turned on or off from Tools >
Options > LibreOffice > General on the main menu bar.

Formula Bar
The Formula Bar is located at the top of the sheet in your Calc workspace. The Formula Bar is
permanently docked in this position and cannot be used as a floating toolbar. If the Formula Bar is
not visible, go to View on the main menu bar and select Formula Bar.

Figure 2: Formula Bar
Going from left to right and referring to Figure 2, the Formula Bar consists of the following:

• Name Box – gives the cell reference using a combination of a letter and number, for
example A1. The letter indicates the column and the number indicates the row of the
selected cell.

• Function Wizard

– opens a dialog from which you can search through a list of
available functions. This can be very useful because it also shows how the functions are
formatted.

• Sum

– clicking on the Sum icon totals the numbers in the cells above the selected cell
and then places the total in the selected cell. If there are no numbers above the selected
cell, then the cells to the left are totaled.

• Function

– clicking on the Function icon inserts an equals (=) sign into the selected cell
and the Input line allowing a formula to be entered.

• Input line – displays the contents of the selected cell (data, formula, or function) and
allows you to edit the cell contents. To edit inside the Input line area, click in the area, then
type your changes. To edit within the current cell, just double-click in the cell.

• You can also edit the contents of a cell directly in the cell itself by double-clicking on the
cell. When you enter new data into a cell, the Sum and Function icons change to Cancel
and Accept icons

Calc main dialog

.

7

Note

In a spreadsheet the term function covers much more than just mathematical
functions. See Chapter 7 Using Formulas and Functions in this guide for more
information.

Spreadsheet layout
Individual cells
The main section of the screen displays the cells in the form of a grid, with each cell being at the
intersection of a column and a row.
At the top of the columns and the left end of the rows are a series of header boxes containing
letters and numbers. The column headers use an alpha character starting at A and go on to the
right. The row headers use a numerical character starting at 1 and go down.
These column and row headers form the cell references that appear in the Name Box on the
Formula Bar (Figure 2). If the headers are not visible on your spreadsheet, go to View on the main
menu bar and select Column & Row Headers.

Sheet tabs
In Calc you can have more than one sheet in a spreadsheet. At the bottom of the grid of cells in a
spreadsheet are sheet tabs indicating how many sheets there are in your spreadsheet. Clicking on
a tab enables access to each individual sheet and displays that sheet. An active sheet is indicated
with a white tab (default Calc setup). You can also select multiple sheet by holding down the Ctrl
key while you click on the sheet tabs.
To change the default name for a sheet (Sheet1, Sheet2, and so on):
1) Right-click on the sheet tab and select Rename Sheet from the context menu. A dialog
opens allowing you to type in a new name for the sheet.
2) Click OK when finished to close the dialog.

Figure 3: Tab Color dialog
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To change the color of a sheet tab:
1) Right-click on the sheet tab and select Tab Color from the context menu to open the Tab
Color dialog (Figure 3).
2) Select your color and click OK when finished to close the dialog.
3) To add new colors to this color palette, see the Getting Started Guide Chapter 14
Customizing LibreOffice for more information.

Status bar
The Calc status bar (Figure 4) provides information about the spreadsheet and convenient ways to
quickly change some of its features. Most of the fields are similar to those in other components of
LibreOffice; see Chapter 1 Introducing LibreOffice in this guide and the Calc Guide Chapter 1
Introducing Calc for more information.

Figure 4: Calc status bar
The various fields on the Status Bar, from left to right, are as follows.
Sheet sequence number
Shows the sequence number of the current sheet and the total number of sheets in the
spreadsheet. The sequence number may not be the same as the name on the sheet tab if
sheets have been moved. Double-click on this zone to open the Navigator.
Page style
Shows the page style of the current sheet. To edit the page style, double-click on this field and
the Page Style dialog opens.
Insert mode
Shows the type of insert mode the program is in. Press the Ins key to change modes. This field
is blank if the program is in insert mode and Overwrite shows when in overwrite mode.
Selection mode
Click to open a context menu and toggle between Standard selection, Extended selection,
Adding selection or Block selection. The icon does not change when different selection modes
are selected, but the tooltip shows the current status.

• Standard selection – click in text or cell where you want to position the cursor and make the
cell active. Any other selection is then deselected.

• Extend selection – clicking in the text either extends or crops the current selection.
• Adding selection – a new selection is added to an existing selection. The result is a multiple
selection.

• Block selection – a block of text can be selected.
Unsaved changes
This icon indicates if there are any unsaved changes that have not been saved. Double-click
this icon or use File > Save to save the spreadsheet.

Calc main dialog
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Digital signature
If the document has been digitally signed, an icon shows here. You can double-click the icon to
view the certificate. See Chapter 6 Printing, Exporting, and E-mailing in this guide for more
information about digital signatures. A document can only be digitally signed after it has been
saved.
Cell or object information
Displays information relevant to the position of the cursor or the selected element of the
spreadsheet. When a group of cells is selected, the sum of the contents is displayed by default.
Right-click on this field and select other functions, such as the average value, maximum value,
minimum value, or count (number of items selected).
Zoom slider
Drag the zoom slider, or click the + and – signs to change the view magnification.
Zoom percentage
Indicates the magnification level of the document. Right-click on the percentage figure to open
a list of magnification values from which to choose. Double-clicking on this percentage figure
opens the Zoom & View Layout dialog.

Creating, opening and saving spreadsheets
Creating and opening
Creating and opening spreadsheets is identical to creating and opening documents to the other
modules within LibreOffice. For more information on creating and opening spreadsheets, see the
Getting Started Guide Chapter 1 Introducing LibreOffice.

Using templates
Calc documents can also be created from templates. For information on how to create and use
templates, see the Getting Started Guide Chapter 3 Using Styles and Templates and Chapter 4
Using Styles and Templates in Calc in this guide.

Opening CSV files
Comma-separated-values (CSV) files are spreadsheet files in a text format where cell contents are
separated by a character, for example comma, semi-colon, and so on. Each line in a CSV text file
represents a row in a spreadsheet. Text is entered between quotation marks; numbers are entered
without quotation marks.
To open a CSV file in Calc:
1) Choose File > Open on the main menu bar and locate the CSV file that you want to open.
2) Select the file and click Open. By default, a CSV file has the extension .csv. However,
some CSV files may have a .txt extension.
3) The Text Import dialog (Figure 5) opens allowing you to select the various options
available when importing a CSV file into a Calc spreadsheet.
4) Click OK to open and import the file.
The various options for importing CSV files into a Calc spreadsheet are as follows:

• Import
– Character Set – specifies the character set to be used in the imported file.
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Figure 5: Text Import dialog

–

Language – determines how the number strings are imported. If Language is set to
Default for CSV import, Calc will use the globally set language. If Language is set to a
specific language, that language will be used when importing numbers.

–

From Row – specifies the row where you want to start the import. The rows are visible
in the preview window at the bottom of the dialog.

• Separator Options – specifies whether your data uses separators or fixed widths as
delimiters.

–

Fixed width – separates fixed-width data (equal number of characters) into columns.
Click on the ruler in the preview window to set the width.

–

Separated by – select the separator used in your data to delimit the data into columns.
When you select Other, you specify the character used to separate data into columns.
This custom separator must also be contained in your data.

–
–

Merge delimiters – combines consecutive delimiters and removes blank data fields.
Text delimiter – select a character to delimit text data.

• Other options
– Quoted fields as text – when this option is enabled, fields or cells whose values are
quoted in their entirety (the first and last characters of the value equal the text delimiter)
are imported as text.

–

Detect special numbers – when this option is enabled, Calc will automatically detect all
number formats, including special number formats such as dates, time, and scientific
notation.

Creating, opening and saving spreadsheets
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The selected language also influences how such special numbers are detected, since
different languages and regions many have different conventions for such special
numbers.
When this option is disabled, Calc will detect and convert only decimal numbers. The
rest, including numbers formatted in scientific notation, will be imported as text. A
decimal number string can have digits 0-9, thousands separators, and a decimal
separator. Thousands separators and decimal separators may vary with the selected
language and region.

• Fields – shows how your data will look when it is separated into columns.
– Column type – select a column in the preview window and select the data type to be
applied to the imported data.

–
–
–

Standard – Calc determines the type of data.

–

Hide – the data in the column are not imported.

Text – imported data are treated as text.
US English – numbers formatted in US English are searched for and included
regardless of the system language. A number format is not applied. If there are no US
English entries, the Standard format is applied.

Saving spreadsheets
For information on how to save files manually or automatically, see the Getting Started Guide
Chapter 1 Introducing LibreOffice. Calc can save spreadsheets in a range of formats and also
export spreadsheets to PDF, HTML and XHTML file formats; see Chapter 6 Printing, Exporting,
and E-mailing in this guide for more information.

Saving in other formats
If you need to exchange files with users who are unable to receive spreadsheet files in Open
Document Format (ODF) (*.ods), which Calc uses as default format, you can save a spreadsheet
in another format.
1) Save your spreadsheet in Calc spreadsheet file format (*.ods).
2) Select File > Save As on the main menu bar to open the Save As dialog (Figure 6).
3) In File name, if you wish, enter a new file name for the spreadsheet.
4) In File type drop-down menu, select the type of spreadsheet format you want to use.
5) If Automatic file name extension is selected, the correct file extension for the
spreadsheet format you have selected will be added to the file name.
6) Click Save.
7) Each time you click Save, the Confirm File Format dialog opens (Figure 7). Click Use
[xxx] Format to continue saving in your selected spreadsheet format or click Use ODF
Format to save the spreadsheet in Calc ODS format.
8) If you select Text CSV format (*.csv) for your spreadsheet, the Export Text File dialog
(Figure 8) opens allowing you to select the character set, field delimiter, text delimiter and
so on to be used for your CSV file.

Note
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Once you have saved a spreadsheet in another format, all changes you make to the
spreadsheet will now occur only in the format you are using because you have
changed the name and file type of your document. If you want to go back to working
with an *.ods version, you must open the spreadsheet again.

Introducing Calc

Figure 6. Save As dialog

Figure 7. Confirm File Format dialog

Figure 8. Export Text File dialog

Creating, opening and saving spreadsheets
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Tip

To have Calc save documents by default in a Microsoft Excel file format, go to
Tools > Options > Load/Save > General. In the section named Default file format
and ODF settings, under Document type, select Spreadsheet, then under Always
save as, select your preferred file format.

Password protection
To protect a spreadsheet and restrict who can open, read, and make changes to a spreadsheet,
you have to use password protection. Password protection is common to all modules within
LibreOffice and more information can be found in the Getting Started Guide Chapter 1 Introducing
LibreOffice.

Navigating within spreadsheets
Calc provides many ways to navigate within a spreadsheet from cell to cell and sheet to sheet. You
can generally use the method you prefer.

Cell navigation
When a cell is selected or in focus, the cell borders are emphasized. When a group of cells is
selected, the cell area is colored. The color of the cell border emphasis and the color of a group of
selected cells depends on the operating system being used and how you have set up LibreOffice.

• Using the mouse – place the mouse pointer over the cell and click the left mouse button.
To move the focus to another cell using the mouse, simply move the mouse pointer to the
cell where you want the focus to be and click the left mouse button.

• Using a cell reference – highlight or delete the existing cell reference in the Name Box on
the Formula Bar (Figure 2 on page 7). Type the new cell reference of the cell you want to
move to and press Enter key. Cell references are case insensitive: for example, typing a3
or A3 will move the focus to cell A3.

Figure 9: Navigator dialog in Calc
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• Using the Navigator – click on the Navigator icon

on the Standard toolbar or press
the F5 key to open the Navigator dialog (Figure 9). Type the cell reference into the Column
and Row fields and press the Enter key.

• Using the Enter key – pressing Enter moves the cell focus down in a column to the next
row. Pressing Shift+Enter moves the focus up in a column to the next row.

• Using the Tab key – pressing Tab moves the cell focus right in a row to the next column.
Pressing Shift+Tab moves the focus to the left in a row to the next column.

• Using the arrow keys – pressing the arrow keys on the keyboard moves the cell focus in
the direction of the arrow pressed.

• Using Home, End, Page Up and Page Down
– Home moves the cell focus to the start of a row.
– End moves the cell focus to the last cell on the right in the row that contains data.
– Page Down moves the cell focus down one complete screen display.
– Page Up moves the cell focus up one complete screen display.

Sheet navigation
Each sheet in a spreadsheet is independent of the other sheets, though references can be linked
from one sheet to another. There are three ways to navigate between different sheets in a
spreadsheet.

• Using the Navigator – when the Navigator is open (Figure 9), double-clicking on any of
the listed sheets selects the sheet.

• Using the keyboard – using key combinations Ctrl+Page Down moves one sheet to the
right and Ctrl+Page Up moves one sheet to the left.

• Using the mouse – clicking on one of the sheet tabs at the bottom of the spreadsheet
selects that sheet.
If there are a lot of sheets in your spreadsheet, then some of the sheet tabs may be hidden behind
the horizontal scroll bar at the bottom of the screen. If this is the case, using the four buttons to the
left of the sheet tabs can move the tabs into view (Figure 10).

Figure 10. Navigating sheet tabs

Note

The sheet tab arrows that appear in Figure 10 are only active if there are sheet
tabs that cannot be seen.

Navigating within spreadsheets
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Note

When you insert a new sheet into your spreadsheet, Calc automatically uses the
next number in the numeric sequence as a name. Depending on which sheet is
open when you insert a new sheet, your new sheet may not be in numerical order.
It is recommended to rename sheets in your spreadsheet to make them more
recognizable.

Keyboard navigation
Pressing a key or a combination of keys allows you to navigate a spreadsheet using the keyboard.
A key combination is where you press more than one key together, for example Ctrl+Home key
combination to move to cell A1. Table 1 lists the keys and key combinations you can use for
spreadsheet navigation in Calc.
Table 1. Keyboard cell navigation
Keyboard
shortcut

Cell navigation

→

Moves cell focus right one cell

←

Moves cell focus left one cell

↑

Moves cell focus up one cell

↓

Moves cell focus down one cell

Ctrl+→

Moves cell focus to the first column on the right containing data in that row if
cell focus is on a blank cell.
Moves cell focus to the last column on the right containing data in that row if
cell focus is on a cell containing data.
Moves cell focus to the last column on the right in the spreadsheet if there are
no more cells containing data.

Ctrl+←

Moves cell focus to the last column on the left containing data in that row if
cell focus is on a blank cell.
Moves cell focus to the first column on the left containing data in the
spreadsheet if cell focus is on a cell containing data.
Moves cell focus to the first column in that row if there are no more cells
containing data.

Ctrl+↑

Moves cell focus from a blank cell to the first cell above containing data in the
same column.
Moves cell focus from a cell containing data to the cell in Row 1 in the same
column.

Ctrl+↓

Moves cell focus from a blank cell to the first cell below containing data in the
same column.
Moves cell focus from a cell containing data to the last cell containing data in
the same column.
Moves cell focus from the last cell containing data to the cell in the same
column in the last row of the spreadsheet.

Ctrl+Home

Moves cell focus from anywhere on the spreadsheet to Cell A1 on the same
sheet.

Ctrl+End

Moves cell focus from anywhere on the spreadsheet to the last cell in the
lower right-hand corner of the rectangular area of cells containing data on the
same sheet.
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Keyboard
shortcut

Cell navigation

Alt+Page Down

Moves cell focus one screen to the right (if possible).

Alt+Page Up

Moves cell focus one screen to the left (if possible).

Ctrl+Page Down

Moves cell focus to the same cell on the next sheet to the right in sheet tabs if
the spreadsheet has more than on sheet.

Ctrl+Page Up

Moves cell focus to the same cell on the next sheet to the left in sheet tabs if
the spreadsheet has more than on sheet.

Tab

Moves cell focus to the next cell on the right

Shift+Tab

Moves cell focus to the next cell on the left

Enter

Down one cell (unless changed by user)

Shift+Enter

Up one cell (unless changed by user)

Customizing the Enter key
You can choose the direction in which the Enter key moves the cell focus by going to Tools >
Options > LibreOffice Calc > General. Select the direction cell focus moves from the drop-down
list. Depending on the file being used or the type of data being entered, setting a different direction
can be useful. The Enter key can also be used to switch into and out of editing mode. Use the first
two options under Input settings in Figure 11 to change the Enter key settings.

Figure 11: Customizing the Enter key

Selecting items in a sheet or spreadsheet
Selecting cells
Single cell
Left-click in the cell. You can verify your selection by looking in the Name Box on the Formula Bar
(Figure 2 on page 7).

Range of contiguous cells
A range of cells can be selected using the keyboard or the mouse.
To select a range of cells by dragging the mouse cursor:
1) Click in a cell.
2) Press and hold down the left mouse button.
Selecting items in a sheet or spreadsheet
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3) Move the mouse around the screen.
4) Once the desired block of cells is highlighted, release the left mouse button.
To select a range of cells without dragging the mouse:
1) Click in the cell which is to be one corner of the range of cells.
2) Move the mouse to the opposite corner of the range of cells.
3) Hold down the Shift key and click.

Tip

You can also select a contiguous range of cells by first clicking in the Selection
mode field on the Status Bar (Figure 4 on page 9) and selecting Extending
selection before clicking in the opposite corner of the range of cells. Make sure to
change back to Standard selection or you may find yourself extending a cell
selection unintentionally.

To select a range of cells without using the mouse:
1) Select the cell that will be one of the corners in the range of cells.
2) While holding down the Shift key, use the cursor arrows to select the rest of the range.

Tip

You can also directly select a range of cells using the Name Box. Click into the
Name Box on the Formula Bar (Figure 2 on page 7). To select a range of cells,
enter the cell reference for the upper left-hand cell, followed by a colon (:), and
then the lower right-hand cell reference. For example, to select the range that
would go from A3 to C6, you would enter A3:C6.

Range of non-contiguous cells
1) Select the cell or range of cells using one of the methods above.
2) Move the mouse pointer to the start of the next range or single cell.
3) Hold down the Ctrl key and click or click-and-drag to select another range of cells to add to
the first range.
4) Repeat as necessary.

Selecting columns and rows
Single column or row
To select a single column, click on the column header (Figure 1 on page 6).
To select a single row, click on the row header.

Multiple columns or rows
To select multiple columns or rows that are contiguous:
1) Click on the first column or row in the group.
2) Hold down the Shift key.
3) Click the last column or row in the group.
To select multiple columns or rows that are not contiguous:
1) Click on the first column or row in the group.
2) Hold down the Ctrl key.
3) Click on all of the subsequent columns or rows while holding down the Ctrl key.
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Entire sheet
To select the entire sheet, click on the small box between the column headers and the row headers
(Figure 12), or use the key combination Ctrl+A to select the entire sheet, or go to Edit on the main
menu bar and select Select All.

Figure 12. Select All box

Selecting sheets
You can select either one or multiple sheets in Calc. It can be advantageous to select multiple
sheets, especially when you want to make changes to many sheets at once.

Single sheet
Click on the sheet tab for the sheet you want to select. The tab for the selected sheet becomes
white (default Calc setup).

Multiple contiguous sheets
To select multiple contiguous sheets:
1) Click on the sheet tab for the first desired sheet.
2) Move the mouse pointer over the sheet tab for the last desired sheet.
3) Hold down the Shift key and click on the sheet tab.
4) All tabs between these two selections will turn white (default Calc setup). Any actions that
you perform will now affect all highlighted sheets.

Multiple non-contiguous sheets
To select multiple non-contiguous sheets:
1) Click on the sheet tab for the first desired sheet.
2) Move the mouse pointer over the sheet tab for the second desired sheet.
3) Hold down the Ctrl key and click on the sheet tab.
4) Repeat as necessary.
5) The selected tabs will turn white (default Calc setup). Any actions that you perform will now
affect all highlighted sheets.

All sheets
Right-click a sheet tab and choose Select All Sheets from the context menu.

Selecting items in a sheet or spreadsheet
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Working with columns and rows
Inserting columns and rows

Note

When you insert a column, it is inserted to the left of the highlighted column. When
you insert a row, it is inserted above the highlighted row.
When you insert columns or rows, the cells take the formatting of the
corresponding cells in the next column to left or the row above.

Single column or row
Using the Insert menu:
1) Select a cell, column, or row where you want the new column or row inserted.
2) Go to Insert on the main menu bar and select either Insert > Columns or Insert > Rows.
Using the mouse:
1) Select a column or row where you want the new column or row inserted.
2) Right-click the column or row header.
3) Select Insert Columns or Insert Rows from the context menu.

Multiple columns or rows
Multiple columns or rows can be inserted at once rather than inserting them one at a time.
1) Highlight the required number of columns or rows by holding down the left mouse button on
the first one and then dragging across the required number of identifiers.
2) Proceed as for inserting a single column or row above.

Deleting columns and rows
Single column or row
To delete a single column or row:
1) Select a cell in the column or row you want to delete,.
2) Go to Edit on the main menu bar and select Delete Cells or right-click and select Delete
from the context menu.
3) Select the option you require from the Delete Cells dialog (Figure 13).

Figure 13: Delete Cells dialog
Alternatively:
1) Click in the column or header to select the column or row.
2) Go to Edit on the main menu bar and select Delete Cells or right-click and select Delete
Columns or Delete Rows from the context menu.
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Multiple columns or rows
To delete multiple columns or rows:
1) Select the columns or rows, see “Multiple columns or rows” on page 18 for more
information.
2) Go to Edit on the main menu bar and select Delete Cells or right-click and select Delete
Columns or Delete Rows from the context menu.

Working with sheets
Inserting new sheets
Click on the Add Sheet icon . This inserts a new sheet after the last sheet in the spreadsheet
without opening the Insert Sheet dialog. The following methods open the Insert Sheet dialog
(Figure 14) where you can position the new sheet, create more than one sheet, name the new
sheet, or select a sheet from a file.

• Select the sheet where you want to insert a new sheet, then go to Insert > Sheet on the
main menu bar.

• Right-click on the sheet tab where you want to insert a new sheet and select Insert Sheet
from the context menu.

• Click in the empty space at the end of the sheet tabs.
• Right-click in the empty space at the end of the sheet tabs and select Insert Sheet from
the context menu.

Figure 14: Insert Sheet dialog

Moving and copying sheets
You can move or copy sheets within the same spreadsheet by dragging and dropping or using the
Move/Copy Sheet dialog. To move or copy a sheet into a different spreadsheet; you have to use
the Move/Copy Sheet dialog.

Working with sheets
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Dragging and dropping
To move a sheet to a different position within the same spreadsheet, click on the sheet tab and
drag it to its new position before releasing the mouse button.
To copy a sheet within the same spreadsheet, hold down the Ctrl key (Option key on Mac) then
click on the sheet tab and drag it to its new position before releasing the mouse button. The mouse
pointer may change to include a plus sign depending on the setup of your operating system.

Using a dialog
The Move/Copy Sheet dialog (Figure 15) allows you to specify exactly whether you want the sheet
in the same or a different spreadsheet, its position within the spreadsheet, the sheet name when
you move or copy the sheet.
1) In the current document, right-click on the sheet tab you wish to move or copy and select
Move/Copy Sheet from the context menu or go to Edit > Sheet > Move/Copy on the main
menu bar.
2) Select Move to move the sheet or Copy to copy the sheet.
3) Select the spreadsheet where you want the sheet to be placed from the drop-down list in
To document. This can be the same spreadsheet, another spreadsheet already open, or
you can create a new spreadsheet.
4) Select the position in Insert before where you want to place the sheet.

Figure 15: Move/Copy Sheet dialog
5) Type a name in the New name text box if you want to rename the sheet when it is moved
or copied. If you do not enter a name, Calc creates a default name (Sheet 1, Sheet 2, and
so on).
6) Click OK to confirm the move or copy and close the dialog.
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Caution

When you move or copy to another spreadsheet or a new spreadsheet, a conflict
may occur with formulas linked to other sheets in the previous location.

Deleting sheets
To delete a single sheet, right-click on the sheet tab you want to delete and select Delete Sheet
from the context menu, or go to Edit > Sheet > Delete from on the main menu bar. Click Yes to
confirm the deletion.
To delete multiple sheets, select the sheets (see “Selecting sheets” on page 19), then right-click
one of the sheet tabs and select Delete Sheet from the context menu, or go to Edit > Sheet >
Delete from on the main menu bar. Click Yes to confirm the deletion.

Renaming sheets
By default, the name for each new sheet added is SheetX, where X is the number of the next sheet
to be added. While this works for a small spreadsheet with only a few sheets, it can become
difficult to identify sheets when a spreadsheet contains many sheets..
You can rename a sheet using one of the following methods:

• Enter the name in the Name text box when you create the sheet using the Insert Sheet
dialog (Figure 14 on page 21).

• Right-click on a sheet tab and select Rename Sheet from the context menu to replace the
existing name with a different one.

• Double-click on a sheet tab to open the Rename Sheet dialog.

Note

Sheet names must start with either a letter or a number; other characters including
spaces are not allowed. Apart from the first character of the sheet name, permitted
characters are letters, numbers, spaces, and the underscore character. Attempting
to rename a sheet with an invalid name will produce an error message.

Viewing Calc
Changing document view
Use the zoom function to show more or fewer cells in the window when you are working on a
spreadsheet. For more about zoom, see the Getting Started Guide Chapter 1 Introducing
LibreOffice.

Freezing rows and columns
Freezing locks a number of rows at the top of a spreadsheet or a number of columns on the left of
a spreadsheet or both rows and columns. Then, when moving around within a sheet, the cells in
frozen rows and columns always remain in view.
Figure 16 shows some frozen rows and columns. The heavier horizontal line between rows 3 and
23 and the heavier vertical line between columns F and Q indicate that rows 1 to 3 and columns A
to F are frozen. The rows between 3 and 23 and the columns between F and Q have been scrolled
off the page.

Viewing Calc
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Figure 16. Frozen rows and columns

Freezing rows or columns
1) Click on the row header below the rows you want the freeze or click on the column header
to the right of the columns where you want the freeze.
2) Go to Window on the main menu bar and select Freeze. A heavier line appears between
the rows or columns indicating where the freeze has been placed.

Freezing rows and columns
1) Click into the cell that is immediately below the rows you want frozen and immediately to
the right of the columns you want frozen.
2) Go to Window on the main menu bar and select Freeze. A heavier line appears between
the rows or columns indicating where the freeze has been placed.

Unfreezing
To unfreeze rows or columns, go to Window on the main menu bar and uncheck Freeze. The
heavier lines indicating freezing will disappear.

Splitting the screen
Another way to change the view is by splitting the screen your spreadsheet is displayed in (also
known as splitting the window). The screen can be split horizontally, vertically, or both, giving you
up to four portions of the spreadsheet in view at any one time. An example of splitting the screen is
shown in Figure 17 where a split is indicated by a black line.
Why would you want to do this? For example, a large spreadsheet in which one cell has a number
in it that is used by three formulas in other cells. Using the split-screen technique, you can position
the cell containing the number in one section and each of the cells with formulas in the other
sections. This allows you to change the number in one cell and watch how it affects each of the
formulas.

Splitting horizontally or vertically
1) Click on the row header below the rows where you want to split the screen horizontally or
click on the column header to the right of the columns where you want to split the screen
vertically.
2) Go to Window on the main menu bar and select Split. A heavy black line appears between
the rows or columns indicating where the split has been placed.
Alternatively for a horizontal split, click on the thick black line at the top of the vertical scroll bar
(Figure 18) and drag the split line below the row where you want the horizontal split positioned.
Alternatively for a vertical split, click on the thick black line at the right of the horizontal scroll bar
(Figure 18) and drag the split line to the right of the column where you want the vertical split
positioned.
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Figure 17. Split screen example

Figure 18. Split screen bars

Splitting horizontally and vertically
1) Click into the cell that is immediately below the rows where you want to split the screen
horizontally and immediately to the right of the columns where you want to split the screen
vertically.
2) Go to Window on the main menu bar and select Split. A heavy black line appears between
the rows or columns indicating where the split has been placed.

Removing split views
To remove a split view, do any of the following:

• Double-click on each split line.
• Click on and drag the split lines back to their places at the ends of the scroll bars.
• Go to Window on the main menu bar and uncheck Split.

Using the Navigator
The Navigator (Figure 19), that is available in all LibreOffice modules, provides tools and methods
to move quickly through a spreadsheet and find specific items. The Navigator categorizes and
groups spreadsheet objects which you can click on to move quickly to that object. If an indicator
(plus sign or arrow) appears next to a category, at least one object in this category exists. To open
a category and see the list of items, click on the indicator.

• When a category is showing the list of objects in it, double-click on an object to jump
directly to that object location in the spreadsheet.

• Objects are much easier to find if you have given them recognizable names when creating
them, instead of using the LibreOffice default names, such as Sheet1, Table1, Table2, and
so on. Note that the default names may not correspond to the actual position of the object
in the spreadsheet.

Using the Navigator
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Figure 19: Navigator dialog in Calc

• The Navigator in each of the individual LibreOffice modules has a different range of
functions and these functions are further explained in the appropriate user guides for each
LibreOffice module.
To open the Navigator, do one of the following:

•
•
•
•

Click the Navigator icon

on the Standard toolbar.

Press the F5 key.
Go to View > Navigator on the main menu bar.
Double-click the sheet number at the left end of the Status Bar.

You can dock the Navigator into the main Calc window or leave it as a floating dialog. To dock or
float the Navigator, hold down the Ctrl key and double-click in an empty area near the icons at the
top of the dialog.
The controls and tools available in the Navigator are as follows:

• Column – enter the column letter and press the Enter key to reposition the cell cursor to
the specified column in the same row.

• Row – enter a row number and press the Enter key to reposition the cell cursor to the
specified row in the same column.

• Data Range

– specifies the current data range denoted by the position of the cell

cursor.

• Start

– moves to the cell at the beginning of the current data range, which you can
highlight using the Data Range icon.

• End

– moves to the cell at the end of the current data range, which you can highlight
using the Data Range icon.

• Contents

– allows you to show or hide the contents.

• Toggle

– toggles the content view. Only the selected Navigator element and its
subelements are displayed. Click the icon again to restore all elements for viewing.
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• Scenarios

– displays all available scenarios. Double-click a name to apply that
scenario and the result is shown in the sheet. If the Navigator displays scenarios, you can
access the following commands when you right-click a scenario entry:

–
–

Delete – deletes the selected scenario.
Properties – opens the Edit scenario dialog, where you can edit the scenario
properties.

• Drag Mode

– opens a submenu for selecting the drag mode. You decide which action
is performed when dragging and dropping an object from the Navigator into a document.
Depending on the mode you select, the icon indicates whether a hyperlink, link or a copy is
created.

–

Insert as Hyperlink – inserts a hyperlink when you drag-and-drop an object from the
Navigator into a document. You can later click the created hyperlink to set the cursor
and the view to the respective object. If you insert a hyperlink that links to an open
document, you need to save the document before you can use the hyperlink.

–

Insert as Link – creates a link when you drag-and-drop an object from the Navigator
into a document.

–

Insert as Copy – generates a copy when you drag-and-drop an object from the
Navigator into a document.

Tip

Ranges, scenarios, pictures, and other objects are much easier to find if you have
given them informative names when creating them, instead of keeping the default
Calc names, for example Graphics 1, Graphics 2, Object 1, and so on. These default
names may not correspond to the position of the object in the document.

Using document properties
To open the Properties dialog for a document, go to File > Properties on the main menu bar. The
Properties dialog allows you to set some of the properties of a spreadsheet and the dialog has six
tabs and these are described as follows.

General
Contains basic information about the current file.

•
•
•
•
•
•

File – displays the file name.
Type – displays the file type for the current document.
Location – displays the path and the name of the directory where the file is stored.
Size – displays the size of the current document in bytes.
Created – displays the date and time and author when the file was first saved.
Modified – displays the date and time and author when the file was last saved in a
LibreOffice file format.

• Digitally signed – displays the date and the time when the file was last signed as well as
the name of the author who signed the document.

• Digital Signature – opens the Digital Signatures dialog where you can manage digital
signatures for the current document.

• Last printed – displays the date and time and user name when the file was last printed.

Using document properties
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• Revision number – displays the number of times that the file has been saved.
• Editing time – displays the amount of time that the file has been open for editing since the
file was created. The editing time is updated when you save the file.

• Apply user data – saves the full name of the user with the file. You can edit the name by
going to Tools > Options > LibreOffice > User Data on the main menu bar.

• Reset – resets the editing time to zero, the creation date to the current date and time, and
the version number to 1. The modification and printing dates are also deleted.

• Template – displays the template that was used to create the file.

Description
Contains descriptive information about the spreadsheet.

• Title – enter a title for the document.
• Subject – enter a subject for the document. You can use a subject to group documents
with similar contents.

• Keywords – enter the words that you want to use to index the content of your document.
Keywords must be separated by commas. A keyword can contain white space characters
or semicolons.

• Comments – enter comments to help identify the document.

Custom Properties
Allows you to assign custom information fields to your document. You can change the name type
and contents of each row. The information in the fields will exported as metadata to other file
formats.
Click Add to add a new now to the custom properties. Click Reset to delete any additional rows
and reset the default rows.

Internet
Sets the refresh and redirect options for an HTML page.

• Do not refresh automatically – you must refresh the page manually.
• Refresh this document – reloads the HTML page after the number of seconds that you
enter in the seconds box. To observe the result, open the page in a browser.

• Seconds – enter the number of seconds to wait before the page is reloaded.
• Redirect from this document – loads a page that you specify after the number of seconds
that you enter in the seconds box.

• after ... seconds – enter the number of seconds to wait before redirecting the browser to a
different file.

• to URL – enter the URL address of the file that you want to open, or click … to locate the
file that you want to open and then click Open.

• to frame – if the current HTML page uses frames, select the name of the target frame
where you want the file to be loaded.
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Security
Sets the password options for the current document.

• Open file read-only – select to allow this document to be opened in read-only mode only.
This file sharing option protects the document against accidental changes. It is still possible
to edit a copy of the document and save that copy with the same name as the original.

• Record changes – select to enable recording changes. This is the same as Edit >
Changes > Record on the main menu bar. To protect the recording state with a password,
click Protect and enter a password. Other users of this document can apply their changes,
but they cannot disable change recording without knowing the password.

• Protect or Unprotect – protects the change recording state with a password. If change
recording is protected for the current document, the button is named Unprotect. Click
Unprotect and type the correct password to disable the protection.

Statistics
Displays statistics for the current file.

• Number of sheets – number of sheets in the file. This statistic does not include tables that
were inserted as OLE objects.

• Number of cells – number of cells with content in the file.
• Number of pages – number of pages in the file.

Using document properties
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